Замена символов русской раскладки на английские в штрихкоде

29.08.21

Интеграция - Сканер штрих-кода

Берешь такой сканер, сканируешь, а у тебя русская раскладка. И началось - переключи, опять отскань... Простое решение, которое можно доделать под себя.

Порой сотрудники забывают переключить раскладку и может выйти грустно, так как 99.9% товаров с серийными номерами идет на англ, то лучше сразу проверить на рус символы.

Когда пришлось сканить много товара с серийными номерами, лень победила.

Решение - простая функция. Проходим по строке, смотрим код символа, если больше 191, тогда идем и меняем по структуре. Символы и цифры упадут в исключение.  На выходе функция вернет уже строку с англ. буквами.

Функция	ЗаменаРУСнаАнгл(ШК) Экспорт
	
	прЗамена = Ложь;
	Для Сч = 1 по СтрДлина(ШК) Цикл
		Если КодСимвола(Сред(ШК,СЧ)) > 191 Тогда
			прЗамена = Истина;
			Прервать;
		КонецЕсли;
	КонецЦикла;

	Если прЗамена тогда
			
		СтруктураЗаменыРБ = Новый Структура;	
			СтруктураЗаменыРБ.Вставить("Й","Q");
			СтруктураЗаменыРБ.Вставить("Ц","W");
			СтруктураЗаменыРБ.Вставить("У","E");
			СтруктураЗаменыРБ.Вставить("К","R");
			СтруктураЗаменыРБ.Вставить("Е","T");
			СтруктураЗаменыРБ.Вставить("Н","Y");
			СтруктураЗаменыРБ.Вставить("Г","U");
			СтруктураЗаменыРБ.Вставить("Ш","I");
			СтруктураЗаменыРБ.Вставить("Щ","O");
			СтруктураЗаменыРБ.Вставить("З","P");
			СтруктураЗаменыРБ.Вставить("Ф","A");
			СтруктураЗаменыРБ.Вставить("Ы","S");
			СтруктураЗаменыРБ.Вставить("В","D");
			СтруктураЗаменыРБ.Вставить("А","F");
			СтруктураЗаменыРБ.Вставить("П","G");
			СтруктураЗаменыРБ.Вставить("Р","H");
			СтруктураЗаменыРБ.Вставить("О","J");
			СтруктураЗаменыРБ.Вставить("Л","K");
			СтруктураЗаменыРБ.Вставить("Д","L");
			СтруктураЗаменыРБ.Вставить("Я","Z");
			СтруктураЗаменыРБ.Вставить("Ч","X");
			СтруктураЗаменыРБ.Вставить("С","C");
			СтруктураЗаменыРБ.Вставить("М","V");
			СтруктураЗаменыРБ.Вставить("И","B");
			СтруктураЗаменыРБ.Вставить("Т","N");
			СтруктураЗаменыРБ.Вставить("Ь","M");
			
		Для Сч = 1 По СтрДлина(ШК) Цикл
			Попытка
				Если СтруктураЗаменыРБ.Свойство(Сред(ШК,Сч,1)) Тогда
				Замена = "";
				СтруктураЗаменыРБ.Свойство(Сред(ШК,Сч,1),Замена)  ;
				ШК = СтрЗаменить(ШК,Сред(ШК,Сч,1),Замена);
			КонецЕсли;
			
			Исключение
				//Скорей всего символ
			КонецПопытки
		КонецЦикла
	КонецЕсли;
		
	Возврат ШК;
	
КонецФункции

 

См. также

"Штрихкод-информер" - мобильный ТСД и прайс-чекер в смартфоне

Мобильная разработка Сканер штрих-кода Терминал сбора данных Управляемые формы Мобильная платформа 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Сбор заказов, инвентаризация, проверка ценников, просмотр полной информации об остатках и ценах со смартфона Онлайн. Отправка данных со смартфона выполняется либо напрямую в открытую форму документа, отсканировав QR-код, либо в общую корзину учетной системы, не подходя к компьютеру. Кассир или оператор сможет просмотреть список присланных данных и загрузить в любую форму, поддерживающую работу с ТСД. Для работы с мобильным приложением требуется опубликовать HTTP-сервис из поставляемого расширения.

2880 руб.

03.12.2018    54115    131    102    

156

Подсистема штрихкодирования серий номенклатуры для 1С:УТ 11.4/11.5 КА, ERP 2.4/2.5

Сканер штрих-кода Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Стандартные конфигурации ERP, КА, УТ 11 позволяют работать с штрихкодированием серий. Есть только одно суровое ограничение – на упаковке должна быть этикетка для номенклатуры и отдельно для серии. Во многих случаях это критически неудобно.

12000 руб.

19.04.2021    20438    56    35    

49

"Мобильный ТСД" - инвентаризация и сбор штрихкодов для iOS и Android

Сканер штрих-кода Терминал сбора данных Мобильная разработка Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Платформа 1С v8.3 Мобильная платформа 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Простой мобильный терминал сбора данных для смартфонов на iOS и Android, не требующий сложных настроек и установки дополнительных программ. Обмен между Вашей 1С и мобильным приложением осуществляется через облачный сервис и расширение конфигурации. Работает с конфигурациями УТ 11, ERP, КА2, Розница 2, Розница 3, УНФ 1.6, УНФ 3.0. Полнофункциональный демо-доступ для своей конфигурации можно запросить в настройках мобильного приложения - все необходимое придет на почту автоматически.

2000 руб.

22.04.2019    90916    505    185    

291

Проверка товаров сканером штрихкода/ТСД для УТ11, КА2, ERP2, УНФ, БП3, Розница 2/ 3

Сканер штрих-кода Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Розница 3.0 Управленческий учет Платные (руб)

У вас возникал вопрос - Как быстро и правильно выполнить приемку товара в торговой точке? Как минимизировать ошибки при сборке заказа клиента? Текущая разработка способна помочь в решении данных проблем. Её назначение - проверка с помощью сканера штрих кода поступления и реализации товаров, заказов клиентов, заказов поставщикам, расходных и приходных ордеров, перемещений и возвратов.

2400 руб.

29.07.2020    33678    150    152    

123

Конфигурация "Информационный киоск". Обработки выгрузки товаров для ТиС 9.2, УТ 10.3, УТ 11 (обмен данными с любой конфигурацией 1С 7.7, 8.х)

Оптовая торговля Розничная торговля Обмен между базами 1C Сканер штрих-кода Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Управленческий учет Платные (руб)

Конфигурация предназначена для организации offline доступа клиента (покупателя) к информации о товарах, услугах или дисконтных картах посредством сканирования штрих-кода. Основная цель – мгновенно предоставить наиболее актуальную информацию о цене, остатках, наименовании товара (услуги) или накоплениях, держателе, состоянии дисконтной карты.

1800 руб.

21.12.2014    59166    8    21    

20

Переоткрытие внешних обработок

Универсальные функции Платформа 1С v8.3 Бесплатно (free)

На заключительных этапах, когда идет отладка или доработка интерфейса, необходимо много раз переоткрыть внешний объект. Вот один из способов автоматизации этого.

30.11.2023    3775    ke.92@mail.ru    16    

60
Оставьте свое сообщение