Подключение торгового оборудования "Электронные весы" к 1С:БП 3

14.02.22

Интеграция - Весы

В данной статье изложен процесс подключения торгового оборудования с типом «Электронные весы» к 1С: БП 3.0.106.101. Новичкам в этой области статья поможет получить первичную информацию об 1С:БПО.

Скачать исходный код

Наименование Файл Версия Размер
Подключение торгового оборудования "Электронные весы" к 1С:БП 3:
.7z 904,27Kb
16
.7z 904,27Kb 16 Скачать

Доброго дня, уважаемые коллеги!

В данной статье изложен процесс подключения торгового оборудования с типом «Электронные весы» к 1С: БП 3.0.106.101. Новичкам в этой области статья поможет получить первичную информацию об 1С:БПО.

В типовых программных продуктах 1С (Бухгалтерия, Управление торговлей, Комплексная автоматизации и т.д.) имеется подсистема, отвечающая за подключение оборудования и его работу, называемая "1С:БПО" (Библиотека подключаемого оборудования). В 1С:БПО имеются такие же релизы, как и в других конфигурациях. Система БПО внедрена в типовые конфигурации и обновляется автоматически при обновлении типовой конфигурации. Для просмотра версии БПО необходимо в режиме Предприятия конкретной конфигурации открыть "Функции для технического специалиста" и выбрать регистр сведений "Версии подсистем"

 

 

В нашем примере стоит задача внедрить оборудование "Электронные весы" в 1С:БП 3.0.106.101. В 1С:БП 3.0.106.101 внедрена подсистема версии 1С:БПО 3.1.2.16.

В 1С:БП 3.0.106.101 в «принципе» отключена возможность работы торгового оборудования (ТО) с типом «Электронные весы». Отключение связано с тем, что 1С:БП служит для ведения бухгалтерского и налогового учета, составления отчетности и отправки ее в налоговые органы.

 

Немного истории БПО.

В 1С:БПО младшей редакции, например, 2.1.6.16, функционал подключения этого вида ТО был урезан, но его можно было довольно легко включить, добавив некоторое перечисление со значение «ЭлектронныеВесы» в один из общих модулей. После этого можно полноценно пользоваться типовым функционалом подсистемы БПО по данному типу оборудования без каких-либо проблем. Причем за функционал по получению данных с ТО (как по Весам, так и вроде по другим видам ТО) отвечал модуль «МенеджерОборудованияКлиент».

Сейчас же в редакции 1С:БПО 3.1 функционал сильно изменили:

- добавили Подсистемы, отвечающие за конкретный вид ТО;

- разделили процедуры/функции общего модуля «МенеджерОборудованияКлиент» на общие модули, отвечающие за свой вид ТО;

- и самое главное, теперь в 1С:БП нельзя «просто» подключить использование вида ТО «Электронные весы», как это делалось в 1С:БПО 2.1. Разработчик создал новую Подсистему по данному виду ТО (и по каждому другому виду ТО), включил в неё все объекты, отвечающие за неё и решил, что в 1С:БП такая подсистема не нужна.

 

Вся информация, изложенная далее, будет соответствовать описанию релиза БПО 3.1.2.16. В этом описании есть вся подробная информация по внедрению БПО для каждого типа торгового оборудования, а также переходу с редакции 2.1. Данное описание можно найти в дистрибутиве установки 1С:БПО, в который входят документы:

- Порядок внедрения БПО.html

- Применение функционала БПО в конфигурациях.html

 

Но это все «лирика», приступаем к делу…)))

 

1. Включаем возможность использовать в настройках подключаемого оборудования тип ТО «Электронные весы».

 

 

Для этого необходимо добавить код в процедуру «ДоступныеТипыОборудования» общего модуля «МенеджерОборудованияВызовСервераПереопределяемый»:

СписокТиповОборудования.Добавить(Перечисления.ТипыПодключаемогоОборудования.ЭлектронныеВесы);

 

2. Добавляем в ветку «Общие модули» общие модули, относящие к типу ТО «Электронные весы»

- ОборудованиеВесовоеОборудованиеКлиент

- ОборудованиеВесовоеОборудованиеВызовСервера

- ОборудованиеВесовоеОборудованиеКлиентСервер

 

3. В событиях форму объекта (Справочника, Документа и т.д.) добавляем процедуры подключения и отключения ТО.

  1. В событии формы «ПриОткрытии»
&НаКлиенте
Процедура ПриОткрытии(Отказ)

  ПоддерживаемыеТипыВО = Новый Массив();
  ПоддерживаемыеТипыВО.Добавить("ЭлектронныеВесы");
  ОповещенияПриПодключении = Новый ОписаниеОповещения("ПодключитьОборудованиеЗавершение", ЭтотОбъект);
  МенеджерОборудованияКлиент.НачатьПодключениеОборудованиеПоТипу(ОповещенияПриПодключении, УникальныйИдентификатор, ПоддерживаемыеТипыВО);

КонецПроцедуры


&НаКлиенте
Процедура ПодключитьОборудованиеЗавершение(РезультатВыполнения, Параметры) Экспорт

   Если Не РезультатВыполнения.Результат Тогда
      ТекстСообщения = НСтр( "ru = 'При подключении оборудования произошла ошибка:""%ОписаниеОшибки%"".'");
      ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%" , РезультатВыполнения.ОписаниеОшибки);
      Сообщить(ТекстСообщения);
   //Иначе
      //ТекстСообщения = НСтр("ru = 'Оборудование подключено.'" );
      //Сообщить(ТекстСообщения);
   КонецЕсли;
           
КонецПроцедуры

 

  1. В событии формы «ПриЗакрытии»
&НаКлиенте
Процедура ПриЗакрытии(ЗавершениеРаботы)

   ПоддерживаемыеТипыВО = Новый Массив();
   ПоддерживаемыеТипыВО.Добавить("ЭлектронныеВесы");
   ОповещенияПриПодключении = Новый ОписаниеОповещения("ОтключитьОборудованиеЗавершение", ЭтотОбъект);
   МенеджерОборудованияКлиент.НачатьОтключениеОборудованияПоТипу(ОповещенияПриПодключении, УникальныйИдентификатор, ПоддерживаемыеТипыВО);

КонецПроцедуры

&НаКлиенте
Процедура ОтключитьОборудованиеЗавершение(РезультатВыполнения, Параметры) Экспорт

   Если Не РезультатВыполнения.Результат Тогда
      ТекстСообщения = НСтр( "ru = 'При отключении оборудования произошла ошибка: ""%ОписаниеОшибки%"".'");
      ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%" , РезультатВыполнения.ОписаниеОшибки);
      Сообщить(ТекстСообщения);
   //Иначе
   //   ТекстСообщения = НСтр("ru = 'Оборудование отключено.'" );
   //   Сообщить(ТекстСообщения);
   КонецЕсли;

КонецПроцедуры

 

4. В процедуру действия кнопки «ПолучитьВес» на форме для получения веса необходимо добавить следующий код

&НаКлиенте
Процедура ПолучитьВес(Команда)

     ЭтаФорма.Доступность = Ложь; // При необходимости можно заблокировать интерфейс пользователя.
     ОповещениеПриЗавершении = Новый ОписаниеОповещения("ПолучитьВесЗавершение", ЭтотОбъект);
     ОборудованиеВесовоеОборудованиеКлиент.НачатьПолученияВесаСЭлектронныхВесов(ОповещениеПриЗавершении, УникальныйИдентификатор, Неопределено, Неопределено);

КонецПроцедуры

&НаКлиенте
Процедура ПолучитьВесЗавершение(РезультатВыполнения, Параметры) Экспорт

     ЭтаФорма.Доступность = Истина; // При необходимости разблокируем интерфейс пользователя.
     Если РезультатВыполнения.Результат Тогда
         ТекстСообщения = "Вес получен: " + РезультатВыполнения.Вес;
         ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);            Иначе
         ТекстСообщения = НСтр("ru = 'При выполнении операции получения веса произошла ошибка:""%ОписаниеОшибки%"".'");
         ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%", РезультатВыполнения.ОписаниеОшибки);
         ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
      КонецЕсли;

КонецПроцедуры

Послесловие:

Для тестов были взяты напольные платформенные Весы с индикатором НВТ-9 с подключением по COM-порту. Драйверы весов получил от разработчика в виде файл zip, проблемы с установкой драйверов не возникло. На что стоит обратить внимание - так это разрядность платформы на клиенте, где будут использоваться данные весы и в этом плане только х32.

При тесте подключения оборудования в настройках экземпляра оборудования Электронных весов 1С:БП «намертво» зависает, если выбран не тот порт подключения в настройках.

 

Во вложении включено Расширение для 1С:БП 3.0.106.101 со всеми доработками, которые были описаны в статье, а также приложение для тестов COM-порта оборудования. Приложение по проверке COM-порта интуитивно понятно: указываем порт, битность, скорость и нажимаем кнопку «Начать тест».

Подсистема БПО Электронные весы

См. также.

Весы Оптовая торговля Розничная торговля Системный администратор Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Драйвер электронных весов предназначен для подключения торговых весов фирмы CAS всех моделей, а также весов АТОЛ MARTA к различным конфигурациям 32-разрядной или 64-разрядной платформы 1С v.8.3. Драйвер разработан по стандарту "1С: Совместимо". Уникальность драйвера заключается в том, что он прост в подключении, надежен в работе и оптимален по цене.

2400 руб.

19.12.2017    68019    385    124    

139

Весы Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием Платные (руб)

Данная обработка позволяет настроить обмен с весами с печатью этикеток ШТРИХ-М серии PC-200 и 1С:Управление торговлей редакция 10. Может быть использована в 1С: Управление производственным предприятием 1.3 ,1С: Комплексная автоматизация 1.1, 1С: Розница 1.х. Универсальная обработка выгрузки номенклатуры для 1С:Розница редакция 2.3 использует типовой функционал "Правила обмена с подключаемым оборудованием offline" Обработка обслуживания весов с печатью этикеток ШТРИХ-М серии PC-200  для ДАЛИОН: Управление магазином 1.2.х Обработка выгрузки данных в весы с печатью этикеток ШТРИХ-М серии PC-200  для Штрих-М: Торговое предприятие 5.2.х Универсальная обработка выгрузки номенклатуры для 1С:Управление торговлей редакция 11 использует типовой функционал "Правила обмена с подключаемым оборудованием offline" Обработка обслуживания весов с печатью этикеток ШТРИХ-М серии PC-200  для ДАЛИОН: ТРЕНД, редакция 3.0

7800 руб.

04.12.2019    21229    71    35    

67

Весы Платформа 1С v8.3 1С:Розница 2 Россия Бесплатно (free)

Подключение старых весов ШТРИХ-ПРИНТ 4.5 к 1С: Розница 2.3+ без внешних обработок и доработок.

17.04.2024    694    Archidemon    7    

3

Весы Системный администратор Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Демонстрируется вариант интеграции 1С с весами по com-порту через реализацию отдельного http-сервиса.

1 стартмани

21.03.2024    590    3    gzharkoj    0    

5

Весы Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Платные (руб)

Драйвер электронных весов Физтех Т11 (x86-64). Внешняя компонента Native API 1С. 1С Совместимо. Версия требований к разработке драйверов 3.9 Компонента предназначена для подключения к конфигурациям с БПО. Тестировалась на конфигурациях ERP, Управление нашей фирмой с БПО 3.2.2.25

3600 руб.

07.03.2024    554    0    0    

0

Весы Пользователь Управляемые формы 1С:Розница 2 Розничная и сетевая торговля (FMCG) Абонемент ($m)

Расширение для работы с весами CAS (AD, AP, CS, ER, ER jr) через бесплатный драйвер.

1 стартмани

28.02.2024    659    14    vet25    0    

5

Весы Платформа 1С v8.3 1С:Розница 3.0 Россия Абонемент ($m)

Альтернативная выгрузка товаров в весы Масса-К для конфигураций Розница 3.0 и УНФ 3.0.

3 стартмани

05.02.2024    396    1    a_kudaev    1    

2
Оставьте свое сообщение