Простые примеры реализации демо-версий обработок на платформе «1С:Предприятие 8».

Публикация № 17199

Разработка - Практика программирования

Каждый из тех кто продает свой интеллектуальный труд, не раз сталкивался с необходимостью создания демо-версии разработки, дабы продемонстрировать клиенту функциональность, но при этом сохранить для клиента потребность в приобретении полнофункциональной версии. В этой статье я хотел бы рассмотреть несколько не сложных примеров создания демо-версий обработок/отчетов для платформы «1С:Предприятие 8».
Перед тем как приступить, собственно, к сути вопроса, хотелось бы сделать небольшое отступление для «крутых хакеров». Как известно, штатные возможности 1С, не представляют достаточно надежных средств для защиты исходного кода, поэтому приведенные здесь примеры – это исключительно защита от ПОЛЬЗОВАТЕЛЯ и ничего более.
Да и в целом, по моему глубокому убеждению, открытость кода в 1С – это одно из важнейших (если не самое важное) её достоинств. Поэтому я сторонник «установки пароля на модуль, поставки без исходного текста», только в случае демо-версии разработки. А при приобретении обработки, клиент приобретает её ЦЕЛИКОМ, в том числе и исходный код.

Для начала, немного общих моментов. Для того что бы ограничить использование нашего «уникального» функционала, будь-то алгоритм проведения документа или процедура формирования отчета, необходимо вынести код в модуль объекта и скрыть его от пользователя. Это можно достичь двумя путями. Во-первых установка пароля на модуль объекта. Что бы установить пароль, откройте модуль объекта, далее в меню «Текст» выберите пункт «Установить пароль». Во-вторых поставка без исходного кода. Что бы получить обработку/отчет без исходного кода, необходимо сначала создать поставку включающую в себя наш отчет без исходного кода, а затем сохранить его как внешний. Настройка поставки производится в диалоге «Конфигурация > Поставка конфигурации > Настройка поставки».

Итак, пример № 1. Ограничение по времени использования. Заключается в том, что функционал работает в течении определенного, ограниченного времени, например 10 дней. Для этого, нам надо как-то «запомнить» дату первого запуска, сделаем это с помощью реестра Windows.
Функция СрокДемоЗакончился()
	Перем Значение;
	RegProv=ПолучитьCOMОбъект("winmgmts:{impersonationLevel=impersonate}!\\.\root\default:StdRegProv");
	// 2147483649 - раздел реестра HKEY_CURRENT_USER 
	RegProv.GetStringValue("2147483649","Software\1C\1Cv8\Report","StartDate",Значение);
	Если Значение=NULL Тогда	// Ключ ещё не создан, считаем этот запуск первым
		// Создадим ключ, установив значение в текущую дату
		RegProv.CreateKey("2147483649","Software\1C\1Cv8\Report");	// создание раздела
		// установка значения для ключа
		RegProv.SetStringValue("2147483649","Software\1C\1Cv8\Report","StartDate",Строка(Формат(ТекущаяДата(),"ДФ=ггггММддЧЧммсс")));
		Возврат Ложь;
	Иначе
		// проверка срока использования демо-версии
		ДатаСтарта=Дата(Значение);
		КонецПериода=ДатаСтарта+60*60*24*10;	// 10 дней
		ТекДата=ТекущаяДата();
		Возврат НЕ (ТекДата>ДатаСтарта И ТекДата<=КонецПериода);
	КонецЕсли;	
КонецФункции

Таким образом, осталось только вставить проверку на продолжение работы в нашу основную процедуру, например:
Процедура СформироватьОтчет() Экспорт
	Если СрокДемоЗакончился() Тогда
		Возврат;	
	КонецЕсли;
	…
КонецПроцедуры 

Для особо хитрых пользователей, можно сделать запрос точного времени из Интернета, что бы защититься от изменения системного времени. Например, так:
Функция ТочноеВремяПоГринвичу()
	XMLHTTP=Новый COMОбъект("MSXML2.XMLHTTP");
	XMLHTTP.Open("get","http://ntp.greenwichmeantime.com/time/scripts/clock-7/x.php",Ложь);
    	XMLHTTP.Send();
	UTC=Цел(XMLHTTP.Responsetext/1000);	// в секундах
	Возврат '19700101000000'+UTC+60*60*4;	// по Москве, летнее время
КонецФункции
Пример №2. Ограничение по количеству выполнений. То есть к примеру, отчет в демо-версии можно сформировать не более 5-ти раз. Делается аналогично предыдущему варианту, разница заключается лишь в том, что в реестр на этот раз будем записывать номер текущего запуска.
Функция СрокДемоЗакончился ()
	Перем Значение;
	RegProv=ПолучитьCOMОбъект("winmgmts:{impersonationLevel=impersonate}!\\.\root\default:StdRegProv");
	RegProv.GetDWORDValue("2147483649","Software\1C\1Cv8\Report","Count",Значение);
	ЭтотЗапуск=1;
	Если Значение=NULL Тогда
		RegProv.CreateKey("2147483649","Software\1C\1Cv8\Report");
	Иначе
		ЭтотЗапуск=Значение+1;
	КонецЕсли;
	Если ЭтотЗапуск<=5 Тогда
		RegProv.SetDWORDValue("2147483649","Software\1C\1Cv8\Report","Count",ЭтотЗапуск);
		Возврат Ложь;
	Иначе
		Возврат Истина;
	КонецЕсли; 
КонецФункции
Пример №3. Реализация защиты «пароль-ответ». Недостаток предыдущих способов, заключается в том, что полнофункциональная версия является отдельной разработкой, которую клиенту необходимо переслать, привести, установить и т.д. При использовании же, следующего способа, всё что потребуется для получения полной версии разработки – это зарегистрировать обработку, т.е. ввести правильный код.
Суть этого способа состоит в том, что при запуске у клиента формируется некий уникальный ключ, для которого, по только нам известному алгоритму, можно сформировать «ответный пароль». И в случае совпадения пары ключ-ответ обработка считается успешно зарегистрированной.
В качестве такого уникального ключа можно, к примеру, использовать серийный номер жесткого диска, MAC-адрес, имя пользователя и т.д. Рассмотрим пример с серийным номером жесткого диска.
Функция ПолучитьСерийныйНомерЖесткогоДиска(Диск)
	ФСО=Новый COMОбъект("Scripting.FileSystemObject");
	ФСО_Диск=ФСО.GetDrive(Диск);
	Возврат ФСО_Диск.SerialNumber;
КонецФункции

Алгоритм получения «ответного значения» по ключу, ограничен лишь Вашей фантазией. Здесь же, в качестве примера, я буду использовать простую перестановку символов в обратном порядке.
Функция ПолучитьОтветПоКлючу(Ключ)
	н=СтрДлина(Ключ);
	Результат="";
	Пока н<>0 Цикл
		Результат=Результат+Сред(Ключ,н,1);
		н=н-1;
	КонецЦикла;
	Возврат Результат;
КонецФункции

Таким образом, наша процедура проверки и подтверждения регистрации будет выглядеть так:
Функция ЭтоЗарегистрированнаяКопия()
	Перем Значение,Ответ;
	RegProv=ПолучитьCOMОбъект("winmgmts:{impersonationLevel=impersonate}!\\.\root\default:StdRegProv");
	RegProv.GetDWORDValue("2147483649","Software\1C\1Cv8\Report","Registered",Значение);
	Если Значение=NULL Тогда	// необходима регистрация копии
		Регистрация=Ложь;
		Ключ=ПолучитьСерийныйНомерЖесткогоДиска("C");
		Если ВвестиСтроку(Ответ,"Ключ: "+Ключ) Тогда
			Если Ответ=ПолучитьОтветПоКлючу(Ключ) Тогда
				// подтвердим регистрацию
				RegProv.SetDWORDValue("2147483649","Software\1C\1Cv8\Report","Registered",1);
				Регистрация=Истина;
			Иначе
				Предупреждение("Регистрационный код введен не верно!");
			КонецЕсли;
		КонецЕсли;
		Возврат Регистрация;
	Иначе	// эта копия уже зарегистрированна
		Возврат Истина;
	КонецЕсли;
КонецФункции

Осталось только вставить проверку регистрации в нашу основную процедуру:
Процедура СформироватьОтчет() Экспорт
	Если НЕ ЭтоЗарегистрированнаяКопия() Тогда
		// работа в демо-режиме
		...
	КонецЕсли;
	...
КонецПроцедуры
На данный момент, существуют различные декомпиляторы, плагины к Total Commander и др. разработки, позволяющие получить исходный программный код, даже если он закрыт паролем или поставляется в скомпилированном варианте. Дабы чуть-чуть усложнить жизнь пользователям умеющим пользоваться Google, можно ключевые моменты алгоритма, такие как работа с реестром или проверка регистрационного кода, дополнительно вынести во внешний шифрованный скрипт.
Начиная с Windows Script 5.0, появилась возможность чтения зашифрованных сценариев машинами сценариев. Поэтому любой сценарий написанный на VBScript или JavaScript, может быть выполнен в зашифрованном виде. Что бы преобразовать код на VBScript в зашифрованный вид, воспользуемся бесплатной утилитой «Windows Script Encoder», которую можно скачать с сайта Microsoft. В результате, например скрипт создания в реестре Windows раздела «HKEY_CURRENT_USER\Software\1C\1Cv8\Report», будет выглядеть следующим образом:

#@~^ZAAAAA==jY~UtVV{ZMnlD+64N+^OvJU^DbwYcj4+^Vr#@#@&j4VsR"noqDrOPJuF;jw?KWDhCM+'FZ'F;-%'InwKDOwr~\(HE^V@#@&hyAAAA==^#~@

Приведу пример функции, осуществляющей проверку введенного пользователем регистрационного кода, с использованием шифрованного скрипта:
Функция ПроверитьРегистрационныйКод(Код)
	Скрипт=Новый COMОбъект("MSScriptControl.ScriptControl");
	Скрипт.Language="VBScript.Encode";
	Скрипт.AddCode("#@~^ewAAAA==o!x^DkKxP;t"+Символ(127)+"^3v|nX*@#@&7zx/SnD{\4wCs/"+Символ(127)+"@#@&d(0~F"+Символ(127)+"XxJ9^+Rl{qOv0q*rPPt"+Символ(127)+"U,bUkh"+Символ(127)+"D'74:.E"+Символ(127)+"P3x9P(W@#@&d;4+13'zUdh"+Символ(127)+"D@#@&3x[~wEUmDrW	hyQAAA==^#~@ ");
	Возврат Скрипт.CodeObject.Check(Код);		
КонецФункции

Эта функция вернет «Истина», если в качестве регистрационного кода передать ей строку «dce8a7196f14». Аналогичным образом можно скрыть и всю работу с реестром. Но, тем не менее, не следует забывать о существующих специализированных программных продуктах, позволяющих отслеживать чтение и запись реестра.

В заключении, хочется сказать, что как известно, надежная защита для программного продукта – это такая защита, стоимость взлома которой, превышает стоимость законного приобретения. Поэтому для крупных проектов следует использовать более надежные средства от незаконного копирования и использования, такие как вынос ключевых функций во внешние dll, аппаратные ключи защиты и пр. Здесь же я попытался привести несколько простых примеров в качестве основ так сказать…

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. support 4526 06.05.08 13:39 Сейчас в теме
2. vasilykushnir 06.05.08 14:20 Сейчас в теме
Согласен с (1) - хорошая статья. А еще можно посмотреть в сторону дополнительных глобальных модулей и их тоже шифрануть...
3. coder1cv8 3488 06.05.08 14:35 Сейчас в теме
(2) Дык, я ж о восьмерке, в ней никаких дополнительных глобальных модулей нету... )
6. vasilykushnir 06.05.08 16:00 Сейчас в теме
(3) Не знал... (8-ку не юзаю).
7. Abadonna 3880 06.05.08 18:41 Сейчас в теме
(3)>Дык, я ж о восьмерке, в ней никаких дополнительных глобальных модулей нету...
В семерке тоже нет ;)
Это спасибо Альфу за formex - с ней они появляются
4. German 874 06.05.08 14:51 Сейчас в теме
больше всего последний абзац понравился..
а сменить серийник жесткого диска можно? чисто ради спортивного интереса.
5. coder1cv8 3488 06.05.08 15:18 Сейчас в теме
(4) Конечно можно ) Это просто пример.
8. artem666 28 07.05.08 00:19 Сейчас в теме
Респект!
Максимум до чего сам додумывался, так это на количество включений
9. kirill_sid 07.05.08 07:21 Сейчас в теме
Хорошая статья. Информация, думаю, многим будет полезна. +1
10. cs25 80 07.05.08 09:18 Сейчас в теме
11. coder1cv8 3488 07.05.08 09:52 Сейчас в теме
Спасибо всем )
У меня вопрос к support-у: почему в коде иногда вырезаются символы "\"? Т.е. вот сейчас я заметил, что везде строка "Software\1C\1Cv8\Report" у меня стала "Software1C1Cv8Report" :( Надо бы исправить!
12. pas-and 07.05.08 09:56 Сейчас в теме
Все гениальное - просто. Понравилась статья.Плюсану.
13. dima1c 27 07.05.08 15:13 Сейчас в теме
14. shachneff 07.05.08 16:28 Сейчас в теме
А можно еще и пример кода, использующего шифрованный скрипт?
15. coder1cv8 3488 07.05.08 16:39 Сейчас в теме
(14) Примеры с шифрованными скриптами будут, но несколько позже...
16. mdzen 238 08.05.08 14:13 Сейчас в теме
17. maloi_a 10.05.08 18:07 Сейчас в теме
Два мелких замечания.
1. В Процедуре ЭтоЗарегистрированнаяКопия()
Ключ=ПолучитьСерийныйНомерЖесткогоДиска("C");
пришлось поменять на
Ключ=Формат(ПолучитьСерийныйНомерЖесткогоДиска("C"),"ЧГ=");
из-за невозможности ввести неразрывный пробел с клавиатуры.

2. В Примере №2 оператор
ЭтотЗапуск=1;
перенес после
Если Значение=NULL Тогда
19. coder1cv8 3488 11.05.08 12:58 Сейчас в теме
(17) Это просто примеры, информация к размышлению, на самом деле я бы не стал использовать это "буквально", в таком виде как здесь. Но тем не менее, спасибо за замечания )
18. tormozit 6183 10.05.08 23:57 Сейчас в теме
Описаны уже устоявшиеся приемы, но разжеваны хорошо да и для 1С это в новинку. Спасибо. Плюс.
20. Stanislaw 12.05.08 07:24 Сейчас в теме
Отличные примеры. Но почему то всплывает ошибка на строчке:

RegProv=ПолучитьCOMОбъект("winmgmts:{impersonationLevel=impersonate}!\.rootdefault:StdRegProv");

Это ошибка при вызове метода. Ошибка получения СОМ-Объекта: IDispatch error #3617

Подскажите пожалуйста в чем проблема
21. coder1cv8 3488 12.05.08 09:38 Сейчас в теме
(20) Проблема в движке этого сайта, есть тут баг, искажается код... Эта строка должна выглядеть так:
RegProv=ПолучитьCOMОбъект("winmgmts:{impersonationLevel=impersonate}!\\.root\default:StdRegProv");
22. coder1cv8 3488 12.05.08 11:51 Сейчас в теме
Как и обещал, добавил пример илюстрирующий использование шифрованного скрипта.
37. eternity 06.12.13 23:23 Сейчас в теме
(22)
Очень интересная тема, спасибо.
Попробовал использовать выполнение зашифрованного скрипта, но 1С ругается на строку:
Скрипт.AddCode("#@~^ew....

Пишет: Произошла исключительная ситуация (Ошибка компиляции Microsoft VBScript): Предполагается наличие инструкции

Почему 1С не может добавить зашифрованный текст скрипта? Или что-то еще надо прописать?
Прикрепленные файлы:
23. O-Planet 6907 21.05.08 23:18 Сейчас в теме
«1С:ПредПИРЯтие 8» - это жОстко! :)
24. coder1cv8 3488 22.05.08 09:34 Сейчас в теме
(23) Спасибо ) Бывает... Хоть кто-то заметил! ))
25. coder1cv8 3488 03.06.08 17:15 Сейчас в теме
Так же на эту тему рекомендую посмотреть мою обработку "Обфускация кода 1С" :)
26. RailMen 17.03.09 19:10 Сейчас в теме
Я как раз разрабатываю самописные функции такой же тематики для внешних обработок. Как - нибудь выложу. Мой подход немного отличается от этого.
27. dobraleks 136 10.04.09 17:14 Сейчас в теме
+1 подчеркнул для себя кое что новенькое
28. AlecoZAV 12 22.07.09 10:57 Сейчас в теме
у меня вылезает ошибка
"Ошибка при вызове метода контекста (send): Произошла исключительная ситуация (msxml3.dll): Не удается найти указанный ресурс."
на строчке
XMLHTTP.Send();

в чем может быть дело?
29. AlecoZAV 12 23.07.09 11:37 Сейчас в теме
вместо кома MSXML2.XMLHTTP использовала winhttp и получилось
30. dardroze 26.12.11 14:04 Сейчас в теме
Попробовал ограничение по времени и количеству запусков - получилось.
Спасибо, отличный сайт!
p.s. По "пароль-ответ" почитаю еще, вдумаюсь. Может пригодится
31. adhocprog 1194 04.03.12 03:25 Сейчас в теме
32. xomaq 16 08.06.12 07:19 Сейчас в теме
Полезная статья!!
Почитаю на досуге более вдумчиво и кое-чем воспользуюсь.
33. dryms 247 25.10.12 02:14 Сейчас в теме
34. mdvinfostart 20.11.12 17:37 Сейчас в теме
Спасибо за сэкономленное время.+
35. papami 36 20.11.12 18:07 Сейчас в теме
36. a-grinyuk 07.08.13 17:20 Сейчас в теме
У меня стоит Windows 7 Prof с включенным UAC.
Запись в реестр срабатывает, но ни чего в реестре не появляется.
Полагаю что это из-за включённого UAC. Можно ли как то вызвать стандартное окно Windows для разрешения действия записи в реестр ?
38. softgarant 60 04.04.14 20:30 Сейчас в теме
Если я правильно понял, используя зашифрованый скрипт можно в скрипт затащить проверку на совпадение неких параметров, пусть то ид винчестера и возврат в код результата Истина или Ложь. А модуль с кодом проверки обфусцировать и запаролить, верно?
39. dreadlord 16.10.14 11:32 Сейчас в теме
40. GSA3D 20.07.17 09:42 Сейчас в теме
а как JavaScript может быть выполнен в зашифрованном виде?
Оставьте свое сообщение

См. также

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    3658    comol    21    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    9700    quazare    33    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    30625    user5300    16    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    35026    ids79    26    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38220    unichkin    74    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    28926    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    21862    kuzyara    38    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    18413    YPermitin    58    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    31671    tormozit    104    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    9332    Sibars    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    32380    HostHost    40    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    38334    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78983    tormozit    131    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    13845    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    61992    rpgshnik    68    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    55897    ids79    54    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    49664    tormozit    48    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    31780    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    26791    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    34198    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    46245    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    100379    ids79    56    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    41893    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    27569    json    15    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16342    m-rv    2    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    71439    ids79    12    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    38837    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    27754    YPermitin    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20842    m-rv    17    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    20221    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    55590    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    58225    ids79    26    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    31856    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    26686    dmurk    146    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    47696    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    37254    ellavs    126    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28727    itriot11    34    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    28300    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    33658    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    45783    Смешной 1С    30    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77939    Serginio    110    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    23659    Vladimir Litvinenko    28    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    36756    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    44447    ids79    11    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    28571    ids79    31    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29925    grumagargler    28    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    44416    ids79    72