Сохранение разделителя GS при сканировании кодов маркировки в УТ 11.5, расположенную в удаленном рабочем столе/терминале/RDP

25.10.23

Интеграция - Сканер штрих-кода

Сканер штрихкодов, имитирующий ввод с клавиатуры, не передаёт разделитель GS в удалённый рабочий стол (терминал/RDP), а форма ПроверкаИПодборПродукцииИСМП, открываемая, например, из Реализации, ругается на такие коды "В структуре кода маркировки отсутствуют разделители GS".

Возможно, проблема проявляется только в нашей инфраструктуре. А может быть и такое, что я не знаю, как отключить такую проверку.

Так или иначе, сделал простое и, пока, рабочее решение.

Суть проблемы: сканер штрихкодов, имитирующий ввод с клавиатуры, не передаёт разделитель GS в удалённый рабочий стол (терминал/RDP), а форма "Подбор и проверка ..." (ПроверкаИПодборПродукцииИСМП), открываемая, например, из Реализации, ругается на такие коды "В структуре кода маркировки отсутствуют разделители GS".

Решил следующим образом.

Кинул в расширение процедуру "Подключаемый_ПолученыДанныеИзТСД" из формы обработки ПроверкаИПодборПродукцииИСМП.ПроверкаИПодбор; с аннотацией &ИзменениеИКонтроль.

Почти в начале процедуры сделал вставку 

......
	Если Штрихкоды.Количество() = 0 Тогда

		ЗагрузкаДанныхТСД = Неопределено;

		ПоказатьПредупреждение(, НСтр("ru = 'В полученных данных не содержится информации о считанных штриховых кодах'"));

		Возврат;

	КонецЕсли;

#Вставка
	ит_ВосстановитьРазделительGSДляШтрихкодов(Штрихкоды, ВидМаркируемойПродукции);
#КонецВставки

	Если ЗагрузкаДанныхПоОснованию Тогда
		ПараметрыУведомления = Новый Структура();
		ПараметрыУведомления.Вставить("Заголовок", НСтр("ru = 'Загрузка данных по заказам'"));
		ПараметрыУведомления.Вставить("Текст",     НСтр("ru = 'Начата загрузка данных по заказам на эмиссию.'"));
	Иначе
		ПараметрыУведомления = Неопределено;
	КонецЕсли;
......

 

Процедура восстанавливает разделитель GS и преобразует в base64 (иначе не вернуть на клиента без потери разделителя GS), также указывает, что код уже преобразован в base64:

&НаСервереБезКонтекста
Процедура ит_ВосстановитьРазделительGSДляШтрихкодов(Штрихкоды, ВидМаркируемойПродукции)
	ПользовательскиеПараметры = РазборКодаМаркировкиИССлужебныйКлиентСервер.ПользовательскиеПараметрыРазбораКодаМаркировки();
	ПользовательскиеПараметры.РасширеннаяДетализация = Истина;

	Для Каждого Элемент Из Штрихкоды Цикл
		Если Элемент.ФорматBase64 ИЛИ Элемент.Свойство("ШтрихкодыПреобразованы") Тогда
			Продолжить;
		КонецЕсли;
		
		КодМаркировки = Элемент.Штрихкод;
		ДанныеРазбора = РазборКодаМаркировкиИССлужебный.РазобратьКодМаркировки(КодМаркировки, , Неопределено, , ПользовательскиеПараметры);
		ПолныйКодМаркировки = РазборКодаМаркировкиИССлужебныйКлиентСервер.ПолныйКодМаркировкиПоДаннымРазбораСРасширеннойДетализацией(ДанныеРазбора, Истина);
		ПолныйКодМаркировкиBase64 = ШтрихкодированиеИСКлиентСервер.ШтрихкодВBase64(ПолныйКодМаркировки);
		Элемент.Штрихкод = ПолныйКодМаркировкиBase64;
		
		Элемент.ФорматBase64 = Истина;
		Элемент.Вставить("ШтрихкодыПреобразованы");
	КонецЦикла;
КонецПроцедуры

Реализовано в УТ 11.5.12.135, но, скорее всего, будет актуально для всей линейки 11.5

У нас:

 - рабочее место пользователя - комп с ОС Debian/Ubuntu/Fedora

 - сканер штрихкодов с имитацией ввода с клавиатуры.

 - 1С на сервере под управлением Windows, попадаем туда через RDP.

маркировка сканер штрихкодов разделитель GS RDP терминал подбор и проверка

См. также

Мобильная разработка Сканер штрих-кода Терминал сбора данных Управляемые формы Мобильная платформа 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Сбор заказов, инвентаризация, проверка ценников, просмотр полной информации об остатках и ценах со смартфона Онлайн - все это содержит в себе решение 1С "Штрихкод-информер" (штрих-код чекер). Отправка данных со смартфона выполняется либо напрямую в открытую форму документа, отсканировав QR-код, либо в общую корзину учетной системы, не подходя к компьютеру. Кассир или оператор сможет просмотреть список присланных данных и загрузить в любую форму, поддерживающую работу с ТСД. Для работы с мобильным приложением требуется опубликовать HTTP-сервис из поставляемого расширения.

2880 руб.

03.12.2018    56957    179    103    

169

Сканер штрих-кода Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Стандартные конфигурации ERP, КА, УТ 11 позволяют работать с штрихкодированием серий. Есть только одно суровое ограничение – на упаковке должна быть этикетка для номенклатуры и отдельно для серии. Во многих случаях это критически неудобно.

12000 руб.

19.04.2021    21685    62    43    

56

Сканер штрих-кода Терминал сбора данных Мобильная разработка Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Программист Пользователь Платформа 1С v8.3 Мобильная платформа 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Простой мобильный ТСД (терминал сбора данных) сканер для 1С для смартфонов на iOS и Android, не требующий сложных настроек и установки дополнительных программ. Обмен между Вашей 1С и мобильным приложением осуществляется через облачный сервис и расширение конфигурации. Работает с конфигурациями УТ 11, ERP, КА2, Розница 2, Розница 3, УНФ 1.6, УНФ 3.0. Полнофункциональный демо-доступ для своей конфигурации можно запросить в настройках мобильного приложения - все необходимое придет на почту автоматически.

2000 руб.

22.04.2019    94169    545    187    

311

Сканер штрих-кода Пользователь Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Розница 3.0 Управленческий учет Платные (руб)

У вас возникал вопрос - Как быстро и правильно выполнить приемку товара в торговой точке? Как минимизировать ошибки при сборке заказа клиента? Текущая разработка способна помочь в решении данных проблем. Её назначение - проверка с помощью сканера штрих кода поступления и реализации товаров, заказов клиентов, заказов поставщикам, расходных и приходных ордеров, перемещений и возвратов.

2400 руб.

29.07.2020    35425    162    158    

135

Сканер штрих-кода Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Теперь практически все торговые документы в конфигурации 1С Бухгалтерия 3.0 (ПРОФ / КОРП) и в конфигурации 1С Бухгалтерия сельскохозяйственного предприятия 3.0 поддерживают подбор товара по штрих-коду. Можно пользоваться сканером штрихкода или подбирать штрих-код вручную. В основных печатных формах документов выводится колонка Штрихкод. Для менеджеров по продажам будет удобным дополнительный отчет Прайс-лист с остатками и штрих-кодом.

3600 руб.

28.07.2020    28417    77    30    

57

Оптовая торговля Розничная торговля Ценообразование, анализ цен Сканер штрих-кода Бухгалтер Пользователь Платформа 1С v8.3 1С:Розница 2 Управленческий учет Платные (руб)

Расширение для конфигурации Розница 2.3. Автоматическое и ручное создание, присвоение (сканирование) штрихкодов номенклатуре непосредственно в документе Поступления товаров. Поддерживается ввод штрихкода через сканер.

1800 руб.

30.03.2021    20750    8    10    

13

Сканер штрих-кода Программист Платформа 1С v8.3 1С:Розница 2 Абонемент ($m)

Небольшой пример работы со сканером штрихкодов через библиотеку БПО и блока виртуальной цифровой клавиатуры.

2 стартмани

09.07.2024    359    1    aximo    0    

3
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. user1972220 15.12.23 07:04 Сейчас в теме
Возможно эта проблема решится простой настройкой RDP. В свойствах удалённого подключения, на вкладке "Локальные ресурсы" надо выставить "На удалённом компьютере"
Прикрепленные файлы:
2. alexey-simf 14 19.12.23 16:49 Сейчас в теме
(1) Возможно, решится у тех, кто работает в Windows, но у нас "рабочее место пользователя - комп с ОС Debian/Ubuntu/Fedora" и там всё более грустно, даже, если, подобная галочка, присутствует в RDP-клиенте.
Оставьте свое сообщение