Добавление отчета в расширение и вывод в меню отчетов на БСП на примере УТ 11.5

31.01.24

Задачи пользователя - Менеджеры внешних отчетов

Пример добавления отчета в расширение в типовые конфигурации на БСП на примере УТ 11.5, с добавлением в типовые меню отчетов.

Скачать исходный код

Наименование Файл Версия Размер
Добавление отчета в расширение и вывод в меню отчетов на БСП на примере УТ 11.5:
.cfe 12,37Kb
0
.cfe 12,37Kb Скачать

Как добавить отчет в расширение так, чтобы он отображался в меню стандартных отчетов для пользователей? Если что, пример в целом описан в демо-конфигурации БСП. Здесь же опишу по шагам, вдруг будет кому полезным.

1. Добавление отчета в расширение

Тут все просто, вставляем свой отчет в расширение. Для примера простой отчет "Отчет по номенклатуре".

2. Настройка свойств отчета

Необходимо убрать флаг "Использовать стандартные команды", и добавить его в подсистему "Подключаемые отчеты и обработки" (для этого данную подсистему необходимо добавить в расширение):

 

 

Также не забываем дать необходимые права на отчет (либо на типовые заимствованные в расширение роли), либо в собственную роль.

 

3. Модуль менеджера отчета

В модуле менеджера отчета необходимо добавить процедуру ПриОпределенииНастроек, и НастроитьВариантыОтчета

Здесь, в процедуре НастроитьВариантыОтчета указываем необходимую подсистему, а также добавляем описание отчета.

#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
	
#Область ПрограммныйИнтерфейс
  
Процедура ПриОпределенииНастроек(Настройки) Экспорт
	
	Настройки.НастроитьВариантыОтчета = Истина;
	//Настройки.ОпределитьНастройкиФормы = Истина;
	Настройки.ДобавитьКомандыОтчетов = Истина;
 КонецПроцедуры
 
#Область КомандыПодменюОтчеты

// Добавляет команду отчета в список команд.
// 
// Параметры:
//   КомандыОтчетов - см. ВариантыОтчетовПереопределяемый.ПередДобавлениемКомандОтчетов.КомандыОтчетов
//
// Возвращаемое значение:
//  Неопределено, СтрокаТаблицыЗначений - Добавить команду отчета
Функция ДобавитьКомандыОтчетов(КомандыОтчетов, Параметры) Экспорт

	Если ПравоДоступа("Просмотр", Метаданные.Отчеты.ОтчетПоНоменклатуре) Тогда
		
		КомандаОтчет = КомандыОтчетов.Добавить();
		
		КомандаОтчет.Менеджер = Метаданные.Отчеты.ОтчетПоНоменклатуре.ПолноеИмя();
		КомандаОтчет.Представление = "Отчет по номенклатуре (Пример отчета)";
		КомандаОтчет.КлючВарианта  = "Основной";
		КомандаОтчет.МножественныйВыбор = Ложь;
		КомандаОтчет.Важность = "Важное";
		
		Возврат КомандаОтчет;
		
	КонецЕсли;

	Возврат Неопределено;

КонецФункции

// См. ВариантыОтчетовПереопределяемый.НастроитьВариантыОтчетов.
//
Процедура НастроитьВариантыОтчета(Настройки, НастройкиОтчета) Экспорт
	
	НастройкиВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, НастройкиОтчета, "Основной");
	НастройкиВарианта.Описание = НСтр("ru = 'Тестовый отчет по номенклатуре'");
	
	ПодсистемаОтчета = Метаданные.НайтиПоПолномуИмени("Подсистема.Продажи.Подсистема.ОптовыеПродажи");
	НастройкиВарианта.Размещение.Вставить(ПодсистемаОтчета, "Важный");
	НастройкиВарианта.ВидимостьПоУмолчанию = Истина;
КонецПроцедуры

#КонецОбласти

#КонецОбласти
		
#КонецЕсли

 

4. Обновление вспомогательных данных

Для обновления вариантов отчетов, можно запустить 1С предприятие с ключом запуска "/C ЗапуститьОбновлениеИнформационнойБазы", либо воспользоваться обработкой Обновления вспомогательных данных подсистемы БСП.

Например, можно указать в конфигураторе в меню сервис - параметры на закладке "Запуск 1С:Предприятие" в параметрах запуска нужный ключ:

 

 

после чего запустить 1С:Предприятие в режиме отладки.

5. Настройка видимости отчета

По умолчанию отчет не отображается в списке отчетов, для отображения требуется открыть меню отчетов (в моем случае продажи - отчеты по продажам), открыть настройки и включить видимость отчета:

 

 

P.S. Кодом не получилось сделать автоматическую видимость отчета, если кто-то знает решение, буду благодарен.

В файлах - пример расширения, тестировалось на УТ 11.5.12.73 на платформе 8.3.23.1912.

Проверено на следующих конфигурациях и релизах:

  • Управление торговлей, редакция 11, релизы 11.5.12.73

отчет в расширение БСП меню отчетов

См. также.

Менеджеры внешних отчетов Анализ учета Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х Платные (руб)

Расширение «Контрольные отчеты» для автоматизации процесса проверки ведения учета в ПП. Со списком ошибок могут работать ответственные пользователи. Помогает в процессе внедрения ПП находить нарушения в бизнес-процессах. 

12000 руб.

08.08.2023    1654    2    1    

5

Менеджеры внешних отчетов Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Очень часто возникает необходимость сохранить в папку на локальном диске все дополнительные внешние отчеты и обработки из базы 1С. Данная обработка позволит сделать это быстро и с учетом внутренней иерархии и с проверкой результата выгрузки (Управляемые формы).

1 стартмани

25.04.2024    1080    9    Suker86    0    

4

Менеджеры внешних отчетов Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Менеджер отчетов, это простой инструмент, который предназначен для организации доступа к отчетам и обработкам, как внешним так и встроенным в конфигурацию. Предоставление доступа реализовано как для пользователей, так и для пользовательских групп.

5 стартмани

04.09.2023    851    3    serg1234    0    

3

Инструментарий разработчика Менеджеры внешних отчетов Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

При изменении и отладке внешней обработки приходится десятки раз заходить в Файл-Открыть и переоткрывать обработку. Данное решение значительно упрощает данную задачу.

1 стартмани

28.07.2023    4776    50    Serg2000mr    30    

59

Менеджеры внешних отчетов Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Добавление кнопки "Показать в списке" в формах отчетов для открытия соответствующего элемента справочника "Варианты отчетов".

1 стартмани

12.12.2022    1462    0    RocKeR_13    2    

4

Рабочее место Менеджеры внешних отчетов Пользователь 8.3.14 Конфигурации 1cv8 1С:Бухгалтерия 3.0 Абонемент ($m)

Иногда пользователю доставляет неудобство открывать разрозненно по спискам разных разделов внешние обработки и отчёты, и есть потребность поместить их в одно единственное окно. Данное расширение призвано решить такую задачу.

2 стартмани

12.04.2022    6184    37    Obertone    7    

28

Менеджеры внешних отчетов Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Управляемые формы. Обработка - поиск варианта отчета по ссылке на вариант. Полезно для конфигураций, имеющих справочник Варианты отчетов.

1 стартмани

02.03.2022    3771    8    Topmuk    0    

2
Оставьте свое сообщение