Приведение телефонных номеров в порядок

Публикация № 272923

Администрирование - Администрирование данных 1С - Обработка справочников

Код для консоли запросов написан для типовых конфигураций с регистром «Контактная информация».
Позволяет унифицировать телефоны и привести их в международный формат с кодом +7.

Используется «Консоль запросов + Обработчик»:

В запрос нужно вставить текст запроса.

В код нужно вставить алгоритм обработки.

Параметры заполнить как на картинке:

Обычно есть несколько видов с наименованием «Телефон», нужно попробовать все по очереди.

Нажать кнопку «Выполнить», результат запроса выгрузится в таблицу.

Далее нажать кнопку «Выполнить обработку», номера будут обработаны и перезаписаны.

 

Выдается протокол, где сообщается, какие номера обработаны, какие нет:

 

Код запроса:

ВЫБРАТЬ

       КонтактнаяИнформация.Объект,

       КонтактнаяИнформация.Тип,

       КонтактнаяИнформация.Вид,

       КонтактнаяИнформация.Представление

ИЗ

       РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация

ГДЕ

       КонтактнаяИнформация.Тип = &Тип

       И КонтактнаяИнформация.Вид = &Вид

       И Подстрока(Представление, 1, 1) <> ""

Код обработки:

ИсхСтр = СокрЛП(Рез.Представление);

РезСтр = "";

Если ИсхСтр <> "" Тогда

       Для Инд = 1 По СтрДлина(ИсхСтр) Цикл

             Симв = Сред(ИсхСтр, Инд, 1);

             Если Найти("0123456789", Симв) = 0 Тогда

                    Продолжить;

             КонецЕсли;

             РезСтр = РезСтр + Симв;

       КонецЦикла;

      

       Если СтрДлина(РезСтр) = 10 Тогда

             РезСтр = "+7" + РезСтр;

       КонецЕсли;

       Если СтрДлина(РезСтр) = 11 И Лев(РезСтр, 1) = "8" ИЛИ Лев(РезСтр, 1) = "7" Тогда

             РезСтр = "+7" + Сред(РезСтр,2);

       КонецЕсли;

      

       ПредставлениеОбъекта = "" + ТипЗнч(Рез.Объект) + ": " + Рез.Объект;

       Если СтрДлина(РезСтр) <> 12 Тогда

             Сообщить(ПредставлениеОбъекта + " Неадеватный номер: " + ИсхСтр + " Пытались: " + РезСтр);

       ИначеЕсли РезСтр <> ИсхСтр Тогда

             Сообщить(ПредставлениеОбъекта + " Замена: " + ИсхСтр + " На: " + РезСтр);

             МЗ = РегистрыСведений.КонтактнаяИнформация.СоздатьМенеджерЗаписи();

             МЗ.Объект = Рез.Объект; МЗ.Тип = Рез.Тип; МЗ.Вид = Рез.Вид;

             МЗ.Прочитать();

             МЗ.Объект = Рез.Объект; МЗ.Тип = Рез.Тип; МЗ.Вид = Рез.Вид;

             МЗ.Представление = РезСтр;

             МЗ.Записать();

       КонецЕсли;

      

      

КонецЕсли;

 

Конечно, можно было бы эту полезную вещь обернуть в обработку, но некогда, если кто сделает, высылайте мне на почту, вставлю в статью.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. leles 66 19.04.14 21:56 Сейчас в теме
Какая у вас консоль запросов интересная. С обработкой выборки, у меня такой нет.
Поделитесь, пожалуйста, буду благодарен.
2. fixin 4042 21.04.14 10:10 Сейчас в теме
3. Forest83 49 16.06.16 12:27 Сейчас в теме
Спасибо! За консоль на удовольствия перевел)
Еще бы она текст обработчика сохраняла - цены бы не было!))

В моем случае видимо совсем все запущено. Обработчик зациклился.
Но для старта помощь просто огромная!
4. php5 19 17.11.16 22:59 Сейчас в теме
Спасибо за готовый алгоритм, сэкономил немного времени!!!
Оставьте свое сообщение

См. также

Копирование реквизита справочника Номенклатура в дополнительный реквизит и обрезка длины артикула

Обработка справочников v8 Бесплатно (free)

Как заполнить дополнительный реквизит номенклатуры данными из другого реквизита.

03.04.2020    2130    gtrr34    2    

Загрузка картинок в справочники (Универсальная загрузка из табличного документа)

Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Бесплатно (free)

Пример загрузки картинок в справочник Номенклатура (с помощью обработки универсальная загрузка данных из табличного документа). Проверялось на конфигурации УТ 11.4.7.

28.05.2019    9169    Rasdag    5    

Групповая обработка (Управляемая консоль отчетов)

Обработка документов Инструментарий разработчика Обработка справочников v8 v8::УФ v8::Запросы 1cv8.cf 1С:Франчайзи, автоматизация бизнеса Бесплатно (free)

Статья предназначена тем, кто понимает, зачем нужна групповая обработка в консоли запросов. Рассматривается групповая обработка в консоли Управляемая консоль отчетов.

13.05.2019    10220    Evg-Lylyk    10    

MDM система для централизованного управления справочниками предприятия типовыми средствами

Обмен через XML Обработка справочников v8 1cv8.cf Бесплатно (free)

Поставили мне пару недель назад задачу настроить единые справочники номенклатуры во всех базах холдинга. Учитывая количество 1С бухгалтерий, которых в процессе выполнения задачи оказалось 32, и учитывая, что они все разных версий (2.0, 3.0, отраслевые), задача казалась из ряда чистой воды подстава. Но решение с технической точки зрения оказалось простейшим.

27.11.2018    6953    lopatin    6    

1С 8. Перенумерация документов и справочников

Обработка документов Обработка справочников v8 1cv8.cf Бесплатно (free)

1с 8. Перенумерация документов и справочников. Как перенумеровать различные документы (и справочники) в 1с 8? Как перенумеровать документы с префиксами по различным организациям?

06.06.2015    39729    pvlunegov    9    

Программисту на заметку: автозаполнение реквизитов документов и справочников

Обработка документов Практика программирования Обработка справочников v8 1cv8.cf Бесплатно (free)

Часто бывает необходимым, чтобы при создании документа, элемента справочника автоматически заполнялись заданным значением определенные его реквизиты. Ниже предлагается вариант реализации механизма автозаполнения реквизитов документов по заданным условиям.

23.09.2013    36901    vdscom    13    

1С:PDM. 3 простых шага от чертежей Компас к спецификациям УПП

Производство готовой продукции (работ, услуг) Управление проектом Обработка справочников Производство готовой продукции (работ, услуг) v8 УПП1 Машиностроение и приборостроение Россия Бесплатно (free)

Методика быстрого создания контрольных примеров (прототипов, пилотов и т.п.) применения «1С:PDM» на данных Заказчика с использованием моих обработок. Не требует глубоких знаний в предметной области (САПР, PDM и ЕСКД), и позволяет наглядно (и без существенных затрат) продемонстрировать Заказчику возможности решения «1С:PDM» на его данных.

22.08.2012    29525    Iyar    1    

Очередная печать справочников и документов, с отбором, но без прикрас

Обработка документов Обработка справочников v8 1cv8.cf Россия Бесплатно (free)

Навеяно http://infostart.ru/projects/3646/ и, в частности, постом (20) из нее. Очень хочется иметь возможность распечатывать элементы справочников или документы, да еще с произвольным отбором, да еще и реквизиты какие хотим для печати указывать.

21.03.2009    10550    tsd    15    

Как я интегрировал 1Сv8 и Virtuemart

Внешние источники данных Обработка справочников WEB v8 УТ10 ИТ-компания Россия Бесплатно (free)

Задача: создать обмен 1Сv8 управление торговлей 10.1 и Virtuemart . Что такое Virtuemart можно почитать тут http://www.virtuemart.ru, вкратце - это компонент интернет-магазина (каталога товаров) к известному CMS-движку Joomla.

09.10.2008    33317    d.snissarenko    21