Хеширование данных с ключом по алгоритму SHA-1 штатными средствами 1С

Публикация № 284214

Разработка - Практика программирования

SHA-1 ХешФункция ХешированиеДанных ХешФункция.SHA1 Хеширование данных с ключом SHA-1 в 1с

Расчет хеш суммы данных по алгоритму SHA-1 с ключом штатными средствами 1С.

Потребовалось реализовать обмен данными с веб-сервером, одним из теребованием авторизации было хеширование данных с секретным ключом.

Пример реализации расчета хеш суммы данных по алгоритму SHA-1 с ключом штатными средствами 1С.

 

//Функция ХэшированиеШтатныеСредства(СтрокаJSON, Base64JSON ,КлючХешированияДанных = "")

//
//Описание:
// Реализует инкрементальный расчет хеш-суммы по добавленным данным, использую хеш функцию SHA1.
//
//Параметры:
// СтрокаJSON - Строка. Строка в формате JSON.
//
// КлючХешированияДанных - Строка. Закодированные данные идентификатора в base64.
//
// Возвращаемое значение:
// Строка. Закодированная хеш сумма в base64.
//
Функция ХэшированиеШтатныеСредства(СтрокаJSON, КлючХешированияДанных = "")

Base64JSON = ЗакодироватьВBase64(СтрокаJSON);

ХешированиеДанных = Новый ХешированиеДанных(ХешФункция.SHA1);
ХешированиеДанных.Добавить(base64Значение(КлючХешированияДанных));
ХешированиеДанных.Добавить(base64Значение(Base64JSON));

ТипДвоичныеДанные = ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "base64Binary");
ДвоичныеДанные = ФабрикаXDTO.Создать(ТипДвоичныеДанные,ХешированиеДанных.ХешСумма);

Возврат ДвоичныеДанные.ЛексическоеЗначение;

КонецФункции
Функция ЗакодироватьВBase64(СтрокаДанных) 

ИмяФайлаЗаписьТекст = ПолучитьИмяВременногоФайла(); 

ЗаписьТекста = Новый ЗаписьТекста(ИмяФайлаЗаписьТекст); 
ЗаписьТекста.ЗаписатьСтроку(СтрокаДанных); 
ЗаписьТекста.Закрыть(); 

ДвДанны = Новый ДвоичныеДанные(ИмяФайлаЗаписьТекст); 

Возврат base64Строка(ДвДанны); 

КонецФункции

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. bulpi 175 28.05.14 12:29 Сейчас в теме
В слове "ключ" мягкий знак не нужен :)
2. ZaPaSoff 28.05.14 21:47 Сейчас в теме
что такое ЗакодироватьВBase64(СтрокаJSON)?
3. dour-dead 241 29.05.14 09:22 Сейчас в теме
(2) ZaPaSoff, В моем варианте это


<pre style="color: blue; overflow: auto;">
<span style="color: green;">// кодируем данные в base64, возможно переделать на штатные средства</span>
<span style="color: red;">Функция</span> ЗакодироватьВBase64<span style="color: red;">(</span>Данные<span style="color: red;">)</span>

СтрокаДанных <span style="color: red;">=</span> Строка<span style="color: red;">(</span>Данные<span style="color: red;">)</span><span style="color: red;">;</span>

WSH <span style="color: red;">=</span> <span style="color: red;">Новый</span> COMОбъект<span style="color: red;">(</span><span style="color: black;">"MSScriptControl.ScriptControl"</span><span style="color: red;">)</span><span style="color: red;">;</span>
WSH<span style="color: red;">.</span>language <span style="color: red;">=</span> <span style="color: black;">"JScript"</span><span style="color: red;">;</span>

лКодbase64encode <span style="color: red;">=</span> <span style="color: black;">"</span>
<span style="color: black;"> |function encode(input) {</span>
<span style="color: black;"> | var output = '';</span>
<span style="color: black;"> | var chr1, chr2, chr3, enc1, enc2, enc3, enc4;</span>
<span style="color: black;"> | var i = 0;</span>
<span style="color: black;"> | var _keyStr = 'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456­789+/=';</span>
<span style="color: black;"> | input = _utf8_encode(input);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | while (i < input.length) {</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | chr1 = input.charCodeAt(i++);</span>
<span style="color: black;"> | chr2 = input.charCodeAt(i++);</span>
<span style="color: black;"> | chr3 = input.charCodeAt(i++);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | enc1 = chr1 >> 2;</span>
<span style="color: black;"> | enc2 = ((chr1 & 3) << 4) | (chr2 >> 4);</span>
<span style="color: black;"> | enc3 = ((chr2 & 15) << 2) | (chr3 >> 6);</span>
<span style="color: black;"> | enc4 = chr3 & 63;</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | if (isNaN(chr2)) {</span>
<span style="color: black;"> | enc3 = enc4 = 64;</span>
<span style="color: black;"> | } else if (isNaN(chr3)) {</span>
<span style="color: black;"> | enc4 = 64;</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | output = output +</span>
<span style="color: black;"> | _keyStr.charAt(enc1) + _keyStr.charAt(enc2) +</span>
<span style="color: black;"> | _keyStr.charAt(enc3) + _keyStr.charAt(enc4);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | return output;</span>
<span style="color: black;"> |}</span>
<span style="color: black;"> |</span>
<span style="color: black;"> |// public method for decoding</span>
<span style="color: black;"> |function decode(input) {</span>
<span style="color: black;"> | var _keyStr = 'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456­789+/=';</span>
<span style="color: black;"> | var output = '';</span>
<span style="color: black;"> | var chr1, chr2, chr3;</span>
<span style="color: black;"> | var enc1, enc2, enc3, enc4;</span>
<span style="color: black;"> | var i = 0;</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | input = input.replace(/[^A-Za-z0-9\+\/\=]/g, '');</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | while (i < input.length) {</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | enc1 = _keyStr.indexOf(input.charAt(i++));</span>
<span style="color: black;"> | enc2 = _keyStr.indexOf(input.charAt(i++));</span>
<span style="color: black;"> | enc3 = _keyStr.indexOf(input.charAt(i++));</span>
<span style="color: black;"> | enc4 = _keyStr.indexOf(input.charAt(i++));</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | chr1 = (enc1 << 2) | (enc2 >> 4);</span>
<span style="color: black;"> | chr2 = ((enc2 & 15) << 4) | (enc3 >> 2);</span>
<span style="color: black;"> | chr3 = ((enc3 & 3) << 6) | enc4;</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | output = output + String.fromCharCode(chr1);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | if (enc3 != 64) {</span>
<span style="color: black;"> | output = output + String.fromCharCode(chr2);</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> | if (enc4 != 64) {</span>
<span style="color: black;"> | output = output + String.fromCharCode(chr3);</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | output = _utf8_decode(output);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | return output;</span>
<span style="color: black;"> |</span>
<span style="color: black;"> |}</span>
<span style="color: black;"> |</span>
<span style="color: black;"> |// private method for UTF-8 encoding</span>
<span style="color: black;"> |function _utf8_encode (string) {</span>
<span style="color: black;"> | var _keyStr = 'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456­789+/=';</span>
<span style="color: black;"> | string = string.replace(/\r\n/g,'\n');</span>
<span style="color: black;"> | var utftext = '';</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | for (var n = 0; n < string.length; n++) {</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | var c = string.charCodeAt(n);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | if (c < 128) {</span>
<span style="color: black;"> | utftext += String.fromCharCode©;</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> | else if((c > 127) && (c < 2048)) {</span>
<span style="color: black;"> | utftext += String.fromCharCode((c >> 6) | 192);</span>
<span style="color: black;"> | utftext += String.fromCharCode((c & 63) | 128);</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> | else {</span>
<span style="color: black;"> | utftext += String.fromCharCode((c >> 12) | 224);</span>
<span style="color: black;"> | utftext += String.fromCharCode(((c >> 6) & 63) | 128);</span>
<span style="color: black;"> | utftext += String.fromCharCode((c & 63) | 128);</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | return utftext;</span>
<span style="color: black;"> |}</span>
<span style="color: black;"> |</span>
<span style="color: black;"> |// private method for UTF-8 decoding</span>
<span style="color: black;"> |function _utf8_decode(utftext) {</span>
<span style="color: black;"> | var _keyStr = 'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456­789+/=';</span>
<span style="color: black;"> | var string = '';</span>
<span style="color: black;"> | var i = 0;</span>
<span style="color: black;"> | var c = c1 = c2 = 0;</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | while ( i < utftext.length ) {</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | c = utftext.charCodeAt(i);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | if (c < 128) {</span>
<span style="color: black;"> | string += String.fromCharCode©;</span>
<span style="color: black;"> | i++;</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> | else if((c > 191) && (c < 224)) {</span>
<span style="color: black;"> | c2 = utftext.charCodeAt(i+1);</span>
<span style="color: black;"> | string += String.fromCharCode(((c & 31) << 6) | (c2 & 63));</span>
<span style="color: black;"> | i += 2;</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> | else {</span>
<span style="color: black;"> | c2 = utftext.charCodeAt(i+1);</span>
<span style="color: black;"> | c3 = utftext.charCodeAt(i+2);</span>
<span style="color: black;"> | string += String.fromCharCode(((c & 15) << 12) | ((c2 & 63) << 6) | (c3 & 63));</span>
<span style="color: black;"> | i += 3;</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | return string;</span>
<span style="color: black;"> |}"</span><span style="color: red;">;</span>

лКодbase64encode <span style="color: red;">=</span> СтрЗаменить<span style="color: red;">(</span>лКодbase64encode<span style="color: red;">,</span><span style="color: black;">"'"</span><span style="color: red;">,</span>Символ<span style="color: red;">(</span><span style="color: black;">34</span><span style="color: red;">)</span><span style="color: red;">)</span><span style="color: red;">;</span>
WSH<span style="color: red;">.</span>AddCode<span style="color: red;">(</span>лКодbase64encode<span style="color: red;">)</span><span style="color: red;">;</span>

Рез1 <span style="color: red;">=</span> WSH<span style="color: red;">.</span>Run<span style="color: red;">(</span><span style="color: black;">"encode"</span><span style="color: red;">,</span>СтрокаДанных<span style="color: red;">)</span><span style="color: red;">;</span>

<span style="color: red;">Возврат</span> Рез1<span style="color: red;">;</span>

<span style="color: red;">КонецФункции</span>

</pre>
4. dour-dead 241 29.05.14 09:23 Сейчас в теме
(2) ZaPaSoff,

<pre style="color: blue; overflow: auto;">
<span style="color: green;">// кодируем данные в base64, возможно переделать на штатные средства</span>
<span style="color: red;">Функция</span> ЗакодироватьВBase64<span style="color: red;">(</span>Данные<span style="color: red;">)</span>

СтрокаДанных <span style="color: red;">=</span> Строка<span style="color: red;">(</span>Данные<span style="color: red;">)</span><span style="color: red;">;</span>

WSH <span style="color: red;">=</span> <span style="color: red;">Новый</span> COMОбъект<span style="color: red;">(</span><span style="color: black;">"MSScriptControl.ScriptControl"</span><span style="color: red;">)</span><span style="color: red;">;</span>
WSH<span style="color: red;">.</span>language <span style="color: red;">=</span> <span style="color: black;">"JScript"</span><span style="color: red;">;</span>

лКодbase64encode <span style="color: red;">=</span> <span style="color: black;">"</span>
<span style="color: black;"> |function encode(input) {</span>
<span style="color: black;"> | var output = '';</span>
<span style="color: black;"> | var chr1, chr2, chr3, enc1, enc2, enc3, enc4;</span>
<span style="color: black;"> | var i = 0;</span>
<span style="color: black;"> | var _keyStr = 'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456­789+/=';</span>
<span style="color: black;"> | input = _utf8_encode(input);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | while (i < input.length) {</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | chr1 = input.charCodeAt(i++);</span>
<span style="color: black;"> | chr2 = input.charCodeAt(i++);</span>
<span style="color: black;"> | chr3 = input.charCodeAt(i++);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | enc1 = chr1 >> 2;</span>
<span style="color: black;"> | enc2 = ((chr1 & 3) << 4) | (chr2 >> 4);</span>
<span style="color: black;"> | enc3 = ((chr2 & 15) << 2) | (chr3 >> 6);</span>
<span style="color: black;"> | enc4 = chr3 & 63;</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | if (isNaN(chr2)) {</span>
<span style="color: black;"> | enc3 = enc4 = 64;</span>
<span style="color: black;"> | } else if (isNaN(chr3)) {</span>
<span style="color: black;"> | enc4 = 64;</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | output = output +</span>
<span style="color: black;"> | _keyStr.charAt(enc1) + _keyStr.charAt(enc2) +</span>
<span style="color: black;"> | _keyStr.charAt(enc3) + _keyStr.charAt(enc4);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | return output;</span>
<span style="color: black;"> |}</span>
<span style="color: black;"> |</span>
<span style="color: black;"> |// public method for decoding</span>
<span style="color: black;"> |function decode(input) {</span>
<span style="color: black;"> | var _keyStr = 'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456­789+/=';</span>
<span style="color: black;"> | var output = '';</span>
<span style="color: black;"> | var chr1, chr2, chr3;</span>
<span style="color: black;"> | var enc1, enc2, enc3, enc4;</span>
<span style="color: black;"> | var i = 0;</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | input = input.replace(/[^A-Za-z0-9\+\/\=]/g, '');</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | while (i < input.length) {</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | enc1 = _keyStr.indexOf(input.charAt(i++));</span>
<span style="color: black;"> | enc2 = _keyStr.indexOf(input.charAt(i++));</span>
<span style="color: black;"> | enc3 = _keyStr.indexOf(input.charAt(i++));</span>
<span style="color: black;"> | enc4 = _keyStr.indexOf(input.charAt(i++));</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | chr1 = (enc1 << 2) | (enc2 >> 4);</span>
<span style="color: black;"> | chr2 = ((enc2 & 15) << 4) | (enc3 >> 2);</span>
<span style="color: black;"> | chr3 = ((enc3 & 3) << 6) | enc4;</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | output = output + String.fromCharCode(chr1);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | if (enc3 != 64) {</span>
<span style="color: black;"> | output = output + String.fromCharCode(chr2);</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> | if (enc4 != 64) {</span>
<span style="color: black;"> | output = output + String.fromCharCode(chr3);</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | output = _utf8_decode(output);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | return output;</span>
<span style="color: black;"> |</span>
<span style="color: black;"> |}</span>
<span style="color: black;"> |</span>
<span style="color: black;"> |// private method for UTF-8 encoding</span>
<span style="color: black;"> |function _utf8_encode (string) {</span>
<span style="color: black;"> | var _keyStr = 'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456­789+/=';</span>
<span style="color: black;"> | string = string.replace(/\r\n/g,'\n');</span>
<span style="color: black;"> | var utftext = '';</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | for (var n = 0; n < string.length; n++) {</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | var c = string.charCodeAt(n);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | if (c < 128) {</span>
<span style="color: black;"> | utftext += String.fromCharCode©;</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> | else if((c > 127) && (c < 2048)) {</span>
<span style="color: black;"> | utftext += String.fromCharCode((c >> 6) | 192);</span>
<span style="color: black;"> | utftext += String.fromCharCode((c & 63) | 128);</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> | else {</span>
<span style="color: black;"> | utftext += String.fromCharCode((c >> 12) | 224);</span>
<span style="color: black;"> | utftext += String.fromCharCode(((c >> 6) & 63) | 128);</span>
<span style="color: black;"> | utftext += String.fromCharCode((c & 63) | 128);</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | return utftext;</span>
<span style="color: black;"> |}</span>
<span style="color: black;"> |</span>
<span style="color: black;"> |// private method for UTF-8 decoding</span>
<span style="color: black;"> |function _utf8_decode(utftext) {</span>
<span style="color: black;"> | var _keyStr = 'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456­789+/=';</span>
<span style="color: black;"> | var string = '';</span>
<span style="color: black;"> | var i = 0;</span>
<span style="color: black;"> | var c = c1 = c2 = 0;</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | while ( i < utftext.length ) {</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | c = utftext.charCodeAt(i);</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | if (c < 128) {</span>
<span style="color: black;"> | string += String.fromCharCode©;</span>
<span style="color: black;"> | i++;</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> | else if((c > 191) && (c < 224)) {</span>
<span style="color: black;"> | c2 = utftext.charCodeAt(i+1);</span>
<span style="color: black;"> | string += String.fromCharCode(((c & 31) << 6) | (c2 & 63));</span>
<span style="color: black;"> | i += 2;</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> | else {</span>
<span style="color: black;"> | c2 = utftext.charCodeAt(i+1);</span>
<span style="color: black;"> | c3 = utftext.charCodeAt(i+2);</span>
<span style="color: black;"> | string += String.fromCharCode(((c & 15) << 12) | ((c2 & 63) << 6) | (c3 & 63));</span>
<span style="color: black;"> | i += 3;</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | }</span>
<span style="color: black;"> |</span>
<span style="color: black;"> | return string;</span>
<span style="color: black;"> |}"</span><span style="color: red;">;</span>

лКодbase64encode <span style="color: red;">=</span> СтрЗаменить<span style="color: red;">(</span>лКодbase64encode<span style="color: red;">,</span><span style="color: black;">"'"</span><span style="color: red;">,</span>Символ<span style="color: red;">(</span><span style="color: black;">34</span><span style="color: red;">)</span><span style="color: red;">)</span><span style="color: red;">;</span>
WSH<span style="color: red;">.</span>AddCode<span style="color: red;">(</span>лКодbase64encode<span style="color: red;">)</span><span style="color: red;">;</span>

Рез1 <span style="color: red;">=</span> WSH<span style="color: red;">.</span>Run<span style="color: red;">(</span><span style="color: black;">"encode"</span><span style="color: red;">,</span>СтрокаДанных<span style="color: red;">)</span><span style="color: red;">;</span>

<span style="color: red;">Возврат</span> Рез1<span style="color: red;">;</span>

<span style="color: red;">КонецФункции</span>

</pre>
5. dour-dead 241 29.05.14 09:24 Сейчас в теме
что то битрикс съедает часть текста)
Прикрепленные файлы:
ЗакодироватьВBase64.txt
6. ZaPaSoff 29.05.14 09:38 Сейчас в теме
Очень интересный вариант. Но в идеале конечно лучше сделать штатными средствами.
7. dour-dead 241 29.05.14 14:31 Сейчас в теме
(6) ZaPaSoff, такое возможно и штатными средствами
8. dour-dead 241 29.05.14 14:33 Сейчас в теме
Вот как пример

Функция ПолучитьBase64ИзСтроки(СтрокаДанных)
	
	ИмяФайлаЗаписьТекст = ПолучитьИмяВременногоФайла();
	
	ЗаписьТекста = Новый ЗаписьТекста(ИмяФайлаЗаписьТекст);
	ЗаписьТекста.ЗаписатьСтроку(СтрокаДанных);
	ЗаписьТекста.Закрыть();
	
	ДвДанны = Новый ДвоичныеДанные(ИмяФайлаЗаписьТекст);
	
	Возврат base64Строка(ДвДанны);
	
КонецФункции
Показать
9. Negator 05.03.18 09:00 Сейчас в теме
Здравствуйте.

Пытаюсь закодировать Json следующего содержания:
{"inputString":"Тест"}
ключом:
123456

Должно получиться (и получается при кодировке различных онлайн кодировщиков):
Dm0Oj8p9SCPeYojkxrtos2mMn9s=
а вместо этого описанная выше функция вообще отказывается работать пока ключ тоже не пропустишь через "ЗакодироватьВBase64", а после этого выдает результат:
zV8nNDDkrNW69zP/sdYCcucUdHU=

Подскажите пожалуйста как получить верный результат.
10. dour-dead 241 06.03.18 12:27 Сейчас в теме
(9)Добрый день. Скорее всего необходимо использовать одинаковые входные данные, что бы получить одинаковый результат на выходе.
12. han_kdz 11 19.03.18 15:16 Сейчас в теме
(9) (11)
та же история
Если делать ХЕШ по 1 строке - все совпадает с онлайн
Если делать по строке + ключ, не совпадает
Если найдено решение, прошу сообщить
Второй день, как рыба об лед (((
13. Negator 28.03.18 09:06 Сейчас в теме
(12)Штатными средствами получить верный результат не получилось. С использованием внешних же компонентов удалось добиться верного результата следующим образом:
Функция ВычислитьНаСервереХешСтрокиПоАлгоритму_HMAC_SHA1(Строка, Ключ, ВернутьBase64 = Истина) Экспорт
    
    Текст = Новый COMОбъект("System.Text.UTF8Encoding");
    КриптоSHA1 = Новый COMОбъект("System.Security.Cryptography.HMACSHA1");
    КриптоSHA1.key = Текст.GetBytes_4(Ключ);
    Если ВернутьBase64 Тогда
        
        Хэш1 = КриптоSHA1.ComputeHash_2(Текст.GetBytes_4(Строка)).Выгрузить();
        СтрокаХэша = Преобразовать64(, Хэш1);
        
    Иначе    
        
        Хэш1 = КриптоSHA1.ComputeHash_2(Текст.GetBytes_4(Строка));
        оStr = Новый COMОбъект("System.Text.StringBuilder");
        Для Каждого стр Из Хэш1 Цикл
            оStr.AppendFormat("{0:x02}", стр);
        КонецЦикла;

        СтрокаХэша = оStr.ToString; //последовательность байтов
        
    КонецЕсли;
        
    Возврат СтрокаХэша;
    
КонецФункции

Функция Преобразовать64(Строка64 = неопределено, Массив64 = неопределено)
    Таб64 = Новый ТаблицаЗначений;
    Таб64.Колонки.Добавить("Код");
    Таб64.Колонки.Добавить("Символ");
    Нпп = 0;
    Для Код = КодСимвола("A") По КодСимвола("Z") Цикл
        стр = Таб64.Добавить();
        стр.Код = Нпп;
        стр.Символ = Символ(Код);
        Нпп = Нпп + 1;
    КонецЦикла;
    Для Код = КодСимвола("a") По КодСимвола("z") Цикл
        стр = Таб64.Добавить();
        стр.Код = Нпп;
        стр.Символ = Символ(Код);
        Нпп = Нпп + 1;
    КонецЦикла;
    стр = Таб64.Добавить();
    стр.Код = Нпп;
    стр.Символ = "0";
    Нпп = Нпп + 1;
    Для Код = 1 По 9 Цикл
        стр = Таб64.Добавить();
        стр.Код = Нпп;
        стр.Символ = Формат(Код,"ЧЦ=1; ЧДЦ=0");
        Нпп = Нпп + 1;
    КонецЦикла;
    стр = Таб64.Добавить();
    стр.Код = Нпп;
    стр.Символ = "+";
    Нпп = Нпп + 1;
    стр = Таб64.Добавить();
    стр.Код = Нпп;
    стр.Символ = "/";
    
    Если Массив64 = неопределено Тогда 
        Если Строка64 = неопределено Тогда
            Сообщить("неверный вызов функции");
            Возврат неопределено;
        КонецЕсли;
        //Уберем переносы строк
        Строка64 = СтрЗаменить(Строка64, Символ(10), "");
        Строка64 = СтрЗаменить(Строка64, Символ(13), "");
        
        //преобразовываем строку в массив
        Если СтрДлина(Строка64) % 4 <> 0 Тогда
            Сообщить("длина строки на входе должна быть кратна 4"); 
            Сообщить(СтрДлина(Строка64)); 
            Возврат неопределено;
        КонецЕсли;
        Кол4 = Цел(СтрДлина(Строка64) / 4);
        РазмерМ = Кол4 * 3;
        Если Прав(Строка64, 2) = "==" Тогда
            РазмерМ = РазмерМ - 2;
        ИначеЕсли Прав(Строка64, 1) = "=" Тогда
            РазмерМ = РазмерМ - 1;
        КонецЕсли;            
        Массив64 = Новый Массив(РазмерМ);
        Для А = 1 По Кол4 Цикл
            Число3 = 0;
            Для Б = 1 По 4 Цикл
                Буква1 = Сред(Строка64, (А-1)*4 + Б, 1);    
                Если Буква1 = "=" Тогда
                    Код4 = 0;
                Иначе
                    стрН = Таб64.Найти(Буква1, "Символ");
                    Если стрН = Неопределено Тогда
                        Сообщить("ошибка при поиске "+ КодСимвола(Буква1));    
                    Иначе 
                        Код4 = стрН.Код;
                    КонецЕсли;
                КонецЕсли;
                Число3 = Число3 * 64 + Код4;
            КонецЦикла;
            Ост = Число3 % 256;
            Индекс = (А-1)*3 + 2;
            Если Индекс <= РазмерМ - 1 Тогда
                Массив64[Индекс] = Ост;
            КонецЕсли;
            Число3 = (Число3 - Ост) / 256;
            Ост = Число3 % 256;
            Индекс = (А-1)*3 + 1;
            Если Индекс <= РазмерМ - 1 Тогда
                Массив64[Индекс] = Ост;
            КонецЕсли;
            Число3 = (Число3 - Ост) / 256;
            Ост = Число3 % 256;
            Массив64[(А-1)*3 + 0] = Ост;
        КонецЦикла;
        Возврат Массив64;
    Иначе //Преобразовываем массив в строку
        Строка64 = "";
        Кол3 = Цел(Массив64.Количество() / 3);
        Если Массив64.Количество() % 3 <> 0 Тогда
            Кол3 = Кол3 + 1;
        КонецЕсли;
        Для А = 1 По Кол3 Цикл
            Число3 = Массив64[(А-1)*3];    
            Если (А-1)*3+1 <= Массив64.ВГраница() Тогда
                Код3 = Массив64[(А-1)*3+1];
            Иначе
                Код3 = 0;
            КонецЕсли;
            Число3 = Число3*256 + Код3;
            Если (А-1)*3+2 <= Массив64.ВГраница() Тогда
                Код3 = Массив64[(А-1)*3+2];
            Иначе
                Код3 = 0;
            КонецЕсли;
            Число3 = Число3*256 + Код3;
            
            Ост4 = Число3 % 64;
            Число3 = (Число3 - Ост4) / 64;
            Ост3 = Число3 % 64;
            Число3 = (Число3 - Ост3) / 64;
            Ост2 = Число3 % 64;
            Число3 = (Число3 - Ост2) / 64;
            Ост1 = Число3 % 64;
            Число3 = (Число3 - Ост1) / 64;
            стрН = Таб64.Найти(Ост1, "Код");
            Если стрН = неопределено Тогда
                Сообщить("Ошибка при поиске");
            Иначе
                Строка64 = Строка64 + стрН.Символ;
            КонецЕсли;
            стрН = Таб64.Найти(Ост2, "Код");
            Если стрН = неопределено Тогда
                Сообщить("Ошибка при поиске");
            Иначе
                Строка64 = Строка64 + стрН.Символ;
            КонецЕсли;
            стрН = Таб64.Найти(Ост3, "Код");
            Если стрН = неопределено Тогда
                Сообщить("Ошибка при поиске");
            Иначе
                Строка64 = Строка64 + стрН.Символ;
            КонецЕсли;
            стрН = Таб64.Найти(Ост4, "Код");
            Если стрН = неопределено Тогда
                Сообщить("Ошибка при поиске");
            Иначе
                Строка64 = Строка64 + стрН.Символ;
            КонецЕсли;
        КонецЦикла;
        //Если количество символов не делится на 3, то на конце должны быть
        //знаки "="
        Если Массив64.Количество() % 3 = 1 Тогда
            Строка64 = Лев(Строка64, СтрДлина(Строка64)-2)+ "==";    
        ИначеЕсли Массив64.Количество() % 3 = 2 Тогда
            Строка64 = Лев(Строка64, СтрДлина(Строка64)-1)+ "=";    
        КонецЕсли;
        Возврат Строка64;
    КонецЕсли;
КонецФункции
Показать
11. Negator 06.03.18 15:10 Сейчас в теме
Входящие данные идентичны - проверено например тут: https://hash.online-convert.com/ru/sha1-generator
14. Negator 26.06.18 10:42 Сейчас в теме
После долгих мытарств решение было найдено (не мое, но работает):
Функция ЗашифроватьSHA1ШтатнымиСредствами(СтрокаТекст,СтрокаКлюч) Экспорт
  
    СтрокаНули = "00000000000000000000000000000000000000000000000000000000000­000000000000000000000000000000000000000000000000000000000000­000000000";
    СтрокаОПАД = "5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5­c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5c5­c5c5c5c5c";
    СтрокаИПАД = "36363636363636363636363636363636363636363636363636363636363­636363636363636363636363636363636363636363636363636363636363­636363636";
    
    К = ПолучитьДвоичныеДанныеИзСтроки(СтрокаКлюч);
    
    К = ПолучитьБуферДвоичныхДанныхИзДвоичныхДанных(К);
    Нули = ПолучитьБуферДвоичныхДанныхИзHexСтроки(СтрокаНули);      
    Нули.ЗаписатьПобитовоеИли(0,К);             
    Шаг1 = ПолучитьДвоичныеДанныеИзБуфераДвоичныхДанных(Нули);
    
    ИПАД = ПолучитьБуферДвоичныхДанныхИзHexСтроки(СтрокаИПАД);
    БуферШаг1 = ПолучитьБуферДвоичныхДанныхИзДвоичныхДанных(Шаг1);
    ИПАД.ЗаписатьПобитовоеИсключительноеИли(0,БуферШаг1);
    Шаг2 = ПолучитьДвоичныеДанныеИзБуфераДвоичныхДанных(ипад);
    
    БуферШаг2 = ПолучитьБуферДвоичныхДанныхИзДвоичныхДанных(Шаг2);
    БуферТекст = ПолучитьБуферДвоичныхДанныхИзСтроки(СтрокаТекст);
    БуферШаг3 = БуферШаг2.Соединить(БуферТекст);
    Шаг3 = ПолучитьДвоичныеДанныеИзБуфераДвоичныхДанных(БуферШаг3);
    
    ХД = Новый ХешированиеДанных(ХешФункция.SHA1);
    ХД.Добавить(Шаг3);
    Шаг4 = ХД.ХешСумма;
    
    ОПАД = ПолучитьБуферДвоичныхДанныхИзHexСтроки(СтрокаОПАД);
    БуферШаг1 = ПолучитьБуферДвоичныхДанныхИзДвоичныхДанных(Шаг1);
    ОПАД.ЗаписатьПобитовоеИсключительноеИли(0,БуферШаг1);
    Шаг5 = ПолучитьДвоичныеДанныеИзБуфераДвоичныхДанных(ОПАД);
    
    БуферШаг4 = ПолучитьБуферДвоичныхДанныхИзДвоичныхДанных(Шаг4);
    БуферШаг5 = ПолучитьБуферДвоичныхДанныхИзДвоичныхДанных(Шаг5);
    БуферШаг6 = БуферШаг5.Соединить(БуферШаг4);
    Шаг6 = ПолучитьДвоичныеДанныеИзБуфераДвоичныхДанных(БуферШаг6);
    
    ХД = Новый ХешированиеДанных(ХешФункция.SHA1);
    ХД.Добавить(Шаг6);
    Шаг7 = ХД.ХешСумма;
    
    Возврат НРег(ПолучитьHexСтрокуИзДвоичныхДанных(Шаг7));      
    
КонецФункции
Показать


Если нужна другая функция хеширования - меняем в двух строчках ХешФункция.SHA1 на нужную и все.
MsDjuice; sir; +2 Ответить
15. sir 2 03.06.19 13:52 Сейчас в теме
(14) спасибо, заработало на sha256

Причем работает более чем в 10 раз быстрее нежели через COMОбъект("System.Security.Cryptography.HMACSHA256")
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37303    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    26013    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    23340    John_d    22    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    17887    kuzyara    33    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30174    tormozit    100    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    16921    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8316    Sibars    19    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    32837    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    77932    tormozit    131    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    11714    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    49124    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    48876    ids79    54    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48306    tormozit    41    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    28112    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25397    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    31279    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    44716    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    80857    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    34864    avalakh    22    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    23554    json    13    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16035    m-rv    2    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    58904    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    35595    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    25938    YPermitin    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20212    m-rv    17    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19599    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    46011    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    52105    ids79    25    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30547    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    24922    dmurk    145    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    42713    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35248    ellavs    126    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28226    itriot11    34    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27339    ellavs    89    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31260    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    38924    Смешной 1С    28    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76297    Serginio    108    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    21880    Vladimir Litvinenko    27    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    34637    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    39252    ids79    9    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    26751    ids79    31    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29200    grumagargler    28    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    41331    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    36908    ids79    42    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    47200    Unk92    25    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    52594    m-rv    61