Процедура для заполнения табличной части обработки "Печать ценников" по документу Установка цен номенклатуры (УТ 10.3)

14.08.15

Задачи пользователя - Этикетки, ценники

Процедура позволит распечатать ценники по товару из документа Установка цен номенклатуры

Данная процедура дополняет функционал стандартной, для УТ 10.3, обработки "Печать ценников". В меню Заполнить добавляем элемент ЗаполнитьПоУстановкаЦен и (соответственно ему) действие КоманднаяПанельТоварыЗаполнитьПоУстановкаЦен

Процедура КоманднаяПанельТоварыЗаполнитьПоУстановкаЦен(Кнопка)
	
	Документ = Документы.УстановкаЦенНоменклатуры.ПолучитьФормуВыбора().ОткрытьМодально();
	
	Если Документ = Неопределено Тогда
		Возврат;
	КонецЕсли;	
	
	Товары.Очистить();
	Если Документ.Товары.Количество()>0 Тогда
		Запрос = Новый Запрос;
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	УстановкаЦенНоменклатурыТовары.Номенклатура,
		|	УстановкаЦенНоменклатурыТовары.Цена,
		|	УстановкаЦенНоменклатурыТовары.ЕдиницаИзмерения
		|ИЗ
		|	Документ.УстановкаЦенНоменклатуры.Товары КАК УстановкаЦенНоменклатурыТовары
		|ГДЕ
		|	УстановкаЦенНоменклатурыТовары.Ссылка = &Ссылка
		|	И УстановкаЦенНоменклатурыТовары.ТипЦен = &ТипЦен";
		
		Запрос.УстановитьПараметр("Ссылка", Документ);
		Запрос.УстановитьПараметр("ТипЦен", ТипЦен);
		
		Результат = Запрос.Выполнить().Выбрать();
		ТЗ=Новый ТаблицаЗначений;
		ТЗ.Колонки.Добавить("Номенклатура");
		ТЗ.Колонки.Добавить("Цена");
		ТЗ.Колонки.Добавить("ЕдиницаИзмерения");
		ТЗ.Колонки.Добавить("Количество");
		ТЗ.Колонки.Добавить("Печать");
		Пока Результат.Следующий() Цикл
			Стр					=ТЗ.Добавить();
			Стр.Номенклатура	=Результат.Номенклатура;
			Стр.Цена			=Результат.Цена;
			Стр.ЕдиницаИзмерения=Результат.ЕдиницаИзмерения;
			Стр.Количество		=1;
			Стр.Печать			=Истина;
		КонецЦикла;
		//
		Если ТЗ.Количество()>0 тогда		
			Товары.Загрузить(ТЗ);
		иначе
			Если  ПустаяСтрока(ТипЦен) тогда
				Сообщить("Не выбрана цена");
			иначе
				Сообщить("В документе отсутствует цена- "+ТипЦен.Наименование+" или у документа неправильно заполнена табличная часть"); 
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры//КоманднаяПанельТоварыЗаполнитьПоУстановкаЦен

Также эту процедуру легко можно переделать под любой другой документ.

Печать ценников Установка цен номенклатуры УТ 10.3

См. также

Штрих-коды в шаблоне этикетки

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Россия Управленческий учет Платные (руб)

Решение позволяет в шаблон этикетки с типом "Этикетка (обувь, одежда, табак...)" добавлять штрих-коды другого типа, например, GTIN в Code128.

4000 руб.

09.06.2021    15335    8    6    

12

Ценники и этикетки со штрих-кодом для 1С 8.х любой конфигурации

Этикетки, ценники Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Беларусь Украина Россия Управленческий учет Платные (руб)

Простая в использовании обработка для формирования и печати ценников и этикеток со штрих-кодом, с дополнительной ценой, для 1С8.х любой конфигурации. Большое разнообразие шаблонов печатных форм. Управляемая форма (Такси) + Обычный режим.

3588 руб.

11.11.2020    48252    55    44    

65

Печать ценников. (Розница 2.3, УНФ 1.6, две цены + серийные номера) + УНФ 3.0

Этикетки, ценники Пользователь Платформа 1С v8.3 Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 Платные (руб)

Встроенная в конфигурации Розница 2.3 и УНФ 1.6 подсистема печати ценников по мне слишком неповоротлива и с усилиями поддается тонкой настройке, решил с нуля написать свою универсальную печать ценников для этих конфигураций.

2000 руб.

04.11.2019    28517    113    87    

52

Печать из Андроид

Этикетки, ценники Программист Мобильная платформа Бесплатно (free)

Печать этикеток на принтер WiFi без драйвера.

20.01.2023    2041    aldar    0    

9

Ценники (этикетки) для термопринтера

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Абонемент ($m)

Внешняя печатная форма для принтера этикеток. В отличие от базовой обработки для печати этикеток эта может выводить на печать дополнительные свойства справочника Номенклатура, а также в ней несложный программный код, что позволяет легко дорабатывать обработку под свои нужды.

2 стартмани

03.01.2023    3306    21    AndreyPonom    7    

10

Набор готовых макетов этикеток (ценников) для Розницы 2.3

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Розница 2 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Архив с экспортными шаблонами этикеток (ценников) формата 58х40. Для тех, кто не хочет сам рисовать их.

2 стартмани

04.05.2022    12836    44    aximo    3    

11

Шаблон этикетки для УНФ (1С:Фреш)

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Описан механизм создания этикетки для термопринтера ТSC TDP-225 в подробностях. Приложен XML-файл с самим шаблоном.

1 стартмани

01.05.2022    11791    6    zemskov    7    

5
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Papilion 19.08.15 10:59 Сейчас в теме
Чтобы не менять конфу можно добавить как внешнюю обработку через "Внешние обработки заполнения табличных частей", используя
Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта = Неопределено) Экспорт.
3. dr2c 44 24.08.15 13:38 Сейчас в теме
(1) Papilion, Безусловно. Здесь нет ни слова, что эти изменения можно(нужно) вносить только в обработку из состава конфигурации.
2. NE_ZNAIY 24.08.15 09:46 Сейчас в теме
А разве нельзя прямо из установки цен напечатать ценники?
Я печатаю. В какой момент эта обработка может понадобиться?
4. dr2c 44 24.08.15 13:39 Сейчас в теме
(2) NE_ZNAIY, Уверены, что у вас стандартное решение? В оригинальной поставке можно распечатать Прайс, но не ценники
Оставьте свое сообщение