Параллельные HTTP-запросы

Публикация № 606129

Разработка - Практика программирования

http асинхронность Msxml2.ServerXMLHTTP WinHttp.WinHttpRequest

Демонстрируется пример параллельных http-запросов с использованием Msxml2.ServerXMLHTTP, WinHttp.WinHttpRequest, что позволяет получать данные сразу с множества ресурсов, экономя время, а также работать файловом режиме.

Когда необходимо производить обработку множетсва интернет-ресурсов (сайтов, web-сервисов и т.д.) , то остро встает проблема с производительностью приложения, так как при синхронных запросах время работы линейно зависит от количества запросов. Общее затраченное время  на получение ресурса можно сократить если использовать параллельную обработку ресурсов.

Один из вариантов решения задачи - это использование под Windows com-объекта Msxml2.ServerXMLHTTP, он позволяет производить асинхронное получение данных после запроса ресурса. Данный объект после получения данных может вызывать callback-фукнцию однако на чистом 1С мне не удалось ее запусить, но данный com-объект позволяет с помощью метода waitForResponse приостанавливать выполнение асинхронной операции ожидая завершения операции, вот этим и воспользуемся организовав тем самым подобие polling (частые опросы). Однако о чистой асинхронности говорить не приходится, так как работа пользователя будет заблокированна на время обработки ресурсов.

Рассмотрим на основе Msxml2.ServerXMLHTTP  пример опроса 30-и страниц статей с сайта microsoft.com, начиная со статьи про Msxml2.ServerXMLHTTP. Все дальнейшие рассуждения верны и для WinHttp.WinHttpRequest.

Подготовка:

Объекты = Новый Массив;
КоличествоОбъектов = 30;

Для ин = 0 По КоличествоОбъектов-1 Цикл
	ОбъектHTTP = Новый COMОбъект("Msxml2.ServerXMLHTTP.6.0");
	// таймаут 30 сек по всем операциям
	ОбъектHTTP.setTimeouts(30000,30000,30000,30000);
	// третий параметр указывает на асинхронность вызова
	ОбъектHTTP.open("GET", "https://msdn.microsoft.com/ru-ru/library/ms" + Формат(762278 + ин, "ЧГ=") + "(v=vs.85).aspx", Истина);		
	// отправляем запрос
	ОбъектHTTP.send();

	// сохраняем данные
	Данные = Новый Структура("Объект, Выполнено, Ошибка", ОбъектHTTP, Ложь, Ложь);
	Объекты.Добавить(Данные);			
КонецЦикла;

Далее запускаем цикл опроса созданных объектов, время ожидания для метода waitForResponse выбрано произвольным образом, очевидно, что оно не должно быть большим, иначе потеряем всю выгоду:

Пока Истина Цикл	
	ОбработаноОбъектов = 0;
	Для ин = 0 По КоличествоОбъектов-1 Цикл
		
		Если Объекты[ин].Выполнено = Ложь И Объекты[ин].Ошибка = Ложь Тогда
                        // readyState = 4 - признак того, что страница загружена полностью
			Если (Объекты[ин].Объект.readyState <> 4) Тогда 	
				Попытка
					// время ожидания
					Объекты[ин].Объект.waitForResponse(50);
				Исключение
					// наиболее вероятная ошибка - сработал таймаут
					Объекты[ин].Ошибка = Истина;
				КонецПопытки;
			Иначе
				// результат получен
				Объекты[ин].Выполнено = Истина;
			КонецЕсли;
		Иначе
			ОбработаноОбъектов = ОбработаноОбъектов + 1;
		КонецЕсли;
		
	КонецЦикла;
	// выходим из цикла, так как все запросы обработаны
	Если ОбработаноОбъектов = КоличествоОбъектов Тогда
		Прервать;
	КонецЕсли;	
КонецЦикла

Пример реализации для WinHttpRequest, ключевое отличие в том, что в нем нет параметра readyState, результат операции возвращает метод WaitForResponse.

Для ин = 0 По КоличествоОбъектов-1 Цикл
	
	ОбъектHTTP = Новый COMObject("WinHttp.WinHttpRequest.5.1");		
	ОбъектHTTP.Open("GET", "https://msdn.microsoft.com/ru-ru/library/ms" + Формат(762278 + ин, "ЧГ=") + "(v=vs.85).aspx", 1);
	ОбъектHTTP.Send();
	ОбъектHTTP.SetTimeouts(30000, 30000, 30000, 30000);
	Данные = Новый Структура("Объект, Выполнено, Ошибка", ОбъектHTTP, Ложь, Ложь);
	Объекты.Добавить(Данные);			
	
КонецЦикла;

// ожидание ответов	
Пока Истина Цикл
	
	ОбработаноОбъектов = 0;
	Для ин = 0 По КоличествоОбъектов-1 Цикл
		
		Если Объекты[ин].Выполнено = Ложь И Объекты[ин].Ошибка = Ложь Тогда
			
			Результат = Ложь;
			
				Попытка
					// время ожидания, в данном случае не существенно
					Результат = Объекты[ин].Объект.WaitForResponse(50);
				Исключение
					// наиболее вероятная ошибка - сработал таймаут
					Объекты[ин].Ошибка = Истина;
				КонецПопытки;
				
			Если Результат = Истина Тогда
				// результат получен
				Объекты[ин].Выполнено = Истина;
			КонецЕсли;
		Иначе
			ОбработаноОбъектов = ОбработаноОбъектов + 1;				
		КонецЕсли;
		
	КонецЦикла;
	
	Если ОбработаноОбъектов = КоличествоОбъектов Тогда
		Прервать;
	КонецЕсли;
	
КонецЦикла;

Результаты: при синхронной работе (3-ий параметр Ложь в функции open) получаем 42 сек, при параллельной работе  получаем 3 сек.  Результаты ответов одинаковые.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. tindir 05.04.17 04:30 Сейчас в теме
Я думал о фоновых заданиях, когда видел эту задачу на бирже. Использование КОМа "некросплатформеннна" =)
BigB; GreenDragon; vano-ekt; +3 Ответить
2. gzharkoj 05.04.17 06:28 Сейчас в теме
(1) В файловом варианте фоновые задачи будут последовательно выполняться. Ну а если необходимо еще кроссплатформенность, то без подключаемой компоненты не обойтись.
3. tindir 05.04.17 07:41 Сейчас в теме
Да, не "универсальненок" с фоновыми выходит. Возможно такое разрулит только компонента. Хотя можно заиспользовать AJAX технологию (которая потребует только наличие HTML поля и JS библиотеки, если я опять не туплю =) ).
4. gzharkoj 05.04.17 09:22 Сейчас в теме
(3) По факту тоже самое получиться, на JS запустите все, что нужно, а 1С также будет висеть и ожидать результата, только время потратите больше на реализацию. Это по идее можно сделать через HTML-поле и XMLHttpRequest под Win, а вот под Linux как организовать не могу сказать, не занимался этим вопросом.
6. TitanLuchs 247 05.04.17 09:54 Сейчас в теме
(4)
XMLHttpRequest под Win

Вчера как раз проверяли на WinHttpRequest - 2200 запросов за 1 минуту отработало отлично. Это больше 30 в секунду.
7. gzharkoj 05.04.17 10:06 Сейчас в теме
(6) На всякий случай замечу, что скорость будет зависеть от запрашиваемого ресурса и линий связи.
8. TitanLuchs 247 05.04.17 10:12 Сейчас в теме
(7) Скорость ответа - да, а скорость генерации запросов - вряд ли. Я же не писал, что на все эти запросы и ответы пришли в течение минуты. WinHttp помогает в том смысле, что позволяет добиться асинхронности на файловой базе, а так - толку от нее не больше, чем от встроенных механизмов платформы.
9. gzharkoj 05.04.17 10:26 Сейчас в теме
(8) Я подумал, что речь идет о завершенных операциях. Так весь смысл в том, чтобы более/менее универсально было вне зависимости от архитектуры, получается, что толк есть!
10. TitanLuchs 247 05.04.17 10:37 Сейчас в теме
(9)
Я подумал, что речь идет о завершенных операциях

Нет, конечно. Мы бомбили собственный достаточно слабый сервер, там пара запросов вернули ответ через 22 секунды.
Наличие толка - вещь субъективная, зависит от многих переменных. Вполне возможно, что где-то это будет наилучшим решением.
gzharkoj; +1 Ответить
5. tindir 05.04.17 09:50 Сейчас в теме
Так это и имеется в виду. HTML работает почти одинаково в ВИНЬ и ЛИНЬ. Мы циклом кидаем XMLHttpRequest в асинхронном или обещанном режиме и ждем пока нам вернутся все события, причем в этот момент 1ц не будет виснуть, тк исполняется реквест в другой программе.
Или я не до конца понимаю и JS методологию?=)
11. Serginio 823 05.04.17 10:45 Сейчас в теме
12. sashs1980 62 05.04.17 12:00 Сейчас в теме
Вот тут ошибку исправьте
ОбъектHTTP.Open("GET", "https://msdn.microsoft.com/ru-ru/library/ms" + Формат(762278 + 0, "ЧГ=") + "(v=vs.85).aspx", 1);
13. gzharkoj 05.04.17 14:48 Сейчас в теме
14. kiruha 384 17.04.17 19:20 Сейчас в теме
А если идет обращение к веб-сервису другой базы 1С(на SQL) - будет параллельное, или в очередь встанут ?
15. gzharkoj 17.04.17 19:45 Сейчас в теме
Там каждый раз создается объект, его состояние на другие не распространяется. Web-сервер, на котором развернут сервис 1С, по идее создаст столько процессов 1С сколько запрос пришло, поэтому не должно ничего вставать в очередь.
16. azubar 37 09.05.17 19:07 Сейчас в теме
Добавлю что на фоновых будет ресурсов жрать уйму... писал парсер на фоновых заданиях 1С, в итоге переписал парсер на php + api для импорта данных в 1С, все стало работать гораздо быстрее не говоря уже об экономии ресурсов.
17. echo77 1164 13.06.17 21:15 Сейчас в теме
Глупый вопрос - что дальше делать, с полученным в массиве объектом? Можно ли картинки так загружать и как их сохранить?
18. gzharkoj 14.06.17 07:20 Сейчас в теме
(17) Например, в каждом объекте для WinHttp.WinHttpRequest будет свойство responseText, в которое содержит то, что вернул сайт/сервис. Если же запросили какие-то двоичные данные (картинка, документы и т.д.), то результат будет в свойстве ResponseBody, обработать это поможет другой объект ADODB.Stream. В сети найдете много примеров, можете и мой посмотреть, там как раз описанная связка используется http://infostart.ru/public/538345/
19. echo77 1164 14.06.17 07:57 Сейчас в теме
(18) Спасибо большое! Все понятно, все получилось.
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    37241    unichkin    74    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    25578    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    23046    John_d    22    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    17605    kuzyara    33    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    30100    tormozit    100    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    16877    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    8274    Sibars    19    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    32550    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    77861    tormozit    131    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    11615    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    48567    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    48485    ids79    54    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    48205    tormozit    41    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    27930    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    25336    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    31175    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    44640    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    79853    ids79    49    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    34479    avalakh    22    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    23315    json    13    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16013    m-rv    2    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    58321    ids79    11    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    35436    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    25867    YPermitin    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20143    m-rv    17    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19554    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    45561    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    51764    ids79    25    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    30488    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    24840    dmurk    145    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    42474    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    35152    ellavs    126    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28205    itriot11    34    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    27298    ellavs    89    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    31157    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    38674    Смешной 1С    28    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76210    Serginio    108    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    21788    Vladimir Litvinenko    27    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    34532    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    38939    ids79    9    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    26617    ids79    31    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29176    grumagargler    28    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    41102    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    36768    ids79    42    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    46904    Unk92    25    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    52498    m-rv    61    

Быстрая загрузка множества изображений с сайта на примере парсера www.moda-nsk.ru

WEB v8 1cv8.cf Абонемент ($m)

Пример того, как ускорить загрузку изображений из web методом распараллеливания загрузок.

2 стартмани

27.10.2018    5451    5    echo77    0