Проверка активности работы

Публикация № 77072

Администрирование - Администрирование данных 1С - Журнал регистрации

Проверка последнего действия пользователя в журнале регистрации.

Очень часто возникает необходимость восстанавливать групповую последовательность документов. Делать это по ночам - самый оптимальный вариант. Однако самому следить за выполнением этой процедуры напряжно, так как клиентов много и баз соответственно. Поэтому у меня все работает по расписанию. Обработка сама запускает восстановление в указанный промежуток времени. Вечером начинает, под утро приостанавливает.

Но последнее время возникли проблемы из-за того, что сотрудники стали задерживаться на работе и автоматическое восстановление последовательности мешает им работать. Конечно можно было сдвинуть время начала на более поздний срок, однако это не совсем эффективно, так как задерживаются сотрудники не всегда. Следующей идеей было проверять наличие пользователей в системе и если они имеются - откладывать начало обработки. Тоже не вариант, так как наши балбесы просто забывали выходить из 1С-ки. Выкидывать их тоже не подходит - могут работать.

Вспомнив о журнале регистрации решил поступить банально просто, проверять последнюю запись в журнале регистрации и таким образом смотреть, когда последний раз кто-то что-то делал в базе. Затем запускать восстановление последовательности, если в базе никто ничего не делал длительное время.

Вот что у меня получилось (просьба не пинать ногами, сильно не заморачивался):

Функция Выделить(Стр, Разделитель = ",")
   
Поз = Найти(Стр,Разделитель);
    Если
Поз=0 Тогда
       
Рез = Стр;
       
Стр = "";
    Иначе
       
Рез = Лев(Стр,Поз-1);
       
Стр = Сред(Стр,Поз+СтрДлина(Разделитель));
    КонецЕсли;
    Возврат
Рез;
КонецФункции

Функция
ПоследнееДействие()
   
Файл = КаталогИБ()+"SYSLOG\1cv7.mlg";
   
FSO = CreateObject("Scripting.FileSystemObject");
   
F = FSO.GetFile(Файл);
   
T = FSO.OpenTextFile(Файл,1);
   
T.Skip(Макс(0,F.Size-256));
   
ПослСтрока = "";
    Пока
T.AtEndOfLine=0 Цикл
       
ПослСтрока = T.ReadLine();
    КонецЦикла;
   
T.Close();
   
T = 0;
   
F = 0;
   
FSO = 0;
   
Рез = СоздатьОбъект("СписокЗначений");
   
ДТ = Дата(Сред(ПослСтрока,7,2)+"."+Сред(ПослСтрока,5,2)+"."+Лев(ПослСтрока,4));
   
Рез.Установить("Дата",ДТ);
   
Выделить(ПослСтрока,";");
   
Время = Выделить(ПослСтрока,";");
   
Рез.Установить("Время",Время);
   
тЧ = 0; тМ = 0; тС = 0; ТекущееВремя(тЧ,тМ,тС);
   
Рез.Установить("Бездействие",Макс(0,Число(ТекущаяДата())*86400 + тЧ * 3600 + тМ * 60 + тС - Число(ДТ)*86400 - Число(Выделить(ВРемя,":"))*3600 - Число(Выделить(ВРемя,":"))*60 - Число(Время)));
   
Рез.Установить("Пользователь",Выделить(ПослСтрока,";"));
   
Рез.Установить("Среда",Выделить(ПослСтрока,";"));
   
Рез.Установить("Тип",Выделить(ПослСтрока,";"));
   
Рез.Установить("Действие",Выделить(ПослСтрока,";"));
   
Выделить(ПослСтрока,";");
   
Выделить(ПослСтрока,";");
   
Ид = СокрЛП(Выделить(ПослСтрока,";"));
    Если
Ид<>"" Тогда
       
Рез.Установить("Объект",ЗначениеИзСтрокиВнутр("{"""+Выделить(Ид,"/")+""",""0"",""0"","""+Выделить(Ид,"/")+""",""0"",""0"","""+Ид+"""}"));
    КонецЕсли;
   
Рез.Установить("Описание",ПослСтрока);
    Возврат
Рез;
КонецФункции

Функция возвращает список значений в котором по ключам хранится следующая информация:

Дата - дата действия (Тип: Дата)
Время - Время действия (Тип: Строка)
Бездействие - количество секунд бездействия между текущем временем и последним действием (Тип: Число)
Пользователь - Имя пользователя (Тип: Строка)
Среда - Флаг среды выполнения E - Предприятие, C - Конфигуратор, M - Монитор (Тип: Строка)
Тип - Тип действия, например Docs - действие с документами (Тип: Строка)
Действие - Выполненное действие (Тип: Строка)
Объект - Объект данных, над которым было произведено действие, если действие не связано с объектом, то это значение не возвращается (Тип: Объект базы данных)
Описание - Опсиание действия из журнала регистрации (Тип: Строка)

В общем, если кому пригодится эта маленькая функция, буду рад.

Пользуйтесь :)

Специальные предложения

См. также

Сбой, отказ 1C:Предприятия 7.7, код исключения e06d7363. APPCRASH 1cv7s.exe

Администрирование СУБД Журнал регистрации v7.7 1cv7.md Бесплатно (free)

Прекращена работа программы "1CV7 starter program". Никто не может зайти в 1C 7.7. Апкреш. Что делать? Проверьте, возможно журнал регистрации информационной базы 1С: Предприятия 7.7 поврежден.

17.08.2020    436    ksnik    3    

Анализ 1С: Предприятие 7.7 с помощью ELK стека

Журнал регистрации Администрирование данных 1С v7.7 1cv7.md Бесплатно (free)

Рассмотрим систему на базе Elasticsearch, Logstash и Kibana (ELK Stack) для анализа логов 1С Предприятие 7.7 с целью визуализации и анализа событий 1С.

22.01.2019    8310    phsin    20    

SQL-доступ к журналу регистрации 1С:Предприятие 7.7

Журнал регистрации v7.7 1cv7.md Бесплатно (free)

Все, кто работают с 7.7, знают, что журнал регистрации тормозит нещадно, в связи с чем пользы от него очень мало, и её ещё меньше, когда размер журнала превышает хотя бы 50 мегабайт. На Инфостарте, по- моему, даже есть средства для просмотра журнала, может, даже они эффективны, но моей мечтой всегда был sql-доступ к этому журналу, т.к. это просто, наглядно, удобно и, что самое важное, - очень быстро. Кому интересно - добро пожаловать.

11.12.2014    14757    VladC#    8    

Ошибка при запуске журнала регистрации 1с 7.7

Журнал регистрации v7.7 Бесплатно (free)

При запуске программы выходило сообщение «Ошибка при запуске журнала регистрации». Дело было не в бабине..

04.10.2013    29711    Alexion    2    

Копия напечатанного документа или как спрятать документ.

Журнал регистрации Практика программирования v7.7 Бесплатно (free)

Возникла необходимость, чтобы при печати определённого документа (даже потом не сохранённого), создавалась его копия, т.е. запись всех напечатанных документов. (В результате чего возникла такая потребность, полагаюсь на вашу фантазию). В итоге получилось два варианта решения, остановился на втором.

11.04.2013    15598    Dima_    8