Как отправить ошибки из журнала регистрации на почту?

Публикация № 997513

Администрирование - Администрирование данных 1С - Журнал регистрации

Журнал регистрации Excel почта почтовый профиль

Процедуры отправки ошибок из журнала регистрации на почту. Журнал регистрации выгружается в файл Excel, далее прикрепляется к письму. Для отправки писем создано регламентное задание.

Для отправки писем необходимо добавить регламентное задание:

Далее необходимо настроить расписание регламентного задания (в моем случае задание выполняется раз в сутки, в 23.50).

Далее нужно указать для регламентного задания процедуру ОтправитьОшибкиИзЖурналаРегистрацииНаПочту(). Процедура должна находиться в общем модуле.

Процедура ОтправитьОшибкиИзЖурналаРегистрацииНаПочту() Экспорт
	
	ФильтрЖурнала = Новый Структура;	
	ВнешниеДанные = Новый ТаблицаЗначений;	
	УровниРегистрацииОшибок = Новый Массив;
 	УровниРегистрацииОшибок.Добавить(УровеньЖурналаРегистрации.Ошибка);
	ФильтрЖурнала.Вставить("Уровень",УровниРегистрацииОшибок);
 	ФильтрЖурнала.Вставить("ДатаНачала",НачалоДня(ТекущаяДата()));	
	ФильтрЖурнала.Вставить("ДатаОкончания",КонецДня(ТекущаяДата())) ;	
	УстановитьПривилегированныйРежим(Истина);
	ВыгрузитьЖурналРегистрации(ВнешниеДанные,ФильтрЖурнала);
	УстановитьПривилегированныйРежим(Ложь);
	Если ВнешниеДанные.Количество() = 0 Тогда
	  Возврат;
	КонецЕсли;
	ТабДок      = Новый ТабличныйДокумент;    
        Построитель = Новый ПостроительОтчета();

        Построитель.ИсточникДанных          = Новый ОписаниеИсточникаДанных(ВнешниеДанные);
        Построитель.ВыводитьЗаголовокОтчета = Ложь;
        Построитель.Вывести(ТабДок );

        ИмяФайла = ПолучитьИмяВременногоФайла("xls");
    
        ТабДок.Записать(ИмяФайла,ТипФайлаТабличногоДокумента.XLS97);
	                     	
	ОтправитьОповещениеОтветственномуЛицу("Ошибки во вложенном файле","Ошибки в журнале регистрации базы "+СтрокаСоединенияИнформационнойБазы(),"it@company.com", ИмяФайла); 		
	
КонецПроцедуры

Функция ОтправитьОповещениеОтветственномуЛицу(ТекстСообщения,ТемаПисьма,email,ПутьКФайлуВложения = "") экспорт   
	
	ИПП = Новый ИнтернетПочтовыйПрофиль;
	ИПП.АдресСервераIMAP	= "mail.company.com"; 
	ИПП.АдресСервераSMTP	= "mail.company.com";
	ИПП.ИспользоватьSSLIMAP	=  Истина;      
	ИПП.ПарольIMAP	        = "Пароль1";
	ИПП.ПарольSMTP	        = "Пароль1";
	ИПП.ПользовательIMAP	= "company\1c";
	ИПП.ПользовательSMTP	= "company\1c";
	ИПП.ПортIMAP	        = 999;  
	ИПП.ПортSMTP	        = 24;
	ИПП.Таймаут	        = 70;  
	
	Попытка
		Сообщение = Новый ИнтернетПочтовоеСообщение;			
		Сообщение.Получатели.Добавить(email);
		Сообщение.Отправитель.Адрес = "1c@company.ru";
		Сообщение.Тема = ТемаПисьма; 	 
		Сообщение.Тексты.Добавить(ТекстСообщения);
		
		Если ЗначениеЗаполнено(ПутьКФайлуВложения) Тогда
		  Сообщение.Вложения.Добавить(ПутьКФайлуВложения);
		КонецЕсли;

		Почта = Новый ИнтернетПочта;
		Почта.Подключиться(ИПП);
		Почта.Послать(Сообщение);
		Почта.Отключиться();
	Исключение
		//ДобавитьСообщениеДляЖурналаРегистрации(СобытиеЖурналаРегистрации(), "Ошибка", ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()),,Истина); 
	КонецПопытки;
	
КонецФункции

Доработка проверялась на конфигурации "Управление производственным предприятием, редакция 1.3 (1.3.49.1)".

К статье приложены 2 обработки по работе с журналом регистрации:

Отчет по журналу регистрации (обычное приложение)

Отчет по журналу регистрации (управляемое приложение)

 

Скачать файлы

Наименование Файл Версия Размер
Отчет по журналу регистрации (обычное приложение)

.erf 12,77Kb
0
.erf 12,77Kb Скачать
Отчет по журналу регистрации (управляемое приложение)

.erf 13,41Kb
1
.erf 13,41Kb 1 Скачать

Специальные предложения

Автор запретил комментарии

См. также

Отчет по журналу регистрации Промо

Журнал регистрации v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Отчет по журналу регистрации с использованием СКД.

2 стартмани

25.07.2011    34611    652    wowik    33    

Мультибазовая очистка Журнала регистрации с автоматическим перемещением архивных данных в указанный каталог

Журнал регистрации v8 Россия Абонемент ($m)

На сервере 1С со временем увеличивается в размерах папка , содержащая журналы регистрации 1С и как следствие может возникнуть проблема свободного пространства на системном жестком диске. Чтобы избежать роста папки, необходимо периодически очищать журнал регистрации 1С.

1 стартмани

26.12.2019    3313    bryantsev.yury    3    

Как отправить ошибки из журнала регистрации на почту? Продолжение. Отдельная база

Журнал регистрации v8 Абонемент ($m)

Добавлена отдельная база: возможность указания списка баз, из которых нужно собирать ошибки, возможность указания почтового профиля для каждой базы.

1 стартмани

27.05.2019    5487    3    wowik    0    

Мониторинг журнала регистрации при помощи Powershell

Сервисные утилиты Журнал регистрации v8 Абонемент ($m)

Работа с журналом регистрации в формате SQLite внешними средствами на примере мониторинга изменений в конфигурации базы данных.

1 стартмани

12.07.2018    13041    user768334    7    

Отчет по журналу регистрации для управляемого приложения Промо

Журнал регистрации v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Отчет по журналу регистрации с использованием СКД

2 стартмани

04.02.2013    27003    329    wowik    12    

Журнал регистрации 1С (sql lite) в web app

Журнал регистрации v8 1cv8.cf Абонемент ($m)

Данная публикация рассматривает построение компонентного решения работы журнала регистрации в стороннем приложении(web app). Встала задача миграции sql lite жр во внешнюю базу. Данное решение было создано: 1. для хранения жр за весь период 2. для ускорения работы с жр 3. для ускорения сервера предприятия, так как именно он (а точнее рагент) пытается записать данные в жр sql lite(фактически файл на диске), после увеличения размера файла более 10 гб, поступали жалобы по вопросу быстродействия 1с (и не только ради этого) Данная публикация может быть полезной администраторам, программистам, оптимизаторам.

1 стартмани

09.07.2018    9660    dmarenin    8    

Повышение качества разработок и онлайн контроль ошибок

Журнал регистрации v8 Абонемент ($m)

Анализ ошибок и сбор ошибок журнала регистраций из десятков и сотен баз в одном месте.

09.03.2018    26829    DitriX    48    

Перенос журналов регистрации при изменении сервера приложения 1С (клиент-серверный вариант)

Журнал регистрации v8 1cv8.cf Россия Абонемент ($m)

Описание расположения журналов регистрации информационных баз 1С при клиент-серверном варианте работы с 1С:Предприятие 8. Пример переноса журналов регистрации информационной базы 1С с платформы 1С:8.2 на платформу 1С:8.3

15.08.2017    23513    OlegAl    2