Печать ценников весового товара для 1С: Розница 2.2

05.09.19

Задачи пользователя - Этикетки, ценники

Обработка формирования ценников для весового товара в Конфигурация 1С: Розница, редакция 2.2 (2.2.9.20).

Скачать исходный код

Наименование Файл Версия Размер
Печать ценников Весового товара 1С: РОЗНИЦА 2.2:
.epf 16,44Kb
22
.epf 16,44Kb 22 Скачать

Обработка формирования Ценников для весового товара в 1С: РОЗНИЦА 2.2

Данная обработка, подключается как внешняя обработка.

Тестировалась на платформе 1С:Предприятие 8.3 (8.3.10.2753)
Конфигурация 1С Розница, редакция 2.2 (2.2.9.20) 

При запуске есть возможность выбрать Весовой товар.

В табличной части заполняется список весового товара в граммах.

Автоматически рассчитывается цена и штрих код.

Для правильного отображения цены, не забудьте для Товара установить через документ "Установка цен номенклатуры" Цену за 1 кг.

На закладке "Ценники для печати" формируются ценники, с возможность печати на принтер. 
 

&НаСервере
Функция ПолучитьКоличествоМиллиметровВПикселе()
	Эталон = Обработки.ПечатьЭтикетокИЦенников.ПолучитьМакет("Эталон");
	КоличествоМиллиметровВПикселе = Эталон.Рисунки.Квадрат100Пикселей.Высота / 100;	
	Возврат КоличествоМиллиметровВПикселе;
КонецФункции

&НаСервере
Процедура СформироватьЦенники()	
	КоличествоМиллиметровВПикселе = ПолучитьКоличествоМиллиметровВПикселе();
	
	ВывелиХотяБыОдинШтрихКод=Ложь;
	
	ВсегоКолонок = Колонок;	
	ВсегоСтрок   = 4;
	
	ТекКолонка = 1;
	ТекСтрока  = 1;
	
	Таб = ТабличныйДокумент1; Таб.Очистить();	
	Таб.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ЦЕННИК";
	
	ЭтотОбъектОбработки=РеквизитФормыВЗначение("Объект");
	Макет =  ЭтотОбъектОбработки.ПолучитьМакет("Макет"); 	

	СтранаПроисхождения = ПолучитьЗначениеУОбъекта(Объект.Номенклатура,"СтранаПроисхождения");	
	Товар=Объект.Номенклатура;	
	ТабличноеПоле1 = Объект.Товары;
	Н=0;
	Для Каждого СтрокаИзСписка Из Объект.Товары Цикл	
		Если СтрокаИзСписка.Вес_В_Граммах=0 Тогда
			Продолжить;
		КонецЕсли;
		Н=Н+1;			
		ШК=СтрокаИзСписка.ШтрихКод;	
		ОбластьЗначение = Макет.ПолучитьОбласть("ВертТело|ГорТело");							
		ОбластьЗначениеМ = Макет.ПолучитьОбласть("ВертТело|Гор_М_Тело");								
		ОбластьЗначениеМпусто = Макет.ПолучитьОбласть("ВертТело|Гор_М_ТелоПусто");										
		
		//************************************
		Попытка
			РисунокШК = ОбластьЗначение.Рисунки.ШтрихКод;		
			Если РисунокШК <> Неопределено Тогда
				Если ПустаяСтрока(ШК) Тогда
					Таб.Рисунки.Удалить(РисунокШК);
				Иначе
					ПараметрыШтрихкода = Новый Структура;
					ПараметрыШтрихкода.Вставить("Ширина",	Окр(РисунокШК.Ширина / КоличествоМиллиметровВПикселе));
					ПараметрыШтрихкода.Вставить("Высота",	Окр(РисунокШК.Высота / КоличествоМиллиметровВПикселе));				
					ПараметрыШтрихкода.Вставить("Штрихкод", ШК);
					ПараметрыШтрихкода.Вставить("ТипКода", 99);
					ПараметрыШтрихкода.Вставить("ОтображатьТекст", Истина);
					ПараметрыШтрихкода.Вставить("Штрихкод", ШК);									
					РисунокШК.Картинка = МенеджерОборудованияВызовСервера.ПолучитьКартинкуШтрихкода(ПараметрыШтрихкода);
				КонецЕсли;
			КонецЕсли;
		Исключение //  не установлен 
			Ошибка = ОписаниеОшибки();
			Сообщить("Не удалось сформировать штрих-код! Подробнее: "+Ошибка);
		КонецПопытки;
				
		//*************************************		
		
		ОбластьЗначение.Параметры.НазваниеТовара = СокрЛП(Товар)+" "+СокрЛП(СтрокаИзСписка.Вес_В_Граммах)+"г";	
		ОбластьЗначение.Параметры.Цена = Формат(СтрокаИзСписка.Цена,"ЧГ=");
		ОбластьЗначение.Параметры.СтранаПроисхождения = СтранаПроисхождения;		
		//~1:
		Если ТекКолонка > ВсегоКолонок Тогда
			ТекКолонка = 1;
			ТекСтрока  = ТекСтрока + 1;
		КонецЕсли;
		
		Если ТекСтрока > ВсегоСтрок Тогда
			ТекСтрока  = 1;
			Таб.ВывестиГоризонтальныйРазделительСтраниц();
		КонецЕсли;
		
		Если ТекКолонка = 1 Тогда
			Таб.Вывести(ОбластьЗначение);
		Иначе
			Таб.Присоединить(ОбластьЗначение);
		КонецЕсли;
		
		ВывелиХотяБыОдинШтрихКод = Истина;	
		ТекКолонка  = ТекКолонка + 1;		
	КонецЦикла;
	
	Если ВывелиХотяБыОдинШтрихКод И ТекСтрока=1 Тогда
	 	Для н=ТекКолонка по Колонок Цикл
			Таб.Присоединить(ОбластьЗначениеМпусто);					
		КонецЦикла   
	КонецЕсли;
	
			
	Таб.АвтоМасштаб=Истина;
	Таб.Защита = Ложь;
	Таб.ПолеСверху=7;
	Таб.ПолеСнизу=7;		
	Таб.ПолеСлева=7;				
	Таб.ПолеСправа=7;						
	Таб.ТолькоПросмотр = Истина;
	Таб.ОтображатьСетку = Ложь;
	Таб.ОтображатьЗаголовки = Ложь;
		
КонецПроцедуры

 

См. также

Штрих-коды в шаблоне этикетки

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Россия Управленческий учет Платные (руб)

Решение позволяет в шаблон этикетки с типом "Этикетка (обувь, одежда, табак...)" добавлять штрих-коды другого типа, например, GTIN в Code128.

4000 руб.

09.06.2021    15306    8    6    

12

Ценники и этикетки со штрих-кодом для 1С 8.х любой конфигурации

Этикетки, ценники Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Беларусь Украина Россия Управленческий учет Платные (руб)

Простая в использовании обработка для формирования и печати ценников и этикеток со штрих-кодом, с дополнительной ценой, для 1С8.х любой конфигурации. Большое разнообразие шаблонов печатных форм. Управляемая форма (Такси) + Обычный режим.

3588 руб.

11.11.2020    48229    55    44    

65

Печать ценников. (Розница 2.3, УНФ 1.6, две цены + серийные номера) + УНФ 3.0

Этикетки, ценники Пользователь Платформа 1С v8.3 Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 Платные (руб)

Встроенная в конфигурации Розница 2.3 и УНФ 1.6 подсистема печати ценников по мне слишком неповоротлива и с усилиями поддается тонкой настройке, решил с нуля написать свою универсальную печать ценников для этих конфигураций.

2000 руб.

04.11.2019    28500    113    87    

52

Печать из Андроид

Этикетки, ценники Программист Мобильная платформа Бесплатно (free)

Печать этикеток на принтер WiFi без драйвера.

20.01.2023    2019    aldar    0    

8

Ценники (этикетки) для термопринтера

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Абонемент ($m)

Внешняя печатная форма для принтера этикеток. В отличие от базовой обработки для печати этикеток эта может выводить на печать дополнительные свойства справочника Номенклатура, а также в ней несложный программный код, что позволяет легко дорабатывать обработку под свои нужды.

2 стартмани

03.01.2023    3287    21    AndreyPonom    7    

10

Набор готовых макетов этикеток (ценников) для Розницы 2.3

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Розница 2 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Архив с экспортными шаблонами этикеток (ценников) формата 58х40. Для тех, кто не хочет сам рисовать их.

2 стартмани

04.05.2022    12790    44    aximo    3    

11

Шаблон этикетки для УНФ (1С:Фреш)

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Описан механизм создания этикетки для термопринтера ТSC TDP-225 в подробностях. Приложен XML-файл с самим шаблоном.

1 стартмани

01.05.2022    11769    6    zemskov    7    

5
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Andrekaa 20.02.20 15:09 Сейчас в теме
Добрый день
Поддержка сканера штрих-кодов реализована? (для выбора номенклатуры)
2. Stæg 29 01.03.21 20:04 Сейчас в теме
А куда этот код надо вписывать?
Оставьте свое сообщение