Печать штрих-кодов и ценников

15.09.19

Задачи пользователя - Этикетки, ценники

Печать ценников и штрих-кодов для ваших товаров.

Скачать исходный код

Наименование Файл Версия Размер
Печать штрих-кодов и ценников:
.epf 32,10Kb
2
.epf 32,10Kb 2 Скачать

Здравствуйте. Первый раз публикую свой продукт(если его можно так назвать).

Обработка для печати ценников и штрих-кодов. Писалась для "Управление торговым предприятием для Украины", редакция 1.2. 
Разработка конфигурации: "ABBYY Ukraine", 2007-2016 (1.2.36.1). 

Есть два макета:

  1. Печати штрих-кодов;
  2. Печати ценников - акционных (с перечеркнутой старой ценой) и обычных. 

Могу переделать макет ценников, если кому-то понадобится.

Форматы печати:

  1. 4х6;
  2. А4;
  3. А5.

обработка печать ценники штрих-коды УТП 8.3

См. также

Штрих-коды в шаблоне этикетки

Этикетки, ценники Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Россия Управленческий учет Платные (руб)

Решение позволяет в шаблон этикетки с типом "Этикетка (обувь, одежда, табак...)" добавлять штрих-коды другого типа, например, GTIN в Code128.

4000 руб.

09.06.2021    15254    8    6    

11

Ценники и этикетки со штрих-кодом для 1С 8.х любой конфигурации

Этикетки, ценники Платформа 1С v8.3 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Беларусь Украина Россия Управленческий учет Платные (руб)

Простая в использовании обработка для формирования и печати ценников и этикеток со штрих-кодом, с дополнительной ценой, для 1С8.х любой конфигурации. Большое разнообразие шаблонов печатных форм. Управляемая форма (Такси) + Обычный режим.

3588 руб.

11.11.2020    48175    55    44    

65

Печать ценников. (Розница 2.3, УНФ 1.6, две цены + серийные номера) + УНФ 3.0

Этикетки, ценники Платформа 1С v8.3 Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 Платные (руб)

Встроенная в конфигурации Розница 2.3 и УНФ 1.6 подсистема печати ценников по мне слишком неповоротлива и с усилиями поддается тонкой настройке, решил с нуля написать свою универсальную печать ценников для этих конфигураций.

2000 руб.

04.11.2019    28461    113    87    

52

Печать из Андроид

Этикетки, ценники Мобильная платформа Бесплатно (free)

Печать этикеток на принтер WiFi без драйвера.

20.01.2023    1998    aldar    0    

8

Ценники (этикетки) для термопринтера

Этикетки, ценники Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Абонемент ($m)

Внешняя печатная форма для принтера этикеток. В отличие от базовой обработки для печати этикеток эта может выводить на печать дополнительные свойства справочника Номенклатура, а также в ней несложный программный код, что позволяет легко дорабатывать обработку под свои нужды.

2 стартмани

03.01.2023    3245    21    AndreyPonom    7    

10

Набор готовых макетов этикеток (ценников) для Розницы 2.3

Этикетки, ценники Платформа 1С v8.3 1С:Розница 2 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Архив с экспортными шаблонами этикеток (ценников) формата 58х40. Для тех, кто не хочет сам рисовать их.

2 стартмани

04.05.2022    12683    44    aximo    3    

11

Шаблон этикетки для УНФ (1С:Фреш)

Этикетки, ценники Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Описан механизм создания этикетки для термопринтера ТSC TDP-225 в подробностях. Приложен XML-файл с самим шаблоном.

1 стартмани

01.05.2022    11707    6    zemskov    7    

5
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. МимохожийОднако 142 16.09.19 07:14 Сейчас в теме
Какую внешнюю компоненту используешь для формирования и печати штрихкодов? Работает ли на 64-разрядном клиенте? Обычная или управляемая форма?
2. Tailor_Made 16.09.19 10:10 Сейчас в теме
(1)
Обычная форма.

Не до конца понимаю, что значит "внешнюю компоненту". Функция так выглядит:
Функция ПечатьШтрихкодов() Экспорт

	ТабДокумент                     = Новый ТабличныйДокумент;
	ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Штрихкод";
	Макет                           = ПолучитьМакет("Штрихкод");
	Область                  		= Макет.ПолучитьОбласть("Строка");
	Для Каждого СтрокаТаблицы Из Товары Цикл
		Для Тмп = 1 По СтрокаТаблицы.Количество Цикл
			Если СтрокаТаблицы.Печать И ЗначениеЗаполнено(СтрокаТаблицы.Штрихкод) Тогда
				
				Область.Рисунки.Штрихкод.ВыводитьНаПечать = Истина;
				Область.Рисунки.Штрихкод.Объект.ТипКода   = 1; //EAN13
				Область.Рисунки.Штрихкод.Объект.Сообщение = СтрокаТаблицы.Штрихкод;
				
				ТабДокумент.Вывести(Область);
				ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
	ТабДокумент.АвтоМасштаб = Истина;
	ТабДокумент.ПолеСверху = 1;
	ТабДокумент.ПолеСнизу = 1;
	ТабДокумент.ПолеСправа = 1;
	ТабДокумент.ПолеСлева = 1;
	ТабДокумент.ТолькоПросмотр = Истина;
	
	ТабДокумент.Показать("Печать штрихкода");

КонецФункции 
Показать
3. МимохожийОднако 142 16.09.19 14:53 Сейчас в теме
Работает ли на 64-разрядном клиенте?
4. Tailor_Made 16.09.19 16:32 Сейчас в теме
(3)тестировал на 32-разрядном. Точно не могу сказать
Оставьте свое сообщение