Печать ценников и этикеток для УТ 8.2 с выбором цены и организации для УТ 10.3

26.09.14

Задачи пользователя - Этикетки, ценники

Возможность печати ценников и этикеток из документов и подборов. Добавлена возможность выбора Организации и цены. для ут 10.3

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки для того, чтобы самостоятельно ее доработать для вашей базы данных. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в вашей базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке Купить один файл
Печать ценников и этикеток для УТ 8.2
.epf 48,53Kb
96
96
1 SM
Скачать Купить за 1 850 руб.

За основу взята обработка //infostart.ru/public/75613/ в свою очередь автор взял её у Alexsisit PechatCennikov.epf  //infostart.ru/public/21680/ и он доработал под себя. Мне показалось неудобно, что организация и тип цен выбираются из настроек пользователя по умолчанию. Пришлось ввести поле выбора организации и выбора типа цен. Это удобно при ведении нескольких организаций в одной базе.  

Используя количество, можно печатать необходимое количество этикеток.

Для печати  на принтер этикеток нужна компонента 1CBarCode.exe

Печать ценников со штрих-кодом

См. также

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Россия Управленческий учет Платные (руб)

Решение позволяет в шаблон этикетки с типом "Этикетка (обувь, одежда, табак...)" добавлять штрих-коды другого типа, например, GTIN в Code128.

4000 руб.

09.06.2021    15518    8    6    

12

Этикетки, ценники Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Беларусь Украина Россия Управленческий учет Платные (руб)

Простая в использовании обработка для формирования и печати ценников и этикеток со штрих-кодом, с дополнительной ценой, для 1С8.х любой конфигурации. Большое разнообразие шаблонов печатных форм. Управляемая форма (Такси) + Обычный режим.

3588 руб.

11.11.2020    48531    56    44    

67

Логистика, склад и ТМЦ Этикетки, ценники Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Абонемент ($m)

Выводит при печати этикетки складской ячейки в качестве штрихкода адрес ячейки вместо уникального идентификатора

1 стартмани

20.06.2024    383    2    Alexei_Siva    4    

5

Этикетки, ценники Программист Мобильная платформа Бесплатно (free)

Печать этикеток на принтер WiFi без драйвера.

20.01.2023    2123    aldar    0    

9

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Абонемент ($m)

Внешняя печатная форма для принтера этикеток. В отличие от базовой обработки для печати этикеток эта может выводить на печать дополнительные свойства справочника Номенклатура, а также в ней несложный программный код, что позволяет легко дорабатывать обработку под свои нужды.

2 стартмани

03.01.2023    3428    22    AndreyPonom    7    

11

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Розница 2 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Архив с экспортными шаблонами этикеток (ценников) формата 58х40. Для тех, кто не хочет сам рисовать их.

2 стартмани

04.05.2022    13240    45    aximo    3    

12

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Описан механизм создания этикетки для термопринтера ТSC TDP-225 в подробностях. Приложен XML-файл с самим шаблоном.

1 стартмани

01.05.2022    12056    6    zemskov    7    

5
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Marishka_2014 25.09.14 21:26 Сейчас в теме
Добрый день! При загрузки из любого документа вылетает ошибка
{Форма.Форма.Форма(451)}: Ошибка при вызове метода контекста (Выполнить)
СписокШт=Запрос.Выполнить().Выгрузить();
по причине:
{(4, 12)}: Поле не найдено "Штрихкоды.ПредставлениеШтрихкода"
Штрихкоды.<<?>>ПредставлениеШтрихкода

Конфигцрация Комплексная автоматизация 1.1 Как можно исправить ?
2. Denis_CFO 48 25.09.14 21:41 Сейчас в теме
(1) Marishka_2014, надо полностью запрос смотреть. там однозначно реквизита с таким именем нет ( "Штрихкоды.ПредставлениеШтрихкода" ). пишите по-больше информации.
3. Marishka_2014 25.09.14 22:42 Сейчас в теме
(2) Denis_CFO, Процедура ЗаполнитьПоСсылке(СписокТоваров);

ТаблЦен=ПолучитьТаблицуЦен(СписокТоваров.выгрузитьКолонку("Номенклатура"));
	ЭлементыФормы.Индикатор1.МаксимальноеЗначение=СписокТоваров.Количество();
    сч=0;

	Для Каждого Эл Из СписокТоваров Цикл
		сч=сч+1;
		ЭлементыФормы.Индикатор1.Значение=сч;
        ОбработкаПрерыванияПользователя();
		НовСтр=Товары.Найти(Эл.Номенклатура,"Номенклатура");
		Если НовСтр=Неопределено Тогда 
			НовСтр=Товары.Добавить();
		КонецЕсли;
		
		Попытка
			НовСтр.Единица=эл.ЕдиницаИзмерения;
		Исключение
			НовСтр.Единица=эл.номенклатура.ЕдиницаХраненияОстатков;
		КонецПопытки;
		
		Запрос = Новый Запрос(
		"ВЫБРАТЬ
		|   Штрихкоды.Штрихкод,
		|	Штрихкоды.ТипШтрихкода,
		|	Штрихкоды.ПредставлениеШтрихкода
		|ИЗ
		|	Справочник.Номенклатура КАК шНоменклатура
		|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.Штрихкоды КАК Штрихкоды
		|		ПО шНоменклатура.Ссылка = Штрихкоды.Владелец
	    |ГДЕ
		|	шНоменклатура.Ссылка В ИЕРАРХИИ(&Ссылка)");
		Запрос.УстановитьПараметр("Ссылка",Эл.Номенклатура);
		СписокШт=Запрос.Выполнить().Выгрузить();
	
		НовСтр.Колво=1;
		НовСтр.Номенклатура=Эл.Номенклатура;
		НовСтр.Артикул=Эл.Номенклатура.Артикул;
		НовСтр.Страна=Эл.Номенклатура.СтранаПроисхождения;
		НовСтр.ШтрихКод = СписокШт.Получить(0).Штрихкод;
		НовСтр.ТипШтрихкода = СписокШт.Получить(0).ТипШтрихкода;
		НовСтр.ПредставлениеШтрихкода = СписокШт.Получить(0).ПредставлениеШтрихкода;

		НовСтр.Цена=0;
		Кол=0;
		
		ЕстьСтр=ТаблЦен.Найти(Эл.Номенклатура,"Номенклатура");
		Если ЕстьСтр<>Неопределено Тогда 
			НовСтр.Цена=ЕстьСтр.Цена;
		КонецЕсли;
		
		Если СсылкаНаОБъект <> Неопределено Тогда
		ЕстьстрК=СсылкаНаОБъект.товары.найти(Эл.Номенклатура,"Номенклатура");
			Если ЕстьСтрК<>Неопределено Тогда
			    Кол = ЕстьстрК.количество;
				НовСтр.Колво = Кол;
			КонецЕсли;
		КонецЕсли;
		
		Если (НовСтр.Цена=0) или (Кол=0)  Тогда 
			НовСтр.Флаг  = Ложь;
			НовСтр.Колво = 0;
		Иначе
			НовСтр.Флаг=Истина;
		КонецЕсли;
		
		//еСЛИ ТипЗНЧ(СсылкаНаОбъект)=Тип("ДокументСсылка.ПоступлениеТоваровУслуг") Тогда
		//	НовСтр.Флаг=Истина;
		//	
		//	Естьстр=СсылкаНаОБъект.товары.найти(Эл.Номенклатура,"Номенклатура");
		//	Кол=0;
		//				
		//	Если Естьстр<>Неопределено Тогда
		//		Кол = Естьстр.количество;
		//		НовСтр.Колво = Кол;
		//	КонецЕсли;	
		//	Если НовСтр.Цена=0 или Кол=0  Тогда 
		//		НовСтр.Колво=0;
		//		НовСтр.Флаг=Ложь;
		//	КонецЕсли;	
		//КонецЕсли;
	КонецЦикла;
	ЭлементыФормы.Индикатор1.Значение=0;
КонецПроцедуры
Показать
5. belakov83 01.03.15 15:39 Сейчас в теме
(1) Marishka_2014, как Вы решили проблему?
4. kobol 61 26.09.14 05:16 Сейчас в теме
Так написано было что под ут 10.3, а ввиду изменения сайта сейчас не вижу где написано.
Оставьте свое сообщение