Программное приведение типа значения поля ввода и колонки табличного поля формы 1С8

21.09.20

Разработка - Работа с интерфейсом

Рассматривается вопрос разработки алгоритма автоматического изменения типа значения поля ввода и колонки табличного поля в соответствие с выбранным типом.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Приведение типа поля формы 1с8
.epf 25,47Kb
3
3
1 SM
Скачать Купить за 1 850 руб.

| Перейти в конец публикации  |

Задача типовая, на просторах интернета разбросана в множестве разных статей. Цель публикации - донести всю необходимую информацию для решения поставленной задачи. Приведенный пример не претендует на лавры и возможны улучшения!

При создании формы возникает вопрос настройки типа значения поля ввода. Не всегда заранее точно известен используемый тип, поскольку это может зависеть от метаданных конфигурации и условий использования.

Если, как минимум, известно, что в поле потребуется вводить и использовать элемент Справочника или Документ, то можно настроить тип на общий вид значения, например СправочникСсылка или ДокументСсылка. Далее решить вопрос программно при открытии формы, для уточнения используемого типа.

Если требуется использовать элемент справочника Номенклатура, но в разных конфигурациях этот объект метаданных может называться по-разному, например Товары или же Номенклатура, то программное определение наименования типа при открытии формы упростит жизнь пользователю.

Следовательно, настроим автоматический выбор и первичное преобразование полей на форме к типу значения Справочник.Номенклатура, если такой есть в метаданных конфигурации. В противном случае, выбираем в качестве начального значения первый в списке имён справочников.

Для примера разработана управляемая форма и форма в обычном режиме (см. скриншоты публикации).

Обычный режим

Ниже приведен алгоритм на языке 1С8 для формы в обычном режиме. На форме есть поле список ВыбранныйТип, для которого настроено событие ПриИзменении. В поле ВыбранныйТип пользователь выбирает тип, который желает использовать для преобразования полей. При открытии формы считываем список справочников из метаданных конфигурации. Ищем справочник Номенклатура в списке, далее инициализируем на форме поле ВыбранныйТип полученным списком имён и найденным значением. Запускаем событие ВыбранныйТипПриИзменении, для преобразования типа полей ввода. В переменную модуля формы СтрокаТипЗнч сохраним полное имя выбранного типа для использования в других процедурах.

Перем СтрокаТипЗнч;

Процедура ПриОткрытии(Отказ)
	ЗагрузитьСписокТипов();
КонецПроцедуры

Процедура ЗагрузитьСписокТипов()
	Перем Справочник;
	ЭлементыФормы.ВыбранныйТип.СписокВыбора.Очистить();
	Для Каждого Спр Из Метаданные.Справочники Цикл
		ЭлементыФормы.ВыбранныйТип.СписокВыбора.Добавить(Спр.Имя,Спр.Синоним);
	КонецЦикла;
	ЗнчНоменклатура = ЭлементыФормы.ВыбранныйТип.СписокВыбора.НайтиПоЗначению("Номенклатура");
	ЭлементыФормы.ВыбранныйТип.Значение=?(НЕ ЗнчНоменклатура=Неопределено,ЗнчНоменклатура,ЭлементыФормы.ВыбранныйТип.СписокВыбора[0].Значение);
	ВыбранныйТипПриИзменении(ЭлементыФормы.ВыбранныйТип);
КонецПроцедуры

Процедура ВыбранныйТипПриИзменении(Элемент)
	ВидСпр = ЭлементыФормы.ВыбранныйТип.Значение;
	Если Не ВидСпр = Неопределено Тогда 
		ПреобразуемоеПоле = ПредопределенноеЗначение("Справочник."+ВидСпр+".ПустаяСсылка");
		СтрокаТипЗнч = "СправочникСсылка."+ВидСпр;
	КонецЕсли;
КонецПроцедуры

Далее необходимо выполнить преобразование типа значения колонки табличного поля. Для этого воспользуемся событием НачалоВыбора.

Код преобразования приведен ниже. В нём используется ранее инициализированная переменная СтрокаТипЗнч для получения имени выбранного типа. Алгоритм можно найти в справке по ключевому слову ПривестиЗначение.

Процедура ТабличноеПолеКолонкаНачалоВыбора(Элемент, СтандартнаяОбработка)
    Элемент.ОграничениеТипа = Новый ОписаниеТипов(СтрокаТипЗнч);
    Значение = Элемент.Значение;
    Элемент.Значение = Элемент.ОграничениеТипа.ПривестиЗначение(Значение);
    Элемент.ВыбиратьТип = Ложь;
КонецПроцедуры //ПривестиЗначение (AdjustValue). Справка

Новый тип назначается полям динамически после каждого выбора значения в списке ВыбранныйТип.

Управляемые формы

Для управляемых форм алгоритм изменяется незначительно. Для преобразования используется свойство ОграничениеТипа. Работа с метаданными только на сервере. Для быстрого доступа к колонке табличного поля при срабатывании события НачалоВыбора сохраним в переменной на клиенте СсылкаЭлементКолонкаТП ссылку с адресом элемента.

&НаКлиенте
Перем СтрокаТипЗнч, СсылкаЭлементКолонкаТП;

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ЗагрузитьСписокТипов();
	ВыбранныйТипПриИзменении(Элементы.ВыбранныйТип);
КонецПроцедуры

&НаСервере
Процедура ЗагрузитьСписокТипов()
	Перем Справочник;
	Элементы.ВыбранныйТип.СписокВыбора.Очистить();
	Для Каждого Спр Из Метаданные.Справочники Цикл
		Элементы.ВыбранныйТип.СписокВыбора.Добавить(Спр.Имя,Спр.Синоним);
	КонецЦикла;
	ЗнчНоменклатура = Элементы.ВыбранныйТип.СписокВыбора.НайтиПоЗначению("Номенклатура");
	Объект.ВыбранныйТип = ?(НЕ ЗнчНоменклатура=Неопределено,ЗнчНоменклатура.Значение,Элементы.ВыбранныйТип.СписокВыбора[0].Значение);
КонецПроцедуры

&НаКлиенте
Процедура ВыбранныйТипПриИзменении(Элемент)
	ВидСпр = Объект.ВыбранныйТип;
	Если Не ВидСпр = Неопределено Тогда 
		СтрокаТипЗнч = "СправочникСсылка."+ВидСпр;
		Элементы.ПреобразуемоеПоле.ОграничениеТипа = Новый ОписаниеТипов(СтрокаТипЗнч);
		Если НЕ СсылкаЭлементКолонкаТП = Неопределено Тогда
			СсылкаЭлементКолонкаТП.ОграничениеТипа = Новый ОписаниеТипов(СтрокаТипЗнч);
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура КолонкаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
	СсылкаЭлементКолонкаТП = Элемент;
	Элемент.ОграничениеТипа = Новый ОписаниеТипов(СтрокаТипЗнч);
КонецПроцедуры

Рассмотренный пример алгоритма можно протестировать, скачав обработку по ссылке из публикации. Работа выполнялась на 1С:Предприятие 8.3 (8.3.15.1747), с использованием конфигураций "Управление торговлей", редакция 10.3 (10.3.46.3), Управление торговлей, редакция 11 (11.4.7.150). В составе обработки одновременно присутствует управляемая форма и форма обычного режима.

Спасибо за внимание! Критика приветствуется.


| Перейти в начало публикации  |


Тип Значения Метаданные Поле Ввод Таблица Форма Обычная Управляемая Приведение Преобразование Алгоритм

См. также

Работа с интерфейсом Программист Платформа 1С v8.3 Конфигурации 1cv8 1С:ERP Управление предприятием 2 Платные (руб)

Обработка предназначена для создания и управления дашбордами.

2400 руб.

29.06.2020    17600    24    6    

38

Работа с интерфейсом Программист Платформа 1С v8.3 Бесплатно (free)

Пример простого и симпатичного прогресс-бара в динамическом списке, без картинок, используя редактирование запроса.

27.05.2024    5332    smielka    37    

95

Работа с интерфейсом Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Зарплата и Управление Персоналом 3.x 1С:Управление нашей фирмой 3.0 Бесплатно (free)

Добавьте новогоднего настроения! Расширение создает декорацию в виде гирлянды на некоторых формах объектов.

27.12.2023    12340    785    elcoan    47    

110

Инструментарий разработчика Работа с интерфейсом Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Подходит для создания web-страниц для замены управляемых форм 1С, красивых отчетов, интерфейса мобильного приложения на платформе 1С и для простых страниц веб-сайтов.

2 стартмани

10.04.2023    10610    158    acces969    31    

120

Работа с интерфейсом Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

"MVC плохо применима в 1С" - познакомьтесь с моделью состояния и, возможно, ваше мнение поменяется! Представленное решение является эволюционным развитием идеи реализации MVC для 1С. В новой версии добавлены DSL для описания модели состояния, а также параметризация свойств параметров и элементов формы.

1 стартмани

05.07.2022    4572    kalyaka    6    

32

Работа с интерфейсом Платформа 1С v8.3 Платные (руб)

Подсистема условного оформления элементов форм (далее подсистема) предназначена для настройки оформления элементов форм (видимость, доступность, цвет фона, цвет текста и прочее) в пользовательском режиме 1С. Также подсистему возможно использовать для ограничения доступа к реквизитам формы для определенных пользователей (или групп пользователей).

6000 руб.

18.01.2022    9340    1    2    

6
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. TMV 14 22.09.20 06:18 Сейчас в теме
Как лучше-то в итоге? Так:
(ЗнчНоменклатура<>Неопределено

или так:
(НЕ ЗнчНоменклатура=Неопределено
2. etmarket 901 22.09.20 11:58 Сейчас в теме
(1) привёл к общему виду. Спасибо.
Оставьте свое сообщение