Графическая компонента для более удобной работы с внешними библиотеками обработки изображений

22.10.20

Разработка - Разработка внешних компонент

Обработка представляет из себя контейнер методов для более простой работы с методами и свойствами внешних библиотек по работе с изображениями. То есть, по сути, это обёртка над API внешних библиотек с более простым интерфейсом.

Скачать файлы

Наименование Файл Версия Размер
ГрафическаяКомпонента
.epf 7,40Kb
2
.epf 7,40Kb 2 Скачать

По изначальной задумке вызывается методом Обработки.ГрафическаяКомпонента.Получить().

К сожалению, при сохранении обработки как внешней из неё удаляются модуль менеджера и все его методы, поэтому этот метод нужно добавить в модуль менеджера при добавлении обработки в конфигурацию.

Либо добавить как метод какого-то другого модуля. Но метод модуля менеджера самой обработки выглядит логичнее (как статический метод класса).

Код метода Получить() добавлен ниже под спойлером.

При неудачной попытке подключения основной библиотеки производится попытка подключения резервной.

Дополнительные попытки добавлять не стал, но ничто не мешает это сделать.

Обработка изображения происходит с помощью метода ОбработатьКартинку(ПутьКФайлу, ДлинаСтороныКартинкиВПикселях).

Формат по умолчанию JPG, качество 90% от исходного.
Поскольку у нас на работе для текущих целей эти параметры изображения приняты как стандартные, они напрямую установлены в коде.
При желании, методы легко доработать, чтобы передавать нужные настройки при вызове основного метода преобразования картинки.

В самой обработке для работы с разными библиотеками в текущей её реализации используется перечисление ГрафическиеКомпоненты со значениями WIA и GFLAx.
Вместо добавления нового перечисления можно создать, например, соответствующую структуру и поместить её в переменную модуля или в реквизит обработки, изменив обращения к перечислению на обращение к этой структуре.

В текущем виде подходит только для обычных форм и для Windows (COMОбъекты).
Судя по информации о WIA здесь, минимальная пользовательская версия Windows Vista, серверная Windows Server 2003 R2.
Тестировалось на КА 1.1.90.1, версии платформы 8.3.13.1644 и 8.3.16.1063.

Важно: Используемые библиотеки должны быть зарегистрированы на машинах, на которых будет выполняться обращение к обработке. В случае использования только WIA на Windows Vista/Windows Server 2003 R2 или выше ничего регистрировать не нужно.

Вариант с сохранением библиотеки из макета и попыткой регистрации добавлять пока не стал.

 

Пример использования в коде:

ГрафическаяКомпонента = Обработки.ГрафическаяКомпонента.Получить();

Если ГрафическаяКомпонента = Неопределено Тогда
    Возврат; // Продолжить, Сообщить() и т.д.
КонецЕсли;

...

ДлинаСтороныКартинкиВПикселях = 200;
КартинкаОбработанаУспешно = ГрафическаяКомпонента.ОбработатьКартинку(ИмяВременногоФайла, ДлинаСтороныКартинкиВПикселях);

Если Не КартинкаОбработанаУспешно Тогда
    
    #Если Клиент Тогда
        Сообщить(СтрШаблон("%1: не удалось обработать основное изображение.", ПредставлениеНоменклатуры));
    #КонецЕсли
    
    Возврат;
    
КонецЕсли;
Код метода Получить():
 
 

 

// Возвращает экземпляр обработки ГрафическаяКомпонента для дальнейшего преобразования изображений.
// 
// Возвращаемое значение:
//  ОбработкаОбъект.ГрафическаяКомпонента, Неопределено - Экземпляр обработки ГрафическаяКомпонента или Неопределено,
//                                                        если не удалось вызвать компоненту или установить ее настройки.
//
Функция Получить() Экспорт
    
    ГрафическаяКомпонента = Обработки.ГрафическаяКомпонента.Создать();
    
    ОсновнойТипКомпоненты  = Перечисления.ГрафическиеКомпоненты.WIA;
    РезервныйТипКомпоненты = Перечисления.ГрафическиеКомпоненты.GFLAx;
    
    ГрафическаяКомпонента.ТипКомпоненты = ОсновнойТипКомпоненты;
    ГрафическаяКомпонента.Инициализировать();
    
    Если Не ГрафическаяКомпонента.Инициализирована() Тогда
        
        ГрафическаяКомпонента.ТипКомпоненты = РезервныйТипКомпоненты;
        ГрафическаяКомпонента.Инициализировать();
        
    КонецЕсли;
    
    Если Не ГрафическаяКомпонента.Инициализирована() Тогда
        Возврат Неопределено;
    КонецЕсли;
    
    ГрафическаяКомпонента.ИнициализироватьНастройки();
    
    Если Не ГрафическаяКомпонента.НастройкиИнициализированы() Тогда
        Возврат Неопределено;
    КонецЕсли;
    
    Возврат ГрафическаяКомпонента;
    
КонецФункции

 

обработка изображения

См. также

Внешняя компонента для сканирования (замена TWAIN-компоненты БСП) (Native Win 32/64)

Разработка внешних компонент Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Внешняя компонента позволяет работать c TWAIN-совместимым оборудованием (сканерами, камерами) . Полностью совместима со стандартной TWAIN-компонентой из БСП и может применяться как ее замена без изменения вызовов, при этом может работать с 64-разрядной платформой, а так же имеет расширенную функциональность, например, сохранение результата непосредственно в PDF без использования сторонних утилит. Прекрасно работает на сервере, тонком клиенте и веб-клиенте (проверена работа в браузерах Google Chrome, Mozilla Firefox и Microsoft Internet Explorer).

2400 руб.

12.05.2020    26048    131    99    

81

Внешняя компонента печати PDF (Native Win 32/64)

Разработка внешних компонент Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Внешняя компонента позволяет печатать PDF файлы непосредственно из 1С, не используя при этом сторонних программ. Прекрасно работает на сервере, тонком клиенте и веб-клиенте. Основана на проекте PDFium из состава проекта Chromium/Chrome

1500 руб.

17.09.2018    34877    104    123    

111

Мастер создания внешних компонент 1С (технология COM) для DELPHI 6/7/8/2005/2006/2007/2008/2010/XE/XE2/XE3

Разработка внешних компонент Платформа 1С v8.3 Платные (руб)

Средство для сверхбыстрой разработки внешних компонент 1С:Предприятия 7.7 и 8 по технологии COM на всех версиях DELPHI, начиная с 6.

2000 руб.

28.03.2013    53911    35    14    

68

Внешняя компонента для подключения 1С к телефонии Asterisk

Разработка внешних компонент Телефония, SIP Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Внешняя компонента выполнена по технологии Native API для 1С 8.х, обеспечивает доступ к программным АТС Asterisk (FreePBX, Elastix) через AMI интерфейс. Через него можно управлять многими функциями Asterisk (определение номеров, перевод звонков, набор телефона и т. д.)

2400 руб.

04.05.2018    44772    116    64    

60

Внешняя компонента 1С и С++. Продолжаем разговор.

Разработка внешних компонент Платформа 1С v8.3 Бесплатно (free)

А давайте запилим 8.3.26 до релиза, или оповещение с сервера...

19.02.2024    3316    starik-2005    27    

48

Внешние компоненты 1С и язык C++

Разработка внешних компонент Механизмы платформы 1С Платформа 1С v8.3 Бесплатно (free)

Некоторые практические аспекты создания внешних компонент на языке С++ для платформы 1С 8.3++.

26.01.2024    4532    starik-2005    32    

38

Внешняя компонента для работы с Apach Kafka

Инструментарий разработчика Разработка внешних компонент Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Пример взаимодействия 1С с Apach Kafka посредством внешней компоненты, разработанной на основе официальной библиотеки librdkafka (the Apache Kafka C/C++ client library).

22.11.2023    2774    57    ivan1703    26    

40

Внешняя компонента GraphQL клиент для 1С

Разработка внешних компонент Платформа 1С v8.3 Платформа 1C v8.2 Платные (руб)

Внешняя компонента, позволяющая посылать команды и получать ответы по GraphQL протоколу из 1С.Может быть использована при интеграции. В 1С работает на стороне "клиента".

4600 руб.

27.06.2023    2614    1    0    

1
Оставьте свое сообщение