1С:Розница: что делать с waybill_v4

08.07.21

Учетные задачи - Розничная торговля

Доработка конфигурации Розница 2.3.8.22 для работы с ТТН версии 4 waybill_v4.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
1С:Розница: что делать с waybill_v4:
.cfe 11,69Kb
21
21
1 SM
Скачать Купить за 1 850 руб.

!Сохранить конфигурацию

1) Создать расширение конфигурации с назначением "Исправление" Загрузить расширение конфигурации из файла, удалить стандартную схему egais_WB_DOC_SINGLE_01

2) В перечислении ФорматыОбменаЕГАИС добавить значение Перечисления.ФорматыОбменаЕГАИС.V4

3) В модуле менеджера перечисления ВидыДокументовЕГАИС в функцию ТаблицаСоответствияДокументовТипамЕГАИС добавить

    НоваяСтрока = Таблица.Добавить();
    НоваяСтрока.ТипЕГАИС = ("WayBill_v4");
    НоваяСтрока.ФорматОбмена      = Перечисления.ФорматыОбменаЕГАИС.V4;
    НоваяСтрока.ВидДокументаЕГАИС = Перечисления.ВидыДокументовЕГАИС.ТТН;
    НоваяСтрока.ПространствоИмен  = "TTNSingle_v4";
    // ++++++++++++++
    НоваяСтрока = Таблица.Добавить();
    НоваяСтрока.ТипЕГАИС = ("WayBillAct_v4");
    НоваяСтрока.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V4;
    НоваяСтрока.ВидДокументаЕГАИС = Перечисления.ВидыДокументовЕГАИС.АктТТНПодтверждение;
    НоваяСтрока.ПространствоИмен = "ActTTNSingle_v4";
    // +++++++++++++
    НоваяСтрока = Таблица.Добавить();
    НоваяСтрока.ТипЕГАИС = ("WayBillAct_v4");
    НоваяСтрока.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V4;
    НоваяСтрока.ВидДокументаЕГАИС = Перечисления.ВидыДокументовЕГАИС.АктТТНОтказ;
    НоваяСтрока.ПространствоИмен = "ActTTNSingle_v4";
    // +++++++++++++
    НоваяСтрока = Таблица.Добавить();
    НоваяСтрока.ТипЕГАИС = ("WayBillAct_v4");
    НоваяСтрока.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V4;
    НоваяСтрока.ВидДокументаЕГАИС = Перечисления.ВидыДокументовЕГАИС.АктТТНРасхождения;
    НоваяСтрока.ПространствоИмен = "ActTTNSingle_v4";


4) Общий Модуль Интеграция ЕГАИС.

В функции ЗагрузитьТТНВходящуюЕГАИС заменить
 

ДокументОбъект.Автомобиль      = ДанныеДокументаТТН.Объект.Header.Transport.TRAN_CAR;

на            

     Если ДанныеДокументаТТН.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V4 Тогда
          ДокументОбъект.Автомобиль      = СокрЛП(ДанныеДокументаТТН.Объект.Header.Transport.TRANSPORT_TYPE)+"/"+СокрЛП(ДанныеДокументаТТН.Объект.Header.Transport.TRANSPORT_REGNUMBER)+"/"+СокрЛП(ДанныеДокументаТТН.Объект.Header.Transport.ChangeOwnership);
     Иначе
          ДокументОбъект.Автомобиль      = ДанныеДокументаТТН.Объект.Header.Transport.TRAN_CAR;
     КонецЕсли;


5) Общий Модуль Интеграция ЕГАИС

Заменить все условия

ДанныеДокументаТТН.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V3

на
 

ДанныеДокументаТТН.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V3 ИЛИ ДанныеДокументаТТН.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V4

6) В модуле менеджера ТТН ВХодящей дополнить условие

в процедуре АктПодтвержденияXML было
    

Иначе
        #Область ФорматОбмена_V3
        
        АктXDTO = ИнтеграцияЕГАИС.ОбъектXDTO(ПространствоИмен, "WayBillActType_v3");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO, "Identity", ИнтеграцияЕГАИС.НовыйИдентификаторДокумента(ДокументСсылка, "awb"), СообщениеXML, 3);
        
        АктXDTO.Header = ИнтеграцияЕГАИС.ОбъектXDTOПоИмениТипа(АктXDTO, "Header");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "IsAccept",  "Accepted",               СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ACTNUMBER", СокрЛП(Шапка.Номер),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ActDate",   ТекущаяДатаСеанса(),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "WBRegId",   Шапка.ИдентификаторЕГАИС, СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "Note",      Шапка.Комментарий,        СообщениеXML);

        #КонецОбласти
        

станет

ИначеЕсли ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V3 Тогда
        
        #Область ФорматОбмена_V3
        
        АктXDTO = ИнтеграцияЕГАИС.ОбъектXDTO(ПространствоИмен, "WayBillActType_v3");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO, "Identity", ИнтеграцияЕГАИС.НовыйИдентификаторДокумента(ДокументСсылка, "awb"), СообщениеXML, 3);
        
        АктXDTO.Header = ИнтеграцияЕГАИС.ОбъектXDTOПоИмениТипа(АктXDTO, "Header");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "IsAccept",  "Accepted",               СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ACTNUMBER", СокрЛП(Шапка.Номер),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ActDate",   ТекущаяДатаСеанса(),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "WBRegId",   Шапка.ИдентификаторЕГАИС, СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "Note",      Шапка.Комментарий,        СообщениеXML);
        
        #КонецОбласти
    Иначе
        
        #Область ФорматОбмена_V4
        
        АктXDTO = ИнтеграцияЕГАИС.ОбъектXDTO(ПространствоИмен, "WayBillActType_v4");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO, "Identity", ИнтеграцияЕГАИС.НовыйИдентификаторДокумента(ДокументСсылка, "awb"), СообщениеXML, 3);
        
        АктXDTO.Header = ИнтеграцияЕГАИС.ОбъектXDTOПоИмениТипа(АктXDTO, "Header");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "IsAccept",  "Accepted",               СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ACTNUMBER", СокрЛП(Шапка.Номер),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ActDate",   ТекущаяДатаСеанса(),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "WBRegId",   Шапка.ИдентификаторЕГАИС, СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "Note",      Шапка.Комментарий,        СообщениеXML);
        
        #КонецОбласти

КонецЕсли;

в процедуре АктОтказаXML было

	Иначе
        #Область ФорматОбмена_V3
        
        АктXDTO = ИнтеграцияЕГАИС.ОбъектXDTO(ПространствоИмен, "WayBillActType_v3");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO, "Identity", ИнтеграцияЕГАИС.НовыйИдентификаторДокумента(ДокументСсылка, "awb"), СообщениеXML, 3);
        
        АктXDTO.Header = ИнтеграцияЕГАИС.ОбъектXDTOПоИмениТипа(АктXDTO, "Header");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "IsAccept",  "Rejected",               СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ACTNUMBER", СокрЛП(Шапка.Номер),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ActDate",   ТекущаяДатаСеанса(),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "WBRegId",   Шапка.ИдентификаторЕГАИС, СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "Note",      Шапка.Комментарий,        СообщениеXML);
    КонецЕсли;

стало

	ИначеЕсли ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V3 Тогда
        
        #Область ФорматОбмена_V3
        
        АктXDTO = ИнтеграцияЕГАИС.ОбъектXDTO(ПространствоИмен, "WayBillActType_v3");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO, "Identity", ИнтеграцияЕГАИС.НовыйИдентификаторДокумента(ДокументСсылка, "awb"), СообщениеXML, 3);
        
        АктXDTO.Header = ИнтеграцияЕГАИС.ОбъектXDTOПоИмениТипа(АктXDTO, "Header");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "IsAccept",  "Rejected",               СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ACTNUMBER", СокрЛП(Шапка.Номер),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ActDate",   ТекущаяДатаСеанса(),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "WBRegId",   Шапка.ИдентификаторЕГАИС, СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "Note",      Шапка.Комментарий,        СообщениеXML);
        
        #КонецОбласти
    Иначе
        
        #Область ФорматОбмена_V4
        
        АктXDTO = ИнтеграцияЕГАИС.ОбъектXDTO(ПространствоИмен, "WayBillActType_v4");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO, "Identity", ИнтеграцияЕГАИС.НовыйИдентификаторДокумента(ДокументСсылка, "awb"), СообщениеXML, 3);
        
        АктXDTO.Header = ИнтеграцияЕГАИС.ОбъектXDTOПоИмениТипа(АктXDTO, "Header");
        
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "IsAccept",  "Rejected",               СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ACTNUMBER", СокрЛП(Шапка.Номер),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "ActDate",   ТекущаяДатаСеанса(),      СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "WBRegId",   Шапка.ИдентификаторЕГАИС, СообщениеXML);
        ИнтеграцияЕГАИС.ЗаполнитьСвойствоXDTO(АктXDTO.Header, "Note",      Шапка.Комментарий,        СообщениеXML);
        
        #КонецОбласти

КонецЕсли;	

7) Чтоб акцизки в проверке ТТН появились в модуле менеджера ТТНВходящей
в функции ВходящиеАкцизныеМарки и ВходящееДеревоУпаковок
было

Результат.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V3

стало
 

(Результат.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V3 ИЛИ Результат.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V4)

8) В модуль перечисления ВидыДокументовЕГАИС
в функцию ПредыдущаяВерсияФорматаОбмена добавить условие
 

	ИначеЕсли ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V4 Тогда
		Возврат Перечисления.ФорматыОбменаЕГАИС.V3;

9) Для работы с самим УТМ 4 В модуль ИнтеграцияЕГАИСКлиентСервер
в функцию ПараметрыHTTPЗапроса

было

   ТелоЗапроса = Новый ТекстовыйДокумент();
   ТелоЗапроса.ДобавитьСтроку("--" + ВремГраница);
   ТелоЗапроса.ДобавитьСтроку("Content-Disposition: form-data; name=""xml_file""");

стало
 

    ТелоЗапроса = Новый ТекстовыйДокумент();
    ТелоЗапроса.РазделительСтрок = Символы.CR+Символы.LF;
    ТелоЗапроса.ДобавитьСтроку("--" + ВремГраница);
    ТелоЗапроса.ДобавитьСтроку("Content-Disposition: form-data; name=""xml_file""; filename=""QueryRest.xml");

в функцию КодФСРАР
было
 

СтруктураДанныхHTTPЗапроса("GET", "/info/certificate/RSA?attachment=true"));

стало
 

СтруктураДанныхHTTPЗапроса("GET", "/api/certificate/download/RSA?attachment=true"));

10) Для проверки акцизок
В модуль менеджера ТТНВхходящаяЕГАИС и ТТНИсходящаяЕГАИС в процедуры ВходящиеАкцизныеМарки и ВходящееДеревоУпаковок
было
 

И Результат.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V3 Тогда

стало
 

И Результат.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V3 ИЛИ Результат.ФорматОбмена = Перечисления.ФорматыОбменаЕГАИС.V4 Тогда

 

розница егаис УТМ4 waybill_v4

См. также

Оптовая торговля Розничная торговля Обмен с ГосИС Бухгалтер Платформа 1С v8.3 1С:Управление торговлей 10 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полнофункциональное расширение (ранее известное как Модуль 1С-ЕГАИС) для взаимодействия типовых конфигураций 1С и ЕГАИС, предоставляющее максимум возможностей по работе с УТМ. Получение и отправка ТТН, отправка акта о постановке на баланс и акта о списании. Получение остатков. Загрузка и сопоставление номенклатуры и контрагентов. Оправка в ЕГАИС отчетов о производстве и импорте.

8970 руб.

15.12.2015    168648    807    364    

394

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    787985    4750    9507    

2816

Бюджетирование и планирование Оптовая торговля Розничная торговля Логистика, склад и ТМЦ Анализ продаж Пользователь Платформа 1С v7.7 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Система управления запасами для 1С помогает работать с запасами правильно: автоматически рассчитывает потребность и делает заказ поставщику, загружает прайсы, перемещает товары по филиалам, анализирует продажи и позволяет управлять ассортиментом.

28500 руб.

21.04.2017    93610    119    40    

210

Розничная торговля Маркетплейсы Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Платные (руб)

Модуль для интеграции 1С с сервисом СберМаркет/Купер. Предназначен для обмена данными из торговых точек розничных сетей из баз данных 1С в базы данных СберМаркет/Купер, для отображения информации по товарам, остаткам, ценам, заказам и статусам заказов. Позволяет оперативно начать работать с сервисом СберМаркет, существенно повысить продажи и лояльность клиентов.

35000 руб.

14.10.2022    8700    15    14    

11

Оптовая торговля Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Платные (руб)

Данная публикация создана для помощи разработчикам, интеграторам и другим заинтересованным лицам по настройке системы маркировки обуви, одежды, лекарств, табака, фото, молока, духов(парфюма), питьевой воды, велосипедов и шин. Смело задавайте вопросы по работе с ЦРПТ, GS1, ЭДО, Национальным каталогом, накопили достаточно большую базу знаний по данным темам и готовы ответить на все Ваши вопросы.

5000 руб.

18.03.2019    111815    29    114    

182

ККМ Кассовые операции Розничная торговля Системный администратор Программист Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия автономного учреждения Россия Платные (руб)

Обработка осуществляет обслуживание ККТ АТОЛ, Штрих и Меркурий для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Поддерживает возможность параллельно пробития чеков на одной ККМ несколькими пользователями. Поддерживает Веб-сервер Атол. Соответствует требованиям 54-ФЗ. Поддерживает ФФД 1.0, 1.05, 1.1 и 1.2. Разделяет чеки по нескольким СНО. Поддерживает механизмы подключения ККТ по TCP/IP, для работы через RDP или интернет. Поддержка маркировки и разрешительного режима.

5400 руб.

25.05.2015    330420    1898    3031    

1013
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. max1m1ch 12.05.21 04:33 Сейчас в теме
Добрый день, для исходящей ттн не делали подобное ?
3. Xeromant 6 13.05.21 16:56 Сейчас в теме
(1) пока можно 3-ю версию отправлять, для исходящих там с владельцем надо чтото придумать протэстирую выложу
2. user633843_s.puchnin 12.05.21 15:09 Сейчас в теме
Не совсем понял, для чего изменения, указанный релиз Розницы (2.3.8.27) как раз с четвертым форматом уже работает, но вроде как перестает понимать третий (хотя в настройках организации доступны на выбор форматы 3 и 4).
4. Xeromant 6 13.05.21 17:03 Сейчас в теме
(2) Вы правы, ошибся с версией, это для 2.3.8.22, с этими доработками работает с v3, v4
5. Генdalf 13.05.21 17:26 Сейчас в теме
Розница 2.3.8.27. В УТМ пришли накладные waybill_v4, но при обмене в Розницу они не загружаются. Всё-таки понимает Розница waybill_v4 или нет ?
6. Xeromant 6 13.05.21 17:34 Сейчас в теме
(5)А формат обмена у грузотправителя на v4 поменяли, там только или 3 или 4
7. Генdalf 13.05.21 18:04 Сейчас в теме
(6)грузоотправителя в базе ещё нет, негде менять, новый контрагент
8. Генdalf 13.05.21 18:18 Сейчас в теме
(6) В Рознице запросил контрагента из ЕГАИС по идентификатору, проставил у него v4 - без изменений, ТТН не загружается.
9. Xeromant 6 13.05.21 18:28 Сейчас в теме
(8) а у своей фирмы если на v4 поменять
10. Генdalf 13.05.21 18:30 Сейчас в теме
(9)пробовал, без изменений.
Вы сами пробовали в 2.3.8.27 загружать ТТН v4 ?
11. Xeromant 6 13.05.21 18:47 Сейчас в теме
(10)нет, я загружаю в 2.3.8.22 с этими доработками
15. Генdalf 14.05.21 17:02 Сейчас в теме
(5) получилось после очистки УТМ и повторного запроса ТТН
12. max1m1ch 13.05.21 20:34 Сейчас в теме
а документ транспортная накладная вы не используете ?
13. Xeromant 6 13.05.21 22:15 Сейчас в теме
14. max1m1ch 13.05.21 23:07 Сейчас в теме
про него не упоминули
16. Watersan 27.05.21 12:45 Сейчас в теме
Здравствуйте.

Обновили релиз розницы до 2.3.8.27. Обновили утм до 4 версии. в 1с в настройках работу с 4 версией установили. приходит в УТМ документ TTNHISTORYF2REG(тоесть поставщик отправил ттн), а загружаться ттн не хочет. Только если в 1с делать запрос по идентификатору, тогда загрузка происходит.

Подскажите, пожалуйста, что можно или нужно сделать, чтобы ттн нормально загружалась через кнопку "Выполнить обмен"?
17. Xeromant 6 27.05.21 13:14 Сейчас в теме
TTNHISTORYF2REG это не накладная, на накладной написано "Накладная" и если в утм в нее зайти там пишет waybill_v3 или waybill_v4, что-то с утм у вас
18. Watersan 27.05.21 14:22 Сейчас в теме
(17) Спасибо за быстрый ответ. пробовал ставить 3 разные версии УТМ 4.2.0 b2427, УТМ 4.2.0 b2403 с сайта https://egais-help.ru и УТМ 4.2.0 b2403 с ЛК Егаис. все время одно и тоже. При этом из 1с получаем остатки, продажи проходят без проблем, а вот с ттн беда какая-то
19. tulapc 01.06.21 12:10 Сейчас в теме
не грузятся накладные по v4 розница 7.19 неизвестный тип документа
22. vin1c 02.06.21 10:31 Сейчас в теме
(19) Обязательно удалите типовую схему egais_WB_DOC_SINGLE_01!!! Я сначала не удалил и у меня также писал.
20. Xeromant 6 01.06.21 13:42 Сейчас в теме
в модуле перечисления ВидыДокументовЕГАИС в функции ТаблицаСоответствияДокументовТипамЕГАИС нужный код добавили? схемы в расширение конфигурации загрузил?
21. vin1c 02.06.21 10:29 Сейчас в теме
Спасибо большое, даже в 2.2 адаптировал вашу разработку!
23. пользователь 03.06.21 10:19
Сообщение было скрыто модератором.
...
24. tuer 1 03.06.21 10:21 Сейчас в теме
(21) vin1c а не поделишься своей доработкой?
25. Xeromant 6 03.06.21 10:50 Сейчас в теме
(24) А вы пробовали прикрутить?
26. tuer 1 03.06.21 12:54 Сейчас в теме
(25) Сейчас сижу, занимаюсь этим.
Вы же расширение скинули только с XDTO пакетами, остальные процедуры надо в расширение самому добавлять. И чет у меня не сростается.

{УТМ4_waybill_v4 Документ.ТТНВходящаяЕГАИС.МодульМенеджера(134)}: Метод объекта не обнаружен (ОбъектXDTOПоИмениТипа)
АктXDTO.Header = ИнтеграцияЕГАИС.ОбъектXDTOПоИмениТипа(АктXDTO, "Header");

egais_WB_DOC_SINGLE_01 - как ее удалить, не пойму. Снял с поддержки, все переименовал, всеравно.

Розница, редакция 2.2 (2.2.13.11)
Прикрепленные файлы:
УТМ4_waybill_v4_v3.cfe
27. tuer 1 03.06.21 14:25 Сейчас в теме
(25) Удалил - egais_WB_DOC_SINGLE_01

{УТМ4_waybill_v4 Документ.ТТНВходящаяЕГАИС.МодульМенеджера(134)}: Метод объекта не обнаружен (ОбъектXDTOПоИмениТипа)
АктXDTO.Header = ИнтеграцияЕГАИС.ОбъектXDTOПоИмениТипа(АктXDTO, "Header");

Все равно ошибка
29. vin1c 04.06.21 10:59 Сейчас в теме
(24) поделюсь, только у меня конфа вся переписана.
28. tuer 1 04.06.21 00:05 Сейчас в теме
В общем, обновился я до последнего релиза, переработал все свои доработки и забил на данный колхоз.

1. В расширении нет ни чего, от слова совсем, кроме XDTO пакетов. (и то, в них все скопировано с основной конфы и добавлено 4 пакета для УТМ 4
2. Нет доработки, для работы с УТМ 4 а именно, просто не будет связи с УТМ4 ( в моем файле есть дописка, взял с соседней ветки)
3. Нет доработки отправки запроса, что мы уже на v4
4. Чтобы внедрить, надо снять конфу с поддержки, убить один пакет, добавить значение в Перечисление.
И еще масса нюансов, но я не буду продолжать.

Хочу заметить, что такие разработки, где пишется, скачайте расширение, если не хотите руками, то это ЛУКАВОСТЬ.

В общем, из ларца.

P.S. на комменты отвечаю редко, сорри.
30. Xeromant 6 04.06.21 12:44 Сейчас в теме
(28) Схемы только через расширение правильно можно импортировать, остальные изменения по пунктам расписаны и делаются руками в коде. Про связь с утм4 согласен, добавил пункт 9.
Функцию ОбъектXDTOПоИмениТипа можно вручную добавить в модуль ИнтеграцияЕГАИС и если вчитаться в код можно увидеть где ее взять

Функция ОбъектXDTOПоИмениТипа(ОбъектXDTOРодитель, ИмяТипа) Экспорт

ТипОбъекта = ОбъектXDTOРодитель.Тип().Свойства.Получить(ИмяТипа).Тип;

Возврат ФабрикаXDTO.Создать(ТипОбъекта);

КонецФункции
31. Xeromant 6 04.06.21 12:59 Сейчас в теме
Отправить запрос можно вручную из УТМ отправиви файлик с именем
InfoVersionTTN

<ns:Documents xmlns:ns="http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01" xmlns:qp="http://fsrar.ru/WEGAIS/InfoVersionTTN" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ns:Owner>
<ns:FSRAR_ID>вашФСРАРИД</ns:FSRAR_ID>
</ns:Owner>
<ns:Document>
<ns:InfoVersionTTN>
<qp:ClientId>вашФСРАРИД</qp:ClientId>
<qp:WBTypeUsed>WayBill_v4</qp:WBTypeUsed>
</ns:InfoVersionTTN>
</ns:Document>
</ns:Documents>

Все это для тех у кого нет возможности обновить конфигурацию, потому все так не просто)
Оставьте свое сообщение