Групповое изменение реквизитов номенклатуры

13.05.21

Задачи пользователя - Корректировка данных

Универсальная обработка для редактирования реквизитов номенклатуры.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Групповое изменение реквизитов Номенклатуры
.epf 104,42Kb
15
15
2 SM
Скачать Купить за 2 150 руб.

Нужна была универсальная обработка, для редактирования реквизитов Номенклатуры. Ничего прочего. 

Немного модифицирована от типовой. Список товаров для отбора заполняется как вручную, так и с помощью вставки значений из буфера (коды Артикулов, по ним происходит поиск требуемых для редактирования номенклатур. Также реализован механизм считывания данных с файлов Excel (xls, xlsx формата), в которых есть заполненные данные, с первой колонкой "Артикул".

  1. Запускается обработка.
  2. В форме отбора выбираются, или загружаются из буфера, excel данные артикулы товаров, по которым надо массово заменить значения в реквизитах.
  3. После считывания данных определяем список товаров, которые редактируем.
  4. На панели реквизитов определяем список реквизитов, которые изменяем, напротив указываем требуемое значение.
  5. Запускаем изменение.

Для безопасности, из редактируемых реквизитов убраны: Наименование, Код, Артикул.

Также после выполнения изменения редактирования реквизитов в журнал регистрации создается запись о редактируемом объекте с данными о пользователе, который вносил изменения, и дата изменения. (для контроля проверки).

Обработка тестировалась на платформе 8.3.13-8.3.17. Подойдет также под платформы свежее.

Обработка универсальная. В модуле объекта и в основной форме обработки основополагающим есть общий модуль. Он может быть в разных конфигурациях именоваться по своему.

Потому в данном куске кода желательно заменять название модуля на свой. К примеру в обработчике модуля формы:

 

 

&НаСервереБезКонтекста
Функция МетодыМенеджераОбъектаДляРедактированияРеквизитов(ИмяОбъекта)
    
    МодульИнтеграцияПодсистемБСП = ОбщийМодуль("ИнтеграцияПодсистемБСП");
    //тут ОбщийМодуль("наименование Вашего модуля из конфигурации, обычно это "Интеграция"")
    МодульГрупповоеИзменениеОбъектовПереопределяемый = ОбщийМодуль("ГрупповоеИзменениеОбъектовПереопределяемый");
    Если МодульИнтеграцияПодсистемБСП = Неопределено Или МодульГрупповоеИзменениеОбъектовПереопределяемый = Неопределено Тогда
        Возврат Новый Массив;
    КонецЕсли;
    
    ОбъектыСЗаблокированнымиРеквизитами = Новый Соответствие;
    МодульИнтеграцияПодсистемБСП.ПриОпределенииОбъектовСРедактируемымиРеквизитами(ОбъектыСЗаблокированнымиРеквизитами);
    МодульГрупповоеИзменениеОбъектовПереопределяемый.ПриОпределенииОбъектовСРедактируемымиРеквизитами(ОбъектыСЗаблокированнымиРеквизитами);
    
    СведенияОМенеджереОбъекта = ОбъектыСЗаблокированнымиРеквизитами[ИмяОбъекта];
    Если СведенияОМенеджереОбъекта = Неопределено Тогда
        Возврат "НеПоддерживается";
    КонецЕсли;
    ДоступныеМетоды = СтрРазделить(СведенияОМенеджереОбъекта, Символы.ПС, Ложь);
    Возврат ДоступныеМетоды;
    
КонецФункции

 


и в обработчике модуля объекта:

 

 

Функция МенеджерыОбъектовДляРедактированияРеквизитов()   
МодульИнтеграцияПодсистемБСП = ОбщийМодуль("ИнтеграцияПодсистемБСП");

    //тут ОбщийМодуль("наименование Вашего модуля из конфигурации, обычно это "Интеграция"")
    МодульГрупповоеИзменениеОбъектовПереопределяемый = ОбщийМодуль("ГрупповоеИзменениеОбъектовПереопределяемый");
    Если МодульИнтеграцияПодсистемБСП = Неопределено Или МодульГрупповоеИзменениеОбъектовПереопределяемый = Неопределено Тогда
        Возврат Новый Массив;
    КонецЕсли;
    
    ОбъектыСЗаблокированнымиРеквизитами = Новый Соответствие;
    МодульИнтеграцияПодсистемБСП.ПриОпределенииОбъектовСРедактируемымиРеквизитами(ОбъектыСЗаблокированнымиРеквизитами);
    МодульГрупповоеИзменениеОбъектовПереопределяемый.ПриОпределенииОбъектовСРедактируемымиРеквизитами(ОбъектыСЗаблокированнымиРеквизитами);
    
    Возврат ОбъектыСЗаблокированнымиРеквизитами;

КонецФункции

 

групповое изменение элементов реквизитов номенклатуры реквизиты номенклатуры.

См. также

Корректировка данных Системный администратор Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Платные (руб)

Незаменимая обработка для сопровождения конфигураций: ERP, УТ, КА. Позволяет вычистить многие ошибки в ключах аналитики, в ключевых справочниках конфигурации.

3600 руб.

10.02.2017    108698    650    173    

690

Закрытие периода Инструменты администратора БД Корректировка данных Бухгалтер Пользователь Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Расширение «Оперативное проведение» в 4 раза уменьшает время проведения документов и закрытия месяца. Является комплексным решением проблем 62 и 60 счетов. Оптимизирует проведение при включенной функциональной опции «Раздельный учет НДС». Используется в более 10 организациях уже 2 года. Совместимо с конфигурацией Бухгалтерия 3.0 (+КОРП).

14400 руб.

29.04.2020    30028    88    151    

63

Корректировка данных Программист Пользователь Платформа 1С v8.3 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Управленческий учет Платные (руб)

Представьте, что есть система QR - кодирования, которая НЕ ТРЕБУЕТ изменения конфигурации, НЕ ТРЕБУЕТ изменения ни одной печатной формы для добавления QR-кода, включая внешние, НЕ ХРАНИТ данные штрихкодов и их связь, от чего база не "пухнет", ИМЕЕТ возможность закодировать в QR-коде произвольные данные параметров для последующей обработки полученных данных, УМЕЕТ прикреплять сканы, УМЕЕТ обработать считанный QR-код как ВЫ захотите. А также ХРАНИТ историю операций в обход базы для каждого пользователя в отдельности и УМЕЕТ работать с 2D - сканерами. А также автоматически распознавать отсканированные печатные формы (картинки или pdf-файлы) и выполнять заданные произвольные алгоритмы, в том числе прикрепление их к документам! Обновление 3.2 от 09.06.2024!

19200 руб.

26.08.2018    51358    14    61    

54

Корректировка данных Зарплата Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет НДФЛ Платные (руб)

Обработка исправляет технические ошибки по НДФЛ, взаиморасчетам с сотрудниками в 1С:ЗУП (1С:ЗКГУ) на начало года. Фактически все ошибки, которые проявляются в ведомостях на выплату, расчетных листках, при заполнении ведомостей на выплату и отчетах 6-НДФЛ и т.д. нужно начинать исправлять с начала расчетного года. Это позволит быть уверенными, что после завершения расчетов предыдущего года, начали работать с «чистого листа» без ошибочных остатков.

4800 руб.

06.10.2023    3506    34    17    

42

Корректировка данных Зарплата Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Внешняя обработка предназначена для исправления самых различных ошибок, возникших по самым разным причинам. Общее проявление этих ошибок видно в различии данных между: проводками и различными отчетами по НДФЛ, заполнении ведомостей на выдачу зарплаты, неверным расчетом НДФЛ при начислении ЗП и т.д.

3600 руб.

09.02.2024    1307    9    5    

11

Закрытие периода Корректировка данных Бухгалтер Пользователь Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Управленческий учет Платные (руб)

Закрытие месяца - важный процесс в современных конфигурациях, таких как УТ 11.4, УТ 11.5, КА 2.4, КА 2.5 ERP 2.4,ERP 2.5, КА 2 Казахстан, УТ 3 Казахстан регламентные операции влияют на расчет себестоимости, и ошибки в данном расчете не дают картины деятельности организации.

2400 руб.

27.10.2021    23450    304    35    

77
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. user709645_a.zavoruev 15.06.23 21:15 Сейчас в теме
Добрый вечер.
В каких конфигурациях работает эта обработка ?
В ERP возникает вот такая ошибка.
Прикрепленные файлы:
2. user1004898 28 22.06.23 14:19 Сейчас в теме
(1) разрабатывал на УНФ. Скорее всего в ЕРП нет модуля с таким названием. Надо искать аналогичный, и сделать замену
3. user709645_a.zavoruev 22.06.23 14:51 Сейчас в теме
Спасибо за информацию.
По мимо этой ошибки, нашли и исправили еще как миниму 5.
В описании по мимо платформы обязательно указывайте конфигурация 1С под которую производилась разработка.
4. Andrey_Aero 12.03.24 16:19 Сейчас в теме
(3) Есть исправленный вариант данной обработки? А то скачал, не посмотрел комментарии. Наткнулся на такую же ошибку. В ERP не открывается
Оставьте свое сообщение