Приведение к единому виду номеров телефонов в УТ 11

11.02.22

Задачи пользователя - Корректировка данных

Приведение к единому виду и наведение порядка в номерах телефонов в УТ 11.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Приведение к единому виду номеров телефонов в УТ 11:
.rar 15,17Kb
36
36
1 SM
Скачать Купить за 1 850 руб.

Не в первый раз сталкиваюсь с тем, что пользователи вводят номера телефонов "как придется".

Также бывают ситуации, когда при обмене с сайтом, например, приходит некорректный формат номера телефона (неправильные значения полей, записано только представление), и нужно массово все исправить. 

Как удалось навести порядок в номерах телефонов:

1) чтобы пользователи вводили так, как нужно, на форме ввода номера телефона - установить маску для номера (в нужном виде: "9999999" или "999-99-99").Если конфигурация типовая, то это лучше сделать в расширении.

2) предыдущие номера привести в порядок с помощью обработки. Пользоваться ей достаточно просто. При необходимости можно дописать "под себя" - код открыт.

Открыть обработку, выбрать вид контактной информации - телефон (справочника Партнеры). Если нужно править телефоны для контрагентов - то надо немного поправить обработку.

Далее Заполнить номера. Таблица на форме будет заполнена всеми телефонами.

 

 

У меня номер телефона должен соответствовать шаблону: +7(999)9999999. Для приведения всех номеров к шаблону - нажать "Преобразовать телефоны по представлению". Эта процедура убирает пробелы, дефисы и скобочки из представления номера телефона, раскладывает его на: код страны, код города и номер телефона. Но нужно проверить, чтоб не было ошибок, особенно с добавочными номерами и с номерами, где изначально некорректное представление. 

Дальше - Обработать строки". Для всех выделенных строк будет изменена контактная информация и сформированы корректные значения полей.

В общем-то, все достаточно быстро - у меня на несколько тысяч партнеров ушло пару часов - с проверкой на тестовой базе. 

Проверена и протестирована мной на УТ 11.4.11.88.

На более старой версии: 11.3.3.178 в таком формате не будет работать, нужно поменять несколько строк кода, которые касаются формирования значений полей

с такого: 


Функция РезультатВыбора(ТекСтрока)
	
	Результат = Новый Структура();
	
	КонтактнаяИнформация = КонтактнаяИнформацияПоЗначениюРеквизитов(ТекСтрока);
	
	ДанныеВыбора = УправлениеКонтактнойИнформациейСлужебный.СтруктураВСтрокуJSON(КонтактнаяИнформация); 

	Результат.Вставить("Вид", ВидКонтактнойИнформации);
	Результат.Вставить("Тип", ВидКонтактнойИнформации.Тип);
	Результат.Вставить("КонтактнаяИнформация", УправлениеКонтактнойИнформацией.КонтактнаяИнформацияВXML(ДанныеВыбора, 
		КонтактнаяИнформация.Value, 
		ВидКонтактнойИнформации.Тип));
	Результат.Вставить("Значение", ДанныеВыбора);
	Результат.Вставить("Представление", КонтактнаяИнформация.Value);
	Результат.Вставить("Комментарий", КонтактнаяИнформация.Comment);
	//Результат.Вставить("КонтактнаяИнформацияОписаниеДополнительныхРеквизитов",
	//	КонтактнаяИнформацияОписаниеДополнительныхРеквизитов);
		
	Возврат Результат
	
КонецФункции

&НаСервере
Функция КонтактнаяИнформацияПоЗначениюРеквизитов(ТекСтрока)
	
	Результат = УправлениеКонтактнойИнформациейКлиентСервер.ОписаниеНовойКонтактнойИнформации(ВидКонтактнойИнформации.Тип);
	
	Результат.CountryCode = ТекСтрока.КодСтраны;
	Результат.AreaCode    = ТекСтрока.КодГорода;
	Результат.Number      = ТекСтрока.НомерТелефона;
	Результат.ExtNumber   = ТекСтрока.Добавочный;
	Результат.Value       = УправлениеКонтактнойИнформациейКлиентСервер.СформироватьПредставлениеТелефона(
		ТекСтрока.КодСтраны, 
		ТекСтрока.КодГорода, 
		ТекСтрока.НомерТелефона, 
		ТекСтрока.Добавочный, "");
	Результат.Comment     = ТекСтрока.Комментарий;
	
	Возврат Результат;
	
КонецФункции

 на такой

Функция РезультатВыбора(ТекСтрока)
	
	Результат = Новый Структура("КонтактнаяИнформация, Представление, Комментарий, Вид, Тип, КонтактнаяИнформацияОписаниеДополнительныхРеквизитов");
		
	XDTOИнформация = КонтактнаяИнформацияПоЗначениюРеквизитов(ТекСтрока);
	
	ДанныеВыбора = УправлениеКонтактнойИнформациейСлужебный.КонтактнаяИнформацияXDTOВXML(XDTOИнформация);
	
	Результат.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонКонтактногоЛица;
	Результат.Тип = Результат.Вид.Тип;
	Результат.КонтактнаяИнформация = ДанныеВыбора;
	Результат.Представление = XDTOИнформация.Представление;
	Результат.Комментарий = XDTOИнформация.Комментарий;
	
	Возврат Результат
	
КонецФункции

Функция КонтактнаяИнформацияПоЗначениюРеквизитов(ТекСтрока)
	
	ПространствоИмен = УправлениеКонтактнойИнформациейКлиентСервер.ПространствоИмен();
	
	Результат = ФабрикаXDTO.Создать( ФабрикаXDTO.Тип(ПространствоИмен, "КонтактнаяИнформация") );
	
	Данные = ФабрикаXDTO.Создать( ФабрикаXDTO.Тип(ПространствоИмен, "НомерТелефона") );
	Данные.КодСтраны  = ТекСтрока.КодСтраны;
	Данные.КодГорода  = ТекСтрока.КодГорода;
	Данные.Номер      = ТекСтрока.НомерТелефона;
	Данные.Добавочный = ТекСтрока.Добавочный;
	Результат.Представление = УправлениеКонтактнойИнформациейСлужебный.ПредставлениеТелефона(Данные);
	
	Результат.Состав      = Данные;
	
	Возврат Результат;
	
КонецФункции

На  УТ 11.1.6.26 - не работает. 

В архиве - две версии обработки. Одна - для УТ 11.3.3.178, другая - для УТ  11.4.11.88.

Обработка

См. также

Корректировка данных Системный администратор Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Платные (руб)

Незаменимая обработка для сопровождения конфигураций: ERP, УТ, КА. Позволяет вычистить многие ошибки в ключах аналитики, в ключевых справочниках конфигурации.

3600 руб.

10.02.2017    108663    650    173    

690

Закрытие периода Инструменты администратора БД Корректировка данных Бухгалтер Пользователь Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Расширение «Оперативное проведение» в 4 раза уменьшает время проведения документов и закрытия месяца. Является комплексным решением проблем 62 и 60 счетов. Оптимизирует проведение при включенной функциональной опции «Раздельный учет НДС». Используется в более 10 организациях уже 2 года. Совместимо с конфигурацией Бухгалтерия 3.0 (+КОРП).

14400 руб.

29.04.2020    29997    88    151    

63

Корректировка данных Программист Пользователь Платформа 1С v8.3 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Управленческий учет Платные (руб)

Представьте, что есть система QR - кодирования, которая НЕ ТРЕБУЕТ изменения конфигурации, НЕ ТРЕБУЕТ изменения ни одной печатной формы для добавления QR-кода, включая внешние, НЕ ХРАНИТ данные штрихкодов и их связь, от чего база не "пухнет", ИМЕЕТ возможность закодировать в QR-коде произвольные данные параметров для последующей обработки полученных данных, УМЕЕТ прикреплять сканы, УМЕЕТ обработать считанный QR-код как ВЫ захотите. А также ХРАНИТ историю операций в обход базы для каждого пользователя в отдельности и УМЕЕТ работать с 2D - сканерами. А также автоматически распознавать отсканированные печатные формы (картинки или pdf-файлы) и выполнять заданные произвольные алгоритмы, в том числе прикрепление их к документам! Обновление 3.2 от 09.06.2024!

19200 руб.

26.08.2018    51341    14    61    

54

Корректировка данных Зарплата Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет НДФЛ Платные (руб)

Обработка исправляет технические ошибки по НДФЛ, взаиморасчетам с сотрудниками в 1С:ЗУП (1С:ЗКГУ) на начало года. Фактически все ошибки, которые проявляются в ведомостях на выплату, расчетных листках, при заполнении ведомостей на выплату и отчетах 6-НДФЛ и т.д. нужно начинать исправлять с начала расчетного года. Это позволит быть уверенными, что после завершения расчетов предыдущего года, начали работать с «чистого листа» без ошибочных остатков.

4800 руб.

06.10.2023    3495    34    17    

42

Корректировка данных Зарплата Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Внешняя обработка предназначена для исправления самых различных ошибок, возникших по самым разным причинам. Общее проявление этих ошибок видно в различии данных между: проводками и различными отчетами по НДФЛ, заполнении ведомостей на выдачу зарплаты, неверным расчетом НДФЛ при начислении ЗП и т.д.

3600 руб.

09.02.2024    1292    8    5    

11
Оставьте свое сообщение