Групповая замена основного менеджера по группе доступа

29.07.22

Администрирование - Роли и права

Для корректной работы должно быть включено ограничение на уровне записей и группы доступа партнеров. Обработка позволяет изменить основного менеджера сразу у всех партнеров с определенной группой доступа. Пригодится, если вам нужно передать всех партнеров уволившегося менеджера новому сотруднику, или просто перераспределить клиентов между менеджерами.

Скачать исходный код

Наименование Файл Версия Размер
Групповая замена основного менеджера по группе доступа:
.epf 12,83Kb
0
.epf 12,83Kb Скачать

Замена основного менеджера по группе доступа

 

 

Отбор партнеров производится по реквизиту «Группа доступа». Если группа не выбрана, тогда партнеры подобраны не будут. При изменении группы доступа таблица с партнерами очищается.

По кнопке «Подобрать клиентов» заполняется таблица всеми партнерами выбранной группы. В колонке «Новый менеджер» устанавливается значение из поля «Менеджер по умолчанию».

Если выбран менеджер в поле «Дополнительный отбор», тогда будут подобраны только те клиенты, у которых выбранный сотрудник указан в качестве основного менеджера.

В полях «По менеджеру» и «Менеджер по умолчанию» доступны для выбора только те сотрудники, для которых разрешена работа с выбранной группой доступа по партнерам.

При нажатии кнопки «Выполнить замену» обрабатываются только те строки, в которых стоит отметка в колонке «Изменить». Если колонка «Новый менеджер» в строке заполнена, тогда в карточку партнера будет записан указанный новый менеджер. Если значение колонки пустое, тогда в карточку партнера будет записан менеджер по умолчанию из шапки формы.

Заполнение списка выбора менеджеров:

Запрос = Новый Запрос;
	
	Запрос.Текст =    
	"ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	ГруппыДоступаПользователи.Пользователь КАК Ссылка
	|ИЗ
	|	Справочник.ГруппыДоступа.ЗначенияДоступа КАК ГруппыДоступаЗначенияДоступа
	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.ГруппыДоступа.Пользователи КАК ГруппыДоступаПользователи
	|		ПО ГруппыДоступаЗначенияДоступа.Ссылка = ГруппыДоступаПользователи.Ссылка
	|ГДЕ
	|	ГруппыДоступаЗначенияДоступа.ЗначениеДоступа = &ГруппаДоступа
	|	";
	
	Запрос.УстановитьПараметр("ГруппаДоступа", Объект.ГруппаДоступа);
	
	РезультатЗапроса = Запрос.Выполнить().Выгрузить();
	Объект.ДоступныеМенеджеры.ЗагрузитьЗначения(РезультатЗапроса.ВыгрузитьКолонку("Ссылка"));
	
	СписокАктуальных = Новый Массив;
	Для Каждого Стр Из РезультатЗапроса Цикл
		Если Стр.Ссылка.Недействителен Тогда
			//пропуск
		Иначе
			СписокАктуальных.Добавить(Стр.Ссылка);
		КонецЕсли;
	КонецЦикла;

Запрос по партнерам:

Запрос.Текст = 
	"ВЫБРАТЬ
	|	Партнеры.Ссылка КАК Партнер,
	|	Партнеры.ОсновнойМенеджер КАК Менеджер,
	|	Партнеры.ОсновнойМенеджер.Недействителен КАК Недействителен,
	|	&НовыйМенеджер КАК НовыйМенеджер
	|ИЗ
	|	Справочник.Партнеры КАК Партнеры
	|ГДЕ
	|	Партнеры.ОсновнойМенеджер В(&Менеджеры)
	|	И ВЫБОР
	|			КОГДА &ПоМ
	|				ТОГДА Партнеры.ОсновнойМенеджер = &ПоМенеджеру
	|			ИНАЧЕ ИСТИНА
	|		КОНЕЦ
	|	И Партнеры.ГруппаДоступа = &ГруппаДоступа";

Изменение основного менеджера:

&НаСервере
Процедура ПоменятьОсновногоМенеджераНаСервере()
	
	СколькоИзменили = 0;
	
	Для Каждого Стр Из Объект.Клиенты Цикл
		Если Стр.Изменить Тогда
			
			Если ЗначениеЗаполнено(Стр.НовыйМенеджер) Тогда
				СпрОбъект = Стр.Партнер.ПолучитьОбъект();
				СпрОбъект.ОсновнойМенеджер = Стр.НовыйМенеджер;
				СпрОбъект.Записать();
			ИначеЕсли ЗначениеЗаполнено(Объект.МенеджерПоУмолчанию) Тогда
				СпрОбъект = Стр.Партнер.ПолучитьОбъект();
				СпрОбъект.ОсновнойМенеджер = Объект.МенеджерПоУмолчанию;
				СпрОбъект.Записать();
			КонецЕсли;	
			
		КонецЕсли;
	КонецЦикла;
	
	ЗаполнитьДоступныхКлиентов();
	
КонецПроцедуры

Протестировано на Управление торговлей, редакция 11 (11.4.13.227) и 1С:ERP Управление предприятием 2 (2.5.7.324), платформа 1С:Предприятие 8.3 (8.3.20.1789).

Подключается как дополнительная внешняя обработка через БСП.

Менеджеры группа доступа групповая обработка партнер клиент

См. также

Infostart Toolkit: Инструменты разработчика 1С 8.3 на управляемых формах

Инструментарий разработчика Роли и права Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    134660    740    391    

775

Автоподбор ролей для профилей и групп доступа в любых типовых базах 1С УТ 11, КА 2, ERP2, Розница 2/3, УНФ 16/3, БП 3, ЗУП 3 и подобных (УФ, Платформа 8.3.14+)

Инструменты администратора БД Роли и права Системный администратор Программист Пользователь 8.3.14 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Документооборот 1С:Зарплата и кадры государственного учреждения 3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Платные (руб)

Роли… Вы тратите много времени и сил на подбор ролей среди около 2400 в ERP или 1500 в Рознице 2, пытаясь понять какими правами они обладают? Вы все время смотрите права в конфигураторе или отчетах чтоб создать нормальные профили доступа? Вы хотите наглядно видеть какие права дает профиль и редактировать все в простом виде? А может хотите просто указать подсистему и дать права на просмотр и добавление на объекты и не лезть в дебри прав и чтоб обработка сама подобрала нужные роли? Все это теперь стало возможно! Обновление от 15.12.2023, версия 1.1.

14400 руб.

06.12.2023    5023    22    1    

48

Infostart FormWizard: Управление данными и формами в 1С 8.3

Инструменты администратора БД Инструментарий разработчика Роли и права Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Расширение позволяет без изменения кода конфигурации выполнять проверки при вводе данных, скрывать от пользователя недоступные ему данные, выполнять код в обработчиках. Не изменяет данные конфигурации, легко устанавливается практически на любую конфигурацию на управляемых формах.

10000 руб.

10.11.2023    6475    16    2    

42

Запрет доступа к данным по зарплате для БП 3.0 и КА 2.5

Зарплата Роли и права Системный администратор Бухгалтер Платформа 1С v8.3 Бухгалтерский учет Управление правами 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Молдова Россия Казахстан Бухгалтерский учет Платные (руб)

Расширение позволяет максимально полно ограничить доступ пользователей к данным по заработной плате, а именно закрывает доступ к документам начисления и выплаты заработной платы, не позволяет просматривать бухгалтерские отчеты по счету учета зарплаты а также убирает зарплатные проводки из журнала проводок. Расширение запрещает просматривать платежные документы на выплату зарплаты, так же не доступны регламентные отчеты в ПФР и ИФНС. Расширение предлагает готовые настроенные профили "Бухгалтер без зарплаты", "Только просмотр без зарплаты".

5700 руб.

27.05.2021    34110    212    89    

171

Универсальная система оповещений в базе или по почте по произвольным условиям, расписанием, ролям и пользователям (Расширение / конфигурация для платформ 8.3.6+, для ЛЮБЫХ баз)

Роли и права Системный администратор Программист Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление торговлей 11 Платные (руб)

Данная система разработана как альтернатива стандартной системе напоминаний. Но имеет ряд существенных преимуществ: отображение в базе или с отправкой по почте, свое расписание, возможность фильтрации по ролям и пользователям, формирование своих запросов и макетов, шаблоны писем, работа в фоне. А также может блокировать работу пользователей при заданных условиях. Может работать в составе любой конфигурации. Имеется справка с описанием возможностей. (Обновление от 20.02.2024, версия 2.2, расширение)

19200 руб.

29.11.2019    25052    14    8    

35

Роли для кладовщика

Логистика, склад и ТМЦ Роли и права Программист Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет Управление правами 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Расширение, которое позволяет использовать отдельные роли для доступа к складским документам, для доступа к документам раздела "Производство" и для доступа к документам раздела "Покупки".

2520 руб.

21.05.2019    1693318    557    193    

136

Ограничения прав пользователей в УНФ

Ценообразование, анализ цен Роли и права Системный администратор Платформа 1С v8.3 Управление правами 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

Расширение возможностей программы УНФ. Функционал расширения - разграничение всевозможных прав пользователей и контроль при совершении различных действий.

3000 руб.

23.02.2018    56533    151    261    

143
Оставьте свое сообщение