Турнир по 1С. Танки на СКД

09.10.23

Задачи пользователя - Игры

Предлагаю свою версию турнира. Особенность этого турнира в том, что тут нет правильных или неправильных решений. Есть твое решение и решение твоих соперников. У кого решение лучше тот и победит.

Скачать файлы

Наименование Файл Версия Размер
Турнир по 1С. Танки на СКД:
.erf 20,27Kb
1
.erf 20,27Kb 1 Скачать

Немного о правилах

  • Игровое поле 50х40.
  • У каждого игрока в начале 100 единиц здоровья
  • Количество боеприпасов неограниченно
  • После каждого выстрела требуется перезарядка, поэтому стрелять можно раз в 10 ходов
  • При попадании снарядом в противника урон составляет от 40 до 70 единиц (рандомно)
  • При выводе из строя соперника - начисляется 5 очков тому, кто его вывел из строя
  • Длительность игры 100 ходов или до последнего танка (смотря что наступит раньше)
  • Если остается только 1 танк на поле - ему начисляется 15 очков.
  • Победитель тот, кто набрал больше очков.

Как управлять танками

При добавлении игроков надо будет указать код на языке 1С, который и будет управлять вашим танком.

Внутри кода доступна переменная СтруктураДанных типа Структура. В ней содержится следующая информация:

  • ШиринаИгровогоМира (тип Число)
  • ВысотаИгровогоМира (тип Число)
  • КоличествоХодов - остаток количества ходов в игре (тип Число)
  • НомерИгрока - ваш номер в таблице игроков (тип Число)
  • ИгровойМир - описание игрового мира, размещение всех объектов на поле (тип Таблица значений)
    Объекты пронумерованы и размещены в игровом мире под числами: 1-10 это танки, -1 вышедший из строя танк, 100-999 снаряды, где 1хх - снаряды первого игрока, 2хх - снаряды второго и т.д.
  • Игроки - список игроков и информация о них.

А еще внутри кода доступна переменная Действие типа структура. В ней нужно указывать ваши действия. Доступные действия:

  • Действие.Движение - может принимать одну из следующих строк "Вверх", "Вниз", "Влево", "Вправо"
  • Действие.Выстрел - тип Булево. Если Истина - значит будет попытка выстрела. Попытка будет успешной, если перезарядка игрока равна 0

Готовый код, который может ездить по периметру и стрелять:

МоеПоложение = СтруктураДанных.ИгровойМир.НайтиСтроки(Новый Структура("КоординатыИгрока", СтруктураДанных.НомерИгрока));
Если МоеПоложение.Количество() > 0 Тогда
	МоиКоординаты = МоеПоложение[0];
	
	Действие.Движение = "Вверх";
	Действие.Выстрел = Истина;
		
	Если МоиКоординаты.Строка < 10 Тогда 
		Действие.Движение = "Влево";
		Если МоиКоординаты.Колонка < 10 Тогда
			Действие.Движение = "Вниз";
		КонецЕсли;
	ИначеЕсли МоиКоординаты.Строка > СтруктураДанных.ВысотаИгровогоМира - 10 Тогда 
		Действие.Движение = "Вправо";
		Если МоиКоординаты.Колонка > СтруктураДанных.ШиринаИгровогоМира - 10 Тогда
			Действие.Движение = "Вверх";
		КонецЕсли;
	ИначеЕсли МоиКоординаты.Колонка < 10 Тогда
		Действие.Движение = "Вниз";
	ИначеЕсли МоиКоординаты.Колонка > СтруктураДанных.ШиринаИгровогоМира - 10 Тогда
		Действие.Движение = "Вверх";
	КонецЕсли;
	
КонецЕсли;

В заключении хочу сказать, что это не онлайн турнир. Чтобы его сделать онлайн нужен сервер и лицензии. А их у меня нет.

Но если кто-то захочет сделать его онлайн - буду только рад, что кому-то, кроме меня тоже зашла эта идея.
 

Во вложении отчет для любых конфигураций на управляемых формах, платформа 8.3, открывается через Файл - Открыть

См. также

Классическая игра "Змейка" на 1С (управляемые формы)

Игры Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Бесплатно (free)

Игра "Змейка" в классическом варианте на управляемых формах в 1С. Собирайте яблоки и ставьте рекорд!

09.02.2024    2270    103    emilyabochkova    12    

22

Игра "5 букв"

Игры Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Игра "5 Букв", сделанная на 1С. В игре загадано слово, существительное в единственном числе. Нужно отгадать загаданное слово.

1 стартмани

29.12.2023    833    2    APTEM_SLV    9    

6

Пятнашки

Игры Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Цель - обучение хитростям нашей всеми любимой 1С.

28.11.2023    784    27    user1834118    0    

6

Кар магедон

Игры Платформа 1С v8.3 Конфигурации 1cv8 1С:ERP Управление предприятием 2 Россия Бесплатно (free)

Держись, российский геймдев, я уже еду. Бета тест, можно оформлять предзаказы, будет донатный магазин с модельками российского автопрома (по цене реальных авто).

01.11.2023    1555    35    user1834118    7    

11

Плоский "Кубик Рубика"

Игры Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Вы можете собрать кубик Рубика? Я - только с помощью инструкции:). Попробуйте справиться с его плоским аналогом.

1 стартмани

29.05.2023    1942    6    Alxby    3    

13

Пасьянс Марии Стюарт (пасьянс Медичи) - попробуй изменить свою судьбу

Игры Платформа 1С v8.3 Россия Абонемент ($m)

Игра - пасьянс Марии Стюарт. Есть возможность создавать свои расклады, обмениваться раскладами и менять картинки карт.

1 стартмани

05.05.2023    2627    1    sandr13    0    

13

Тетрис

Игры Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Когда под рукой только 1С и как-то нужно скоротать время, можно поиграть в Тетрис.

1 стартмани

29.04.2023    3236    13    user1693438    2    

15

Головоломка Пентамино

Игры Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Широко известная головоломка, основанная на составлении фигур из составных частей. В данной реализации в качестве фигуры используется прямоугольник, а в качестве составных частей - пентамино, тетрамино или гексамино. Реализованы классические варианты головоломки и вариант со случайной генерацией фигур.

1 стартмани

18.04.2023    5314    5    Alxby    9    

23
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. PowerBoy 3338 09.10.23 15:04 Сейчас в теме
Я так понял башня не вращается, тогда это не танк а пт. :)
webresurs; +1 Ответить
Оставьте свое сообщение