Выбор цвета из палитры web цветов 1с в обычной и управляемой формах

01.07.15

Разработка - Работа с интерфейсом

Все web цвета 1с на одной форме.
Цвета упорядочены по оттенкам и подписаны.
Вариант для обычной и управляемой формы.

Скачать исходный код

Наименование Файл Версия Размер
Обработка ВыборWebЦвета платформа 8.3
.epf 15,92Kb
93
.epf 1.0.83 15,92Kb 93 Скачать
Обработка ВыборWebЦвета платформа 8.2
.epf 18,04Kb
47
.epf 1.0.82 18,04Kb 47 Скачать

Обработка была разработана для быстрого и наглядного выбора конечным пользователем цветов кнопок меню. Используются именно web цвета 1c – проименованые цвета проще запомнить, чем цифровые коды.

Используются стандартные средства платформы — на формах рисуются кнопки выбора цвета с наименованием цвета и соответствующим фоном кнопки.

Количество строк кнопок можно настраивать в реквизите формы КоличествоСтрок при открытии.

Для использования в конфигурации можно либо встроить обработкой, либо общей формой.

Результатом модального вызова формы есть выбранный web цвет.

Примеры вызова разных вариантов для обычной формы:

 

//Если форма общая
ВыбраныйWebЦвет = ПолучитьОбщуюФорму("ПалитраWebЦветов").ОткрытьМодально();
 
//Если встроена в конфигурацию обработкой
ВыбраныйWebЦвет = Обработки.ВыборWebЦвета.ПолучитьФорму("ПалитраWebЦветов").ОткрытьМодально();
 
Если НЕ ВыбраныйWebЦвет = Неопределено Тогда
        Элемент.ЦветФонаКнопки = ВыбраныйWebЦвет;
        Элемент.Заголовок = ВыбраныйWebЦвет;
КонецЕсли;

 

 

Пример вызова для управляемой формы 8.3:

 

&НаКлиенте
Процедура ПриНажатииДемоКнопки(Команда)
Кнопка = ЭтаФорма.ТекущийЭлемент;
Обработчик = Новый ОписаниеОповещения("ПриВыбореWebЦвета", ЭтаФорма);
Режим = РежимОткрытияОкнаФормы.БлокироватьОкноВладельца;
ДопПарам = Новый Структура("ИмяКнопки", Кнопка.Имя);
 
//Если форма общая
ОткрытьФорму("ОбщаяФорма.ПалитраWebЦветовУправляемая", ДопПарам,,,,, Обработчик, Режим);
 
//Если встроена в конфигурацию обработкой
ОткрытьФорму("Обработка.ВыборWebЦвета.Форма.ПалитраWebЦветовУправляемая", ДопПарам,,,,, Обработчик, Режим);
 КонецПроцедуры
 
&НаКлиенте
Процедура ПриВыбореWebЦвета(ВыбраныйWebЦвет, ДополнительныеПараметры) Экспорт
     Если НЕ ВыбраныйWebЦвет = НеопределеноТогда
       ИмяКнопки = ЭтаФорма.ТекущийЭлемент.Имя;
       Элементы[ИмяКнопки].ЦветФона = ВыбраныйWebЦвет;
        Элементы[ИмяКнопки].Заголовок = ВыбраныйWebЦвет;
   КонецЕсли;
 КонецПроцедуры


Пример вызова для управляемой формы 8.2:

 

  

  //Если форма общая
   ВыбраныйWebЦвет = ОткрытьФормуМодально("ОбщаяФорма.ПалитраWebЦветовУправляемая");
    
    //Если встроена в конфигурацию обработкой
   ВыбраныйWebЦвет = ОткрытьФормуМодально("Обработка.ВыборWebЦвета.Форма.ПалитраWebЦветовУправляемая");
    
    
    //Обработка выбора цвета
Если НЕ ВыбраныйWebЦвет = НеопределеноТогда
        ИмяКнопки = ЭтаФорма.ТекущийЭлемент.Имя;
        Элементы[ИмяКнопки].ЦветФона  = ВыбраныйWebЦвет;
        Элементы[ИмяКнопки].Заголовок = ВыбраныйWebЦвет;
    КонецЕсли; 



 

Для платформ 8.2 и 8.3 обычная форма работает одинаково. Для управляемой формы в платформе 8.3 в отличие от 8.2 используется немодальный вызов формы выбора и расширенная подсказка для кнопок.


цвет webцвет web цвет Color Picker ColorPicker выбор цвета

См. также

Богатый редактор картинок, хранимых в базе, с возможностью РИСОВАНИЯ. Редактор внешних файлов картинок. Объект, расширяющий возможности работы с картинками из встроенного языка (Три в одном) + Обработка «Стандартизация картинок»

Работа с интерфейсом Рабочее место Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Платные (руб)

Обработка предназначена для редактирования картинок в режиме «Предприятие», с возможностью РИСОВАТЬ на них. Поддерживается работа как в обычных формах (толстый клиент) так и на управляемых формах (тонкий клиент). Обработка позволяет редактировать как картинки, хранимые в базе, так и графические файлы с диска на файловой системе. Помимо базовых функций (изменение размеров, преобразование формата, обрезание картинки, повороты и т.п.) – редактор имеет богатый набор инструментов для рисования. Доступна функция вставки изображения из буфера обмена. Также обработка может быть использована из встроенного языка как объект для редактирования картинок. Объект может быть использован: на стороне клиента, на стороне сервера, из внешнего соединения. Данная обработка будет особенно полезна тем, кто вносит картинки в базу (изображения номенклатуры, фотографии физических лиц и т.п.). Функционал реализуется с использованием JavaScript и бесплатного ПО ImageMagick (без использования внешних компонент).

6000 руб.

16.01.2015    62237    43    59    

81

Управление дашбордами

Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Обработка предназначена для создания и управления дашбордами.

2400 руб.

29.06.2020    17072    24    4    

37

Новогоднее оформление для 1С

Работа с интерфейсом Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Зарплата и Управление Персоналом 3.x 1С:Управление нашей фирмой 3.0 Бесплатно (free)

Добавьте новогоднего настроения! Расширение создает декорацию в виде гирлянды на некоторых формах объектов.

27.12.2023    11490    769    elcoan    45    

106

Конструктор HTML, CSS и javascript

Инструментарий разработчика Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Подходит для создания web-страниц для замены управляемых форм 1С, красивых отчетов, интерфейса мобильного приложения на платформе 1С и для простых страниц веб-сайтов.

2 стартмани

10.04.2023    10089    156    acces969    31    

119

Модель состояния для MVC

Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

"MVC плохо применима в 1С" - познакомьтесь с моделью состояния и, возможно, ваше мнение поменяется! Представленное решение является эволюционным развитием идеи реализации MVC для 1С. В новой версии добавлены DSL для описания модели состояния, а также параметризация свойств параметров и элементов формы.

1 стартмани

05.07.2022    4094    kalyaka    4    

31

Табло очереди заказов на экран телевизора

WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 1С:Розница 2 Платные (руб)

Связка из веб-приложения и расширения для 1С: Розница 2.3.

3600 руб.

29.04.2022    12450    1    5    

11

Условное оформление элементов форм в пользовательском режиме 1С (управление видимостью и доступностью элементов форм)

Работа с интерфейсом Платформа 1С v8.3 Платные (руб)

Подсистема условного оформления элементов форм (далее подсистема) предназначена для настройки оформления элементов форм (видимость, доступность, цвет фона, цвет текста и прочее) в пользовательском режиме 1С. Также подсистему возможно использовать для ограничения доступа к реквизитам формы для определенных пользователей (или групп пользователей).

6000 руб.

18.01.2022    9038    1    2    

6

Программный интерфейс для доработки форм

Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Реализовал простой способ программного создания новых элементов, команд и реквизитов на форме.

25.11.2021    9858    AtamanovYS    19    

139
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Alexey_ 27 02.07.15 09:08 Сейчас в теме
В следующих публикациях ждем обработки по выбору файла, вводу строки, числа и т.п.
TheOldGuard; ovasiliev; wolovits; kuzz; +4 Ответить
2. chmv 02.07.15 09:40 Сейчас в теме
Любопытно. А Зачем?
TheOldGuard; user1538758; +2 3 Ответить
3. alex_4x 86 02.07.15 10:12 Сейчас в теме
Клёво! Красочно! Ярко! Креативно! Но зачем?

TheOldGuard; user1538758; daMaster; +3 Ответить
4. YaSan 49 02.07.15 11:36 Сейчас в теме
Зачем - в моем случае пользователи так настраиваются себе интерфейс. Выбирают цвета для кнопок в фронте фастфуда под тачскрин
TheOldGuard; MrFlanker; semagin@gmail.com; +3 Ответить
5. Alexey_ 27 02.07.15 11:42 Сейчас в теме
(4) Зачем обработка, когда есть ДиалогВыбораЦвета?
6. YaSan 49 02.07.15 12:12 Сейчас в теме
(5) Alexey_, Под тачскрин нужны были кнопки побольше. Вот и сделал, чтобы все цвета сразу на виду и пальцем проще тыкать.
MrFlanker; CratosX; +2 Ответить
10. join2us 18 30.01.18 23:44 Сейчас в теме
(5) В ДиалогеВыбораЦвета еще присутствуют цвета стиля, которые не всегда и нужны...

Автору - респект, встроил в УТ10.
MrFlanker; +1 Ответить
7. v.l. 435 02.02.16 17:45 Сейчас в теме
Молодец.
Я себе тоже ваял чтобы видеть наглядно цвет и как он называется программно.
8. inf012 19.03.17 21:58 Сейчас в теме
Такая вещь нужна, но я смотрю - по скринам, как будто не совсем упорядочивание правильное.
Зеленые в разнобой немного, розовые.
Если бы автоматическое было (по ргб) - вот хорошо бы.

Кто-нибудь знает, как автоматически упорядочить web-цвета по РГБ?

Можно, конечно, руками, но лучше автоматом.
9. air_mike 25 21.09.17 10:51 Сейчас в теме
Отлично. После некоторых доработок встроил в упп. Вопрос зачем. У нас много производственного оборудования. Каждое оборудование нужно выделять цветом. Чтобы не приходилось кодить, сделал выбор через эту обработку.

По РГБ было бы не плохо.. Кто отсортирует "СтрокаЦветов" выкладывайте. в комменты.
11. juker 252 08.07.18 23:16 Сейчас в теме
Правильно человек сказал.
Для пользунов сие произведение, ленивых пользунов.
Не стоит их так баловать, пусть хоть немного мозги включают.
12. unduty 20.12.19 19:07 Сейчас в теме
В 8.3.15 Управляемые формы обработки открываются пустыми , элементы формы создаются но их не видно.
15. air_mike 25 28.04.20 19:10 Сейчас в теме
(12)
В 8.3.15 Управляемые формы обработки открываются пустыми , элементы формы создаются но их не видно


Я добавил:
НоваяКнопка.Ширина = 12;
НоваяКнопка.Высота = 1;

Только после этого начало появляться.
13. KazanKokos 11 30.01.20 22:53 Сейчас в теме
Автору спасибо за табличку в заголовке. Пользуюсь постоянно :)
gluglugluglu; +1 Ответить
14. acanta 30.01.20 23:07 Сейчас в теме
Публикация супер и 1С с их названиями в коде тоже! Но питерцы об этом не в курсе....
Прикрепленные файлы:
Оставьте свое сообщение