ActiveX для просмотра изображений IP видеокамер

22.06.16

Разработка - Разработка внешних компонент

ActiveX, написанный на c# для просмотра изображений IP видеокамер, позволяет получать поток с IP камер в виде MJPEG или JPEG (Snapshot).

Скачать исходный код

Наименование Файл Версия Размер
ActiveX + обработка для 1С
.zip 150,78Kb
8
.zip 150,78Kb 8 Скачать

ActiveX, написанный на c# (FrameWork 4.0) для просмотра изображений IP видеокамер, позволяет получать поток с IP камер в виде MJPEG или JPEG. В ActiveX используется сторонний фреймфорк Aforge.

Для регистрации необходимо запустить файл reg.cmd. Или заругистрировать вручную командой C:\Windows\Microsoft.NET\Framework\v4.0.30319\regasm.exe Video1C.dll /tlb /codebase

 

Требования: Net Framework 4.0

 

Имеются следующие параметры:

 

Процедура START_JPEG(Кнопка)
	
	// Можно использовать либо JPEG либо MPEG поток. 
	
	// JPEG - снимает скриншоты с камеры через определенный интервал времени (FrameInterval). JPEG менее ресурсоемкий по сравнение с MJPEG.
	// MJPEG - поток в формате MJPEG. Из плюсов: плавность движения на видео, из минисув: нагружает процессор.
	
	ЭлементыФормы.ActiveX.Stop();	
	
	//поток JPEG 
	ЭлементыФормы.ActiveX.Potok = "JPEG";
	
	ЭлементыФормы.ActiveX.URL = "http://192.168.2.60/dms?nowprofileid=2"; // URL путь получения снапшота камеры.
	
	ЭлементыФормы.ActiveX.FrameInterval = 250; // время опроса камеры. 250 - каждые 250мс получается новый кадр.
	
	ЭлементыФормы.ActiveX.RequestTimeout = 10000; // время ожидания ответа от камеры перед выдачей ошибки соединения.
	
	ЭлементыФормы.ActiveX.Login = "";
	
	ЭлементыФормы.ActiveX.Password = "";
	
	ЭлементыФормы.ActiveX.Start();
	
	
	
КонецПроцедуры

Процедура STOP(Кнопка)
	
	ЭлементыФормы.ActiveX.Stop();
	
КонецПроцедуры

Процедура START_MJPEG(Кнопка)
	
	ЭлементыФормы.ActiveX.Stop();
		// поток MJPEG 
	ЭлементыФормы.ActiveX.Potok = "MJPEG";
		
	ЭлементыФормы.ActiveX.URL = "http://cam.mnc.ru/axis-cgi/mjpg/video.cgi?camera=1&dummy=0.22951200%201466582223"; // URL путь получения потока камеры.  	

	ЭлементыФормы.ActiveX.RequestTimeout = 10000; // время ожидания ответа от камеры перед выдачей ошибки соединения.
	
	ЭлементыФормы.ActiveX.Login = "";
	
	ЭлементыФормы.ActiveX.Password = "";
	
	ЭлементыФормы.ActiveX.Start();

КонецПроцедуры

Получение изображения с IP камер Получение потока с IP камер

См. также

Внешняя компонента печати PDF (Native Win 32/64)

Разработка внешних компонент Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Внешняя компонента позволяет печатать PDF файлы непосредственно из 1С, не используя при этом сторонних программ. Прекрасно работает на сервере, тонком клиенте и веб-клиенте. Основана на проекте PDFium из состава проекта Chromium/Chrome

1500 руб.

17.09.2018    35607    110    127    

113

Внешняя компонента для сканирования (замена TWAIN-компоненты БСП) (Native Win 32/64)

Разработка внешних компонент Программист Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 Платные (руб)

Внешняя компонента позволяет работать c TWAIN-совместимым оборудованием (сканерами, камерами) . Полностью совместима со стандартной TWAIN-компонентой из БСП и может применяться как ее замена без изменения вызовов, при этом может работать с 64-разрядной платформой, а так же имеет расширенную функциональность, например, сохранение результата непосредственно в PDF без использования сторонних утилит. Прекрасно работает на сервере, тонком клиенте и веб-клиенте (проверена работа в браузерах Google Chrome, Mozilla Firefox и Microsoft Internet Explorer).

3000 руб.

12.05.2020    26834    134    98    

85

GGraphics - внешняя компонента для работы с картинками jpg (jpeg), png, bmp, gif, tif

Разработка внешних компонент Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Позволяет автоматизировать работу с картинками. С помощью компоненты можно измерять размер изображений, поворачивать их, наносить водяные знаки, конвертировать из одного формата в другой. Будет очень полезна для интернет-магазинов и всех, кому постоянно требуется работать с различными графическими форматами. Выполнена по технологии NativeAPI. Работает с форматами: jpg (jpeg), png, bmp, gif, tif

3600 руб.

02.09.2010    76380    71    255    

189

Внешняя компонента для подключения 1С к телефонии Asterisk

Разработка внешних компонент Телефония, SIP Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Внешняя компонента выполнена по технологии Native API для 1С 8.х, обеспечивает доступ к программным АТС Asterisk (FreePBX, Elastix) через AMI интерфейс. Через него можно управлять многими функциями Asterisk (определение номеров, перевод звонков, набор телефона и т. д.)

2400 руб.

04.05.2018    45696    117    66    

61

Внешние компоненты 1С и язык C++

Разработка внешних компонент Механизмы платформы 1С Программист Стажер Платформа 1С v8.3 Бесплатно (free)

Некоторые практические аспекты создания внешних компонент на языке С++ для платформы 1С 8.3++.

26.01.2024    5439    starik-2005    32    

40

Внешняя компонента для работы с Apach Kafka

Инструментарий разработчика Разработка внешних компонент Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Пример взаимодействия 1С с Apach Kafka посредством внешней компоненты, разработанной на основе официальной библиотеки librdkafka (the Apache Kafka C/C++ client library).

22.11.2023    3314    70    ivan1703    26    

41

Внешняя компонента GraphQL клиент для 1С

Разработка внешних компонент Программист Платформа 1С v8.3 Платформа 1C v8.2 Платные (руб)

Внешняя компонента, позволяющая посылать команды и получать ответы по GraphQL протоколу из 1С.Может быть использована при интеграции. В 1С работает на стороне "клиента".

4600 руб.

27.06.2023    2915    1    0    

2
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. scorpionkgma 7 25.06.16 05:17 Сейчас в теме
Я не часто появляюсь на данном сайте, но очень уважаю мнение участников этого форума (не почтите за лесть :) ) Поэтому хотелось бы узнать мнение участников - есть ли спрос на подобные вещи. Стоит ли развивать данное направление (переделать например на COM объект)?
2. rinik88 32 29.11.16 16:17 Сейчас в теме
3. drmaxart 146 07.03.17 00:20 Сейчас в теме
4. details 2 13.03.18 12:02 Сейчас в теме
Данная компонента может сохранять видео?
Оставьте свое сообщение