Пример создания мобильного приложения в 1С с нуля

19.08.16

Разработка - Мобильная разработка

В данной статье мы создадим мобильное приложение для повышения продуктивности по «помидорной» технологии под ОС Android и ОС iOS. По ходу создания, мы реализуем таймер средствами 1С, реализуем программный вывод анимированной диаграммы на форму («Поле диаграммы» управляемой формы), также работу с PUSH-уведомлениями на мобильном устройстве, показ рекламы в приложении и работу со встроенными покупками.

Скачать исходный код

Наименование Файл Версия Размер
Файл конфигурации мобильного приложения Pomodoro
.cf 165,71Kb
89
.cf 165,71Kb 89 Скачать

Позволю напомнить - метод Pomodoro заключается в делении вашего рабочего времени на 25-минутные отрезки, называемые «помидорами», между которыми вы можете позволить себе отдых в течение 5 минут. Вы должны работать без отвлечения 25 минут, затем 5 минут отдохнуть и приниматься за следующий рабочий «помидор». После четырёх таких отрезков — отдых на целых 15 минут.

Описание «Помидорной» техники несколько странное, но стоит её попробовать, и Вы убедитесь, что это отличный способ повышения продуктивности работы.

Здесь вы можете скачать файл конфигурации, приложение для ОС Android расположено на сайте http://www.mykib.org/article/primer-sozdaniya-mobilnogo-prilozheniya-v-1s-s-nulya и в Google Play https://play.google.com/store/apps/details?id=org.mykib.pomodoro


Создание конфигурации для мобильного приложения

Создадим новую «пустую» базу. Дадим имя конфигурации «Pomodoro». Обязательно укажем свойство «назначение использования» - «Мобильное приложение»

 

 

а в свойстве «Требуемые разрешения мобильного приложения» установим флажки «Локальные уведомления» и «Встроенные покупки»

 

 

Создадим регистр сведений, в котором будет храниться информация о «полученных» помидорах (количество законченных отрезков времени, в течение которого пользователь продуктивно работал)

 

 

Таймер средствами 1С

В обработке можно запустить таймер и дождаться окончания его работы, либо остановить таймер. В первом случае пользователь получит PUSH-уведомление о том, что он заработал очередной помидор (запись в регистр сведений «Помидоры»), во втором случае PUSH-уведомление о том, что помидор не получен (запись в регистр не производится).

Также на форме в процессе работы таймера будет показан индикатор, выполняться обратный отсчет и показываться текущее время и время окончания работы таймера

Создадим обработку Таймер и основную форму

 

 

Для формы создадим команду «Запустить таймер», обработчик действия (нажатие):

&НаКлиенте
Процедура ЗапуститьТаймер(Команда)
    
    Элементы.ФормаОстановитьТаймер.Доступность = Истина;
    Элементы.ФормаЗапуститьТаймер.Доступность = Ложь;
    
    КоличествоМинут = 25;
    
    МаксимальноеЗначение = КоличествоМинут * 60;
    
    Элементы.Индикатор.МинимальноеЗначение = 0;
    Элементы.Индикатор.МаксимальноеЗначение = ЭтотОбъект.МаксимальноеЗначение;
    
    ЭтотОбъект.Начало = ТекущаяДата();
    ЭтотОбъект.Конец = Начало + МаксимальноеЗначение;
    
    ЭтотОбъект.ТекущаяДата = ТекущаяДата();
    
    ПодключитьОбработчикОжидания("ВыполнитьОтсчет", 1);
    
КонецПроцедуры

И команду «ОстановитьТаймер», обработчик действия (нажатие):

&НаКлиенте
Процедура ОстановитьТаймер(Команда)
    
    Элементы.ФормаОстановитьТаймер.Доступность = Ложь;
    Элементы.ФормаЗапуститьТаймер.Доступность = Истина;
    
    ОтключитьОбработчикОжидания("ВыполнитьОтсчет");
    
    #Если МобильноеПриложениеКлиент Тогда
    Уведомление = Новый ДоставляемоеУведомление;
    Уведомление.Заголовок = "К сожалению, Вы не получите помидор.";
    Уведомление.Текст = "К сожалению, Вы не получите помидор.";
    Уведомление.ЗвуковоеОповещение = ЗвуковоеОповещение.ПоУмолчанию;
    ДоставляемыеУведомления.ДобавитьЛокальноеУведомление(Уведомление);
    ДоставляемыеУведомления.ПодключитьОбработчикУведомлений("ПриПолученииУведомления");
    #Иначе
    Сигнал();
    Сообщение = Новый СообщениеПользователю;
    Сообщение.Текст = "К сожалению, Вы не получите помидор.";
    Сообщение.Сообщить();
    #КонецЕсли
    
КонецПроцедуры

В этих процедурах подключается (либо отключается) обработчик ожидания «ВыполнитьОтсчет», а также выполняется работа с PUSH-уведомлениями

Уведомление = Новый ДоставляемоеУведомление;

Код процедуры обработчика ожидания ВыполнитьОтсчет»:

&НаКлиенте
Процедура ВыполнитьОтсчет()
    
    Если ЭтотОбъект.ТекущаяДата <= ЭтотОбъект.Конец Тогда
        
        ЭтотОбъект.Индикатор = ЭтотОбъект.ТекущаяДата - ЭтотОбъект.Начало;        
        ЭтотОбъект.ТекущаяДата = ТекущаяДата();       
        ОсталосьАбсолютно = ЭтотОбъект.МаксимальноеЗначение - ЭтотОбъект.Индикатор;       
        ЭтотОбъект.Осталось = "" + Формат(Цел(ОсталосьАбсолютно / 60), "ЧЦ=2; ЧН=00; ЧВН=") + ":" + Формат(ОсталосьАбсолютно - Цел(ОсталосьАбсолютно / 60) * 60, "ЧЦ=2; ЧН=00; ЧВН=");       
        ЭтотОбъект.ОбновитьОтображениеДанных();
        
    Иначе
        
        ЭтотОбъект.Индикатор = МаксимальноеЗначение;
        ЭтотОбъект.ТекущаяДата = ЭтотОбъект.Конец;
        ЭтотОбъект.Осталось = Формат(0, "ЧЦ=2; ЧН=00; ЧВН=") + ":" + Формат(0, "ЧЦ=2; ЧН=00; ЧВН=");
        
        #Если МобильноеПриложениеКлиент Тогда
        Уведомление = Новый ДоставляемоеУведомление;
        Уведомление.Заголовок = "Вы собрали еще один помидор.";
        Уведомление.Текст = "Вы собрали еще один помидор. Отдохните " + ПолучитьКоличествоМинутОтдыхаНаСервере(ЭтотОбъект.ТекущаяДата) + " минут.";
        Уведомление.ЗвуковоеОповещение = ЗвуковоеОповещение.ПоУмолчанию;
        ДоставляемыеУведомления.ДобавитьЛокальноеУведомление(Уведомление);
        ДоставляемыеУведомления.ПодключитьОбработчикУведомлений("ПриПолученииУведомления");
        #Иначе
        Сигнал();
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Вы собрали еще один помидор. Отдохните " + ПолучитьКоличествоМинутОтдыхаНаСервере(ЭтотОбъект.ТекущаяДата) + " минут.";
        Сообщение.Сообщить();
        #КонецЕсли   
        
        Элементы.ФормаОстановитьТаймер.Доступность = Ложь;
        Элементы.ФормаЗапуститьТаймер.Доступность = Истина;
        
        ОтключитьОбработчикОжидания("ВыполнитьОтсчет");
        
    КонецЕсли;
    
КонецПроцедуры

&НаСервере
Функция ПолучитьКоличествоМинутОтдыхаНаСервере(Дата)
    
    //Занесем запись в регистр
    РС = РегистрыСведений.Помидоры.СоздатьМенеджерЗаписи();
    РС.Активность = Истина;
    РС.Количество = 1;
    РС.Период = Дата;
    РС.Записать();
    
    //по умолчанию 5 минут
    //после каждого 4-го помидора в день - 15 минут
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
        |	СУММА(Помидоры.Количество) КАК Количество
        |ИЗ
        |	РегистрСведений.Помидоры КАК Помидоры
        |ГДЕ
        |	Помидоры.Период МЕЖДУ НАЧАЛОПЕРИОДА(&Период, ДЕНЬ) И КОНЕЦПЕРИОДА(&Период, ДЕНЬ)";
    
    Запрос.УстановитьПараметр("Период", Дата);
    
    Результат = Запрос.Выполнить().Выгрузить();
    
    Если Результат.Количество() > 0 Тогда
        
        Сумма = Результат[0].Количество;        
        Если Цел(Сумма / 4) = (Сумма / 4) Тогда

            Возврат 15;
            
        КонецЕсли;
        
    КонецЕсли;
    
    Возврат 5;
    
КонецФункции

Вывод PUSH-уведомлений реализуется так:

&НаКлиенте
Процедура ПриПолученииУведомления(Уведомление, Локальное, Показано) Экспорт
    Если Локальное Тогда
        Сообщить(Уведомление.Текст);
    КонецЕсли;
КонецПроцедуры

В коде выполняется управление доступностью кнопок запуска и остановки таймера в зависимости от его состояния (запущен таймер, либо остановлен) – осталось установить первоначальную видимость этих кнопок при открытии формы:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    Элементы.ФормаОстановитьТаймер.Доступность = Ложь;
    Элементы.ФормаЗапуститьТаймер.Доступность = Истина;
    
КонецПроцедуры


Статистика – диаграмма

Создадим обработку Статистика и основную форму

 

 

Полную реализацию Вы можете посмотреть во вложенном файле конфигурации. Сейчас рассмотрим программный вывод анимированной диаграммы на форму

Инициализация:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    Для Каждого Стр Из ТипДиаграммы Цикл
        Элементы.ВидДиаграммы.СписокВыбора.Добавить(Стр, Стр, , ); //Статистика
        Элементы.ВидДиаграммыПродуктивность.СписокВыбора.Добавить(Стр, Стр, , ); //Продуктивность
    КонецЦикла;
    
    //Статистика
    Период.Вариант = ВариантСтандартногоПериода.ЭтаНеделя;
    Периодичность = "ДЕНЬ";
    
    ВидДиаграммы = ТипДиаграммы.Изометрическая;
    
    ОбновитьДиаграмму();
    
    //Продуктивность
    ПериодПродуктивность.Вариант = ВариантСтандартногоПериода.ЭтаНеделя;
    ПериодичностьПродуктивность = "ДЕНЬНЕДЕЛИ";
    
    ВидДиаграммыПродуктивность = ТипДиаграммы.Изометрическая;
    ОбновитьДиаграммуПродуктивность();
    
    
КонецПроцедуры

Вывод диаграммы:

&НаКлиенте
Процедура ВидДиаграммыПриИзменении(Элемент)
    ОбновитьДиаграмму();
КонецПроцедуры

&НаСервере
Процедура ОбновитьДиаграмму()
    
    // Очистить диаграмму, возможно ранее в нее уже выводились данные.
    Диаграмма.Очистить();
    
    //Диаграмма.ОбластьЗаголовка.Текст = "Статистика собранных помидоров";
    
    //Диаграмма.МаксимумСерий = МаксимумСерий.Ограничено;
    //Диаграмма.МаксимумСерийКоличество = 7;
    
    // Запретить обновление диаграммы на время вывода данных.
    Диаграмма.Обновление = Ложь;
    
    //Диаграмма.Анимация = АнимацияДиаграммы.Использовать;
    Диаграмма.ТипДиаграммы = ?(ВидДиаграммы <> Неопределено, ВидДиаграммы, ТипДиаграммы.ГистограммаОбъемная); //ТипДиаграммы.ГистограммаОбъемная;
    
    // Установить единственную точку.
    Диаграмма.КоличествоТочек = 1;
    Диаграмма.Точки[0].Текст = "Количество";
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
        |	НАЧАЛОПЕРИОДА(Помидоры.Период, ДЕНЬ) КАК Период,
        |	СУММА(Помидоры.Количество) КАК Количество
        |ИЗ
        |	РегистрСведений.Помидоры КАК Помидоры
        |ГДЕ
        |	Помидоры.Период МЕЖДУ &НачалоПериода И &КонецПериода
        |
        |СГРУППИРОВАТЬ ПО
        |	НАЧАЛОПЕРИОДА(Помидоры.Период, ДЕНЬ)
        |
        |УПОРЯДОЧИТЬ ПО
        |	Период";
    
    
    Запрос.Текст = СтрЗаменить(Запрос.Текст, "ДЕНЬ", Периодичность);
    
    Запрос.УстановитьПараметр("НачалоПериода", Период.ДатаНачала);
    Запрос.УстановитьПараметр("КонецПериода", Период.ДатаОкончания);
    
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    
    ФорматнаяСтрока = "ДФ=dd.MM.yyyy";
    
    Если Периодичность = "МЕСЯЦ" Тогда
        ФорматнаяСтрока = "ДФ=MMMM.yyyy";
    ИначеЕсли Периодичность = "ГОД" Тогда
        ФорматнаяСтрока = "ДФ=yyyy";
    КонецЕсли;
    
    Пока Выборка.Следующий() Цикл
        
        КоличествоСерий = Диаграмма.Серии.Количество();
        Диаграмма.КоличествоСерий = КоличествоСерий + 1;
        
        Диаграмма.Серии[КоличествоСерий].Текст = Формат(Выборка.Период, ФорматнаяСтрока);
        Диаграмма.УстановитьЗначение(0, КоличествоСерий, Выборка.Количество);
        
    КонецЦикла;
    
    Диаграмма.ОбластьЛегенды.Прокрутка = Истина;
    
КонецПроцедуры


Управление рекламой

Для управления рекламой используется свойство глобального контекста «ОтображениеРекламы»

Реклама будет выводиться в виде рекламного баннера вверху, либо внизу (свойство «ОтображениеРекламногоБаннера») окна приложения:

 

 

Включение показа рекламного баннера реализуем в Модуле управляемого приложения в процедуре ПриНачалеРаботыСистемы():

Процедура ПриНачалеРаботыСистемы()
    
    Если СлужебныйВызовСервера.ПоказыватьРекламу() Тогда
        #Если МобильноеПриложениеКлиент ИЛИ МобильноеПриложениеСервер Тогда
        ОР = ОтображениеРекламы;
        ОР.УстановитьИспользование(Истина);
        ОР.SetAdBannerID("ca-app-pub-1356011826682846/4780285411");
        ОР.УстановитьОтображениеРекламногоБаннера(ОтображениеРекламногоБаннера.Верх);
        #КонецЕсли
    КонецЕсли;
    
КонецПроцедуры

В строке ОР.SetAdBannerID("ca-app-pub-1356011826682846/4780285411") в параметре процедуры SetAdBannerID укажите Идентификатор рекламного блока, полученный в AddMod (https://apps.admob.com)

 

 

Управление покупками

Управление покупками выполняется в следующей последовательности:

ВП = ВстроенныеПокупки;
ВП.НачатьПриобретение();
ВП.ИзрасходоватьПокупку();
ОплатаПроизведена = ВП.НачатьПриобретение();

 

См. также

"Штрихкод-информер" - мобильный ТСД и прайс-чекер в смартфоне

Мобильная разработка Сканер штрих-кода Терминал сбора данных Управляемые формы Мобильная платформа 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Сбор заказов, инвентаризация, проверка ценников, просмотр полной информации об остатках и ценах со смартфона Онлайн. Отправка данных со смартфона выполняется либо напрямую в открытую форму документа, отсканировав QR-код, либо в общую корзину учетной системы, не подходя к компьютеру. Кассир или оператор сможет просмотреть список присланных данных и загрузить в любую форму, поддерживающую работу с ТСД. Для работы с мобильным приложением требуется опубликовать HTTP-сервис из поставляемого расширения.

2880 руб.

03.12.2018    55775    166    102    

163

SALE! 25%

Что нам стоит бота построить? Нарисуем - будет жить! Графический конструктор телеграм-ботов/Telegram

Мобильная разработка Мессенджеры и боты Платформа 1С v8.3 Платные (руб)

Теперь создать telegram-бота - элементарно. Достаточно просто нарисовать блок-схему телеграм-бота, и он сразу заработает. Это возможно при использовании Графического конструктора телеграм-ботов. Это единственный конструктор ботов для telegram, чье качество и функционал подтверждены фирмой 1С, есть сертификат 1С:Совместимо. Расширение в интерактивном режиме, с помощью блок-схем, позволяет с минимальными трудозатратами создать телеграм-ботов в любой конфигурации, работающей на платформе «1С:Предприятие 8.3».

13200 9900 руб.

27.12.2021    34448    86    161    

181

"Мобильный ТСД" - инвентаризация и сбор штрихкодов для iOS и Android

Сканер штрих-кода Терминал сбора данных Мобильная разработка Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Платформа 1С v8.3 Мобильная платформа 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Простой мобильный терминал сбора данных для смартфонов на iOS и Android, не требующий сложных настроек и установки дополнительных программ. Обмен между Вашей 1С и мобильным приложением осуществляется через облачный сервис и расширение конфигурации. Работает с конфигурациями УТ 11, ERP, КА2, Розница 2, Розница 3, УНФ 1.6, УНФ 3.0. Полнофункциональный демо-доступ для своей конфигурации можно запросить в настройках мобильного приложения - все необходимое придет на почту автоматически.

2000 руб.

22.04.2019    92981    532    186    

302

Склад 15 ВЕЩЕВОЙ - автоматизация складов с маркированным товаром

Логистика, склад и ТМЦ Мобильная разработка Платформа 1С v8.3 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

Программное обеспечение для автоматизации складских операций со встроенными функциями работы с маркированной продукцией. Предназначено для автоматизации всех товароучетных операций на складах, обычных и адресного хранения. «Склад 15 ВЕЩЕВОЙ» объединил в себе несколько товарных групп маркированного товара (ОБУВЬ, ОДЕЖДА, ШИНЫ, ПАРФЮМ, БАДы, ЮВЕЛИРНЫЕ ИЗДЕЛИЯ), которые чаще всего встречаются в складской логистике вместе.

33550 руб.

02.06.2023    3129    2    0    

0

Магазин 15 - приемка товара по штрихкодам или инвентаризация в торговом зале

Логистика, склад и ТМЦ Мобильная разработка Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Розничная и сетевая торговля (FMCG) Россия Платные (руб)

Специализированное программное обеспечение для мобильных устройств со встроенным сканером штрихкодов. Позволяет быстро автоматизировать, оптимизировать рабочие места и бизнес процессы по учету товара в магазине. Например, приемку товара по штрихкодам или инвентаризацию прямо в торговом зале.

12950 руб.

30.05.2023    3543    2    0    

4

Мобильная торговля для Android

Розничная торговля WEB-интеграция Мобильная разработка Мобильная платформа Управленческий учет Платные (руб)

Сис­те­ма поддержки мо­биль­ной тор­гов­ли это про­грам­м­ный ком­плекс, раз­ра­бо­тан­ный для ав­то­ма­ти­за­ции ра­бо­ты тор­го­вых пред­ста­ви­те­лей, за­ни­ма­ю­щих­ся сбо­ром за­ка­зов на смартфонах в точ­ках роз­нич­ной тор­гов­ли, про­да­жей то­ва­ра с ко­лес и мер­чен­дай­зин­гом.

4800 руб.

19.02.2008    42342    24    24    

40

Работа с графикой в браузере (SimpleWEB). Векторный редактор

Мобильная разработка WEB-интеграция Мобильная платформа Абонемент ($m)

В SimpleWEB добавились средства для работы с графикой и отслеживание событий мыши, в онлайн редактор https://seditor.ru:1555/ добавился «Векторный редактор» на этом API. Теперь можно нарисовать схемы складов на ПК, сделать карты (*.sug-файлы) для мобильной платформы SimpleUI, выводить данные из 1С в графическом виде. Таким образом, API для работы с векторными файлами теперь есть и в веб- и в мобильной платформе, а также средства для создания и редактирования векторных файлов есть тоже в обеих платформах.

1 стартмани

20.03.2024    1760    1    informa1555    1    

42
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. DitriX 2096 20.08.16 19:38 Сейчас в теме
У меня на курсах, что бы объяснить это - ушел не один час, особенно про AdMob и про push в iOS :)
А вы тут уложились в пару страниц :) Оставив все самое интересное и сложное - за занавесом :)
Не хорошо так статьи писать.
user2024516; user1068140; wolder; Sikh; Gendelf; Craig; wowik; jig; dsdred; Zircool; maksa2005; dj_serega; Andrew_1C; Dimtok; nomadon; Dach; +16 Ответить
2. Константин С. 668 23.08.16 16:54 Сейчас в теме
Оставив все самое интересное и сложное - за занавесом :)

(1) DitriX, за сложное ты берешь деньги. Автор выдал направление как делается. Реально это нужно 1 или менее процента, остальным для общего развития хвати и этого объема.
user1395171; simuljakr; UnashevRM; rrustam11983; Mechanik21; Gendelf; pvlunegov; strange2007; wowik; SmArtist; nbondarenko; SirAlexIT; aparinp; spiteful41; rpgshnik; headMade; +16 Ответить
9. DitriX 2096 11.09.16 00:01 Сейчас в теме
(2) Константин С., Никто же не говорит что я сама щедрость. Я просто к тому, что если уж и писать статьи, то не оставлять самое интересное закулисами. Я так статьи не пишу, между прочим, а стараюсь выжать максимум из темы.
А на счет того, что я беру деньги за самое интересное - это да, каюсь. Но вот только я еще и экономлю время и нервы:)
kild; Liris; dbachinsky; tindir; dj_serega; +5 Ответить
3. zekrus 151 24.08.16 07:50 Сейчас в теме
Доброе утро!
Тема очень актуальная.
А нет подробного руководства для компиляции мобильного приложения под iOS?
С уважением
4. METAL 294 24.08.16 09:39 Сейчас в теме
5. a3a3elloxxxx 24.08.16 10:07 Сейчас в теме
Вопрос к знатокам мобильной 1С. Возможен ли такой вариант использования 1С. Есть файловая база 1С. Кидаем ее на DropBox или яндекс диск и работаем то с мобилы то с планшета а то с десктопа. Понятно, что формы для мобилы и десктопа надо делать разные, главное что бы данные можно было набивать с разных устройств.
privin731; +1 Ответить
6. flyer 232 25.08.16 05:39 Сейчас в теме
(5) a3a3elloxxxx, зачем так усложнять? и для чего это необходимо. арендуете сервер и с него настраиваете подключение. база будет в облаке фактически а моб.приложение будет подключаться к ней.
privin731; +1 Ответить
7. a3a3elloxxxx 25.08.16 14:57 Сейчас в теме
(6) flyer,
Арендовать сервер как раз сложнее и дороже чем кинуть пару файлов на диск.
pvlunegov; A7_Sash; Gorus; bow; +4 Ответить
23. s_vidyakin 63 13.09.18 11:46 Сейчас в теме
(7) А Firebase вас не спасает?
8. Константин С. 668 31.08.16 09:10 Сейчас в теме
(5) a3a3elloxxxx, Нет одновременная работа с одной базой Мобайл - Десктоп нельзя. Нужно два приложение и далее на уровне обменов. Или как сказали ранее сервер + web, если на 1-2 пользователе ценав выделенного сервера на Линуксе в приемлема.
privin731; +1 Ответить
11. awk 742 04.10.16 13:38 Сейчас в теме
(5) a3a3elloxxxx, Нет. Такой вариант невозможен.
privin731; +1 Ответить
10. vano-ekt 124 04.10.16 13:27 Сейчас в теме
самое интересное в конфигураторе и не напишешь...
да и политика по распространению приложений пока не вдохновляет писать даже учетные программки на 1С для этих ваших Плэймаркетов/Аппсторов
где-то же они озвучивали, что начиная от 50 пользователей/скачек распространение возможно только по соглашению с 1С
такшта АндроидСтудио пока наше всё
pvlunegov; privin731; +2 Ответить
22. aparinp 52 12.09.18 16:43 Сейчас в теме
(10) Не совсем так
При бесплатном распространении мобильного приложения, созданного на платформе "1С:Предприятие", среди третьих лиц через магазины приложений AppStore, Google Play и Windows Store и любыми другими способами, заключение лицензионного договора с фирмой "1С" не требуется, никаких финансовых обязательств перед "1С" у разработчика не возникает, а вот для установки и использования мобильных приложений, созданных на платформе "1С:Предприятие", на мобильных устройствах своих сотрудников, организация должна приобрести клиентскую лицензию на соответствующее количество мобильных рабочих мест.

Источники:
Мобильная платформа 1С: лицензионная политика
О правилах распространения и использования мобильных приложений, разработанных на платформе "1С:Предприятие", для использования сотрудниками одной организации-пользователя "1С"
28. Region102 13.09.18 15:44 Сейчас в теме
(10) Пусть АндроидСтудио визуализацию лайоутов допилят до нормального состояния, а так есть задачи, где 1С использовать выгоднее в разы, чем писать нативное приложение. А расширить возможности можно внешними компонентами.
12. Aphanas 92 05.10.16 04:47 Сейчас в теме
Как этот .cf в телефон затолкать, непонятно
kild; privin731; +2 Ответить
13. VovkaBo 06.10.16 17:46 Сейчас в теме
(12) Aphanas,
cf никак. Ищи сборщик мобильных приложений, загружай туда cf, собирай мобильное приложение, получишь apk. Его и кидаешь в телефон.
Gendelf; privin731; +2 Ответить
15. silver_a 16.02.17 08:49 Сейчас в теме
(12) как вариант - установить мобильную платформу на смартфон, установить апач, опубликовать cf-ку и таким образом загрузить. я так использую. Вот тут есть пошаговое описание.
privin731; +1 Ответить
25. Region102 13.09.18 15:22 Сейчас в теме
(12) Посмотри на моем канале, много вопросов отпадет, еще больше появится ) https://www.youtube.com/watch?v=e4mq2I8wtU4&list=PLkvJd0RKh5mkt3hA-ttps0ewqp9b3YAKm
14. silver_a 16.02.17 08:05 Сейчас в теме
Интересное приложение. Но только вот при блокированном экране и при свёрнутом режиме приложения - локальные сообщения выходят через раз или просто вибрирует без вывода сообщений. Так должно быть или это ошибка? Конфа эта без изменений, версия мобильной платформы 8.3.9.74.
privin731; +1 Ответить
16. user754495 14.06.17 13:27 Сейчас в теме
Скажите пожалуйста как сделать чтобы у графика рядом с точкой выводить значение ?
privin731; +1 Ответить
17. d.zhukov 1407 11.10.17 12:32 Сейчас в теме
Забавно написано. Ожидал, что в статье будет пошаговое описание от внесения кода в модули до публикации приложения в маркетах. Первый этап вроде есть, а потом прыг-скок и автор пишет о получении итогового кэша с рекламы) где основная инфа о муках компиляции и размещении приложения?))
Gendelf; privin731; +2 Ответить
26. Region102 13.09.18 15:24 Сейчас в теме
(17) Есть видео по сборке, но пока без выкладывания в маркет, подписывайся https://www.youtube.com/watch?v=e4mq2I8wtU4&list=PLkvJd0RKh5mkt3hA-ttps0ewqp9b3YAKm
18. privin731 11.06.18 17:01 Сейчас в теме
Отличная статья! Огромное спасибо Автору! По этой статье пытаюсь повторить. И вот получил такую ошибку:

{Обработка.Таймер.Форма.Форма.Форма(47,1)}: Неопознанный оператор
<<?>>&НаКлиенте
Мобильное приложение содержит синтаксические ошибки.
Прикрепленные файлы:
19. privin731 11.06.18 17:16 Сейчас в теме
К сожалению, не могу скачать файл конфигурации, так как нет денег. Я только учусь. Но очень хочу запустить эту конфигурацию. Сожалею, что не могу скачать, хотя радует статистика Просмотры 21389 Загрузки 50 . Убедительная просьба, пожалуйста, помогите мне.
Прикрепленные файлы:
20. privin731 12.06.18 17:42 Сейчас в теме
Спасибо всем! Всё решил сам. Статья действительно очень замечательная!!!
21. oleshko_alexey 2 12.09.18 15:32 Сейчас в теме
24. Luchik 675 13.09.18 13:10 Сейчас в теме
(21) Этой публикации более двух лет - google удалил приложение, т.к. за это время поменялись какие-то правила по возрастным ограничениям, на которые я не стал обращать внимания. Но apk-файл у меня остался
27. Region102 13.09.18 15:38 Сейчас в теме
Я тут интенсив пишу по разработке корпоративного мобильного приложения с нуля, так уже часов на 6-8 тянет, и это все вырезал что смог, а тут статья на пару листов. При этом у меня нет ни монетизации, ни push, ни других возможностей, ни сборки, ни публикации. Чистый кодинг несколько часов подряд.

Вообще банеры решение спорное для монетизации в 1С, лучше уж подписка, а еще лучше бесплатное приложение ограниченное, и полноценное платное. Так как подписки и банеры уже многих начинают бесить неимоверно.
Fox-trot; +1 Ответить
29. YanTsys 12 14.09.18 09:19 Сейчас в теме
(27)
Так как подписки и банеры уже многих начинают бесить неимоверно.

Разве не в этом основное назначение бесплатной версии :))))
30. Region102 14.09.18 11:36 Сейчас в теме
(29) Вы можете ограничить программно количество помидоров, допустим 4 и это будет бесплатная версия. А в платной трекер задач с синхронизацией в облако и еще какие-нибудь плюшки.
31. YanTsys 12 14.09.18 15:23 Сейчас в теме
(30) Понятное дело :) Это самые распространенные методы, метод пряника, и метод кнута...

Идет человек по бульвару, видит сидят два нищих, у одного табличка "Подайте бедному Василию" а у второго "Подайте бедному Абраму" толпа людей идет смотрит на таблички и все кидают монеты Василию с ехидцей поглядывая на Абрама. Сжалился прохожий подошел к Абраму и говорит: "Ну зачем ты сидишь с такой табличкой, напиши просто "Подайте на еду" или что нибудь еще"
На что Абрам оборачивается ко второму нищему и говорит: "Слышишь Мойша? Этот поц еще будет нас бизнесу учить" :)
32. nextkmv 129 17.09.18 11:55 Сейчас в теме
Кто нибудь использовал мобильную платформу в реальных условиях корпоративной среды?
Как ведет себя мобильная платформа если к примеру мы выгрузили на мобильное устройство справочники номенклатуры с несколькими тысячами наименованиями с остатками и ценами?
Как обстоят дела с производительностью с бюджетными устройствами(планшет 7 дюймов стоимостью до 10 000 рублей)?
Как отзываются пользователи о производительности, удобстве интерфейсов, скорости полнотекстового поиска?
33. zavsom 104 28.05.19 22:56 Сейчас в теме
скажите пожалуйста . а как можно нескольким людям одновременно работать в одном мобильном приложении с разных телефонов - вообще в 1с такое реализовано или это пока что фантастика? Ну чтобы база лежала на сервере а к ней десять пользователей через мобилы с разными операционными системами одновременно подключались и что то делали - один накладные печатает. другой их правит. третий справочник корректирует и т.д. ?
34. KTo 29.04.20 04:56 Сейчас в теме
(33) в 1С для этого придумали мобильный клиент.
35. Rif_md 6 09.08.20 11:25 Сейчас в теме
До блока "Управление рекламой" было интересно. А потом возникло ощущение, что приложение создается исключительно для монетизации от рекламы. В программах учёта это конечно архиважно.
36. GetNight 47 27.01.21 16:42 Сейчас в теме
(35) Тот самый случай, когда "немыслимое" при СССР, стало "обыденным" при "свободном" недокапитализме.
Окна Овертона сделали своё дело... Все мыслят категориями "деньги понад усе!"
37. viki_glebova 24.07.21 07:29 Сейчас в теме
Добрый день. Подскажите, пожалуйста, как вывести локальное уведомление в нужное время?
Вот тут ведем обсуждение. Пока результатов нет
https://forum.infostart.ru/forum92/topic266244/#message2689714
Оставьте свое сообщение