Массовая печать документов

17.12.16

Задачи пользователя - Пакетная печать

Печать или сохранение документов всех типов, у которых есть печатная форма.

Скачать файлы

Наименование Файл Версия Размер
Массовая печать любого вида
.epf 17,22Kb
5
.epf 17,22Kb 5 Скачать

По просьбе бухгалтеров была написана эта обработка. Умеет печатать или сохранять печатные формы документов. Предлагает на выбор печать на принтер, вывод на экран или сохранение в указанный каталог, Есть возможность задать формат (PDF,DOCX,XLS,XLSX) в котором сохранить печатную форму. Обработка не притендует на универсальность, так как требует внесения изменений в конфигурацию.

// Общий модуль - Универсальные механизмы
//
Процедура НапечататьДокумент(ПечДокумент, КоличествоЭкземпляров = 1, НаПринтер = Ложь, Заголовок = "", НепосредственнаяПечать = Ложь, Ссылка = Неопределено, ИмяМакета = "") Экспорт

	Если ПечДокумент = Неопределено тогда
		Возврат;
	КонецЕсли;

	// Получить необходимое количество копий
	Если КоличествоЭкземпляров > 0 Тогда
		ПечДокумент.КоличествоЭкземпляров = КоличествоЭкземпляров;
	КонецЕсли;

	Если НЕ ПечДокумент.АвтоМасштаб
	   И НЕ ЗначениеЗаполнено(ПечДокумент.ИмяПринтера) Тогда
		ПечДокумент.АвтоМасштаб = Истина;
	КонецЕсли;

	Если ТипЗнч(НаПринтер) = Тип("Булево") Тогда
		Если НаПринтер Тогда
			ПечДокумент.Вывод = ИспользованиеВывода.Разрешить;
			ПечДокумент.Напечатать(НепосредственнаяПечать = Истина);
		Иначе
			ФормаПечати = ПолучитьОбщуюФорму("ФормаПечати",, Заголовок + ИмяМакета + Ссылка);
			ФормаПечати.Документ = Ссылка;
			ФормаПечати.Заголовок = Заголовок;
			ФормаПечати.ИмяМакета = ИмяМакета;
			ФормаПечати.ПечатныйДокумент = ПечДокумент;
			ФормаПечати.Открыть();

		КонецЕсли;
	ИначеЕсли ТипЗнч(НаПринтер) = Тип("СписокЗначений") Тогда		
		Каталог = НаПринтер.Получить(0).Значение;
		Формат = НаПринтер.Получить(1).Значение;
		ИмяФайла = НаПринтер.Получить(2).Значение;
		
		ПечДокумент.Записать(Каталог+ИмяФайла,Формат);
	ИначеЕсли ТипЗнч(НаПринтер) = Тип("Массив") Тогда
		ПечДокумент.Вывод = ИспользованиеВывода.Разрешить;
		ПечДокумент.Напечатать(НепосредственнаяПечать = Истина);
		
		НаПринтер.Добавить(ПечДокумент);
	ИначеЕсли ТипЗнч(НаПринтер.Значение) = Тип("Строка") Тогда	
		Если НаПринтер.Значение = "На экран (Предварительный просмотр)" тогда
			ФормаПечати = ПолучитьОбщуюФорму("ФормаПечати",, Заголовок + ИмяМакета + Ссылка);
			ФормаПечати.Документ = Ссылка;
			ФормаПечати.Заголовок = Заголовок;
			ФормаПечати.ИмяМакета = ИмяМакета;
			ФормаПечати.ПечатныйДокумент = ПечДокумент;
			ФормаПечати.Открыть();

		Иначе	
			ПечДокумент.Имяпринтера = СокрЛп(НаПринтер);
			ПечДокумент.Вывод = ИспользованиеВывода.Разрешить;
			ПечДокумент.Напечатать(НепосредственнаяПечать = Истина);
		КонецЕсли;	
	КонецЕсли;
	
	//Если НаПринтер Тогда

	//	ПечДокумент.Напечатать(НепосредственнаяПечать = Истина);

	//Иначе

	//	// Отобразить печатный документ на экране
	//	//ФормаПечати = ПолучитьОбщуюФорму("ФормаПечати",, Новый УникальныйИдентификатор);
	//	ФормаПечати = ПолучитьОбщуюФорму("ФормаПечати",, Заголовок + ИмяМакета + Ссылка);
	//	ФормаПечати.Документ = Ссылка;
	//	ФормаПечати.Заголовок = Заголовок;
	//	ФормаПечати.ИмяМакета = ИмяМакета;
	//	ФормаПечати.ПечатныйДокумент = ПечДокумент;
	//	ФормаПечати.Открыть();

	//КонецЕсли;

КонецПроцедуры // НапечататьДокумент()

Проверял на работоспособнуть на платформе 8.2.19 и выше. Точно могу сказать на платформе 8.2.13 не работает так как нет поддержки PDF.

массовая печать

См. также

Infostart PrintWizard

Пакетная печать Печатные формы Инструментарий разработчика Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    6647    16    5    

36

Журнал учета ТТН (исходящих и от поставщика) для Бухгалтерии предприятия, редакция 3.0

Пакетная печать Документооборот и делопроизводство (СЭД) Оптовая торговля Печатные формы Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Обработка содержит новую форму Транспортной накладной с 01.01.2021 г. (в ред. Постановления Правительства РФ от 30.11.2021 № 2116) В отличие от внешних печатных форм, подключаемых к документу реализации, позволяет вести отдельный журнал документов. Дополнительным преимуществом является возможность формирования документов за поставщика.

2280 руб.

15.04.2014    52482    50    50    

38

Групповая печать чеков из банковской выписки с настройкой (БП 3.0)

Пакетная печать Банковские операции Кассовые операции Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Платные (руб)

Обработка для групповой печати чеков ККМ с настройкой, загруженных из банковской выписки. На основании документа Поступление на расчетный счет!

4800 руб.

21.08.2019    19785    69    10    

23

Групповая пакетная печать документов "Реализация товаров и услуг" и связанных с ними "Счетов-фактур"

Пакетная печать Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Работаете с сетями, у каждой из которых свои требования к оформлению документов? Клиент попросил перепечатать документы за год? Печатаете по 100-500 документов в день, тогда эта обработка Вам просто необходима. Данная обработка позволит Вам сэкономить время при больших объемах печати документов по отгрузке товаров и не только.

1000 руб.

29.09.2016    35763    20    5    

22

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    1919    17    progmaster    7    

3

Пакетная выгрузка стандартных бухгалтерских отчетов

Пакетная печать Регламентированный учет и отчетность Файловый обмен (TXT, XML, DBF), FTP Загрузка и выгрузка в Excel Платформа 1С v8.3 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Налоговый учет Платные (руб)

Быстрое формирование сразу нескольких видов стандартных бухгалтерских отчетов - .Анализ счета, Карточка счета, Оборотно-сальдовая ведомость по счету, Отчет по проводкам. В периоды проведения проверок со стороны ФНС в деятельности предприятий часто возникает необходимость предоставления сведений из бухгалтерского учета. Обработка сократит время на формирование отчетов бухгалтеру.

6000 руб.

30.03.2023    6047    4    0    

6

Печать на стороне сервера при помощи Ghostscript

Инструментарий разработчика Пакетная печать Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Пример выполнения печати на принтер на сервере 1С используя библиотеку Ghostscript

1 стартмани

17.10.2022    3863    18    prog-1s    1    

8

[Расширение] Печать "по умолчанию" для БП 3, ЗУП 3, УТ 11, КА 2, ERP 2

Пакетная печать Печатные формы Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Абонемент ($m)

Расширение с функционалом "печать по умолчанию" для форм документов и списков документов в режиме управляемого приложения для типовых распространенных конфигураций: Бухгалтерия 3.0 (базовая/проф/корп), Зарплата и управление персоналом 3, Управление торговлей 11, Комплексная автоматизация 2, ERP 2

2 стартмани

26.04.2022    3773    5    zhuravlev_as    12    

5
Оставьте свое сообщение