Отсчет секунд до Нового года

04.04.17

Разработка - Универсальные функции

В ожидании Нового года считаем часы и секунды до этого события=)

Скачать файлы

Наименование Файл Версия Размер
ТаймерДоНовогоГода
.epf 6,09Kb
1
.epf 6,09Kb 1 Скачать
Перем мСчет;

&НаКлиенте
Процедура Старт(Команда)
	мСчет = 0;
	ПодключитьОбработчикОжидания("Отсчет", 1);
КонецПроцедуры

&НаКлиенте
Процедура Стоп(Команда)
	ОтключитьОбработчикОжидания("Отсчет");
КонецПроцедуры

&НаКлиенте
Процедура Отсчет() 

	//мСчет = мСчет + 1;
	мСчет = КонецГода(ТекущаяДата()) - ТекущаяДата();
	Элементы.ЗначениеТаймера.Заголовок = Время(мСчет);
	ПоказатьОповещениеПользователя(Время(мСчет));

КонецПроцедуры // Отсчет()

&НаКлиенте
Функция Время(Значение)

	Если Значение < 60 Тогда
		Возврат Строка(Значение) + " сек.";
	ИначеЕсли Значение >= 60 И Значение < 60*60 Тогда 
		Возврат Строка(Цел(Значение/60)) + " мин. " + Строка(Значение-Цел(Значение/60)*60) + " сек.";
	ИначеЕсли Значение >= 60*60 и Значение < 60*60*24 Тогда 
		Возврат Строка(Цел(Значение/(60*60))) + " час. " 
				+  Строка(Цел((Значение - (Цел(Значение/(60*60))*60*60))/60)) + " мин. " 
				+ Строка(Значение-Цел(Значение/60)*60) + " сек.";
	ИначеЕсли Значение >= 60*60*24 и Значение < 60*60*24*31 Тогда
		Возврат Строка(Цел(Значение/(60*60))) + " час. " 
				+ Строка(Цел((Значение - (Цел(Значение/(60*60))*60*60))/60)) + " мин. " 
				+ Строка(Значение-Цел(Значение/60)*60) + " сек.";
	КонецЕсли;

КонецФункции // Время()

Внешняя обработка для управляемых форм с отчетом часов, минут, секунд до Нового Года.

Код честно позаимствован тут, за что автору спасибо=)

См. также

Переоткрытие внешних обработок

Универсальные функции Платформа 1С v8.3 Бесплатно (free)

На заключительных этапах, когда идет отладка или доработка интерфейса, необходимо много раз переоткрыть внешний объект. Вот один из способов автоматизации этого.

30.11.2023    3718    ke.92@mail.ru    16    

60

Валидация JSON через XDTO (включая массивы)

WEB-интеграция Универсальные функции Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

При работе с интеграциями рано или поздно придется столкнуться с получением JSON файлов. И, конечно же, жизнь заставит проверять файлы перед тем, как записывать данные в БД.

28.08.2023    7964    YA_418728146    6    

134

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    1843    16    progmaster    7    

3

Расширение: Быстрые отборы через буфер [Alt+C] Копировать список, [Alt+V] Вставить список, [Ctrl+C] Копировать из файлов

Инструментарий разработчика Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Копирует в буфер значения из списков, из ячеек отчетов, таблиц, настроек списков, других отборов и вставляет в выбранную настройку отбора. Работает с Объект не найден. Работает как в одной так и между разными базами 1С. Использует комбинации [Alt+C] Копировать список, [Alt+V] Вставить список. Также для копирования данных используется стандартная [Ctrl+C] (например из открытого xls, mxl, doc и т.п. файла скопировать список наименований)

1 стартмани

13.10.2022    15729    124    sapervodichka    111    

128

Система контроля ведения учета [БСП]

Универсальные функции Механизмы типовых конфигураций БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данном материале рассмотрим типовой алгоритм подсистемы контроля учета БСП в конфигурациях на примерах.

18.07.2022    7077    quazare    8    

108

Хитрости СКД. Часть 3

СКД Универсальные функции Платформа 1С v8.3 Система компоновки данных Конфигурации 1cv8 Бесплатно (free)

Столкнулся с тем, что мне приходится писать гору отчетов. Во многих приходится использовать повторяющиеся приемы. Решил написать шпаргалку, которая, надеюсь пригодится не только мне. В этой статье: Объединение ячеек в отчете только на определенном уровне иерархии, Постобработка итогов в табличном документе, Скрытие колонок в зависимости от количества месяцев в периоде.

28.05.2022    9083    milkers    11    

94
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. tehas 44 28.12.16 12:05 Сейчас в теме
2. TrinitronOTV 14 28.12.16 16:41 Сейчас в теме
(1) Присоединяюсь, С наступающим Новым годом!
3. MariNew 28.12.16 16:43 Сейчас в теме
4. Fox-trot 155 28.12.16 17:30 Сейчас в теме
(0) не хватает рекурсии в функции Время()
5. myALKleon 28.12.16 18:33 Сейчас в теме
Хм, похоже, благотворительный сбор монеток, хоть бы оформил красиво, автор.
6. MishaD 14 28.12.16 19:03 Сейчас в теме
Эх, нарисовал свою, аналогичную. А вот как бы внедрить ее в конфигурацию БП3, чтобы при старте запускалась, так и не придумал. Права на запуск внешних обработок закрыты. Может кто посоветует ?
Прикрепленные файлы:
ТаймерНовГод.epf
7. Fox-trot 155 28.12.16 20:16 Сейчас в теме
(6) может как расширение?
9. ketr 125 30.11.21 17:48 Сейчас в теме
(6) обновил вашу версию)
Прикрепленные файлы:
ТаймерНовГод.epf
Anchoret; +1 Ответить
8. milkers 2851 19.12.18 11:23 Сейчас в теме
(0) Поздравление на управляемых формах https://infostart.ru/public/960899/
Оставьте свое сообщение