Окно со списком отчетов при запуске 1С

Публикация № 1090863

Разработка - Обработки - Менеджеры внешних отчетов

Две обработки, которые позволяют показать список отчетов при входе в 1С.

За несколько лет работы в нашей базе УПП собралось достаточно много внешних отчетов. Сам справочник сгруппирован по организациям, отделам и т.д. При необходимости воспользоваться тем или иным отчетом, руководителям приходится тратить время на его поиски. В связи с этим поступило пожелание, чтобы при входе в 1С появлялось окно с перечнем нужных отчетов. Для каждого руководителя перечень может быть индивидуальным.

Реализовал это следующим образом: добавил новую настройку в регистре сведений НастройкиПользователей, сделал 2 внешние обработки и дописал немного кода в процедуру ПриНачалеРаботыСистемы().

Рассмотрим подробнее.

Новая настройка пользователя в регистре сведений НастройкиПользователей, результат видно на скринах.

Внешние обработки.

Первая обработка нужна для настройки списка показываемых отчетов.

Обработка имеет один реквизит (тип ТаблицаЗначений) и одну форму.

В модуле формы при выборе пользователя пытаемся получить настройки, если они были заданы ранее. Если настроек еще не было, то список отчетов заполняется отчетами из определенной группы. Но это не обязательно.

Процедура РуководительПриИзменении(Элемент)
	Если Элемент.Значение <> Справочники.Пользователи.ПустаяСсылка() Тогда
		Запрос = Новый Запрос;
		Запрос.Текст = "ВЫБРАТЬ
	               |	НастройкиПользователей.Значение КАК ЗначениеНастройки
	               |ИЗ
	               |	РегистрСведений.НастройкиПользователей КАК НастройкиПользователей
	               |ГДЕ
	               |	НастройкиПользователей.Пользователь.ИдентификаторПользователяИБ = &ТекПользователь
	               |	И НастройкиПользователей.Настройка.Код = &КодНастройки";
		Запрос.УстановитьПараметр("ТекПользователь", Руководитель.ИдентификаторПользователяИБ);			   
		Запрос.УстановитьПараметр("КодНастройки", "00138"); //При запуске показывать список отчетов для руководителей
		РезультатЗапроса = Запрос.Выполнить();
		Если НЕ РезультатЗапроса.Пустой() Тогда
			Выборка = РезультатЗапроса.Выбрать();
			Выборка.Следующий();
			ПоказатьОтчеты = Выборка.ЗначениеНастройки;
		КонецЕсли;
		
		СтруктураОбщихПараметров = ХранилищеОбщихНастроек.Загрузить("Обработка.ПросмотрОтчетов",,,Руководитель.Наименование);                       
		Если СтруктураОбщихПараметров <> Неопределено Тогда
			Если ТаблицаОтчетов.Колонки.Количество() = 0 Тогда
				ТаблицаОтчетов.Колонки.Добавить("НаименованиеОтчета",,"Наименование отчета");
				ТаблицаОтчетов.Колонки.Добавить("ДоступенДляПросмотра",,"Доступен для просмотра");
			КонецЕсли;
			Если СтруктураОбщихПараметров.Количество()>0 Тогда
				ТаблицаОтчетов = СтруктураОбщихПараметров;
			Иначе
				ТаблицаОтчетов = ЗаполнитьПоУмолчанию();
			КонецЕсли;	
		Иначе
			Если ТаблицаОтчетов.Колонки.Количество() = 0 Тогда
				ТаблицаОтчетов.Колонки.Добавить("НаименованиеОтчета",,"Наименование отчета");
				ТаблицаОтчетов.Колонки.Добавить("ДоступенДляПросмотра",,"Доступен для просмотра");
			КонецЕсли;
			ТаблицаОтчетов = ЗаполнитьПоУмолчанию();
		КонецЕсли;
	
	КонецЕсли;	
КонецПроцедуры

Функция ЗаполнитьПоУмолчанию()
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	ВнешниеОбработки.Ссылка КАК НаименованиеОтчета,
	               |	ЛОЖЬ КАК ДоступенДляПросмотра
	               |ИЗ
	               |	Справочник.ВнешниеОбработки КАК ВнешниеОбработки
	               |ГДЕ
	               |	ВнешниеОбработки.Родитель.Код = ""000000443""
	               |	И НЕ ВнешниеОбработки.ПометкаУдаления";
	 ТЗ = Запрос.Выполнить().Выгрузить();			   
	 Возврат ТЗ;
КонецФункции

При нажатии на кнопку "Сохранить ":

Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	Попытка
		ХранилищеОбщихНастроек.Сохранить("Обработка.ПросмотрОтчетов",,ТаблицаОтчетов,,Руководитель.Наименование);
	Исключение
		Сообщить("Не удалось сохранить значение настройки списка отчетов!");
	КонецПопытки;	
		
	Попытка
		НаборЗаписей = РегистрыСведений.НастройкиПользователей.СоздатьНаборЗаписей(); 
		НаборЗаписей.Отбор.Пользователь.Установить(Руководитель.Ссылка); 
		НаборЗаписей.Отбор.Настройка.Установить(ПланыВидовХарактеристик.НастройкиПользователей.НайтиПоКоду("00138")); 
		НоваяЗапись = НаборЗаписей.Добавить(); 
		НоваяЗапись.Пользователь = Руководитель.Ссылка; 
		НоваяЗапись.Настройка = ПланыВидовХарактеристик.НастройкиПользователей.НайтиПоКоду("00138"); 
		НоваяЗапись.Значение = ПоказатьОтчеты; 
		НаборЗаписей.Записать();
	Исключение
		Сообщить("Не удалось сохранить настройку пользователя для показа отчетов!");
	КонецПопытки;	
КонецПроцедуры

Вторая обработка стартует после входа в 1С. На ней список кнопок с наименованиями отчетов. При нажатии открывается соответствующий отчет.

Как можно заметить на скрине, на форме нет элементов кроме Панели. Кнопки на данную панель добавляются программно в соответствии с сохраненными настройками. Происходит это при открытии формы.

Процедура ПриОткрытии()
	
	Попытка
		СтруктураПараметров = ХранилищеОбщихНастроек.Загрузить("Обработка.ПросмотрОтчетов",,,ПользователиИнформационнойБазы.ТекущийПользователь().ПолноеИмя);
	Исключение
		Сообщить("Не удалось получить структуру параметров");
	КонецПопытки;	
	
	ДействиеПриНажатииКнопки = Новый Действие("НажатаКнопкаОтчета");
	Если СтруктураПараметров <> Неопределено Тогда
		НомерКнопки = 0;
		Для каждого Строка Из СтруктураПараметров Цикл
			Если Строка.ДоступенДляПросмотра = Истина Тогда
				НомерКнопки = НомерКнопки+1;
				КнопкаОтчет = ЭлементыФормы.Добавить(Тип("Кнопка"), "Кнопка"+НомерКнопки, Истина, ЭлементыФормы.Панель1);
				КнопкаОтчет.Заголовок = Строка.НаименованиеОтчета.Наименование;
				КнопкаОтчет.Верх = НомерКнопки*30;
				КнопкаОтчет.Лево = 6;
				КнопкаОтчет.Ширина = 50;
				КнопкаОтчет.Высота = 20;
				КнопкаОтчет.Подсказка = Строка.НаименованиеОтчета.Наименование;
				КнопкаОтчет.УстановитьДействие("Нажатие",ДействиеПриНажатииКнопки);
			КонецЕсли;	
		КонецЦикла;	
	КонецЕсли;
	
	СтраницыПанели = ЭлементыФормы.Панель1.Страницы; 
	ТекущаяСтраница = СтраницыПанели.Получить(0); 
	ЭлементыФормы.Панель1.ТекущаяСтраница = ТекущаяСтраница;

КонецПроцедуры

Процедура НажатаКнопкаОтчета(Элемент)
	ВнешняяФорма = Справочники.ВнешниеОбработки.НайтиПоНаименованию(Элемент.Подсказка); 
	ИмяФайла = ПолучитьИмяВременногоФайла(); 
	ДвоичныеДанные = ВнешняяФорма.ХранилищеВнешнейОбработки.Получить(); 
	ДвоичныеДанные.Записать(ИмяФайла); 
	Форма = ВнешниеОтчеты.ПолучитьФорму(ИмяФайла); 
	Форма.Открыть();
КонецПроцедуры

А теперь рассмотрим код, который срабатывает при запуске 1С и открывает нашу обработку со списком отчетов.

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               |	НастройкиПользователей.Значение КАК ЗначениеНастройки
               |ИЗ
               |	РегистрСведений.НастройкиПользователей КАК НастройкиПользователей
               |ГДЕ
               |	НастройкиПользователей.Пользователь.ИдентификаторПользователяИБ = &ТекПользователь
               |	И НастройкиПользователей.Настройка.Код = &КодНастройки";
Запрос.УстановитьПараметр("ТекПользователь", ПользователиИнформационнойБазы.ТекущийПользователь().УникальныйИдентификатор);			   
Запрос.УстановитьПараметр("КодНастройки", "00138"); //При запуске показывать список отчетов для руководителей
РезультатЗапроса = Запрос.Выполнить();
Если НЕ РезультатЗапроса.Пустой() Тогда
	Выборка = РезультатЗапроса.Выбрать();
	Выборка.Следующий();
	Если Выборка.ЗначениеНастройки Тогда
		ВнешняяФорма = Справочники.ВнешниеОбработки.НайтиПоНаименованию("Просмотр отчетов"); 
		ИмяФайла = ПолучитьИмяВременногоФайла(); 
		ДвоичныеДанные = ВнешняяФорма.ХранилищеВнешнейОбработки.Получить(); 
		ДвоичныеДанные.Записать(ИмяФайла); 
		Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла); 
		Форма.Открыть();
	КонецЕсли;		
КонецЕсли;

Проверено на конфигурации УПП 1.3.122.2.

Скачать файлы

Наименование Файл Версия Размер
Окно со списком отчетов при запуске 1С:

.zip 10,40Kb
0
.zip 10,40Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Обновитель регламентных отчетов для Бухгалтерии 2.0 - 3.0 для Казахстана Промо

Менеджеры внешних отчетов v8 v8::УФ 1cv8.cf Казахстан Абонемент ($m)

Обработка на управляемых формах для обновления внешних регламентных форм - позволяет обновлять регламентные формы сразу в нескольких базах.

1 стартмани

02.09.2016    13340    3    kumga99    1    

Выгрузка дополнительных отчетов и обработок из базы 1С (обычные и управляемые формы)

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Если в базе много дополнительных отчетов и обработок и их необходимо все (или большую часть) скачать на локальный диск, то данная обработка позволяет это сделать.

1 стартмани

24.02.2021    375    1    Denr83    0    

Помощник обновления дополнительных отчетов и обработок

Менеджеры внешних отчетов v8 1cv8.cf Россия Абонемент ($m)

Обработка, используя внешнее соединение (V83.COMConnector), подключается к базам по списку, и обновляет в них дополнительный отчет или обработку.

1 стартмани

22.12.2020    917    18    hiduk    1    

Программный запуск регламентированных бухгалтерских отчетов

Менеджеры внешних отчетов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Программный запуск отчета Баланс или ОФР для получения значений его показателей.

1 стартмани

04.12.2020    899    14    hiduk    0    

Подсистема "Универсальные отчеты СКД", версия 1.3.1.4 Промо

Менеджеры внешних отчетов Инструментарий разработчика v8::СКД 1cv8.cf Россия Абонемент ($m)

Подсистема позволяет без изменения конфигурации добавлять в систему новые отчеты, настраивать доступ к ним. NEW! + Рассылаем отчеты по расписанию! Кому угодно, когда угодно и сколько угодно.

3 стартмани

10.05.2011    104038    2196    krv2k    353    

Хранилище внешних отчетов и обработок (интегрируемый модуль)

Хранилище Менеджеры внешних отчетов БСП (Библиотека стандартных подсистем) v8::УФ 1cv8.cf Абонемент ($m)

Сие идея по принципу хранилища конфигурации была реализована для удобства и надежности совместной работы программистов с внешними отчетами и обработками для БСП справочника "Дополнительные отчеты и обработки": все файлы ВОиО для спр. ДОиО всех подключенных ИБ хранятся и учитываются в одном месте; возможность захвата/освобождения файла ВОиО; создание версий с комментариями (добавление новой или обновление текущей); признак проверенности (для связки работы с аналитиком); проверочный механизм совместимости версий файла ВОиО и конфигурации; быстрое переключение между версиями.

3 стартмани

10.08.2020    2048    0    mr_sav    0    

Сохранение внешних отчетов, обработок + СКД и настроек

Менеджеры внешних отчетов Универсальные обработки Обмен через XML v8 УПП1 Россия Абонемент ($m)

Обработка позволяет сохранять в каталог внешние отчеты и обработки с подпапками по типу обработки и принадлежности. Дополнительно добавлена возможность выгружать схемы СКД и настройки как основные, так и пользователей в xml файлы.

1 стартмани

05.06.2020    1974    5    RanisNetMan    2    

Автоматическая регистрация внешнего отчета или обработки для управляемых форм

Менеджеры внешних отчетов v8 v8::УФ 1cv8.cf Абонемент ($m)

Автоматическая регистрация отчёта или обработки в справочнике Дополнительные отчеты и обработки при открытии. Протестировано на: Бухгалтерия предприятия, редакция 3.0 (3.0.75.37) 1С:Предприятие 8.3 (8.3.16.1224), автоматически добавляется в раздел - "Руководителю", в быстрый доступ добавляется текущий пользователь. Поиск в интернете не дал положительных результатов. Сделал сам. Делюсь с вами. Часть кода жестко привязывает обработку к разделу / пользователи и..д. и.т.п но так и задумано. Напильником обработать под себя.

1 стартмани

12.03.2020    2517    0    agent00mouse    9    

Массовая выгрузка и загрузка внешних отчетов и обработок (для последующего поиска и замены в них) и загрузка обратно (управляемые формы)

Универсальные обработки Менеджеры внешних отчетов v8 БП3.0 Абонемент ($m)

Наверное, каждый программист сталкивался с проблемой, когда в результате обновления типовой конфигурации изменилось название или расположение функции и  возникла необходимость исправить все внешние отчеты, обработки, внешние печатные формы, там, где  используется подобный код. Особенно, когда у вас много внешних обработок и отчетов, то приходится все их выгрузить, произвести замену и потом обратно загрузить, и главное при этом не ошибиться!  Данная обработка позволит выполнить эту работу в кратчайший срок.   

1 стартмани

28.12.2019    3195    6    o.kovalev    4    

Расширение: кнопка "Открыть" для справочника дополнительных внешних отчетов и обработок

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Кнопка открывает внешние обработки и отчеты из справочника внешних отчетов и обработок

1 стартмани

07.11.2019    5340    1    IsiKosta    0    

Пакетная выгрузка / загрузка внешних отчетов и обработок

Прочие инструменты разработчика Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Пакетная выгрузка / загрузка внешних отчетов и обработок для массовый манипуляций с ними.

2 стартмани

04.11.2019    10982    51    YPermitin    22    

Шаблон программного открытия внешнего отчета из справочника "Дополнительные отчеты и обработки"

Менеджеры внешних отчетов Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Шаблон программного открытия внешнего отчета из справочника "Дополнительные отчеты и обработки" для конфигураций с подсистемой БСП "Дополнительные отчеты и обработки".

1 стартмани

10.09.2019    3738    1    tmn72.1C    2    

Копирование вариантов отчетов для внешних отчетов между пользователями

Менеджеры внешних отчетов v8 БП3.0 Россия Абонемент ($m)

Обработка для копирования вариантов отчетов для дополнительных (внешних) отчетов между пользователями.

1 стартмани

01.06.2019    3761    4    zahb    2    

Автоматическое сохранение отчетов (УТ 10.3)

Менеджеры внешних отчетов v8 УТ10 Абонемент ($m)

Автоматическое сохранение стандартных отчетов УТ 10.3 в различных форматах. Без изменения конфигурации.

1 стартмани

07.05.2019    4164    5    help1s    0    

УНФ. Внешние отчеты не попадают в отбор по подсистемам и в "Избранное"

Менеджеры внешних отчетов v8 УНФ Россия Абонемент ($m)

Часто при добавлении внешнего отчета в конфигурацию "1С: Управление нашей фирмой" его невозможно добавить в "Избранное" в списке "Все отчеты", а также не работает фильтр по подсистемам, за которой этот отчет закрепляли. Попробуем разобраться, почему такое происходит.

1 стартмани

27.11.2018    8256    23    xSavantx    1    

Менеджер дополнительных отчетов для 8.3

Менеджеры внешних отчетов v8 БП3.0 Россия Абонемент ($m)

Предложен менеджер дополнительных отчетов для 8.3, реализованный в расширении.

1 стартмани

08.11.2018    6172    1    vikhrov53    1    

Выгрузка/Загрузка внешних обработок УТ 10.3 / УПП 1.3

Универсальные обработки Менеджеры внешних отчетов v8 БП2.0 ЗУП2.5 УТ10 УПП1 Абонемент ($m)

Обработка для выгрузки на диск/загрузки с диска элементов справочника "Внешние обработки"

1 стартмани

20.07.2018    6154    10    vano-ekt    2    

Настройка сортировки начислений в отчетах ЗКГУ 3, ЗУП 3

Зарплата Менеджеры внешних отчетов Зарплата v8 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Обработка позволяет быстро настроить порядок вывода начислений в различных типовых отчетах ЗКГУ 3, ЗУП 3.

1 стартмани

20.04.2018    8493    44    ZHPN24    1    

Контекст внешних (дополнительных) отчетов. УНФ

Менеджеры внешних отчетов Практика программирования v8 УНФ Россия Абонемент ($m)

Расширение для исправления ошибки в "Управление нашей фирмой, редакция 1.6 (1.6.12.4) "

1 стартмани

20.02.2018    8202    0    shetill    0    

Открытие всех отчетов сразу с расширенной настройкой

Менеджеры внешних отчетов v8 УТ11 Россия Абонемент ($m)

Сделал, чтобы пользователи не приставали с вопросами как изменить настройки, так как все отчеты открываются без возможности изменения Структуры.

1 стартмани

23.01.2018    8491    5    fedor40    2    

Дополнительное меню в Рознице 2.2 без изменения конфигурации

Работа с интерфейсом Менеджеры внешних отчетов Рабочее место Розничная торговля Розничная торговля v8 v8::Права Розница УУ Абонемент ($m)

Заказчик захотел, чтобы кассиру были доступны специально настроенные варианты отчетов по остаткам и движениям товаров с артикулами, а также ввод счетчиков посетителей и просмотр этих счетчиков. Причем изменять конфигурацию было нельзя – она была типовая, и кроме того, была развернута РИБ из нескольких узлов.

1 стартмани

10.10.2017    12762    4    fixin    0    

Обновление/добавление вариантов отчета, разработанного с помощью СКД, в режиме 1С: Предприятия 8.3

Менеджеры внешних отчетов v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Версия БСП 1.2 При разработке нового отчета при помощи системы компоновки данных и при добавлении нескольких вариантов отчета на этапе разработки. После добавления данного отчета в состав конфигурации данные варианты отчета не появляются в режиме предприятия. Есть конечно же и стандартная обработка для регистрации вариантов отчета, но насколько мне известно она работает если конфигурация разработана на базе БСП. Если этот момент отсутствует либо не перенесены все необходимые подсистемы из БСП в разрабатываемую конфигурацию стандартную обработку необходимо "допилить". Для этого и была разработана данная обработка, которая работает в любой конфигурации без подсистем БСП.

1 стартмани

30.08.2017    21560    73    mityushov.vv    11    

Перенос настроек отчетов на шаблоне типового отчета

Менеджеры внешних отчетов v8 v8::СКД КА1 ЗУП2.5 УПП1 Абонемент ($m)

Обработка предназначена для переноса настроек отчетов внешних отчетов, написанных на шаблоне типового отчета (СКД, настройки хранятся в справочнике Сохраненные настройки) из одной базы в другую

2 стартмани

18.05.2017    15783    14    echo77    0    

Предопределенные варианты отчетов в УТ 11 не появляются в форме выбора

Менеджеры внешних отчетов v8 УТ11 Россия Абонемент ($m)

Я думаю, многие разработчики сталкивались с такой проблемой. Создаем отчет - добавляем несколько вариантов, но в пользовательском режиме почему-то нет этих вариантов и все тут...

1 стартмани

07.03.2017    13309    22    lenna1c    0    

Добавление внешнего отчета, обработки, печатной формы в несколько десятков баз. 8.2, обычные формы.

Менеджеры внешних отчетов Универсальные обработки Рабочее место v8 1cv8.cf Абонемент ($m)

Автоматизируем рабочее место автоматизатора. После того, как готов новый отчет, начинается самое муторное. Его надо добавить в базу, чтобы им смогли пользоваться те, для кого он написан. Если баз 3-5-7, это не страшно. А если их 40-50, добавление нового отчета вручную становится очень нудной задачей.

1 стартмани

11.11.2016    15220    6    корум    8    

Управление дополнительными отчетами и обработками УФ для БП 3.0 и УТ 11

Информационная безопасность Универсальные обработки Менеджеры внешних отчетов v8 v8::УФ БП3.0 УТ11 Абонемент ($m)

Что делать, когда у вас куча дополнительных обработок? Использовать эту обработку. Которая позволяет для выделенных элементов установить размещение и быстрый доступ

2 стартмани

06.03.2016    12898    10    Andruykha    2    

Выгрузка всех внешних отчетов и обработок

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Обработка выгружает все внешние отчеты, обработки, печатные формы, обработки табличных частей.

1 стартмани

30.06.2014    22502    109    Ivan_Sol    10    

Подсистема хранения внешних файлов

Менеджеры внешних отчетов Обработка документов Обработка справочников v8 1cv8.cf Абонемент ($m)

Мы долго шли к тому, чтобы на производстве технологи заводили номенклатуру, а мастера знали как ее собирать, имея под рукой чертеж, чтобы оперативно видеть документы по контрагенту или сканы документов. Но стандартный функционал УПП принуждал хранить данные в базе. Есть способ хранения внешних файлов без изменения стандартного функционала.

1 стартмани

27.12.2013    32209    205    sovital    32    

Универсальное меню

Менеджеры внешних отчетов Обработка документов Универсальные обработки v8 1cv8.cf Абонемент ($m)

Движок меню. 1. Без изменения конфигурации присвоение статусов со светофором (раскраска строк по статусам) 2. Подключение внешних обработок и отчетов

1 стартмани

07.11.2013    18758    8    Shagzhin    11    

Обработка для просмотра файлов .vrp

Менеджеры внешних отчетов v8 1cv8.cf Украина Абонемент ($m)

Обработка позволяет просматривать файлы vrp, которые можно сохранить из формы элемента справочника "Варианты отчетов" (Сохраненные настройки). Также выводится представление XML для значений параметров отчетов. Это позволяет получить Настройки компоновки данных для их вставки в Консоль системы компоновки данных.

1 стартмани

25.10.2013    22514    64    algabas    2    

PARAM. Карта разума и 1С Предприятие 8

Менеджеры внешних отчетов Практика программирования v8 Абонемент ($m)

Скрипт PARAM служит для перехода из ветки интеллектуальной карты в конкретное место конфигурации 1С.

1 стартмани

01.10.2013    23227    14    knight2007    11    

Менеджер внешних отчетов и обработок

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Решение для хранения используемых внешних отчетов и обработок без привязки к конфигурации. С возможностью экспорта/импорта списка.

1 стартмани

19.09.2013    14085    25    killitch    4    

Синхронизатор внешней обработки по нескольким базам (8.2)

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Обработка, которая копирует внешнюю обработку из справочника "внешние обработки" одной базы в несколько других.

1 стартмани

18.07.2013    17042    37    zhmurr    11    

Менеджер внешних обработок и отчетов

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Обработка, которая находит внешние отчеты и обработки в указанном каталоге и позволяет их открывать.

1 стартмани

27.06.2013    18621    55    Demic    7    

Каталог внутренних и внешних объектов (для 1С8)

Менеджеры внешних отчетов Универсальные обработки v8 1cv8.cf Абонемент ($m)

Универсальная обработка предназначена для быстрого доступа к различным внешним и внутренним объектам базы 1С 8. С ее помощью можно легко создать аналог собственного динамически фильтруемого интерфейса.

1 стартмани

19.04.2012    23657    141    Altair777    26    

Синхронизация файлов

Универсальные обработки Сервисные утилиты Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Простая обработка для синхронизации файлов на локальных и сетевых дисках. По мотивам http://infostart.ru/public/63296/, доработанная и переведенная на управляемые формы.

1 стартмани

08.02.2012    17162    28    Mopo3    1    

Вызвать внешний отчёт или обработку - быстро и удобно (8.2)

Менеджеры внешних отчетов Универсальные обработки v8 1cv8.cf Абонемент ($m)

Эта обработка поможет организовать удобный и быстрый доступ ко внешним отчётам и обработкам.

1 стартмани

03.10.2011    19567    106    Somebody1    50    

Обработка для синхронизации файлов 8.1

Менеджеры внешних отчетов Универсальные обработки v8 1cv8.cf Абонемент ($m)

Вот, решил выложить свою обработку для синхронизации файлов. Синхронизируются файлы по дате.

1 стартмани

03.06.2011    16490    75    greystone    4    

ДОРАБОТАННАЯ конвертация обработок и ВНЕШНИХ ОТЧЕТОВ из 8.1 в 8.2

Менеджеры внешних отчетов Универсальные обработки Обработка справочников v8 1cv8.cf БП2.0 ЗУП2.5 УТ10 ЗКБУ Розница УПП1 УНФ Россия Абонемент ($m)

Выполнял срочный перевод БД на 8.2, т.к. срочно нужно обеспечить защиту персональных данных с помощью Z- модуля - очередного способа распила бабла, вероятно.. Оказалось, что после использования штатной обработки (встроенной в бюджетный ЗУП) при переходе с платформы 8.1 на 8.2 ВСЕ ВНЕШНИЕ ОТЧЕТЫ РАЗРУШАЮТСЯ.. Не остается ни кодов, ни форм, ни фига вообще.. а у нас их 130 штук.. Оценили шутку, да? 1С - ВЫ &$%#@& !!!!..

1 стартмани

01.12.2010    25191    1018    kote    31    

Пакетный запуск обработок

Сервисные утилиты Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Обработка, позволяющая без изменения конфигурации, выполнять/открывать при старте системы произвольное количество дополнительных отчетов/обработок, передавать им параметры. Возможно открывать как обработки в составе конфигурации, как внешние обработки в файле, так и внешние обработки из справочника Внешние обработки.

1 стартмани

01.06.2010    24731    577    zzerro    16