Просмотр файлов PDF

Публикация № 1110428

Разработка - Обработки - Универсальные обработки

Просмотр файлов PDF

13
Еще один пример просмотра файлов PDF. В обработке реализован пример просмотра локальных файлов PDF. Дополнительно добавлен тестовый режим (один из вариантов для использования на сервере), в котором можно увидеть ограничение платформы 1С при попытке просмотра больших файлов PDF (~более 20Мб), при этом (не смотря на предупреждение об ошибке) будет сформирован валидный тестовый файл html, который можно будет протестировать в разных браузерах. П.С. Тестировалось в тонком, толстом и web клиентах на 8.3.13.1690
// Процедуры и функции
&НаКлиенте
Процедура ОбновитьТекстБраузера(ТекАдресФайлаВХранилище)
	
	Если ЭтоТест Тогда 
		// {{ Для теста
		ОбновитьТекстБраузера_Тест(ТекАдресФайлаВХранилище);
		// }} Для теста
	Иначе 
		Браузер = ?(ЭтоВебКлиент, ТекАдресФайлаВХранилище, "file:///" + СтрЗаменить(ПутьКФайлуPDF, "\", "/"));
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура СозданиеДвоичныхДанныхИзФайлаЗавершение(ДвоичныеДанные, ДополнительныеПараметры) Экспорт
	
	ТекАдресФайлаВХранилище = ПоместитьВоВременноеХранилище(ДвоичныеДанные, ЭтаФорма.УникальныйИдентификатор);
	ОбновитьТекстБраузера(ТекАдресФайлаВХранилище);
	
	Если ЭтоТест Тогда 
		Если Не ЭтоВебКлиент Тогда 
			// {{ Для теста
			ПутьКФайлу_HTML = "" + ПутьКФайлуPDF + ".html";
			ПараметрыЗаписиТекстовогоДокумента = Новый Структура;
			ПараметрыЗаписиТекстовогоДокумента.Вставить("ПутьКФайлу", ПутьКФайлу_HTML);
			ТекстовыйДокумент = Новый ТекстовыйДокумент;
			ТекстовыйДокумент.УстановитьТекст(Браузер);
			ТекстовыйДокумент.НачатьЗапись(Новый ОписаниеОповещения("ПослеНачалаЗаписиТекстовогоДокумента", ЭтотОбъект, ПараметрыЗаписиТекстовогоДокумента), ПутьКФайлу_HTML);
			// }} Для теста
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры


// {{ Для теста
#Область Тест

&НаКлиенте
Процедура ОбновитьТекстБраузера_Тест(ТекАдресФайлаВХранилище)
	
	// Формирование может быть вынесено на сервер (при необходимости использования в регламентных и фоновых заданиях)
	
	ТекУникальныйИдентификатор = СтрЗаменить(Новый УникальныйИдентификатор, "-", "");
	
	Если ЭтоВебКлиент Тогда 
		Браузер = "<!DOCTYPE html>
		|<html>
		|<head>
		|<meta charset='utf-8'>
		|<meta name='viewport' content='width=device-width, initial-scale=1.0'>
		|<meta http-equiv='X-UA-Compatible' content='IE=edge'>
		|<style>html,body{margin:0;padding:0;} iframe{width:100%;height:99.4vh;border:none;}</style>
		|</head>
		|<body id='" + ТекУникальныйИдентификатор + "'>
		|<iframe src='" + ТекАдресФайлаВХранилище + "'></iframe>
		|</body>
		|</html>
		|";
	Иначе
		Браузер = "<!DOCTYPE html>
		|<html>
		|<head>
		|<meta charset='utf-8'>
		|<meta name='viewport' content='width=device-width, initial-scale=1.0'>
		|<meta http-equiv='X-UA-Compatible' content='IE=edge'>
		|<style>html,body{margin:0;padding:0;} embed, iframe{width:100%;height:99.4vh;border:none;} button {display: inline-block;border-radius: 2px;color: #4b4b4b;font-family: Arial;font-size: 10pt;position: relative;margin: 0;vertical-align: top;word-spacing: normal;box-sizing: border-box;border: 1px solid rgba(0,0,0,0.3);border-bottom-color: rgba(0, 0, 0, 0.3);border-bottom-color: rgba(0,0,0,0.4);background-color: #fff;box-shadow: 0 1px 0 0 rgba(0,0,0,0.2);height: 27px;}</style>
		|<script>
		|var fileName = '" + ?(ЗначениеЗаполнено(ИмяФайлаPDF), ИмяФайлаPDF, "document.pdf") + "';
		|var data='" + СтрЗаменить(Base64Строка(ПолучитьИзВременногоХранилища(ТекАдресФайлаВХранилище)), Символы.ВК + Символы.ПС, "") + "';
		|var byteCharacters = atob(data);
		|var byteNumbers = new Array(byteCharacters.length);
		|for (var i = 0; i < byteCharacters.length; i++) {
		|    byteNumbers[i] = byteCharacters.charCodeAt(i);
		|}
		|var byteArray = new Uint8Array(byteNumbers);
		|var blob = new Blob([byteArray], {type: 'application/pdf'});
		|function openPDF(blob, fileName) {
		|    window.navigator.msSaveOrOpenBlob(blob, fileName);
		|}
		|window.onload = function() {
		|if (window.navigator && window.navigator.msSaveOrOpenBlob) { // IE workaround
		|    document.body.innerHTML = ""<br><br><br><center><button fileName)'>Просмотреть - "" + fileName + ""</button></center>"";
		|}
		|else { // much easier if not IE
		|    document.body.innerHTML = ""<iframe src='"" + window.URL.createObjectURL(blob) + ""'></iframe>"";
		|}
		|}
		|</script>
		|</head>
		|<body id='" + ТекУникальныйИдентификатор + "'>
		|</body>
		|</html>
		|";
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура ПослеНачалаЗаписиТекстовогоДокумента(Результат, ДополнительныеПараметры) Экспорт 
	
	Если Результат Тогда
		Если ДополнительныеПараметры.Свойство("ПутьКФайлу") Тогда 
			ТекПутьКФайлу = ДополнительныеПараметры.ПутьКФайлу;
			#Если ВебКлиент Тогда
				ТекПутьКФайлу_НавигационнаяСсылка = "";
			#Иначе
				ТекПутьКФайлу_НавигационнаяСсылка = "file:///" + ТекПутьКФайлу;
			#КонецЕсли
			Попытка
				ПоказатьОповещениеПользователя("Save", ТекПутьКФайлу_НавигационнаяСсылка, ТекПутьКФайлу, БиблиотекаКартинок.Информация32);
			Исключение
				ПоказатьОповещениеПользователя("Save", , ТекПутьКФайлу);
			КонецПопытки;
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

#КонецОбласти
// }} Для теста


&НаКлиенте
Процедура ОбновитьТекстБраузераКлиент(ПутьКФайлу, АдресФайла = "")
	
	Если ЗначениеЗаполнено(АдресФайла) Тогда 
		ОбновитьТекстБраузера(АдресФайла);
	Иначе	
		Если ЗначениеЗаполнено(ПутьКФайлу) Тогда
			// {{ Для теста
			ФайлНаДиске = Новый Файл(ПутьКФайлу);
			ИмяФайлаPDF = ФайлНаДиске.Имя;
			ФайлНаДиске = Неопределено;
			// }} Для теста
			НачатьСозданиеДвоичныхДанныхИзФайла(Новый ОписаниеОповещения("СозданиеДвоичныхДанныхИзФайлаЗавершение", ЭтотОбъект, Параметры), ПутьКФайлу);		
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры


&НаКлиенте
Процедура ПомещениеФайловЗавершение(Результат, Адрес, ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт
	
	ПутьКФайлуPDF = ВыбранноеИмяФайла;
	АдресФайлаPDF = Адрес;
	ОбновитьТекстБраузераКлиент(ПутьКФайлуPDF, АдресФайлаPDF);
	
КонецПроцедуры

&НаКлиенте
Процедура ПутьКФайлуПослеВыбораФайла(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт
	
	Если Не ВыбранныеФайлы = Неопределено Тогда 
		ПутьКФайлуPDF = ВыбранныеФайлы[0];
		ОбновитьТекстБраузераКлиент(ПутьКФайлуPDF);
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура ПутьКФайлуНачалоВыбораЗавершение(Результат) Экспорт
	
	АдресФайлаPDF = "";
	ДиалогВыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
	ДиалогВыбораФайла.Заголовок = "Укажите имя файла";
	ДиалогВыбораФайла.Фильтр = "Документ PDF (*.pdf)|*.pdf";
	ДиалогВыбораФайла.ПроверятьСуществованиеФайла = Истина;
	ДиалогВыбораФайла.МножественныйВыбор = Ложь;
	ДиалогВыбораФайла.ПолноеИмяФайла = ПутьКФайлуPDF;
	#Если ВебКлиент Тогда
		Если ПодключитьРасширениеРаботыСФайлами() Тогда
			ДиалогВыбораФайла.Показать(Новый ОписаниеОповещения("ПутьКФайлуПослеВыбораФайла", ЭтотОбъект));
		Иначе
			НачатьПомещениеФайла(Новый ОписаниеОповещения("ПомещениеФайловЗавершение", ЭтотОбъект), , ДиалогВыбораФайла, Истина, УникальныйИдентификатор);
		КонецЕсли;
	#Иначе
		ДиалогВыбораФайла.Показать(Новый ОписаниеОповещения("ПутьКФайлуПослеВыбораФайла", ЭтотОбъект));
	#КонецЕсли
	
КонецПроцедуры

&НаКлиенте
Процедура ПутьКФайлуНачалоВыбораЗавершениеВебКлиент(Подключено, ДополнительныеПараметры) Экспорт
	
	Если Не Подключено Тогда
		НачатьУстановкуРасширенияРаботыСФайлами(Новый ОписаниеОповещения("ПутьКФайлуНачалоВыбораЗавершение", ЭтотОбъект));
	Иначе
		ПутьКФайлуНачалоВыбораЗавершение(Неопределено);	
	КонецЕсли;
	
КонецПроцедуры



// Обработчики событий
&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	#Если ВебКлиент Тогда 
		ЭтоВебКлиент = Истина;
	#Иначе
		ЭтоВебКлиент = Ложь;
	#КонецЕсли
	
КонецПроцедуры

&НаКлиенте
Процедура ПутьКФайлуНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
	
	#Если ВебКлиент Тогда 
		НачатьПодключениеРасширенияРаботыСФайлами(Новый ОписаниеОповещения("ПутьКФайлуНачалоВыбораЗавершениеВебКлиент", ЭтотОбъект));
	#Иначе
		ПутьКФайлуНачалоВыбораЗавершение(Неопределено);	
	#КонецЕсли
	
КонецПроцедуры



// Обработчики команд
&НаКлиенте
Процедура КомандаОбновить(Команда)
	
	ОбновитьТекстБраузераКлиент(ПутьКФайлуPDF, АдресФайлаPDF);
	
КонецПроцедуры

13

Скачать файлы

Наименование Файл Версия Размер
PDFViewer
.epf 8,97Kb
20.08.19
11
.epf 8,97Kb 11 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. maikl007 86 04.09.19 12:26 Сейчас в теме
Оставьте свое сообщение

См. также

Новости для пользователей 130

Отчеты и формы Пользователь Расширение (cfe) v8 1cv8.cf Абонемент ($m) Универсальные обработки

Для уведомления пользователей программных продуктов 1С о разных событиях, в них включена подсистема «Новостной центр». Это довольно удобная штука, т.к. новостные ленты сообщают о выходе обновлений, о новостях и событиях в сфере учёта. Но можно увеличить пользу от новостной подсистемы используя её локально в рамках 1С базы. Например, внутренняя служба техподдержки или внедряющая компания может через новостную ленту оповещать пользователей информационной базы об изменениях в программе, совещаниях, проведении тестирований, заполнения нужных документов или сдача отчетов к определенной дате и т.п.

1 стартмани

05.08.2019    7716    21    sapervodichka    17       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Работа с файлами (обычная и управляемая форма) 90

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Нужно загрузить файл с клиента на сервер или же, наоборот, файл загрузить с сервера на клиент, а впридачу все это на web-клиенте, да еще и асинхронно? Нет ничего проще, читай далее, как это сделать!

1 стартмани

10.06.2019    9745    63    Xershi    44       

Быстрый запрос 42

Отчеты и формы Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки

Можно ли дать пользователю "удочку", а не "рыбу"? До сих пор ответ на этот вопрос был отрицательным. Всякий инструмент, который мог бы делать с базой данных все или почти все (или хотя бы многое), отвергался пользователями, как слишком сложный. Вспомните тот же SQL, который изначально разрабатывался именно как пользовательский инструмент. "Быстрый запрос" - это попытка устранить сложность, но сохранить при этом универсальность.

1 стартмани

29.04.2019    8290    15    mkalimulin    28       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Электронная таблица в 1С средствами табличного документа 68

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Универсальные обработки

Функционал электронной таблицы для программ на платформе 1С реализован на основе табличного документа. Функционал реализован в виде обработки (тонкий клиент). В формулах электронной таблицы можно использовать любые языковые конструкции, процедуры и функции 1С, ссылки на другие ячейки электронной таблицы. Допустимо обращаться к ячейкам электронной таблицы по имени именованной области. В случае использования в формулах электронной таблицы данных из самой таблицы пересчет зависимых ячеек с формулами производится автоматически. Электронную таблицу можно сохранить в файл формата xml.

1 стартмани

23.04.2019    8069    46    user706545_kseg1971    36       

Удобная консоль регламентных и фоновых заданий 46

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Сервисные утилиты Администрирование данных 1С

Аналог обработки БСП "РегламентныеИФоновыеЗадания". Не требует наличия библиотек, может использоваться в качестве внешней обработки. В отличие от обработки БСП предоставляет больше информации о свойствах регламентных и фоновых заданий, а также об ошибках и сообщениях для пользователей, возникших во время их выполнения. Позволяет управлять регламентными (создание, удаление, настройка расписания, ручной запуск) и фоновыми (прерывание) заданиями.

1 стартмани

06.02.2019    7357    117    Alxby    16       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX 172

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    17554    70    Synoecium    40       

Редактор объектов информационной базы 8.3 47

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.37 от 14.12.2019

2 стартмани

23.01.2019    13528    169    ROL32    28       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Сравнение pdf-файлов актов сверки 1

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП2.0 Россия БУ Дебиторская и кредиторская задолженность Абонемент ($m) Универсальные обработки

Обработка сравнивает два pdf-файла, в которых находятся стандартные печатные формы актов сверки, и показывает на экране совпадающие и/или отличающиеся по суммам документы взаиморасчетов.

1 стартмани

19.12.2018    8542    4    Torin99    2       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Обнуление остатков регистров бухгалтерии и накопления 42

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m) Универсальные обработки Чистка базы

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    12859    186    morozov.sv    30       

Навигатор по конфигурации базы 1С 8.3 110

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика Универсальные обработки

Универсальная внешняя обработка (СДРНавигаторУпр) для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Небольшой набор сервисных функций для повседневной работы. Для программистов и пользователей. Платформа 8.3, управляемые формы. Версия 1.1.0.51 от 08.01.2020

3 стартмани

28.10.2018    19779    207    ROL32    60       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Просмотр, изменение реквизитов объекта. Сравнение двух одинаковых объектов метаданных ИБ 0

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Универсальные обработки

Показывает реквизиты объекта (ов) или сравнивает два одинаковых объекта конфигурации справочники, документы.

1 стартмани

26.04.2018    10946    19    Vin_Tik    0       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Групповая обработка прикрепленных файлов 61

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::БУ БП3.0 Абонемент ($m) Универсальные обработки

Кому не знакомы авралы в бухгалтерии, когда налоговая требует представить копии всех документов за два-три года? Кто не получал сюрпризов в виде отсутствия документов, когда завтра их нужно уже представлять проверяющим? 1С предлагает прикрепление и хранение копий документов (в том числе со сканера) в базе, а данная обработка решает вопрос их быстрой подборки, сортировки и выгрузки, а также быстрого и эффективного контроля наличия или отсутствия документов в базе с формированием реестров как выгруженных, так и отсутствующих документов. В настоящий момент обработка бесплатна, в дальнейшем планируется платная версия с расширенными возможностями. Скажите решительное "Нет" авралам в бухгалтерии и штрафам за несвоевременное представление документов!

4 стартмани

16.04.2018    10613    27    Krasnyj    0       

Построение маршрута доставки с расчётом расстояния для любой базы УФ 58

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Оптовая торговля Абонемент ($m) Универсальные обработки WEB

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    23119    39    KorotkovRV    16       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Навигация по функциональным опциям типовых конфигураций 130

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Пользователю системы

Из релиза в релиз разделы и функциональные опции меняют своё местоположение. Вкупе с многостраничными формами настроек поиск нужной настройки становится испытанием для терпеливых. Я нашел такое решение.

1 стартмани

30.01.2018    18123    75    kuzyara    12       

Проверка орфографии средствами Yandex Speller 81

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Проверка орфографии средствами Yandex Speller с опциями и коррекцией ошибок. Возможность вызова как с сервера, так и с клиента (с последующим исправлением).

1 стартмани

09.11.2017    15412    52    🅵🅾️🆇    40       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Ведение локального каталога обработок с Инфостарт 67

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Обработка наводит порядок в ваших скачанных и локально хранимых обработках с Инфостарта. Это особенно удобно тем коллегам, которые уже скачали немалый объем обработок и хотят получить удобный инструмент навигации по списку.

1 стартмани

06.10.2017    21560    55    rpgshnik    48       

Инструменты бухгалтера: Виджеты рабочего стола 127

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::БУ БП3.0 Windows Абонемент ($m) Универсальные обработки Рабочее место

Настраиваемые виджеты на начальной странице, своеобразная панель для быстрого доступа к объектам. Виджеты это элементы интерфейса в виде цветных прямоугольников со ссылками на объекты конфигурации. Использование виджетов позволяет сконцентрировать на начальной странице часто используемые функции, например, варианты отчетов, списки документов, или используя виджет вводить новый документ прямо из начальной страницы.

2 стартмани

28.08.2017    28888    169    Bazil    26       

Открыто голосование за доклады на INFOSTART MEETUP Krasnodar Промо

Выбирайте и голосуйте за самые интересные доклады, лучшие из них попадут в окончательную программу митапа. Голосование продлится до 30 января 2020 года.

Консоль сравнения данных (1С 8, 1С 7.7, SQL, CSV, TXT, DBF, XLS, DOC, XML, JSON, табличный документ) (версия 15.0.47) 93

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Беларусь Абонемент ($m) Универсальные обработки

Обработка Консоль сравнения данных (КСД) предназначена для сравнения данных, полученных из разных источников данных: информационных баз 1С 8, 1С 7.7, баз данных SQL, файлов формата CSV/TXT/DBF/XLS/DOC/XML, строки JSON, вручную заполненного табличного документа. Минимально необходимая версия платформы: 8.3.6.1977.

1 стартмани

13.02.2017    25003    108    sertak    76       

Разбор адреса на составляющие с помощью Яндекс API и Google API 45

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Есть адрес строкой, а нужно разбить его на составляющие? Для этого не обязательно писать собственный код, пользуемся Яндекс API и Google API.

1 стартмани

10.02.2017    20513    101    Ivon    23       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

Настройка начальной страницы (Рабочего стола) 47

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом Рабочее место Универсальные обработки

Альтернатива стандартной настройке начальной страницы. В типовой доступны лишь те формы, что явно "разрешены" разработчиком в режиме конфигуратора. Эта обработка позволяет собрать "Рабочий стол" из любых подходящих форм в пользовательском режиме. Без программирования. БСП не используется. Не расширение. Универсальна, т.е. подойдет для любой конфигурации (в т.ч. самописной).

2 стартмани

19.10.2016    28084    186    Erne100    24       

Поиск и отключение зависших сеансов на сервере 1С: Предприятия 11

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Универсальные обработки

Обработка предназначена для мониторинга и отключения спящих (зависших) сеансов на сервере 1С: Предприятия.

1 стартмани

14.09.2016    24618    68    wowchik_85    11       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора. 24

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Обработка документов Универсальные обработки Обмен через XML

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    31793    150    Aphanas    4       

Универсальный поиск объектов по глобальному уникальному идентификатору (ГУИД, GUID) 9

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Поиск данных

Универсальная обработка поиска объектов информационной базы по глобальному уникальному идентификатору (ГУИД, GUID) или по его части.

1 стартмани

06.09.2016    25811    103    Dzenn    9