Изменение имени домена для выбранных пользователей информационной базы

Публикация № 1187592 30.01.20

Администрирование - Администрирование СУБД

Предлагаю Вашему вниманию обработку используемую в реальном производственном процессе на нашем предприятии. Задача переименования доменов возникла при реорганизации предприятия, имена некоторых доменов для удобства решено было изменить, но при таком количестве пользователей изменение имен доменов штатными средствами выглядело нереально. Было решено создать обработку для изменения имен доменов Информационной базы. Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854. Работает в режиме внешней обработки.

   Алгоритм работы обработки выглядит так:
1. При нажатии кнопки "Создать список доменов" на закладке формы появляется список доменов, на котором необходимо галочками отметить домены, предназначенные для изменения.
2. В строку ввода "Новое имя домена" необходимо записать имя домена, на которое будут изменены отмеченные домены.   
3. После нажатия кнопки "Переименовать домены" запускается процедура переименования, по окончании обработки выйдет сообщение о количестве переименованных пользователей.
 

    Перейдем к рассмотрению программного кода.
    
    Процедура "ИнструкцияПоЭксплуатации" описывает порядок действий при пользовании обработкой.    

Код процедуры:

&НаКлиенте
 Процедура ИнструкцияПоЭксплуатации(Команда)
//Процедура выводит текстовый файл Инструкция по эксплуатации	 

	Инструкция="          Инструкция для обработки переименование доменов."+Символы.ПС+" 
	|1. В строку ""Новое имя домена"" запишите новое имя домена."+Символы.ПС+" 
	|2. Нажмите кнопку ""Создать список доменов"", на экране появится список доменов для данной базы."+Символы.ПС+" 
	|   Выберите те домены которые вы хотите изменить (поставте галочки)."+Символы.ПС+" 
	|3. Нажмите кнопку ""Переименовать домены"", по окончании обработки выйдет сообщение о количестве переименованных пользователей.";
	
	Предупреждение(Инструкция);
	
КонецПроцедуры

 

    Процедура "ПриОткрытииОбработки" запускает процедуру "СозданиеСпискаДоменов", результатом работы которой является список доменов базы.

Код процедуры:
  

&НаКлиенте
Процедура ПриОткрытииОбработки(Команда)
ОчиститьСообщения();
СозданиеСпискаДоменов();	
Сообщить("Список доменов создан,выберите нужные домены для переименования.");
	
КонецПроцедуры	

  

    Процедуры "СозданиеСпискаДоменов"    и  "ЗаполняемТаблицуВсеДомены" заполняют таблицу значений "ВсеДомены", в которую вносятся все домены пользователей базы.

Код процедуры:
        

&НаСервере
Процедура СозданиеСпискаДоменов() 
//Создаем Массив пользователей Информационной Базы для создания списка доменов ************************
		ВсеДомены.Очистить();
		ТаблицаДоменов.Очистить();
      Выборка= ПользователиИнформационнойБазы.ПолучитьПользователей();                	 
	  Для Каждого ЭлементМассива Из Выборка Цикл                                       
		          ПользовательУникльныйИдентификатор=ЭлементМассива.УникальныйИдентификатор;
				  
				  ЗаполняемТаблицуВсеДомены(ПользовательУникльныйИдентификатор);
				  
	  КонецЦикла;
			  
			      ЗаполняемТаблицуТаблицаДоменов();

КонецПроцедуры

 &НаСервере
Процедура ЗаполняемТаблицуВсеДомены(ПользовательУникльныйИдентификатор)
	  УстановитьПривилегированныйРежим(Истина);
//Заполняем таблицу ВсеДомены ************************************************************************			  
              ПользовательИБ = ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатору(ПользовательУникльныйИдентификатор);
              ФИО1  = ПользовательИБ.ПолноеИмя;
			  ДоменЛогин=ПользовательИБ.ПользовательОС;
			  ДлинаДомена=СтрДлина(ДоменЛогин);
			  СчетчикБукв=3;
			  Буква="";
			  ИмяДоменаВТаблице="";
			  Буква=Сред(ДоменЛогин,СчетчикБукв,1);
			Пока НЕ Буква="\" И СчетчикБукв < ДлинаДомена Цикл
				ИмяДоменаВТаблице=ИмяДоменаВТаблице+Буква; 
				СчетчикБукв=СчетчикБукв+1;
				Буква=Сред(ДоменЛогин,СчетчикБукв,1);  
			КонецЦикла;	 
			УстановитьПривилегированныйРежим(Ложь);
			 Строка=ВсеДомены.Добавить();
	         Строка.ИменаДоменов=ИмяДоменаВТаблице;
			 
КонецПроцедуры	
	

   

  Процедура "ЗаполняемТаблицуТаблицаДоменов" заполняет таблицу значений "ТаблицаДоменов", которая выводится на закладке формы для выбора изменяемого имени домена.    

Код процедуры:
        

&НаСервере
Процедура ЗаполняемТаблицуТаблицаДоменов()
	  УстановитьПривилегированныйРежим(Истина);
//Заполняем таблицу ВсеДомены ************************************************************************			  
    ПустойДомен="";
    СчетчикДоменов=1;
	ВД = РеквизитФормыВЗначение("ВсеДомены",Тип("ТаблицаЗначений"));                 //Выгружаем Табличный реквизит формы в переменную
	Запрос = Новый Запрос;
	МВТ=Новый МенеджерВременныхТаблиц;                                               //Создаем МенеджерВременныхТаблиц
	Запрос.МенеджерВременныхТаблиц=МВТ;
	Запрос.Текст = 
	        "ВЫБРАТЬ
	        |	ВД1.ИменаДоменов КАК ИмяДомена
	        |ПОМЕСТИТЬ ВТДанные
	        |ИЗ
	        |	&ВД1 КАК ВД1
	        |;
	        |
	        |////////////////////////////////////////////////////////////////////////////////
	        |ВЫБРАТЬ
	        |	ВТДанные.ИмяДомена КАК ИмяДомена
	        |ИЗ
	        |	ВТДанные КАК ВТДанные
	        |ГДЕ
	        |	ВТДанные.ИмяДомена <> &ПустойДомен
	        |
	        |СГРУППИРОВАТЬ ПО
	        |	ВТДанные.ИмяДомена"
		     ;
			 Запрос.УстановитьПараметр("ПустойДомен",ПустойДомен);
			 Запрос.УстановитьПараметр("ВД1",ВД);
	         РезультатЗапроса = Запрос.Выполнить();
	         Выборка = РезультатЗапроса.Выбрать();                                
			 Пока Выборка.Следующий() Цикл                                            //Выбираем результат запроса в цикле
				   Строка=ТаблицаДоменов.Добавить();
				   Строка.Номер=СчетчикДоменов;
	               Строка.ИмяДомена=Выборка.ИмяДомена;
				   СчетчикДоменов=СчетчикДоменов+1;
            КонецЦикла;   

			 
КонецПроцедуры	

 

    Процедура "КнопкаВыполнить" запускает процедуру изменения имени домена "ИзменениеИмениДомена" которая собственно изменяет выбранные имена доменов пользователей.    

Код процедуры:
        

&НаКлиенте
Процедура КнопкаВыполнить(Команда)
Сообщить("Начато изменение имен доменов.");
НовоеИмяДомена=ИмяДомена;
	Если НовоеИмяДомена="" Тогда
		Сообщить("Введите Новое Имя Домена, без него программа не работает");
		Возврат;
	КонецЕсли;

ИзменениеИмениДомена(НовоеИмяДомена);

Сообщить("Имена доменов изменены.");

КонецПроцедуры

&НаСервере
Процедура ИзменениеИмениДомена(НовоеИмяДомена)
//Создаем Массив пользователей Информационной Базы для изменения доменов *****************************
		КоличествоПользователей=0;
      Выборка= ПользователиИнформационнойБазы.ПолучитьПользователей();                	 
	  Для Каждого ЭлементМассива Из Выборка Цикл                                       
		          ПользовательУникльныйИдентификатор=ЭлементМассива.УникальныйИдентификатор;
				  
				  ИзменениеИмениДомена1(ПользовательУникльныйИдентификатор,НовоеИмяДомена,КоличествоПользователей);
				  
	  КонецЦикла;
	  
  Сообщить("Изменены домены у "+КоличествоПользователей+" пользователей.");

КонецПроцедуры
	 
 &НаСервере
Процедура ИзменениеИмениДомена1(ПользовательУникльныйИдентификатор,НовоеИмяДомена,КоличествоПользователей)
	  УстановитьПривилегированныйРежим(Истина);
//Разбиваем	ДоменЛогин на ДоменПользователя и ЛогинПользователя		  
              ПользовательИБ = ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатору(ПользовательУникльныйИдентификатор);
              ФИО1  = ПользовательИБ.ПолноеИмя;
			  ДоменЛогин=ПользовательИБ.ПользовательОС;
Если НЕ	ДоменЛогин="" Тогда		  
			  ДлинаДомена=СтрДлина(ДоменЛогин);
			  ДоменПользователя="";
			  ЛогинПользователя="";
			  Буква="";
			  СчетчикБукв=3;
			  Буква=Сред(ДоменЛогин,СчетчикБукв,1);
			  ФлагДЛ="Д";
	Пока СчетчикБукв <= ДлинаДомена Цикл
		Если Буква="\" Тогда
				ФлагДЛ="Л";
				СчетчикБукв=СчетчикБукв+1;
				Буква=Сред(ДоменЛогин,СчетчикБукв,1);
			Иначе
				Если ФлагДЛ="Д" Тогда
					ДоменПользователя=ДоменПользователя+Буква; 
					СчетчикБукв=СчетчикБукв+1;
					Буква=Сред(ДоменЛогин,СчетчикБукв,1);  
				КонецЕсли;
				Если ФлагДЛ="Л" Тогда
					ЛогинПользователя=ЛогинПользователя+Буква; 
					СчетчикБукв=СчетчикБукв+1;
					Буква=Сред(ДоменЛогин,СчетчикБукв,1);  
				КонецЕсли;
		КонецЕсли;
	КонецЦикла;	 
//Смотрим стоит ли у домена галочка выбора			  
	ТД = РеквизитФормыВЗначение("ТаблицаДоменов",Тип("ТаблицаЗначений"));            //Выгружаем Табличный реквизит формы в переменную
	Запрос = Новый Запрос;
	МВТ=Новый МенеджерВременныхТаблиц;                                               //Создаем МенеджерВременныхТаблиц
	Запрос.МенеджерВременныхТаблиц=МВТ;
	Запрос.Текст = 
	        "ВЫБРАТЬ
	        |	ТД1.ИмяДомена КАК ИмяДомена,
	        |	ТД1.ОтметкаВыбора КАК ОтметкаВыбора
	        |ПОМЕСТИТЬ ВТДанные
	        |ИЗ
	        |	&ТД1 КАК ТД1
	        |;
	        |
	        |////////////////////////////////////////////////////////////////////////////////
	        |ВЫБРАТЬ
	        |	ВТДанные.ИмяДомена КАК ИмяДомена,
	        |	ВТДанные.ОтметкаВыбора КАК ОтметкаВыбора
	        |ИЗ
	        |	ВТДанные КАК ВТДанные
	        |ГДЕ
	        |	ВТДанные.ИмяДомена = &ДоменПользователя
	        |	И ВТДанные.ОтметкаВыбора = ИСТИНА"
		     ;
			 Запрос.УстановитьПараметр("ДоменПользователя",ДоменПользователя);
			 Запрос.УстановитьПараметр("ТД1",ТД);
	         РезультатЗапроса = Запрос.Выполнить();
	         Выборка = РезультатЗапроса.Выбрать();                                
			 Пока Выборка.Следующий() Цикл                                            //Выбираем результат запроса в цикле
					ДоменЛогин="\\"+НовоеИмяДомена+"\"+ЛогинПользователя;
             		ПользовательИБ.ПользовательОС =ДоменЛогин;
    		  		ПользовательИБ.Записать();
					КоличествоПользователей=КоличествоПользователей+1;
			КонецЦикла; 
КонецЕсли;				
 			УстановитьПривилегированныйРежим(Ложь);
 
КонецПроцедуры

    Обработка особенно актуальна для случая, когда пользователи имеют аутентификацию операционной системы и работают через консоль.

Скачать файлы

Наименование Файл Версия Размер
Изменение имени домена для выбранных пользователей информационной базы.:

.epf 10,35Kb
0
.epf 10,35Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

CF & SQL : конструктор прямых запросов к БД 1С Промо

Инструментарий разработчика Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Программа для чтения и анализа внутренней структуры данных 1С V8.х, Содержит конструктор прямых SQL запросов, позволяет обрабатывать и редактировать тексты SQL-запросов, выполнять прямые запросы к базе данных 1С и обрабатывать полученные результаты.

1 стартмани

02.10.2019    29825    292    dmitrydemenew    62    

Анализ используемых отчетов

Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Если вам необходимо анализировать, кто, когда и какой запустил отчет, то это расширение для Вас!

1 стартмани

14.10.2021    362    1    Smikle    1    

Протокол TCP/IP обмена данными с RAS (описание, пример использования C++)

Сервисные утилиты Администрирование СУБД v8 Абонемент ($m)

Описание протокола взаимодействия с консольной утилитой администрирование кластера 1С (RAS) по tcp/ip. Описание двоичных данных, консольная утилита для обмена данными с ras.

1 стартмани

21.09.2021    591    0    sdf1979    4    

Полная очистка кэша 1С (платформа 8.2 и 8.3)

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Скрипт выполняет полную очистку кэша 1С:Предприятие 8.2, 8.3, хранящегося по умолчанию на диске С.

1 стартмани

16.08.2021    1010    11    napan    4    

Легкое и гибкое управление списком доступных баз 1С у пользователей Промо

Стартеры 1С Сервисные утилиты Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

7 стартмани

05.12.2018    21378    22    RomikR    9    

Файловый менеджер для 1С. Работает на сервере 1С Предприятия на ОС Linux и Windows

Администрирование СУБД v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка "файловый менеджер". Может быть запущена из любой типовой или самописной конфигурации. Будет работать как в файловом, так и в клиент-серверном режиме работы 1С: Предприятия. Управляемые формы.

5 стартмани

09.08.2021    1133    3    Svb84    2    

Список пользователей за указанный период по выбранным информационным базам с возможностью настройки вывода через СКД (управляемые формы)

Администрирование СУБД v8 v8::УФ v8::СКД 1cv8.cf Россия Абонемент ($m)

Внешняя обработка для вывода списка пользователей за указанный период по выбранным информационным базам с возможностью настройки вывода через СКД (управляемые формы).

1 стартмани

23.07.2021    1460    2    mayz    0    

Исправление ошибки "Не удалось выполнить обработчик обновления" при обновлении БГУ на релиз 2.0.78.38

Тестирование и исправление Администрирование СУБД v8 v8::БУ БГУ Россия БУ Абонемент ($m)

Обход ошибки обновления релиза Бухгалтерии государственного учреждения на 2.0.78.38 вида Не удалось выполнить обработчик обновления "Документы.ЭлектронныйДокументВходящийЭДО.ОбработатьДанныеДляПереходаНаНовуюВерсию".

1 стартмани

08.06.2021    2501    6    the1    2    

Как «подружить» 1С v8.2 и IIS Промо

Администрирование СУБД IIS v8 1cv8.cf Россия Абонемент ($m)

Иллюстрированное руководство по предоставлению доступа к БД 1С v8.2 через веб-сервер IIS.

1 стартмани

12.11.2009    54700    442    marsohod    43    

Выполнение регламентного задания не в фоне на управляемых формах

Администрирование СУБД v8 v8::УФ 1cv8.cf Абонемент ($m)

Иногда как в процессе отладки, так и при администрировании базы 1С нужно быстро выполнить регламентное задание не в фоне.

2 стартмани

31.05.2021    1918    2    capitan    2    

Копирование конфигурации 1С с сохранением структуры хранения SQL

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Скрипт SQL, позволяющий скопировать базу данных 1С без данных, но с конфигурацией и с сохранением структуры хранения на сервере SQL.

1 стартмани

28.05.2021    1373    1    tedkuban    2    

Отправка обращений в службу поддержки из базы 1С

Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Расширение конфигурации, позволяющее отправить обращение в службу поддержки из базы 1С.

1 стартмани

12.05.2021    1389    1    itsys    9    

Массовое добавление баз на сервере

Администрирование СУБД v8 Платформа 1C v8.2 Платформа 1С v8.1 Абонемент ($m)

Программа для массового добавления баз пользователям на сервере терминалов (RDP).

1 стартмани

21.04.2021    1691    0    dcdn    3    

Оперативное оповещение пользователей прямо в 1С, принудительное завершение сеанса

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Наше расширение позволяет оперативно оповещать всех пользователей 1С. Расширение будет полезно, когда нужно, чтобы все пользователи завершили сеанс. Возможность принудительного закрытия сеанса пользователя происходит без агента сервера. Данная разработка подходит для всех основных конфигураций линейки продуктов 1С:Предприятие 8.3 (8.3.18.1289). Особенно подойдет тем, кто работает в файловой базе.

3 стартмани

15.04.2021    1874    8    SerG_Mur    6    

Работа с фоновыми заданиями (уведомления о зависших, отмена, анализ)

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Не ждите, когда "зазвонят во все колокола", если фоновое задание зависнет, вы получите письмо.

1 стартмани

14.04.2021    1581    0    pridecom    0    

Блокировка работы с внешними ресурсами - режим копии базы

Администрирование СУБД v8 БП3.0 Россия Абонемент ($m)

Обработка для перевода базы в режим работы "копия". Блокировка работы базы с внешними ресурсами.

1 стартмани

30.03.2021    2300    5    stdstd    0    

Обновление нетиповой конфигурации с приведением к типовой и выносом всех доработок в расширение. Часть/Способ №1

Администрирование СУБД v8 8.3.14 1cv8.cf Абонемент ($m)

Думаю, многие сталкивались с тем, что срочно необходимо из-за законов, оборудования, функционала обновиться на последний релиз. Данная публикация будет полезна как опытным программистам - упростить свою жизнь и работу, так и начинающим - узнать, как работают механизмы расширения, накопительного обновления, получить примеры кода, упростить обновление нетиповых конфигураций.

1 стартмани

10.03.2021    3253    3    cloud666    19    

Восстановление базы Postgres

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Скрипт переноса таблиц из битой базы в рабочую.

1 стартмани

09.03.2021    1750    0    hudoznik    5    

Включение/отключение использования итогов регистров

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Универсальная обработка для включения/отключения использования итогов по регистрам накопления и бухгалтерии.

1 стартмани

12.02.2021    2195    11    Kopitsa.k    3    

Проверка обновления конфигурации по расписанию с уведомлением на почту

Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Внешняя обработка для проверки обновления конфигурации по расписанию и отправки уведомления на почту. Предназначена для программистов и системных администраторов, ответственных за обновление конфигураций 1С.

1 стартмани

23.01.2021    2085    4    r.moschenskiy    0    

Обслуживание баз SQL средствами 1С

Администрирование СУБД v8 Абонемент ($m)

Обработка позволяет обслуживать SQL базы средствами 1С. Выполнять скрипты по перестроению индексов, обновлению статистики и очистки SQL кэша.

1 стартмани

21.01.2021    3217    4    elephant_x    4    

Расширение "Вышибала"

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Простое расширение конфигурации для прекращения работы пользователей (для базы в файловом варианте работы).

1 стартмани

31.12.2020    3715    3    AnryMc    6    

Выгрузка файлов из внутренних документов 1С: ДО с формированием структуры каталогов на локальном диске

Администрирование СУБД v8 ДО Россия Абонемент ($m)

Обработка создает структуру папок в Windows на основании структуры папок внутренних документов и вложенных внутренних документов, выгружает файлы в созданную структуру.

1 стартмани

29.10.2020    2580    5    user1077162    0    

Управление настройками видимости отчетов пользователей для УТ 11.4

Администрирование СУБД v8 v8::Права УТ11 Россия Абонемент ($m)

Возникла необходимость настроить видимость отчетов пользователям. При большом числе внешних отчетов с настройкой видимости "для всех" список отчетов сложно воспринимать. Пользователи просили убрать лишние не нужные им отчеты. Они могут настроить сами, но, конечно, ленятся - в итоге это ложится на плечи программиста 1С. Обработка позволяет скрыть неиспользуемые отчеты из списка отчетов по разделам, доступным пользователю. Также данные настройки можно скопировать другим пользователям из списка. Может быть полезна программистам 1С, администраторам БД. Делалась для себя, может, кому-то пригодится.

1 стартмани

22.10.2020    3240    6    natlens    1    

Просмотр и редактирование таблиц базы данных

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Очередная обработка для просмотра и редактирования таблиц базы данных из разряда "на каждый день".

1 стартмани

20.10.2020    2739    3    KAPACEB.AA    0    

Шаблон обработки для выполнения по областям данных

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Нередко приходится передавать команде по эксплуатации обработки по настройке или миграции данных, которые нельзя вшить в процедуру обновления информационной базы. Задача заключается в том, чтобы это была обработка с кнопкой "Сделать хорошо" и не требовала от эксплуатации каких либо дополнительных действий. Для решения подобных задач был сделан этот шаблон.

24.09.2020    3509    0    pallid    0    

Автозавершение работы пользователей

Администрирование СУБД v8 v8::БУ БП3.0 БАУ Россия Абонемент ($m)

Расширение выбрасывает активных пользователей из БД в заданный промежуток времени.

1 стартмани

23.09.2020    2655    11    maksa2005    7    

Значения по умолчанию для пользователей (Расширение)

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

При заполнении документов и справочников пользователи часто сталкиваются с необходимостью ввода одних и тех же реквизитов. Заполнение в документах некоторых из них, таких как: Организация, Склад и т.п. - выполняется реализованным в 1С механизмом подстановки значения из последних 3-5 введенных документов. Если же вы хотите заполнять все реквизиты шапки (и даты, и флажки, и другие поля, включая дополнительные реквизиты), то вам поможет данный механизм.

2 стартмани

21.09.2020    9760    78    sapervodichka    34    

Мастер создания копии информационной базы для отчетности

Производительность и оптимизация (HighLoad) Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Прототип инструмента для подготовки реплики в режиме только для чтения к использованию. Позволяет использовать "read-only" реплики как обычные информационные базы 1С.

10 стартмани

28.08.2020    8966    5    YPermitin    12    

Подключение к другой базе по OLE с выбором базы для 8.3 (через COMОбъект("V83.Application"))

Администрирование СУБД v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка демонстрирует методику подключения к другой базе 1С v8.3 с возможностью выбора базы из привычного окна выбора баз и с вводом имени пользователя и пароля. Также приведен пример работы с HTML документом, и созданием и заполнением дерева значений в управляемых формах.

1 стартмани

17.08.2020    3425    13    bayce    2    

Размер таблиц 1С в базе данных MS SQL

Статистика базы данных Администрирование СУБД v8 Абонемент ($m)

Данная обработка позволяет получить структуру БД 1С и размер таблиц без использования механизма ADODB соединения с БД MSSQL.

1 стартмани

14.08.2020    6050    45    donpadlo    5    

Копирование базы без конфигуратора

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Продолжаем нарушать правила, рвать шаблоны и делать невозможное!

1 стартмани

15.07.2020    8411    17    m-rv    41    

Переход с ERP на КА 2 или УТ 11

Администрирование СУБД Обмен данными 1С Перенос данных из 1C8 в 1C8 v8 УТ11 КА2 УУ Абонемент ($m)

Как известно сейчас 1С реализует программные продукты «1С:ERP Управление предприятием 2», «1С:Комплексная автоматизация 2» и «1С:Управление торговлей 11» одним блоком. Именно благодаря этому подходу на текущий момент во всех решениях есть переход на решения более высокого уровня. Ну как говорится если можно вперед, значит можно и назад. Хотя данный подход нигде и не задокументирован.

1 стартмани

13.07.2020    5764    17    user923728    15    

Сравнение пометок удаления в текущей и архивной копии базы

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Эта обработка подключается к указанному архиву базы и сравнивает его с текущей конфигурацией на пометку удаления. При необходимости можно отменить привести к соответствию эти базы нажатием всего на одну кнопку.

1 стартмани

13.07.2020    3513    1    nurligaianov    0    

Подбор последовательности обновления

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Обработка позволяет найти самый короткий путь для обновления древнего релиза.

1 стартмани

08.07.2020    3722    0    Dmitr033    9    

Система контроля действий пользователя / Employee Monitoring Software (СКДП, EMS)

Администрирование СУБД v8 ERP2 Россия Абонемент ($m)

Подсистема для сбора информации об активности пользователей.

1 стартмани

29.06.2020    5424    3    PerlAmutor    0    

Получение списка необновлённых баз напрямую из SQL

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Обработка будет полезна в организациях с большим числом баз. Позволяет быстро сформировать список тех баз, у которых редактируемая конфигурация отличается от конфигурации БД.

1 стартмани

01.06.2020    2993    2    cvsbook    0    

Обслуживание базы данных на PostgreSQL

Администрирование СУБД v8 Россия Абонемент ($m)

Предысторией создания данного продукта был перевод одного из своих клиентов на PostgreSQL. Серверная платформа не позволяла установить там pgAdmin. А скриптами и планировщиками пользоваться неудобно. Поэтому пришла идея реализовать обслуживание баз данных PostgreSQL средствами 1С.

1 стартмани

27.05.2020    7214    15    andrewbc    9    

Включение отладки на сервере

Администрирование СУБД v8 Абонемент ($m)

Два простых VBS скрипта для автоматического включения отладки на сервере для x32 и x64 систем.

1 стартмани

20.05.2020    3700    2    Andy_NTG    0    

Оптимизация и работа с системными представлениями

Администрирование СУБД v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка сделана для понимания работы системных представлений. В принципе, вы можете написать целую систему мониторинга ресурсов. Основа для этого, как раз, и дана в этой обработке. Внешний вид особо не шлифовался. Считаю, что это не так критично. Использовал обращение только к MS SQL, но при желании, такое же можно написать и для Postgres, и для Oracle. Тестировал на платформе 1С 8.2.19.90.

1 стартмани

12.05.2020    4295    1    darkdan77    1    

Ошибка "Для одного ссылочного кода существует более одной таблицы в базе данных" - как проще исправить

Администрирование СУБД Тестирование и исправление v8 v8::УФ 1cv8.cf Абонемент ($m)

При обновлении платформы 1с 8.3.6.2100 на платформу 8.3.16.224 под УПП 1.3.138.1 возникла ошибка "Для одного ссылочного кода существует более одной таблицы в базе данных...". В интернете много есть информации по этой проблеме, в частности в публикации https://infostart.ru/public/1126277/ приведено ее решение, но оно довольно громоздкое. Есть вариант более простой

2 стартмани

28.04.2020    6708    5    Ион    3    

Проверка подписки ИТС

Администрирование СУБД v8 1cv8.cf Абонемент ($m)

Проверка подписки ИТС по регистрационным номерам, логинам. Практическое применение API по интеграции с Порталом 1С:ИТС.

1 стартмани

17.03.2020    5686    13    kostik_love    2    

История работы пользователей (отчет на СКД)

Администрирование СУБД v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Отчет для просмотра истории работы пользователей (СКД, просмотр для любого пользователя).

2 стартмани

14.03.2020    10570    93    YPermitin    27