Трактиръ: Nano. Обработка загрузки меню в весы Штрих-Принт

Публикация № 1206181

Администрирование - Торговое оборудование - Весы

Трактир Нано Nano весы печать этикеток Штрих Принт загрузка обработка драйвер

Трактир Нано не умеет загружать весы с печатью этикеток Штрих-принт, зато умеет разбирать весовые штрихкоды в режиме продажи. Обработка позволяет загружать в весы справочник Меню по заданному типу цен.

Обработка загружает товары через драйвер Штрих-принт. Версия драйвера на скриншоте. В качестве кода товара в весах используется код элемента меню. Для упрощения PLU совпадает с кодом.

Код формы обработки:

Перем DRV Экспорт;

Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	Если Не Подключить() Тогда
		Возврат;
	КонецЕсли;                                 
	
	Для Каждого СтрокаТовар Из ТаблицаТоваров Цикл
			
		DRV.PLUNumber  	= СтрокаТовар.Код;
		DRV.Price 		= СтрокаТовар.Цена;
		DRV.ItemCode 	= СтрокаТовар.Код;
		DRV.NameFirst  	= СтрокаТовар.Наименование;
		DRV.NameSecond 	= "";
		DRV.MessageNumber = 0;
		DRV.ShelfLife	= 0;
		DRV.Tare 		= 0;
		DRV.GroupCode 	= "28";
		DRV.GoodsType 	= 0; 
		
		DRV.SetPLUDataEx();
		
		Если Ошибка() Тогда
			Возврат;
		КонецЕсли;

	КонецЦикла;                   	
		
	Если Ошибка() Тогда
		Возврат;
	Иначе
		Сообщить("Товары загружены");
	КонецЕсли;

КонецПроцедуры

Функция Подключить() Экспорт
	
	ЗагрузитьВнешнююКомпоненту("DrvLP.dll");
	DRV = Новый("AddIn.DrvLP");
	
	DRV.LDNumber = ЛогическийНомер;
	DRV.SetActiveLD();
	DRV.Connect();
	Возврат Не Ошибка();
	
КонецФункции

Процедура ЗаполнитьТоварыНажатие(Элемент)
	ТаблицаТоваров.Очистить();
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ЦеныСрезПоследних.Товар.Код КАК Код,
		|	ЦеныСрезПоследних.Товар.Наименование КАК Наименование,
		|	ЦеныСрезПоследних.Цена КАК Цена
		|ИЗ
		|	РегистрСведений.Цены.СрезПоследних КАК ЦеныСрезПоследних
		|ГДЕ
		|	ЦеныСрезПоследних.ТипЦен = &ТипЦен
		|
		|УПОРЯДОЧИТЬ ПО
		|	Наименование";
	
	Запрос.УстановитьПараметр("ТипЦен", ТипЦен);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		НоваяСтрока = ТаблицаТоваров.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяСтрока, ВыборкаДетальныеЗаписи);
	КонецЦикла;
	
КонецПроцедуры

Функция Ошибка() Экспорт
		
	ResultCode			= DRV.ResultCode;
	ResultDescription	= DRV.ResultCodeDescription;
	
	Если ResultCode = 0 Тогда
		Возврат Ложь;
	Иначе
		Возврат Истина;
	КонецЕсли;
	
КонецФункции

Процедура ПриОткрытии()
	НоваяСтрока = ТаблицаТоваров.Добавить();
	НоваяСтрока.Код = 3000;
	НоваяСтрока.Наименование = "Тестовый товар";
	НоваяСтрока.Цена = 123;
КонецПроцедуры

Процедура СчитатьИзВесовНажатие(Элемент)
	Подключить();
	ТаблицаТоваров.Очистить();
	Для ТекНомер = 1 По 3000 Цикл    
		
		DRV.PLUNumber = ТекНомер;
		DRV.GetPLUDataEx();		
		
		НоваяСтрока = ТаблицаТоваров.Добавить();
		НоваяСтрока.Код = DRV.PLUNumber;
		НоваяСтрока.Цена = DRV.Price;
		НоваяСтрока.Наименование = DRV.NameFirst;
	КонецЦикла;
КонецПроцедуры

Тестировалось с Трактиръ: Nano (1.0.12.7), платформа 1с 8.3.13.1513.

Скачать файлы

Наименование Файл Версия Размер
Трактиръ: Nano. Обработка загрузки меню в весы Штрих-Принт:
.epf 8,93Kb
04.03.20
0
.epf 8,93Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Обработка обслуживания весов с печатью этикеток ШТРИХ-М серии PC-200 для УТ 10.х

Инструменты и обработки Системный администратор Программист Архив с данными v8 КА1 УТ10 Розница УПП1 Windows Абонемент ($m) Весы

Данная обработка позволяет настроить обмен с весами с печатью этикеток ШТРИХ-М серии PC-200 и 1С:Управление торговлей редакция 10. Может быть использована в 1С: Управление производственным предприятием 1.3 ,1С: Комплексная автоматизация 1.1, 1С: Розница 1.х.

10 стартмани

04.12.2019    1404    3    Torin    0       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Управление электронными весами Днепровес (Украина)

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Украина УУ Абонемент ($m) Розничная торговля Весы

Все больше в прошлое уходит механическое весовое оборудование. Ему на смену пришли электронные весы, которые обладают массой преимуществ. Стоимость таких моделей несколько выше, чем у механических, но вы платите за множество полезных функций. Причем, в зависимости от вида, набор опций может меняться. Такой крутой текст написан на сайте производителя, но этого мало, если ты разработчик 1С:Предприятие. Тебе надо код, который должен выполняться при работе с этими весами, но его попросту неоткуда взять. Пришлось редактировать похожие обработки и вычислять опытным путем, как работает это оборудование с платформой 1С.

1 стартмани

18.09.2019    2121    1    yarsort    0       

Онлайн-курс «Автоматизация процессов управления МТО: методика сбора и формализации требований» с 1 апреля по 13 мая 2020 года. Промо

Цель курса - повысить полноту и качество сбора и формализации требований к автоматизации процессов управления материально-техническим обеспечением. Курс основан на процессном подходе, позволяет в полном объеме выявить и учесть все факторы, влияющие на специфику процессов управления МТО. Участники курса получают теоретические знания в области организации процессов управления МТО и готовый инструментарий для сбора и формализации требований по автоматизации этих процессов (шаблоны, опросники, модели).

40000 рублей

Подключение промышленных весов Масса-К ТВ-S-60.2-А1 к 1С

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Розничная торговля Абонемент ($m) Весы

Доброго времени всем! Предлагаю небольшую памятку-публикацию по подключению весов марки Масса-К ТВ-S-60.2-А1 к 1С 8.2 или 8.3.

4 стартмани

30.08.2019    3326    aximo    3       

Драйвер для электронных весов Атол MARTA (МАРТА)

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Розничная и сетевая торговля (FMCG) Windows Розничная торговля Абонемент ($m) Разработка внешних компонент Весы

Драйвер для электронных весов Атол MARTA(МАРТА). Com-объект. С одним единственным методом для возврата веса с весов. Писался для себя, успешно используется на нескольких магазинах.

1 стартмани

01.08.2019    2402    1    MORT32Ram    0       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Простая выгрузка для весов МАССА-К

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8::УФ Розница Розничная и сетевая торговля (FMCG) Россия Windows Розничная торговля Абонемент ($m) Весы

Выгрузка для весов МАССА-К через файл с помощью ПО Менеджер данных в комплекте поставки весов.

1 стартмани

03.07.2019    2229    1    AntonNV    0       

Решение проблемы с оборудованием "Штрих-М:Весы с печатью этикеток" в конфигурации Розница, редакция 2.2 (2.2.12.30)

Инструменты и обработки Программист Приложение (exe) v8 Розница Windows Абонемент ($m) Весы

В новой конфигурации Розница, редакция 2.2 (2.2.12.30), перестали совсем работать драйверы весов "Штрих-М:Весы с печатью этикеток", которые до этого использовали, убирая галочку в справочнике "Драйверы оборудования" "снят с поддержки". После долгого поиска решения на просторах интернета, сам пришел к простому и рабочему решению проблемы.

1 стартмани

27.06.2019    5446    1    limonas    1       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Расширение для УНФ: загрузка в документ данных взвешивания из весов

Инструменты и обработки no Расширение (cfe) v8 УНФ УУ Учет ТМЦ Абонемент ($m) Терминал сбора данных Весы

Универсальный драйвер к весам, который встроен в типовые конфигурации на базе БСП позволяет читать регистрации как записи терминала сбора данных, однако функционал, который позволит этот делать из формы документа в конфигурации Управление нашей фирмой отсутствует.

3 стартмани

20.06.2019    3243    1    al_zzz    0       

Формирование файла товаров для загрузки в весы METTLER TOLEDO Tiger / CAS CL 3000/5000/7000 Розница 2.2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Пищевая промышленность Россия Розничная торговля Абонемент ($m) Весы

Обработка для формирования файла PLU из ИБ Розница 2.2 для загрузки в весы METTLER TOLEDO Tiger / CAS CL3000/5000/7000. Используется предварительно настроенный элемент справочника "Правила обмена с подключаемым оборудованием offline". Данные из созданного файла загружаются в весы с использованием штатной программы SPCT (Tiger) / CL-Works (CAS). Код открыт, можно изменять и использовать по вашему усмотрению. Можно подключить к конфигурацию как Дополнительную обработку.

3 стартмани

27.05.2019    3511    5    Now    0       

Базовый курс для начинающих 1С-программистов. Онлайн-интенсив со 2 июня по 2 июля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500-9500 рублей

Выгрузка в весы с печатью этикеток в формате ШТРИХ-ПРИНТ

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Розничная торговля Абонемент ($m) Весы

После последних обновлений 1С: Розница 2.2 перестала работать выгрузка в весы ШТРИХ-ПРИНТ, а точнее выгружается 200 позиций. Найти решение не удалось, решил сделать сам.

1 стартмани

28.02.2019    5803    27    AlexStar    11       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Обмен между ПО "Сервер терминалов" и 1С: УТ 10.3 с нужных весов серии R производства Масса-К

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия УУ Windows Оптовая торговля Производство готовой продукции (работ, услуг) Абонемент ($m) Весы

Подредактировал обработку для обмена между Программой Масса-К ПО "Сервер Терминалов" и 1С 10.3 Управление торговлей. Другие конфигурации 1С не поддерживаются. Стандартный обмен ПО "Сервер Терминалов" (СТ кратко говоря) и 1С 10.3 Управление торговлей реализовывался стандартной обработкой, которая была в составе ПО СТ, но которая собирала транзакции сразу со всех весов серии R, подключенных к ПО Сервер Терминалов. Я ее модифицировал, чтобы получать транзакции только с нужных мне весов.

1 стартмани

18.02.2019    3194    brotherm    0       

Решение проблемы с незакрытыми кавычками при выгрузке описания номенклатуры на весы с печатью этикеток ШТРИХ-ПРИНТ из 1С: Розница ред. 2 (2.2.11.24) без изменения конфигурации

Инструменты и обработки Программист Расширение (cfe) v8 Розница Розничная и сетевая торговля (FMCG) Россия Розничная торговля Абонемент ($m) Весы

Расширение конфигурации. Решение проблемы с незакрытыми кавычками при выгрузке описания номенклатуры на весы с печатью этикеток ШТРИХ-ПРИНТ из 1С Розница ред. 2 (2.2.11.24) без изменения конфигурации.

1 стартмани

07.02.2019    3586    1    dimachita    3       

Онлайн-интенсив "1C:Предприятие для программистов: Бухгалтерские задачи" с 22 июня по 8 июля 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для решения задач бухгалтерского учета. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Бухгалтерия” и прочих прикладных решений, в которых реализованы соответствующие механизмы для автоматизации бухгалтерских задач.

4900 рублей

Выгрузка в весы Штрих-Принт через драйвер (Розница 2.2)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Розничная торговля Абонемент ($m) Весы

Обработка для выгрузки весового и невесового товара с упрощенным интерфейсом для Розницы 2.2. Поддерживает выгрузку сроков годности через дополнительные реквизит номенклатуры. Работает с драйвером версии A.1.8.550 (1С: Совместимо). UPDATE 18.03.2019

2 стартмани

26.01.2019    8117    41    anig99    37       

Удаление ПЛУ из весов (Далион, Трактир)

Инструменты и обработки Пользователь Внешняя обработка (ert,epf) v8 1cv8.cf ОС Розничная торговля Абонемент ($m) Весы

С помощью обработки возможно удалить выборочно номенклатуру из весов: ПЛУ без остатка, ПЛУ без цены, ПЛУ с минусовым остатком, ПЛУ с удаленной номенклатурой.

1 стартмани

15.01.2019    3853    5    paulis    0       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Обработка загрузки весов Масса-К

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8::УФ Розница Розничная и сетевая торговля (FMCG) Розничная торговля Абонемент ($m) Весы

Обработка осуществляет выгрузку товаров на весы с печатью этикетки Масса-К через приложение "Export Manager". Обработка работает с толстым и тонким клиентами.

1 стартмани

14.01.2019    3694    4    newbas    1       

Загрузка весов Масса-К с печатью этикеток

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ Розница Розничная и сетевая торговля (FMCG) Windows Розничная торговля Абонемент ($m) Весы

Обработка для загрузки весов Масса-К ВП с печатью этикеток, подключенных через Ethernet. Для управляемых форм. Работает на 1С: Розница 2.0 для Украины.

1 стартмани

10.01.2019    3355    vaniiok    0       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Выгрузка товаров в весы Штрих-ПРИНТ 4.5 из 1С:Общепит 3.0 (Расширение)

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 1cv8.cf Рестораны, кафе и фаст-фуд Абонемент ($m) Весы

Расширение предназначено для выгрузки товаров в весы Штрих-ПРИНТ с последующим использованием этикеток в 1С:Ресторан.

2 стартмани

23.11.2018    11517    9    RocKeR_13    6       

Пример выгрузки данных в весы АТОЛ LS5X. УТ 10.3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::ОУ УТ10 Россия УУ Windows Розничная торговля Абонемент ($m) Весы

Работает с Frontol Unit от атола. Будет полезна для внедрения в 1С: Управление торговлей 10.3

1 стартмани

12.10.2018    4436    3    SdFs    0       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

1C 8.3 УТ 11 и весы CAS AP, CAS AD, CAS ER-Jr (без печати этикеток)

Инструменты и обработки Системный администратор Архив с данными v8 1cv8.cf Россия Розничная торговля Абонемент ($m) Весы

Обнаружил, что в свободном доступе не описан способ легально подключить весы CAS, не покупая платных драйверов. По картинкам всё видно на примере УТ 11.

1 стартмани

16.08.2018    6087    16    dsdmsk    2       

DevOps для 1С. Онлайн-курс проходит с 16 апреля по 11 июня 2020 года. Промо

Данный онлайн-курс предусматривает изучение процессов DevOps, их применение при разработке на платформе 1С. В результате прохождения онлайн-курса вы сможете: настроить ПО необходимое для проведения проверок и тестирования, создавать сценарии тестирования и объединять их в комплексные процессы, создавать скрипты для автоматизации процессов DevOps.

12000 рублей

Выгрузка товара из Управление Торговлей 10.3 в весы CAS с составом продукта

Инструменты и обработки Программист Бухгалтер Руководитель проекта Архив с данными v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) УУ Розничная торговля Абонемент ($m) Весы

Внешняя обработка для выгрузки весового товара из 1С: Управление торговлей 10.3 в весы CAS (LP-15,16 и CL3000) по Ethernet (TCP/IP) включая состав (ингридиенты) продукта.

2 стартмани

02.08.2018    6464    9    Shomak    4       

Весы МАССА-К ВПМ 15.2 - Т1. Путеводитель по настройке и подключению. Интеграция в 1С:Розница

Статья Программист Архив с данными v8 Розница Розничная торговля Абонемент ($m) Весы

Самая подробная инструкция по подключению, настройке и интеграции весов МАССА - К ВПМ 15.2 - Т1 в 1С:Розница.

2 стартмани

12.07.2018    25074    48    user594264_e.sitnik    24       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Выгрузка номенклатуры в весы Bizerba для 1С: Далион-ТРЕНД

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf УУ Розничная торговля Абонемент ($m) Весы

Обработка для выгрузки номенклатуры в весы Bizerba для конфигурации 1С: Далион-ТРЕНД.

1 стартмани

09.07.2018    5152    2    biruk    0       

Чтение данных с весов Штрих-Принт в РМК Розница 2.2 без печати этикеток. Это возможно!

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 Розница УУ Розничная торговля Абонемент ($m) Весы

Данное расширение позволяет использовать весы с печатью этикеток Штрих-принт в качестве прикассовых. Т.е. получать данные о товаре в РМК Розницы не с распечатанной этикетки, а непосредственно с весов. Зачем? Оказывается, очень удобно.

5 стартмани

02.07.2018    16658    24    asdfgcom    51