Автоматическая регистрация внешнего отчета или обработки для управляемых форм

Публикация № 1209248

Разработка - Обработки - Менеджеры внешних отчетов

Автоматическая регистрация во внешних отчётах обработках

Автоматическая регистрация отчёта или обработки в справочнике Дополнительные отчеты и обработки при открытии. Протестировано на: Бухгалтерия предприятия, редакция 3.0 (3.0.75.37) 1С:Предприятие 8.3 (8.3.16.1224), автоматически добавляется в раздел - "Руководителю", в быстрый доступ добавляется текущий пользователь. Поиск в интернете не дал положительных результатов. Сделал сам. Делюсь с вами. Часть кода жестко привязывает обработку к разделу / пользователи и..д. и.т.п но так и задумано. Напильником обработать под себя.

Создаем две формы.

1. ОбновитьОбработку

2. ФормаОбработки

 

Основной выставляем - первую.

Код для процедуры при открытии:


&НаСервере
Процедура ПриОткрытииНаСервере()
	ОтчетОбъект = РеквизитФормыВЗначение("Объект");
	ПутьКФайлу = Новый ДвоичныеДанные( ОтчетОбъект.ИспользуемоеИмяФайла );
	Адрес = ПоместитьВоВременноеХранилище(ПутьКФайлу, ЭтаФорма.УникальныйИдентификатор);
	ОтчетОбъект.ОбновитьВрешнююОбработку( Адрес, ПутьКФайлу );
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ПриОткрытииНаСервере();
	Отказ	= Истина;
	ОткрытьФорму("ВнешняяОбработка.АвтоРегистрацияОбработки.Форма.ФормаОбработки");
КонецПроцедуры

 

В модуле объекта пишем:

 

Перем	мВерсия;
Перем	мНаименованиеОбр;


Функция СведенияОВнешнейОбработке() Экспорт
	
	ДанныеДляРег = Новый Структура();
	ДанныеДляРег.Вставить("Наименование", мНаименованиеОбр);
	ДанныеДляРег.Вставить("БезопасныйРежим", Ложь);
	ДанныеДляРег.Вставить("Версия", мВерсия);
	ДанныеДляРег.Вставить("Информация", мНаименованиеОбр);
	
	ДанныеДляРег.Вставить("Вид", "ДополнительнаяОбработка");
	
	ТабЗнКоманды = Новый ТаблицаЗначений;
	ТабЗнКоманды.Колонки.Добавить("Идентификатор");
	ТабЗнКоманды.Колонки.Добавить("Использование");
	ТабЗнКоманды.Колонки.Добавить("Представление");
	
	НовСтрока = ТабЗнКоманды.Добавить();
	НовСтрока.Идентификатор = "ОткрытьОбработку";
	НовСтрока.Использование = "ОткрытиеФормы";
	НовСтрока.Представление = "Открыть обработку";
	ДанныеДляРег.Вставить("Команды", ТабЗнКоманды);
	
	Возврат ДанныеДляРег;
	
КонецФункции


&НаСервере
Процедура ОбновитьВрешнююОбработку( Адрес, ПутьКФайлу ) Экспорт
	
	ИмяФайла	= Новый Файл(ПутьКФайлу);
	ИмяФайла	= ИмяФайла.Имя;
	СведенияОбр	= СведенияОВнешнейОбработке();
	
	//Наищем нужный нам раздел
	ИспользуемыеРазделы = Новый Массив;
	//Если ВидОбр	= Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительнаяОбработка Тогда
		ИспользуемыеРазделы = ДополнительныеОтчетыИОбработки.РазделыДополнительныхОбработок();
	//Иначе
	//	ИспользуемыеРазделы = ДополнительныеОтчетыИОбработки.РазделыДополнительныхОтчетов();
	//КонецЕсли;
	
	РабочийСтол = ДополнительныеОтчетыИОбработкиКлиентСервер.ИмяНачальнойСтраницы();
	Раздел = Справочники.ИдентификаторыОбъектовМетаданных.ПустаяСсылка();
	Для Каждого Раздел Из ИспользуемыеРазделы Цикл
		ПредстРаздела 	= ДополнительныеОтчетыИОбработки.ПредставлениеРаздела(	Раздел	);
		Если ПредстРаздела = "Руководителю" ТОгда
			Раздел = ОбщегоНазначения.ИдентификаторОбъектаМетаданных(Раздел);
			Прервать;
		КонецЕсли;
	КонецЦикла;
	
	
	СпрВО	=	Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию( мНаименованиеОбр );
	
	Если СпрВО.Пустая()	Тогда
		СпрВО_О	= Справочники.ДополнительныеОтчетыИОбработки.СоздатьЭлемент();
		СпрВО_О.Наименование	= мНаименованиеОбр;
		СпрВО_О.БезопасныйРежим	= Ложь;
		СпрВО_О.Версия			= мВерсия;
		СпрВО_О.Вид				= Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительнаяОбработка;
		СпрВО_О.ИмяОбъекта		= ЭтотОбъект.Метаданные().ПолноеИмя();
		СпрВО_О.ИмяФайла		= ЭтотОбъект.ИспользуемоеИмяФайла; // "SendMessage.epf";
		СпрВО_О.Информация		= мНаименованиеОбр;
		СпрВО_О.ИспользоватьДляФормыОбъекта	= Истина;
		СпрВО_О.ИспользоватьДляФормыСписка	= Истина;
		СпрВО_О.Ответственный	= ПараметрыСеанса.ТекущийПользователь;
		СпрВО_О.Публикация		= Истина;
		СпрВО_О.РежимСовместимостиРазрешений	= Перечисления.РежимыСовместимостиРазрешенийДополнительныхОтчетовИОбработок.Версия_2_1_3;
		
		СпрВО_О.ОбменДанными.Загрузка	= Истина;
		СпрВО_О.Записать();
	Иначе
			СпрВО_О	= СпрВО.ПолучитьОбъект();
			Если 	СпрВО.Версия < мВерсия Тогда
				Возврат;
		КонецЕсли;
	КонецЕсли;
	
	ДвоичныеДанные = ПолучитьИзВременногоХранилища( Адрес );
	//ВремФайл	= ПолучитьИмяВременногоФайла("tmp");
	//ДвоичныеДанные.Записать( ВремФайл );	
	ХранилищеОбр				= Новый ХранилищеЗначения( ДвоичныеДанные );
	СпрВО_О.ХранилищеОбработки	= ХранилищеОбр;
	
	//Добавим раздел доступа для каждой команды - Руководителю
	СпрВО_О.Команды.Очистить();
	Для Каждого ИнфОбОбр	из СведенияОбр.Команды Цикл
		//Добавим команды
		Ком		= СпрВО_О.Команды.Добавить();
		Ком.Идентификатор	= ИнфОбОбр.Идентификатор;
		Ком.ВариантЗапуска	= Перечисления.СпособыВызоваДополнительныхОбработок[ИнфОбОбр.Использование];
		Ком.Представление	= ИнфОбОбр.Представление;
		Ком.ПоказыватьОповещение	= Ложь;
		
		
		//Добавим раздел доступа  - Руководителю
		РегДоступа = РегистрыСведений.ПользовательскиеНастройкиДоступаКОбработкам;
		НаборДост = РегДоступа.СоздатьНаборЗаписей();
		
		НаборДост.Отбор.ДополнительныйОтчетИлиОбработка.Установить(СпрВО_О.Ссылка);
		НаборДост.Отбор.ИдентификаторКоманды.Установить( ИнфОбОбр.Идентификатор );
		НаборДост.Отбор.Пользователь.Установить( ПараметрыСеанса.ТекущийПользователь );
		НаборДост.Прочитать();
		
		Если НаборДост.Количество() = 0 Тогда
			ДовыйДоступ = НаборДост.Добавить();
		ИначеЕсли НаборДост.Количество() = 1 Тогда
			ДовыйДоступ = НаборДост[0];
		КонецЕсли;
		ДовыйДоступ.ДополнительныйОтчетИлиОбработка		= СпрВО_О.Ссылка;
		ДовыйДоступ.ИдентификаторКоманды				= ИнфОбОбр.Идентификатор ;
		ДовыйДоступ.Пользователь						= ПараметрыСеанса.ТекущийПользователь;
		ДовыйДоступ.Доступно							= Истина;
		НаборДост.Записать();   	
		
	КонецЦикла;
	СпрВО_О.ОбменДанными.Загрузка	= Истина;
	СпрВО_О.Записать();
	
КонецПроцедуры



мВерсия				= "1.1";
мНаименованиеОбр	= "Авто регистрация обработки";

 

Скачать файлы

Наименование Файл Версия Размер
Автоматическая регистрация внешнего отчета или обработки:
.epf 10,73Kb
12.03.20
0
.epf 10,73Kb Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. platonov.e 71 12.03.20 16:11 Сейчас в теме
А при открытии этой же обработки потом из справочника? Что будет? Она опять попытается себя загрузить? Не выдаст ли ошибку на то что в ИспользуемоеИмяФайла не путь к обработки лежит?)
А что будет в двоичных данных, когда открываете вы файл на локальном компе, а база лежит на сервере? Вы ведь ДД загружаете на сервере...
3. agent00mouse 204 13.03.20 10:22 Сейчас в теме
(1) сравнивается версия. при равной ни чего не происходит и открывается форма обработки
7. platonov.e 71 13.03.20 10:53 Сейчас в теме
(3) так может на клиенте проверить?
И что с двоичными данными на сервере то? ок отрабатывает?
8. agent00mouse 204 13.03.20 13:06 Сейчас в теме
(7)Таки не только можно но и нужно. Спасибки. В Рефакторинг.
2. VmvLer 12.03.20 16:11 Сейчас в теме
не понял, для чего этой велик со сломанным рулем(
4. agent00mouse 204 13.03.20 10:24 Сейчас в теме
(2)Где сломано?
Облегчена жизнь рядовому пользователю. йуЗверь скачивает обработки и запускает оную. Вопрос интеграции закрыт не открывшись.
Понятно, что дыра в виде прав на запуск внешних отчётов и обработок присутствует.
Можно добавить вообще cmd для автоматического засасывания обработки в базу с командной строки. А в коде реализовать подбор правильных пользователей и нужных разделов.
5. VmvLer 13.03.20 10:28 Сейчас в теме
(4) не-а.
обычный юзер приобретет приключения на 5-ю точку и все, а спец будет терять время на понимание вашей уникальной логики.
6. agent00mouse 204 13.03.20 10:32 Сейчас в теме
(5) ...Каждый выбирает для себя... как и какие кактусы ему грызть
Оставьте свое сообщение

См. также

Имя открываемого отчета в оповещении при открытии

Отчеты и формы Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Менеджеры внешних отчетов

При открытии отчета показывает в оповещении его имя в метаданных.

1 стартмани

23.01.2020    673    AntonH851    0       

Базовый курс по обмену данными в системе 1С:Предприятие. Онлайн-интенсив с 12 по 28 мая 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, обеспечивающих обмен данными между различными прикладными 1С-решениями и взаимодействие с другими информационными системами. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”.

5500 рублей

Массовая выгрузка и загрузка внешних отчетов и обработок (для последующего поиска и замены в них) и загрузка обратно (управляемые формы)

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 БП3.0 Абонемент ($m) Универсальные обработки Менеджеры внешних отчетов

Наверное, каждый программист сталкивался с проблемой, когда в результате обновления типовой конфигурации изменилось название или расположение функции и  возникла необходимость исправить все внешние отчеты, обработки, внешние печатные формы, там, где  используется подобный код. Особенно, когда у вас много внешних обработок и отчетов, то приходится все их выгрузить, произвести замену и потом обратно загрузить, и главное при этом не ошибиться!  Данная обработка позволит выполнить эту работу в кратчайший срок.   

1 стартмани

28.12.2019    1196    1    o.kovalev    2       

Запуск отчета через сом-соединение

Отчеты и формы Программист Внешний отчет (ert,erf) v8::БУ БП3.0 Россия Абонемент ($m) Менеджеры внешних отчетов

В представленной статье описано решение задачи запуска отчета пользователем базы Бухгалтерии Корп 3.0 отчета, созданного и выполняемого в базе ЗУП 3.1.

1 стартмани

03.12.2019    1377    user682398_paul_candle    1       

Онлайн-интенсив "1C:Предприятие для программистов: Бухгалтерские задачи" с 22 июня по 8 июля 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для решения задач бухгалтерского учета. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Бухгалтерия” и прочих прикладных решений, в которых реализованы соответствующие механизмы для автоматизации бухгалтерских задач.

4900 рублей

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Открытие типовых отчетов из карточки номенклатуры

Отчеты и формы no Внешняя обработка (ert,epf) v8 УПП1 Россия Абонемент ($m) Менеджеры внешних отчетов

Обработка для открытия типовых отчетов из карточки номенклатуры. Экономит массу времени и поднимает настроение :)

10 стартмани

14.10.2019    1844    2    adhocprog    0       

Шаблон программного открытия внешнего отчета из справочника "Дополнительные отчеты и обработки"

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Менеджеры внешних отчетов Инструментарий разработчика

Шаблон программного открытия внешнего отчета из справочника "Дополнительные отчеты и обработки" для конфигураций с подсистемой БСП "Дополнительные отчеты и обработки".

1 стартмани

10.09.2019    2135    1    tmn72.1C    2       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Окно со списком отчетов при запуске 1С

Инструменты и обработки Программист Архив с данными v8 УПП1 Россия Абонемент ($m) Менеджеры внешних отчетов

Две обработки, которые позволяют показать список отчетов при входе в 1С.

1 стартмани

09.07.2019    3120    AlexU4    0       

Копирование вариантов отчетов для внешних отчетов между пользователями

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 БП3.0 Россия Абонемент ($m) Менеджеры внешних отчетов

Обработка для копирования вариантов отчетов для дополнительных (внешних) отчетов между пользователями.

1 стартмани

01.06.2019    2082    1    zahb    2       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Автоматическое сохранение отчетов (УТ 10.3)

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 УТ10 Абонемент ($m) Менеджеры внешних отчетов

Автоматическое сохранение стандартных отчетов УТ 10.3 в различных форматах. Без изменения конфигурации.

1 стартмани

07.05.2019    2308    4    help1s    0       

Особенность при добавлении внешних отчетов в УНФ 1.6

Статья Программист Внешний отчет (ert,erf) v8 v8::УФ v8::СКД УНФ Россия УУ Windows Монитор заказов Абонемент ($m) Менеджеры внешних отчетов Управленческие

Добавляем внешний отчет в УНФ 1.6, Устанавливаем "тэги" для внешнего отчета в УНФ 1.6; устанавливаем "изображение образца" для внешнего отчета в УНФ 1.6.

1 стартмани

04.04.2019    6397    16    d.saladin    14       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

УНФ. Внешние отчеты не попадают в отбор по подсистемам и в "Избранное"

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 УНФ Россия Абонемент ($m) Менеджеры внешних отчетов

Часто при добавлении внешнего отчета в конфигурацию "1С: Управление нашей фирмой" его невозможно добавить в "Избранное" в списке "Все отчеты", а также не работает фильтр по подсистемам, за которой этот отчет закрепляли. Попробуем разобраться, почему такое происходит.

1 стартмани

27.11.2018    4498    4    xSavantx    1       

Менеджер дополнительных отчетов для 8.3

Инструменты и обработки Системный администратор Расширение (cfe) v8 БП3.0 Россия Windows Абонемент ($m) Менеджеры внешних отчетов

Предложен менеджер дополнительных отчетов для 8.3, реализованный в расширении.

1 стартмани

08.11.2018    4527    vikhrov53    1       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Панель отчетов (v8 обычные формы)

Отчеты и формы Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Менеджеры внешних отчетов

В конфигурациях типа УТ, УПП, УТП (Украина) и им подобных достаточно неудобно организован доступ к справочнику "Внешние отчеты". Для полного интерфейса доступ глубоко "закопан" в меню "Сервис". Ну а для рядовых пользователей интерактивный доступ становится вовсе невозможен. В какой-то момент самому надоело делать по пять кликов мышью для вызова отчета. Поиск подходящего варианта на Инфостарте результатов не дал. В итоге быстренько была написана обработка отвечающая моему представлению "о прекрасном" )) Предлагаемая внешняя обработка позволяет организовать быстрый доступ к доступным отчетам и обработкам, создание персонального списка "любимых отчетов", поиск отчета в списке по ключевым словам. Подключить обработку можно к любой конфигурации на обычных формах.

1 стартмани

21.04.2018    6330    5    Некто A. Petti    1       

Настройка сортировки начислений в отчетах ЗКГУ 3, ЗУП 3

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 ЗКГУ3.0 ЗУП3.x Россия БУ Зарплата Абонемент ($m) Менеджеры внешних отчетов

Обработка позволяет быстро настроить порядок вывода начислений в различных типовых отчетах ЗКГУ 3, ЗУП 3.

1 стартмани

20.04.2018    6542    42    ZHPN24    1       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Список дополнительных внешних обработок и отчетов на начальной странице без подключения через БСП. Универсальное расширение

Отчеты и формы Системный администратор Программист Расширение (cfe) v8 1cv8.cf Россия Абонемент ($m) Менеджеры внешних отчетов

Некоторый беспорядок с версиями и расположением внешних обработок породил необходимость создать решение для запуска внешних обработок пользователями прямо из папки без подключения через стандартный механизм БСП.

1 стартмани

14.03.2018    7294    15    had    0       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Открытие всех отчетов сразу с расширенной настройкой

Инструменты и обработки no Расширение (cfe) v8 УТ11 Россия Абонемент ($m) Менеджеры внешних отчетов

Сделал, чтобы пользователи не приставали с вопросами как изменить настройки, так как все отчеты открываются без возможности изменения Структуры.

1 стартмани

23.01.2018    7016    6    fedor40    1       

Дополнительное меню в Рознице 2.2 без изменения конфигурации

Инструменты и обработки Системный администратор Программист Руководитель проекта Архив с данными v8 v8::Права Розница УУ Розничная торговля Абонемент ($m) Менеджеры внешних отчетов Работа с интерфейсом Рабочее место

Заказчик захотел, чтобы кассиру были доступны специально настроенные варианты отчетов по остаткам и движениям товаров с артикулами, а также ввод счетчиков посетителей и просмотр этих счетчиков. Причем изменять конфигурацию было нельзя – она была типовая, и кроме того, была развернута РИБ из нескольких узлов.

1 стартмани

10.10.2017    11003    4    fixin    0       

DevOps для 1С. Онлайн-курс проходит с 16 апреля по 11 июня 2020 года. Промо

Данный онлайн-курс предусматривает изучение процессов DevOps, их применение при разработке на платформе 1С. В результате прохождения онлайн-курса вы сможете: настроить ПО необходимое для проведения проверок и тестирования, создавать сценарии тестирования и объединять их в комплексные процессы, создавать скрипты для автоматизации процессов DevOps.

12000 рублей

Обновление/добавление вариантов отчета, разработанного с помощью СКД, в режиме 1С: Предприятия 8.3

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Менеджеры внешних отчетов

Версия БСП 1.2 При разработке нового отчета при помощи системы компоновки данных и при добавлении нескольких вариантов отчета на этапе разработки. После добавления данного отчета в состав конфигурации данные варианты отчета не появляются в режиме предприятия. Есть конечно же и стандартная обработка для регистрации вариантов отчета, но насколько мне известно она работает если конфигурация разработана на базе БСП. Если этот момент отсутствует либо не перенесены все необходимые подсистемы из БСП в разрабатываемую конфигурацию стандартную обработку необходимо "допилить". Для этого и была разработана данная обработка, которая работает в любой конфигурации без подсистем БСП.

1 стартмани

30.08.2017    16511    53    mityushov.vv    11       

Перенос настроек отчетов на шаблоне типового отчета

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 v8::СКД КА1 ЗУП2.5 УПП1 Абонемент ($m) Менеджеры внешних отчетов

Обработка предназначена для переноса настроек отчетов внешних отчетов, написанных на шаблоне типового отчета (СКД, настройки хранятся в справочнике Сохраненные настройки) из одной базы в другую

2 стартмани

18.05.2017    13566    12    echo77    0       

Базовый курс для начинающих 1С-программистов. Онлайн-интенсив со 2 июня по 2 июля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500-9500 рублей

Предопределенные варианты отчетов в УТ 11 не появляются в форме выбора

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 УТ11 Россия Windows Абонемент ($m) Менеджеры внешних отчетов

Я думаю, многие разработчики сталкивались с такой проблемой. Создаем отчет - добавляем несколько вариантов, но в пользовательском режиме почему-то нет этих вариантов и все тут...

1 стартмани

07.03.2017    11275    20    lenna1c    0       

Добавление внешнего отчета, обработки, печатной формы в несколько десятков баз. 8.2, обычные формы.

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Абонемент ($m) Менеджеры внешних отчетов Универсальные обработки Рабочее место

Автоматизируем рабочее место автоматизатора. После того, как готов новый отчет, начинается самое муторное. Его надо добавить в базу, чтобы им смогли пользоваться те, для кого он написан. Если баз 3-5-7, это не страшно. А если их 40-50, добавление нового отчета вручную становится очень нудной задачей.

1 стартмани

11.11.2016    13482    6    корум    8       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Обновитель регламентных отчетов для Бухгалтерии 2.0 - 3.0 для Казахстана

Инструменты и обработки Системный администратор Бухгалтер Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Казахстан Абонемент ($m) Менеджеры внешних отчетов

Обработка на управляемых формах для обновления внешних регламентных форм - позволяет обновлять регламентные формы сразу в нескольких базах.

1 стартмани

02.09.2016    11079    3    kumga99    1       

Управление дополнительными отчетами и обработками УФ для БП 3.0 и УТ 11

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ БП3.0 УТ11 Windows Абонемент ($m) Информационная безопасность Менеджеры внешних отчетов Универсальные обработки

Что делать, когда у вас куча дополнительных обработок? Использовать эту обработку. Которая позволяет для выделенных элементов установить размещение и быстрый доступ

2 стартмани

06.03.2016    11291    10    Andruykha    2