Автоматическая регистрация внешнего отчета или обработки для управляемых форм

Публикация № 1209248

Разработка - Обработки - Менеджеры внешних отчетов

Автоматическая регистрация во внешних отчётах обработках

Автоматическая регистрация отчёта или обработки в справочнике Дополнительные отчеты и обработки при открытии. Протестировано на: Бухгалтерия предприятия, редакция 3.0 (3.0.75.37) 1С:Предприятие 8.3 (8.3.16.1224), автоматически добавляется в раздел - "Руководителю", в быстрый доступ добавляется текущий пользователь. Поиск в интернете не дал положительных результатов. Сделал сам. Делюсь с вами. Часть кода жестко привязывает обработку к разделу / пользователи и..д. и.т.п но так и задумано. Напильником обработать под себя.

Создаем две формы.

1. ОбновитьОбработку

2. ФормаОбработки

 

Основной выставляем - первую.

Код для процедуры при открытии:


&НаСервере
Процедура ПриОткрытииНаСервере()
	ОтчетОбъект = РеквизитФормыВЗначение("Объект");
	ПутьКФайлу = Новый ДвоичныеДанные( ОтчетОбъект.ИспользуемоеИмяФайла );
	Адрес = ПоместитьВоВременноеХранилище(ПутьКФайлу, ЭтаФорма.УникальныйИдентификатор);
	ОтчетОбъект.ОбновитьВрешнююОбработку( Адрес, ПутьКФайлу );
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ПриОткрытииНаСервере();
	Отказ	= Истина;
	ОткрытьФорму("ВнешняяОбработка.АвтоРегистрацияОбработки.Форма.ФормаОбработки");
КонецПроцедуры

 

В модуле объекта пишем:

 

Перем	мВерсия;
Перем	мНаименованиеОбр;


Функция СведенияОВнешнейОбработке() Экспорт
	
	ДанныеДляРег = Новый Структура();
	ДанныеДляРег.Вставить("Наименование", мНаименованиеОбр);
	ДанныеДляРег.Вставить("БезопасныйРежим", Ложь);
	ДанныеДляРег.Вставить("Версия", мВерсия);
	ДанныеДляРег.Вставить("Информация", мНаименованиеОбр);
	
	ДанныеДляРег.Вставить("Вид", "ДополнительнаяОбработка");
	
	ТабЗнКоманды = Новый ТаблицаЗначений;
	ТабЗнКоманды.Колонки.Добавить("Идентификатор");
	ТабЗнКоманды.Колонки.Добавить("Использование");
	ТабЗнКоманды.Колонки.Добавить("Представление");
	
	НовСтрока = ТабЗнКоманды.Добавить();
	НовСтрока.Идентификатор = "ОткрытьОбработку";
	НовСтрока.Использование = "ОткрытиеФормы";
	НовСтрока.Представление = "Открыть обработку";
	ДанныеДляРег.Вставить("Команды", ТабЗнКоманды);
	
	Возврат ДанныеДляРег;
	
КонецФункции


&НаСервере
Процедура ОбновитьВрешнююОбработку( Адрес, ПутьКФайлу ) Экспорт
	
	ИмяФайла	= Новый Файл(ПутьКФайлу);
	ИмяФайла	= ИмяФайла.Имя;
	СведенияОбр	= СведенияОВнешнейОбработке();
	
	//Наищем нужный нам раздел
	ИспользуемыеРазделы = Новый Массив;
	//Если ВидОбр	= Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительнаяОбработка Тогда
		ИспользуемыеРазделы = ДополнительныеОтчетыИОбработки.РазделыДополнительныхОбработок();
	//Иначе
	//	ИспользуемыеРазделы = ДополнительныеОтчетыИОбработки.РазделыДополнительныхОтчетов();
	//КонецЕсли;
	
	РабочийСтол = ДополнительныеОтчетыИОбработкиКлиентСервер.ИмяНачальнойСтраницы();
	Раздел = Справочники.ИдентификаторыОбъектовМетаданных.ПустаяСсылка();
	Для Каждого Раздел Из ИспользуемыеРазделы Цикл
		ПредстРаздела 	= ДополнительныеОтчетыИОбработки.ПредставлениеРаздела(	Раздел	);
		Если ПредстРаздела = "Руководителю" ТОгда
			Раздел = ОбщегоНазначения.ИдентификаторОбъектаМетаданных(Раздел);
			Прервать;
		КонецЕсли;
	КонецЦикла;
	
	
	СпрВО	=	Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию( мНаименованиеОбр );
	
	Если СпрВО.Пустая()	Тогда
		СпрВО_О	= Справочники.ДополнительныеОтчетыИОбработки.СоздатьЭлемент();
		СпрВО_О.Наименование	= мНаименованиеОбр;
		СпрВО_О.БезопасныйРежим	= Ложь;
		СпрВО_О.Версия			= мВерсия;
		СпрВО_О.Вид				= Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительнаяОбработка;
		СпрВО_О.ИмяОбъекта		= ЭтотОбъект.Метаданные().ПолноеИмя();
		СпрВО_О.ИмяФайла		= ЭтотОбъект.ИспользуемоеИмяФайла; // "SendMessage.epf";
		СпрВО_О.Информация		= мНаименованиеОбр;
		СпрВО_О.ИспользоватьДляФормыОбъекта	= Истина;
		СпрВО_О.ИспользоватьДляФормыСписка	= Истина;
		СпрВО_О.Ответственный	= ПараметрыСеанса.ТекущийПользователь;
		СпрВО_О.Публикация		= Истина;
		СпрВО_О.РежимСовместимостиРазрешений	= Перечисления.РежимыСовместимостиРазрешенийДополнительныхОтчетовИОбработок.Версия_2_1_3;
		
		СпрВО_О.ОбменДанными.Загрузка	= Истина;
		СпрВО_О.Записать();
	Иначе
			СпрВО_О	= СпрВО.ПолучитьОбъект();
			Если 	СпрВО.Версия < мВерсия Тогда
				Возврат;
		КонецЕсли;
	КонецЕсли;
	
	ДвоичныеДанные = ПолучитьИзВременногоХранилища( Адрес );
	//ВремФайл	= ПолучитьИмяВременногоФайла("tmp");
	//ДвоичныеДанные.Записать( ВремФайл );	
	ХранилищеОбр				= Новый ХранилищеЗначения( ДвоичныеДанные );
	СпрВО_О.ХранилищеОбработки	= ХранилищеОбр;
	
	//Добавим раздел доступа для каждой команды - Руководителю
	СпрВО_О.Команды.Очистить();
	Для Каждого ИнфОбОбр	из СведенияОбр.Команды Цикл
		//Добавим команды
		Ком		= СпрВО_О.Команды.Добавить();
		Ком.Идентификатор	= ИнфОбОбр.Идентификатор;
		Ком.ВариантЗапуска	= Перечисления.СпособыВызоваДополнительныхОбработок[ИнфОбОбр.Использование];
		Ком.Представление	= ИнфОбОбр.Представление;
		Ком.ПоказыватьОповещение	= Ложь;
		
		
		//Добавим раздел доступа  - Руководителю
		РегДоступа = РегистрыСведений.ПользовательскиеНастройкиДоступаКОбработкам;
		НаборДост = РегДоступа.СоздатьНаборЗаписей();
		
		НаборДост.Отбор.ДополнительныйОтчетИлиОбработка.Установить(СпрВО_О.Ссылка);
		НаборДост.Отбор.ИдентификаторКоманды.Установить( ИнфОбОбр.Идентификатор );
		НаборДост.Отбор.Пользователь.Установить( ПараметрыСеанса.ТекущийПользователь );
		НаборДост.Прочитать();
		
		Если НаборДост.Количество() = 0 Тогда
			ДовыйДоступ = НаборДост.Добавить();
		ИначеЕсли НаборДост.Количество() = 1 Тогда
			ДовыйДоступ = НаборДост[0];
		КонецЕсли;
		ДовыйДоступ.ДополнительныйОтчетИлиОбработка		= СпрВО_О.Ссылка;
		ДовыйДоступ.ИдентификаторКоманды				= ИнфОбОбр.Идентификатор ;
		ДовыйДоступ.Пользователь						= ПараметрыСеанса.ТекущийПользователь;
		ДовыйДоступ.Доступно							= Истина;
		НаборДост.Записать();   	
		
	КонецЦикла;
	СпрВО_О.ОбменДанными.Загрузка	= Истина;
	СпрВО_О.Записать();
	
КонецПроцедуры



мВерсия				= "1.1";
мНаименованиеОбр	= "Авто регистрация обработки";

 

Скачать файлы

Наименование Файл Версия Размер
Автоматическая регистрация внешнего отчета или обработки:

.epf 10,73Kb
0
.epf 10,73Kb Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. platonov.e 112 12.03.20 16:11 Сейчас в теме
А при открытии этой же обработки потом из справочника? Что будет? Она опять попытается себя загрузить? Не выдаст ли ошибку на то что в ИспользуемоеИмяФайла не путь к обработки лежит?)
А что будет в двоичных данных, когда открываете вы файл на локальном компе, а база лежит на сервере? Вы ведь ДД загружаете на сервере...
3. agent00mouse 214 13.03.20 10:22 Сейчас в теме
(1) сравнивается версия. при равной ни чего не происходит и открывается форма обработки
7. platonov.e 112 13.03.20 10:53 Сейчас в теме
(3) так может на клиенте проверить?
И что с двоичными данными на сервере то? ок отрабатывает?
8. agent00mouse 214 13.03.20 13:06 Сейчас в теме
(7)Таки не только можно но и нужно. Спасибки. В Рефакторинг.
2. VmvLer 12.03.20 16:11 Сейчас в теме
не понял, для чего этой велик со сломанным рулем(
4. agent00mouse 214 13.03.20 10:24 Сейчас в теме
(2)Где сломано?
Облегчена жизнь рядовому пользователю. йуЗверь скачивает обработки и запускает оную. Вопрос интеграции закрыт не открывшись.
Понятно, что дыра в виде прав на запуск внешних отчётов и обработок присутствует.
Можно добавить вообще cmd для автоматического засасывания обработки в базу с командной строки. А в коде реализовать подбор правильных пользователей и нужных разделов.
5. VmvLer 13.03.20 10:28 Сейчас в теме
(4) не-а.
обычный юзер приобретет приключения на 5-ю точку и все, а спец будет терять время на понимание вашей уникальной логики.
6. agent00mouse 214 13.03.20 10:32 Сейчас в теме
(5) ...Каждый выбирает для себя... как и какие кактусы ему грызть
9. SlavaKron 16.06.20 08:44 Сейчас в теме
Сильно не вникал, но код:
&НаСервере
Процедура ПриОткрытииНаСервере()
	ОтчетОбъект = РеквизитФормыВЗначение("Объект");
	ПутьКФайлу = Новый ДвоичныеДанные( ОтчетОбъект.ИспользуемоеИмяФайла );
	Адрес = ПоместитьВоВременноеХранилище(ПутьКФайлу, ЭтаФорма.УникальныйИдентификатор);
	ОтчетОбъект.ОбновитьВрешнююОбработку( Адрес, ПутьКФайлу );
КонецПроцедуры
будет работать только в том случае, если у вас файловая база или 1С Предприятие вы открываете на сервере, в остальных случаях ИспользуемоеИмяФайла имеет смысл только на клиенте.
Оставьте свое сообщение

См. также

Обновитель регламентных отчетов для Бухгалтерии 2.0 - 3.0 для Казахстана Промо

Менеджеры внешних отчетов v8 v8::УФ 1cv8.cf Казахстан Абонемент ($m)

Обработка на управляемых формах для обновления внешних регламентных форм - позволяет обновлять регламентные формы сразу в нескольких базах.

1 стартмани

02.09.2016    13385    3    kumga99    1    

Выгрузка дополнительных отчетов и обработок из базы 1С (обычные и управляемые формы)

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Если в базе много дополнительных отчетов и обработок и их необходимо все (или большую часть) скачать на локальный диск, то данная обработка позволяет это сделать.

1 стартмани

24.02.2021    451    2    Denr83    0    

Помощник обновления дополнительных отчетов и обработок

Менеджеры внешних отчетов v8 1cv8.cf Россия Абонемент ($m)

Обработка, используя внешнее соединение (V83.COMConnector), подключается к базам по списку, и обновляет в них дополнительный отчет или обработку.

1 стартмани

22.12.2020    950    18    hiduk    1    

Программный запуск регламентированных бухгалтерских отчетов

Менеджеры внешних отчетов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Программный запуск отчета Баланс или ОФР для получения значений его показателей.

1 стартмани

04.12.2020    926    14    hiduk    0    

Подсистема "Универсальные отчеты СКД", версия 1.3.1.4 Промо

Менеджеры внешних отчетов Инструментарий разработчика v8::СКД 1cv8.cf Россия Абонемент ($m)

Подсистема позволяет без изменения конфигурации добавлять в систему новые отчеты, настраивать доступ к ним. NEW! + Рассылаем отчеты по расписанию! Кому угодно, когда угодно и сколько угодно.

3 стартмани

10.05.2011    104102    2196    krv2k    353    

Хранилище внешних отчетов и обработок (интегрируемый модуль)

Хранилище Менеджеры внешних отчетов БСП (Библиотека стандартных подсистем) v8::УФ 1cv8.cf Абонемент ($m)

Сие идея по принципу хранилища конфигурации была реализована для удобства и надежности совместной работы программистов с внешними отчетами и обработками для БСП справочника "Дополнительные отчеты и обработки": все файлы ВОиО для спр. ДОиО всех подключенных ИБ хранятся и учитываются в одном месте; возможность захвата/освобождения файла ВОиО; создание версий с комментариями (добавление новой или обновление текущей); признак проверенности (для связки работы с аналитиком); проверочный механизм совместимости версий файла ВОиО и конфигурации; быстрое переключение между версиями.

3 стартмани

10.08.2020    2110    0    mr_sav    0    

Сохранение внешних отчетов, обработок + СКД и настроек

Менеджеры внешних отчетов Универсальные обработки Обмен через XML v8 УПП1 Россия Абонемент ($m)

Обработка позволяет сохранять в каталог внешние отчеты и обработки с подпапками по типу обработки и принадлежности. Дополнительно добавлена возможность выгружать схемы СКД и настройки как основные, так и пользователей в xml файлы.

1 стартмани

05.06.2020    2004    6    RanisNetMan    2    

Массовая выгрузка и загрузка внешних отчетов и обработок (для последующего поиска и замены в них) и загрузка обратно (управляемые формы)

Универсальные обработки Менеджеры внешних отчетов v8 БП3.0 Абонемент ($m)

Наверное, каждый программист сталкивался с проблемой, когда в результате обновления типовой конфигурации изменилось название или расположение функции и  возникла необходимость исправить все внешние отчеты, обработки, внешние печатные формы, там, где  используется подобный код. Особенно, когда у вас много внешних обработок и отчетов, то приходится все их выгрузить, произвести замену и потом обратно загрузить, и главное при этом не ошибиться!  Данная обработка позволит выполнить эту работу в кратчайший срок.   

1 стартмани

28.12.2019    3234    6    o.kovalev    4    

Расширение: кнопка "Открыть" для справочника дополнительных внешних отчетов и обработок

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Кнопка открывает внешние обработки и отчеты из справочника внешних отчетов и обработок

1 стартмани

07.11.2019    5365    1    IsiKosta    0    

Пакетная выгрузка / загрузка внешних отчетов и обработок

Прочие инструменты разработчика Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Пакетная выгрузка / загрузка внешних отчетов и обработок для массовый манипуляций с ними.

2 стартмани

04.11.2019    11081    57    YPermitin    22    

Шаблон программного открытия внешнего отчета из справочника "Дополнительные отчеты и обработки"

Менеджеры внешних отчетов Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Шаблон программного открытия внешнего отчета из справочника "Дополнительные отчеты и обработки" для конфигураций с подсистемой БСП "Дополнительные отчеты и обработки".

1 стартмани

10.09.2019    3763    1    tmn72.1C    2    

Окно со списком отчетов при запуске 1С

Менеджеры внешних отчетов v8 УПП1 Россия Абонемент ($m)

Две обработки, которые позволяют показать список отчетов при входе в 1С.

1 стартмани

09.07.2019    4818    0    AlexU4    0    

Копирование вариантов отчетов для внешних отчетов между пользователями

Менеджеры внешних отчетов v8 БП3.0 Россия Абонемент ($m)

Обработка для копирования вариантов отчетов для дополнительных (внешних) отчетов между пользователями.

1 стартмани

01.06.2019    3805    4    zahb    2    

Автоматическое сохранение отчетов (УТ 10.3)

Менеджеры внешних отчетов v8 УТ10 Абонемент ($m)

Автоматическое сохранение стандартных отчетов УТ 10.3 в различных форматах. Без изменения конфигурации.

1 стартмани

07.05.2019    4191    5    help1s    0    

УНФ. Внешние отчеты не попадают в отбор по подсистемам и в "Избранное"

Менеджеры внешних отчетов v8 УНФ Россия Абонемент ($m)

Часто при добавлении внешнего отчета в конфигурацию "1С: Управление нашей фирмой" его невозможно добавить в "Избранное" в списке "Все отчеты", а также не работает фильтр по подсистемам, за которой этот отчет закрепляли. Попробуем разобраться, почему такое происходит.

1 стартмани

27.11.2018    8326    23    xSavantx    1    

Менеджер дополнительных отчетов для 8.3

Менеджеры внешних отчетов v8 БП3.0 Россия Абонемент ($m)

Предложен менеджер дополнительных отчетов для 8.3, реализованный в расширении.

1 стартмани

08.11.2018    6199    1    vikhrov53    1    

Выгрузка/Загрузка внешних обработок УТ 10.3 / УПП 1.3

Универсальные обработки Менеджеры внешних отчетов v8 БП2.0 ЗУП2.5 УТ10 УПП1 Абонемент ($m)

Обработка для выгрузки на диск/загрузки с диска элементов справочника "Внешние обработки"

1 стартмани

20.07.2018    6181    10    vano-ekt    2    

Настройка сортировки начислений в отчетах ЗКГУ 3, ЗУП 3

Зарплата Менеджеры внешних отчетов Зарплата v8 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Обработка позволяет быстро настроить порядок вывода начислений в различных типовых отчетах ЗКГУ 3, ЗУП 3.

1 стартмани

20.04.2018    8527    44    ZHPN24    1    

Контекст внешних (дополнительных) отчетов. УНФ

Менеджеры внешних отчетов Практика программирования v8 УНФ Россия Абонемент ($m)

Расширение для исправления ошибки в "Управление нашей фирмой, редакция 1.6 (1.6.12.4) "

1 стартмани

20.02.2018    8233    0    shetill    0    

Открытие всех отчетов сразу с расширенной настройкой

Менеджеры внешних отчетов v8 УТ11 Россия Абонемент ($m)

Сделал, чтобы пользователи не приставали с вопросами как изменить настройки, так как все отчеты открываются без возможности изменения Структуры.

1 стартмани

23.01.2018    8529    5    fedor40    2    

Дополнительное меню в Рознице 2.2 без изменения конфигурации

Работа с интерфейсом Менеджеры внешних отчетов Рабочее место Розничная торговля Розничная торговля v8 v8::Права Розница УУ Абонемент ($m)

Заказчик захотел, чтобы кассиру были доступны специально настроенные варианты отчетов по остаткам и движениям товаров с артикулами, а также ввод счетчиков посетителей и просмотр этих счетчиков. Причем изменять конфигурацию было нельзя – она была типовая, и кроме того, была развернута РИБ из нескольких узлов.

1 стартмани

10.10.2017    12794    4    fixin    0    

Обновление/добавление вариантов отчета, разработанного с помощью СКД, в режиме 1С: Предприятия 8.3

Менеджеры внешних отчетов v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Версия БСП 1.2 При разработке нового отчета при помощи системы компоновки данных и при добавлении нескольких вариантов отчета на этапе разработки. После добавления данного отчета в состав конфигурации данные варианты отчета не появляются в режиме предприятия. Есть конечно же и стандартная обработка для регистрации вариантов отчета, но насколько мне известно она работает если конфигурация разработана на базе БСП. Если этот момент отсутствует либо не перенесены все необходимые подсистемы из БСП в разрабатываемую конфигурацию стандартную обработку необходимо "допилить". Для этого и была разработана данная обработка, которая работает в любой конфигурации без подсистем БСП.

1 стартмани

30.08.2017    21687    74    mityushov.vv    11    

Перенос настроек отчетов на шаблоне типового отчета

Менеджеры внешних отчетов v8 v8::СКД КА1 ЗУП2.5 УПП1 Абонемент ($m)

Обработка предназначена для переноса настроек отчетов внешних отчетов, написанных на шаблоне типового отчета (СКД, настройки хранятся в справочнике Сохраненные настройки) из одной базы в другую

2 стартмани

18.05.2017    15810    14    echo77    0    

Предопределенные варианты отчетов в УТ 11 не появляются в форме выбора

Менеджеры внешних отчетов v8 УТ11 Россия Абонемент ($m)

Я думаю, многие разработчики сталкивались с такой проблемой. Создаем отчет - добавляем несколько вариантов, но в пользовательском режиме почему-то нет этих вариантов и все тут...

1 стартмани

07.03.2017    13339    22    lenna1c    0    

Добавление внешнего отчета, обработки, печатной формы в несколько десятков баз. 8.2, обычные формы.

Менеджеры внешних отчетов Универсальные обработки Рабочее место v8 1cv8.cf Абонемент ($m)

Автоматизируем рабочее место автоматизатора. После того, как готов новый отчет, начинается самое муторное. Его надо добавить в базу, чтобы им смогли пользоваться те, для кого он написан. Если баз 3-5-7, это не страшно. А если их 40-50, добавление нового отчета вручную становится очень нудной задачей.

1 стартмани

11.11.2016    15261    6    корум    8    

Управление дополнительными отчетами и обработками УФ для БП 3.0 и УТ 11

Информационная безопасность Универсальные обработки Менеджеры внешних отчетов v8 v8::УФ БП3.0 УТ11 Абонемент ($m)

Что делать, когда у вас куча дополнительных обработок? Использовать эту обработку. Которая позволяет для выделенных элементов установить размещение и быстрый доступ

2 стартмани

06.03.2016    12931    10    Andruykha    2    

Выгрузка всех внешних отчетов и обработок

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Обработка выгружает все внешние отчеты, обработки, печатные формы, обработки табличных частей.

1 стартмани

30.06.2014    22536    109    Ivan_Sol    10    

Подсистема хранения внешних файлов

Менеджеры внешних отчетов Обработка документов Обработка справочников v8 1cv8.cf Абонемент ($m)

Мы долго шли к тому, чтобы на производстве технологи заводили номенклатуру, а мастера знали как ее собирать, имея под рукой чертеж, чтобы оперативно видеть документы по контрагенту или сканы документов. Но стандартный функционал УПП принуждал хранить данные в базе. Есть способ хранения внешних файлов без изменения стандартного функционала.

1 стартмани

27.12.2013    32234    205    sovital    32    

Универсальное меню

Менеджеры внешних отчетов Обработка документов Универсальные обработки v8 1cv8.cf Абонемент ($m)

Движок меню. 1. Без изменения конфигурации присвоение статусов со светофором (раскраска строк по статусам) 2. Подключение внешних обработок и отчетов

1 стартмани

07.11.2013    18783    8    Shagzhin    11    

Обработка для просмотра файлов .vrp

Менеджеры внешних отчетов v8 1cv8.cf Украина Абонемент ($m)

Обработка позволяет просматривать файлы vrp, которые можно сохранить из формы элемента справочника "Варианты отчетов" (Сохраненные настройки). Также выводится представление XML для значений параметров отчетов. Это позволяет получить Настройки компоновки данных для их вставки в Консоль системы компоновки данных.

1 стартмани

25.10.2013    22546    64    algabas    2    

PARAM. Карта разума и 1С Предприятие 8

Менеджеры внешних отчетов Практика программирования v8 Абонемент ($m)

Скрипт PARAM служит для перехода из ветки интеллектуальной карты в конкретное место конфигурации 1С.

1 стартмани

01.10.2013    23261    14    knight2007    11    

Менеджер внешних отчетов и обработок

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Решение для хранения используемых внешних отчетов и обработок без привязки к конфигурации. С возможностью экспорта/импорта списка.

1 стартмани

19.09.2013    14114    25    killitch    4    

Синхронизатор внешней обработки по нескольким базам (8.2)

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Обработка, которая копирует внешнюю обработку из справочника "внешние обработки" одной базы в несколько других.

1 стартмани

18.07.2013    17062    37    zhmurr    11    

Менеджер внешних обработок и отчетов

Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Обработка, которая находит внешние отчеты и обработки в указанном каталоге и позволяет их открывать.

1 стартмани

27.06.2013    18672    55    Demic    7    

Каталог внутренних и внешних объектов (для 1С8)

Менеджеры внешних отчетов Универсальные обработки v8 1cv8.cf Абонемент ($m)

Универсальная обработка предназначена для быстрого доступа к различным внешним и внутренним объектам базы 1С 8. С ее помощью можно легко создать аналог собственного динамически фильтруемого интерфейса.

1 стартмани

19.04.2012    23688    141    Altair777    26    

Синхронизация файлов

Универсальные обработки Сервисные утилиты Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Простая обработка для синхронизации файлов на локальных и сетевых дисках. По мотивам http://infostart.ru/public/63296/, доработанная и переведенная на управляемые формы.

1 стартмани

08.02.2012    17191    28    Mopo3    1    

Вызвать внешний отчёт или обработку - быстро и удобно (8.2)

Менеджеры внешних отчетов Универсальные обработки v8 1cv8.cf Абонемент ($m)

Эта обработка поможет организовать удобный и быстрый доступ ко внешним отчётам и обработкам.

1 стартмани

03.10.2011    19590    106    Somebody1    50    

Обработка для синхронизации файлов 8.1

Менеджеры внешних отчетов Универсальные обработки v8 1cv8.cf Абонемент ($m)

Вот, решил выложить свою обработку для синхронизации файлов. Синхронизируются файлы по дате.

1 стартмани

03.06.2011    16516    75    greystone    4    

ДОРАБОТАННАЯ конвертация обработок и ВНЕШНИХ ОТЧЕТОВ из 8.1 в 8.2

Менеджеры внешних отчетов Универсальные обработки Обработка справочников v8 1cv8.cf БП2.0 ЗУП2.5 УТ10 ЗКБУ Розница УПП1 УНФ Россия Абонемент ($m)

Выполнял срочный перевод БД на 8.2, т.к. срочно нужно обеспечить защиту персональных данных с помощью Z- модуля - очередного способа распила бабла, вероятно.. Оказалось, что после использования штатной обработки (встроенной в бюджетный ЗУП) при переходе с платформы 8.1 на 8.2 ВСЕ ВНЕШНИЕ ОТЧЕТЫ РАЗРУШАЮТСЯ.. Не остается ни кодов, ни форм, ни фига вообще.. а у нас их 130 штук.. Оценили шутку, да? 1С - ВЫ &$%#@& !!!!..

1 стартмани

01.12.2010    25232    1018    kote    31    

Пакетный запуск обработок

Сервисные утилиты Менеджеры внешних отчетов v8 1cv8.cf Абонемент ($m)

Обработка, позволяющая без изменения конфигурации, выполнять/открывать при старте системы произвольное количество дополнительных отчетов/обработок, передавать им параметры. Возможно открывать как обработки в составе конфигурации, как внешние обработки в файле, так и внешние обработки из справочника Внешние обработки.

1 стартмани

01.06.2010    24771    577    zzerro    16