Проверка подписки ИТС

Публикация № 1211359

Администрирование - Администрирование СУБД

Проверка подписки ИТС по регистрационным номерам, логинам. Практическое применение API по интеграции с Порталом 1С:ИТС.

Обработка позволяет проверить как кой статус у договора 1С:ИТС на текущий момент (Договор 1С:ИТС не оформлен, Срок действия договора 1С:ИТС завершился, Договор 1С:ИТС оформлен), а так же получить информацию о договорах 1С:ИТС по логину пользователя (Пользователь с таким логином не найден, Для данного пользователя проверка 1С:ИТС не предусмотрена, Срок действия договора 1С:ИТС завершился и т.д.)

Для получения информации достаточно просто указать рег.номер или логин ИТС. Для доступа к API вам потребуется Логин и Пароль- как их получить можно прочитать тут:
https://portal.1c.ru/partner/faq#subscription

В результате проверки выводится сообщение с информацией: какой рег.номер, статус, код статуса, описание статуса, описание ошибки (если были), дата начала и окончания договора получены с портала ИТС.

Весь код отработки открыт и так же прилагается ниже
Протестировано на платформе 1С:Предприятие 8.3 (8.3.16.1063) в файловом и клиент серверном режимах.

Наверное аналогия //infostart.ru/public/1104962/ (но проверить не могу- так как там нужно покупать).

&НаСервере
Процедура ПроверитьИТСПоРегНомеруНаСервере()

    МестоположениеWSDL = "https://partner-api.1c.ru/api/ws/subscription/v2?wsdl";
    URIПространстваИмен = "http://api.repository.onec.ru/v2";
    ИмяСервиса = "PartnerSubscriptionApiV2ServiceImplService";
    ИмяТочкиПодключения = "PartnerSubscriptionApiV2ServiceImplPort";
    ОписаниеОшибки = "";

    Прокси = ПроксиСервиса(МестоположениеWSDL, URIПространстваИмен, ИмяСервиса, ИмяТочкиПодключения, ОписаниеОшибки);

    // Можно проверять по 100 рег номеров.
    МассивРегистрационныхНомеров = Новый Массив;
    МассивРегистрационныхНомеров.Добавить(РегистрационныйНомер);

    Если ПустаяСтрока(ОписаниеОшибки) Тогда

        ФабрикаXDTOСервиса = Прокси.ФабрикаXDTO;

        ВходныеПараметры = ФабрикаXDTOСервиса.Создать(Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "checkItsByRegNum"));

        // Передача списка рег.номеров.
        ТипregNumList = ФабрикаXDTOСервиса.Тип(URIПространстваИмен, "regNumList");
        ОбъектregNumList = ФабрикаXDTOСервиса.Создать(ТипregNumList);
        Для Каждого РегНомер Из МассивРегистрационныхНомеров Цикл 
            ОбъектregNumList.regNumList.Добавить(РегНомер);
        КонецЦикла;    

        ВходныеПараметры.regNumList = ОбъектregNumList;            

        Попытка
            ОбъектXDTO = Прокси.checkItsByRegNum(ВходныеПараметры);
        Исключение
            ИнформацияОбОшибке = ИнформацияОбОшибке();
            ОписаниеОшибки = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке);
        КонецПопытки;
    КонецЕсли;

    ПараметрыОтвета = ПараметрыОтветаСервисаПроверкиИТС();

    Если ПустаяСтрока(ОписаниеОшибки) Тогда 
        Для Каждого ОбъектXDTOreturn Из ОбъектXDTO.return Цикл 

            ПараметрыОтвета.РегНомер = ОбъектXDTOreturn.element;

            // AgreementNotExists     101     Договор 1С:ИТС не оформлен
            // OldContract             104     Срок действия договора 1С:ИТС завершился
            // Success                 1         Договор 1С:ИТС оформлен
            ПараметрыОтвета.КодСтатуса = ОбъектXDTOreturn.code;
            ПараметрыОтвета.Статус = ОбъектXDTOreturn.status;
            ПараметрыОтвета.ОписаниеСтатуса = ОбъектXDTOreturn.description;

            // Список ошибок.
            Для Каждого ОбъектXDTOsubscriptionInfoList Из ОбъектXDTOreturn.subscriptionInfoList Цикл 
                ПараметрыОтвета.ОписаниеОшибки = ОбъектXDTOsubscriptionInfoList.description;
                ПараметрыОтвета.ДатаНачала = ОбъектXDTOsubscriptionInfoList.startDate;
                ПараметрыОтвета.ДатаОкончания = ОбъектXDTOsubscriptionInfoList.endDate;
            КонецЦикла;    
        КонецЦикла;    
    КонецЕсли;    

    Для Каждого Параметр Из ПараметрыОтвета Цикл 
        Сообщить(Параметр.Ключ + " / " + Параметр.Значение);
    КонецЦикла;    

КонецПроцедуры
&НаСервере
Процедура ПроверитьИТСПоЛогинуНаСервере()

    МестоположениеWSDL = "https://partner-api.1c.ru/api/ws/subscription/v2?wsdl";
    URIПространстваИмен = "http://api.repository.onec.ru/v2";
    ИмяСервиса = "PartnerSubscriptionApiV2ServiceImplService";
    ИмяТочкиПодключения = "PartnerSubscriptionApiV2ServiceImplPort";
    ОписаниеОшибки = "";

    Прокси = ПроксиСервиса(МестоположениеWSDL, URIПространстваИмен, ИмяСервиса, ИмяТочкиПодключения, ОписаниеОшибки);

    Если ПустаяСтрока(ОписаниеОшибки) Тогда

        ФабрикаXDTOСервиса = Прокси.ФабрикаXDTO;

        ВходныеПараметры = ФабрикаXDTOСервиса.Создать(Прокси.ФабрикаXDTO.Тип(URIПространстваИмен, "checkItsByLogin"));

        // Передача списка логинов.
        ТипloginList = ФабрикаXDTOСервиса.Тип(URIПространстваИмен, "loginList");
        ОбъектloginList = ФабрикаXDTOСервиса.Создать(ТипloginList);

        // Так же можно проверять и массив как сделано в ПроверитьИТСПоРегНомеруНаСервере
        ОбъектloginList.loginList.Добавить(РегистрационныйНомер);

        ВходныеПараметры.loginList = ОбъектloginList;            

        Попытка
            ОбъектXDTO = Прокси.checkItsByLogin(ВходныеПараметры);
        Исключение
            ИнформацияОбОшибке = ИнформацияОбОшибке();
            ОписаниеОшибки = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке);
        КонецПопытки;
    КонецЕсли;

    ПараметрыОтвета = ПараметрыОтветаСервисаПроверкиИТС();

    Если ПустаяСтрока(ОписаниеОшибки) Тогда 
        Для Каждого ОбъектXDTOreturn Из ОбъектXDTO.return Цикл 

            // LoginNotFound    102    Пользователь с таким логином не найден
            // IsNotUser        103    Для данного пользователя проверка 1С:ИТС не предусмотрена
            // OldContract        104    Срок действия договора 1С:ИТС завершился
            // NoContract        105    У пользователя нет действующего договора 1С:ИТС
            // Success            1    Договор 1С:ИТС оформлен            
            ПараметрыОтвета.КодСтатуса = ОбъектXDTOreturn.code;
            ПараметрыОтвета.Статус = ОбъектXDTOreturn.status;
            ПараметрыОтвета.ОписаниеСтатуса = ОбъектXDTOreturn.description;

            // Список ошибок.
            Для Каждого ОбъектXDTOsubscriptionInfoList Из ОбъектXDTOreturn.subscriptionInfoList Цикл 
                ПараметрыОтвета.ОписаниеОшибки = ОбъектXDTOsubscriptionInfoList.description;
                ПараметрыОтвета.ДатаНачала = ОбъектXDTOsubscriptionInfoList.startDate;
                ПараметрыОтвета.ДатаОкончания = ОбъектXDTOsubscriptionInfoList.endDate;
            КонецЦикла;    
        КонецЦикла;    
    КонецЕсли;

    Для Каждого Параметр Из ПараметрыОтвета Цикл 
        Сообщить(Параметр.Ключ + " / " + Параметр.Значение);
    КонецЦикла;    

КонецПроцедуры
#Область СлужебныеПроцедурыИФункции

Функция ПроксиСервиса(URLМестоположенияWSDL, URIПространстваИмен, ИмяСервиса, ИмяТочкиПодключения, ОписаниеОшибки)

    Прокси = Неопределено;

    ПараметрыПодключения = ОбщегоНазначения.ПараметрыПодключенияWSПрокси();
    ПараметрыПодключения.АдресWSDL           = URLМестоположенияWSDL;
    ПараметрыПодключения.URIПространстваИмен = URIПространстваИмен;
    ПараметрыПодключения.ИмяСервиса          = ИмяСервиса;
    ПараметрыПодключения.ИмяТочкиПодключения = ИмяТочкиПодключения;
    ПараметрыПодключения.ИмяПользователя     = ЛогинAPI;
    ПараметрыПодключения.Пароль              = ПарольAPI;
    ПараметрыПодключения.Таймаут             = 60;

    Попытка
        Прокси = ОбщегоНазначения.СоздатьWSПрокси(ПараметрыПодключения);
    Исключение
        ОписаниеОшибки = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке());
    КонецПопытки;

    Возврат Прокси;

КонецФункции

Функция ПараметрыОтветаСервисаПроверкиИТС()

    ПараметрыОтвета = Новый Структура;
    ПараметрыОтвета.Вставить("РегНомер", "");
    ПараметрыОтвета.Вставить("КодСтатуса", "");
    ПараметрыОтвета.Вставить("Статус", "");
    ПараметрыОтвета.Вставить("ОписаниеСтатуса", "");
    ПараметрыОтвета.Вставить("ОписаниеОшибки", "");
    ПараметрыОтвета.Вставить("ДатаНачала", "");
    ПараметрыОтвета.Вставить("ДатаОкончания", "");
    Возврат ПараметрыОтвета;

КонецФункции // ПараметрыОтветаСервисаПроверкиИТС()

#КонецОбласти

 

Скачать файлы

Наименование Файл Версия Размер
Проверка подписки ИТС:
.epf 8,35Kb
17.03.20
0
.epf 8,35Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

История работы пользователей (отчет на СКД)

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m) Администрирование СУБД

Отчет для просмотра истории работы пользователей (СКД, просмотр для любого пользователя).

2 стартмани

14.03.2020    2408    28    YPermitin    22       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Ограничение доступа в базу по количеству сеансов или дате

Инструменты и обработки Системный администратор Расширение (cfe) v8 1cv8.cf Абонемент ($m) Администрирование СУБД

Расширение позволяет ограничить доступ в базу по количеству активных сеансов или дате. Не затрагивает объекты типовой конфигурации. Сделано и протестировано на БП 8.3 версий 3.0.65.84 и выше. Требует платформу не ниже 8.3.16. Представлены версии расширения для конфигураций с режимом совместимости 8.3.12, 8.3.14 и 8.3.15.

2 стартмани

12.03.2020    571    folo    0       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Изменение имени домена для выбранных пользователей информационной базы

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Россия Абонемент ($m) Администрирование СУБД

Предлагаю Вашему вниманию обработку используемую в реальном производственном процессе на нашем предприятии. Задача переименования доменов возникла при реорганизации предприятия, имена некоторых доменов для удобства решено было изменить, но при таком количестве пользователей изменение имен доменов штатными средствами выглядело нереально. Было решено создать обработку для изменения имен доменов Информационной базы. Обработка предназначена для работы в клиент-серверных базах и тестировалась на платформе 8.3.14.1854. Работает в режиме внешней обработки.

1 стартмани

30.01.2020    732    bryantsev.yury    0       

Онлайн-курс «Автоматизация процессов управления МТО: методика сбора и формализации требований» с 1 апреля по 13 мая 2020 года. Промо

Цель курса - повысить полноту и качество сбора и формализации требований к автоматизации процессов управления материально-техническим обеспечением. Курс основан на процессном подходе, позволяет в полном объеме выявить и учесть все факторы, влияющие на специфику процессов управления МТО. Участники курса получают теоретические знания в области организации процессов управления МТО и готовый инструментарий для сбора и формализации требований по автоматизации этих процессов (шаблоны, опросники, модели).

40000 рублей

Проверка SQL базы данных 1С 8.1, 8.2, 8.3

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf MS SQL Абонемент ($m) Администрирование СУБД

Обработка предназначена для проверки SQL базы данных 1С. Используется только для клиент-серверной версии 1С, у которой база данных хранится под управлением MS SQL Server. Конфигурация 1С значения не имеет.

2 стартмани

25.12.2019    4521    36    dgonson    19       

На время отключаем контроль остатков и проверку документов

Статья Системный администратор Программист Расширение (cfe) v8 ERP2 УТ11 КА2 Абонемент ($m) Администрирование СУБД

На время сеанса отключаем контроль остатков и проверку документов в ERP, КА, УТ типовыми средствами и простым расширением.

1 стартмани

24.12.2019    4084    5    sapervodichka    2       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Тест серверного оборудования на допустимое количество пользователей: как это использовать?

Статья Системный администратор Программист Архив с данными v8 1cv8.cf Абонемент ($m) Администрирование СУБД Нагрузочное тестирование Сервера

Выполнил 3 разных теста для проверки серверного оборудования (тест 1С, тесты gilev) на возможное число 1С онлайн-пользователей одновременно работающих на нем и интерпретировал результаты тестов через легких, средних и тяжелых пользователей с помощью таблицы с профилями реальных пользователей.

3 стартмани

17.12.2019    7449    9    sapervodichka    3       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Очистка кэша нескольких баз прямо из 1С

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Администрирование СУБД

Обработка предназначена для очистка кэша нескольких баз непосредственно из 1С (только в обычном режиме).

1 стартмани

04.12.2019    2170    15    r.moschenskiy    2       

Работа с базами данных 1С в SQL Server Management Studio (Расширение для SSMS)

Инструменты и обработки Системный администратор Программист Архив с данными v8 Windows Абонемент ($m) Администрирование СУБД Производительность и оптимизация (HighLoad) Администрирование данных 1С Структура метаданных

Расширение позволяет просматривать связи объектов метаданных и таблиц БД, сгруппированные данные (по группам метаданных) об используемом дисковом пространстве и выполнять трансляцию SQL текста запроса в термины 1С. И бонусом - при наведении курсора мыши на таблицу или поле показывает назначение объекта в терминах 1С.

10 стартмани

27.11.2019    7807    32    akpaevj    46       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

CF & SQL : конструктор прямых запросов к БД 1С

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Россия MS SQL Абонемент ($m) Инструментарий разработчика Администрирование СУБД

Программа для чтения и анализа внутренней структуры данных 1С V8.х, Содержит конструктор прямых SQL запросов, позволяет обрабатывать и редактировать тексты SQL-запросов, выполнять прямые запросы к базе данных 1С и обрабатывать полученные результаты.

1 стартмани

02.10.2019    11234    157    dmitrydemenew    36       

DevOps для 1С. Онлайн-курс проходит с 16 апреля по 11 июня 2020 года. Промо

Данный онлайн-курс предусматривает изучение процессов DevOps, их применение при разработке на платформе 1С. В результате прохождения онлайн-курса вы сможете: настроить ПО необходимое для проведения проверок и тестирования, создавать сценарии тестирования и объединять их в комплексные процессы, создавать скрипты для автоматизации процессов DevOps.

12000 рублей

Закрытие незавершенных сеансов

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Сервисные утилиты Администрирование СУБД

Как удалять потерянные сеансы пользователей, чтобы они не мешали работе. Обработка протестирована на платформе версии 8.3.13.1644.

1 стартмани

20.09.2019    7279    33    AnatolPopov    8       

Легкое и гибкое управление списком доступных баз 1С у пользователей

Инструменты и обработки Системный администратор Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Стартеры 1С Сервисные утилиты Администрирование СУБД

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

5 стартмани

05.12.2018    10587    9    RomikR    9       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 20 апреля по 15 мая 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Размер таблицы SQL базы 1С

Отчеты и формы Программист Внешний отчет (ert,erf) v8 1cv8.cf Россия Абонемент ($m) Статистика базы данных Сервисные утилиты Администрирование СУБД Структура метаданных

Обработка для анализа структуры БД в виде таблиц SQL, их объемов и объемов индексов таблиц. Писалась для анализа в целях оптимизации работоспособности и быстродействия 1С. Будет полезна администраторам и разработчикам, в целях поиска нужной таблицы в SQL по метаданным конфигурации. Две обработки: 1. "Размер таблицы SQL базы 1С не УФ" - не управляемые формы - работает на любой конфигурации 1С 8.2/8.3 (тестировалась УПП 10.3, КА 1.1, ЗУП 2.5 и т.д.) 2. "Размер таблицы SQL базы 1С УФ" - под управляемые формы - работает под любыми конфигурациями 1С 8.3 (тестировалась УТ 11)

1 стартмани

11.04.2017    16715    83    Mouros    5