Типовая борьба - личный опыт работы с типовыми конфигурациями 1С:8

Публикация № 122229

Разработка - Практика программирования

118
Мои личные заметки по работе с типовыми конфигурациями. Записывал то, что может пригодиться у других клиентов, для повторного использования. Планирую регулярно обновлять.

Личный опыт Гения 1С борьбы с типовыми конфигурациями 1С8

Оглавление

Технологии сопровождения типовых конфигураций. 2

Обновление типовых конфигураций. 2

Принципы внесения доработок. 2

Внешние компоненты.. 3

Права доступа. 3

Дополнительные права доступа. 3

Права доступа на внешние обработки. 4

Некоторые конкретные рецепты по правам доступа. 5

Дата запрета редактирования. 6

Кастомизация пользователей. 6

Настройки пользователей. 6

Архитектура. 6

Документы.. 6

Оргструктура. 7

Организации. 7

Складской функционал. 7

Отчет по стоимостной оценке склада. 7

Работа по ордерной схеме. 7

Торговый функционал. 8

Резервирование товаров. 8

Реализация. 9

Cчет-фактуры выданные. 10

Технологии. 10

Партионный учет. 10

Отчеты.. 11

Печать. 13

Взаимодействие пользователя с программой. 13

Работа с задачами пользователей. 13

РАЗДЕЛ: ТОРГОВОЕ ОБОРУДОВАНИЕ. 14

Рабочее место кассира. 14

Настройки рабочего места кассира. 14

Фискальный регистратор. 14

Драйвер ФР в 1С. 14

Штрих-кодирование. 14

Поиск по штрих-коду. 14

РАЗДЕЛ: ОБМЕНЫ ДАННЫМИ.. 17

Общие свойства типовых обменов. 17

Внутренняя механика работы обменов. 17

Типовые обмены в РИБ. 17

Типовые обмены данными по правилам.. 17

Проведение отложенных документов. 17

Обмен УТ-БП.. 17

РАЗДЕЛ: ОШИБКИ ТИПОВЫХ. 18

Ошибки в розничной торговле. 18

Ошибки в процедуре закрытия кассовых смен. 18

 

Опыт борьбы с типовыми конфигурациями Гения 1С.

Технологии сопровождения типовых конфигураций

Обновление типовых конфигураций

Номер версии конфигурации

Иногда обновление конфигурации не происходит, при этом при каждом запуске программа сообщает об этом:

      

НомерВерсии = Константы.НомерВерсииКонфигурации.Получить();

       ПервыйЗапуск = (НомерВерсии = "");

      

       Если НЕ ПустаяСтрока(Метаданные.Версия)

          И НомерВерсии <> Метаданные.Версия Тогда

             Если Не ПервыйЗапуск Тогда

                    Предупреждение("Изменился номер версии конфигурации. Будет выполнено обновление информационной базы.");

             КонецЕслИ;

       Иначе

             Возврат;

       КонецЕсли;

 

Чтобы избавиться от проблемы, нужно выполнить в консоли кода такой код:

 

Константы.НомерВерсииКонфигурации.Установить("");

 

По сути, он указывает программе, что произошел первый запуск программы.

Принципы внесения доработок

Альтернатива предопределенным элементам

Правильный подход – добавлять предопределенные элементы в справочнике для предопределенных объектов. Но если изменения в конфигурацию вносить нельзя, можно добавлять обычные элементы и искать их по определенному коду. Ведь если вносится новый предопределенный элемент, конфигурацию уже нельзя обновить динамически.

 

Внешние компоненты

1С: Печать штрих-кодов

Файл установки элемента управления «1CBarCode.exe» находится на диске ИТС в каталоге «1CITS\EXE\TradeWare\1C\1CBarCode»

Права доступа

Дополнительные права доступа

В типиках есть возможность назначать дополнительные права пользователям. Можно создавать свои дополнительные права.

Права доступа на внешние обработки

В типовых конфигурациях нельзя назначить права доступа на каждую обработку. Вариант решения – создать дополнительное право пользователя и в самой обработке проверять, доступно это право или нет.

Дополнительные права доступа и RLS

Если есть частая потребность, чтобы объекты могли редактировать/просматривать пользователи, обладающие каким-либо дополнительным правом, можно использовать следующий поход.

Допустим, нужно дать доступ только избранным пользователям к регистру «Премии».

Нужно завести дополнительное право с идентификатором «ПросмотрПремий», параметр сеанса «ПравоПросмотрПремий».

Параметры сеанса такого типа заполняются автоматически кодом, который нужно вставить в процедуру 

ПередНачаломРаботыПриложения:

       //Осипов - устанавливаем права доступа

       З = Новый Запрос(

       "ВЫБРАТЬ

       |      ПраваПользователей.Ссылка

       |ИЗ

       |      ПланВидовХарактеристик.ПраваПользователей КАК ПраваПользователей

       |ГДЕ

       |      ПраваПользователей.Предопределенный");

       МассивПрав = З.Выполнить().Выгрузить().ВыгрузитьКолонку("Ссылка");

       Для Каждого Право ИЗ МассивПрав Цикл

             ИмяПрава = ПланыВидовХарактеристик.ПраваПользователей.ПолучитьИмяПредопределенного(Право);

             ИмяПараметраСеанса = "Право" + ИмяПрава;

             Если Метаданные.ПараметрыСеанса.Найти(ИмяПараметраСеанса) <> Неопределено Тогда

                    ПараметрыСеанса[ИмяПараметраСеанса] = _Функции.ЕстьДополнительноеПраво(ПланыВидовХарактеристик.ПраваПользователей[ИмяПрава], ложь);

             КонецЕсли;

       КонецЦикла;

Далее, в RLSна чтение и/или изменение на нужно добавить простое условие для набора полей «Дополнительные поля», в нашем примере «ГДЕ &ПравоПросмотрПремий». К сожалению, платформа не позволяет назначить одинаковые RLSсразу на все роли.

Теперь можно управлять RLS-ом непосредственно из дополнительных прав пользователей.
Отсутствие функции по получению булева права доступа (УТ 10)

Почему-то отсутствует функция для проверки, имеет пользователь дополнительное право или нет. Проверка прав везде делается одним и тем же кодом из 8 строчек, почему для этого кода не сделана отдельная функция, не понятно:

       Разрешено = УправлениеПользователями.ПолучитьЗначениеПраваДляТекущегоПользователя(ПланыВидовХарактеристик.ПраваПользователей.НайтиПоНаименованию("Разрешено использовать реестр "), Ложь);

       Если Разрешено.Количество() = 0 Тогда

             Разрешено = Ложь;

       ИначеЕсли Разрешено.Количество() > 1 Тогда

             Разрешено = Истина;

       Иначе

             Разрешено = Разрешено[0].Значение;

       КонецЕсли;

Рекомендую вместо этих строк использовать функцию:

Функция ЕстьДополнительноеПраво(Право, ЗначениеПоУмолчанию = ложь) Экспорт

       Разрешено = УправлениеПользователями.ПолучитьЗначениеПраваДляТекущегоПользователя(Право, ЗначениеПоУмолчанию);     

       Если Разрешено.Количество() = 0 Тогда         

             Разрешено = Ложь;         

       ИначеЕсли Разрешено.Количество() > 1 Тогда           

             Разрешено = Истина;       

       Иначе       

             Разрешено = Разрешено[0].Значение;            

       КонецЕсли;  

       Возврат Разрешено; 

КонецФункции

 

Очистка кэша дополнительных права доступа

Если администратор меняет пользователю дополнительные права доступа, пользователю нужно перезайти в 1с. Это неудобно. Проще дать ему команду для очистки сохраненных в кэше прав доступа:

Кэш = глЗначениеПеременной("ЗначенияДополнительныхПравПользователя");

Если Кэш <> Неопределено Тогда

  Кэш.Очистить();

КонецЕсли;
 

Права доступа на внешние обработки

Как запретить запускать и редактировать внешние обработки (УТ 10)

Для того, чтобы в типовых запретить доступ к типовым обработкам, нужно добавить дополнительное право и поставить заглушки.

В код запуска обработки при щелчке в форме списка в процедуру СправочникСписокВыбор добавить в начало код:

      

ДП = ПланыВидовХарактеристик.ПраваПользователей.РазрешитьПрямуюРаботуСВнешнимиОбработками;

       Если НЕ УправлениеПользователями.ПолучитьБулевоЗначениеПраваПользователя(ДП, Ложь) Тогда

             Предупреждение("Запускать непосредственно внешние обработки может только пользователь с ДП """ + ДП + """!");

             СтандартнаяОбработка = ложь;

             Возврат;

       КонецЕсли;

 

В процедуре ПриОткрытии формы элемента:

      

ДП = ПланыВидовХарактеристик.ПраваПользователей.РазрешитьПрямуюРаботуСВнешнимиОбработками;

       Если НЕ УправлениеПользователями.ПолучитьБулевоЗначениеПраваПользователя(ДП, Ложь) Тогда

             Предупреждение("Редактировать непосредственно внешние обработки может только пользователь с ДП """ + ДП + """!");

             Закрыть(ложь);

             Возврат;

       КонецЕсли;

 

Процедура ПриОткрытии используется, т.к. события ПередОткрытием нет.

Некоторые конкретные рецепты по правам доступа

Право только на ввод физических лиц (ЗУП 2.5)

Назначаем пользователю основную роль «МенеджерПоНаборуПерсонала» и минимальную роль «Пользователь». Создаем дополнительную новую пустую роль «_ВводФЛ» и добавляем ее пользователю. Назначаем интерфейс «Набор персонала».

Создаем новую подписку на все объекты метаданных, заканчивающиеся на Объект на общее для всех событие ПриЗаписи. В коде обработчика прописываем:

Процедура _ВводФЛПриЗаписи(Источник, Отказ) Экспорт

       Если РольДоступна("_ВводФизЛиц") И ТипЗнч(Источник) <> Тип("СправочникОбъект.ФизическиеЛица") Тогда

             ВызватьИсключение "Вашей роли можно записывать только физических лиц";

       КонецЕсли;

КонецПроцедуры

Процедура _ВводФЛПриЗаписи(Источник, Отказ) Экспорт

       Если РольДоступна("_ВводФизЛиц") И ТипЗнч(Источник) <> Тип("СправочникОбъект.ФизическиеЛица") Тогда

             ВызватьИсключение "Вашей роли можно записывать только физических лиц";

       КонецЕсли;

КонецПроцедуры
 

В результате при записи будет выдаваться сообщение вида:

Если требуется не только вводить физлиц, но и вносить сопутстующую информацию, заполняя связанные справочники, пригодится такой код проверки:

Процедура _ВводФЛПриЗаписи(Источник, Отказ) Экспорт

       Если РольДоступна("_ВводФизЛиц") И

             НЕ (

             ТипЗнч(Источник) = Тип("СправочникОбъект.ФизическиеЛица") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.Военкоматы") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.КлассификаторСтранМира") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.ЗваниеГражданскогоВоинскогоУчета") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.СоставыВоеннослужащих") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.УчебныеЗаведения") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.ВидыОбразованияФизЛиц") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.КлассификаторСпециальностейПоОбразованию") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.ПрофессииРабочих") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.УченыеСтепени") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.УченыеЗвания") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.ВидыСтажа") ИЛИ           ТипЗнч(Источник) = Тип("СправочникОбъект.КлассификаторСпециальностейПоОбразованию") ИЛИ

             ТипЗнч(Источник) = Тип("СправочникОбъект.Награды")

             ) Тогда

             ВызватьИсключение "Вашей роли можно записывать только физических лиц";

       КонецЕсли;

КонецПроцедуры
 

Также в роль «_ВводФЛ» нужно право на чтение, изменение и добавление справочника «Виды стажа».

Дата запрета редактирования

Обмен с учетом даты запрета редактирования

Дата запрета редактирования может застопорить обмен. Поэтому пользователю, под которым происходит обмен, нужно или ставить максимально раннюю дату, или добавлять в конфигурации в начало методов ПередЗаписьюДокументаДатаЗапретаРедактированияПередЗаписью и ПередЗаписьюРегистраДатаЗапретаРедактированияПередЗаписью  код:

    

  Если Источник.ОбменДанными.Загрузка = истина Тогда

             Возврат;

       КонецЕсли;

 

Кастомизация пользователей

Настройки пользователей

Программно получить пользователей, у которых включена настройка

Чтобы получить пользователей с заданным значением настройки, можно использовать функцию:

Функция ПользователиСУказаннойНастройкой(Настройка, Значение) Экспорт

       //Возвращает массив пользователей, у которых включена настройка

       З = Новый Запрос(

       "ВЫБРАТЬ

       |      НастройкиПользователей.Пользователь

       |ИЗ

       |      РегистрСведений.НастройкиПользователей КАК НастройкиПользователей

       |ГДЕ

       |      НастройкиПользователей.Настройка = &Настройка

       |      И НастройкиПользователей.Значение = &Значение");

       З.УстановитьПараметр("Настройка", Настройка);

       З.УстановитьПараметр("Значение", Значение);

       Возврат З.Выполнить().Выгрузить().ВыгрузитьКолонку("Пользователь");

      

 

КонецФункции
 

Архитектура

Документы

Формализация документов

В типиках достаточно сложно создавать новые виды документов, которые комбинировали бы типовые операции по взаиморасчетам, товарам, деньгам и т.п.

В коде много привязок к конкретному виду документа, к виду операции документа. Виды операций не формализованы и не изолированы. Поэтому если вы хотите создать документ, который бы делал, скажем, перемещение с последующим списанием, лучше сделать пачку документов – основной документ и привязанные к нему списание и перемещение, т.к. повторить такой функционал в новом документе обойдется дорого во времени.

Кроме того, формы документов содержат много copy-paste кода, одинаковые участки не формализированы, можно создать форму копированием существующей, но при обновлении типовой конфигурации с работой формы могут возникнуть проблемы.

Удобство работы с движениями документов

В типиках для большинства регистров не сделаны формы списков. А типовое поведение платформы подразумевает, что по щелку на строке списка движений открывается регистратор, а не значение, содержащееся в ячейке. Это не удобно, поэтому имеет смысл сделать доработки.

Добавление своих полей в регистр Продаж (УТ 10.3)

Чтобы добавить свои поля в движения по регистру продаж, их нужно добавить в регистр и табличную часть документа и прописать эти поля в процедуру «ПодготовитьТаблицыДокумента» модуля документа.

 

 

Оргструктура

Организации

 

Связь между организацией и контрагентами

Между организацией и контрагентом не всегда есть связь. Дежурный способ – по ИНН организации найти контрагента и наоборот:

Грузоотправитель = Справочники.КОнтрагенты.НайтиПоРеквизиту("ИНН", Организация.ИНН);

Складской функционал

Отчет по стоимостной оценке склада

Вывод усредненной себестоимости в отчет (УТ 10.3)

В отчете «Стоимостная оценка склада» в неоперативном режиме не выводится себестоимость за единицу. Чтобы она выводилась, нужно:

Добавляем показатель:

 

ИначеЕсли Режим = 1 Тогда // Неоперативный режим
…
             УниверсальныйОтчет.ДобавитьПоказатель("СебестоимостьЦена", "Цена себестоимости", Истина, "ЧЦ=15; ЧДЦ=2");

 

Меняем текст запроса:

      

ИначеЕсли Режим = 1 Тогда // Неоперативный режим
       …
       |      ВЫБОР КОГДА КоличествоОстаток = 0 ТОГДА 0 ИНАЧЕ
             СтоимостьОстаток / КоличествоОстаток КОНЕЦ  КАК СебестоимостьЦена,
       |{ВЫБРАТЬ
             …
       |      СебестоимостьЦена,
       |ИТОГИ
       |      СРЕДНЕЕ(СебестоимостьЦена),

 

Вставляем в структуру полей (вроде бы не обязательно):

УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("СебестоимостьЦена", "СебестоимостьЦена");

 

Работа по ордерной схеме

Проверка записанности документа-основания при приеме/отправке товара по ордерной схеме (Розница 1.0)

Удобно проверять  то, что документ-основание записан в базу, пользователи часто обращаются с этим вопросом.  В процедуре ПередОткрытием добавить:

 

   Если НЕ ЗначениеЗаполнено(ДокументОбъект.Ссылка) Тогда
        Предупреждение("Не записан в базу документ-основание, запишите и повторите вызов обработки!");
        Отказ = истина;
        Возврат;
    КонецЕсли;

Контроль остатков при перемещениях по ордерной схеме

Почему-то в типиках при перемещениях по ордерной схеме не контролируются остатки на складе-отправителе. В результате операторы могут ошибиться и заметить ошибку только когда уже выписывают расходный ордер.

Для того, чтобы отменить это поведение, достаточно заменить строку в модуле проведения документа «Перемещение товаров»:

     

 //Если ЗначениеЗаполнено(СтруктураШапкиДокумента.СкладОтправитель) И Не РеализацияПоОрдернойСхеме Тогда

       //Проверяем остатки всегда, даже при проведении по ордерной схеме...

       Если ЗначениеЗаполнено(СтруктураШапкиДокумента.СкладОтправитель) Тогда

 

Торговый функционал

Резервирование товаров

Кто зарезервировал товары?

Менеджеров часто интересует вопрос – кто из их коллег зарезервировал товары на складе? Для анализа можно использовать отчет «Анализ доступности товаров на складах», добавив группировку «Документ-основание: Ответственный». Но есть один нюанс – по умолчанию менеджеры не могут видеть поля документа «Заказ покупателей», поэтому в роль «Менеджер по продажам» нужно в список доступных для чтения полей RLSдобавить поле «Ответственный».

Можно создать кнопочку, чтобы менеджерам добавлялось/удалялось поле группировки самостоятельно, например, так:

Процедура КоманднаяПанельФормыПоРезервам(Кнопка)

       //Осипов для учета резервов

       ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ПоРезервам.Пометка = НЕ ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ПоРезервам.Пометка;

       НужнаРасшифровкаРезервов = ЭлементыФормы.КоманднаяПанельФормы.Кнопки.ПоРезервам.Пометка;

      

       ИскИзмерение = НайтиИзмерениеСтрокиПостроителяПоПутиКДанным(УниверсальныйОтчет.ПостроительОтчета.ИзмеренияСтроки, "ДокументОснование.Ответственный");

       Если НужнаРасшифровкаРезервов Тогда

             Если ИскИзмерение = Неопределено Тогда

                    УниверсальныйОтчет.ПостроительОтчета.ИзмеренияСтроки.Добавить("ДокументОснование.Ответственный");

             КонецЕсли;

       Иначе

             Если ИскИзмерение <> Неопределено Тогда

                    УниверсальныйОтчет.ПостроительОтчета.ИзмеренияСтроки.Удалить(ИскИзмерение);

             КонецЕсли;

       КонецЕсли;

 

КонецПроцедуры

Функция ВыбратьНастройкуУниверсальногоОтчета(ФормаОтчета, Приставка, ЭлементФормы)

       Перем ИмяОбъекта;

 

       ИмяОбъекта =  Строка(ФормаОтчета.ЭтотОбъект);

      

       СтруктураНастройки = Новый Структура;

       СтруктураНастройки.Вставить("Пользователь", глЗначениеПеременной("глТекущийПользователь"));

       СтруктураНастройки.Вставить("ИмяОбъекта", ИмяОбъекта);

       СтруктураНастройки.Вставить("НаименованиеНастройки", Неопределено);

      

       З = Новый Запрос(

       "ВЫБРАТЬ

       |      СохраненныеНастройки.ИмяОбъекта,

       |      СохраненныеНастройки.НаименованиеНастройки,

       |      СохраненныеНастройки.СохраненнаяНастройка,

       |      СохраненныеНастройки.Пользователь

       |ИЗ

       |      РегистрСведений.СохраненныеНастройки КАК СохраненныеНастройки

       |ГДЕ

       |      СохраненныеНастройки.ИмяОбъекта = &ИмяОбъекта");

       З.УстановитьПараметр("ИмяОбъекта", ИмяОбъекта);

       РезНаборНастроек = Новый СписокЗначений();

       ТЗ = З.Выполнить().Выгрузить();

       Для Каждого Стр ИЗ ТЗ Цикл

             Если Лев(Стр.НаименованиеНастройки, СтрДлина(Приставка)) = Приставка Тогда

                    РезНаборНастроек.Добавить(Стр.СохраненнаяНастройка, Стр.НаименованиеНастройки);

             КонецЕсли;

       КонецЦикла;

      

       Выбор = Неопределено;

       Если РезНаборНастроек.Количество() > 0 Тогда

             Выбор = ФормаОтчета.ВыбратьИзСписка(РезНаборНастроек, ЭлементФормы);

       КонецЕсли;

       Если Выбор <> Неопределено Тогда

             ИскСтрокаТЗ = ТЗ.Найти(Выбор.Значение, "СохраненнаяНастройка");

            

             СтруктураНастройки.Вставить("НаименованиеНастройки",  Выбор.Представление);

             СтруктураНастройки.Вставить("СохраненнаяНастройка",  Выбор.Значение);

             //Чтобы можно было подгружать настройку другого пользователя

             СтруктураНастройки.Вставить("Пользователь",  ИскСтрокаТЗ.Пользователь);

             УниверсальныеМеханизмы.ПолучитьНастройку(СтруктураНастройки);

            

            

             Результат = СтруктураНастройки;

            

             Отчет = ФормаОтчета.ЭтотОбъект;

             Объект = ФормаОтчета.ЭтотОбъект.УниверсальныйОтчет;

             Объект.мТекущаяНастройка = Результат;

             Отчет.ВосстановитьНастройкиИзСтруктуры(Результат.СохраненнаяНастройка);

             Объект.ВосстановитьПараметрыПечати(Объект, Отчет, ФормаОтчета, Результат);

 

       КонецЕсли;

      

      

КонецФункции
 

Реализация

Часто в типиках реквизиты Грузополучатель и Грузоотправитель не связаны с Организацией и Покупателем. А ведь на практике Грузоотправителем чаще всего является Организация, а Грузополучателем – Покупатель. Связка реализовывается через обработчик событий изменения Организации и Покупателя. При открытии нового документа также надо принудительно вызывать эти обработчики – они сами по себе не вызываются для новых документов.

Скидки при продаже

В типиках есть автоматические скидки при продаже. Код реализован в процедурах ЗапросПоСкидкам  и РассчитатьСкидкиПриПродаже модуля ОбработкаТабличныхЧастей.

Контрагенты, для которых не нужно делать скидку УТ 10.3.7.9

Пользователи попросили для некоторых контрагентов не начислять скидку. Я предпочел косметическое вмешательство, а не глобальную перекройку задачи.

В функции, где строится массив получателей скидки (в том числе и пустой получатель – по всем контрагентам), я просто исключаю контрагента, если по нему не нужно делать скидок. Чтобы пометить такого контрагента, в его комментарий добавляю строку «-СКИДКИ;». Можно было бы конечно, использовать свойства контрагентов, но это более трудный путь. Все замечательно работает.

Функция ПолучитьМассивПолучателейСкидки(ВидРеализации, ДокументОбъект) Экспорт

       МассивПолучателей = Новый Массив;

 

       Если ВидРеализации = Перечисления.ВидыСкидок.Розничная Тогда

             МассивПолучателей.Добавить(ДокументОбъект.Склад);

             МассивПолучателей.Добавить(Справочники.Склады.ПустаяСсылка());

       Иначе

             //Осипов 20091216

             Если Найти(ДокументОбъект.Контрагент.Комментарий, "-СКИДКИ;") <> 0 Тогда

                    Возврат МассивПолучателей;

             КонецЕсли;

             МассивПолучателей.Добавить(ДокументОбъект.Контрагент);

             МассивПолучателей.Добавить(ДокументОбъект.ДоговорКонтрагента);

             МассивПолучателей.Добавить(Справочники.ДоговорыКонтрагентов.ПустаяСсылка());

       КонецЕсли;

 

       Возврат МассивПолучателей;

 

КонецФункции // ПолучитьМассивПолучателейСкидки()
 

Cчет-фактуры выданные

Отсутствие грузоотправителя и грузополучателя в счет-фактурах на услуги

В типиках если счет-фактура выдана на услуги, т.е. нет груза, то не печатаются грузоотправитель и грузополучатель. Однако некоторые организации просят всегда их печатать. Было бы логично для универсальности сделать константу «Печатать грузоотправителя и грузополучателя в счет-фактурах на услуги». Но пока мы дождемся этого от 1С, нужно комментировать код в модуле печати счет-фактуры:

      

Если Не ЕстьТовары Тогда

             //ДанныеДляПечати.Грузоотправитель = "";

             //ДанныеДляПечати.Грузополучатель = "";       

             //ДанныеДляПечати.АдресДоставки = "";         

       КонецЕсли;

 

Технологии

Партионный учет

Для чего используется регистр списанные товары

Регистр списанные товары используется, чтобы партионное списание не лазило в табличную часть документа, а узнавало, что нужно списывать сразу из этого регистра. Поэтому документы должны заполнять этот регистр.

Недостатком архитектуры регистра является то, что у него только одно измерение – номер строки. Поэтому одна строка документа может сделать только одно движение (приход, расход, перемещение) по партиям. Проблема решается путем добавления строк с номерами на 100 000, 200 000, 300 000 больше, чем исходный номер строки. В документах 1с не может быть больше 100 000 строк, поэтому использование виртуального номера строки правомерно.

Проверка, что себестоимость правильно списывается в разрезе характеристик (УТ 10.3)

Допустим, нужно проверить, учитывает ли программа разрез по характеристикам при списании себестоимости.

Рассмотрим ситуацию для методики оценки себестоимости «по средней» без учета склада и только для характеристик.

 

Заведем два прихода товара «Тест товара»:

1 марта 2011 года – 10 штук по цене 100 с характеристикой 111

10 марта 2011 года – 20 штук по цене 110 с характеристикой 222

 

Регистр партий выглядит так:

 

Производим продажу 15 штук товара 20 марта 2011 года, из них 10 штук с характеристикой 111, 5 штук – с  характеристикой 222.

Производим продажу 5 штук товара 25 марта 2011 года с  характеристикой 222.

 

Регистр партий выглядит так:

 

Т.е. программа использовала для списания товаров не среднюю себестоимость всех товаров (1000 + 2200) / 30 = 107 рублей, а по каждой характеристике свою сумму.

Чтобы себестоимость комиссии была равна себестоимости продаж УТ 10.3

Мне понадобилось, чтобы товар, который поступал на комиссию, при продаже формировал такую же себестоимость, как и купленный товар. Просто в базе велся учет себестоимости по марже, а тип договора нужно было сохранить, чтобы выгружать его в бухгалтерию правильно.

Пришлось поправить код процедуры УправлениеЗапасамиПартионныйУчет.СформироватьДвиженияСписанияНаСебестоимостьПродажУпр:

     

 Если ИСТИНА ИЛИ НЕ Строка.СтатусПартии = Перечисления.СтатусыПартийТоваров.НаКомиссию Тогда

             Движение.Стоимость  = КоэффициентСторно*Строка.Стоимость;

       Иначе

 

Просто убрать это условие (помечено желтым).

Отчеты

Выбор заранее составленных настроек для пользователей

Удобно сделать какие-то настройки, которые должны быть у всех пользователей и вызывать их одной кнопкой. Таким настройкам можно дать имя, начинающееся с «!». Пользователь нажимает кнопку выбора и ему открывается список настроек, начинающихся на «!». Он может быстро выбрать настроенные пользователям программистом настройки.

Процедура ВыбратьНастройку(Кнопка)

       ВыбратьНастройкуУниверсальногоОтчета(ЭтаФорма, "!", ЭлементыФормы.КоманднаяПанельФормы);

       // Выбираем все настройки, начинающиеся на ! знак

      

КонецПроцедуры

 

Функция ВыбратьНастройкуУниверсальногоОтчета(ФормаОтчета, Приставка, ЭлементФормы)

       Перем ИмяОбъекта;

 

       ИмяОбъекта =  Строка(ФормаОтчета.ЭтотОбъект);

      

       СтруктураНастройки = Новый Структура;

       СтруктураНастройки.Вставить("Пользователь", глЗначениеПеременной("глТекущийПользователь"));

       СтруктураНастройки.Вставить("ИмяОбъекта", ИмяОбъекта);

       СтруктураНастройки.Вставить("НаименованиеНастройки", Неопределено);

      

       З = Новый Запрос(

       "ВЫБРАТЬ

       |      СохраненныеНастройки.ИмяОбъекта,

       |      СохраненныеНастройки.НаименованиеНастройки,

       |      СохраненныеНастройки.СохраненнаяНастройка

       |ИЗ

       |      РегистрСведений.СохраненныеНастройки КАК СохраненныеНастройки

       |ГДЕ

       |      СохраненныеНастройки.ИмяОбъекта = &ИмяОбъекта");

       З.УстановитьПараметр("ИмяОбъекта", ИмяОбъекта);

       РезНаборНастроек = Новый СписокЗначений();

       ТЗ = З.Выполнить().Выгрузить();

       Для Каждого Стр ИЗ ТЗ Цикл

             Если Лев(Стр.НаименованиеНастройки, СтрДлина(Приставка)) = Приставка Тогда

                    РезНаборНастроек.Добавить(Стр.СохраненнаяНастройка, Стр.НаименованиеНастройки);

             КонецЕсли;

       КонецЦикла;

      

       Выбор = Неопределено;

       Если РезНаборНастроек.Количество() > 0 Тогда

             Выбор = ФормаОтчета.ВыбратьИзСписка(РезНаборНастроек, ЭлементФормы);

       КонецЕсли;

       Если Выбор <> Неопределено Тогда

             СтруктураНастройки.Вставить("НаименованиеНастройки",  Выбор.Представление);

             СтруктураНастройки.Вставить("СохраненнаяНастройка",  Выбор.Значение);

             УниверсальныеМеханизмы.ПолучитьНастройку(СтруктураНастройки);

             Результат = СтруктураНастройки;

            

             Отчет = ФормаОтчета.ЭтотОбъект;

             Объект = ФормаОтчета.ЭтотОбъект.УниверсальныйОтчет;

             Объект.мТекущаяНастройка = Результат;

             Отчет.ВосстановитьНастройкиИзСтруктуры(Результат.СохраненнаяНастройка);

             Объект.ВосстановитьПараметрыПечати(Объект, Отчет, ФормаОтчета, Результат.СохраненнаяНастройка);

 

       КонецЕсли;

      

      

КонецФункции
 

 При открытии универсального отчета показывать быстрые отборы

Часто пользователи хотят такого поведения универсального отчета. Реализуется просто. В модуле отчета «Универсальный отчет» в самом конце добавляем строку:

 

БыстрыйОтборРазвернут = истина; //Для удобства пользователей

 

Печать

Внешние печатные формы

При грамотном проектировании конфигурации можно было бы добиться того, что любую печатную форму можно было бы легко превратить во внешнюю печатную форму, но этого увы, не сделано.

Самый простой способ – скопировать модуль объекта целиком во внешнюю обработку и назначить обработке основной объект того типа, который распечатывается. Тогда практически ничего переделывать не надо.

Взаимодействие пользователя с программой

Работа с задачами пользователей

Создание извещений пользователей через задачи пользователей УТ 10.3

Если нужно сформировать извещения некоторым пользователям, можно создать булеву настройку пользователей, которую назначать тем пользователям, которые должны получать извещения. Далее, получить список этих пользователей и поставить им задачу с оповещением текущим времен.

      

Пользователи = ПользователиСУказаннойНастройкой(ПланыВидовХарактеристик.НастройкиПользователей.ПолучатьИзвещенияОНочномПерепроведении, истина);

       Для Каждого Пользователь Из Пользователи Цикл

             //Формируем извещение

             Задача = Задачи.ЗадачиПользователя.СоздатьЗадачу();

             Задача.Дата = ТекущаяДата();

             Задача.Исполнитель = Пользователь;

             Задача.Оповещение = истина;

             Задача.СрокОповещения = ТекущаяДата();

            

             Задача.Наименование = "Состояние ночного перепроведения";

             Задача.Описание =

             "Последний раз перепроведение работало: " + Константы.ДатаПоследнегоЗапускаПроведенияДокументов.Получить() + Символы.ПС +

             "Перепроведение дошло до даты: " + Константы.ДатаПоследнегоЗапускаПроведенияДокументов.Получить() + Символы.ПС +

             "Список ошибок по документам: " + Символы.ПС +

             Константы.ОшибкиПриПроведенииДокументов.Получить() + Символы.ПС;

            

             Задача.Записать();

            

            

       КонецЦикла;

 

 

Избавление от навязчивости списка задач УТ 10.3

Окошко напоминания о задачах довольно навязчивое. Каждые Nсекунд оно активизируется, показывая текущие задачи пользователя. В идеале было бы, чтобы оно активизировалось только, если появляются новые задачи. Но можно поступить проще – если окошко открыто, то не активизировать его.

Для этого нужно в процедуре УправлениеКонтактами.ПроверитьНапоминанияПользователя::ПроверитьНапоминанияПользователя использовать такой код (жирным отмечены мои правки):

      

РезультатЗапроса = Запрос.Выполнить();

       Если НЕ РезультатЗапроса.Пустой() Тогда

            

             ИзначальноФормаОповещенияЗадачОткрыта = ФормаОповещенияЗадачОткрыта; //Осипов

             Если НЕ ФормаОповещенияЗадачОткрыта Тогда

                   

                    ФормаОповещения.Открыть();

                    ФормаОповещенияЗадачОткрыта = Истина;

                   

             КонецЕсли;

            

             ВыгрузкаДляСверки = РезультатЗапроса.Выгрузить();

             Если НЕ ИзначальноФормаОповещенияЗадачОткрыта Тогда //Осипов

                    ФормаОповещения.АктивизироватьФорму(ВыгрузкаДляСверки);

             КонецЕсли; //Осипов

 

 

РАЗДЕЛ: ТОРГОВОЕ ОБОРУДОВАНИЕ

Рабочее место кассира

Настройки рабочего места кассира

Использование настройки РМК по умолчанию

Часто на предприятиях используется только одна настройка РМК, общая для всех компьютеров. Это делается, чтобы продавцы привыкли к интерфейсу и не испытывали проблем при переходе из магазина в магазин сети.

При запуске нового магазина приходится везде прописывать основную настройку РМК в регистр сведений «Настройки РМК».

Избежать этого можно вставкой подобного кода в процедуру «ПолучитьНастройкуРМККомпьютера» модуля «РМК»:

     

 //Основная настройка РМК, вставка

       ПоУмолчанию = Справочники.ДопКонстанты.ОсновнаяНастройкаРМК.Значение;

       Если ЗначениеЗаполнено(ПоУмолчанию) Тогда

             Возврат ПоУмолчанию;

       КонецЕсли;

 

       Возврат Результат; //Это типовой код

 

Фискальный регистратор

Драйвер ФР в 1С

Где происходит печать чека

Печать чека происходит в процедуре «ПечатьЧека» обработки «ТОСервер».

Шапка печатается средствами драйвера ФР, хотя 1С поддерживает возможность полной настройки чека, если задан шаблон чека.

Штрих-кодирование

Поиск по штрих-коду

Расположение процедуры поиска по штрих-коду

В рознице процедура поиска по штрих-коду – процедура модуля РаботаСТорговымОборудованием.ОбработатьВведенныйШтрихКод. В УТ 10.3 это процедура обработки ТОСервер. ОбработатьСобытиеСШК и дублируется в процедуре ТОСервер.ОбработатьВведенныйШтрихкод.

 

Поиск не только по регистру штрих-кодов

В типовых конфигурациях поиск по штрих-коду осуществляется только по регистру сведений штрих-кодов. Но иногда достаточно неудобно заносить в этот регистр копию серийных номеров из справочников серийные номера или характеристики.

Проще доработать общую для конфигурации функцию поиска по штрих-коду РаботаСТорговымОборудованием.ОбработатьВведенныйШтрихКод, чтобы программа искала также и по наименованию этих справочников. Вот пример доработки для поиска по характеристикам (добавленный код в блоке Если):

      

Запрос = Новый Запрос(

       "ВЫБРАТЬ

       |    РегШК.Владелец                   КАК Владелец,

       |    РегШК.ЕдиницаИзмерения           КАК ЕдиницаИзмерения,

       |    РегШК.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры

       |ИЗ

       |    РегистрСведений.Штрихкоды        КАК РегШК

       |ГДЕ

       |    РегШК.Штрихкод = &Штрихкод");

      

       Если ЗначениеЗаполнено(СокрЛП(ШтрихКод)) Тогда

             Запрос.Текст =  Запрос.Текст +

             " ОБЪЕДИНИТЬ  " +

             "ВЫБРАТЬ

             |      Т.Владелец КАК Владелец,

             |      Т.Владелец.ЕдиницаДляОтчетов КАК ЕдиницаИзмерения,

             |      Т.Ссылка КАК ХарактеристикаНоменклатуры

             |ИЗ

             |      Справочник.ХарактеристикиНоменклатуры КАК Т

             |ГДЕ

             |      Т.Наименование = &Штрихкод";

       КонецЕсли;

 

Используется именно «ОБЪЕДИНИТЬ», чтобы не дублировались одни и те же товары с одинаковыми единицами и штрих-кодами.

 

Пример из УТ доработки для поиска по наименованию серийного номера. В исходный код внедряется дополнительная функция ДополнительныйПоискШКПоХарактеристикам:

      

РезультатЗапроса = Запрос.Выполнить();

      

       ДополнительныйПоискШКПоХарактеристикам(РезультатЗапроса, ШК);   //Осипов

 

      

       Если Не РезультатЗапроса.Пустой() Тогда

             РезультатЗапроса.Следующий();

             Ответ = Клиент.СШКНоменклатура(РезультатЗапроса.Владелец,

             РезультатЗапроса.ХарактеристикаНоменклатуры,

             РезультатЗапроса.СерияНоменклатуры,

             РезультатЗапроса.Качество,

             РезультатЗапроса.ЕдиницаИзмерения,

             1,

             СШК);

             Если Ответ Тогда

                    Обработка.СобытиеОбработано(Объект);

                    Возврат Результат;

             КонецЕсли;

       КонецЕсли;   

 

Эта функция делает дополнительный поиск:

Функция      ДополнительныйПоискШКПоХарактеристикам(РезультатЗапроса, ШК)

       //Если ничего не найдено, ищем по характеристикам товара

       //20100720 осипов

       Если РезультатЗапроса.Пустой() Тогда

            

             Запрос = Новый Запрос;

             Запрос.Текст =

             "ВЫБРАТЬ ПЕРВЫЕ 1

             |      ЗначенияСвойствОбъектов.Объект.Владелец КАК Владелец,

             |      ЗначенияСвойствОбъектов.Объект.Владелец.ЕдиницаХраненияОстатков КАК ЕдиницаИзмерения,

             |      ЗначенияСвойствОбъектов.Объект КАК ХарактеристикаНоменклатуры,

             |      ЗНАЧЕНИЕ(Справочник.Качество.Новый) КАК Качество,

             |      ЗНАЧЕНИЕ(Справочник.СерииНоменклатуры.ПустаяСсылка) КАК СерияНоменклатуры

             |ИЗ

             |      РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов

             |ГДЕ

             |      ЗначенияСвойствОбъектов.Свойство = &Свойство

             |      И ЗначенияСвойствОбъектов.Значение = &Штрихкод";

            

             Запрос.УстановитьПараметр("Свойство",ПланыВидовХарактеристик.СвойстваОбъектов.СерийныйНомер);

             Запрос.УстановитьПараметр("Штрихкод", ШК);

            

             РезультатЗапроса = Запрос.Выполнить();

       КонецЕсли;

      

       Если РезультатЗапроса.Пустой() Тогда

             Запрос = Новый Запрос;

             Запрос.Текст = "ВЫБРАТЬ

             |      Т.Владелец КАК Владелец,

             |      Т.Владелец.ЕдиницаДляОтчетов КАК ЕдиницаИзмерения,

             |      Т.Ссылка КАК ХарактеристикаНоменклатуры,

             |      Неопределено КАК СерияНоменклатуры,

             |      Неопределено КАК Качество,

             |      &Штрихкод

             |ИЗ

             |      Справочник.ХарактеристикиНоменклатуры КАК Т

             |ГДЕ

             |      Т.Наименование = &Штрихкод";

             Запрос.УстановитьПараметр("Штрихкод", ШК);

            

             РезультатЗапроса = Запрос.Выполнить();

       КонецЕсли;

      

      

КонецФункции
 

Добавление в форму поддержку сканера штрих-кода (УТ10, РТ1)

Чтобы форма реагировала на сканер штрих-кода, нужно добавить в нее следующий код:

Функция СШКОбработатьШтрихкод(ШК) Экспорт

       //... некий код по обработке ШК

КонецФункции

 

Процедура ВнешнееСобытие(Источник, Событие, Данные)

       Если Событие = "BarCodeValue" Тогда

             ПолучитьСерверТО().ОбработатьВнешнееСобытие(Событие, Данные, ЭтаФорма);

       КонецЕсли;

КонецПроцедуры

 

 

Процедура ПриОткрытии()

       ПолучитьСерверТО().ПодключитьКлиента(ЭтаФорма);

КонецПроцедуры

 

 

Функция ПоддерживаетсяВидТО(ВидТО) Экспорт

       Возврат ВидТО = Перечисления.ВидыТорговогоОборудования.СканерШтрихКода;

КонецФункции
 

Обратите внимание – выполняется некоторая инициализация при открытии формы.

РАЗДЕЛ: ОБМЕНЫ ДАННЫМИ

В этом разделе собрана информация обо всех обменах данными.

Общие свойства типовых обменов

Внутренняя механика работы обменов

Размещение временных файлов обмена и блокировки

При распаковке файла сообщения 1С размещает файлы из архива во временном каталоге. При этом файлы распаковываются в этот каталог под теми же именами, что были в архиве. Имена файлов в архиве не меняются, поэтому возможна ситуация, когда файл не получится распаковать, т.к. файл во временном каталоге с таким именем заблокирован. Почему возникает блокировка, непонятно, но это частое явление.  Поэтому имеет смысл распаковывать всегда в новый временный каталог. Доработка выглядит так:

 

Функция РазархивироватьФайл(СтруктураНастроекОбменаДанными)
    ...
    КаталогДляРаспаковки = КаталогВременныхФайлов(); //Исходный код
    ...
    //При каждой распаковке использую отдельный каталог, чтобы не было блокировок...
    КаталогДляРаспаковки = РаботаСФайлами.ПолучитьИмяФайла(КаталогДляРаспаковки, Строка(Новый УникальныйИдентификатор()));
    СоздатьКаталог(КаталогДляРаспаковки);

    ...
КонецФункции   

 

 

Типовые обмены в РИБ

Типовые обмены данными по правилам

Проведение отложенных документов

Права доступа для проведения отложенных документов

Причиной, почему не проводятся отложенные к проведению документы может быть то, что для регламентного задания не задан пользователь, а в конфигурации сделана проверка прав доступа, привязанная к пользователю. К сожалению, в 1С нельзя проводить документы в режиме «Обмен данными - загрузка». Поэтому нужно для регламентных заданий назначить пользователя с максимальными правами.

У нас была проблема с тем, что при выполнении фонового задания, где не определен пользователь, срабатывал запрет на проведение документа задним числом, в результате отложенное проведение работало только при запуске вручную под администратором.

Обмен УТ-БП

Общие настройки обмена УТ-БП

В плане обмена в УТ не нужно использовать префикс, лучше использовать разные префиксы по организациям в УТ и БП. Префиксация может привести к опасному глюку, когда несколько номеров могут конвертироваться при добавке префикса в один, в результате несколько документов будут сливаться в один. Это возникает, если номер документа короткий, т.е. справа в номере есть пробелы. Лучше не рисковать и не использовать префиксацию.

Можно отключить в правилах обмена сопоставление по номеру документа для всех документов, т.к. это часто приводит к ошибкам сопоставления.

Изменение счета после загрузки банковских документов в БП из УТ

Меня попросили сделать настройку для документа «Платежный ордер на списание денежных средств», чтобы для операция по расчетно-кассовому обслуживанию в УТ эти операции ставились на нужный счет в БП, а не на счет 000 или счет взаиморасчетов с контрагентом, как это происходило автоматом.

Я написал следующий код в  конец алгоритма «После выгрузки» правила «ПлатежныйОрдерСписаниеДенежныхСредств»:

//Осипов 20100428 добавил платежки

//Объект = Документы.ПлатежныйОрдерСписаниеДенежныхСредств.НайтиПоНомеру( "RZ000000026", '20100426').ПолучитьОбъект();

Если СокрЛП(Объект.СтатьяДвиженияДенежныхСредств.Наименование) = "Услуги РКО"

       И Объект.ВидОперации = Перечисления.ВидыОперацийСписаниеБезналичныхДенежныхСредств.ПрочееСписаниеБезналичныхДенежныхСредств

       И (НЕ ЗначениеЗаполнено(Объект.СчетУчетаРасчетовСКонтрагентом) ИЛИ Объект.СчетУчетаРасчетовСКонтрагентом.Код = "000") Тогда

             Объект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.ПрочиеРасходы;

             ЭлементДР = Справочники.ПрочиеДоходыИРасходы.НайтиПоНаименованию("Расходы на услуги банков");

             Объект.СубконтоДт1 = ЭлементДР;

             Объект.СчетУчетаНУ = ПланыСчетов.Налоговый.ВнереализационныеРасходы;

             Объект.СубконтоДт1НУ = ЭлементДР;

             Если Объект.РасшифровкаПлатежа.Количество() > 0 Тогда

                    ЗаполнитьЗначенияСвойств(Объект.РасшифровкаПлатежа[0], Объект, "СчетУчетаРасчетовСКонтрагентом")

             КонецЕсли;

             //Объект.ПолучитьФорму().Открыть();

КонецЕсли;
 

Этот код я отлаживал в консоли кода на конкретном документе, а потом просто вставил в правила обмена. Для возможности последующей отладки оставил закомментированный код по работе с конкретным документом.

РАЗДЕЛ: ОШИБКИ ТИПОВЫХ

Ошибки в розничной торговле

Ошибки в процедуре закрытия кассовых смен

Несущественная ошибка отмены транзакции (УТ 10.3, Розница 1.0)

В процедуре ОбработкаЧековККМ обработки ЗакрытиеКассовойСмены есть такой код:

               

Если РезультатЗапроса.Пустой() Тогда

                               ТекстСообщения = "За кассовую смену не продано ни одного товара по выбранной кассе ККМ.";

                               ОбщегоНазначения.СообщитьОбОшибке(ТекстСообщения);

                               ОтменитьТранзакцию = Истина;

Ниже есть код:

                               Если ОтменитьТранзакцию Тогда

                                               ОтменитьТранзакцию();

 

Но из-за особенностей расположения условий, если срабатывает первое условие, то во второй код выполнение не заходит. Поэтому транзакция так и остается не отмененной.

 

 

118

Скачать файлы

Наименование Файл Версия Размер
Статья в формате Word
.doc 199,00Kb
25.10.18
135
.doc 199,00Kb 135 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. awk 693 27.03.12 21:55 Сейчас в теме
(0) Есть спорные моменты, но в целом +.
2. simargle 92 28.03.12 12:32 Сейчас в теме
(0)
>"Контрагенты, для которых не нужно делать скидку УТ 10.3.7.9"

Мне кажется, что в данном случае более удобно было бы реализовать такую схему, используя типовой механизм свойств и категорий конфигурации.
Т.е. добавить категорию у контрагента "Не применять скидки к контрагенту" и в функции "ПолучитьМассивПолучателейСкидки" использовать отбор контрагентов по определенной категории. Такая схема будет удобнее пользователям (достаточно поставить отметку, что не требуется начислять скидку контрагентам, чем запоминать о необходимости размещения в комментариях контрагента определенной надписи). С точки зрения разработчика реализация такой схемы также не вызывает трудностей, единственное что можно порекомендовать - реализовать базовые процедуры для работы со свойствами и категориями, чтобы исключить дублирование кода при пользовании механизмом свойств и категорий в дальнейшем. К примеру код для получения списка контрагентов без скидки может выглядеть так:

КатегорияКонтрагентыБезСкидки = ...//код получения категории, поиск по коду или другим способом
МассивПолучателей = ПолучитьМассивОбъектовПоКатегории(КатегорияКонтрагентыБезСкидки);

Не сочтите за холивар, просто мое мнение.
3. fixin 3882 28.03.12 12:56 Сейчас в теме
(2) вам правильно кажется. Я же так и пишу: Можно было бы конечно, использовать свойства контрагентов, но это более трудный путь. Все замечательно работает.

Модераторы! Почему не отображается описание, содержащее текст статьи? Статью можно почему-то скачать только из файла.. Ау!
4. simargle 92 28.03.12 13:10 Сейчас в теме
(3)

Прошу прощения, невнимательно прочитал.
5. Alraune 1465 28.03.12 13:37 Сейчас в теме
(3)
Модераторы! Почему не отображается описание, содержащее текст статьи?

Не знаю, о чем речь, у меня все нормально отображается, целиком весь текст. Firefox
8. daho 8 31.03.12 07:58 Сейчас в теме
(2) simargle, да.. так изящнее, но возни больше чем в способе что предложен в статье... А если задачу еще решать в глобальном плане, т.е. состояние без скидки может меняться с завидным постоянством, или существует очень хитрая система скидок, прайсов, бонусов размеры которых зависят от объема, сумм, расположения филиала, погоды в Гваделупе и количества черепах на Галапагосских островах одновременно то отсутствие скидки только частный случай.. тут одними категориями регистров сведений не обойтись, нужно еще и подчиненные справочники использовать и кучу всякой ерунды в плоть до независим таблиц в БД (если SQL).. если уж делать так делать.. такие примочки часто встречаются d крупных оптово-розничных компаниях с развитой сетью в разных странах..
6. 1C82 43 30.03.12 02:34 Сейчас в теме
Толковая статья ! Многим пригодится.
7. knowikDen 3 30.03.12 02:56 Сейчас в теме
Спасибо за статью, мне как начинающему очень пригодится
9. daho 8 31.03.12 08:03 Сейчас в теме
В догонку..
часто еще приходится на это все вешать систему разграничения прав менеджера на предоставление той или иной скидки.. то есть, например, менеджер низшего звена может делать скидку только 2% и то только по Гондурасу но исключительно в летную погоду и то после дождика в четверг, а до дождика только когда старший галочку поставить в документе, а старший галочку ставить не может больше 7%, для этого есть начальник подразделения.. и т.д.....
так что фиксин правильн в данном случае поступил.. сугубо в рамках поставленной задачи.. хоть конечно и не глямурно...

спасибо, статья корошая...
rosinfo1; +1 Ответить
10. KliMich 20.08.13 10:31 Сейчас в теме
Познавательная статья! Спастибо!
11. Al-X 23.07.14 09:40 Сейчас в теме
12. LexSeIch 205 17.12.14 12:33 Сейчас в теме
Мир этому дому!
Статья интересная - чужой опыт (особенно практический) всегда полезен. Спасибо!
Оставьте свое сообщение

См. также

Списание (корректировка) задолженности контрагентов УНФ 1.6 5

Инструменты и обработки Программист Бухгалтер Внешняя обработка (ert,epf) v8 УНФ Украина БУ Дебиторская и кредиторская задолженность Абонемент ($m) Закрытие периода Обработка документов

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    6522    4    DMon    1       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Вам нравятся запросы в 1С? 14

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    11272    1    m-rv    79       

Регистрация документов с измененной суммой 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Обработка документов

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    6049    1    ryan    0       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Блин, мы забыли включить регламентные задания… 51

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Абонемент ($m) Сервисные утилиты

Привет, Инфостарт! Сегодня расскажу, как я решил проблему с выключенными регламентными заданиями в рабочих базах. Желая исключить человеческий фактор и минимизировать количество ошибок, я написал небольшую конфигурацию.  В конфигурации два регламентных задания. Первое периодически подключается к кластеру и сохраняет текущие параметры: имя, Сервер БД, базу СУДБ, блокировки входа и регламентных заданий и т.д. Второе задание периодически проверяет эти параметры на ошибки.

1 стартмани

08.04.2019    8233    10    slozhenikin_com    36       

Безопасная работа с транзакциями во встроенном языке 190

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    17476    8    tormozit    44       

Онлайн-интенсив "Бизнес-процессы для подготовки к экзамену 1С:Специалист по платформе" 12 декабря 2019 г. Промо

На интенсиве будут рассмотрены все теоретические вопросы, связанные с устройством механизма бизнес-процессов – это необходимо для успешной сдачи экзамена 1С:Специалист по платформе. Также, в качестве практического примера, будет решена задача, аналогичная экзаменационной.

777 рублей

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 560

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

1 стартмани

31.01.2019    30920    274    bonv    116       

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации) 6

Инструменты и обработки Бухгалтер Пользователь Внешняя обработка (ert,epf) v8 КА1 УПП1 УУ Абонемент ($m) Обработка документов

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    8187    6    stvorl    3       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Централизованное управление списком доступных баз 1С у пользователей 8

Инструменты и обработки Системный администратор Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Стартеры 1С Сервисные утилиты Администрирование СУБД

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

5 стартмани

05.12.2018    7034    8    RomikR    9       

Многопоточная обработка данных 47

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 v8::УФ 1cv8.cf Абонемент ($m) Производительность и оптимизация (HighLoad) Администрирование данных 1С

Конфигурация "Универсальные механизмы: пакеты данных". Набор инструментов для быстрой организации отказоустойчивой многопоточной обработки данных.

1 стартмани

23.11.2018    12351    46    _ASZ_    14       

Очный семинар по регулярному менеджменту Александра Фридмана "Вы или Хаос", 12 декабря 2019 г. , Санкт-Петербург Промо

Семинар по регулярному менеджменту от Александра Фридмана для собственников, первых лиц и топов. Технология управленческого планирования, комплексного управления временем и другими ресурсами, выполнением поручений, делами, информацией, контактами (встречи-звонки-почта).

от 11000 до 29000 рублей

Обнуление остатков регистров бухгалтерии и накопления 42

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m) Универсальные обработки Чистка базы

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    11344    186    morozov.sv    30       

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек. 36

Инструменты и обработки Системный администратор Компонента, плагин (dll, vbs,..) v8 1cv8.cf Россия Windows Абонемент ($m) Чистка базы Сервисные утилиты Администрирование данных 1С

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    21842    301    Eugen-S    34       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Работа с публикациями "Инфостарт" 14

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    10683    10    RocKeR_13    16       

Онлайн-курс "Технология выполнения проектов ERP-класса – процессный подход". Третий поток. Курс проходит с 21 января по 18 марта 2020 года. Промо

Курс разработан Внедренческим центром «Раздолье». Курс предназначен для подготовки аналитиков, архитекторов и руководителей проектов автоматизации процессов управления с использованием комплексных ИТ-систем (1С:ERP, 1С:УХ, 1С:КА, 1С:УТ). В основе курса лежит методика применения процессного подхода.

9000 рублей

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2 12

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    17144    78    asdfgcom    45       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции 65

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    17290    23    informa1555    26       

Работа с данными выбора 41

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    24089    14    kalyaka    15       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.127.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Очистка периодических регистров посредством T-SQL (удаление записей, кроме среза последних) 4

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Чистка базы

Обработка для ленивых. Составит вместо Вас запрос для SQL, который удалит все не актуальные записи (т.е все, кроме среза последних)

5 стартмани

22.06.2018    9392    14    Alexander.Shvets    9       

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") 105

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    20931    86    m-rv    57       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному 242

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    29383    28    dsdred    34       

Как выполнить отчет на СКД через COM и получить данные отчета? 86

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    19049    10    wowik    3       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Автоматическое заполнение графиков в ЗУП 3.1 6

Инструменты и обработки Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Учет рабочего времени Абонемент ($m) Обработка справочников

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    11412    16    notserioussam    1       

Работа со схемой запроса 176

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    30245    75    kalyaka    34       

Перенос данных БП 3.0 => УТ 11 / КА 2 / ERP 2 (ЕРП) (перенос остатков, документов и справочной информации из "1С:Бухгалтерия предприятия 8", ред.3.0). Обновлено до БП 3.0.73.х, УТ 11.4.10.х, КА 2.4.10.х., ERP 2.4.10.х! Промо

Переносятся документы за выбранный период, справочная информация и остатки по счетам бух. учета в программу УТ 11 / КА 2 / ЕРП 2 (ERP). Переносятся все возможные виды операций ввода остатков на нужную дату. Есть отбор по периоду переноса документов и фильтр по организации, доступен выбор даты ввода остатков. Если нужно переносить что-то дополнительно, то обычно бесплатно добавляем это в перенос . Смотрите видеодемонстрацию со звуком - советами по переносу и рекомендациями настройки программ.

29700 руб.

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1) 21

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::СПР ЗУП3.x БУ Управление персоналом (HRM) Абонемент ($m) Обработка справочников

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    18018    51    charivnick    3       

Повышение качества разработок и онлайн контроль ошибок 164

Статья no Расширение (cfe) v8 Абонемент ($m) Журнал регистрации

Анализ ошибок и сбор ошибок журнала регистраций из десятков и сотен баз в одном месте.

09.03.2018    20443    137    DitriX    47