Игра "Сапер" by STivO (v.1.2)

Публикация № 125531

Сообщество - Игры

28
Написана максимально приближенно к оригиналу игры "Сапер" для Windows

Кто не знаком с этой игрой, можете почитать тут http://ru.wikipedia.org/wiki/Сапёр_(игра)

Изменения в версии 1.2:

- Устранены баги при открытии ячеек

Изменения в версии 1.1:

- Открытие ячейки щелчком ЛКМ

- Установка флажков/вопросов щелчком ПКМ

P.S. Идея "отлова" нажатия ЛКМ, ПКМ была взята из статьи Ввод щелчком мыши: правым, левым, двойным


 

Все замечания и предложения приветствуются!

28

Скачать файлы

Наименование Файл Версия Размер
Сапер by STivO v.1.2.epf
.epf 118,68Kb
18.03.13
27
.epf 118,68Kb 27 Скачать
Сапер by STivO v.1.1.epf
.epf 117,02Kb
18.03.13
8
.epf 117,02Kb 8 Скачать
Сапер by STivO v.1.0.epf
.epf 123,42Kb
18.03.13
25
.epf 123,42Kb 25 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Serj1C 477 19.04.12 12:43 Сейчас в теме
Мне понравилось. Единственное, что пришлось поправить - открытие поля одним щелчком мыши (при Активизации Ячейки а не при Выборе)
2. STivO 59 19.04.12 12:48 Сейчас в теме
(1) Serj1C, Спасибо. Да, изначально так и было, но в данном случае невозможно было бы установить флажок/метку. Хотя есть те, кто их не используют.
3. _apelsin4ik 28.06.12 11:08 Сейчас в теме
Вообще, вполне играбельная программа. Мне понравилась)
4. ShantinTD 86 15.08.12 11:17 Сейчас в теме
реально продумал. молодец. борись за правую кнопку.
5. codmal 64 18.09.12 10:51 Сейчас в теме
По поводу нерешённой проблемы с управлением (не отлавливается событие ПКМ) :
она решена в публикациях "Ввод щелчком мыши: правым, левым, двойным" и "Игра «Сапёр»"
http://infostart.ru/public/62233/
http://infostart.ru/public/62411/
6. DrAku1a 1300 02.01.13 18:51 Сейчас в теме
Предлагаю алгоритм автоматического решателя:
//--- DrAku1a
// анализ игрового поля, открытие 100% пустых клеток и установка флажков.
// с высокой вероятностью - выигрыш
Функция ОткрытьСмежныеЯчейки(Поле, ЭлементПоле) Экспорт
	фл=ложь;
	Пока СостояниеИгры=1 Цикл
		фл=ложь;
		Для x = 0 по ВысотаПоля - 1 Цикл
			Для y = 0 по ШиринаПоля - 1 Цикл
				чм = Поле[x][y];
				Если (чм>0) и (чм<9) Тогда
					чя = 0;
					Для dx=-1 По 1 Цикл
						Для dy=-1 По 1 Цикл
							xx = x + dx; yy = y + dy;
							Если (dx=0 и dy=0) или (xx<0) или (xx>=ВысотаПоля) или (yy<0) или (yy>=ШиринаПоля) Тогда
								Продолжить;
							КонецЕсли;
							Если Поле[xx][yy]=0 Тогда
								чя = чя + 1;
							ИначеЕсли Поле[xx][yy]=9 Тогда
								чм = чм - 1;
							КонецЕсли;
						КонецЦикла;
					КонецЦикла;				
					Если (чя=чм) и (чм>0) и (чм<9) Тогда
						фл = Истина;
						Для dx=-1 По 1 Цикл
							Для dy=-1 По 1 Цикл
								xx = x + dx; yy = y + dy;
								Если (dx=0 и dy=0) или (xx<0) или (xx>=ВысотаПоля) или (yy<0) или (yy>=ШиринаПоля) Тогда
									Продолжить;
								КонецЕсли;
								Если Поле[xx][yy]=0 Тогда
									Поле[xx][yy]=9;
								КонецЕсли;
							КонецЦикла;
						КонецЦикла;
					ИначеЕсли чм=0 Тогда
						Для dx=-1 По 1 Цикл
							Для dy=-1 По 1 Цикл
								xx = x + dx; yy = y + dy;
								Если (dx=0 и dy=0) или (xx<0) или (xx>=ВысотаПоля) или (yy<0) или (yy>=ШиринаПоля) Тогда
									Продолжить;
								КонецЕсли;
								Если Поле[xx][yy]=0 Тогда
									фл=Истина;
									ЭлементПоле.ТекущаяСтрока = Поле[xx];
									ЭлементПоле.ТекущаяКолонка = ЭлементПоле.Колонки[yy];
									ОткрытьЯчейку();
									Если СостояниеИгры=0 Тогда
										Сообщить("Ой...");
										ИзобразитьЧислоМин();
										Возврат истина;
									КонецЕсли;
								КонецЕсли;
							КонецЦикла;
						КонецЦикла;
					КонецЕсли;
				КонецЕсли;
			КонецЦикла;
		КонецЦикла;	
		Если не фл Тогда
			Прервать;
		КонецЕсли;
	КонецЦикла;
	ИзобразитьЧислоМин();
	Возврат фл;
КонецФункции
Показать

(Прошу прощения за названия переменных)

Далее - в форме - переделываем процедуру
Процедура ПолеВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)

	ОткрытьЯчейку();
	
	//DrAku1a ---
	ОткрытьСмежныеЯчейки(Поле, ЭлементыФормы.Поле);
	
КонецПроцедуры
Показать


Всё! Теперь после клика на ячейку - будет открыта часть поля, затем анализируются клетки окружения, выставляются флажки и открываются клетки... Т.е., компьютер уже думает за нас :)
AerinSwift; dimidron1; STivO; +3 Ответить
7. STivO 59 03.01.13 10:22 Сейчас в теме
(6) DrAku1a, Весьма забавно получилось) С первого хода несколько раз выигрывал, "читерство" получается))
dimidron1; +1 Ответить
9. alean 35 23.05.13 11:39 Сейчас в теме
понравилось.
прекрасно реализовано!
10. Gendalf_beliy 04.09.14 14:10 Сейчас в теме
я так понял эта обработка для платформы 7.7?
11. Ёпрст 1036 04.09.14 13:49 Сейчас в теме
12. STivO 59 04.09.14 14:31 Сейчас в теме
13. Gendalf_beliy 08.09.14 17:56 Сейчас в теме
(10) Gendalf_beliy, для 8.2
(12)
Спасибо за ответ, тогда скачаю.
Просто показалось, что цветовой оформление такое же как у 1с 7.7.
Ксати создание сапер, это одно из заданий обучения 1с для школьников ))
Оставьте свое сообщение

См. также

Блэк Джек 4

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Блэк джек, написанный на платформе 1С 8.2 (обычные формы).

1 стартмани

07.10.2019    611    Azamatex    2       

Игра "Ван Хельсинг" 1

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Игры

Игра "Ван Хельсинг". Интерфейс "Обычный". Аркада.

1 стартмани

03.07.2019    1305    1    Lion_LexXx    0       

Игра "Логика" 3

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Игры

Старая советская «Логика» для 1С УФ. Угадайте комбинацию цветов, загаданную компьютером.

1 стартмани

13.06.2019    1377    legenda-nsh    0       

Игра в кости "1000" (сетевая) 2

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Игры

Аналог игры в кости 1000 (классика). Работает на управляемом приложении, любой конфигурации и без неё. Тестировал на платформе 1С:Предприятие 8.3 (8.3.10.2667) и выше.

1 стартмани

07.05.2019    2477    1    APTEM_SLV    5       

Игра "Арканоид" (Javascript фреймворк Phaser). HTML 5 Сanvas + WebGL. Управляемые формы (ТОНКИЙ, ТОЛСТЫЙ клиент), Обычные формы 6

Отчеты и формы no Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Игры

Общеизвестная игра "Арканоид", доступная для запуска в 1с. Выполнена в виде обработки, запускаемой из папки, в которой расположены файлы проекта (html, js файла и картинки) Любые конфигурации на обычных формах, управляемых формах (Тонкий + Толстый клиент). УПП, БП 2.0, 3.0. После открытия обработки нажимаем мышью на область экрана игры, точнее, нажимаем на кнопку "СТАРТ" (области игры). Начинается игра. Управление мышью.

1 стартмани

04.05.2019    1859    2    pvlunegov    2       

Игра Змейка с автопилотом 11

Отчеты и формы no Архив с данными v8 1cv8.cf Абонемент ($m) Игры

Игра Змейка с автопилотом реализована в парадигме автоматного программирования.

1 стартмани

23.04.2019    1779    RonX01    17       

Розыгрыш к 1 апреля (№2) [Расширение] УТ11 6

Отчеты и формы no Расширение (cfe) v8 УТ11 Россия Абонемент ($m) Игры

Меняем язык надписей на формах для пользователя с помощью сервиса яндекс-переводчик.

1 стартмани

26.03.2019    2032    2    noprogrammer    1       

Розыгрыш к 1 апреля [Расширение] 7

Отчеты и формы no Расширение (cfe) v8 1cv8.cf Абонемент ($m) Игры

Небольшой розыгрыш к 1 апреля.

1 стартмани

19.03.2019    2347    5    noprogrammer    13       

Magic 8 ball (Магический шар 8) 11

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Игры

Mystic 8 ball, шар судьбы, шар вопросов и ответов, шар предсказаний. Помогает в принятии важных решений

1 стартмани

13.03.2019    3019    4    Смешной 1С    3       

Тест Ауюму. Тренировка памяти 3

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Игры

Это шуточная обработка, сделанная по подобию известного теста японского ученого Тетсуро Матсузава.

1 стартмани

05.03.2019    1620    acesdjazzz    1       

Конфигурация-игра "Сто к одному" (1С + html + js + css) 9

Отчеты и формы no Архив с данными v8 Россия Windows Абонемент ($m) Игры

Конфигурация/база для игры в "Сто к одному" с архитектурой "Ведущий - игровое поле". Конфигурация/база используется для всего цикла игры: 1. Хранение вопросов/ответов по типам игры (Простая, Двойная, Тройная, Игра наоборот и Большая игра); 2. Управление игрой (роль ведущего) - заполнение имён команд, формирование набора вопросов, запуск раундов, выполнение действий на игровом поле, завершение приложения игрового поля; 3. Игровое поле (роль игровое поле) - выполнение действий команд ведущего. Платформа: 8.3.12.1567

1 стартмани

25.02.2019    2275    2    Rabot    2       

Решение судоку 3

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Игры

Во вложении обработка, способная решить судоку высокой сложности, в том числе имеющий несколько решений. Для начала решение производится классическими способами, затем подбором с проверкой достижения правильного решения.

1 стартмани

07.02.2019    2498    3    dobrodeev    4       

Игра "Сними последнюю галку" 1

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Игры

Докажи, что ты человек, сделай эту прогу! Сними последнюю галку. Режим обычной и управляемой формы

1 стартмани

22.01.2019    2276    1    senshkr    3       

Игра пасьянс (домино) "Пирамида" 2

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Игры

Играть в домино и раскладывать пасьянс или собирать пасьянс фишками от домино – выбирайте, как вам больше нравится. Работает на любой конфигурации, даже без конфигурации. Тестировал на платформе 1С 8.3 (8.3.13.1513), конфигурация Зарплата и кадры государственного учреждения, редакция 3.1 (3.1.8.137).

1 стартмани

20.12.2018    3354    1    APTEM_SLV    4       

Инструмент для проведения мероприятия Secret Santa (или Секретный Дед Мороз) 2

Отчеты и формы no Архив с данными v8 Абонемент ($m) Игры

Данная конфигурация поможет Вам провести мероприятие "Секретный санта". Причем абсолютно анонимно.

1 стартмани

12.12.2018    2281    EXAN    2       

Игра "Бродяга" 8

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Игры

Полноценный рогалик на 1С (обычные формы, платформа не ниже 8.2.19, для любого типа платформы).

1 стартмани

15.11.2018    2966    7    Caliban    14       

Пятнашки 2

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Игры

Игра "Пятнашки" на управляемых формах.

14.11.2018    2791    11    supermen    0       

Игра "Подземелье" (HTML5 canvas + javascript). Управляемые + Обычные формы 19

Отчеты и формы no Архив с данными v8 v8::УФ 1cv8.cf Windows Абонемент ($m) Игры

Простейшая игра на HTML5 + canvas + javascript. Управляемые + Обычные формы. Запуск во всех конфигурациях, во всех видах интерфейсов (Упр. формы Такси, упр. формы во вкладках, обычные формы). В 1С используется встроенный объект ПолеHTMLДокумента. УПРАВЛЕНИЕ ПЕРСОНАЖЕМ с клавиатуры (клавиши движения WASD). Персонаж двигается, собирает ключи, открывает двери.

1 стартмани

13.08.2018    6601    11    pvlunegov    21       

Выбор шкатулки. Проверка задачи по теории вероятностей 2

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Игры

Одна из любопытных задач по теории вероятностей. Любая конфигурация (в том числе пустая) на обычных формах. Платформа 8.3.

1 стартмани

25.07.2018    3469    boba13    3       

Морской бой 3

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Игры

Игра-обработка для 1С, Морской бой

1 стартмани

23.07.2018    3769    3    tbkvpvl    4       

Тетрис 2

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Игры

Обработка-игра для 1С, тетрис

1 стартмани

23.07.2018    4067    12    tbkvpvl    2       

Сколько лепестков у розы? 4

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Игры

Сколько лепестков у розы? Простая игра, смысл которой заключается в том, чтобы угадать (понять логику), сколько лепестков у розы.

1 стартмани

03.07.2018    3868    Denis_CFO    0       

Шуточная кодировка текста и как мы воспринимаем текст 10

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Сделайте паузу, попробуйте прочитать!

1 стартмани

17.06.2018    4986    Timur.V    1       

Игра-головоломка "Лейцвет" (1С:Предприятие 8.3), управляемая форма для всех типов клиентов 1

Отчеты и формы no Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Игры

Увлекательная головоломка, где придется применить логику, чуткое зрительное восприятие и пройти 65 уровней различной сложности.

1 стартмани

23.05.2018    4408    1    bobank    0       

Игра "2048" (для 1С:Предприятие 8.3), управляемая форма для всех типов клиентов 3

Отчеты и формы no Архив с данными v8 1cv8.cf Абонемент ($m) Игры

Один из ярких представителей игр - "убийц" времени. Позволяет расслабиться, отдохнуть от мозговой деятельности и хорошо провести время.

1 стартмани

02.04.2018    6367    6    bobank    3       

Игра "Цветоблок" (для 1С:Предприятие 8.3), управляемая форма, для всех типов клиентов 1

Отчеты и формы no Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Игры

Яркий представитель игр - "убийц" времени. Позволяет расслабиться, отдохнуть от мозговой деятельности и хорошо провести время.

1 стартмани

28.03.2018    5370    bobank    0       

Карточная игра BLACK JACK для 1С 8.2(3) 3

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Игры

Игра BLACK JACK, тестировалось на 1С 8.3 (8.3.10.2466).

1 стартмани

21.03.2018    5049    1    Helgy    3       

Пасьянс "Пирамида" 3

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Пример написания игры пасьянс "Пирамида" на платформе 1С:Предприятие 8.2 обычное приложение.

1 стартмани

17.03.2018    4798    5    van010190    2       

Каталог игр с приставок из моего детства 44

Отчеты и формы no Архив с данными v8 Windows Абонемент ($m) Игры

Каталог игр Dendy, Sega, Nintendo из нашего детства.

1 стартмани

06.02.2018    11664    56    user621724_Dimav1979    34       

Случайность, совпадение, закономерность. Генератор случайных чисел 6

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования Математика и алгоритмы Игры

Объект ГенераторСлучайныхЧисел удобно выдает случайные числа в заданном интервале значений. Исследование особенностей, рассуждения на тему случайных чисел, практика применения. Увлекательно в игровой форме можно исследовать работу генератора случайных чисел.

1 стартмани

20.01.2018    15565    2    Ликреонский    58       

Приход белого медведя (игра) 4

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Уникальный способ отметить день рождения с друзьями и подружками - это провести такую игру - называется Приход белого медведя. Но участники должны быть очень выдержанными и смелыми.

1 стартмани

13.01.2018    6356    HitLis    21       

Игра "Удачливая обезьяна" 1

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Игра, имитирующая "однорукого бандита", теперь на 1С.

1 стартмани

08.11.2017    7139    ivannn    0       

Invoker coach 4

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Игры

"Жвачка" для ваших пальцев по мотивам игры Dota.

1 стартмани

25.09.2017    8134    1    Sergey901    3       

Тренируем искусственный интеллект 8

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Добрый день, уважаемые коллеги. Хочу с Вами поделиться одной пятничной разработкой. Виндиниум - игра, в которой необходимо программировать искусственный интеллект. Вы должны взять под контроль легендарного героя, используя язык программирования по вашему выбору. Вы будете сражаться с другим ИИ. Победит герой с наибольшим количеством золота.

1 стартмани

18.08.2017    8764    2    Rokstedi    0       

Парсер БК 5

Отчеты и формы Программист Конфигурация (md, cf) v8 Домашние учет и финансы Россия Windows Абонемент ($m) Игры WEB

Пример конфигурации парсера (в данном случае парсер БК фонбет). Программа парсит коэфициенты БК, записывает их в события, парсит результаты этих событий.

1 стартмани

21.07.2017    13211    10    Hitchenson91    11       

Игра Bomberman 14

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Игры

Аналог старой популярной игры Bombermen. Отличный способ занять себя на работе, не отрываясь от 1С)

1 стартмани

02.06.2017    9723    11    tjurikov_ivan    5       

Пишем игру 21 (очко). Пример использования 1С и ActiveX 48

Статья Программист Архив с данными v8 1cv8.cf Россия Windows Абонемент ($m) Практика программирования Игры

Пишем игру "очко". Программный код состоит из двух частей: 1.Разработка компоненты работы с графикой на Delphi 2.Логическая реализация игрового процесса на 1С

1 стартмани

23.05.2017    15789    3    user621724_Dimav1979    17       

Безубыточный Пуш-Фолд в техасском холдеме. Стратегия под названием «Числа Склански-Чубукова» 7

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Обработка помогает при игре в покер. В интернете, конечно, можно найти покерные калькуляторы, но пользоваться ими во время игры нельзя и неудобно. Этой же обработкой можно спокойно пользоваться во время игры.

2 стартмани

12.04.2017    8944    2    kanat1    7       

Вероятность выпадения нуля или единицы 3

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Обработка для расчетв вероятности выпадения нуля или единицы

1 стартмани

24.03.2017    8791    NECHISTb    5       

Переводчик имбецильного текста в стиле Fallout 1-2 (beta) 8

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Игры

Не хотите нормально общаться с людьми? Будете пускать слюни и мычать? Пусть игнорят Вас в открытую? То вам сюда!

1 стартмани

14.03.2017    10844    6    ZhokhovM    34       

Игра "Крестики-нолики" 3

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Игры

Очередная реализация известной игры. Добавлена управляемая форма. Начал разработку мобильной версии.

1 стартмани

18.11.2016    9590    4    JohnGalt    2       

Сетевая игра "СловоБой" на управляемых формах 9

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Игры

СловоБой - это новый взгляд на ставшие уже классическими игры, где нужно составлять слова из букв, наподобие Балды и Эрудита. Играйте онлайн с друзьями! В игре СловоБой побеждает не тот, кто может придумать самое длинное слово, а тот, кто знаком с тактикой не понаслышке и способен использовать оптимальную стратегию.

1 стартмани

10.11.2016    15433    8    woldemarr    0       

Игра Four in line (Четыре в ряд) 3

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Для Управляемых форм. На поле размером 6x7  Вы играете с компьютером. Цвет шаров игрока красный, цвет шаров компьютера синий.  Игроки ходят последовательно.  Сделать ход можно в свободную ячейку либо в самый нижний ряд (шестой ряд), либо в свободную ячейку под которой (ряд ниже по вертикали) уже расположен шар любого цвета.  Цель игры игрока - составить непрерывный ряд из четырех шаров красного цвета либо по горизонтали, либо по вертикали, либо по диагонали. Соответственно цель игры компьютера составить непрерывный ряд из четырех шаров синего цвета либо по горизонтали, либо по вертикали, либо по диагонали. Выигрывает тот, кто сделает это первым. За победу присуждается одно очко. ПРИЯТНОЙ ВАМ ИГРЫ!!!

1 стартмани

20.09.2016    9517    4    Robertik    1       

Игра 2048 5

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Новая версия классической игры 2048.

1 стартмани

01.09.2016    8326    11    imam    3       

Игра 1-2-3-4 2

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Игры

Решение простых примеров на время.

1 стартмани

17.08.2016    8242    2    ark.zv    5       

Поиск слов в поле 5*5 2

Отчеты и формы no Конфигурация (md, cf) v8 Россия Windows Абонемент ($m) Игры

Я написал полуавтоматическую обработку поиска слов в поле букв 5*5 с указанием бонусных букв.

1 стартмани

06.08.2016    22901    14    kyzma-kyzmi4    9       

Battle City на 1С 174

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Игры

Данная обработка представляет из себя реинкарнацию популярной в 90-е годы XX-го века игры на игровых консолях Dendy, Nintendo и пр.: "BattleCity"(c)Namcot (Танчики ). Воспроизведен оригинальный геймплей, уровни и аудиовизуальный контент. Никаких внешних компонент не использовано. Написано на "голом" 1С82 в неуправляемых формах. Добавлен мультиплеер.

1 стартмани

05.08.2016    22185    352    slava_1c    53       

Антар: приключенческая игра. Исследование лабиранта с элементами выживания (1С 8.3, Управляемые формы, любая конфигурация) 18

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Игры

Смысл игры в исследовании случайно сгенерированного лабиринта (поля?) из различных ландшафтов, для преодоления которых требуются различные предметы (изначально у игрока отсутствующие) и сборе всех монет (конечная цель). Необходимость поиска предметов, поддержания запаса воды и выносливости позволяет использовать термин "Элементы выживания" :) Идея игры базируется на статье «Страна Монстров» журнала "Техника Молодежи" за 1990 год.

1 стартмани

02.08.2016    10796    30    HorusTheOne    29