Работа с Атол ДТО10 в 1С 7.7

Публикация № 1350696

Администрирование - Торговое оборудование - ККМ

1С7.7 ТиС Атол ДТО10

Обработка торгового оборудования. Для 1С 7.7 ТиС + Атол ДТО10.

Заказчик перешил все фискальные регистрторы новой прошивкой. После чего аппараты стали недоступны для  драйверов ДТО8. Не найдя на просторах интернета бесплатной обработки для работы с фискальным регистратором и 1С7.7 ТиС переделал frATOL54_comm_105.ert для работы с 10ми драйверами. 

Обработка подключается (показано на скриншоте) как стандартная обработка для работы с торговым оборудованием.

Обработка тестировалась на измененной конфигурации 1с7.7 ТиС 9.х

До начала использования обработки необходимо зарегистрировать библиотеку.

Запустите командную строку под администратором и выполните команду 

regsvr32 "C:\Program Files (x86)\.....\addin_fptr10_x86.dll"

 

//********************************************************************************
Функция ПечататьЧек(Объект, Пароль, СписокТоваров, СуммаЧека, Получено, Скидка, ПризнВозврата, ПУП, Кассир, НомерСекции, НомерЧека, ДлинаСтроки, Покупатель="")
	
	Рез = 0;            
	
    СписокТоваров	= УстановитьЦенуБезСкидки(СписокТоваров);
	ВыполнитьФорматноЛогическийКонтроль(СписокТоваров); 
    СписокТоваров	= УстановитьЦенуБезСкидки(СписокТоваров);

	
	Если Подключить(Объект) = 1 Тогда	
		
		//ДТО 10
		//Открыть чек
		Объект.setParam(1021, СокрЛП(Кассир));
		Объект.operatorLogin();
		
		Если ПризнВозврата=1 Тогда
			Объект.setParam(Объект.LIBFPTR_PARAM_RECEIPT_TYPE, Объект.LIBFPTR_RT_SELL_RETURN);
		Иначе
			Объект.setParam(Объект.LIBFPTR_PARAM_RECEIPT_TYPE, Объект.LIBFPTR_RT_SELL);
		КонецЕсли;  

		Ответ	= Объект.openReceipt();
		Если Ответ<>0 Тогда
			Ошибка(Объект, Ответ);
			рез = 0;
			Объект.cancelReceipt();
			Возврат 0;
		КонецЕсли;

		                                  
		Если НЕ (Покупатель="") Тогда   
			
			ПолнНаименование = Покупатель.ПолнНаименование;
			ИНН              = Покупатель.ИНН;  
			
			Если Найти(ИНН, "\") <> 0 Тогда
				ИНН = Лев(ИНН, Найти(ИНН, "\") - 1);
			ИначеЕсли Найти(ИНН, "/") <> 0 Тогда
				ИНН = Лев(ИНН, Найти(ИНН, "/") - 1);
			КонецЕсли;
			
			Если ИННСоответствуетТребованиямНаСервере(ИНН)=0 Тогда	
				Сообщить("ИНН не соответствует требованиям налоговой "+ ИНН);
				Возврат 0;
			КОнецЕсли;
						 
			//1227	Наименование получателя	string
			Объект.setParam(1227, ЗаменитьСпецСимволы(ПолнНаименование) );
			//1228	ИНН получателя	string
			Объект.setParam(1228,СокрЛП(ИНН));
			//1117	Электронный адрес отправителя чека	string
			//Объект.setParamString(1117, Док.Фирма.ЭлПочта );
			//1055	Применяемая система налогообложения (СНО)	int
			Объект.setParam(1055, Объект.LIBFPTR_TT_OSN );
			//1187	Место расчета	string
			//1060	Адрес сайта ФНС	string
			//1057	Признак агента	int
			//Объект.setParamInt(1055, _cons.LIBFPTR_AT_NONE );
			//1171	Телефон поставщика	string
			//fptr.setParamString(1171, СокрЛП(Док.Фирма.ЮрЛицо.Телефоны) );
			//1044	Операция платежного агента	string
			//1073	Телефон платежного агента (может повторяться несколько раз)	string
			//1005	Адрес оператора перевода	string
			//1016	ИНН оператора перевода	string
			//1026	Наименование оператора перевода	string
			//1075	Телефон оператора перевода (может повторяться несколько раз)	string
			//1074	Телефон оператора по приему платежей (может повторяться несколько раз)	string
			//1084	Дополнительный реквизит пользователя	bytearray
			//1192	Дополнительный реквизит чека (БСО)	string
			
		КонецЕсли;
			
		СписокТоваров.ВыбратьСтроки();
		Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
			
			//Продажа ЗаменитьСпецСимволы(СписокТоваров.ТовНаим)  
			Объект.setParam(Объект.LIBFPTR_PARAM_COMMODITY_NAME, СокрЛП(СписокТоваров.ТовНаим));
			Объект.setParam(Объект.LIBFPTR_PARAM_PRICE, СписокТоваров.Цена);
			Объект.setParam(Объект.LIBFPTR_PARAM_QUANTITY, СписокТоваров.Количество);  
			
			Если СписокТоваров.СтавкаНДС = "none" Тогда 
				Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_NO );
			ИначеЕсли СписокТоваров.СтавкаНДС = "18" Тогда
				Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_VAT18 );
			ИначеЕсли СписокТоваров.СтавкаНДС = "20" Тогда
				Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_VAT20 );
			ИначеЕсли СписокТоваров.СтавкаНДС = "10" Тогда
				Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_VAT10 );
			ИначеЕсли СписокТоваров.СтавкаНДС = "0" Тогда
				Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_VAT0 );
			КонецЕсли;
                    
			//Объект.setParam( Объект.LIBFPTR_PARAM_TAX_SUM, СписокТоваров.НДС);   
			
			//1212	Признак предмета расчета	int
			// Признак предмета расчёта. Свойство ItemType может принимать значения:
			// 	1 - товар, за исключением подакцизного товара
			// 	2 - подакцизный товар
			// 	3 - работа
			// 	4 - услуга
			// 	5 - приём ставок при деятельность по организации и проведению азартных игр
			// 	6 - выплата выигрышей в азартных играх
			// 	7 - реализация лотерейных билетов или ставок при деятельность по организации и проведению лотерей
			// 	8 - выплата выигрышей в лотереях
			// 	9 -  прав на использование результатов интеллектуальной деятельности или средств индивидуализации
			// 	10 -  аванс, задаток, предоплата, кредит, взносе в счет оплаты, пени, штраф, вознаграждение, бонус и иной аналогичный предмет расчета
			// 	11 -  предмет расчета, состоящий из предметов, каждому из которых может быть присвоено значение от 0 до 10 (набор)
			// 	12 -  предмет расчета, не относящийся к предметам расчета, которым может быть присвоено значение от 0 до 11
			Объект.setParam(1212,1);
			
			//1214	Признак способа расчета	int
			// Признак способа расчёта. Свойство PaymentMode может принимать значения:
			// 	1 - Полная предварительная оплата до момента передачи предмета расчета
			// 	2 - Частичная предварительная оплата до момента передачи предмета расчета
			// 	3 - Аванс
			// 	4 - Полная оплата, в том числе с учетом аванса (предварительной оплаты) в момент передачи предмета расчета
			// 	5 - Частичная оплата предмета расчета в момент его передачи с последующей оплатой в кредит
			// 	6 - Передача предмета расчета без его оплаты в момент его передачи с последующей оплатой в кредит
			// 	7 - Оплата предмета расчета после его передачи с оплатой в кредит (оплата кредита)
			Объект.setParam(1214,4);
			
			Ответ	= Объект.registration();   
			Если Ответ<>0 Тогда
				Ошибка(Объект, Ответ);
				рез = 0;  
				Возврат рез;
			КонецЕсли;
			
		КонецЦикла;      
		
		//Закрыть чек
		Если ПризнВозврата=0 Тогда
			//Оплата
			Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_TYPE, Объект.LIBFPTR_PT_CASH);
			Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_SUM, СуммаЧека);
			Объект.payment();
		КонецЕсли;
		
		Ответ	= Объект.closeReceipt();
		 
		Если Ответ<>0 Тогда 
			Ошибка(Объект, Ответ); 
			рез = 0; 
			Возврат Рез;
		КонецЕсли;	

		НомерЧека				= ПолучитьНомерЧека(Объект);
		Рез = Объект.close();

		
		ОписаниеПоследнейОшибки =	Объект.ErrorDescription();
		КодПоследнейОшибки		= 	Объект.ErrorCode(); 
		
		Если КодПоследнейОшибки = 0 тогда
			Рез = 1;
		Иначе
			ОписаниеРезультата = ОписаниеПоследнейОшибки;
		КонецЕсли; 
	КонецЕсли;
	
	Возврат Рез;
	
КонецФункции

 

Скачать файлы

Наименование Файл Версия Размер
1С7.7 Атол ДТО10:

.ert 38,00Kb
41
.ert 38,00Kb 41 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Petrushka 13.01.21 16:58 Сейчас в теме
Здравствуйте
Выдаёт ошибку при регистрации ФР в Торговом оборудовании
Ошибка при создании объекта из компоненты F:\Tunes_1C\Torg_NEW_for_Admin\addin_fptr10_x86.dll (отсутствует интерфейс IInitDone)
Фискальный регистратор: ошибка при подключении
не удалось загрузить внешнюю компоненту "addin_fptr10_x86.dll"

Как правильно зарегистрировать?
Прикрепленные файлы:
2. aldar 10 13.01.21 21:41 Сейчас в теме
Компоненту надо регистрировать regsrv32 под администратором. Иначе не работает.
3. ultra_plus 18.01.21 06:23 Сейчас в теме
Здравствуйте. Я может неправильно указываю номер порта? Или тут ничего не указывается. Подскажите, пожалуйста, как правильно надо настроить оборудование. АТОЛ 30Ф, ТиС 77. Под Windows XP будет работать?
Прикрепленные файлы:
4. aldar 10 18.01.21 10:32 Сейчас в теме
Здравствуйте. Написать обработку надо было срочно и я жестко прописал ком порт в функции подключения

//********************************************************************************
Объект.setSingleSetting(Объект.LIBFPTR_SETTING_COM_FILE, "COM8"); //"COM"
5. vladimir.gl 19.01.21 11:23 Сейчас в теме
Здравствуйте. Спасибо, работает. При закрытии смены не печатает Z-отчет, буду разбираться.
6. grafit 8 30.01.21 12:34 Сейчас в теме
Как отключиться после печати чека и освободить порт?
8. aldar 10 02.02.21 20:30 Сейчас в теме
(6) Я думаю как и всегда это делали. Удалить объект.
7. grafit 8 02.02.21 15:49 Сейчас в теме
На платформе 5 невозможно корректно передать скиду по позиции (насколько я понял). Если на старой можно было сумму передать и поделить на количество, получив таким образом корректную ИТОГОВУЮ сумму чека, то сейчас этот метод не работает.
Есть соображения по этому поводу?
10. aldar 10 02.02.21 20:58 Сейчас в теме
(7)Эта проблема уже давно. Во второй рознице эту проблему решали делением строки на несколько и игрой +- с копейками. Т.е. если у вас 2 товара по 50 копеек (т.е. общей стоимостью 1 р.) и вы сделали скидку 1 копейку то пробивается двумя строками 1я за 50 коп. и 2я за 49 коп. У меня в обработке для этого есть 2 процедуры:
1. СписокТоваров = УстановитьЦенуБезСкидки(СписокТоваров);
2. ВыполнитьФорматноЛогическийКонтроль(СписокТоваров);
9. alexstav 4 02.02.21 20:33 Сейчас в теме
СписокТоваров = УстановитьЦенуБезСкидки(СписокТоваров);
ВыполнитьФорматноЛогическийКонтроль(СписокТоваров);
СписокТоваров = УстановитьЦенуБезСкидки(СписокТоваров);

Я правильно понял, эти функции выполняют "подгон" сумм с строках под общую сумму ПКО?
11. aldar 10 02.02.21 20:58 Сейчас в теме
12. aldar 10 03.02.21 00:07 Сейчас в теме
13. alexstav 4 03.02.21 13:09 Сейчас в теме
Обработку подключил, при печать чека выдает;
передается в тег ООО Виола
Ответ = -1 #148= [Ошибка программирования реквизита 1227] Фискальный регистратор: ошибка при печати чека

Если закомментировать эту строку, то ругается на следующую строку (ИНН)

Ответ = -1 #148= [Ошибка программирования реквизита 1228] Фискальный регистратор: ошибка при печати чека

Что может быть?

драйвер 10.5.0
ID серии 10-7942
14. aldar 10 03.02.21 17:38 Сейчас в теме
Может быть прошивка? Я делал обработку в срочном порядке под Атол ДТО 10 после перепрошивки фискальных регистраторов на 5 версию. Когда 8 и 9 драйвера перестали видеть фискальник.
15. Slavez 24 18.02.21 19:48 Сейчас в теме
Добрый день! На одном компе возникает "Ошибка при создании объекта AddIn.Fptr10". Не подскажите с чем это может быть связано?
16. aldar 10 19.02.21 09:00 Сейчас в теме
(15)Регистрируйте regsrv32 под администратором.
17. Vslav 6 24.02.21 18:39 Сейчас в теме
Добрый вечер ! Почему данная обработка не закрывает смену ? Возможно просто сам отчет не печатается ? Но как то все молча ? В 8-м драйвере, при закрытии смены печатался, здесь нет...
18. Vslav 6 24.02.21 18:54 Сейчас в теме
Все разобрался, спасибо !
19. aldar 10 24.02.21 23:03 Сейчас в теме
(18)Добрый вечер. вы уже второй у кого не печатается Z-отчет. Поделитесь в чём было дело. У меня проблем небыло.
20. GreyCrazyWolf 04.03.21 13:57 Сейчас в теме
Добрый день, не совсем разобрался, как в чек передать признак наличной / безналичной оплаты.
21. suhal 04.03.21 14:32 Сейчас в теме
Здравствуйте. Имеется конфигурация 1С: Торговля+Склад. Необходимо доработать 1С так, чтобы могла продавать «Маркированный товар» (постельное бельё ) документом «ЧекККМ». Так же необходимо изменить внешнюю обработку для работы с ККТ Атол 30-Ф (frATOL54_comm_105.ert ), чтобы могла работать с ДТО v10, т.к. одну из ККТ прошили платформой 5 и её не видит ДТО v8. Что для этого необходимо и сколько будет стоить?
С уважением, Сухочев Алексей.
24. aldar 10 04.03.21 21:33 Сейчас в теме
(21)Если обратите внимание на публикацию то в ней как раз и идёт речь об обработке frATOL54_comm_105.ert которую я переделал для работы с ДТО10. И она как раз работает с "1С77 Торговля и склад". Переделать обработку frATOL54_... для приёма маркировки не сложно. А вот для оценки сложности и стоимости изменения конфигурации надо какое ни будь ТЗ.
22. GreyCrazyWolf 04.03.21 14:41 Сейчас в теме
Кажется нашел вот это
Способ расчета (LIBFPTR_PARAM_PAYMENT_TYPE) может принимать следующие значения:
LIBFPTR_PT_CASH - наличными
LIBFPTR_PT_ELECTRONICALLY - безналичными
....
подскажите это правильно?
23. aldar 10 04.03.21 21:12 Сейчас в теме
(22) Да. https://integration.atol.ru/api/#zaregistrirovat-oplatu

Там Вы найдёте подробное описание API АТОЛ
GreyCrazyWolf; +1 Ответить
Оставьте свое сообщение

См. также

Печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54-ФЗ, поддержка изменений от 01/07/19). Для 1С (7.7 и 8 УФ, обычных форм) есть готовые обработки Промо

ККМ Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Абонемент ($m)

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

10 стартмани

11.04.2017    75582    222    ah7777777    575    

Печать чеков маркированного товара ККТ Атол 1С 7.7

Розничная торговля ККМ v77::ОУ 1С7:ТиС БУ ПСН (патентная система налогообложения) Абонемент ($m)

Обработка обслуживания драйвера ККТ Атол ДТО 10 маркированного товара для 1С 7.7.

10 стартмани

26.02.2021    408    1    aksyoma    1    

Обработка печати чеков для кассы Штрих Онлайн (1С 7.7 Торговля и Склад)

Кассовые операции Розничная торговля ККМ v7.7 1С7:ТиС БУ УУ Абонемент ($m)

Обработка позволяет печатать чеки для кассы Штрих Online из 1С 7.7 (Торговля и склад). Есть возможность печать чеков из разных касс. Также можно подставить функционал в любую конфигурацию.

1 стартмани

18.02.2021    415    0    Drfreeman    6    

Загрузка товаров в ККТ "Меркурий" из 1С:Торговля и склад 9.2

Кассовые операции Розничная торговля ККМ v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия БУ УУ Абонемент ($m)

Обработка для загрузки базы кодов цен в ККТ "Меркурий" с помощью программы-конфигуратора MercConfig из базы Торговля и склад 9.2 1С: Предприятие 7.7.

1 стартмани

25.01.2021    1570    1    aleksandr_leiman    0    

API Штрих-М чекопечати для конфигураций 1с7.7

ККМ v7.7 1cv7.md Россия Абонемент ($m)

Подключение Штрих-М Чекопечати  к конфигурации 1с7.7 на примере Штрих-М Торговое Предприятие Prof 4.13.05.

1 стартмани

02.07.2020    2087    1    Ignatov_mu    2    

Обработки обслуживания для "ВебЧек: Программный регистратор расчетных операций" (ПРРО)

Кассовые операции Розничная торговля ККМ Фискальный регистратор v7.7 v8 1cv8.cf 1cv7.md Украина Абонемент ($m)

ВебЧек: ПРРО - это программное решение для регистрации расчетных операций, создания электронных чеков на сервере фискальной службы. Решение совместимо со всем типовыми и не типовыми конфигурациями 1С / BAS для Украины.

1 стартмани

03.03.2020    6000    5    sergoff1    17    

ККМ в 1С 7.7 через Атол-вебсервер 10.Х

ККМ v77::ОУ 1С7:ТиС Фармацевтика, аптеки Россия Абонемент ($m)

Обработка для работы с Онлайн-ККМ в Е-Фарма 1.2.7 (1С 7.70.027) с помощью Атол-вебсервер 10.Х.

1 стартмани

17.12.2019    4044    12    Vlx    0    

Обработка для ККТ Атол 10.Х

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Оптовая торговля, дистрибуция, логистика Россия БУ Абонемент ($m)

Обработка обслуживания ККТ Атол версии 10.Х в среде 1С 7.7 в ТиС релиз 7.70.998

10 стартмани

24.07.2019    5350    5    _s_y_a_    2    

1С 7.7: Обработка для печати чеков на ККМ ШТРИХ формата ФДД 1.05

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Россия БУ Абонемент ($m)

Обработка позволяет печатать чеки формата ФДД 1.05 на кассовом аппарате ШТРИХ. Проверялась на версиях драйвера 4.14.721 - 749.

1 стартмани

03.04.2019    7547    8    user872794    1    

Штрих-М Онлайн-кассы для 1С 7.7 для новых прошивок с НДС20%

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Россия НДС Абонемент ($m)

Обработка работает с новыми прошивками касс Штрих-М с НДС20%.

1 стартмани

20.02.2019    8779    23    fugitiveLDN    3    

Обработка обслуживания торгового оборудования. 1С: 7.7 ТиС

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка обслуживания для 1с 7.7 ТиС. Версия драйвера ККТ Атол 8.16.5.9221 Обработка предназначена для корректной передачи СНО при пробитии чека.

1 стартмани

18.01.2019    12842    27    artmaks1988    47    

Работа с пробитыми чеками по БД Атол

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v7.7 1cv7.md Абонемент ($m)

Получение данных о пробитых чеках по ККМ Атол драйверов версии 8 на ОФД СБИС.

1 стартмани

13.07.2018    9797    1    pakko    7    

Поддержка Онлайн ККМ АТОЛ. Доработка ТиС 7.7 (Бюджетное решение) v 1.0

Кассовые операции ККМ Кассовые операции v77::ОУ 1С7:ТиС Россия УУ Абонемент ($m)

Релиз ТиС 7.70.987. Комплекс позволяет быстро и бюджетно подключить клиенту печать чеков на технике АТОЛ: АТОЛ 30Ф, АТОЛ 55Ф, АТОЛ 22Ф, АТОЛ 52Ф, АТОЛ 11Ф, АТОЛ 90Ф.

1 стартмани

09.07.2018    11397    16    zoeh    9    

Оболочка для работы с последними драйверами ККМ АТОЛ для 1С 7.7, 8.1

Разработка внешних компонент ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Абонемент ($m)

Внешняя компонента - оболочка для работы в среде 1С 7.7 или 1С 8.1 с последними версиями драйверов ККМ от АТОЛ. Поддерживаются драйвера x32 начиная с версии 9.11. Присутствует внешняя обработка для полноценной работы с данными драйверами (поддержка ревизий 2.0, 2.1, 2.2, поддержка протокола ОФД 1.0, 1.0.5, 1.1).

1 стартмани

09.08.2017    41208    319    asdfghgghjdhg    118    

54-ФЗ: Онлайн-касса (кассы). 1С 7.7 + Атол 55Ф ДТО8/10

ККМ Кассовые операции Кассовые операции v7.7 1cv7.md БУ Абонемент ($m)

Обработка ККМ-онлайн для нетиповой 1С:7.7 с печатью на несколько касс. Поддержка тегов 1227,1228. Поддержка версий драйверов ККТ: ДТО8, ДТО10 для Атол. Исходный код открыт.

2 стартмани

23.06.2017    22260    45    vakham    11    

Обработка подключения онлайн-кассы к 1С 7.7 (ПОЛУФАБРИКАТ)

ККМ Кассовые операции Кассовые операции v7.7 1С7:Бух Россия БУ Абонемент ($m)

Обработка обслуживания торгового оборудования для печати чеков ККМ. Протестирована на Конфигурации бухгалтерский учет (7.70.634) с кассой АТОЛ 30 Ф, Печать ПКО и РКО. Также работает на Торговля + Склад.

2 стартмани

31.05.2017    39445    109    Di_Denis    46    

Подключение Онлайн кассы Штрих М к 1С 7.7

Разработка внешних компонент ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Абонемент ($m)

Подключение онлайн кассы Штрих М к любой конфигурации 1С 7.7. Показаны основные приемы работы с драйвером. Обработка представляет из себя набор готовых функций для встраивания в свою конфигурацию: ИнициализироватьФР(); ПодключитьФР(); ОтключитьФР(); ОткрытьСмену(); ЗакрытьСмену(); НапечататьЧек(); АннулироватьЧек(); СнятьХОтчет().

1 стартмани

08.05.2017    26299    79    crimeait    2    

Обработка для 1С ТиС 9.2 для работы с ККМ Offline под РМК Штрих-М Кассир 1.*\2.*\5.*

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработки предназначены для 1С: Предприятие 7.7 типовой конфигурации Торговля и Склад 9.2. Сделано несколько существенных изменений по отношению к стандартной обработке Off_spos. И доработана обработка "Загрузка ККМ Off-Line".

1 стартмани

28.08.2015    30110    34        4    

Подключение фискального регистратора Мини ФП54 через интернет бета

ККМ v7.7 1cv7.md Украина Абонемент ($m)

В продолжении темы подключения фискальных регистраторов через интернет http://infostart.ru/public/91545/.

1 стартмани

08.12.2014    22233    9    assa    4    

Печать чеков на Штрих-М-ФР-К в RDP (Удаленные филиалы)

Печатные формы документов Кассовые операции ККМ Кассовые операции v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Печать на Штрих-М-ФР-К через "Удаленный рабочий стол" RDP в филиалах. При печати через RDP в филиалах столкнулись с проблемой медленной печати и подключение Фискальных регистраторов к 1С. Эта обработка автоматически находит к какому порту подключен ФР и подключает его со всеми установленными настройками.

1 стартмани

28.02.2014    33250    62    Ronin    5    

Выгрузка-загрузка касс, персонала и дисконта.

Розничная торговля POS терминал ККМ Фискальный регистратор Розничная торговля v7.7 1С7:ТиС Розничная и сетевая торговля (FMCG) Абонемент ($m)

Данная обработка совмещает в себе выгрузку-загрузку (поддерживает различные режимы, как с документа, так и подбором), выгрузка дисконтных карт и персонала.

1 стартмани

23.07.2013    23703    18    kodinsklpz    11    

Внешняя компонента для работы с ККМ Искра "Прим-07К"

Разработка внешних компонент Кассовые операции ККМ Фискальный регистратор Кассовые операции v7.7 1cv7.md БУ Абонемент ($m)

Бесплатная внешняя компонента для 1С7.7, позволяющая работать с фискальными регистраторами производства Искра, такими как ПРИМ-07К, ПРИМ-08ТК и пр.

1 стартмани

18.06.2013    23817    64    sandyanf    3    

Печать идентификационного знака контрольно-кассовой техники для ЦТО

ККМ Кассовые операции Кассовые операции v7.7 1cv7.md Россия Абонемент ($m)

Печать идентификационного знака контрольно-кассовой техники для ЦТО.

1 стартмани

02.08.2012    18234    29    ta-so    6    

Банковский терминал и 1С7.7

ККМ v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Абонемент ($m)

1с7.7 и банковский терминал. Внешняя обработка обслуживания.

3 стартмани

21.05.2012    83453    1077    avers007    46    

Отправка электронного письма в ККМ Frontol

Email ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка облегчает процесс отправки электронного письма на ККМ Frontol.

1 стартмани

03.12.2011    24085    20    BorisBelov    3    

Дружба 1С Торговля и Склад 7.7 и Atol Frontol

ККМ Управленческие Розничная торговля Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Несколько обработок на тему получения информации о продажах в 1С из Atol Frontol

1 стартмани

08.11.2011    19941    37    Denis_Viktorovich    5    

Переходим на летнее время (перевод времени на кассе (ФР))

Фискальный регистратор ККМ v77::ОУ 1cv7.md 1С7:ТиС Россия Абонемент ($m)

Уважаемые коллеги! Россия переходит на «летнее» время: стрелки часов в ночь на воскресенье, 28 марта, будут переводиться на час вперед, при этом в пяти регионах поменяются часовые пояса и их жителям переводить свои наручные и настенные «куранты» не придется.

1 стартмани

26.03.2010    20840    21    Tatitutu    4    

Штрих ФР-К обработка

ККМ Фискальный регистратор v77::ОУ Россия Абонемент ($m)

Обработка обслуживания ККМ Штрих ФР-К позволяет снимать X-отчёт, Z-Отчёт и проводить чеки с указанием наличной, безналичной и смешанной оплаты. Прилагается обработка для самого регистратора.

1 стартмани

15.11.2007    22449    1559    sviaz    21    

Сверка Штрих-кодов в SMS и 1C на текущую дату

ККМ v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Проблемы были, товар не "бъётся" по кассе, хотя в базе всё есть. Вот и захотелось проверить что в SMS есть, а что в 1С. Сопоставить данные. Результаты позволили выявить "небъющийся товар". Т.к. Астор в новых релизах менял структуру базы SQL SMS, пришлось сделать 2 кнопки, для старого и нового формата sms.

1 стартмани

04.06.2007    12447    80    bnik    2