Работа с Атол ДТО10 в 1С 7.7

Публикация № 1350696 25.12.20

Администрирование - Торговое оборудование - ККМ

1С7.7 ТиС Атол ДТО10

Обработка торгового оборудования. Для 1С 7.7 ТиС + Атол ДТО10.

Заказчик перешил все фискальные регистрторы новой прошивкой. После чего аппараты стали недоступны для  драйверов ДТО8. Не найдя на просторах интернета бесплатной обработки для работы с фискальным регистратором и 1С7.7 ТиС переделал frATOL54_comm_105.ert для работы с 10ми драйверами. 

Обработка подключается (показано на скриншоте) как стандартная обработка для работы с торговым оборудованием.

Обработка тестировалась на измененной конфигурации 1с7.7 ТиС 9.х

До начала использования обработки необходимо зарегистрировать библиотеку.

Запустите командную строку под администратором и выполните команду 

regsvr32 "C:\Program Files (x86)\.....\addin_fptr10_x86.dll"

 

//********************************************************************************
Функция ПечататьЧек(Объект, Пароль, СписокТоваров, СуммаЧека, Получено, Скидка, ПризнВозврата, ПУП, Кассир, НомерСекции, НомерЧека, ДлинаСтроки, Покупатель="")
	
	Рез = 0;            
	
    СписокТоваров	= УстановитьЦенуБезСкидки(СписокТоваров);
	ВыполнитьФорматноЛогическийКонтроль(СписокТоваров); 
    СписокТоваров	= УстановитьЦенуБезСкидки(СписокТоваров);

	
	Если Подключить(Объект) = 1 Тогда	
		
		//ДТО 10
		//Открыть чек
		Объект.setParam(1021, СокрЛП(Кассир));
		Объект.operatorLogin();
		
		Если ПризнВозврата=1 Тогда
			Объект.setParam(Объект.LIBFPTR_PARAM_RECEIPT_TYPE, Объект.LIBFPTR_RT_SELL_RETURN);
		Иначе
			Объект.setParam(Объект.LIBFPTR_PARAM_RECEIPT_TYPE, Объект.LIBFPTR_RT_SELL);
		КонецЕсли;  

		Ответ	= Объект.openReceipt();
		Если Ответ<>0 Тогда
			Ошибка(Объект, Ответ);
			рез = 0;
			Объект.cancelReceipt();
			Возврат 0;
		КонецЕсли;

		                                  
		Если НЕ (Покупатель="") Тогда   
			
			ПолнНаименование = Покупатель.ПолнНаименование;
			ИНН              = Покупатель.ИНН;  
			
			Если Найти(ИНН, "\") <> 0 Тогда
				ИНН = Лев(ИНН, Найти(ИНН, "\") - 1);
			ИначеЕсли Найти(ИНН, "/") <> 0 Тогда
				ИНН = Лев(ИНН, Найти(ИНН, "/") - 1);
			КонецЕсли;
			
			Если ИННСоответствуетТребованиямНаСервере(ИНН)=0 Тогда	
				Сообщить("ИНН не соответствует требованиям налоговой "+ ИНН);
				Возврат 0;
			КОнецЕсли;
						 
			//1227	Наименование получателя	string
			Объект.setParam(1227, ЗаменитьСпецСимволы(ПолнНаименование) );
			//1228	ИНН получателя	string
			Объект.setParam(1228,СокрЛП(ИНН));
			//1117	Электронный адрес отправителя чека	string
			//Объект.setParamString(1117, Док.Фирма.ЭлПочта );
			//1055	Применяемая система налогообложения (СНО)	int
			Объект.setParam(1055, Объект.LIBFPTR_TT_OSN );
			//1187	Место расчета	string
			//1060	Адрес сайта ФНС	string
			//1057	Признак агента	int
			//Объект.setParamInt(1055, _cons.LIBFPTR_AT_NONE );
			//1171	Телефон поставщика	string
			//fptr.setParamString(1171, СокрЛП(Док.Фирма.ЮрЛицо.Телефоны) );
			//1044	Операция платежного агента	string
			//1073	Телефон платежного агента (может повторяться несколько раз)	string
			//1005	Адрес оператора перевода	string
			//1016	ИНН оператора перевода	string
			//1026	Наименование оператора перевода	string
			//1075	Телефон оператора перевода (может повторяться несколько раз)	string
			//1074	Телефон оператора по приему платежей (может повторяться несколько раз)	string
			//1084	Дополнительный реквизит пользователя	bytearray
			//1192	Дополнительный реквизит чека (БСО)	string
			
		КонецЕсли;
			
		СписокТоваров.ВыбратьСтроки();
		Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
			
			//Продажа ЗаменитьСпецСимволы(СписокТоваров.ТовНаим)  
			Объект.setParam(Объект.LIBFPTR_PARAM_COMMODITY_NAME, СокрЛП(СписокТоваров.ТовНаим));
			Объект.setParam(Объект.LIBFPTR_PARAM_PRICE, СписокТоваров.Цена);
			Объект.setParam(Объект.LIBFPTR_PARAM_QUANTITY, СписокТоваров.Количество);  
			
			Если СписокТоваров.СтавкаНДС = "none" Тогда 
				Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_NO );
			ИначеЕсли СписокТоваров.СтавкаНДС = "18" Тогда
				Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_VAT18 );
			ИначеЕсли СписокТоваров.СтавкаНДС = "20" Тогда
				Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_VAT20 );
			ИначеЕсли СписокТоваров.СтавкаНДС = "10" Тогда
				Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_VAT10 );
			ИначеЕсли СписокТоваров.СтавкаНДС = "0" Тогда
				Объект.setParam(Объект.LIBFPTR_PARAM_TAX_TYPE, Объект.LIBFPTR_TAX_VAT0 );
			КонецЕсли;
                    
			//Объект.setParam( Объект.LIBFPTR_PARAM_TAX_SUM, СписокТоваров.НДС);   
			
			//1212	Признак предмета расчета	int
			// Признак предмета расчёта. Свойство ItemType может принимать значения:
			// 	1 - товар, за исключением подакцизного товара
			// 	2 - подакцизный товар
			// 	3 - работа
			// 	4 - услуга
			// 	5 - приём ставок при деятельность по организации и проведению азартных игр
			// 	6 - выплата выигрышей в азартных играх
			// 	7 - реализация лотерейных билетов или ставок при деятельность по организации и проведению лотерей
			// 	8 - выплата выигрышей в лотереях
			// 	9 -  прав на использование результатов интеллектуальной деятельности или средств индивидуализации
			// 	10 -  аванс, задаток, предоплата, кредит, взносе в счет оплаты, пени, штраф, вознаграждение, бонус и иной аналогичный предмет расчета
			// 	11 -  предмет расчета, состоящий из предметов, каждому из которых может быть присвоено значение от 0 до 10 (набор)
			// 	12 -  предмет расчета, не относящийся к предметам расчета, которым может быть присвоено значение от 0 до 11
			Объект.setParam(1212,1);
			
			//1214	Признак способа расчета	int
			// Признак способа расчёта. Свойство PaymentMode может принимать значения:
			// 	1 - Полная предварительная оплата до момента передачи предмета расчета
			// 	2 - Частичная предварительная оплата до момента передачи предмета расчета
			// 	3 - Аванс
			// 	4 - Полная оплата, в том числе с учетом аванса (предварительной оплаты) в момент передачи предмета расчета
			// 	5 - Частичная оплата предмета расчета в момент его передачи с последующей оплатой в кредит
			// 	6 - Передача предмета расчета без его оплаты в момент его передачи с последующей оплатой в кредит
			// 	7 - Оплата предмета расчета после его передачи с оплатой в кредит (оплата кредита)
			Объект.setParam(1214,4);
			
			Ответ	= Объект.registration();   
			Если Ответ<>0 Тогда
				Ошибка(Объект, Ответ);
				рез = 0;  
				Возврат рез;
			КонецЕсли;
			
		КонецЦикла;      
		
		//Закрыть чек
		Если ПризнВозврата=0 Тогда
			//Оплата
			Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_TYPE, Объект.LIBFPTR_PT_CASH);
			Объект.setParam(Объект.LIBFPTR_PARAM_PAYMENT_SUM, СуммаЧека);
			Объект.payment();
		КонецЕсли;
		
		Ответ	= Объект.closeReceipt();
		 
		Если Ответ<>0 Тогда 
			Ошибка(Объект, Ответ); 
			рез = 0; 
			Возврат Рез;
		КонецЕсли;	

		НомерЧека				= ПолучитьНомерЧека(Объект);
		Рез = Объект.close();

		
		ОписаниеПоследнейОшибки =	Объект.ErrorDescription();
		КодПоследнейОшибки		= 	Объект.ErrorCode(); 
		
		Если КодПоследнейОшибки = 0 тогда
			Рез = 1;
		Иначе
			ОписаниеРезультата = ОписаниеПоследнейОшибки;
		КонецЕсли; 
	КонецЕсли;
	
	Возврат Рез;
	
КонецФункции

 

Скачать файлы

Наименование Файл Версия Размер
1С7.7 Атол ДТО10:

.ert 38,00Kb
87
.ert 38,00Kb 87 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Petrushka 13.01.21 16:58 Сейчас в теме
Здравствуйте
Выдаёт ошибку при регистрации ФР в Торговом оборудовании
Ошибка при создании объекта из компоненты F:\Tunes_1C\Torg_NEW_for_Admin\addin_fptr10_x86.dll (отсутствует интерфейс IInitDone)
Фискальный регистратор: ошибка при подключении
не удалось загрузить внешнюю компоненту "addin_fptr10_x86.dll"

Как правильно зарегистрировать?
Прикрепленные файлы:
2. aldar 19 13.01.21 21:41 Сейчас в теме
Компоненту надо регистрировать regsrv32 под администратором. Иначе не работает.
3. ultra_plus 18.01.21 06:23 Сейчас в теме
Здравствуйте. Я может неправильно указываю номер порта? Или тут ничего не указывается. Подскажите, пожалуйста, как правильно надо настроить оборудование. АТОЛ 30Ф, ТиС 77. Под Windows XP будет работать?
Прикрепленные файлы:
4. aldar 19 18.01.21 10:32 Сейчас в теме
Здравствуйте. Написать обработку надо было срочно и я жестко прописал ком порт в функции подключения

//********************************************************************************
Объект.setSingleSetting(Объект.LIBFPTR_SETTING_COM_FILE, "COM8"); //"COM"
5. vladimir.gl 19.01.21 11:23 Сейчас в теме
Здравствуйте. Спасибо, работает. При закрытии смены не печатает Z-отчет, буду разбираться.
6. grafit 8 30.01.21 12:34 Сейчас в теме
Как отключиться после печати чека и освободить порт?
8. aldar 19 02.02.21 20:30 Сейчас в теме
(6) Я думаю как и всегда это делали. Удалить объект.
7. grafit 8 02.02.21 15:49 Сейчас в теме
На платформе 5 невозможно корректно передать скиду по позиции (насколько я понял). Если на старой можно было сумму передать и поделить на количество, получив таким образом корректную ИТОГОВУЮ сумму чека, то сейчас этот метод не работает.
Есть соображения по этому поводу?
10. aldar 19 02.02.21 20:58 Сейчас в теме
(7)Эта проблема уже давно. Во второй рознице эту проблему решали делением строки на несколько и игрой +- с копейками. Т.е. если у вас 2 товара по 50 копеек (т.е. общей стоимостью 1 р.) и вы сделали скидку 1 копейку то пробивается двумя строками 1я за 50 коп. и 2я за 49 коп. У меня в обработке для этого есть 2 процедуры:
1. СписокТоваров = УстановитьЦенуБезСкидки(СписокТоваров);
2. ВыполнитьФорматноЛогическийКонтроль(СписокТоваров);
9. alexstav 5 02.02.21 20:33 Сейчас в теме
СписокТоваров = УстановитьЦенуБезСкидки(СписокТоваров);
ВыполнитьФорматноЛогическийКонтроль(СписокТоваров);
СписокТоваров = УстановитьЦенуБезСкидки(СписокТоваров);

Я правильно понял, эти функции выполняют "подгон" сумм с строках под общую сумму ПКО?
11. aldar 19 02.02.21 20:58 Сейчас в теме
12. aldar 19 03.02.21 00:07 Сейчас в теме
13. alexstav 5 03.02.21 13:09 Сейчас в теме
Обработку подключил, при печать чека выдает;
передается в тег ООО Виола
Ответ = -1 #148= [Ошибка программирования реквизита 1227] Фискальный регистратор: ошибка при печати чека

Если закомментировать эту строку, то ругается на следующую строку (ИНН)

Ответ = -1 #148= [Ошибка программирования реквизита 1228] Фискальный регистратор: ошибка при печати чека

Что может быть?

драйвер 10.5.0
ID серии 10-7942
14. aldar 19 03.02.21 17:38 Сейчас в теме
Может быть прошивка? Я делал обработку в срочном порядке под Атол ДТО 10 после перепрошивки фискальных регистраторов на 5 версию. Когда 8 и 9 драйвера перестали видеть фискальник.
15. Slavez 24 18.02.21 19:48 Сейчас в теме
Добрый день! На одном компе возникает "Ошибка при создании объекта AddIn.Fptr10". Не подскажите с чем это может быть связано?
16. aldar 19 19.02.21 09:00 Сейчас в теме
(15)Регистрируйте regsrv32 под администратором.
17. Vslav 6 24.02.21 18:39 Сейчас в теме
Добрый вечер ! Почему данная обработка не закрывает смену ? Возможно просто сам отчет не печатается ? Но как то все молча ? В 8-м драйвере, при закрытии смены печатался, здесь нет...
18. Vslav 6 24.02.21 18:54 Сейчас в теме
Все разобрался, спасибо !
19. aldar 19 24.02.21 23:03 Сейчас в теме
(18)Добрый вечер. вы уже второй у кого не печатается Z-отчет. Поделитесь в чём было дело. У меня проблем небыло.
20. GreyCrazyWolf 04.03.21 13:57 Сейчас в теме
Добрый день, не совсем разобрался, как в чек передать признак наличной / безналичной оплаты.
21. suhal 04.03.21 14:32 Сейчас в теме
Здравствуйте. Имеется конфигурация 1С: Торговля+Склад. Необходимо доработать 1С так, чтобы могла продавать «Маркированный товар» (постельное бельё ) документом «ЧекККМ». Так же необходимо изменить внешнюю обработку для работы с ККТ Атол 30-Ф (frATOL54_comm_105.ert ), чтобы могла работать с ДТО v10, т.к. одну из ККТ прошили платформой 5 и её не видит ДТО v8. Что для этого необходимо и сколько будет стоить?
С уважением, Сухочев Алексей.
24. aldar 19 04.03.21 21:33 Сейчас в теме
(21)Если обратите внимание на публикацию то в ней как раз и идёт речь об обработке frATOL54_comm_105.ert которую я переделал для работы с ДТО10. И она как раз работает с "1С77 Торговля и склад". Переделать обработку frATOL54_... для приёма маркировки не сложно. А вот для оценки сложности и стоимости изменения конфигурации надо какое ни будь ТЗ.
27. user1587212 21.04.21 15:15 Сейчас в теме
Напишите в личку, помогу.
22. GreyCrazyWolf 04.03.21 14:41 Сейчас в теме
Кажется нашел вот это
Способ расчета (LIBFPTR_PARAM_PAYMENT_TYPE) может принимать следующие значения:
LIBFPTR_PT_CASH - наличными
LIBFPTR_PT_ELECTRONICALLY - безналичными
....
подскажите это правильно?
23. aldar 19 04.03.21 21:12 Сейчас в теме
(22) Да. https://integration.atol.ru/api/#zaregistrirovat-oplatu

Там Вы найдёте подробное описание API АТОЛ
GreyCrazyWolf; +1 Ответить
25. user663268_infolet 17.03.21 16:41 Сейчас в теме
Доброго дня! Покажите, пожалуйста, процедуру Подключить(Объект)
26. aldar 19 17.03.21 22:08 Сейчас в теме
(25) У меня так




//********************************************************************************
Функция Подключить(Объект)

	Рез = 1;
	Если ПустоеЗначение(Объект) = 1 Тогда
		
		ИмяКомпоненты="AddIn.Fptr10";
		Попытка
			Объект = СоздатьОбъект("AddIn.Fptr10");
		исключение
			Сообщить("Ошибка при создании объекта "+ИмяКомпоненты,"!");
		конецпопытки;
		
		Объект.setSingleSetting(Объект.LIBFPTR_SETTING_MODEL, строка(Объект.LIBFPTR_MODEL_ATOL_AUTO));
		Объект.setSingleSetting(Объект.LIBFPTR_SETTING_PORT, строка(Объект.LIBFPTR_PORT_COM));
		Объект.setSingleSetting(Объект.LIBFPTR_SETTING_COM_FILE, "COM8"); //"COM"      
		Объект.setSingleSetting(Объект.LIBFPTR_SETTING_ACCESS_PASSWORD, "0");
		Объект.setSingleSetting(Объект.LIBFPTR_SETTING_USER_PASSWORD, "30");
		Объект.applySingleSettings();
	КонецЕсли;
	
	Ответ	= Объект.Open();      
	Если Объект.isOpened()=0 Тогда 
		Ошибка(Объект, Ответ);
		рез = 0;  
		Объект.Close();   
	КонецЕсли;  
	
	Возврат Рез;
	
КонецФункции
Показать
28. Asuneft 2 24.05.21 07:02 Сейчас в теме
День добрый, а где эту библиотеку взять addin_fptr10_x86.dll?
29. aldar 19 24.05.21 10:23 Сейчас в теме
День добрый/ Установите драйвер Атол (32х разрядный) с сайта atol.ru
30. VSE 09.07.21 03:20 Сейчас в теме
Доброе время суток.
Столкнулся с проблемой.
При продажи ип или юрику вводится ИНН.
Чек печатает все правильно, но данные в ОФД передаются без ИНН.
Никто не сталкивался?
31. user953984 15.08.21 09:58 Сейчас в теме
Все сделал как описал автор. Вроде ФР подключился - проверить этого не смог, так как если ткнуть кнопку - Параметры подключения - вылазит ошибка - что то связанное с параметрами.

Попробовал пробить чек - вылазит ошибка на строку:

Объект.DeviceEnabled = 1;

Объект.DeviceEnabled = 1;
{E:\1CTEST\EXTFORMS\EQUIP\FRATOL54_COMM_105.ERT(23)}: Поле агрегатного объекта не обнаружено (DeviceEnabled)

Вот что я поменял в стандартной обработке атола:


Функция Подключить(Компонента, ПрогИд, Объект)

    Рез = 1;

		Попытка
			Объект = СоздатьОбъект("AddIn.Fptr10");  // Создание объекта внешней компоненты
		Исключение
            Сообщить("Ошибка при создании объекта "+ ПрогИд ,"!");
		КонецПопытки;
		

		Если ПустоеЗначение(Объект) = 1 Тогда
			ОписаниеРезультата = "не удалось создать объект внешней компоненты с программым идентификатром AddIn." + ПрогИд;
		Иначе
			Рез = 1;
		КонецЕсли;
		
    Возврат Рез;
    
КонецФункции


//********************************************************************************
Функция ПодключитьсяКФР(Объект)

	Рез = 0;
		
	// занимаем порт
  	Объект.DeviceEnabled = 1;
  	Если Объект.ResultCode = 0 тогда
  		// получаем состояние ККМ
  		Если Объект.GetStatus() = 0 тогда
  			// если есть открытый чек, то отменяем его
  			Если Объект.CheckState <> 0 тогда
  				Если Объект.CancelCheck() = 0 тогда
  					Рез = 1;
  				КонецЕсли;
  			КонецЕсли;
  		КонецЕсли;
  	КонецЕсли;
		
	ОписаниеПоследнейОшибки =	Объект.ResultDescription;
    КодПоследнейОшибки		= 	Объект.ResultCode;
 	
	Если КодПоследнейОшибки = 0 тогда
    	Рез = 1;
	Иначе
		ОписаниеРезультата = ОписаниеПоследнейОшибки;
  	КонецЕсли;
	
  	Возврат Рез;
	
КонецФункции
Показать
32. aldar 19 15.08.21 13:48 Сейчас в теме
День добрый.
Компоненту надо регистрировать regsrv32 под администратором. Иначе не работает.
33. user953984 15.08.21 21:06 Сейчас в теме
это я сделал. Иначе бы кассовик не подключился функцией "Функция Подключит"
34. basil_m 18.08.21 13:37 Сейчас в теме
Подскажите, под Windows XP у кого-нибудь работает?
Переделал кассовое ПО с ДТО8 на ДТО10. На 7ке и 10ке - все ОК.
В XP при Объект = СоздатьОбъект("AddIn.Fptr10"); выдает Ошибка при создании объекта
35. user1020738 21.08.21 09:53 Сейчас в теме
Добрый день, какая версия драйвера содержит библиотеку addin_fptr10_x86.dll, может ставлю ни так пробывал 10.9, 10.8, 10.5, 10.0
37. aldar 19 23.08.21 08:50 Сейчас в теме
36. user1020738 21.08.21 10:38 Сейчас в теме
при открытии обработки вот такая ошибка T(618)}: Значение не представляет агрегатный объект (Выгрузить)
38. user1020738 23.08.21 09:01 Сейчас в теме
да но я по ходу знаю где промахнулся чуть позже попробую
39. user1020738 23.08.21 11:20 Сейчас в теме
дальше больше, в не могу выбрать путь к вашей обработке предлагается только выпадающей список , где ее нет
Прикрепленные файлы:
40. user1020738 23.08.21 11:56 Сейчас в теме
{D:\РАБОЧАЯ БАЗА\+DB+\EXTFORMS\PUBID_1350696-FRATOL54_COMM_ДТО10.ERT(618)}: Значение не представляет агрегатный объект (Выгрузить)
41. aldar 19 23.08.21 12:48 Сейчас в теме
42. @lexandr 174 28.08.21 00:03 Сейчас в теме
Если не печатает z-отчет то добавьте:
Объект.setParam(Объект.LIBFPTR_PARAM_REPORT_ELECTRONICALLY, 0);

Должно получиться следующее:
Объект.setParam(1021, СокрЛП(Кассир));
Объект.operatorLogin();
Объект.setParam(Объект.LIBFPTR_PARAM_REPORT_TYPE, Объект.LIBFPTR_RT_CLOSE_SHIFT);
Объект.setParam(Объект.LIBFPTR_PARAM_REPORT_ELECTRONICALLY, 0);
Объект.report();
Объект.checkDocumentClosed();

Это включит печать бумажного закрытия смены.
43. alex_gus 2 06.09.21 10:15 Сейчас в теме
Доброго дня! Так же "вляпался" в такую-же ситуацию, пытаюсь подключить АТОЛ ЗОФ на ДТО 10 к 7.7, выдает вот это " не удалось создать объект внешней компоненты с программым идентификатром AddIn." dll - зарегистрировал.
44. alex_gus 2 06.09.21 12:54 Сейчас в теме
Все, разобрался. Чеки начали пробиваться и уходить в ОФД.
45. user654398_liana0988 29.09.21 14:11 Сейчас в теме
Добрый день при пробитий чека выходит ошибка: {D:\БАЗЫ 1С\MAG\EXTFORMS\EQUIP\FRATOL54_COMM_ДТО10.ERT(435)}: Значение не представляет агрегатный объект (ПолнНаименование)
46. maxim33 13.10.21 18:00 Сейчас в теме
Добрый день! Установила драйвер 10.9.0.0...в дистрибутиве почему то нет addin_fptr10_x86.dll...где можно найти эту библиотеку. Драйвер установлен по XP. Есть только C:\Program Files\ATOL\Drivers10\KKT\1Cv83\ATOL_KKT_10.zip...внутри есть файл fptr10_1c_win32_10_9_0_0.dll...

но он почему-то при регистрации выдает ошибку.
47. aldar 19 13.10.21 22:52 Сейчас в теме
(46)
addin_fptr10_x86.dll

Для корректной работы обработки должны быть установлены драйвера ККТ АТОЛ версии 10.7.0.0 и выше, версия x86 (с версией x64 обработка работать не будет). Далее необходимо зарегистрировать командой "regsvr32 addin_fptr10_x86.dll" com-сервер драйвера, находящийся в папке
C:\Program Files (x86)\ATOL\Drivers10\KKT\langs\com\
(данная операция требует прав администратора).
48. maxim33 14.10.21 11:11 Сейчас в теме
Спасибо. Зарегистрировала ее на компьютере где касса подключена, от имени администратора (XP). При подключении в 1с пишет
Ошибка при создании объекта из компоненты \\Server\Торг_new\addin_fptr10_x86.dll (отсутствует интерфейс IInitDone)
Фискальный регистратор: ошибка при подключении
не удалось загрузить внешнюю компоненту "addin_fptr10_x86.dll"

addin_fptr10_x86.dl лежит не на сервер, а на компьютере на котором установлена касса, в папке C:\Program Files (x86)\ATOL\Drivers10\KKT\langs\com\...я там ее и зарегистрировала...Я что то опять не так сделала?
Еще dll положила в \\Server\Торг_new, где база лежит.
Прикрепленные файлы:
49. aldar 19 14.10.21 12:35 Сейчас в теме
Это не полноценная обработка, а пример. Поэтому после регистрации вручную не надо больше регистрировать с помощью 1с. Или дописать...
50. maxim33 14.10.21 13:49 Сейчас в теме
Ответ = -1 #4= [Порт недоступен]
Фискальный регистратор: ошибка при подключении
51. maxim33 14.10.21 13:51 Сейчас в теме
Пишет при нажатии на кнопку "Параметры подключения" ...не подключается почему то
52. aldar 19 14.10.21 15:38 Сейчас в теме
(51)прочитайте сообщение 4 выше
53. maxim33 15.10.21 09:23 Сейчас в теме
Теперь выдает Ответ = -1 #3= [Порт занят]
Фискальный регистратор: ошибка при подключении. В каком случае может быть такая ошибка?
54. aldar 19 15.10.21 10:33 Сейчас в теме
(53)В случае если порт занят.
55. maxim33 15.10.21 18:20 Сейчас в теме
Да, все подключилось нормально. Спасибо
56. maxim33 19.10.21 15:47 Сейчас в теме
Не подскажите , а X отчет данная обработка не печатает?
57. aldar 19 19.10.21 20:54 Сейчас в теме
58. maxim33 20.10.21 11:03 Сейчас в теме
z отчет печатает, х отчет не печатает (Отчет без гашения)
59. aldar 19 20.10.21 12:08 Сейчас в теме
(58) я думаю так же добавить в обработку печати х-отчета LIBFPTR_PARAM_REPORT_ELECTRONICALLY.
https://integration.atol.ru/api/#fn_registration
60. maxim33 21.10.21 10:38 Сейчас в теме
В обработке не нашла команду которая вообще создает x -отчет...
61. Rest001 25.10.21 10:29 Сейчас в теме
Подскажите, кто-то реализовал "Частичную оплату" на 10 драйвере? А то на 8 я так и не смог это вывести.
Оставьте свое сообщение

См. также

Печать чеков маркированного товара ККТ Атол 1С 7.7

Розничная торговля ККМ v77::ОУ 1С7:ТиС БУ ПСН (патентная система налогообложения) Абонемент ($m)

Обработка обслуживания драйвера ККТ Атол ДТО 10 маркированного товара для 1С 7.7.

2 стартмани

26.02.2021    3276    10    aksyoma    2    

Обработка печати чеков для кассы Штрих Онлайн (1С 7.7 Торговля и Склад)

Кассовые операции Розничная торговля ККМ v7.7 1С7:ТиС БУ УУ Абонемент ($m)

Обработка позволяет печатать чеки для кассы Штрих Online из 1С 7.7 (Торговля и склад). Есть возможность печать чеков из разных касс. Также можно подставить функционал в любую конфигурацию.

1 стартмани

18.02.2021    3359    4    Drfreeman    8    

Загрузка товаров в ККТ "Меркурий" из 1С:Торговля и склад 9.2

Кассовые операции Розничная торговля ККМ v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия БУ УУ Абонемент ($m)

Обработка для загрузки базы кодов цен в ККТ "Меркурий" с помощью программы-конфигуратора MercConfig из базы Торговля и склад 9.2 1С: Предприятие 7.7.

1 стартмани

25.01.2021    3709    1    aleksandr_leiman    0    

API Штрих-М чекопечати для конфигураций 1с7.7

ККМ v7.7 1cv7.md Россия Абонемент ($m)

Подключение Штрих-М Чекопечати  к конфигурации 1с7.7 на примере Штрих-М Торговое Предприятие Prof 4.13.05.

1 стартмани

02.07.2020    3417    2    Ignatov_mu    2    

Обработки обслуживания для "ВебЧек: Программный регистратор расчетных операций" (ПРРО)

Кассовые операции Розничная торговля ККМ Фискальный регистратор v7.7 v8 1cv8.cf 1cv7.md Украина Абонемент ($m)

ВебЧек: ПРРО - это программное решение для регистрации расчетных операций, создания электронных чеков на сервере фискальной службы. Решение совместимо со всем типовыми и не типовыми конфигурациями 1С / BAS для Украины.

1 стартмани

03.03.2020    9474    6    sergoff1    18    

ККМ в 1С 7.7 через Атол-вебсервер 10.Х

ККМ v77::ОУ 1С7:ТиС Фармацевтика, аптеки Россия Абонемент ($m)

Обработка для работы с Онлайн-ККМ в Е-Фарма 1.2.7 (1С 7.70.027) с помощью Атол-вебсервер 10.Х.

1 стартмани

17.12.2019    5567    12    Vlx    0    

Обработка для ККТ Атол 10.Х

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Оптовая торговля, дистрибуция, логистика Россия БУ Абонемент ($m)

Обработка обслуживания ККТ Атол версии 10.Х в среде 1С 7.7 в ТиС релиз 7.70.998

10 стартмани

24.07.2019    6743    5    _s_y_a_    2    

1С 7.7: Обработка для печати чеков на ККМ ШТРИХ формата ФДД 1.05

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Россия БУ Абонемент ($m)

Обработка позволяет печатать чеки формата ФДД 1.05 на кассовом аппарате ШТРИХ. Проверялась на версиях драйвера 4.14.721 - 749.

1 стартмани

03.04.2019    9307    9    user872794    1    

Штрих-М Онлайн-кассы для 1С 7.7 для новых прошивок с НДС20%

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Россия НДС Абонемент ($m)

Обработка работает с новыми прошивками касс Штрих-М с НДС20%.

1 стартмани

20.02.2019    10301    25    fugitiveLDN    9    

Обработка обслуживания торгового оборудования. 1С: 7.7 ТиС

ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка обслуживания для 1с 7.7 ТиС. Версия драйвера ККТ Атол 8.16.5.9221 Обработка предназначена для корректной передачи СНО при пробитии чека.

1 стартмани

18.01.2019    15203    30    artmaks1988    48    

Работа с пробитыми чеками по БД Атол

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v7.7 1cv7.md Абонемент ($m)

Получение данных о пробитых чеках по ККМ Атол драйверов версии 8 на ОФД СБИС.

1 стартмани

13.07.2018    11305    1    pakko    7    

Поддержка Онлайн ККМ АТОЛ. Доработка ТиС 7.7 (Бюджетное решение) v 1.0

Кассовые операции ККМ Кассовые операции v77::ОУ 1С7:ТиС Россия УУ Абонемент ($m)

Релиз ТиС 7.70.987. Комплекс позволяет быстро и бюджетно подключить клиенту печать чеков на технике АТОЛ: АТОЛ 30Ф, АТОЛ 55Ф, АТОЛ 22Ф, АТОЛ 52Ф, АТОЛ 11Ф, АТОЛ 90Ф.

1 стартмани

09.07.2018    13013    18    zoeh    9    

Оболочка для работы с последними драйверами ККМ АТОЛ для 1С 7.7, 8.1

Разработка внешних компонент ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Абонемент ($m)

Внешняя компонента - оболочка для работы в среде 1С 7.7 или 1С 8.1 с последними версиями драйверов ККМ от АТОЛ. Поддерживаются драйвера x32 начиная с версии 9.11. Присутствует внешняя обработка для полноценной работы с данными драйверами (поддержка ревизий 2.0, 2.1, 2.2, поддержка протокола ОФД 1.0, 1.0.5, 1.1).

1 стартмани

09.08.2017    44609    329    asdfghgghjdhg    120    

54-ФЗ: Онлайн-касса (кассы). 1С 7.7 + Атол 55Ф ДТО8/10

ККМ Кассовые операции Кассовые операции v7.7 1cv7.md БУ Абонемент ($m)

Обработка ККМ-онлайн для нетиповой 1С:7.7 с печатью на несколько касс. Поддержка тегов 1227,1228. Поддержка версий драйверов ККТ: ДТО8, ДТО10 для Атол. Исходный код открыт.

2 стартмани

23.06.2017    24267    48    vakham    11    

Обработка подключения онлайн-кассы к 1С 7.7 (ПОЛУФАБРИКАТ)

ККМ Кассовые операции Кассовые операции v7.7 1С7:Бух Россия БУ Абонемент ($m)

Обработка обслуживания торгового оборудования для печати чеков ККМ. Протестирована на Конфигурации бухгалтерский учет (7.70.634) с кассой АТОЛ 30 Ф, Печать ПКО и РКО. Также работает на Торговля + Склад.

2 стартмани

31.05.2017    42113    111    Di_Denis    46    

Подключение Онлайн кассы Штрих М к 1С 7.7

Разработка внешних компонент ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Абонемент ($m)

Подключение онлайн кассы Штрих М к любой конфигурации 1С 7.7. Показаны основные приемы работы с драйвером. Обработка представляет из себя набор готовых функций для встраивания в свою конфигурацию: ИнициализироватьФР(); ПодключитьФР(); ОтключитьФР(); ОткрытьСмену(); ЗакрытьСмену(); НапечататьЧек(); АннулироватьЧек(); СнятьХОтчет().

1 стартмани

08.05.2017    28260    79    crimeait    2    

Обработка для 1С ТиС 9.2 для работы с ККМ Offline под РМК Штрих-М Кассир 1.*\2.*\5.*

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработки предназначены для 1С: Предприятие 7.7 типовой конфигурации Торговля и Склад 9.2. Сделано несколько существенных изменений по отношению к стандартной обработке Off_spos. И доработана обработка "Загрузка ККМ Off-Line".

1 стартмани

28.08.2015    31641    34        4    

Подключение фискального регистратора Мини ФП54 через интернет бета

ККМ v7.7 1cv7.md Украина Абонемент ($m)

В продолжении темы подключения фискальных регистраторов через интернет http://infostart.ru/public/91545/.

1 стартмани

08.12.2014    24013    9    assa    4    

Печать чеков на Штрих-М-ФР-К в RDP (Удаленные филиалы)

Печатные формы документов Кассовые операции ККМ Кассовые операции v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Печать на Штрих-М-ФР-К через "Удаленный рабочий стол" RDP в филиалах. При печати через RDP в филиалах столкнулись с проблемой медленной печати и подключение Фискальных регистраторов к 1С. Эта обработка автоматически находит к какому порту подключен ФР и подключает его со всеми установленными настройками.

1 стартмани

28.02.2014    34631    62    Ronin    5    

Выгрузка-загрузка касс, персонала и дисконта.

Розничная торговля POS терминал ККМ Фискальный регистратор Розничная торговля v7.7 1С7:ТиС Розничная и сетевая торговля (FMCG) Абонемент ($m)

Данная обработка совмещает в себе выгрузку-загрузку (поддерживает различные режимы, как с документа, так и подбором), выгрузка дисконтных карт и персонала.

1 стартмани

23.07.2013    24940    18    kodinsklpz    11    

Внешняя компонента для работы с ККМ Искра "Прим-07К"

Разработка внешних компонент Кассовые операции ККМ Фискальный регистратор Кассовые операции v7.7 1cv7.md БУ Абонемент ($m)

Бесплатная внешняя компонента для 1С7.7, позволяющая работать с фискальными регистраторами производства Искра, такими как ПРИМ-07К, ПРИМ-08ТК и пр.

1 стартмани

18.06.2013    25148    64    sandyanf    3    

Печать идентификационного знака контрольно-кассовой техники для ЦТО

ККМ Кассовые операции Кассовые операции v7.7 1cv7.md Россия Абонемент ($m)

Печать идентификационного знака контрольно-кассовой техники для ЦТО.

1 стартмани

02.08.2012    19029    29    ta-so    6    

Банковский терминал и 1С7.7

ККМ v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Абонемент ($m)

1с7.7 и банковский терминал. Внешняя обработка обслуживания.

3 стартмани

21.05.2012    86676    1095    avers007    50    

Отправка электронного письма в ККМ Frontol

Email ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка облегчает процесс отправки электронного письма на ККМ Frontol.

1 стартмани

03.12.2011    25275    20    BorisBelov    3    

Дружба 1С Торговля и Склад 7.7 и Atol Frontol

ККМ Управленческие Розничная торговля Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Несколько обработок на тему получения информации о продажах в 1С из Atol Frontol

1 стартмани

08.11.2011    20910    37    Denis_Viktorovich    5    

Переходим на летнее время (перевод времени на кассе (ФР))

Фискальный регистратор ККМ v77::ОУ 1cv7.md 1С7:ТиС Россия Абонемент ($m)

Уважаемые коллеги! Россия переходит на «летнее» время: стрелки часов в ночь на воскресенье, 28 марта, будут переводиться на час вперед, при этом в пяти регионах поменяются часовые пояса и их жителям переводить свои наручные и настенные «куранты» не придется.

1 стартмани

26.03.2010    21924    21    Tatitutu    4    

Штрих ФР-К обработка

ККМ Фискальный регистратор v77::ОУ Россия Абонемент ($m)

Обработка обслуживания ККМ Штрих ФР-К позволяет снимать X-отчёт, Z-Отчёт и проводить чеки с указанием наличной, безналичной и смешанной оплаты. Прилагается обработка для самого регистратора.

1 стартмани

15.11.2007    23502    1559    sviaz    21    

Сверка Штрих-кодов в SMS и 1C на текущую дату

ККМ v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Проблемы были, товар не "бъётся" по кассе, хотя в базе всё есть. Вот и захотелось проверить что в SMS есть, а что в 1С. Сопоставить данные. Результаты позволили выявить "небъющийся товар". Т.к. Астор в новых релизах менял структуру базы SQL SMS, пришлось сделать 2 кнопки, для старого и нового формата sms.

1 стартмани

04.06.2007    13272    80    bnik    2