Пакетная печать документов

Публикация № 14229

Разработка - Печать - Пакетная печать

43
Пакетная печать документов

v1.02 Поддержка БП 1.6.13

43

Скачать файлы

Наименование Файл Версия Размер
Пакетная печать v1.02
.1222082850 20,71Kb
13.02.13
773
.1222082850 20,71Kb 773 Скачать бесплатно

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Foxy 30.10.06 15:35 Сейчас в теме
Господа....а есть ли такая-же обработка- но для версии 7.7 мне Очень срочно (точней нашей бухгалтерии) нужна она...конкретно-возможность печати документов пакетами, а именно - таких как:счет,счет фактура,акт
(желательно пономеру, в пределах даты)
заранее благодарен всем кто откликнется на мою "головную боль", т.к. я ток начинающий программист 1С..то прошу помощи у старших братьев!!
С ув. Денис!
Шлите сюда:Ichalovsky@mail.ru
3. kandellaster 30.01.07 07:20 Сейчас в теме
4. vasilykushnir 30.01.07 09:58 Сейчас в теме
Foxy, если не хочешь навеки остатся начинающим программистом - мой тебе дружеский совет: пиши сам. Чужие используй только как источник идей и методов "хитрого" программирования.
Пиши на мыло - скину образец для 7-ки. Но предупреждаю - писалась под себя: унификация и рядом не лежала. Подробности по мылу или ася - не хочется засорять чужие разработки не нужными комметами.
5. noname777 18.06.08 16:43 Сейчас в теме
А есть пакетная печать М-11 для 8.0???
6. Sedow 27 05.10.08 21:30 Сейчас в теме
Немного запоздал но может надется время, сбросте пакетную печать для 7.7
sedowank@mail.ru
7. NtS 14.01.09 05:19 Сейчас в теме
в качестве пожелания - добавить пакетную печать счетов на оплату
8. 227405 14.01.09 10:11 Сейчас в теме
Почему то выдает ошибку:
{Форма.Форма(23)}: Метод объекта не обнаружен (ПолучитьДеревоМакетовПечати)
9. Igortid 167 26.02.09 17:37 Сейчас в теме
ДеревоМакетовПечати = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Объект.Ссылка, СтруктураВнутреннихПечатныхФорм);
=======================================================
Вот это поможет
10. 227405 06.03.09 14:32 Сейчас в теме
Не помогает:
ДеревоМакетовПечати = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Объект.Ссылка, СтруктураВнутреннихПечатныхФорм);
При нажатии "Сформировать" просто ничего не присходит.
11. Tishu 3 11.04.09 09:25 Сейчас в теме
Поправте в вызове НапечататьВнешнююФорму ссылку на общий модуль (надо УниверсальныеМеханизмы).
12. Romeo53 27.01.11 12:24 Сейчас в теме
где тут ссылка на общий модуль, что исправить не понятно
-------------------
Функция НапечататьВнешнююФорму(Ссылка, ИсточникМакета) Экспорт

Перем ДополнительныеПараметры;

ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.Принадлежность[ИсточникМакета.НомерСтроки - 1].ХранилищеВнешнейОбработки.Получить();

// Получить дополнительные параметры внешней обработки
ИсточникМакета.Свойство("ДополнительныеПараметрыОбработки", ДополнительныеПараметры);

Если ДвоичныеДанные = Неопределено Тогда
ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.ХранилищеВнешнейОбработки.Получить();
КонецЕсли;

Если ДвоичныеДанные = Неопределено Тогда
Возврат Неопределено;
КонецЕсли;

ТабДокумент = Неопределено;

ИмяФайла = ПолучитьИмяВременногоФайла("epf");
Попытка
ДвоичныеДанные.Записать(ИмяФайла);
Обработка = ВнешниеОбработки.Создать(ИмяФайла);
Обработка.СсылкаНаОбъект = Ссылка;

// Передать внешней обработке дополнительные параметры
Если ДополнительныеПараметры <> Неопределено Тогда

// Если у внешней обработки есть реквизит для дополнительных параметров, присвоить ему значение
Если НЕ Обработка.Метаданные().Реквизиты.Найти("ДополнительныеПараметры") = Неопределено Тогда
Обработка.ДополнительныеПараметры = ДополнительныеПараметры;
КонецЕсли;

КонецЕсли;

ТабДокумент = Обработка.Печать();
УдалитьФайлы(ИмяФайла);
Исключение
ОбщегоНазначения.СообщитьОбОшибке(ОписаниеОшибки(),, "Не удалось сформировать внешнюю печатную форму!");
КонецПопытки;

Возврат ТабДокумент;

КонецФункции

------------------------------------
13. Svetlana_K 05.10.11 15:43 Сейчас в теме
14. ai000 35 14.10.11 16:10 Сейчас в теме
Понадобилась печать одновременно нескольких печатных форм одного документа, немного переработал, выложил тут:
http://infostart.ru/public/94523/
Также добавил краткую печать реестра обработанных документов.
Версия для 8.2
15. Igortid 167 15.10.11 18:08 Сейчас в теме
16. mezonik 19.10.11 09:28 Сейчас в теме
без флуда теперь не обойтись, спасибо
Оставьте свое сообщение

См. также

Пакетная печать в строго заданном порядке 6

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Пакетная печать

В силу различных особенностей ПО, ОС, драйверов и т.д. порядок печати документов не всегда совпадает с порядком их отправки на печать. Данный метод позволяет всегда получать на выходе нужный порядок документов.

19.09.2018    5285    crazycat    17       

Пакетная печать документов "Реализация товаров и услуг" 38

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 УТ10 Россия БУ УУ Windows Оптовая торговля Розничная торговля НДС Бесплатно (free) Пакетная печать

Обработка позволяет распечатать пакет отгрузочных документов для конфигураций УТ и БП, должна выдерживать обновления конфигураций. Что она позволяет распечатать 2 торг12, 2 счет фактуры , 2 ттн за два нажатия кнопки. + Встроен универсальный отбор по документам реализации товаров и услуг (н-р можно распечатать все документы за опред период по опред. контрагенту) + Возможность отсылки сразу на принтер и распределения по копиям + все общие модули вынесены в модуль обработки) + Печатает пакетно также и внешние печатные формы для документов реализация товаров и услуг и счетов фактур + при печати использует типовые модули печати документов в конфигурации (как будто вы сами отправляете на печать из формы документов) проверялась УТ 10.3.3.3 и БП 1.6.10.6

02.09.2009    22109    846    y22-k    33       

Универсальная настраиваемая печать документов 56

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Пакетная печать

Универсальная настраиваемая печать документов. Умеет печатать реестр документов, сформированный согласно произвольному отбору а также сами документы по любой доступной печатной форме.

05.07.2009    14796    981    Magister    39       

Групповая печать карточек 1-НДФЛ 25

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия БУ Зарплата НДФЛ Бесплатно (free) Пакетная печать

В 2009 не нашла в типовой печати 1-НДФЛ по всем сотрудникам. Сделала групповую печать карточек 1-НДФЛ по документу "Сведения о доходах физлиц", подготовленному для передачи в ИФНС. Может быть кому-нибудь пригодится. В 2010 году обработку посчитала уже неактуальной, так как в типовой появилась возможность групповой печати в стандартном отчете. Но расчетчица попросила и на последнем релизе (2.5.20) сделать печать по документу "Сведения о доходах физлиц". Поэтому выкладываю обновленную обработку, так как предыдущая версия не работает на более ранних релизах.

06.02.2009    12619    210    Ирка    12       

Обработка для печати регистра налоговых накладных 4

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Украина НУ Оптовая торговля Бесплатно (free) Пакетная печать

Обработка сама выводит на печать налоговые накладные (за укр. законодательством - неплательщик НДС (два экземпляра) и плательщик НДС(вариант организации)...

04.06.2008    6752    17    mut_mut    1       

Помощник печати 5

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Пакетная печать

Помощник печати с выбором печатных форм, подключенных к документу.

21.12.2007    11064    28    Legavaz    1       

Универсальный редактор реквизитов документов и справочников из УПП 8.0 3

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 УПП1 Бесплатно (free) Обработка документов Пакетная печать Обработка справочников

Обработка не моя. Добавил пару строк и процедур. Но чтоб никто больше не пыхтел зря, рекомендую воспользоваться. Если бы кто-нибудь написал DLL-ку, которая вытаскивала бы из 8.0 тексты процедур во внешние текстовые файлы, тогда и групповую печать для встроенных печатных форм можно было бы сделать универсальной. Потому что макет-то доступен, а вот процедура печати должна быть только в модуле объекта, да еще и с директивой "Экспорт". Конечно можно все документы конфигурации снабдить такими процедурами, но увы, это будет уже не универсально... Призываю крутых помочь! См. идею в дополнительно.

13.08.2007    10738    110    ge_ni    3       

Групповая печать документов 14

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Бесплатно (free) Пакетная печать

"Множественная" печать документов из любой типовой конфигурации. "Сканирует" виды документов конфигурации, общие макеты и макеты документов. Выбираете вид документов и макет на основании которого будет формироваться печатная форма. К примеру: документы - "Перемещение товаров", макет - "ТОРГ13". Можно настроить непосредственную печать на принтер без предварительного просмотра, количество копий и др. Если для выбранных документа и макета не существует печатных форм, то выдаётся сообщение при попытки печати. Обработка писалась "на скорую руку", поэтому не судите строго. Рабочая, быстронастраиваемая программулина.

11.05.2007    8342    380    yalex9    14