Заказ Кодов Маркировок с помощью Api Честный знак (Молочная продукция)

Публикация № 1461562 18.06.21

Разработка - Системная интеграция - Интеграция с WEB

Маркировка Api

Небольшой пример взаимодействия с системой "Честный знак", для получения Кодов Маркировок с помощью Api (Молочная продукция).

 

Недавно столкнулись с одной проблемой при работе с "Честным знаком (ЧЗ)". Получение Кодов маркировок можно лишь в 2 форматах (PDF и EPS), с которыми без особых проблем этикетки не распечатать. При повторной загрузке с сайта "ЧЗ", также можно получить КМ в усеченном варианте, которые можно распечатать в формате datamatrix и и нанести на упаковку. Данный код считывается и определяется в мобильном приложении "ЧЗ". Однако обратно такой код маркировки не загрузить в систему "ЧЗ", так как для работы с "ЧЗ" необходимо предоставлять полные коды маркировки. (Например при подаче "Отчета о нанесении КМ", "Ввода в оборот" и т.д., система требует полные коды маркировки (В усеченном варианте КМ не проходят валидацию на сайте).


Получить коды маркировки в цифро-буквенном значении могут только автоматизированные системы управления технологическим процессом, управляющие преобразованием кодов маркировки в средства идентификации. Либо с помощью метода API.
 

Данная обработка поможет сэкономить время тем, кто работает в Не типовых конфигурациях и столкнулся с подобной ситуацией.

Данная обработка получает Коды маркировок с "Честного знака" по API и сохраняет в csv-файле на диске. При необходимости обработку можно доработать для своих нужд (Записать в документ, регистр, справочник и тд.).


Для работы вам потребуется Идентификатор OMS и Токен. Получить можно в Личном кабинете "Честного знака" в разделе "Станция управления заказами" - "Устройства".


 

А в программе 1С должны быть Справочник "Номенклатура" и регистр сведений "Штрихкоды номенклатуры".


Также для работы необходим "КриПто-Про" для работы с сертификатами!

 

 

В обработке предоставлен пример взаимодействия с сертификатами, подписание документов и отправляемых данных, взаимодействие с Api СУЗ ЧЗ.

Полезные ссылки:
Примеры работы с API в Честный знак (обувь).
Обмен через API с Честный знак (Система маркировки товаров).
Маркировка обуви, автоматизация через API.
 

Руководство СУЗ Облако

 

Обработка универсальная, для управляемых форм. Тестировалась на 1С:Предприятие 8.3 (8.3.13.1644)

Скачать файлы

Наименование Файл Версия Размер
Заказ Кодов Маркировок с помощью Api Честный знак (Молочная продукция):

.epf 15,29Kb
5
.epf 1 15,29Kb 5 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. oleg-x 17 18.06.21 16:50 Сейчас в теме
Это только заказ маркировки? Без ввода в оборот?
2. 33lab 783 18.06.21 18:40 Сейчас в теме
(1) Вот расширение в котром реализовано "заказ кодов, отчет о нанесении и ввод в оборот"
3. user5300 716 21.06.21 08:19 Сейчас в теме
(1) Реализовал и ввод в оборот, чуть позже выложу.
16. lsnr 10.10.21 22:16 Сейчас в теме
(3) А где можно посмотреть ввод в оборот?
17. user5300 716 11.10.21 08:34 Сейчас в теме
18. lsnr 11.10.21 20:26 Сейчас в теме
(17) спасибо.. а где можно посмотреть код Типа продукта, соответствующий упакованной воде? Вот в вашей обработке код 20 - молочная продукция (параметр templateId), а какой код соответствует воде?
20. lsnr 12.10.21 10:13 Сейчас в теме
(19) спасибо.. Но кода товарной группы воды там нет к сожалению.. Другие группы есть, а воды нет.. (
22. lsnr 13.10.21 19:01 Сейчас в теме
(19) ой, извиняюсь, не увидел сразу..
4. SolarGard 110 25.06.21 10:16 Сейчас в теме
Как с динамическим токеном работать?
5. user5300 716 25.06.21 10:27 Сейчас в теме
(4) Приведу свой пример:
Динамический токен действует 10 часов, поэтому создал константу (Строка: 500). Если пустая или срок более 10 часов - получал новый.

////Клиент
Функция ПолучитьТокен(Сертификат = Неопределено)
	
	ТокенДоступа = РаботаСМаркировкойСервер.ПолучитьТокен(); /// возвращает Константы.Токен.Получить()
	
	Если ПустаяСтрока(ТокенДоступа) Тогда
		ТокенДоступа = СформироватьНовыйДинамическийТокен(Сертификат);
	КонецЕсли;
	Если СрокДействияТокенаИстек(ТокенДоступа) Тогда
		ТокенДоступа = СформироватьНовыйДинамическийТокен(Сертификат);
	КонецЕсли;

	Возврат ТокенДоступа;
	
КонецФункции


Функция СформироватьНовыйДинамическийТокен(Сертификат)
	
	Если Сертификат = Неопределено Тогда
		ВызватьИсключение("Отсутсвует сертификат!");
	КонецЕсли;
		
	Сервер = "markirovka.crpt.ru";
		
	// Получение данных для получения токена
	HTTPСоединение =    Новый HTTPСоединение(Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL);
	HTTPЗапрос = новый HTTPЗапрос("/api/v3/auth/cert/key");
	HTTPОтвет = HTTPСоединение.ВызватьHTTPМетод("GET",HTTPЗапрос);
	ОтветСтрока = HTTPОтвет.ПолучитьТелоКакСтроку("UTF-8"); 
	
	ЧтениеJSON = Новый ЧтениеJSON; 
	ЧтениеJSON.УстановитьСтроку(ОтветСтрока); 
	ДанныеJSON = ПрочитатьJSON(ЧтениеJSON); 
	ЧтениеJSON.Закрыть();
	
	УИД = ДанныеJSON.uuid;
	ДанныеДляПолученияТокена = ДанныеJSON.data;
	
	// Подписание данных для получения токена

	ДанныеДляПолученияТокена = ПодписатьСертификатомДокумент(
				ПолучитьСертификаты(Истина,Истина,Сертификат),
				ЗашифроватьBase64(ДанныеДляПолученияТокена, КодировкаТекста.UTF8),Ложь);
	
	// Получение токена с использованием подписанных данных
	Соединение = Новый HTTPСоединение(Сервер,443,,,,,Новый ЗащищенноеСоединениеOpenSSL);
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Content-Type", "application/json; charset=UTF-8");
	Заголовки.Вставить("Accept", "application/json");
	HTTPЗапрос = Новый HTTPЗапрос("/api/v3/auth/cert/",Заголовки);
	ЗаписьJOIN = Новый ЗаписьJSON;
	ЗаписьJOIN.УстановитьСтроку();
	ДанныеДляЗапроса = Новый Структура;
	ДанныеДляЗапроса.Вставить("uuid",УИД);
	ДанныеДляЗапроса.Вставить("data",ДанныеДляПолученияТокена);	
	ЗаписатьJSON(ЗаписьJOIN,ДанныеДляЗапроса);
	СтрокаДляЗапроса = ЗаписьJOIN.Закрыть();
	
	HTTPЗапрос.УстановитьТелоИзСтроки(СтрокаДляЗапроса,КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
	Ответ = Соединение.ОтправитьДляОбработки(HTTPЗапрос);
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(Ответ.ПолучитьТелоКакСтроку());
	
	Токен = ПрочитатьJSON(ЧтениеJSON, Ложь).token;
	
	РаботаСМаркировкойСервер.УстановитьНовый(Токен);  ///Константы.Токен.Установить(Токен)
	
	возврат Токен;
	
КонецФункции


Функция СрокДействияТокенаИстек(ТокенДоступа)
	
	РезультатРазбораТокена = РасшифроватьТокенJWT(ТокенДоступа);
	Если РезультатРазбораТокена = Неопределено Тогда
		Возврат Истина;
	Иначе  
        ДействуетДо = ДатаИзСтрокиUNIX(РезультатРазбораТокена.exp, 1);
		Если ДействуетДо < (ТекущаяДата() - 600) Тогда     /// Истекает через 10 мин
			Возврат Истина; 
		Иначе
			возврат Ложь;
		КонецЕсли;
	КонецЕсли;
	
КонецФункции


#Область РасшифровкаТокена

Функция РасшифроватьТокенJWT(Токен) Экспорт
    
    ВозвращаемоеЗначение = Новый Структура;
    ВозвращаемоеЗначение.Вставить("РезультатРасшифровки", Неопределено);
    ВозвращаемоеЗначение.Вставить("ТекстОшибки", "");
    
    ЭлементыТокена = СтрРазделить(Токен, ".");
    Если ЭлементыТокена.Count() <> 3 Тогда
        ВозвращаемоеЗначение.ТекстОшибки = НСтр("ru = 'Токен не соответствует формату JWT'");
		Возврат Неопределено;
        //Возврат ВозвращаемоеЗначение;
    КонецЕсли;
    
    ЭлементТокенаДанные = ЭлементыТокена[1];

    Данные = ТекстJSONВОбъект(
        ПолучитьСтрокуИзДвоичныхДанных(
            ДвоичныеДанныеЭлементаТокенаJWT(ЭлементТокенаДанные)));

    Возврат Данные;
    
КонецФункции

Функция ДвоичныеДанныеЭлементаТокенаJWT(Знач Значение)
    
    Значение = СтрЗаменить(Значение, "-", "+");
    Значение = СтрЗаменить(Значение, "_", "/");
    
    Остаток = СтрДлина(Значение) % 4;

    Если Остаток = 1 Тогда
        Возврат Неопределено;
    ИначеЕсли Остаток = 2 Тогда
        Значение = Значение + "==";
    ИначеЕсли Остаток = 3 Тогда
        Значение = Значение + "=";
    КонецЕсли;
    
    Возврат Base64Значение(Значение);
    
КонецФункции

// Получить из текста JSON структуру.
// 
// Параметры:
//     ТекстJSON                    - Строка - Текст JSON.
//     ПреобразовыватьВСоответствие - Булево - Признак преобразования в соответствие.
// Возвращаемое значение:
//     Структура, Неопределено - Результат преобразования JSON.
Функция ТекстJSONВОбъект(ТекстJSON, ПреобразовыватьВСоответствие = Ложь) Экспорт
    
    Чтение = Новый ЧтениеJSON;
    Чтение.УстановитьСтроку(ТекстJSON);
    
    Попытка
        РезультатРазбора = ПрочитатьJSON(Чтение, ПреобразовыватьВСоответствие);
    Исключение
        РезультатРазбора = Неопределено;
    КонецПопытки;
    
    Возврат РезультатРазбора;
    
КонецФункции

// Формирует из структуры текст JSON
// 
// Параметры:
//     Структура - Структура - Произвольная структура данных
// Возвращаемое значение:
//     Строка - Текст JSON
Функция ОбъектВТекстJSON(Структура, УдалитьПробелыИПереносыСтрок = Ложь) Экспорт
    
    Если УдалитьПробелыИПереносыСтрок Тогда
        ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет, "");
    Иначе
        ПараметрыЗаписиJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Авто, "  ");
    КонецЕсли;
    
    ЗаписьJSON = Новый ЗаписьJSON();
    ЗаписьJSON.УстановитьСтроку(ПараметрыЗаписиJSON);
    
    ЗаписатьJSON(ЗаписьJSON, Структура);
    
    ТекстJSON = ЗаписьJSON.Закрыть();
    
    Возврат ТекстJSON;
    
КонецФункции

Функция ДатаИзСтрокиUNIX(Значение, Делитель = 1000) Экспорт
    
    Возврат МестноеВремя('19700101' + Цел(Значение / Делитель));
    
КонецФункции
#КонецОбласти


Показать
6. user703659_elvan.1c 07.07.21 11:56 Сейчас в теме
Вчера скачал
Не найден экспортируемый метод: ПриЗакрытииФормыВыбора
{ВнешняяОбработка.СозданиеЗаказаНаЭмиссиюКодовМаркировок.Форма.Форма.Форма(8)}: ОбработкаВыбора = Новый ОписаниеОповещения("ПриЗакрытииФормыВыбора", ЭтаФорма,"ПодборРеализации");

по причине:
Не найден экспортируемый метод: ПриЗакрытииФормыВыбора

Надо добавить Экспорт
&НаСервере
Процедура ПриЗакрытииФормыВыбора(Значение, ДопПараметры) Экспорт
7. user5300 716 07.07.21 14:09 Сейчас в теме
8. user5300 716 07.07.21 14:15 Сейчас в теме
9. oleg-x 17 07.07.21 14:38 Сейчас в теме
(8) по той же ссылке на 13 версии это не работает, вообщем баг платформы, поэтому и работает без экспорта.
11. user5300 716 07.07.21 15:26 Сейчас в теме
(9) Работает если режим совместимости стоит до 13 версии, на новых исправили уже,
но моя обработка исправлена)
10. user703659_elvan.1c 07.07.21 14:55 Сейчас в теме
1С:Предприятие 8.3 (8.3.15.1869)
12. SolarGard 110 16.07.21 21:50 Сейчас в теме
(5) Большое спасибо.
URL: <url стенда>/auth/cert/{omsConnection}

Надо omsConnection вставлять?
HTTPЗапрос = Новый HTTPЗапрос("/api/v3/auth/cert/aacbbe08-73af-4b7b-b8aa-7c6b4c88c2c0",Заголовки);
Так ?
13. user5300 716 18.07.21 18:47 Сейчас в теме
(12) я не вставлял... подключался так:
HTTPЗапрос = Новый HTTPЗапрос("/api/v3/auth/cert/",Заголовки);

на текущий день всё работает, (примере выше)
14. SolarGard 110 18.07.21 23:23 Сейчас в теме
(13) Я уже вставлял вчера {omsConnection} разные в Песочнице. Для каждого токен свой динамический на 10 часов создается. А старый статический в одном устройстве заменился на динамический. Ну и теперь с ним далее только так жить. Как в документации все.
15. user5300 716 23.07.21 15:28 Сейчас в теме
(14) Да, вы были правы.
В СУЗ необходимо добавлять параметр {omsConnection}

В ГИС МП этот параметр не требуется.
21. lsnr 13.10.21 18:49 Сейчас в теме
Добрый день. У меня РезультатРазбора в Функции ПолучитьСтатусыЗаказовСУЗ() содержит только {"omsId": ...} и не содержит поля orderInfos, которое затем присваивается массиву МассивЗаказов. Не подскажите - по какой причине это может быть?
Оставьте свое сообщение

См. также

Модуль обмена с QIWI Промо

Банковские операции WEB v8 1cv8.cf УУ Абонемент ($m)

Компании, которые используют систему моментальных платежей QIWI, ценят ее за удобство по скорости выплат и для платежей по запросу. Но такие переводы сложны для учета, а при большом объеме проводимых операций отнимают много времени и превращаются в дополнительную головную боль. Мы сотрудничали с компаниями, которые отправляют большое количество платеже на QIWI, и часто слышали боль бухгалтеров о том, как им сложно работать с такими переводами. Поэтому мы автоматизировали выплаты через QIWI в 1С и создали модуль интеграции 1С c API QIWI Wallet и QIWI TopUp.

5 стартмани

25.05.2020    7371    0    Neti    10    

Расширение конфигурации для Web-доступа к 1С (1С в роли back-end)

WEB v8 1cv8.cf Россия Абонемент ($m)

Для реализации того, чтобы 1С формировала и отдавала страницу, которую можно было бы открыть через браузер было написано расширение, которое позволяет публиковать из 1С произвольные ресурсы, будь то API, сайт или изображения / прочие файлы.

1 стартмани

01.04.2021    7974    11    SaschaG    4    

Работа с картами в 1С на примере бесплатной библиотеки Leaflet

Практика программирования Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Разработка функционала отображения и выбора пунктов доставки на карте прямо в 1С с помощью бесплатной библиотеки Leaflet. Тестирование производилось на платформе 8.3.15.1534 на тонком клиенте.

1 стартмани

31.03.2021    9246    27    Parsec1C    11    

Отправка Push-уведомлений через сервис Firebase Cloud Messaging по протоколу FCM HTTP v1 API

Практика программирования WEB v8 Абонемент ($m)

При разработке нативного приложения Android для ТСД, в котором присутствует функционал отображения задач кладовщикам, созданных в 1С, возникла необходимость отправлять push-уведомления о появлении новых задач. Для отправки таких уведомлений было решено использовать сервис Firebase Cloud Messaging (FCM). Так как для 1С, в отличии от других языков программирования, не существует готовых библиотек, что вполне логично, то очевидным способом отправки является использование протокола HTTP. Однако, существующая информация в интернете в части 1С содержит только сведений об отправке push-уведомлений через этот сервис с использованием устаревшего протокола HTTP Firebase Cloud Messaging. Сам Google не рекомендует использовать данный протокол и настоятельно склоняет к переходу на новый протокол FCM HTTP v1 API. Что ж, пришлось разбираться самостоятельно.

1 стартмани

24.03.2021    6036    10    ltfriend    11    

BIM: взаимодействие с платформой Autodesk Forge Промо

WEB v8 1cv8.cf Строительство Абонемент ($m)

Предлагаемый пример демонстрирует широкие возможности для взаимодействия «1С:Предприятие» с платформой Autodesk Forge и позволяет вам получить базовые представления о применения технологий информационного моделирования в строительстве. Поддерживаются все версии платформы от 8.3.12 и выше до 8.3.18.

1 стартмани

25.11.2020    33461    11    kandr    2    

Генератор маршрута по "документам отгрузки" в Google.Maps

Оптовая торговля Розничная торговля WEB v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Данная обработка будет полезна для построения маршрута по документам реализаций за выбранный период.

7 стартмани

08.11.2020    9216    14    quazare    20    

Продажи со склада поставщика WildBerries. Взаимодействие с АПИ из 1С

WEB Розничная торговля v8 УТ11 УУ Абонемент ($m)

Взялся я тут делать интеграцию с АПИ нового проекта Диких Ягод - Продажи со склада поставщика (ПССП). Это было нелегко. Никто же не читает инструкцию (уже аж 7 версии!), а зря! Для начала сделал получение списка товаров и обмен остатками.

5 стартмани

06.11.2020    27971    176    kiv1c    136    

Чатбот WhatsApp

WEB v8 1cv8.cf Абонемент ($m)

Внешняя обработка для написания чат-бота WhatsApp

1 стартмани

21.10.2020    10135    24    ripreal1    30    

Односторонний файловый обмен с сайтом по ftp (1C 2 Web) Промо

Обмен данными 1С Файловые протоколы обмена, FTP WEB v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Подходит под любую конфигурацию на управляемом интерфейсе на базе БСП 2.4.4 и выше. Позволяет гибко настроить выгрузку, практически любых, данных по расписанию на сервер ftp вашего ресурса. Ведение лога процесса выгрузки также предусмотрено.

3 стартмани

09.12.2019    11591    14    LamerSoft    0    

1С + react native

WEB v8 1cv8.cf Абонемент ($m)

Пример реализации клиента для 1С на react native.

1 стартмани

09.10.2020    9683    6    van_za    6    

Учимся создавать http сервис (часть третья). Передача нескольких параметров в http сервис

WEB Практика программирования v8 1cv8.cf Абонемент ($m)

Пошаговое руководство по созданию http сервиса (часть третья). Передача нескольких параметров в http сервис, a также формирование сложных JSON строк.

1 стартмани

02.10.2020    13541    5    hpi    16    

Подключаем WhatsApp к 1С

WEB v8 1cv8.cf Абонемент ($m)

Обработка для быстрого подключения WhatsApp к любой конфигурации 1С.

1 стартмани

30.09.2020    12660    66    andrew_shamin    61    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3 Промо

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    19357    23    capitan    11    

Обмен через API с Честный знак (Система маркировки товаров)

Оптовая торговля WEB v8 1cv8.cf Оптовая торговля, дистрибуция, логистика Россия Абонемент ($m)

Рассмотрен пример обмена через API с Честным знаком с использованием электронной подписи.

1 стартмани

10.08.2020    22169    93    vasilievil    25    

HTTP сервисы по OpenAPI спецификациям

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Начинаем путь разработки HTTP сервисов с создания спецификаций OpenAPI. Автодокументация сервисов формата Swagger UI без зависимостей. Настройка сервисов в режиме предприятия.

1 стартмани

29.06.2020    15118    15    shmalevoz    22    

Конструктор HTTP-соединений в 1С (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Иногда возникают мысли о том, чтобы прикрутить сервисы, связанные с HTTP-соединениями, в 1С. Необходимо писать обработку и анализировать результат.

1 стартмани

02.06.2020    8243    28    Denr83    0    

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

2 стартмани

30.03.2018    35983    65    Ditron    103    

Примеры работы с API в Честный знак (обувь)

WEB Розничная торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

К сожалению, документация API честного знака полна пробелов и неточностей. В данной статье описан мой опыт отгрузки маркированных товаров с одного юр. лица на другое.

1 стартмани

15.05.2020    25913    41    stas8359    54    

DaJet QL - расширяемый язык запросов

Интеграция WEB v8 Абонемент ($m)

DaJet QL поддерживает практический полный синтаксис SQL Server 2005-2016. Кроме этого это расширяемый язык запросов. Обращение к объектам СУБД выполняется в терминах метаданных 1С. Доступ к возможностям этого языка запросов реализован в виде web api сервиса. Результаты запросов возвращаются в виде JSON.

1 стартмани

20.04.2020    12574    12    zhichkin    19    

Обмен данными между OZON и 1С

Оптовая торговля WEB v8 v8::ОУ УТ11 УУ Абонемент ($m)

Данная подсистема позволяет загружать отправления «с моего склада» из OZON (в статусе «Ожидают сборки») в 1с Управление торговлей 11 по API. Так же есть возможность выгружать статусы отправлений «awaiting_deliver, т.е. Ожидает отгрузки» и «cancelled, т.е. Отменен» из 1с в OZON по API.

10 стартмани

09.04.2020    29629    213    vex2865    146    

Работа с релизами 1С и договорами ИТС Промо

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    20790    60    RocKeR_13    37    

Пример работы с Trello из 1С

WEB v8 1cv8.cf Россия УУ Абонемент ($m)

Небольшая конфигурация содержит примеры обмена с онлайн-сервисом Trello.

1 стартмани

15.02.2020    17482    53    terrorion    14    

Взаимодействие HTML (COM объект, WebKit) с 1С (обычные и управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования HTML (COM объект, WebKit) в 1С (8.3).

2 стартмани

18.01.2020    12546    30    Deniskinr83    0    

Google drive - менеджер файлов

WEB Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Синхронизация с гугл диском легко и просто!

10 стартмани

05.12.2019    22721    36    zykov_vitaliy    26    

Проверка VAT номеров Промо

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    18026    3    wtlz    1    

Автозаполнение адреса по КЛАДР в УПП при выгрузке контрагента с портала компании (API dadata)

WEB v8 1cv8.cf Абонемент ($m)

Заведение, согласование контрагентов организовано на портале компании. Далее по web-сервису контрагенты выгружаются в УПП (юр.адрес и факт.адрес выгружаются строкой). Задача автоматизировать заполнение адреса в УПП по КЛАДР.

1 стартмани

03.12.2019    10233    3    John_d    10    

Работа с Яндекс-картами в 1С (вывод меток, прокладка маршрута, отображение балуна, вывод меток в кластеры) (обычное и управляемое приложение)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Работа с Яндекс-картами в 1С (управляемое приложение). Обработка показывает, как можно найти адреса на карте Яндекс, проложить маршрут.

2 стартмани

20.11.2019    20251    147    Denr83    0    

Пример взаимодействия HTML (COM объект, WebKit) с 1С (динамический отбор) (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования WebKit в 1С (8.3).

2 стартмани

18.11.2019    13898    17    Denr83    0    

Трекинг номеров РПО в Почте России Промо

WEB Оптовая торговля Оптовая торговля v8 Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    32604    38    Smaylukk    3    

Яндекс сервисы [Расширение]

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Расширение для работы с Яндекс-сервисами (предиктор,переводчик,проверка орфографии)

1 стартмани

24.10.2019    14981    11    noprogrammer    12    

Telegram бот на 1С

WEB v8 1cv8.cf Абонемент ($m)

Telegram бот на 1С в виде внешней обработки, встраиваемой в типовые 1С 8.3.

1 стартмани

24.09.2019    24916    49    budidich    19    

Выгрузка номенклатуры в социальную сеть Вконтакте

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    22948    61    kaliuzhnyi    48    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты Промо

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

10 стартмани

31.08.2017    25188    19    vipchep    1    

Путеводитель по истории релизов

WEB v8 1cv8.cf Абонемент ($m)

Отчет по истории выпуска релизов и анализа информации по обновлениям.

5 стартмани

13.08.2019    19056    13    YPermitin    18    

Подключение к сайту и отправка или получение данных по API (POST, GET...) (с описанием кода)

WEB v8 1cv8.cf Абонемент ($m)

Простая обработка по отправке или получение данных с любого сервера главное знать ресурс (выполняемую функцию) и тело запроса.

1 стартмани

12.08.2019    27301    48    MaxPowerr    5    

Конфигурация для обмена данными (интеграционная шина)

Внешние источники данных WEB v8 1cv8.cf Абонемент ($m)

Система позволяет организовать обмен данными, как с базами 1С, так и любыми другими приложениями. Система представляет собой отдельную конфигурацию. Система позволяет организовать гибкие возможности по настройке обмена. В качестве брокера сообщений, для передачи данных, используется отдельная самостоятельная конфигурация на 1С. Комплект поставки содержит файл расширения для "клиентской" части шины, данное расширение позволяет без снятия "ключа" организовать гибкий механизм обмена данными.

4 стартмани

08.07.2019    20124    35    miha-28    17    

Работа с картами 1С 4 в 1: Яндекс, Google , 2ГИС, OpenStreetMap(OpenLayers) Промо

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

С каждым годом становится все очевидно, что использование онлайн-сервисов намного упрощает жизнь. К сожалению по картографическим сервисам условия пока жестковаты. Но, ориентируясь на будущее, я решил показать возможности API выше указанных сервисов: Инициализация карты Поиск адреса на карте с текстовым представлением Геокодинг Обратная поиск адреса по ее координатами Взаимодействие с картами - прием координат установленного на карте метки Построение маршрутов по указанным точками Кластеризация меток на карте при увеличении масштаба Теперь также поддержка тонкого и веб-клиента

1 стартмани

28.12.2012    118704    2733    Smaylukk    365    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    26223    88    MarkoSokolov    48    

1С и WebKit. Вариант взаимодействия

WEB v8 1cv8.cf Абонемент ($m)

В результате перехода на WebKit тип свойства Документ у поля, имеющего вид ПолеHTMLДокумента, изменился с COMОбъект на ВнешнийОбъект. Также изменилась DOM модель документа, доступная через это свойство.

2 стартмани

23.02.2019    40386    88    mi1man    59    

Строим маршруты на картах в 1С с помощью OpenStreetMap, OSRM и Leaflet

WEB v8 1cv8.cf Транспорт, автопарки, такси Абонемент ($m)

Краткая статья о том как вывести на карту (в 1С) маршруты с помощью OpenStreetMap, OSRM и Leaflet. По данной системе очень мало примеров, но так как OpenStreetMap является бесплатным сервисом и не требует никаких ключей и регистраций, и является довольно мощным механизмом, решил написать небольшую статью "как это сделать?". В первую очередь скажу, все намного проще, если вы используете последнюю версию платформы (8.3.14), где есть поддержка практически всех браузеров (IE 11, EDGE, Mozilla), но что делать если у нас не самая свежая платформа, где поддержка только IE 9?

2 стартмани

12.02.2019    36859    121    Ditron    118    

Пример использования REST API Яндекс Диска Промо

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    33800    54    MKFreeUser    15    

Яндекс карта в документе "Заказ клиента" на закладке "Доставка". (Расширение) УТ 11.4

Обработка документов WEB Оптовая торговля Оптовая торговля v8 УТ11 Россия УУ Абонемент ($m)

Показ яндекс карты в документе "Заказ клиента" на закладке "Доставка" и печать карты для курьера с контактными данными. (Расширение)

3 стартмани

05.02.2019    14699    13    ret    9    

Яндекс карты 2.1. Построение маршрута. Передача длины маршрута в реквизит формы

WEB v8 1cv8.cf Абонемент ($m)

Пригодится как пример использования Яндекс карты 2.1 для построения маршрута.

1 стартмани

24.01.2019    19554    93    John_d    33    

Веб-форма авторизации/регистрации/восстановления пароля для веб-клиента 1С с помощью HTML/CSS/PHP/HTTP-сервисов 1С

WEB v8 1cv8.cf Абонемент ($m)

Пришла в голову идея создать универсальную веб-форму входа в веб-клиент 1С на HTML/CSS/PHP/HTTP-сервисы 1С. Чтобы прямо как на нормальных сайтах. Заодно и для ознакомления с 1С с новой, для себя, стороны. Интересно было попробовать интеграцию PHP - 1С.

1 стартмани

08.11.2018    25729    30    Бэнни    22    

Работа с публикациями "Инфостарт" Промо

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    28682    14    RocKeR_13    16    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    28988    42    echo77    73    

Конфигурация для просмотра публичных телеграм каналов Промо

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    22390    13    DO_WHILE_LOOP    7