Запрет редактирования/пометки на удаление/отмены проведения задним числом для каждого пользователя.

Публикация № 148793

Администрирование - Информационная безопасность

Запрет редактирования/пометки на удаление/отмены проведения задним числом для каждого пользователя.
В Справочнике Пользователи надо добавить Реквизит "ЗапрРед" (число) и добавить его в форму. Теперь вы можете назначать для каждого пользователя свои сроки работы задним числом.
 
//в Глобальном Модуле.

Перем Запрет;
...
Функция глПроверкаПроведенияЗаднимЧислом (Конт) Экспорт
        //проверка на пользователя - проведение задним числом 
    Запрет=Число(глПользователь.ЗапрРед);
    Если ИмяПользователя()<>"Администратор" Тогда 
              //устанавливаем пользователя, которому можно всё. 
        Если (ТекущаяДата () - Конт.ДатаДок) > Запрет  Тогда 
            Возврат 1;
        КонецЕсли;
    КонецЕсли;                             
    // конец проверки на проведение задним числом 
КонецФункции

Процедура ПриУдаленииДокумента(УдаляемыйДок, Режим)
    Если Режим = 1 Тогда
        // запрет на непосредственное удаление 
        Возврат;
    КонецЕсли;  
    Если ИмяПользователя()<>"Администратор" Тогда
        Если (ТекущаяДата() - УдаляемыйДок.ДатаДок) > Запрет Тогда
            СтатусВозврата(0);
            Предупреждение("Запрещено удалять документы (операции),"+РазделительСтрок+"введенные по "+Формат((ТекущаяДата() - Запрет),"ДДДММММГГГГ")+" !");
            Возврат;
        КонецЕсли;        
    КонецЕсли;
КонецПроцедуры


Процедура ПриОтменеПроведенияДокумента(Док)
    Если ИмяПользователя()<>"Администратор" Тогда
        Если (ТекущаяДата() - УдаляемыйДок.ДатаДок) > Запрет Тогда
            СтатусВозврата(0);
            Предупреждение("Запрещено удалять проведение документов (операций),"+РазделительСтрок+"введенных по "+Формат((ТекущаяДата() - Запрет),"ДДДММММГГГГ")+" !");
            Возврат;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. sournk 27 29.08.12 13:14 Сейчас в теме
'Если ИмяПользователя()<>"Администратор" Тогда' - это ужас!
Slypower; +1 Ответить
3. Иваныч 23 22.11.12 10:20 Сейчас в теме
Извиняюсь за задержку ответа.
В глобальном модуле дописана строка:
Константа.ДатаЗапретаРедактирования=ТекущаяДата()-1;

еще добавление:
Функция глПроверкаРазрешенияРедактирования(Конт) Экспорт

Конт.ПриЗаписиПерепроводить(1);
Если (Конт.Автор<>глПользователь)и(НазваниеНабораПрав()<>"Администратор") Тогда
Конт.Форма.ТолькоПросмотр(1);
Предупреждение("Вы не создавали этот документ, но можете просмотреть его!",4);
Возврат 0;
КонецЕсли;
это для того, чтобы пользователи (продавцы) на своих распределёнках не могли внести какие-либо изменения в чужой документ (например, ОтчетККМ)
5. Slypower 04.08.17 17:50 Сейчас в теме
Так проще проверять на администратора.

	НаборПрав = ВРег(НазваниеНабораПрав(1));
	Если (НаборПрав = "") Или (Найти(НаборПрав, "АДМИНИСТРАТОР") <> 0) Тогда
		Доступ = 1;
	Иначе
		Доступ = 0;
	КонецЕсли;


А далее передавать на проверку удаления и т.д.
2. Иваныч 23 09.11.12 21:18 Сейчас в теме
Я делал устанавливал запрет редактирования документов:( Текущая дата - 1 день.), всем пользователям на торговых точках поставил минимальные полномочия и исключил возможность нагадить в чужом документе "ОтчетККМ", т.н. "защита от глупости". Завтра постараюсь выложить куски кода с описанием, может кому и сгодится.
4. Umka23 10 04.08.17 11:30 Сейчас в теме
"В Справочнике Пользователи надо добавить Реквизит "ЗапрРед" (число) и добавить его в форму." (Число) в смысле (Дата)?
Оставьте свое сообщение

См. также

Дата запрета редактирования для каждого пользователя

Информационная безопасность v77::ОУ 1С7:ТиС Россия Бесплатно (free)

Данная обработка позволяет вместо общей даты запрета редактирования установить дату запрета редактирования для каждого пользователя.

23.07.2009    10916    0    Sn1cker5    10    

login имхо

Информационная безопасность v7.7 1cv7.md Россия Бесплатно (free)

Нередко сталкивался, когда нужно не мудрствуя лукаво защитить настройки внешней обработки от пользователя (или что еще подобное), Чтобы каждый раз не искать и копипастить коды - написал простенькую обработку для идентификации, хранения логинов и администрирования пользователей. Защита кшно чистое имхо, но "продвинутых пользователей" может остановить

18.06.2008    9382    0    nnn    4    

Расширенная настройка прав пользователей

Информационная безопасность v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free)

Расширенная настройка прав пользователей...управление правами из режима предприятия, права вступают в силу немедленно... ЧТО ОБНОВИЛОСЬ!!!! //10-06-2008 - переделано на классы //16-06-2008 - расширен функционал пробной версии, улучшена настройка прав //20-06-2008 отслеживание изменений набора прав и автоматическое перезаполнение новых прав для каждого активного пользователя и текущего набора прав настройка прав доступа для отчетов и для документов

18.06.2007    22167    0    skom    16    

Сравнение существующих наборов прав доступа

Информационная безопасность v7.7 1cv7.md Россия Бесплатно (free)

Обработка предназначена для сравнения наборов прав доступа существующих в информационной базе. Можно наглядно сравнить права доступа к документам и справочникам. Описание прав доступа строится на основании файла с описанием структуры метаданных, который формируется конфигуратором.

18.09.2006    16183    0    yu    18    

User Commander for v.7

Информационная безопасность v7.7 1cv7.md Россия Бесплатно (free)

Программа позволяет менять пароли пользователей информационных баз 1С:Предприятия 7.7. Помимо этого можно отслеживать работающих пользователей.

31.08.2006    16502    0    yu    39    

Если нельзя, но очень хочется - разрешаем администратору запрещенные действия.

Информационная безопасность v7.7 1cv7.md Россия Бесплатно (free)

Часто бывает: период закрыт, а документ НУЖНО исправить, или нет на остатке, но НУЖНО провести и т.п.. Пользователю с набором прав "Администратор" предоставится возможность сделать (или не сделать) это, с внесением записи о разрешенном действии в журнал регистрации.

30.06.2006    12622    0    antonrost    4    

Внешняя компонента "2-й пароль в 1с" pass2m.dll для конфигураций v 7.7.

Информационная безопасность v7.7 1cv7.md Россия Бесплатно (free)

Данная компонента реализует следующую политику безопасности паролей в 1с: - пользователь сам себе устанавливает пароль - пароль имеет определенный срок действия - по окончании срока действия пользователь сам себе меняет пароль. - если пользователь забыл пароль, то администратор может сбросить его пароль, после чего пользователь заведет себе новый пароль при следующем логине. Т.к. стандартный пароль в 1с 7.7 имеет ограниченный функционал, данная политика реализована с помощью второго пароля (Пароль №2), который появляется при логине вслед за стандартным. Сам пароль хранится в справочнике пользователей в зашифрованном виде.

20.03.2006    11073    0    mshapkin    7    

Шифратор 1С

Информационная безопасность v7.7 1cv7.md Россия Бесплатно (free)

Данная программа позволяет шифровать программный код 1С, который находится в отчетах и обработках. Обработка работает по следующим принципам: - идет переименование всех процедур и функций; - идет переименование всех переменных; - удаляется форматирование текста; - удаляются комментарии; - шифруются текстовые значения; - учитываются имена переменных и функций из глобального модуля; - учитываются имена переменных и функций, которые используются в таблице отчета.

27.01.2006    15622    0    victor    31