Пакетная печать документов

Публикация № 15307

Разработка - Печать - Пакетная печать

8
Список в одном окне, любого вида, только необходимо раз поменять конфигурацию.

Позволяет производить печать документов пакетно, то есть формы документов печатаются по очереди в одном окне за определенный период, ну критерии, в принципе, можно уже установить самому, главное сама мысля. 

Кроме того, что используешь обработку, нужно : 

1)В глобальном модуле создать глобальную переменную глТаб;

2)В процедуре документа ПриОткрытии() нужно прописать проверку

Если ТипЗначенияСтр(Форма.параметр) = "Строка" тогда 
Если Форма.Параметр = "Печать" тогда 
инд = 0;
Печать(Инд);
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецЕсли;


3)В процедуре Печать(Инд)

Если (Инд = 0) и (Форма.Параметр <> "Печать") тогда 
Таб = СоздатьОбъект("Таблица");
ИначеЕсли (Инд=0) и (Форма.Параметр = "Печать") тогда 
Таб = глТаб;
КонецЕсли;


а ниже, где идет вывод на печать, прописать:

Если (Инд = 0) и (Форма.Параметр <> "Печать") тогда 
Таб = Показать();
ИначеЕсли (Инд=0) и (Форма.Параметр = "Печать") тогда 
Таб.ПараметрыСтраницы(1,,,10,10,,,,,1,,);
Таб.НоваяСтраница();
КонецЕсли;


Ну и, в принципе, усе... зацените

8

Скачать файлы

Наименование Файл Версия Размер
-
.1196061888 20,50Kb
13.02.13
275
.1196061888 20,50Kb 275 Скачать бесплатно

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. MatveyIgor 23 26.11.07 13:18 Сейчас в теме
народ и что вы на счет этого думаете???
2. Звездочет 93 26.11.07 17:58 Сейчас в теме
Туфта!
Пакетная печать ценна только тогда, когда ничего в конфигурации менять не нужно, а еще есть выбор печатных форм (коих может быть несколько).
Предложенный тобой способ очевиден, но неудобен.
3. viacht 27.11.07 22:26 Сейчас в теме
Полностью поддерживаю Звездочёта!
4. spondg 29.11.07 09:36 Сейчас в теме
Сам отчет не видела, но когда касается крупного предприятия - это очень удобно.
5. nikolega 161 03.12.07 09:21 Сейчас в теме
Так в 8-ке есть групповая обработка документов .... Эта зачем ?
6. nikolega 161 03.12.07 09:21 Сейчас в теме
7. Skylark 66 03.12.07 09:44 Сейчас в теме
Это очень нужная вещь, сам делал такую для печати счетов, счетов-фактур и актов выполненных работ. Представьте, что у вас несколько сотен клиентов на абонентской плате за какие-либо услуги - до этой обработки специальная девочка сидела и каждый месяц целую неделю занималась только созданием и распечаткой этих документов в 1С.
Сделал так же грубо - добавлял код в модули документов, в процедуры ПриОткрытии и Печать. Периодически посещает мысль сделать все красиво, с использованием внешних печатных форм, чтобы можно было использовать без изменения конфигурации. Вот это действительно актуальная задача. Может у автора найдется энтузиазм для этого?
8. MatveyIgor 23 03.12.07 10:13 Сейчас в теме
Skylark спасибо, подумаю, просто думаю успею ли я следить за изменениями печатной формы... такое бывает у нас
9. vasis 3 22.05.08 15:22 Сейчас в теме
Встроил в универсальный журнал ..... доработал конфу и теперь и условие можно задавать и печатать
10. lemaxs 04.10.11 20:35 Сейчас в теме
11. mezonik 19.10.11 09:24 Сейчас в теме
Не очень удобно что-то менять в конфе
13. lemaxs 05.06.12 15:41 Сейчас в теме
Не работает с авансовыми отчетами на Предприятии и упрощенке
Оставьте свое сообщение

См. также

Печать внешних форм документов для 7.7 80

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v7.7 1cv7.md Россия БУ Бесплатно (free) Пакетная печать

Печать внешних форм документов за выбранный период. Для ТиС/Комплексной/Бухии

15.10.2009    24180    960    Ёпрст    95       

Пакетная печать документов 32

Отчеты и формы no Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Пакетная печать

Пакетная печать документов. Ограничение версии - печать только при помощи зарегистрированных внешних печатных форм

25.11.2008    15840    724    UrbSI    17       

Групповая обработка документов v1.0: копирование, печать, ввод на основании. 95

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Обработка документов Пакетная печать

Обработка будет полезна для тех организаций, где периодически повторяются одни и те же документы, с незначительными изменениями, в больших количествах. Обработка позволяет копировать (все конфигурации), вводить на основании (бух), печатать (бух) документы группой.

24.11.2006    20495    1226    svsrus    40       

Печать наклеек на конверты 20

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ БП2.0 Россия Бесплатно (free) Пакетная печать

Печать наклеек с адресами и индексами на почтовые конверты

20.10.2006    11061    224    Звездочет    8