IE2017

Пакетная печать документов

Печать - Пакетная печать

Список в одном окне, любого вида, только необходимо раз поменять конфигурацию.

Позволяет производить печать документов пакетно, то есть формы документов печатаются по очереди в одном окне за определенный период, ну критерии, в принципе, можно уже установить самому, главное сама мысля. 

Кроме того, что используешь обработку, нужно : 

1)В глобальном модуле создать глобальную переменную глТаб;

2)В процедуре документа ПриОткрытии() нужно прописать проверку

Если ТипЗначенияСтр(Форма.параметр) = "Строка" тогда 
Если Форма.Параметр = "Печать" тогда 
инд = 0;
Печать(Инд);
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецЕсли;


3)В процедуре Печать(Инд)

Если (Инд = 0) и (Форма.Параметр <> "Печать") тогда 
Таб = СоздатьОбъект("Таблица");
ИначеЕсли (Инд=0) и (Форма.Параметр = "Печать") тогда 
Таб = глТаб;
КонецЕсли;


а ниже, где идет вывод на печать, прописать:

Если (Инд = 0) и (Форма.Параметр <> "Печать") тогда 
Таб = Показать();
ИначеЕсли (Инд=0) и (Форма.Параметр = "Печать") тогда 
Таб.ПараметрыСтраницы(1,,,10,10,,,,,1,,);
Таб.НоваяСтраница();
КонецЕсли;


Ну и, в принципе, усе... зацените

Скачать файлы

Наименование Файл Версия Размер
-
.1196061888 20,50Kb
13.02.13
262
.1196061888 20,50Kb 262 Скачать бесплатно

См. также

Комментарии
1. Igor (MatveyIgor) 23 26.11.07 13:18 Сейчас в теме
народ и что вы на счет этого думаете???
2. Старостин Николай (Звездочет) 92 26.11.07 17:58 Сейчас в теме
Туфта!
Пакетная печать ценна только тогда, когда ничего в конфигурации менять не нужно, а еще есть выбор печатных форм (коих может быть несколько).
Предложенный тобой способ очевиден, но неудобен.
3. Viacht (viacht) 27.11.07 22:26 Сейчас в теме
Полностью поддерживаю Звездочёта!
4. Ирина (spondg) 29.11.07 09:36 Сейчас в теме
Сам отчет не видела, но когда касается крупного предприятия - это очень удобно.
5. Олег Никоноров (nikolega) 147 03.12.07 09:21 Сейчас в теме
Так в 8-ке есть групповая обработка документов .... Эта зачем ?
6. Олег Никоноров (nikolega) 147 03.12.07 09:21 Сейчас в теме
7. Владимир (Skylark) 66 03.12.07 09:44 Сейчас в теме
Это очень нужная вещь, сам делал такую для печати счетов, счетов-фактур и актов выполненных работ. Представьте, что у вас несколько сотен клиентов на абонентской плате за какие-либо услуги - до этой обработки специальная девочка сидела и каждый месяц целую неделю занималась только созданием и распечаткой этих документов в 1С.
Сделал так же грубо - добавлял код в модули документов, в процедуры ПриОткрытии и Печать. Периодически посещает мысль сделать все красиво, с использованием внешних печатных форм, чтобы можно было использовать без изменения конфигурации. Вот это действительно актуальная задача. Может у автора найдется энтузиазм для этого?
8. Igor (MatveyIgor) 23 03.12.07 10:13 Сейчас в теме
Skylark спасибо, подумаю, просто думаю успею ли я следить за изменениями печатной формы... такое бывает у нас
9. Vas (vasis) 22.05.08 15:22 Сейчас в теме
Встроил в универсальный журнал ..... доработал конфу и теперь и условие можно задавать и печатать
10. lemaxs (lemaxs) 04.10.11 20:35 Сейчас в теме
11. mezonik (mezonik) 19.10.11 09:24 Сейчас в теме
Не очень удобно что-то менять в конфе
13. lemaxs (lemaxs) 05.06.12 15:41 Сейчас в теме
Не работает с авансовыми отчетами на Предприятии и упрощенке
Оставьте свое сообщение