Интеграция с API WIldberries. Что нового в 2022 во взаимодействии 1С и Вайлдберриз

Публикация № 1581395 09.01.22

Интеграция и обмен данными - Маркетплейсы

интеграция вайлдберриз wildberries api маркетплейс

Демонстрация взаимодействия системы учета на 1С и АПИ Вайлдберриз. Готовое решение, которое можно доработать под ваши запросы. Новая версия API 1.0.2, расскажу, как получить supplierID, как создать карточки товара на вайлдберриз, как получить остатки и задать цены.

Всем привет!

Прошлую статью по интеграции с Wildberries я писал в конце 2020 и с тех пор многое поменялось. Работа с API стала чуть проще, однако нюансы взаимодействия с Вайлдберриз никуда не делись. В этой статье я покажу как взаимодействовать с АПИ из 1С и представленную мной обработку можно взять за пример и доработать. 

Если вы предприниматель и продавец на Wildberries: в конце статьи есть возможность скачать обработку (платформа 8.3.14 , 8.3.8). В ней есть лишь несколько базовых функций (получение остатков, получение и обновление цен, создание карточки товара и получение списка карточек уже созданных). Для доработки остальных функций можно отдать обработку вашему программисту или написать мне в телеграм, поискав меня по имени.

Если вы программист: Здравствуйте, коллега! В статье расскажу некоторые нюансы схемы данных у WB и дам примеры кода. У Вайлдберриз теперь есть для тестирования запросов Swagger, и по сути главное для интеграции правильно сформировать JSON на стороне 1С. Но будьте аккуратны, тестовой среды больше нет и все запросы сразу попадают в продакшн и в ЛК вашего Заказчика. Не забудьте поставить плюсик статье!

 

1. Получение токена АПИ и supplierId для запросов.

Токен для АПИ получить легко. В разделе "настройки" в ЛК есть вкладка "доступ к новому API" где этот токен и получается. Токен нужно передавать в каждом запросе в HTTP заголовке Authorization

 

 

Как получить supplierId в личном кабинете Wildberries

Проще всего для этого в ЛК открыть список ваших юрлиц в правом верхнем углу (там где в меню Профиль и Настройки), кликнуть правой кнопкой мыши и нажать "просмотреть код" в Chrome.

 

 

Там сразу в HTML коде видна метка "FOR" где прописан ваш идентификатор supplierID. 

 

 

Еще можно написать запрос в поддержку, с просьбой отправить вам supplierID, но они долго отвечают.

Этот самый идентификатор нужен для многих запросов к АПИ, хотя некоторые запросы и без него работают - видимо, есть связь между Токеном доступа к АПИ и supplierID. 

 

2.  Получение списка существующих карточек

 

Чаще всего бывает так, что карточки товара уже созданы вручную или загружены из Ексель, и их надо получить на стороне 1С. Делаем для этого запрос "/card/list" к АПИ. Важно убрать все из параметра filter и поставить limit побольше. Впрочем, я в обработке сделал пример где limit 100 и получение идет в цикле, увеличивая offset. Вот код в функции СписокКарточекВБ:

&НаКлиенте
Функция СобратьЗапросКарточек(Лимит,ОФсет)
	СтруктураЗ = Новый Структура;
	СтруктураЗ.Вставить("id",1);
	СтруктураЗ.Вставить("jsonrpc","2.0");
	СтрПарам = Новый Структура;//Params
	СтрФильтра = Новый Структура;
	СтрФильтра.Вставить("filter",Новый Массив);
	СтрФильтра.Вставить("find",Новый Массив);
	СтрОрдер = Новый Структура;
	СтрОрдер.Вставить("column","");
	СтрОрдер.Вставить("order","");
	
	СтрФильтра.Вставить("order",СтрОрдер);
	
	СтрПарам.Вставить("filter",СтрФильтра);
	
	СтрЗапроса = Новый Структура;
	СтрЗапроса.Вставить("limit",Лимит);//max 100
	СтрЗапроса.Вставить("offset",ОФсет);
	СтрПарам.Вставить("query",СтрЗапроса);
	СтрПарам.Вставить("isArchive", ЛОЖЬ);
	СтрПарам.Вставить("supplierID",Объект.supplierID);
	СтрПарам.Вставить("withError", ЛОЖЬ);
	
	СтруктураЗ.Вставить("params",СтрПарам);
	
	Возврат СтруктураЗ;
КонецФункции

&НаКлиенте
Процедура СписокКарточекВБ(Команда)
	СтруктураЗ = СобратьЗапросКарточек(100,0);
	//json
	СериализованнаяСтрока = СтруктураВJson(СтруктураЗ);
	
	ЖсонОтправка = СериализованнаяСтрока;
	
	Адрес = "/card/list";
	СоответствиеОтветАПИ = ВыполнитьМетодАПИ(СериализованнаяСтрока,Адрес,"POST");
	Если НЕ СоответствиеОтветАПИ=Неопределено Тогда
		
		Рез = СоответствиеОтветАПИ.получить("result");
		Курсор = Рез.Получить("cursor");
		
		ВсегоНоменклатурыУВБ = Курсор.Получить("total");
		
		ВыданоСейчас = Курсор.Получить("limit");
		Смещение = Курсор.Получить("offset");
		
		КартыМассив = Рез.Получить("cards");
		сообщить("найдено артикулов="+ВыданоСейчас+ " шаг=0");
		//СОПОСТАВИТЬ с 1С
		СопоставитьНом1С(КартыМассив);
		Лимит = 100;
		счШага = 1;
		Пока ВсегоНоменклатурыУВБ > ВыданоСейчас + Смещение Цикл
			Смещение = Смещение+100;
			счШага = счШага + 1;
			//получим остальные страницы
			Если ВсегоНоменклатурыУВБ - Смещение < 100 Тогда
				СтруктураЗ = СобратьЗапросКарточек(ВсегоНоменклатурыУВБ - Смещение,Смещение);
			Иначе
				СтруктураЗ = СобратьЗапросКарточек(100,Смещение);
			КонецЕсли;
			СоответствиеОтветАПИ = ВыполнитьМетодАПИ(СериализованнаяСтрока,Адрес,"POST");
			Если НЕ СоответствиеОтветАПИ=Неопределено Тогда
				
				Рез = СоответствиеОтветАПИ.получить("result");
				Курсор = Рез.Получить("cursor");
				
				ВыданоСейчас = Курсор.Получить("limit");
				Смещение = Курсор.Получить("offset");
				КартыМассив = Рез.Получить("cards");
				//СОПОСТАВИТЬ с 1С
				СопоставитьНом1С(КартыМассив);
				
			Иначе
				Сообщить("Неверный код ответа card/list");
				
			КонецЕсли;
			сообщить("найдено артикулов="+ВыданоСейчас+ " шаг="+счШага);
		КонецЦикла;
		
	Иначе
		Сообщить("Неверный код ответа card/list");
		//ПоказатьПредупреждение(, "Ошибка соединения с Wildberries");
		Возврат;
	КонецЕсли;
	
	
КонецПроцедуры

 

На вкладке "служебное" всегда можно посмотреть отправленный и полученный текст JSON 

 

 

3. Сопоставление данных Вайлдберриз и 1С. Нюансы схемы данных.

У Wildberries есть следующие сущности: Карточка (Card) и ее идентификатор imtId и supplierVendorCode (Артикул Поставщика), Номенклатура (массив nomenclatures в карточке) и ее идентификатор nmId и vendorCode (Артикул Цвета). 
Еще у Карточки есть дополнения (addin) где указывается Бренд и ТНВЭД. 
А у Номенклатуры есть variations где указывается Размер (идентификатор chrtId) и его Штрихкоды (barcodes). Внутри variations есть еще addin где указывается цена товара (целое число без копеек). 

Для примера рассмотрим поиск по штрихкоду, а затем если не нашли, по артикулу номенклатуры (vendorCode) в базе 1С. Вот код:

&НаСервере
Процедура СопоставитьНом1С(КартыМассив)
	счч=0;
	Для Каждого КартаСоотв Из КартыМассив Цикл
		//ид карты, в карте может быть несколько номенклатур
		мИдВБ = КартаСоотв.Получить("imtId");//не используется далее
		Номенклатуры =  КартаСоотв.Получить("nomenclatures");//массив, в массиве соответствия
		Для Каждого СоотвНом ИЗ Номенклатуры Цикл
			//нужно для обмена остатками
			nmId = СоотвНом.Получить("nmId");//ид конкретной номенклатуры
			Артикул1С = СоотвНом.Получить("vendorCode");//артикул конкретной номенклатуры
			//размеры
			//у номенклатуры может быть несколько variations с разными ид chrtId
			Вариации = СоотвНом.Получить("variations");
			стрРазмеров="";//запишем через точку с запятой размеры
			НайденоПОШК = Ложь; 
			Для Каждого СоотвВар Из Вариации Цикл
				Баркод = СоотвВар.Получить("barcode");
				Если Баркод=Неопределено Тогда
					массивШК = СоотвВар.Получить("barcodes");
					Для Каждого шк из массивШК Цикл
						Баркод = шк;
					КонецЦикла;					
				КонецЕсли;	
				chrtId = СоотвВар.Получить("chrtId");//число
				ЭддИны = СоотвВар.Получить("addin");
				//Размер = Эддины.Получить(1).Получить("params").Получить(0).Получить("value");
				//chrtid = СтрЗаменить(Строка(chrtId)," ","") + "_" + СокрЛП(Размер);
				стрРазмеров = стрРазмеров + Строка(chrtId) + ";" ;
				//поищем номенклатуру по ШК
				Если НЕ ПустаяСтрока(Баркод) Тогда
					Номенклатура1С = ПоискПоШК(Баркод); 
				КонецЕсли;
			КонецЦикла;
			
			Если НайденоПОШК = Ложь Тогда
				//поищем номенклатуру
				Номенклатура1С = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул",Артикул1С);
			КонецЕсли;
			
			
			Если НЕ Номенклатура1С.Пустая() Тогда
				//запишем доп свойства
				
				//ЗаписатьДопСвойство(Номенклатура1С,"wb_chrtid",стрРазмеров);
				ЗаписатьДопСвойство(Номенклатура1С,"wb_nmid",nmId);
				счн=счн+1;
			Иначе
				Сообщить("артикул не найден <"+Артикул1С+">");
			КонецЕсли;
			
		КонецЦикла;				
		счч = счч+1;
		
	КонецЦикла;
	Сообщить("Обработано Карт "+счч);
КонецПроцедуры

Функция ПоискПОШК(Баркод)
	//{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
	// Данный фрагмент построен конструктором.
	// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ШтрихкодыНоменклатуры.Штрихкод КАК Штрихкод,
	|	ШтрихкодыНоменклатуры.Номенклатура КАК Номенклатура,
	|	ШтрихкодыНоменклатуры.Характеристика КАК Характеристика,
	|	ШтрихкодыНоменклатуры.Упаковка КАК Упаковка
	|ИЗ
	|	РегистрСведений.ШтрихкодыНоменклатуры КАК ШтрихкодыНоменклатуры
	|ГДЕ
	|	ШтрихкодыНоменклатуры.Штрихкод = &Штрихкод";
	
	Запрос.УстановитьПараметр("Штрихкод", Баркод);
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		Возврат ВыборкаДетальныеЗаписи.Номенклатура; 
	КонецЦикла;
	
	//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
	Возврат Справочники.Номенклатура.ПустаяСсылка();
КонецФункции

Запишем идентификаторы nmId в регистр Дополнительные сведения, чтобы связать с номенклатурой 1С. Вот код:

&НаСервере
Процедура ЗаписатьДопСвойство(НоменклатураСсылка,ИмяСвойства,ЗначениеСвойства)
	ПВХСвойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию(ИмяСвойства,Истина);
	Если ПВХСвойство.Пустая() Тогда
		ПВХ = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.СоздатьЭлемент();
		ПВХ.Наименование = ИмяСвойства;
		ПВХ.Заголовок = ИмяСвойства;
		ПВХ.ТипЗначения = Типзнч(ЗначениеСвойства);
		ПВХ.Записать();
		ПВХСвойство = ПВХ.Ссылка;
	КонецЕсли;
	Набор = РегистрыСведений.ДополнительныеСведения.СоздатьМенеджерЗаписи();
	Набор.Период = ТекущаяДата();
	Набор.Объект = НоменклатураСсылка;
	Набор.Свойство = ПВХСвойство;
	Набор.Значение = ЗначениеСвойства;
	Набор.Записать(Истина);
	
КонецПроцедуры

 

Для более глубокой доработки механизма поиска Номенклатуры в 1С можно скачать обработку и дорабатывать как вам угодно.

 

4. Получение цен

 

 

Делаем GET Запрос на ресурс АПИ "/public/api/v1/info?quantity=0". В запросе нам возвращаются идентификаторы номенклатуры nmId, поэтому важно на шаге 3 понять как эти nmId сопоставлены с вашей базой 1С. Я в своей обработке предположил, что сначала получаются Карточки, и поэтому делаю поиск по табличке которая там есть. Цены беру в регистре ЦеныНоменклатуры. Поля discount и promoCode я не использую в расчете, просто храню и отображаю их в таблице в обработке.

 

 

5.  Изменение цен

Для примера я взял УТ 11 на платформе 8.3.18, где цены лежат в регистре ЦеныНоменклатуры. Для своей конфигурации можно модифицировать запрос цен нужным образом. Отправляется POST запрос на ресурс "/public/api/v1/prices". Из таблички на форме отправляю те строки, где есть цена 1С и стоит галочка "Обновить цену". Чтобы не отправлять HTTP запрос по каждой строке с ценами, собираю в JSON запрос массив номенклатур. 

 

 

Пример кода:

&НаСервере
Процедура ЗадатьЦеныИз1СНаСервере()
	//задаем цены в ВБ из 1С - Таблички на форме
	Адрес = "/public/api/v1/prices";
	МассивЗапроса = Новый Массив;
	Для Каждого СтрТ из Объект.Товары Цикл
		Если СтрТ.ОбновитьЦену Тогда
			СтруктураЦены = Новый Структура;
			СтруктураЦены.Вставить("nmId",СтрТ.nmID);//число!
			СтруктураЦены.Вставить("price",СтрТ.Цена1С);
		КонецЕсли;
	КонецЦикла;
	
	Жсон = СтруктураВJson(МассивЗапроса);
	ОтветАПИ = ВыполнитьМетодАПИ(Жсон,Адрес,"POST");
	
КонецПроцедуры

 

6. Получение и обновление остатков

Для получения остатков - делаем GET Запрос на ресурс АПИ "/api/v2/stocks?skip=0&take=1000". Кстати, по примеру видно что программисты в Вайлдберриз фанаты Властелина колец. Их пример:

 

 

Для обновления же остатков нужен POST запрос на ресурс "/api/v2/stocks" и там еще надо знать warehouseId. Где же его взять? Только из предыдущего запроса по получению остатков, либо сделать GET запрос к АПИ "/api/v2/warehouses". 

 

 

7. Получение списка заказов

Делаем GET Запрос на ресурс АПИ "/api/v2/orders?date_start=2022-01-01T13:00:00Z&status=2&take=10&skip=0". Тут главное форматировать дату по RFC3339 в формате "yyyy-MM-ddTHH:mm:ssZ". Пример, который должен получиться из ответа АПИ:

 

 

Для обработки 1С я предполагаю, что структура заказа такая же, как в примере у Вайлдберриз. Нюанс обработки заказов в том, что Вайлдберриз выдают очередные левые идентификаторы в описании OrdersAPIResponse вместо привычного уже идентификатора номенклатуры nmID выдают идентификатор размера chrtId, ну и штрихкод тоже есть.

Как реализовать поиск в 1С заказов по данным штрихкода и chrtId оставляю на ваше усмотрение. Лично я решил в процессе получения карточек (вкладка 2 Карточки ВБ) записывать для Номенклатуры все ее ид размеров chrtId в регистр ДопСведений. И, таким образом, есть сопоставление chrtId и Номенклатуры 1С. Можно еще искать по Штрихкоду в регистре штрихкодов, но у ВБ могут быть свои штрихкоды, отличные от 1С.

 

Скриншоты интерфейса обработки:

По просьбам в комментариях добавил скриншоты интерфейса обработки.

8. Остальные функции

Думаю, что вышеприведенных примеров достаточно, чтобы дальше доработать остальное самостоятельно. Если есть вопросы, можно написать мне в телеграм, поискав меня по имени. Не забудьте поставить плюсик статье!

Также в конце статьи приведу список ошибок АПИ, с которыми я сталкивался в процессе тестирования, для того чтобы их могли найти в поисковике и прочитать эту статью. Обычно эти ошибки были следствием некорректного JSON, хотя иногда я был уверен что и баги в АПИ тоже есть.

Ошибки:

list of cards: (BadValue) $and must be an array 

Следующие комбинации характеристик \"Артикул поставщика\" и \"Бренд\" уже используются

validation error, errorValidation

failed get card by imt id: unexpected end of JSON input cause: map[Внутренняя ошибка:None] card.cardByImtID

Характеристика: tech_size. Ошибка: Артикул с таким размером уже создан! Удалите позицию из спецификации и загрузите на нее баркод в разделе Загрузки - Загрузки баркодов

update card cause: map[err:get origin card: Internal Server Error]

Следующие комбинации характеристик \"Артикул поставщика\", \"Артикул цвета\" и \"Бренд\" уже используются

batch create error cause: map[err:Нет карточек для добавления. Карточки товара с штрихкодом уже созданы

Такая комбинация бренда  и артикула поставщика уже используется

Характеристика: sa_nm. Ошибка: Артикул принадлежит другому поставщику

Ошибка: Артикул удален

Категория из выбранной карточки товара запрещена к реализации, возможность работать с такой карточка закрыта

Удаление номенклатуры невозможно, ввиду наличия поставок по ней

Благодарю за прочтение! 

Скачать файлы

Наименование Файл Версия Размер
Интеграция с API WIldberries. Что нового в 2022 во взаимодействии 1С и Вайлдберриз.:

.epf 23,90Kb
104
.epf 23,90Kb 104 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. sher_70 12.01.22 12:07 Сейчас в теме
Прошу уточнить, можно ли использовать вашу обработку для БУХ и УНФ последние версии для получения по АПИ актов того что было принято из товаров на Вайлдберриз и Озон?
3. kiv1c 776 12.01.22 12:16 Сейчас в теме
(1) конкретно в этой реализации нет, обработку получения актов (кажется в АПИ это получение списка поставок называется) здесь я не делал. нужна доработка.
5. sher_70 12.01.22 12:31 Сейчас в теме
Сможете сделать, сколько будет стоить и как долго ждать?
2. maks_20 157 12.01.22 12:15 Сейчас в теме
По поводу п.7 Получение списка заказов - в данном возвращаемом пакете отсутствуют сведения по количеству, цене, есть только поле totalPrice - общая сумма заказа. Каким образом получить цену и количество каждой номенклатуры в заказе?
4. kiv1c 776 12.01.22 12:20 Сейчас в теме
(2) а это уже ограничения АПИ со стороны ВБ. судя по их описанию метода "/api/v2/orders - Метод возвращает список сборочных заданий поставщика." там нет списка номенклатур и цен, только totalPrice.

с другой стороны стоит проверить на практике, возможно что для каждого ИД размера chrtId создается свой заказ.
6. maks_20 157 12.01.22 13:57 Сейчас в теме
(4) номенклатура есть, точнее массив ее штрихкодов. А вообще техподдержка вайлдберис оставляет желать лучшего. Мне они месяц уже не могут ответить на вопросы (в том числе и этот). С озоном в этом плане гораздо приятнее работать, там и api понятный и тестовая площадка есть и техподдержка отвечает максимум минут 30.
7. Maksim7487 13.01.22 12:25 Сейчас в теме
Спасибо. Думаю это мне поможет, как раз сейчас впервые делаю интеграцию с ягодами. Было бы не плохо если бы они расписали подробнее что означает каждый параметр в ответе на запрос, как это сделано в руководстве по работе с сервисом статистики. Пока приходится догадываться.
8. kiv1c 776 13.01.22 20:43 Сейчас в теме
(7) хахаха, расписали каждый параметр. щаз. самое плохо документированное АПИ за всю мою жизнь. догадывайтесь интуитивно:)
9. пользователь 18.01.22 19:18
Сообщение было скрыто модератором.
...
10. пользователь 20.01.22 09:22
Сообщение было скрыто модератором.
...
11. suma 24.01.22 02:50 Сейчас в теме
Здравствуйте. Есть ли наработки по внесению изменений в карточку,например поменять цвет, размер, заголовок (название)? Добавьте пожалуйста больше фото интерфейса обработки, если он там вообще есть).
12. kiv1c 776 24.01.22 15:27 Сейчас в теме
(11) такие возможности через АПИ есть. фото интерфейса добавлю, спасибо.
13. suma 25.01.22 17:43 Сейчас в теме
(12) Да, но как я понял в данном примере не представлено. К сожалению у меня самостоятельно не хватает знаний реализовать. Если у вас есть время, можете за доп. вознаграждение что-то такое воспроизвести? Именно интересует редактирование карточки (редактирование названия (заголовка) карточки, смена основного цвета.
14. info6 04.02.22 11:16 Сейчас в теме
Иван, добрый день, мне необходим базовый API из 1С по выгрузке карточек товаров (не для WB). Сколько будет стоить данная обработка?
15. kiv1c 776 05.02.22 15:20 Сейчас в теме
(14) а для какого маркетплейса?
16. user1745249 16.02.22 08:27 Сейчас в теме
Добрый день, при отправке документов вайлдберис по эдо они отклоняют с текстом - не найдено в ерп сопоставление по товару по всем проверкам, что это может быть?
31. unknown181538 111 28.06.22 13:58 Сейчас в теме
(16) вы смогли понять, в чем проблема?
17. ndacoder 110 04.03.22 11:50 Сейчас в теме
Добрый день а как стыкуются данные по заказам (/api/v2/orders ) со старым api v1 сервер статистики
18. kiv1c 776 05.03.22 12:49 Сейчас в теме
(17) расшифруйте вопрос подробнее, сервер статистики для чего вам нужен?
19. ndacoder 110 05.03.22 12:51 Сейчас в теме
(18) Добры день нужно получить затраты на логистику, желательно позаказно
20. kiv1c 776 08.03.22 15:10 Сейчас в теме
(19) а где вы видели у Вайлдберриз такой функционал? это вопрос к учету затрат в 1С.
21. simuljakr 198 15.03.22 18:09 Сейчас в теме
Здравствуйте.

Есть ли в вашей обработке возможность создания новых карточек товара в WB, на базе карточек номенклатуры из 1С?
Как решается проблема "выпадающих списков" - когда у разных карточек номенклатуры есть разные свойства, и эти свойства задаются не текстом, а "выпадающим списком" ?
22. Korotkiy 01.04.22 09:15 Сейчас в теме
В прилагаемой обработке ошибка, в процедуре ЗадатьОстатокИз1СНаСервере() задублирован код процедуры установки цен.
23. kiv1c 776 01.04.22 09:56 Сейчас в теме
(22) возможно, но код открыт и это можно исправлять
24. Korotkiy 01.04.22 10:48 Сейчас в теме
(23) Хотел посмотреть именно структуру передаваемую в POST /api/v2/stocks для обновления остатков
26. kiv1c 776 04.04.22 11:22 Сейчас в теме
(24) так структура у WB описана. там нужен баркод, ИД склада, и остаток

https://suppliers-api.wildberries.ru/swagger/index.html#/Marketplace/post_api_v2_stocks

а список складов можно получить запросом на /api/v2/warehouses
25. tps_01 57 01.04.22 16:32 Сейчас в теме
(23) Сможете прислать в личку обработку, когда поправите команду "Задать остаток из 1С"?
Скачивал 31/03. Если я правильно понял, то там не исправить придется, а разработать.
27. Drizer2000 14 27.04.22 20:41 Сейчас в теме
А как вы отслеживаете возвраты от клиента, которые вернулись на склад wildberries?
user1781390; +1 Ответить
28. Alexmtx 01.06.22 12:15 Сейчас в теме
Ключ для работы с API статистики x32 или x64 использовать, в чем разница?
29. Jestery 15.06.22 13:17 Сейчас в теме
Непонятен один момент - можно ли и как загрузить картинки в wildberies через api. В статье к сожалению нет примеров насчет этого.
30. kiv1c 776 15.06.22 17:35 Сейчас в теме
(29) ничего такого про загрузку картинок в карточки в описании АПИ у них нет.
37. fatman78 8 27.07.22 12:23 Сейчас в теме
(29) Вот здесь механизм взаимодействия API, в том числе и по загрузке фотографий описан Интеграция с API WB (Wildberries). Создание карточки товара (спецификации)
32. alexusiv 28.06.22 17:30 Сейчас в теме
Добрый день! Подскажите что за ошибка /card/update "Категория из выбранной карточки товара запрещена к реализации, возможность работать с такой карточка закрыта"
33. rennerv 30.06.22 06:18 Сейчас в теме
Доброго времени суток, скачал Вашу обработку... безусловно подошла, пришлось дорабатывать в своих интересах под Розницу.
С запросом по получению остатков вопроса нет, код отработать 5 мин, но вот остался такой вопрос, пользователь создает карту товара на WB в личном кабинете, 1С опросила WB подгрузила себе ихний imid, barcode, chrtId, id склада и при попытке обновить остаток обработка записывает остатки но как бы на те карты по которым было движение, а на вновь созданные не пишет остатки, если пользователь загрузит остатки с ихнего файла barcode количество xls, затем обновит с 1С обработкой товар сразу обновляется... не подскажите в чем может быть проблема?
34. пользователь 30.06.22 15:37
Сообщение было скрыто модератором.
...
35. user1818296 21.07.22 10:49 Сейчас в теме
Доброго времени суток! Как можно получить более актуальную версию обработки? И возможно ли лично напрямую взять её у вас?
36. user1818296 21.07.22 15:48 Сейчас в теме
(30) Доброго времени суток! Как можно получить более актуальную версию обработки? И возможно ли лично напрямую взять её у вас?
38. Hiden86 03.08.22 09:57 Сейчас в теме
Доброго времени суток. Приобрели обработку, есть несколько вопросов, подскажите как их можно задать разработчику.
39. Hiden86 03.08.22 12:46 Сейчас в теме
(38) Вопросы сняты, разобрались.
40. coollerinc 169 15.08.22 13:13 Сейчас в теме
Не знаете, почему запрос отрабатывает, но товары не получаются по апи? Товары создал неделю назад, просто завел карточки. но на остатках.

ИД специально измели в сообщении

Запрос:
{
"id": 1,
"jsonrpc": "2.0",
"params": {
"filter": {
"filter": [],
"find": [],
"order": {
"column": "",
"order": ""
}
},
"query": {
"limit": 100,
"offset": 0
},
"isArchive": false,
"supplierID": "111111111111111111111",
"withError": false
}
}
Ответ:
{"id":1,"jsonrpc":"2.0","result":{"cards":[],"cursor":{"total":0,"limit":100,"offset":0}}}
41. coollerinc 169 15.08.22 18:20 Сейчас в теме
(40)
withError
Сам себе отвечу, т.к. этот метод не работает у тех у кого новый интерфейс(Карточка товара New).
43. SeverBaP 4 19.08.22 12:00 Сейчас в теме
(41) Эти ушлепки в wildberies, до сих пор не могут предоставить новую версию API для работы с новыми карточками товаров. Это началось почти с начала лета, встала работа.
45. coollerinc 169 19.08.22 17:06 Сейчас в теме
(43)Вообще у них даже личный кабинет, ужасный и багованный. Я был о них лучшего мнения)
42. ok_sunny 18.08.22 11:14 Сейчас в теме
Добрый день, интересует есть ли возможность создание обработки для получения всех документов по API от WB для КА 2.5
Акты приемки
Заказы
Утилизация
Отчет по продажам
44. kiv1c 776 19.08.22 12:43 Сейчас в теме
(42) нет у них очень тупое АПИ и таких документов там нет.
46. SanyMaga 66 08.09.22 12:35 Сейчас в теме
Как зная штрихкоды в ордере получить артикулы поставщика. Может кому пригодиться


Процедура ОбработатьАртикулыТовараВБ(ФильтрНоменклатуры,  МассивАртиклей)

	//СписокТоваровPOST = Новый HTTPЗапрос("/card/list", Заголовки);  далее пост запрос с сериализацией в json "ФильтрНоменклатуры"

	ДанныеЗапроса = ВыполнитьЗапрос(HTTPДанные, СписокТоваровPOST, "POST", , ФильтрНоменклатуры);


	Если ДанныеЗапроса <> Неопределено Тогда // результат список карточек
		
		Для Каждого Карта Из ДанныеЗапроса.result.cards Цикл   
			
			МассивАртиклей.Добавить( Карта.nomenclatures[0].vendorCode);
			
			
		КонецЦикла;	
		
	КонецЕсли;
	
КонецПроцедуры	


Процедура ЗапонитьАртикулыПоШКWB(ШтрихКоды)
	
		МассивАртиклей = Новый Массив; 

		// создание фильта
		ШтрихкодаВХ = Новый Массив; 
		ШтрихкодаОтбор = Новый Массив; 
		ШтрихкодаОтбор.Добавить(Новый Структура("column,search", "nomenclatures.variations.barcode", ШтрихкодаВХ));
		
		ФильтрНоменклатуры = Новый Структура("jsonrpc,params", "2.0", Новый Структура("filter", Новый Структура("find",  ШтрихкодаОтбор)));
		
		Для Каждого ШтрихКод Из ШтрихКоды Цикл // Добавляем в фильтр наши штрих коды
			
			Если ШтрихкодаВХ.Количество() = 10 Тогда 
				ОбработатьАртикулыТовараВБ(ФильтрНоменклатуры , МассивАртиклей );// заполняем массив артиклей по фильтру
				ШтрихкодаВХ.Очистить();
			Иначе 
				ШтрихкодаВХ.Добавить(ШтрихКод.Ключ);
			КонецЕсли;	
			
		КонецЦикла;	
		
		Если ШтрихкодаВХ.Количество() > 0 Тогда 
			ОбработатьАртикулыТовараВБ(ФильтрНоменклатуры, МассивАртиклей );
		КонецЕсли;	
		
		
КонецПроцедуры		


Показать
47. user1409821 12.09.22 10:27 Сейчас в теме
Добрый день! При попытке воспользоваться обработкой, выходит сообщение -
"Значение не является значением объектного типа (Получить)
{ВнешняяОбработка.АпиВайлдберриз2022.Форма.Форма.Форма(466)}: Курсор = Рез.Получить("cursor");"

Подскажите пожалуйста, что нужно поправить?
48. igor_nat 28.09.22 15:12 Сейчас в теме
Подскажите как правильно называется ключ и куда вносится supplierID в заголовки, в ключи, или другое. у меня постоянно пишет ошибку. (api-new) supplier key not found
49. virgor 29.09.22 13:58 Сейчас в теме
Здравствуйте Иван, подскажите пожалуйста, как купить обработку за деньги?
Интересует рабочий метод /card​/list для КА2.4
50. klaus38 01.10.22 09:33 Сейчас в теме
ТП WB "Здравствуйте. Card-методы отменены. Описание АPI для «Карточка товара NEW» опубликовано: https://seller.wildberries.ru/news?id=2572"
51. user1246775 05.10.22 17:48 Сейчас в теме
Здравствуйте, работает на УТ 11.5.9.94?
52. user785225 17 12.10.22 17:00 Сейчас в теме
👋 не удается получить Склады продаж через API v1,v2. Отблагодарю 5ю SM за верный совет

- за один и тот же период загружаю отчет комиссионера чз API и детальный отчет в формате эксель из ЛК
- Получаю недельный отчет методом reportDetailByPeriod , к нему слева присоединяю заказы методом orders, но складов FBS (таких 2) в колонке StoreId - только 109 из 2108, в остальных строках просто не заполнен StoreId
- Скачиваю тот же отчет из ЛК - все склады заполнены, складов FBS 1399 из 2107 в колонке Склады (в основном FBS, есть и FBO), все остальыне - заполнены складами FBO
- Примечательно что в экселе - 2107 строк, а чз API - 2108

ЧЯДНТ?
хотим вести учет в разрезе 2 складов, отчет из ЛК их выдает (см.рис), а отчет чз API - нет
Прикрепленные файлы:
54. user785225 17 28.12.22 12:50 Сейчас в теме
(52) стало возможным при соединении reportDetailByPeriod (v1) и orders (v3) левым соединением по srid (а если не заполнен, то по rid).

ps: осторожно, склады м.б. перепутаны местами на сайте (или в api warehouses)
53. user1704976 28.12.22 11:41 Сейчас в теме
добрый день! А есть ли интеграция между ВБ и 1С по новой версии API?
И вопрос, у нас сейчас работает интеграция по старой версии, если я получу новый токен будет ли работать старая версия v2 и одновременно писать по новой версии??)))
Если кто писал по новой версии откликнитесь!)))
Оставьте свое сообщение

См. также

Загрузка товаров с Яндекс.Маркет Промо

Обработка справочников Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Абонемент ($m) Абонемент ($m)

Обработка предназначена для загрузки товаров (их описаний, свойств, изображений) с торговой площадки Яндекс.Маркет в базу Управление Торговлей 11. В отличие от других подобных обработок Вам самим не придется парсить страницы Яндекс.Маркет и решать сопутствующие этому процессу проблемы (бан, капча, поиск прокси-серверов, длительное ожидание результатов при больших объемах данных), так как все данные уже загружены на наш сервер и готовы для использования. Обновление данных осуществляется раз в месяц. Таким образом, все что Вам нужно - подключиться раз в месяц к нашему сервису и получить обновленный ассортимент товаров.

1 стартмани

12.01.2015    45110    184    Sirruf    81    

Загрузка размеров и веса для Wildberries

Маркетплейсы Загрузка и выгрузка в Excel Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Обработка для загрузки веса и размеров для товаров маркетплейса Wildberries. Загружает измерения из файла excel. Корректирует существующие измерения с пересчетом и создает отсутствующие. Протестировано для версии УТ 10.3.28.1 платформа 8.3.18.1779. Работать будет для всех конфигураций серии 10.3 и для любых версий платформ.

5 стартмани

13.01.2023    556    0    XuMbI4    0    

Обмен с Wildberries

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Обработка позволит через API выгрузить в личный кабинет Wildberries остатки и цены. Загрузить новые заказы в 1С. Вернет статус заказа назад в личный кабинет.

1 стартмани

17.11.2022    826    9    чингачгук    4    

Загрузка данных отчета о реализации товаров из Excel файла М.Видео

Оптовая торговля Загрузка и выгрузка в Excel Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Управление нашей фирмой 3.0 Абонемент ($m) Абонемент ($m)

Загрузка данных отчета о реализации товаров из маркетплейса М.Видео в следующие конфигурации: Бухгалтерия предприятия, редакция 3.0; Управление торговлей, редакция 11; Комплексная автоматизация 2; ERP 2 Управление предприятием и Управление нашей фирмой, редакция 1.6 - 3.0 в документ "Отчет комиссионера (агента) о продажах".

5 стартмани

08.11.2022    1203    2    LamerSoft    0    

Загрузка отчета комиссионера OZON для юридических лиц

Обработка документов Оптовая торговля Файловый обмен (TXT, XML, DBF), FTP Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

Обработка заполнения табличной части документа "Отчет комиссионера о продажах" из файла OZON по юр. лицам. Контрагенты создаются автоматически . Из созданного типовым методом общего документа "Отчет комиссионера о продажах" удаляются строки по юр.лицам. В итоге получаем 2 документа - для юр лиц и для физ лиц.

1 стартмани

06.10.2022    1429    8    kida1    13    

Загрузка отчета комиссионера Ozon, Яндекс Маркет в 1С из Excel и Openoffice

Оптовая торговля Файловый обмен (TXT, XML, DBF), FTP Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Обработка предназначена для следующей конфигурации: Управление торговлей, редакция 10.3. С помощью этой обработки можно заполнить отчет комиссионера из файла, присланного маркетплейсом Ozon(Озон), ЯндексМаркет.

2 стартмани

15.08.2022    1663    8    ismashik    10    

Работа через локальный API aliExpress

Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Управление торговлей 11 Абонемент ($m) Абонемент ($m)

Загрузка заказов с aliExpress через локальный АПИ с 15 августа 2022 года. В связи с тем, что в aliExpress 15 августа начнётся переход на новый алгоритм обработки заказа, некоторые глобальные методы перестанут работать.

5 стартмани

07.08.2022    2447    12    kserdyukov    2    

Обмен заказами и остатками с маркетплейсом Wildberries и конфигурацией 1С:Розница

Розничная торговля Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Розница 1С:Розница Розничная и сетевая торговля (FMCG) Розничная и сетевая торговля (FMCG) Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Представляю Вашему вниманию обработку для конфигурации 1С:Розница, при помощи которой можно осуществлять обмен остатками и заказами с маркетплейсом Wildberries. Данная обработка может быть подключена в качестве дополнительной внешней обработки  и использоваться для обмена заказами и остатками с вышеуказанным маркетплейсом. Кроме того, она может послужить основой для адаптации  программистами под нужды заказчика, а  также использоваться как примеры работы с Wildberries api и http запросами (в определенной степени).

9 стартмани

07.06.2022    3102    2    user596590_pavel.kuznecov    0    

Изменение наименования товара на Wildberries

Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Абонемент ($m) Абонемент ($m)

Обработка для изменения наименования номенклатуры на сайте WB посредством API.

1 стартмани

24.05.2022    2803    7    crushos    21    

Загрузка продаж из маркетплейсов Ozon и Wildberries в 1С: БП 3.0

Оптовая торговля Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 Бухгалтерский учет Бухгалтерский учет 1С:Бухгалтерия 3.0 1С:Бухгалтерия 3.0 Бухгалтерский учет Бухгалтерский учет Абонемент ($m) Абонемент ($m)

В конце месяца, квартала, года возникает необходимость загрузить данные о продажах из маркетплейсов в 1С:Бухгалтерия 8, ред.3.0. Данная обработка позволит совершить данную загрузку.

1 стартмани

15.04.2022    2368    19    evn-zorin    2    

Выгрузка цен на Яндекс.Маркет для УТ 10.3, УПП 1.3, КА 1.1 c помощью API

Оптовая торговля Розничная торговля Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление торговлей 10 1С:Управление производственным предприятием 1С:Управление производственным предприятием Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Выгрузка цен на Яндекс.Маркет c помощью API для УТ 10.3, УПП 1.3, КА 1.1. Реализованы GET и POST запросы для работы с API Яндекса. Это обработка позволяет сопоставляет товары 1С и товары на Яндекс Маркет и выгружает установленные цены. Код обработки открыт, будет полезно для изучения API Яндекс Маркета.

1 стартмани

05.04.2022    2542    15    SP2000    2    

Выгрузка остатков и цен в Озон

Загрузка и выгрузка в Excel Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 Платформа 1C v8.2 Платформа 1C v8.2 1С:Управление торговлей 10 1С:Управление торговлей 10 Абонемент ($m) Абонемент ($m)

Выгрузка текущих остатков и цен из 1C УТ 10.3 в шаблон для Озон (OZON). Обработка позволяет заполнить шаблон в формате Эксель остатками и ценами из 1С УТ 10.3, для последующей их загрузки в Озон. Шаблон для заполнения остатков и цен должен быть скачан из вашего личного кабинета OZON. Но подойдет и любой файл Эксель.

1 стартмани

21.03.2022    3032    5    simuljakr    2    

Интеграция 1С и OZON

Оптовая торговля Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Абонемент ($m) Абонемент ($m)

Обработка для обмена между 1С и OZON по API: загрузка на сайт товаров, цен, получение в 1С остатков, списка отправлений со своего склада (FBS) и со склада OZON (FBO), создание заказов, отчеты.

2 стартмани

10.02.2022    3340    40    user_as_01    11    

Интеграция Aliexpress и Управление торговлей 10.3

Оптовая торговля Розничная торговля Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Абонемент ($m) Абонемент ($m)

Обработки для заполнения "product id" по артикулам/наименованиям и для обновления цен и остатков товаров в личном кабинете продавца на AliExpress по данным из 1С: Управление торговлей 10.3.

1 стартмани

01.12.2021    2830    11    boba13    0    

Получение токена для Aliexpress

Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Позволяет быстро получить токен для начала работы с API Aliexpress.

1 стартмани

19.10.2021    3728    9    unknown181538    6    

Загрузка заказов по API Wildberries. Печать стикеров для FBS (в т.ч. в формате QR-кода). Для УТ 10.3. Загрузка и выгрузка остатков

Оптовая торговля Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление торговлей 10 Оптовая торговля, дистрибуция, логистика Оптовая торговля, дистрибуция, логистика Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Используется API версии v2. Также, использован новый метод "/api/v2/orders/stickers". Создает документ "Реализация товаров и услуг". Печать стикеров производится с помощью внешней печатной формы. Отдельная обработка для выгрузки и загрузки товаров.

2 стартмани

12.10.2021    3918    83    unknown181538    25    

Интеграция 1С по API c интернет-магазином «Wildberries» для получения статистики по продажам, заказам и остаткам на складах

Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Предлагаю рассмотреть обмен с Wildberries (Вайлтберриз) по API - такая задача сейчас стоит перед многими организациями и частными лицами. Для просмотра статистики и создания документов по отчетам за период реализовано две обработки - универсальная и для УНФ 1.6

1 стартмани

23.08.2021    4202    44    nikbarb    19    

Работа с API ОЗОН для УТ 11

Оптовая торговля Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 Оперативный учет Оперативный учет 1С:Управление торговлей 11 1С:Управление торговлей 11 Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Разработка позволяет работать с маркетплейсом ОЗОН по API. Разработка позволяет осуществлять полный цикл продаж на ОЗОНе полностью автоматически. В цикл входят загрузка номенклатуры на ОЗОН, обновление артикулов (Id) номенклатуры для конкретного кабинета пользователя на ОЗОНе, обновление цен и остатков номенклатуры, загрузка заказов с ОЗОН раздельно для каждого кабинета пользователя и каждой из моделей работы (fbo и fbs).

5 стартмани

18.08.2021    5308    16    Torin99    23    

Обновление цены и остатка товаров на Ozon.ru через фид YML

Оптовая торговля Маркетплейсы Оперативный учет Оперативный учет 8.3.14 8.3.14 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 1.6 1С:Управление торговлей 11 1С:Управление торговлей 11 Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Внешняя обработка, которая выгружает на Ozon.ru данные о ценах и остатках товаров из 1С через YML-файл. Новая возможность автоматической выгрузки данных через фид.(Yandex Market Language).

1 стартмани

04.08.2021    6534    23    elcoan    6    

Интеграция Wildberries API FBS. Продажи по схеме со склада поставщика

Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Абонемент ($m) Абонемент ($m)

Расширения для конфигураций УТ 11.4 и УНФ 1.6 для реализации взаимодействия с WB API по схеме Продажи со склада поставщика. Поддерживается новая версия API v2, реализованы выгрузка остатков, выгрузка цен, загрузка сборочных заданий, загрузка статусов доставки заказов, печать стикеров, передача статусов заказов в WB API. Выгрузка остатков и загрузка заказов реализована регламентными заданиями. В расширении для УТ реализована возможность работы от лица нескольких организаций. В новой версии расширения для УТ добавлен функционал по работе с поставками Вайлдбериз (получение списка поставок, создание поставки, добавление заказов в поставку, закрытие поставки, получение щтрихкода поставки, печать поставки).

10 стартмани

28.06.2021    10264    109    nvpwasp    78    

Загрузка "Отчета комиссионера" с маркетплейсов Ozon и Wildberries в 1С Управление Торговлей 11

Загрузка и выгрузка в Excel Оптовая торговля Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Управление торговлей 11 Абонемент ($m) Абонемент ($m)

Заполнение Отчет комиссионера (агента) о продажах из файлов Excel: xls (xlsx). Загрузка "Отчета комиссионера" с маркетплейсов Ozon и Wildberries в 1С Управление Торговлей 11.

3 стартмани

18.06.2021    10503    96    Nik-An    79    

Загрузка отчетов комиссионеров из Вайлдберриз и ОЗОН в УТ 11 по API

Маркетплейсы Платформа 1С v8.3 Платформа 1С v8.3 8.3.14 8.3.14 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Россия Россия Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Расширения для загрузки отчетов комиссионеров данными о продажах с маркетплейсов Wildberries и OZON по API. Расширения позволяют: 1) Заполнить отчет комиссионера данными о продажах из сервиса; 2) Создать документ оказания услуг по сборке, логистике; 3) Создать документ "Взаимозачет задолженности", которым задолженность по оказанным услугам переносится на отчет комиссионера.

2 стартмани

08.06.2021    13490    255    asdes    142