Расширение типового функционала работы с ККМ в 1с Розница 1.0 (добавление произвольного количества типов оплаты)

Публикация № 175928

Администрирование - Торговое оборудование - ККМ

49
У одного клиента,занимающегося розничной торговлей, появилась необходимость разделять продажи по типам оплаты в Z-отчете с бОльшим разнообразием,чем позволяет типовой функционал работы с ТО.
Т.е. стандартную разбивку на наличную и безналичную оплату расширить до нал,оплата по платежным картам(безнал),банковским кредитам.В то же время исключить  кредит из секции «оплата по безналу».
Почему возникла такая потребность?Все просто,в бэк-офисе так проще сверять Отчет о розничных продажах с Z-отчетом.

Итак.Начну с того,что в качестве ККМ используется принтер чеков ЕНВД под управлением стандратного атоловского драйвера версии 6.17.1

В настройках этого драйвера можно указать произвольное количество типов оплаты(врамках разумного) см.рис. "Настройка ККМ"

Однако  выяснилось,что раньше для взаимодействия с ккм использовался стандартный интерфейс("AddIn.FPrnM45"),потом переделали на стандарт 1с с использованием "AddIn.ATOL_KKM_1C".Так вот,новый стандарт 1с сильно усечен и через новый объект вызовы Fprnm1C.dll с указанием типа оплаты использовать нельзя.В текущих обработках обслуживания ТО для закрытия чека используется функция вида:

Функция ЗакрытьЧек(Объект, СуммаНал, СуммаБезнал) Экспорт

    Результат = мНетОшибки;

    Если Не Объект.Драйвер.ЗакрытьЧек(Объект.ИДУстройства, СуммаНал, СуммаБезнал) Тогда
        Результат = мОшибкаНеизвестно;
        Объект.Драйвер.ПолучитьОшибку(Объект.ОписаниеОшибки);

        ОтменитьЧек(Объект);
    КонецЕсли;

    Возврат Результат;

КонецФункции // ЗакрытьЧек()

В ней передается на ККМ всего лишь 2 суммы по налу и безналу.

Решение проблемы:

- Документ.ЧекККМ.Модуль объекта

Изменена Функция ПечатьЧекаККМ(Идентификатор, НомерЧека, НомерСмены,

                      ОписаниеЧека, СуммаНал, СуммаБезнал, ПризнакВозврата)

//Марат

//Результат = ПолучитьСерверТО().ЗакрытьЧек(Идентификатор, СуммаНал, СуммаБезнал);

Результат = ПолучитьСерверТО().ЗакрытьЧек(Идентификатор, СуммаНал, СуммаБезнал,ПолучитьСуммуОплатыБанковскимКредитом());

 

- Обработка.ТОСервер.Модуль объекта

Изменена Функция ЗакрытьЧек(Идентификатор, СуммаНал, СуммаБезнал,СуммаКредит=0) Экспорт  //Марат добавлен параметр СуммаКредит=0

//марат

//Результат = Обработка.ЗакрытьЧек(Объект, СуммаНал, СуммаБезнал,СуммаБезнал,СуммаКредит);

Результат = Обработка.ЗакрытьЧек(Объект, СуммаНал, Макс(0,СуммаБезнал-СуммаКредит),СуммаКредит);

-Обновлена обработка обслуживания ТО ATOLFiscalPrinters_v2.epf

Заменена Функция ЗакрытьЧек(Объект, СуммаНал, СуммаБезнал,СуммаКредит=0) Экспорт

//марат+

                Попытка

                               ПрогИД = "AddIn.FPrnM45";

                               //ПодключитьВнешнююКомпоненту(ПрогИД);

                               Драйвер = Новый (ПрогИД);

                Исключение

                               Попытка

                                               ПодключитьВнешнююКомпоненту(ПрогИД);

                                               Драйвер = Новый (ПрогИД);

                               Исключение

                                               Результат = мОшибкаЗагрузкиДрайвера;

                                               ОписаниеОшибки = "Невозможно подключить внешнюю компоненту AddIn.FPrnM45.

                                               | Попытайтесь зарегистрировать драйвер ККМ FprnM1C.dll в системе

                                               | командой regsvr32.";

                                               Сообщить(ОписаниеОшибки);

                                               Возврат Результат;

                               КонецПопытки;

                КонецПопытки;

 

               

                Результат  = мНетОшибки;

                Ответ      = 0;

 

                Если СуммаНал > 0 Тогда

                               Драйвер.Summ       = СуммаНал;

                               Драйвер.TypeClose = 0;

                               Драйвер.Payment();

                               Ответ = Драйвер.Результат;

                КонецЕсли;

 

                Если Ответ = 0 Тогда

                               Если СуммаБезнал > 0 Тогда

                                               Драйвер.Summ       = СуммаБезнал;

                                               Драйвер.TypeClose = 1;

                                               Драйвер.Payment();

                                               Ответ = Драйвер.Результат;

                               КонецЕсли;

                КонецЕсли;

               

                Если Ответ = 0 Тогда

                               Если СуммаКредит > 0 Тогда

                                               Драйвер.Summ       = СуммаКредит;

                                               Драйвер.TypeClose = 2;

                                               Драйвер.Payment();

                                               Ответ = Драйвер.Результат;

                               КонецЕсли;

                КонецЕсли;

 

                Если Ответ = 0 Тогда

                               Драйвер.CloseCheck(); // Закрыть чек

                КонецЕсли;

 

                Если Ответ = 0 Тогда

                               //Объект.Удалить("ЭтоВозврат");

                Иначе

                               Результат = мОшибкаНеизвестно;

                               Объект.ОписаниеОшибки = Драйвер.ОписаниеРезультата;

                               ОтменитьЧек(Объект);

                КонецЕсли;

 

                Возврат Результат;

КонецФункции // ЗакрытьЧек()


Буду очень рад если кому то данная статья поможет.

49

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. mirajen 08.03.13 19:50 Сейчас в теме
Очень полезная статья!!! спасибо тебе!
2. CnupT 53 17.07.13 09:21 Сейчас в теме
Делал систему бонусов для Розницы 1.0, возникла аналогичная проблема: в чеке надо было печатать
не только наличные и безнал, но и оплату бонусами. Стандартная обработка этого не умела, и Ваша
статья мне очень сильно помогла. Спасибо!
3. Yuris 17 13.12.13 17:12 Сейчас в теме
Спасибо большое. Статья существенно сократила время на решение проблемы.
4. oleg212 03.01.14 00:26 Сейчас в теме
Автору однозначно плюс за статью!
5. kolombo_eburg 70 13.01.14 10:17 Сейчас в теме
Небольшие усовершенствования:
Если используется конфигурация "Розница 8. Магазин одежды и обуви, редакция 1." или другая отраслевая розница, то процедура закрытия чека там вызывается из фронта, поэтому необходимо еще внести изменения в ОбщийМодуль.ФронтКассира в строку:
Результат = ПолучитьСерверТО().ЗакрытьЧек(Идентификатор, СуммаНаличные, СуммаБезнал);
добавить еще параметр по аналогии с описанием в статье.

Также нужно обратить внимание на строку:
СуммаБезнал = МИН(СуммаДокумента, ТаблицаПоОплатам.Итог("Сумма")-СуммаНаличные);


В моем случае таким образом разделяли по секциям Безнал от оплаты подарочными сертификатами, поскольку в стандартном механизме такая оплата проходит по секции безналичной оплаты.
6. ecstazi 26.02.14 15:59 Сейчас в теме
а как реализовать данный механизм в рознице 2.1 с fprint 22k
7. ecstazi 26.02.14 16:00 Сейчас в теме
Есть типы оплат нал,безнал,сертификатом.
8. orehova123 21.03.14 20:43 Сейчас в теме
Мои бухи захотели, чтобы денежные документы возврата проводились в магазинах, да еще плюс отражались в Z-отчете. Да, это противоречит НК. У нас даже почти до драки дошло. Но вот лень им, и все тут!!!
Поэтому пришлось еще учесть, что необходимо сделать доработки в документах РКО, ПКО (на всякий уж случай), Оплата платежной картой.
Автору за статью спасибо, навел на правильный курс - не пришлось долго сидеть с отладчиком и пошагово проходить операцию за операцией. Третьим видом оплаты, кстати, используем подарочные сертификаты
9. ToJIuK 08.12.14 13:55 Сейчас в теме
В случае РОЗНИЦЫ 2.0 и Фискального регистратора АТОЛ . Проблема решается установкой обновления до версии 2.1.2.8 (Может и раньше появилось , но на это версии точно работает). В настройке Торг Оборудования , появиться пункт АТОЛ (Универсальный) кот через него работает нормально , Бензнал идет 2ым видом оплаты, Подарочные сертификаты - Четверным . Все Работает нормально
Yura77; ivprovotorov; +2 Ответить
10. ivprovotorov 15 21.12.14 23:34 Сейчас в теме
(9) ToJIuK, Красавец!!! Настоящий программист , предложил решение без единой строчки кода. ;-)

11. ToJIuK 09.01.15 17:46 Сейчас в теме
(10) ivprovotorov, А смысл изобретать колесо ?! Если давно есть и успешно работает велосипед.
14. bio.ejiki 27.11.15 11:18 Сейчас в теме
(9) ToJIuK, но вот есть один минус который в универсальном драйвере не нашел как поменять. Нету настройки Таймаута у принтера.
12. Amirzhan 10.03.15 16:28 Сейчас в теме
Здравствуйте ! Блин интересная статья, но у немного по другому - никак не могу настроить ФР Aura с драйвером от Atol. Оплаты сертификатом садятся на без нал, в общем и так и так крутил - не смог настроить... версия 1.0.8.1 Розница для Казахстана. Не знаете куда копать ? Заранее спасибо ! Статей много, но везде все не то, что нужно .
13. Amirzhan 13.03.15 20:41 Сейчас в теме
Получилось. Все работает отлично. Но нужен дельный совет. В Рознице есть документ Оплата от покупателя платежной картой в момент проведения документа проблем нет, но в момент нажатия ЧЕК выходит ошибка в 1С что много фактических параметров, а на ФР чек пробивается и сразу аннулируется. В момент когда выходит ошибка, я прохожу в Конфигуратор и попадаю в документ Оплата от покупателя платежной картой модуль документа - дальше ошибка именно где то в этом коде Процедура ОсновныеДействияФормыЧек(Кнопка)

Перем ФР;

Если НомерЧекаККМ <> 0 Тогда
Предупреждение("Чек уже пробит на фискальном регистраторе!");
Возврат;
КонецЕсли;

Если Не Проведен Тогда
Предупреждение("Перед пробитием чека на фискальном регистраторе документ необходимо провести!");
Возврат;
КонецЕсли;

Если Не РаботаСДиалогами.ПроверитьМодифицированностьВФорме(ЭтотОбъект, ЭтаФорма) Тогда
Возврат;
КонецЕсли;

Если Не РаботаСТорговымОборудованием.ПолучитьПроверитьПараметрыДляПробитияЧека(ФР) Тогда
Возврат;
КонецЕсли;

Позиция = Неопределено;
НомерСмены = Неопределено;
ТаблицаПлатежей = Новый ТаблицаЗначений();
ТаблицаПлатежей.Колонки.Добавить("Заголовок");
ТаблицаПлатежей.Колонки.Добавить("Сумма");
ТаблицаПлатежей.Колонки.Добавить("НДС");

Для Каждого Позиция Из РасшифровкаПлатежа Цикл
СтрокаТаблицы = ТаблицаПлатежей.Добавить();
СтрокаТаблицы.Заголовок = "Принято от " + СокрЛП(Контрагент)
+ "
|Основание: " + СокрЛП(ЭтотОбъект);
СтрокаТаблицы.Сумма = Позиция.СуммаПлатежа;
СтрокаТаблицы.НДС = УчетНДСИАкциза.ПолучитьСтавкуНДС(Позиция.СтавкаНДС);
КонецЦикла;

Если ВидОперации = Перечисления.ВидыОперацийОплатаОтПокупателяПлатежнойКартой.ОплатаПокупателя Тогда
Результат = ПолучитьСерверТО().ПечатьЧекаПКО(ФР,
НомерЧекаККМ,
НомерСмены,
ТаблицаПлатежей,
0,
СуммаДокумента);
Иначе
Результат = ПолучитьСерверТО().ПечатьЧекаРКО(ФР,
НомерЧекаККМ,
НомерСмены,
ТаблицаПлатежей,
0,
СуммаДокумента);

КонецЕсли;

Если Не ЗначениеЗаполнено(Результат) Тогда
Оплачено = Истина;
Иначе
ТекстОшибки = ПолучитьСерверТО().ПолучитьТекстОшибкиФРТО(Результат);
Предупреждение(ТекстОшибки);
КонецЕсли;

КонецПроцедуры

Буду рад если подскажите в чем проблема...
15. Morisato 14.01.16 13:03 Сейчас в теме
Для Штрих-М все на много проще
0 вид оплаты - Наличные
1 вид оплаты - ПЛАТ. КАРТА
2 вид оплаты - Подарочный серт

Плюс надо немного фискалку донастроить.

ТаблицаОплат = Новый Массив();
				
				// Наличные
				СтрокаОплаты = Новый СписокЗначений();
				СтрокаОплаты.Добавить(0);
				СтрокаОплаты.Добавить(СуммаНаличнойОплаты());
				СтрокаОплаты.Добавить("Наличная оплата");
				СтрокаОплаты.Добавить("");
				ТаблицаОплат.Добавить(СтрокаОплаты);
				
				// Безналичные
				СтрокаОплаты = Новый СписокЗначений();
				СтрокаОплаты.Добавить(1);
				//СтрокаОплаты.Добавить(СуммаБезналичнойОплаты() + СуммаОплатыПодарочнымиСертификатами());
				СтрокаОплаты.Добавить(СуммаБезналичнойОплаты()); 
				СтрокаОплаты.Добавить("Безналичная оплата");
				СтрокаОплаты.Добавить("");
				ТаблицаОплат.Добавить(СтрокаОплаты);
				
				//{// Подарочный сертификат
				СтрокаОплаты = Новый СписокЗначений();
				СтрокаОплаты.Добавить(2);
				СтрокаОплаты.Добавить(СуммаОплатыПодарочнымиСертификатами()); 
				СтрокаОплаты.Добавить("Подарочный сертификат");
				СтрокаОплаты.Добавить("");
				ТаблицаОплат.Добавить(СтрокаОплаты);
                //}
Показать
16. bajen 6 20.10.16 12:56 Сейчас в теме
(15) Morisato, Куда эту таблицу оплат подставлять не совсем понятно?
17. maksa2005 296 25.02.17 09:46 Сейчас в теме
Марат Ибрагимов СПАСИБО ОГРОМНОЕ.
Оставьте свое сообщение

См. также

Подключение АТОЛ 91/92Ф к 1С:Касса 5

Статья Системный администратор Нет файла v8 1cv8.cf Россия Кассовые операции Бесплатно (free) ККМ

Т.к. я не нашел данной информации в гугле (возможно, плохо искал), решил, что нужно оставить эту статью здесь, может, поможет кому.

10.09.2019    1166    rule_2    2       

Чеки ККМ для расчетов с ИП по безналу. Новые обязательные реквизиты в чеке 32

Статья Программист Нет файла v8 v8::ОУ УТ11 УУ Windows Оптовая торговля Бесплатно (free) Практика программирования ККМ Разработка

Новые требования законодательства по пробитию чеков ККМ при расчетах с индивидуальными предпринимателями по безналу. Нюансы подключения интеграционной компоненты ДТО 10.5.0 на примере кассы ККТ АТОЛ 11Ф и конфигурации 1С УТ 11.4. Необходимые доработки типовой конфигурации УТ 11.4 для вывода на печать новых обязательных реквизитов: покупатель, ИНН, ГТД, страна происхождения.

22.07.2019    5666    ids79    16       

Работа с кассой Atol через веб-сервер ДТО-10 55

Статья Программист Нет файла v8 Россия Кассовые операции НДС Бесплатно (free) Внешние источники данных ККМ Фискальный регистратор

Поддержка многопользовательской печати на одном устройстве ККТ. Поддержка изменений в законодательстве (Переход на ФФД 1.05 и НДС 20%).

31.12.2018    16940    medangel    36       

Авансы, кредиты и предоплаты. Примеры чеков ФФД 1.05 24

Статья Бухгалтер Нет файла v8 УТ11 Розничная и сетевая торговля (FMCG) Россия БУ Розничная торговля Бесплатно (free) ККМ

В публикации рассмотрено, как должны выглядеть корректные чеки ФФД 1.05 при авансах, кредитах и предоплатах. Чеки получены с помощью демонстрационной базы 1С:Управление торговлей 11.4.5.54 (Платформа 8.3.11.3034).

30.07.2018    30277    vasilievil    28       

Отправка http запросов с Дайджест-аутентификацией из 1С на примере кассового аппарата MG N707TS 4

Статья Системный администратор Программист Нет файла v8 1cv8.cf Украина Бесплатно (free) ККМ

Возникала необходимость использовать кассовый аппарат MG N707TS под ubuntu, как известно, COM объекты не поддерживаются. На самом деле не все так сложно! Расписывать долго не буду, смотрите "Процедура КнопкаСформироватьНажатие" , может кому пригодится.

16.07.2018    4443    IgKR    8       

Чеки ККМ онлайн касс Атол на конфигурации КА 1.1 5

Статья Программист Нет файла v8 КА1 Россия Кассовые операции Бесплатно (free) ККМ

Онлайн касса печатает тип СНО УСН, хотя организация работает на ЕНВД.

13.07.2018    7129    dima_finne    6       

Учет и сверка Z-Отчетов ККМ в 1С 15

Статья Программист Нет файла v8 КА1 УПП1 Розничная и сетевая торговля (FMCG) Россия БУ Кассовые операции Бесплатно (free) ККМ

Думаю, все крупные компании при внедрении/эксплуатации 1С делают значительные изменения в ее конфигурации. Как бы вы ни пытались все бизнес процессы решить типовыми решениями от 1С, все равно наступает момент, когда приходится заняться конфигурированием. Я решил написать серию статей, где постараюсь описать решения, которые мне пришлось реализовывать в разных компаниях. Если разработчики 1С посчитают что-то интересным для внедрения в типовые решения, мы будем только рады. В текущей статье речь пойдет о кассовых z-отчетах в 1С.

03.06.2018    12956    dima_home    12       

Подключение онлайн кассы (ККМ) ATOL к УТ 10.3 в терминале. Личный опыт 20

Статья Системный администратор Программист Нет файла v8 БП2.0 УТ10 Windows Кассовые операции Бесплатно (free) ККМ

Использование Онлайн Кассы на Windows HOME c драйвером без цифровой подписи. Проброска портов для ККМ. Использование компьютера с кассой в качестве сервера для быстрой печати чеков через терминал без использования сквозных COM портов.

10.05.2018    21340    pridecom    26       

Ошибка печати чека на ККМ Атол FPrint22. ПоследующаяОплата (Кредит) вместо Электронными. Розница 2 7

Статья Системный администратор Программист Нет файла v8 Розница Россия Кассовые операции Розничная торговля Бесплатно (free) Адаптация типовых решений ККМ

При печати чека на FPrint22 неожиданно выяснилось, что вместо Электронными (пробивали по платежной карте) в чеке вставало на вид оплат ПоследущаяОплата (Кредит).

22.01.2018    23043    ah7777777    15       

Как печатать чеки с разными видами деятельности на онлайн-кассе 7

Статья Программист Нет файла v8::ОУ УТ10 Россия Кассовые операции Розничная торговля ИП, ПБОЮЛ, КФХ Бесплатно (free) ККМ

Как печатать чеки по разным видам деятельности (с НДС и БЕЗ НДС) для одной организации и одного кассового аппарата, не используя сторонних доработок.

17.10.2017    16476    serpolit    10       

Подключение ККТ (Торгового оборудования) в разрезе Пользователя или Клиента RDP 30

Статья Программист Нет файла v8 1cv8.cf Кассовые операции Бесплатно (free) ККМ

Старые конфигурации (Комплексная автоматизаци 1.1, УТ 10.3...) не поддерживают разрез пользователей или клиентов RDP при подключение кассового оборудования. Решил немного освежить идею статьи https://infostart.ru/public/197612/ и комментарии Сергея Муравьёва и Сергея Капустина собрав воедино. В этой статье-заметке вы узнаете, как с минимальными доработками изменить видимость ККТ в разрезе пользователей или терминальных сессий по RDP даже с вводом новых документов по работе с ККТ.

28.09.2017    20307    rpgshnik    24       

Комплексное решение для малого бизнеса: 1С:УНФ + онлайн-касса "ШТРИХ-МPAY-Ф" 4

Статья Системный администратор Программист Нет файла v8 Россия Кассовые операции Бесплатно (free) ККМ

Фирма "1С" представляет новый программно-аппаратный комплекс для интернет-магазинов, предпринимателей и компаний сферы торговли и услуг, предпочитающих облачные решения, а также для тех, кто торгует алкоголем и кому в связи с этим необходимо обеспечить поддержку ЕГАИС.

29.08.2017    13799    user818734    5       

Способы решения ошибок при настройке кассы ККТ для ФЗ-54 22

Статья Системный администратор Программист Нет файла v8 1cv8.cf Россия Кассовые операции Бесплатно (free) ККМ

Решение ошибок: 1. "При выполнении операции произошла ошибка: FFFFFFF8h, Смена открыта, программирование налогов невозможно" 2. "При выполнении операции произошла ошибка: 37h, Команда не поддерживается в данной реализации" 3. "Касса через какой то период перестает отправлять данные в налоговую"

31.05.2017    81431    lightvdv    55       

Внедрение ККМ Онлайн в сторонние конфигурации 1С 105

Статья Программист Нет файла v8 1cv8.cf Кассовые операции Розничная торговля Бесплатно (free) ККМ Фискальный регистратор

В данной статье мне бы хотелось поделиться опытом внедрения ККМ онлайн (Атол 11Ф) в одну из сторонних конфигураций 1С. Надеюсь, что она поможет сэкономить время моим коллегам, которые столкнулись с ситуацией, когда есть конфигурация, но ее поддержка разработчиком уже давно прекращена. В статье мы рассмотрим общие моменты, которые позволят "подружить" ее с онлайн кассами.

22.04.2017    63378    lord_soth    28       

54 ФЗ своими руками 94

Статья Программист Нет файла v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Windows Кассовые операции Розничная торговля Бесплатно (free) ККМ

Практический опыт внедрения изменений в 54ФЗ в розничной сети, работающей на 1С. Если вы не хотите платить каким-либо подрядчикам, которые "всё сделают и настроят за вас", то статься может оказаться крайне полезной.

17.04.2017    53466    comol    124       

Практика подключения ККМ онлайн 176

Статья Системный администратор Нет файла v8 Россия Кассовые операции Розничная торговля Бесплатно (free) ККМ

С 1 июля 2017 года большинство юридических лиц и индивидуальных предпринимателей работающие с наличными должны использовать контрольно-кассовую технику(ККТ) в режиме онлайн или проще говоря перейти на онлайн кассы. Расскажу на практическом примере, как я подключал и зарегистрировал кассу ATOL FPrint 90Ф.

13.12.2016    275714    ApocalypseNTC    794       

Важные изменения в 54-ФЗ: какой будет ККМ в 2017 году 31

Статья Бухгалтер Пользователь Нет файла v7.7 v8 Розничная и сетевая торговля (FMCG) Россия Кассовые операции Розничная торговля Бесплатно (free) ККМ Фискальный регистратор

Уже начиная с апреля 2016 года нас ждут довольно серьезные изменения по передаче данных о продажах в налоговую. Не только ожесточится контроль над тем, сколько мы продаем, но и изменятся сами ККМ.

11.05.2016    91137    alis112358    80       

Не смогли определить доступный магазин или доступные кассы ККМ. Обратитесь к Администратору системы 13

Статья Системный администратор Нет файла v8 Розница Розничная и сетевая торговля (FMCG) Windows Кассовые операции Бесплатно (free) Администрирование данных 1С ККМ

Иногда бывает, что, после включения рабочего места возникает ошибка «Не смогли определить доступный Магазин или доступные кассы ККМ. Обратитесь к Администратору системы».

04.12.2015    47822    Dima_    4       

Подключение торгового оборудования по rdp. 87

Статья Системный администратор Программист Нет файла v8 КА1 УПП1 Россия УУ Windows Розничная торговля Бесплатно (free) ККМ Сканер штрих-кода

Задача следующая, есть две розничные точки и центральная оптовая. Пользователи работают в терминале на Win Server 2003, база находится на центральной точке, розничные подключаются по интернету. Необходимо подключить сканеры штрих-кода в центральной точке на складе и Сканеры и ФР в розничных точках. При чем в розничных точках один сканер должен переподключаться между кассовым узлом и компьютером в приёмке. Сканеры ШК - Datalogic QuickScan I QM2100 (беспроводной), Honeywell Eclipse 5145, ФР - Штрих-М-ФР-К. Все устройства с интерфейсом USB.

14.08.2013    119632    de0nis    37       

Формирование печати чека ККМ и Z - отчета по нескольким отделам магазина одновременно 5

Статья Программист Нет файла v8 Розница Розничная и сетевая торговля (FMCG) Россия Розничная торговля Бесплатно (free) Практика программирования ККМ

Статья на тему: как сделать так, чтобы из 1С Розницы (Розница Магазин Автозапчастей, Розница Магазин обуви и одежды) можно было распечатать ЧекККМ на несколько отделов.

02.08.2012    20592    rsvp201    3       

Подключение ККМ Пирит ФР01К 6

Статья no Нет файла v8 1cv8.cf Россия Бесплатно (free) ККМ Фискальный регистратор

Наша организация всегда работала с ФР "Штрих", сейчас она решила перейти на ФР "Пирит ФР01К", хочу рассказать о проблемах с подключением этого ФР к 1с8 (по крайней мере о тех проблемах что возникли у меня), обработка стандартная с 1с ИТС "CrystalsPiritFR01K.epf", драйвер с сайта Кристалл "CrystalsPiritFR01K.dll";

12.10.2011    26746    Ткачев    3       

Обмен между Атол РМК 3.9.4 и УТ 10.3.1.17 6

Инструменты и обработки no Внешняя обработка (ert,epf) v8 УТ10 Розничная торговля Бесплатно (free) Обработка документов ККМ

Перенос товара из 1С в ККМ Offline и загрузка продаж обратно. Товар переносится иерархически, с разрезами по характеристиками. Также выгружаются скидки по дисконтным картам.

21.05.2009    19662    334    kstukov    6