IE2017

Вариант реализации анимации только средствами 1С

Программирование - Практика программирования

Oldskool-плазма.

Всем надоевший Oldskool-compo эффект.

Скачать файлы

Наименование Файл Версия Размер
Oldskool.rar
.1235891484 4,17Kb
26.01.13
406
.1235891484 4,17Kb 406 Скачать бесплатно
Oldskool2.rar (by zyto)
.1236799957 4,51Kb
26.01.13
107
.1236799957 4,51Kb 107 Скачать бесплатно
Oldskool3.rar (со счётчиком FPS)
.1237462567 5,01Kb
26.01.13
111
.1237462567 5,01Kb 111 Скачать бесплатно

См. также

Комментарии
1. Василий Демидов (Душелов) 3807 01.03.09 12:49 Сейчас в теме
2. Игорь Белышев (biv75) 02.03.09 07:39 Сейчас в теме
Интересно, неординарно ))
3. Кирилл Коновалов (akkvamarin) 117 02.03.09 11:12 Сейчас в теме
4. Алексей Мутовкин (mrWatson) 303 02.03.09 11:42 Сейчас в теме
Молоток, ждем вращающийся тор, пламя и что там еще было...
5. Artem N (Artem N) 90 02.03.09 12:51 Сейчас в теме
2(mrWatson): К сожалению, использованный метод достаточно медленный. Сделай замер производительости...

Именно поэтому такой маленький размер поля и всего 10fps.
6. naus (Danil.Potapov) 02.03.09 15:32 Сейчас в теме
5. чаще обработчик не может работать, 0.1 - это его предел.
7. Artem N (Artem N) 90 02.03.09 16:03 Сейчас в теме
2(naus): Ага, по документации 1/10 секунды. Но, похоже, имеют место быть "особенности реализации" и обработчик можно вызывать чаще.
8. Сергей Старых (tormozit) 4339 04.03.09 18:00 Сейчас в теме
GREETENGS ARE GOING TO

--AMIGA SCENE--
@THE BLACK LOTUS@
*EPHIDRENA*
"MAD ELKS"

--PC SCENE--
#FAIRLIGHT#
$MFX$

LET'S GO!
9. Денис (xdenx) 07.03.09 20:52 Сейчас в теме
--ZX SCENE--
>EXTREME<
>DMS<
>CODE BUSTERS<

:)
10. zyto (zyto) 10.03.09 12:08 Сейчас в теме
То же самое, без привязки к ПодключитьОбработчикОжидания и его 0.1 сек. Теперь завит только от быстродействия вашего компьютера.
http://www.rapidshare.ru/956950
Сделано на основании этого примерчика:
http://infostart.ru/projects/2460/
11. Artem N (Artem N) 90 10.03.09 12:15 Сейчас в теме
Класс! :-) Давно искал нечто подобное :-)
12. zyto (zyto) 10.03.09 14:00 Сейчас в теме
13. Artem N (Artem N) 90 12.03.09 12:48 Сейчас в теме
Ужас!!!
Подключил к плазме вывод fps (код ниже). И что вы думаете?! 5! Всего пять! И это при условии, что обработчик вызывается с параметром "0.1"...
Вариант zyto стабильно выдаёт значение 25.

===
Перем СчётчикФПС;

Процедура ПриОткрытии()
СчётчикФПС = 0;
ПодключитьОбработчикОжидания( "ФПС", 1 );
КонецПроцедуры

Процедура ФПС()
ЭлементыФормы.КоманднаяПанель1.Кнопки.ФПС.Текст = СчётчикФПС;
СчётчикФПС = 0;
КонецПроцедуры

Процедура Нарисовать()
СчётчикФПС = СчётчикФПС + 1;
КонецПроцедуры
===
Оставьте свое сообщение