Быстрый поиск в справочниках по наименованию, с использованием svcsvc.dll

Публикация № 194178

Администрирование - Администрирование данных 1С - Поиск данных

12
По аналогии с http://infostart.ru/public/14286/, недавно узнал что в svcsvc.dll несколько обновился функционал, в частности был добавлен метод AddString().
В прилагаемом коде показан запрос, реализованный методами ВК 1SQlite, т.е. только для DBF.
Это только пример. Т.е. если например у справочника отсутствует поле "Наименование", то скорее всего будет ошибка.
Тем не менее критика приветствуется)))
Необходимые ВК: 1SQlite, FORMEX, svcsvc.dll (отсюда: http://www.1cpp.ru/forum/YaBB.pl?num=1373266553).

p.s.
Спасибо огромное уважаемому ADirks за все эти прекрасные плюшки, и помощь в их освоении)))
//Все вставляем в глобальный модуль
//======================================================================
Функция гв_ПоискЭлементаСправочникаВСписке_svc(ВидСправочника, Владелец = "", Элем = "") Экспорт
    

    //Эту процедуру удобно использовать и в дальнейшем, например для отчетов        
    База = СоздатьОбъект("SQLiteBase");

    База.Открыть(":memory:");
    Запрос = База.НовыйЗапрос();
    ТекстЗапроса = "
    |SELECT
    |    спр.DESCR||'|'||спр.CODE as [Поиск],
    |    спр.ID as [Ид :Справочник."
+ ВидСправочника +"]
    |FROM
    |    [Справочник."
+ ВидСправочника +"] as спр
    |WHERE
    |    1=1
    |ORDER BY спр.DESCR
    |"
;


    Условие = "
    |    спр.ISMARK <> '*'
    |"
;

    
    Если Метаданные.Справочник(ВидСправочника).КоличествоУровней > 1 Тогда
        Условие = Условие + "
        |    AND
        |    спр.ISFOLDER = 2
        |"
;

    КонецЕсли;
    
    Если ПустоеЗначение(Владелец) = 0 Тогда
        Условие = Условие + "
        |    AND
        |    спр.PARENTEXT = :Владелец
        |"
;

        Запрос.Подставлять("Владелец", Владелец);
    КонецЕсли;
    
    ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "1=1", Условие);
    
    тз = Запрос.ВыполнитьЗапрос(ТекстЗапроса);    

    свц = CreateObject("svcsvc.Service");

    тз.выбратьСТроки();
    Пока тз.ПолучитьСтроку() = 1 Цикл
        свц.AddString(тз.Поиск);

    КонецЦикла;

    рез = свц.FilterValue("", 1, "");

    свц = "";
    Если ПустаяСтрока(рез) = 0 Тогда
        нс = 0;

        тз.НайтиЗначение(рез, нс, "Поиск");
        Элем = тз.ПолучитьЗначение (нс, "Ид");
        Возврат 1;
    Иначе
        Возврат 0;

    КонецЕсли;
    
            
КонецФункции // гв_ПоискЭлементаСправочникаВСписке_svc        
//======================================================================
Процедура ПриНажатииКнопкиКлавиатуры(Конт, КодКлавиши, Альт, Шифт, Контрол, Символ, ФСО)

    Если Альт = 1 Тогда
        Если КодКлавиши = 116 Тогда // ALT-F5
        ФСО = 0;

        РасширениеФормы = СоздатьОбъект("РасширениеФормы");
        Попытка
            РасширениеФормы.УстановитьФорму(КонтФормы.Форма);

            ПолныйТипОбъекта = РасширениеФормы.ПолныйТипОбъекта();
            Если Найти(ПолныйТипОбъекта, "ФормаСписка") > 0 Тогда
                Владелец = "";

                Если Метаданные.Справочник(КонтФормы.Вид()).Владелец.Выбран() = 1 Тогда
                    Владелец = КонтФормы.Владелец;

                КонецЕсли;
                ДлинаНаименования = Метаданные.Справочник(КонтФормы.Вид()).ДлинаНаименования;
                ДлинаКода = Метаданные.Справочник(КонтФормы.Вид()).ДлинаКода;
                
                Если (ДлинаНаименования > 0) и (ДлинаКода > 0) Тогда
                    Элем = "";

                    Если гв_ПоискЭлементаСправочникаВСписке_svc(КонтФормы.Вид(), Владелец, Элем) = 1 Тогда
                        КонтФормы.АктивизироватьОбъект(Элем);

                        Попытка
                            КонтФормы.Активизировать("Наименование", 0);    

                        Исключение
                        КонецПопытки;

                    КонецЕсли;    
                Иначе
                    Сообщить("В справочнике вида """+ КонтФормы.Вид() +""" быстрый поиск невозможен.");

                КонецЕсли;
            КонецЕсли;
        Исключение
        КонецПопытки;

            
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
 
12

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Ёпрст 1036 16.07.13 14:04 Сейчас в теме
пихать весь справочник в тз и потом скармливать компоненте не есть гуд.
2. Ёпрст 1036 16.07.13 14:04 Сейчас в теме
3. unichkin 16.07.13 14:20 Сейчас в теме
На небольших справочниках работает неплохо. У меня самый большой - номенклатура - 4 тыс. элементов, время на формирование подбора ~0.3 сек.
В тз ищу одну строчку, заведомо уникальную. Но если результат запроса перед формированием списка загружать в ИТЗ, или список значений, мне кажется тормозить будет больше, нет?
4. selesta 16 27.07.13 22:45 Сейчас в теме
на скл можно передалть запрос? должно работать?
у меня пару справочников свыше 500 тыс. элементов (скл база) - есть шансы на нормальную работу?
или даже не пробовать?
5. unichkin 28.07.13 18:28 Сейчас в теме
Текст запроса написан для sqlite, на SQL не работал, скорее всего нужно будет переписать.
Свыше 500 тыс. - нет, даже не пробуйте.
Лучше переписать поиск из типовой, и передавать в запрос часть наименования СРАЗУ, чтобы отсеивать по LIKE.
Посмотрите пример отсюда: http://www.1cpp.ru/forum/YaBB.pl?num=1373266553
6. lelusha 06.02.14 22:22 Сейчас в теме
работает и под dbf и под скульную версию базы?
7. unichkin 07.02.14 00:04 Сейчас в теме
(6) lelusha, Ток dbf, читай шапку "В прилагаемом коде показан запрос, реализованный методами ВК 1SQlite, т.е. только для DBF." Но никто не запрещает перегнать под скуль, только надо учитывать, что это для небольших справочников, пост №3: "4 тыс. элементов, время на формирование подбора ~0.3 сек". Если больше - то читаем пост №5 и идем на http://www.1cpp.ru/forum/YaBB.pl?num=1373266553.
Вот так =)
9. Stæg 7 11.05.19 02:03 Сейчас в теме
(7)Пытаюсь реализовать полнотекстовый поиск в 1с 7.7 торговля и склад. Закинул dll в папку базы и скопировал выложенный текст в глобальный модель. В итоге пишет ошибку "Определения процедур и функций должны размещаться перед операторами основной программы" В чем может быть проблема?
10. acanta 67 11.05.19 02:21 Сейчас в теме
Скопированный текст следует размещать в глобальном модуле после глобальных переменных.
11. Stæg 7 16.05.19 00:05 Сейчас в теме
(10) Вставил после глобальных переменных, теперь появились другие ошибки
Ошибки
Оставьте свое сообщение

См. также

Мини-класс для непосредственного ввода в элементах диалога V7.7 51

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Работа с интерфейсом

Класс основан на баге платформы 7.7, является продолжением публикации http://infostart.ru/public/140861/ позволяет искать по наименованию в реквизитах типа справочник "а-ля снеговик".

26.06.2012    18282    139    Ёпрст    87       

Настройка содержимого обработки "Дополнительные возможности" индивидуально для каждого пользователя 6

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Работа с интерфейсом

При большом количестве внешних отчетов в обработке "Дополнительные возможности" пользователям трудно стало искать нужные отчеты, более того некоторые отчеты нужны были только определенным пользователям, а некоторым пользователям не нужно было в принципе видеть все, что содержалось в списке. В Итоге появилось желание настроить список отчетов для каждого пользователя индивидуально.

07.09.2011    5261    vlgogolev    5       

Вычисление определителей и обратных матриц 12

Инструменты и обработки no Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Универсальные обработки

Внешняя обработка для вычисления определителей и обратных матриц.

22.04.2011    7237    30    Serge_Renard    17       

Как раскрасить контрагентов в отчетах за 15 минут 80

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Работа с интерфейсом

Попросили меня как-то ввести «цветовую дифференциацию штанов» у контрагентов в базе 1С 7.7, да так, чтобы они и в печатных формах отчетов выводились соответствующим цветом. Например, чтобы можно было каких-нибудь «злостных» должников выделять красным, а особо важных – синим, а уже не актуальных – сереньким и т.п. И если раскрасить формы списков справочника и организовать выбор цвета с формы элемента справочника не особо напряжно (с FormEx’ом), то с отчетами хотелось бы сделать так, чтобы не прилагать «титанических» усилий по переписыванию и дописыванию разнообразных отчетов, где фигурируют контрагенты. И поэтому, немного подумав, поступил так…

06.12.2010    23143    venger    27       

Имитация бурной деятельности (шутка) 38

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Работа с интерфейсом

Как изобразить бурную деятельность программы для нежелательного контролера

01.12.2010    10914    vladismi    12       

ПрогрессБар в строке состояния 35

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Работа с интерфейсом

ПрогрессБар в строке состояния. Маленький, шустренький (без ВК)

13.11.2010    17752    via    19       

Замена элементов в реквизитах и проводках документов, реквизитах справочников и движениях регистров. (SQL) 15

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Чистка базы Поиск данных

Иногда возникает необходимость заменить один элемент справочника на другой по всей конфигурации. При этом нежелательно перепроводить документы. Эта разработка позволит проделать такую операцию на SQL-базах

26.10.2010    13970    292    MadDAD    17       

Web клиент к 7.7 80

Статья no Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Работа с интерфейсом

В качестве примера возможности использования API J1C предлагается демонстрация реализации web-клиента к 7.7

13.09.2010    18712    gildebrand    36       

Восстановление потерянных реквизитов документов v 7.7 7

Статья Системный администратор Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Поиск данных Администрирование данных 1С Тестирование и исправление

В ранее записанных и проведённых документах пропали неторые реквизиты. В результате в отчётах полный бардак. Как я решил эту проблему.

13.09.2010    10051    vladimir_makarov    8       

Обработка для поиска Контрагентов 9

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Поиск данных Обработка справочников Универсальные функции

Не первая и не последняя.. Не лучшая, и не худшая. Просто вариант поиска контрагентов по нескольким словам или их частям в наименовании.

19.05.2010    8644    108    aka AMIGO    7       

Поиск и замена дублирующихся элементов справочников, КОД ОТКРЫТ, для 7.7 44

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Бесплатно (free) Сервисные утилиты Поиск данных Универсальные обработки

1. Работа над обработкой продолжается. Критика (любая) принимается. 2. Для установки: 2.1 Переименуйте файл WithoutConf.exe_ в WithoutConf.exe и разархивируйте (запустите на выполнение). 2.2 Каталог DLL скопируйте в Вашу базу (копию !!!), каталог ExtForms в одноименный каталог Вашей базы. 3. Для открытия: Сервис Дополнительные возможности 1С:Студио: Отчёты и обработки Поиск и замена элементов справочников 4. В обработке использованы 1С++, FormEx, StrMatch

11.05.2010    20369    612    Незнайка    64       

1c v 7.7. Установка владельца для справочника, имеющего записи. 9

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Итак, в конфигурацию я должен был добавить новый справочник, и, самое странное, должен был поставить ему в подчинение уже существующий справочник, причем активно использующийся. Если делать это штатными средствами, 1с при сохранении конфигурации выдает сообщение, что справочник такой-то имеет записи и не может быть подчинен.

28.04.2010    7430    Майкопчанин    12       

Простое решение проблемы с казахстанской кодировкой 8

Статья Программист Нет файла v7.7 1cv7.md Казахстан Windows Бесплатно (free) Практика программирования Работа с интерфейсом

Известно, что для того, чтобы работать в 1С с казахскими шрифтами, нужно изменить кодировку в ОС. Иногда это может быть не очень удобно.

22.01.2010    13733    Gvozdod    3       

Поиск реализаций без выписаных Счет-фактур 1

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::ОУ 1С7:ТиС НУ Windows НДС Бесплатно (free) Поиск данных

Возникают случаи когда оператор не выписал счет-фактуру по реализации. Обработка выполняет поиск этих реализаций. Присутствует отбор по контрагенту и типу договора.

12.01.2010    7716    141    Maks_Alexey    10       

Работа с периодическими реквизитами 1С версии 7.7 при помощи прямых запросов. 74

Статья Программист Нет файла openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Описание структуры хранения периодических реквизитов, рассмотрены подробно несколько простых примеров использования прямых запросов при работе с периодическими реквизитами. Приведены несколько текстов прямых запросов для решения на мой взгляд распространенных задач.

23.12.2009    35613    glassman    11       

"Быстрый" выбор периода в журнале 14

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Всего одна функция глобального модуля и у вас в каждом журнале появиться возможность в 2 клика выбрать любой месяц.

09.12.2009    9900    mdbm    11       

Поиск ссылок прямыми запросами для SQL версии. 23

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Поиск данных

Поиск ссылок стандартным методом довольно долгая процедура. В этой обработке реализован обход метаданных для поиска реквизитов, которые могут содержать ссылку на искомый объект, составление и выполнение запросов по найденным таблицам. Для работы необходима компонента 1С++.

13.11.2009    12211    185    MadDAD    25       

Трансляция кириллических имен в латинский алфавит 6

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Универсальные обработки

Обработка преобразовывает фамилии имена из кириллицы в латинский алфавит, данная обработка очень удобна когда необходимо создать например почту т.е. Вы вписываете "Иванов Иван Иванович" получаете "IvanovII" или в зависимости от настройки "IvanovIvanIvanovich".

29.09.2009    11815    121    fAngel    9       

Обработки для печати и исправления реквизитов табличных частей документов (унив.) 29

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Обработка документов Поиск данных Тестирование и исправление

Обработка предназначена для печати и исправления реквизитов табличных частей документов. Вид документа выбирается из списка. Предусмотрен механизм множественного отбора для реквизитов табличной части. Возможно указать какие реквизиты печатаются, какие - нет. Обработка универсальная и работает в любой базе.

28.09.2009    12071    281    swimdog    7       

Журнал документов с индивидуальной настройкой периода для пользователей 0

Инструменты и обработки no Конфигурация (md, cf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Работа с интерфейсом

Позволяет использовать журналы документов с периодами индивидуальными для текущего пользователя.

02.09.2009    6071    19    try2007    34       

Альтернатива стандартному предупреждению(вопросу) 18

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Работа с интерфейсом Универсальные функции

Начальство решило, что на предупреждения оформляемые стандартными средствами 1С малоприметны... В результате родилась прикольная штучка... Вывод текста сообщения бАААААльшими буквами, цвет можно задавать. 7 кнопок видимость и текст задаются при вызове Возвращает текст нажатой кнопки..... ВК у нас не применяются...

28.08.2009    9111    59    nikakoy    29       

Тест группировок в Эксель. Для 1С 7.7 9

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel Работа с интерфейсом

Тестовая выгрузка справочника номенклатуры в Эксель с xls-группировками. (Такие плюсики слева от листа)

12.08.2009    10124    183    dav405    12       

[PDF Viewer] - Просмотр PDF в 1С 65

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Разработка внешних компонент Работа с интерфейсом

ActiveX-компонента для просмотра PDF. Позволяет сохранить в виде текста, картинки и PostScript. Реализованы механизмы поиска текста и печати.

15.07.2009    28275    865    Душелов    57       

Граф(ин) 7.7. 7

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Работа с интерфейсом

Что порождает чудовищ? 1С+Дракон или сны разума?

01.07.2009    12289    Арчибальд    10       

[ОБУЧАЛОВКА] Позиционирование на последнем элементе списка справочника 6

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Для журналов можно задать режим отображения при открытии журнала (в режиме 1С:Предприятие): Меню - Сервис - Параметры-Журналы - "При открытии жирнала переходить в конец = вКл". Вопрос: почему нельзя задать такой вариант для справочников?

30.06.2009    19932    CheBurator    11       

Замена значений справочников 13

Инструменты и обработки no Внешняя обработка (ert,epf) v77::БУ 1cv7.md Windows Бесплатно (free) Универсальные обработки Тестирование и исправление

Элементарная обработка позволяющая заменить одно значение справочника на другое везде, где оно присутствует (шапки и табличные части документов, владельцы справочников, ссылки в других справочниках, константах, и в проводках, где может присутствовать в виде субконто). Обработка предназначена для компоненты 7.7 Бухгалтерия.

23.06.2009    8830    224    Лев    8       

Часы в 1С 19

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Работа с интерфейсом

Пользователям понадобились часы при работе в терминальном доступе.

08.06.2009    11675    436    Vit aka proger    13       

Калькулятор "который умеет" (нужен ли он кому-нибудь, или пустая трата времени?) 8

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Универсальные обработки

Поздно было ...не спалось мучал вопрос...вот 1С вроде для учета создана... а как вот посчитать (ну приспичило в 1 час ночи такое выражение (456*(34/2,56)+ V(456/26+12*57)-((456+56/2,6)*4))"3 = ? (где V - это корень,а "- степень числа- добавил,что бы про ТАБЛО не упоминал) вернее ни как ? а как быстрее.

06.06.2009    13794    101    Tatitutu    3       

Удлинение строковых реквизитов справочников,документов за пределы 100 символов 2

Статья Программист Нет файла v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free) Работа с интерфейсом

Как сделать реквизит типа "Строка" длиной 250 символов? (без применения строк неограниченной длины)

29.05.2009    2740    mike65    9       

Обработки для просмотра таблиц, списков, справочников, документов, регистров. Групповая обработка справочников и документов. 38

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Инструментарий разработчика Универсальные обработки Работа с интерфейсом

Для работы мне нужен был ряд возможностей в 1С, которых я не нашёл в обработках в инете, хотя нашёл какие-то обработки. Пришлось написать эти обработки "для себя". Для того, чтобы ими могли пользоваться люди без особых знаний конфигураций 1С, мне пришлось сделать доработки "для людей", что сделало использование гораздо более удобным, в том числе и мне :о). Желаю успехов.

13.05.2009    16837    1034    legcc    16       

[IFilter] Поиск в содержании файлов из 1С (ВК, .NET) 14

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Поиск данных Разработка внешних компонент

Компонента для работы с фильтрами поисковых систем. Получает текст из файла по установленном в системе фильтрам. Индексирует и ищет файлы по их содержанию (аналог Desktop Search) Поддерживает *.doc, *.xls, *.txt, *.ppt. Дополнительные фильтры можно скачать с http://www.ifilter.org/Links.htm

24.03.2009    28582    141    Душелов    44       

Как найти новые документы автора, в т.ч. созданные программно 9

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Чистка базы Практика программирования Работа с интерфейсом

Как найти новые документы автора, в т.ч. созданные программно и не прописанные в журнале регистрации (v77). Передо мной встала такая задача: пользователь создал много новых документов обработкой в разных периодах, а потом захотел сделать откат назад. Делюсь, может кому-нибудь пригодится.

11.03.2009    13144    Shaman100M    16       

Перерасчет по конкретному виду расчета 14

Инструменты и обработки no Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Сервисные утилиты Универсальные обработки

Иногда нужно сделать перерасчет по выбранному виду расчета в текущем периоде журнала зарплаты по всем объектам. Данная обработка позволяет это сделать.

25.01.2009    8479    158    berator37    1       

Быстрое сохранение в Excel (автор romix) 8

Инструменты и обработки no Конфигурация (md, cf) v7.7 1cv7.md Windows Бесплатно (free) Разработка внешних компонент Загрузка и выгрузка в Excel Работа с интерфейсом

Помогает быстро сохранить печатные формы в формате Excel. Имеет смысл при сохранении больших отчетов, что обычно занимает немало времени.

25.12.2008    10851    285    kasperok    16       

Смотрелка движений документов по регистрам,Реестр документов 6

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ 1cv7.md Россия Бесплатно (free) Работа с интерфейсом

Как и написано - показывает, что документ двигает по ресурсам РЕГИСТРОВ. Заодно получился реестр документов с одиночными фильтрами. Теперь банановый, тьфу, теперь и с множественными фильтрами.

14.12.2008    6167    44    dav405    10       

Предупреждение о ближайших днях рождения сотрудников 8

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия Управление персоналом (HRM) Бесплатно (free) Универсальные обработки

Обработка сообщает о ближайших днях рождения. Старенькая обработка, но, может, кому-нибудь окажется полезной. Работает в 1С Бухгалтерии 7.7, однако нехитрыми манипуляциями можно подправить под другие конфигурации. Проста в использовании ;)

06.12.2008    7052    134    Струнин    8       

Распределение процентов по кредитам 2

Инструменты и обработки Бизнес-аналитик Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ Займы, кредит, лизинг Бесплатно (free) Универсальные обработки

Распределение % по кредитам с новой ставкой рефинансирования от 28.11.08 и возможными изменениями ст. 269 п.1 НК РФ

03.12.2008    7423    75    kivduts    2       

"Захват окон" - ActiveX-компонента для 1С 49

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Разработка внешних компонент Работа с интерфейсом

Захватывает открытые окна и помещает их в 1С, так же получает скриншот выбранного окна. Хотите играть в пасьянс в 1С, смотреть кино или просматривать секретные документы ;) и не светить эти окна на рабочем столе, тогда эта компонента для Вас :)

20.11.2008    20412    219    Душелов    64       

ЗиК: Исправление задвоенных шаблонов проводок 42

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК БУ Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Чистка базы Поиск данных Тестирование и исправление

Обработка предназначена для поиска одинаковых шаблонов проводок конфигурации Зарплата+Кадры 2.3, поиска и замены ссылок на один из них.

21.10.2008    15090    450    poppy    6