Преобразования цвета: RGB, Web, Hex, 1С

Публикация № 201708

Разработка - Работа с интерфейсом

цвет преобразование RGB colour

15
У вас есть поле "Цвет" на форме. А что дальше?..
Эта обработка и приведённые функции позволят легко манипулировать такими разными ипостасями понятия "Цвет". Очень простое, топорное и понятное, решение.

Понадобилось мне скомпоновать html с выбором цвета в диалоге. И, увы, не так просто оказалось преобразовать элемент стиля в 16-ричную строку. Конечно, есть функции для веб-разработчиков, и где-то на ИС я тоже выкладывал функцию из rgb в hex, но тут понадобилось более масштабно. Нарыл было //infostart.ru/public/115963/, но рано радовался - работает далеко не для всех случаев, а только для элементов стиля в определённых условиях. Никакие фокусы и преобразования не помогли, 1С упрямо поддерживала тот вид цвета, каким он родился изначально. Поэтому я озверел и воспользовался мировой паутиной, откуда вытащил таблицу соответствий. Состряпал функции. Для удобства тестирования обернул в обычную и управляемую формы.

Для тех, кто не может скачивать, публикую тут самое основное:


Функция ПрочитатьТаблицуЦветов(рНижнийРегистр=Ложь) Экспорт
   
тЦветов=Новый ТаблицаЗначений;
   
тЦветов.Колонки.Добавить("Название");
   
тЦветов.Колонки.Добавить("Красный");
   
тЦветов.Колонки.Добавить("Синий");
   
тЦветов.Колонки.Добавить("Зеленый");
   
тЦветов.Колонки.Добавить("Шестнадцатиричный");
   
мак=ПолучитьМакет("ТаблицаЦветов");
    Для
й=2 По мак.ВысотаТаблицы Цикл
       
#Если Клиент Тогда
           
ОбработкаПрерыванияПользователя();
       
#КонецЕсли
       
мргб=мРазложитьСтрокуВМассивПодстрок(мак.Область(й,2).Текст," ");
       
стро=тЦветов.Добавить();
       
стро.Название=мак.Область(й,1).Текст;
       
стро.Красный=Число(мргб.Получить(0));
       
стро.Синий=Число(мргб.Получить(1));
       
стро.Зеленый=Число(мргб.Получить(2));
       
стро.Шестнадцатиричный=мак.Область(й,3).Текст;
        Если
рНижнийРегистр Тогда
           
стро.Название=НРег(стро.Название);
        КонецЕсли;
    КонецЦикла;
    Возврат
тЦветов;
КонецФункции


Функция
ПолучитьЦветИзСтиляПлатформы(рЦветКакЭлементСтиля) Экспорт
Попытка
   
// спасибо за идею //infostart.ru/public/115963/, хотя работает только для случая таких стилей
   
т=Новый ТабличныйДокумент;
   
т.Область(1,1,1,1).ЦветФона=рЦветКакЭлементСтиля;
   
вф=ПолучитьИмяВременногоФайла("htm");
   
т.Записать(вф,ТипФайлаТабличногоДокумента.HTML);
   
// читаем грубо, без ДокументHTML
   
рКодПоиска="tr.R0 td.R0C0{ background-color:"; // если 1С изменит формат, эту строку придётся поменять
   
т=Новый ТекстовыйДокумент;
   
т.Прочитать(вф);
   
стро=т.ПолучитьТекст();
   
пози=Найти(стро,рКодПоиска);
    Если
пози<>0 Тогда
        Возврат
ВРег(Сред(стро,пози+СтрДлина(рКодПоиска),8));
    КонецЕсли;
    Возврат
"";
Исключение
   
Сообщить("ПолучитьЦветИзСтиляПлатформы, ошибка: "+ОписаниеОшибки(),СтатусСообщения.Важное);
    Возврат
"";
КонецПопытки;
КонецФункции


Функция
ПреобразоватьЦвет(рИсходныйЦвет,рВидИтоговогоЦвета,тЦветов="") Экспорт
Попытка
    Если
ТипЗнч(рИсходныйЦвет)=Тип("Цвет") Тогда
        Если
рИсходныйЦвет.Вид=ВидЦвета.ЭлементСтиля Тогда
           
стрЦвет=ПолучитьЦветИзСтиляПлатформы(рИсходныйЦвет); // вернёт hex, т.е. 16-ричный
           
Если не ПустаяСтрока(стрЦвет) Тогда
                Если
рВидИтоговогоЦвета=1 Тогда // нужен web-цвет
                   
Если ТипЗнч(тЦветов)<>Тип("ТаблицаЗначений") Тогда
                       
тЦветов=ПрочитатьТаблицуЦветов();
                    КонецЕсли;
                   
строц=тЦветов.Найти(стрЦвет,"Шестнадцатиричный");
                    Если
строц<>Неопределено Тогда
                        Возврат
строц.Название;
                    КонецЕсли;
                ИначеЕсли
рВидИтоговогоЦвета=2 Тогда // нужен RGB
                   
Если ТипЗнч(тЦветов)<>Тип("ТаблицаЗначений") Тогда
                       
тЦветов=ПрочитатьТаблицуЦветов();
                    КонецЕсли;
                   
строц=тЦветов.Найти(стрЦвет,"Шестнадцатиричный");
                    Если
строц<>Неопределено Тогда
                        Возврат Новый
Структура("Красный,Синий,Зеленый",строц.Красный,строц.Синий,строц.Зеленый);
                    КонецЕсли;
                ИначеЕсли
рВидИтоговогоЦвета=3 Тогда // нужен 16-ричный
                   
Возврат стрЦвет; // это он и есть
               
КонецЕсли;
            КонецЕсли;

        ИначеЕсли
рИсходныйЦвет.Вид=ВидЦвета.WebЦвет Тогда
           
// вытащим из скобок англоязычное написание цвета
           
стрЦвет=СокрЛП(Строка(рИсходныйЦвет));
           
пози1=Найти(стрЦвет,"(");
            Если
пози1<>0 Тогда
               
стрЦвет=НРег(СтрЗаменить(Сред(стрЦвет,пози1+1),")",""));
                Если
рВидИтоговогоЦвета=1 Тогда // нужен web-цвет
                   
Возврат стрЦвет; // это он и есть
               
ИначеЕсли рВидИтоговогоЦвета=2 Тогда // нужен RGB
                   
Если ТипЗнч(тЦветов)<>Тип("ТаблицаЗначений") Тогда
                       
тЦветов=ПрочитатьТаблицуЦветов(Истина);
                    КонецЕсли;
                   
строц=тЦветов.Найти(стрЦвет,"Название");
                    Если
строц<>Неопределено Тогда
                        Возврат Новый
Структура("Красный,Синий,Зеленый",строц.Красный,строц.Синий,строц.Зеленый);
                    КонецЕсли;
                ИначеЕсли
рВидИтоговогоЦвета=3 Тогда // нужен 16-ричный
                   
Если ТипЗнч(тЦветов)<>Тип("ТаблицаЗначений") Тогда
                       
тЦветов=ПрочитатьТаблицуЦветов(Истина);
                    КонецЕсли;
                   
строц=тЦветов.Найти(стрЦвет,"Название");
                    Если
строц<>Неопределено Тогда
                        Возврат
строц.Шестнадцатиричный;
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;

        ИначеЕсли
рИсходныйЦвет.Вид=ВидЦвета.Абсолютный Тогда
            Если
рВидИтоговогоЦвета=1 Тогда // нужен web-цвет
               
Если ТипЗнч(тЦветов)<>Тип("ТаблицаЗначений") Тогда
                   
тЦветов=ПрочитатьТаблицуЦветов();
                КонецЕсли;
               
отб=Новый Структура("Красный,Синий,Зеленый",рИсходныйЦвет.Красный,рИсходныйЦвет.Синий,рИсходныйЦвет.Зеленый);
               
мстроц=тЦветов.НайтиСтроки(отб);
                Если
мстроц.Количество()<>0 Тогда
                    Возврат
мстроц[0].Название;
                КонецЕсли;
            ИначеЕсли
рВидИтоговогоЦвета=2 Тогда // нужен RGB
                // фактически, он и есть
               
Возврат Новый Структура("Красный,Синий,Зеленый",рИсходныйЦвет.Красный,рИсходныйЦвет.Синий,рИсходныйЦвет.Зеленый);
            ИначеЕсли
рВидИтоговогоЦвета=3 Тогда // нужен 16-ричный
               
Если ТипЗнч(тЦветов)<>Тип("ТаблицаЗначений") Тогда
                   
тЦветов=ПрочитатьТаблицуЦветов();
                КонецЕсли;
               
отб=Новый Структура("Красный,Синий,Зеленый",рИсходныйЦвет.Красный,рИсходныйЦвет.Синий,рИсходныйЦвет.Зеленый);
               
мстроц=тЦветов.НайтиСтроки(отб);
                Если
мстроц.Количество()<>0 Тогда
                    Возврат
мстроц[0].Шестнадцатиричный;
                КонецЕсли;
            КонецЕсли;

        КонецЕсли;
// по вариантам видов цвета как типа Цвет

   
ИначеЕсли ТипЗнч(рИсходныйЦвет)=Тип("Строка") Тогда
       
// ищем во всех колонках таблицы, т.к. заведомо не знаем, какой это цвет
       
Если ТипЗнч(тЦветов)<>Тип("ТаблицаЗначений") Тогда
           
тЦветов=ПрочитатьТаблицуЦветов();
        КонецЕсли;
       
строц=тЦветов.Найти(СокрЛП(рИсходныйЦвет));
        Если
строц<>Неопределено Тогда
            Если
рВидИтоговогоЦвета=1 Тогда // нужен web-цвет
               
Возврат строц.Название;
            ИначеЕсли
рВидИтоговогоЦвета=2 Тогда // нужен RGB
               
Возврат Новый Структура("Красный,Синий,Зеленый",строц.Красный,строц.Синий,строц.Зеленый);
            ИначеЕсли
рВидИтоговогоЦвета=3 Тогда // нужен 16-ричный
               
Возврат строц.Шестнадцатиричный;
            КонецЕсли;
        КонецЕсли;

    КонецЕсли;

    Возврат Неопределено;
Исключение
   
Сообщить("ПреобразоватьЦвет, ошибка: "+ОписаниеОшибки(),СтатусСообщения.Важное);
    Возврат Неопределено;
КонецПопытки;
КонецФункции

Саму таблицу легко найти на сайтах наподобие http://www.cloford.com/resources/colours/500col.htm, скопировать и вставить в обычный моксель. Я, увы, закрыл страницу, откуда брал свою табличку, а повторно не нашёл... Кстати, по ссылке больше, чем у меня, но тамошнюю надо слегка причесать под вышеприведённое считывание.

Всё крайне кондово, но может пригодиться. Единственно, учитывайте, что лучше 1 раз прочитать таблицу соответствий и далее по ней искать. Ну и проиндексируйте по нужной колонке, исходя из ситуации.

Тестировалось на 8.2.17

 

 

 

15

Скачать файлы

Наименование Файл Версия Размер
ПреобразованиеЦветов
.epf 21,10Kb
23.09.13
70
.epf 21,10Kb 70 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Yashazz 2838 23.09.13 12:07 Сейчас в теме
Да, и ещё: для RGB коды можно использовать как числа, а можно как строки - смотрите сами, как кому удобнее.
2. OrsoBear 15.01.14 08:15 Сейчас в теме
Вот за код в описании огромное спасибо!
Часто приходится сначала скачать, а потом уже смотреть, что внутри.
miavolas; baton_pk; +2 Ответить
3. Yimaida 35 19.11.14 16:18 Сейчас в теме
Уважаемый автор, поменяйте в обработке кусок кода:

Попытка стро.Красный=Число(СокрЛП(мргб.Получить(0))) Исключение КонецПопытки;
Попытка стро.Синий=Число(СокрЛП(мргб.Получить(2))) Исключение КонецПопытки;
Попытка стро.Зеленый=Число(СокрЛП(мргб.Получить(1))) Исключение КонецПопытки;

у Вас перепутаны G и B составляющие цвета.

И еще, нет в макете цвета Зеленовато-лимонный (Lime), а может и еще каких.

А так поставил +, т.к. до этого не заморачивался работой с цветами, а тут вдруг пришлось. Идея делать через макет мне нравится, т.к. это самый правильный (на мой взгляд) способ получения значений из предопределенной таблицы. Только вот мне не понятно зачем было раскладывать строковое представление RGB, может их проще было бы в отдельных колонках хранить (и потом быстрее получать).
4. Yashazz 2838 19.11.14 17:13 Сейчас в теме
(3) Yimaida, ага, докопипастился я... Спасибо за поправку, отредактирую. Что касается раскладывания - честно, просто стрельнуло в одно место так сделать.

Недостающие цвета, подозреваю, появились не сразу, хотя может и я чего упустил.
5. dj_serega 367 13.03.15 11:58 Сейчас в теме
имхо, код страшный :( Не хочется даже читать что бы разобраться как работает.
Jonovich; Ivon; +2 Ответить
6. Ivon 638 15.03.16 11:50 Сейчас в теме
(5) dj_serega, У него во всех обработках такой код.
7. Yashazz 2838 27.04.16 15:43 Сейчас в теме
(6) Ivon, и это целенаправленно. Я всегда отличу свой код от чужого. Считайте это вариантом обфускации для защиты интеллектуального права)))
Ну и потом, так компактнее, а мониторы, знаете ли, не у всех 30-ти дюймовые.
9. Jonovich 26 01.11.16 23:10 Сейчас в теме
(5) dj_serega, Полностью согласен с тобой, вникать в решение смысла нет. Автор сего безобразия предлагает бредовую идею по причине:
1. Делать запись файла на диск, а затем читать и парсить файл... и все это только ради того, чтобы узнать RGB составляющие web-цвета... кошмарно и неоправданно, но если это не аргумент, то
2. Алгоритм не будет корректно работать для web-цветов, на то и придумали web-цвета чтобы определять их по идентификатору, а не составляющим RGB. При конвертации в HTML табличного документа с цветом WebЦвета.СветлоРозовый. в HTML получим tr.R0 td.R0C0{ background-color: LightPink; и в этом случае получим ошибку

Считаю более оптимальным решением брать цвета из заранее подготовленного макета. Также оптимально будет на основе его данных построить соответствие всех цветов, и при необходимости обращаться к нему по ключу. Выкладываю такой макет, со всеми цветами используемыми в 1С. Такой табличный документ получить труда не составит, если кому интересно:
1. Забиваем в табло "ЦветаСтиля", "WebЦвета" и "WindowsЦвета", останавливаемся на точке останова, выводим содержимое табло в табличный документ и сохраняем.
2. В цикле назначаем цвет фона ячеек строк табличного документа по указанным в строках именам цветов и сохраняем в *.xls
3. В EXCEL нехитрыми функциями VBA получаем значение и составляющие RGB цвета фона ячейки в строках листа.
Прикрепленные файлы:
Цвета 1С.mxl
10. Yashazz 2838 26.11.17 23:28 Сейчас в теме
(9) Ну, всё ж таки отвечу. Во-первых, уважаемый, вы невнимательно читали. Автор сего безобразия, если говорить о сохранении на диск, цитирует чужую идею и приводит ссылку на неё, прям там в комментарии, а в остальном аналогично Вам работает с табличным документом из макета. Невнимательно читаете, батенька. Во-вторых, если что не менее бредовое, так это предложенное использование экселя - это ограничивает нас виндой и установленным офисом, нуждой мочь запускать ком и в нём гонять vba-скрипты.
8. sound 529 12.09.16 13:00 Сейчас в теме
Пригодилось, спасибо. Какая-то у 1С дурка, на старых версиях платформы можно было в диалоге выбора цвета выбрать как Web цвет, так и абсолютный, сейчас только Web, нафига так сделано непонятно. Вернее понятно, что они все к вебу стремятся, но зачем для толстого клиента закрыли возможность выбора абсолютного цвета непонятно.
11. Yashazz 2838 27.11.17 22:41 Сейчас в теме
Кстати, немного в продолжение темы, раз уж наткнулся.

Преобразование из RGB в 16-ричный:
// строим представление в html
Попытка
	фд=Новый ФорматированныйДокумент;
	тфд=фд.Добавить("Текст",Тип("ТекстФорматированногоДокумента"));
	тфд.ЦветТекста=рЦветРГБ;
	хтмл="";
	фд.ПолучитьHTML(хтмл,Новый Структура);
Исключение
	Сообщить("Ошибка при построении служебного форматированного документа: "+ОписаниеОшибки(),СтатусСообщения.Важное);
	Продолжить;
КонецПопытки;				
// распознаём его и получаем цвет
Попытка
	рЧтение=Новый ЧтениеHTML;
	рЧтение.УстановитьСтроку(хтмл);
	пострДом=Новый ПостроительDOM;
	докДом=пострДом.Прочитать(рЧтение);
	знчАтрибута=докДом.Тело.ДочерниеУзлы[1].ПервыйДочерний.Атрибуты[0].Значение;
	рЦвет16ричный=СокрЛП(СтрЗаменить(СтрЗаменить(знчАтрибута,"color: ",""),";",""));
Исключение
	Сообщить("Ошибка при распознании содержания форматированного документа: "+ОписаниеОшибки(),СтатусСообщения.Важное);
	Продолжить;
КонецПопытки;
Показать


и преобразование из 16-ричного в RGB, соответственно,
рЦвет16ричный="#536ac2";
хтмл="<HTML><HEAD><META content=""text/html; charset=utf-8"" http-equiv=Content-Type><META name=GENERATOR content=""MSHTML 11.00.9600.18817""></HEAD>
|<BODY><P><FONT color="+рЦвет16ричный+">Текст<FONT</P></BODY></HTML>";
фд=Новый ФорматированныйДокумент;
фд.УстановитьHTML(хтмл,Новый Структура);
рЦветРГБ=фд.Элементы[0].Элементы[0].ЦветТекста;


Ну и в принципе, ясно дело, можно просто циклами от 0 до 255 нагенерить все 16-ричные по возрастанию, выполняя простой пересчёт между системами счисления)
12. qazaas 15.08.18 09:36 Сейчас в теме
НЕ РАБОТАЕТ!!
Проверял на платформе 8.3.11.2924, как на управляемых, так и на обычных формах.
Будьте добры, исправьте.
Оставьте свое сообщение

См. также

Альтернативный способ добавления элементов и реквизитов на формы 29

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 ERP2 УТ11 Россия Абонемент ($m) Работа с интерфейсом

Предлагаю альтернативный вариант добавления динамически создаваемых элементов и реквизитов на форму.

1 стартмани

09.09.2019    2326    4    bmk74    0       

Удобный выбор из таблицы/дерева в УФ 61

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом Разработка

Выбор из таблицы значений или дерева значений в выпадающем списке рядом с полем ввода - УФ, быстро и просто!

1 стартмани

12.08.2019    2862    4    Yashazz    18       

[Механизм интерфейса] Свой флажок (чекбокс) 109

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Создадим свой флажок для интерфейса, используем простой универсальный алгоритм.

1 стартмани

09.08.2019    4059    4    rpgshnik    37       

Отбор на управляемой форме из списка значений 41

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом Разработка

Пример простого удобного отбора любых данных ссылочного типа на управляемой форме. Работа обработки проверена на релизе: 1С:Предприятие 8.3.13.1513.

1 стартмани

09.08.2019    4167    4    nagaitseff    6       

Изменяющееся контекстное меню в 1С 8.3 44

Статья Программист Архив с данными v8 v8::УФ Абонемент ($m) Практика программирования Разработка Работа с интерфейсом

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    4196    1    signum2009    14       

"Мобильный ТСД" - инвентаризация и сбор штрихкодов для iOS и Android 21

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 v8::Mobile Розница УНФ ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Внешние источники данных Сканер штрих-кода Терминал сбора данных Работа с интерфейсом Мобильная разработка

Простой мобильный терминал сбора данных для iOS и Android, не требующий сложных настроек и установки дополнительных программ. Для выгрузки базы штрихкодов и загрузки собранных штрихкодов в документы учетной системы используется Яндекс Диск или облачный сервис и расширение конфигурации. Работает с конфигурациями Розница 2, УНФ 1.6, УТ 11, ERP, КА2.

3 стартмани

22.04.2019    9552    51    suepifanov    61       

Шпаргалка разработчика для работы с формами 23

Отчеты и формы Программист Архив с данными v8 Россия Абонемент ($m) Работа с интерфейсом

Сборник помогает быстро освоить встроенный язык и средства конфигурирования при разработке обычных и управляемых форм.

3 стартмани

31.10.2018    7797    68    ELAM    3       

Открывашка ячеек таблиц 85

Инструменты и обработки Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Глобальное сочетание клавиш для открытия объекта по ссылке из текущей ячейки любой таблицы в большинстве управляемых форм

1 стартмани

27.10.2018    9180    11    tormozit    28       

Визуализация событий на временной шкале средствами "Поле HTML документа" 165

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Интересный способ наглядно отобразить события на временной шкале. Например, может быть применен для красивого вывода документов по клиенту. Тестировалось на платформе 8.3.12.1469

1 стартмани

31.07.2018    13814    127    Plotks2017    24       

Продвинутое рисование в табличном документе (стрелок и не только) 73

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Практика программирования Работа с интерфейсом

Вспоминаем геометрию и основы компьютерной графики. Матрицы и аффинные преобразования на плоскости.

1 стартмани

24.07.2018    8038    16    WalterMort    27       

Работа с данными выбора 38

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    19507    13    kalyaka    15       

Управление состоянием формы через конечный автомат 81

Статья Программист Конфигурация (md, cf) v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

Взаимодействие пользователя с интерфейсом приводит к изменению состояния формы и её элементов. Элементы отражают текущее состояние формы через свойства: видимости, доступности, оформления, текста заголовка и т.д. Даже при небольшом количестве элементов количество возможных состояний формы может быть достаточно большим. Необходимость учета всех состояний формы порождает сложные алгоритмы настройки элементов. В статье рассматривается алгоритмическое решение перехода к состоянию формы с использованием функционального подхода на основе декларативного описания

1 стартмани

19.06.2018    9891    11    kalyaka    35       

Иерархическая диаграмма 42

Инструменты и обработки Программист Бизнес-аналитик Руководитель проекта Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Концепция диаграммы по иерархической структуре данных, например по номенклатуре (продажи или остатки на складах).

2 стартмани

17.06.2018    7121    14    DrAku1a    4       

Программная работа с графическими схемами. Готовое решение 39

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Универсальные обработки Работа с интерфейсом

Работоспособное, проверенное на практике, простое и удобное программное управление графическими схемами.

1 стартмани

18.02.2018    11356    16    Yashazz    13       

Тестирование интерфейса в обычном приложении 8.2 при помощи SikuliX 105

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Как же не хватает клиента тестирования на платформе 8.2. Не кликнешь на кнопку, не выберешь из списка, не проверишь видит ли надпись пользователь. Воспользуемся внешним инструментом SikuliX, который позволит нам протестировать функционал форм. Данный инструмент легко встраивается в линию сборки и может "дружить" с уже известным многим Open-source продуктами.

1 стартмани

03.01.2018    19523    2    kraynev-navi    40       

Программное формирование форматированной строки в стиле html+inline CSS 52

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом Инструментарий разработчика

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    19141    24    bonv    5       

Размеры управляемой формы 100

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом Универсальные функции

Как рассчитать ширину и высоту управляемой формы или отдельного элемента, чтобы адаптировать интерфейс программно при их изменении.

1 стартмани

08.10.2017    17520    46    json    8       

Программное создание элементов графической схемы (через XSLT) 57

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Встала как-то передо мной задача визуализировать определенный прикладной процесс, лучше всего для этого подходит графическая схема. Так уж вышло, что 1С по не понятным мне причинам не предоставила возможность программно работать с элементами графической схемы. Пришлось импровизировать.....

1 стартмани

20.07.2017    13839    49    lazarenko    16       

Расширенная настройка динамического списка УФ 115

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Работа с интерфейсом

Открывая управляемую форму выбора и не увидев там видимых в форме списка элементов, часто хочется узнать причину их отсутствия там, т. е. какой наложен отбор. Но стандартная настройка списка управляемой формы показывает только пользовательские настройки, скрывая от пользователя фиксированный отбор. Предлагаю вам расширение конфигурации с расширенной настройкой динамического списка, отображающей пользователю кроме пользовательских настроек еще фиксированные.

1 стартмани

31.05.2017    24099    143    tormozit    20       

Простой редактор плана помещения JavaScript 100

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования Работа с интерфейсом

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    14819    91    igel9780    16       

Настройка начальной страницы (Рабочего стола) 47

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом Рабочее место Универсальные обработки

Альтернатива стандартной настройке начальной страницы. В типовой доступны лишь те формы, что явно "разрешены" разработчиком в режиме конфигуратора. Эта обработка позволяет собрать "Рабочий стол" из любых подходящих форм в пользовательском режиме. Без программирования. БСП не используется. Не расширение. Универсальна, т.е. подойдет для любой конфигурации (в т.ч. самописной).

2 стартмани

19.10.2016    24128    186    Erne100    24       

[Расширение] Стартовые страницы. Автозапуск форм при старте 1С. (8.3.9+, без доработки конфигурации) 51

Инструменты и обработки no Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Уверен, что в большинстве случаев список справочников, отчетов, обработок (объектов 1С в целом), к которому обращаются пользователи после запуска конфигурации 1С, раз от раза меняется не сильно. Так почему бы немного не упростить процесс открытия часто используемых форм? Данное расширение позволяет настроить автоматическое открытие различных форм объектов сразу после запуска 1С. Список форм настраивается индивидуально для каждого пользователя. Работает на платформе 8.3.9, без доработки конфигурации.

1 стартмани

03.10.2016    15865    78    Artem-B    19       

Конструктор условного оформления 40

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Иногда требуется сделать отчет, который бы содержал в себе множество показателей. В таком случае в получившейся "портянке" показатели сливаются. Как один из вариантов решения (ну, кроме упрощения отчета) можно рассматривать раскраску показателей в индивидуальные цвета. После нескольких подобных случаев (особенно, когда в уже готовый отчет добавляются или убираются поля) сделал обработку, которая позволяет в режиме предприятия быстро подготовить болванку условного оформления для подобных отчетов.

1 стартмани

27.09.2016    12722    15    Fragster    6       

HTTP-сервис: отчеты [Расширение] 122

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    18850    125    Stepa86    15       

Простые радости жизни программиста 1С: выбор типа значения 51

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    38449    45    yuraos    17       

Визуальный редактор цветовых схем подсветки синтаксиса 1С + импорт схем Visual Studio 43

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Работа с интерфейсом

Данная обработка призвана облегчить настройку рабочего места программиста 1С, а именно улучшить визуальное восприятие кода, уменьшить утомляемость, и, как следствие, увеличить общую производительность труда!

1 стартмани

29.01.2016    11465    74    ram3    27       

Передача реквизитов объекта из основной формы в дополнительную и обратно на управляемых формах 91

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Работа с интерфейсом

Наверное, многие сталкивались с ситуацией, когда у некоего редактируемого объекта (справочник, документ, внешняя обработка) кроме основной формы нужно сделать парочку дополнительных, чтобы часть реквизитов заполнять в них, а потом возвращать заполненные значения в основную форму и в сам объект. И если бы речь шла об обычных формах, то проблемы бы и не было. Но в управляемых формах с этим возникает проблема, а в случае отказа от модальности она становится немного больше.

1 стартмани

02.11.2015    22165    8    Wolex    29       

Инструмент для создания веб приложений на основе 1С REST сервиса 67

Инструменты и обработки Программист Пользователь Приложение (exe) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика WEB Работа с интерфейсом

Обзор платформы-конструктора для создания веб-приложений, использующих в качестве источника базы данных 1С

1 стартмани

13.10.2015    21300    82    dmzubr    23       

Асинхронная загрузка данных на Управляемую Форму. Прогресс бар (УФ 8.3). Индикация состояния процесса 78

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Работа с интерфейсом Универсальные функции Внешние источники данных

Часто бывает, что возникает необходимость загрузить множество данных из разнообразных источников в определенную форму или рабочее место. В процессе загрузки пользователь в неведении — информация готовится или нет. Прием позволяет загружать данные из нескольких источников асинхронно, не блокируя форму\интерфейс, а также отображать ошибки и состояние прогресса. По мере готовности данных, они будут отображены на форме

1 стартмани

09.10.2015    28675    133    pbazeliuk    6       

Визуальный html редактор на управляемых формах 64

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB Работа с интерфейсом

Мы рассмотрим некоторые особенности и возможности подключения сторонних визуальных html редакторов на javascript - TinyMCE, CK Editor. С помощью приложенной обработки Вы сможете попробовать в действии полноценный и удобный визуальный html редактор, а при желании перенести подобный функционал к себе.

1 стартмани

30.09.2015    20659    183    ivanov660    26       

NativeDraw: Компонента рисования для 1С [V2.6.2] 106

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Windows Абонемент ($m) Разработка внешних компонент Работа с интерфейсом

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    39462    421    ПерваяСистема    140       

Универсальное настраиваемое рабочее место (Версия 2.0) 52

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Работа с интерфейсом Рабочее место

При работе очень часто штатные интерфейсы 1С бывают неудобны в силу разной специфики работы каждого пользователя, а также конфигурация обычно "обрастает" новыми обработками, отчетами, документами и справочниками, которые требуются для работы организации, а в стандартных меню их, естественно, нет. Это особенно относится к толстому клиенту (например, программы УПП, УТ10.3 и пр.). Делать свои интерфейсы - не всегда спасает: то, что нужно одному пользователю, другому совершенно не надо, даже если у них одинаковые функциональные обязанности. Открывать все через меню "Операции" тоже неудобно: у нас, например, за несколько лет работы добавилось столько нового и специфичного, что уже и не помнишь, что и для чего. Поэтому родилась идея сделать что-то удобное и универсальное, что и получилось в результате: пользователь сам, не прибегая к помощи программиста, может сделать удобное меню для себя и всегда изменить, если требуется. И без всяких изменений конфигурации...

3 стартмани

13.06.2015    11945    120    yuraskid    29       

Кнопки управления группировками табличного документа для управляемых форм 23

Инструменты и обработки Программист Внешний отчет (ert,erf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Универсальный механизм управления группировками табличного документа из управляемой формы

1 стартмани

02.06.2015    21606    31    unichkin    9       

Управляемая форма 1С 8.2 (8.3) – работа с деревом значений и таблицей значений. Часть I (Основы) 64

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Практика программирования Работа с интерфейсом

Как известно, в платформе 1С 8.1 не составляло никакого труда связать дерево значений с табличным полем на форме, единственное, что при этом нужно было не забыть, так это СоздатьКолонки(). В управляемом приложении 1С 8.2 (8.3) сделать это не так просто, как кажется на первый взгляд. В данной статье речь пойдет о программном создании дерева значений (таблицы значений) на управляемой форме в управляемом приложении 1С

2 стартмани

14.05.2015    69574    25    ll13    13       

[БП 3.0] [ЗУП 3.1 ] [БГУ 2.0] [УТ 11.4 ] [Расширения] Отключение регламента, оповещений и пр. 43

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::БУ БП3.0 Россия Windows Абонемент ($m) Работа с интерфейсом

Облегчить жисть БП 3.0 отключением всякого разного можно! Обработка позволяет отключить ряд оповещений, регламентных заданий (подробно описано в http://infostart.ru/public/303564/). Кроме того, позволяет более подробную настройку использования: - Регламентных и фоновых заданий; - Информации для форм; - Задач бухгалтера (где они есть). 21.01.2019 Версии с новым режимом совсместимости для основных конфигураций С удовольствием выслушаю (по возможности реализую) сообщество, что ещё можно сделать, чтобы программа работала по шустрее.

1 стартмани

04.03.2015    22311    131    Alex_E    17       

Подсистема "Планировщик" (версия 1.1) 138

Отчеты и формы no Конфигурация (md, cf) v8 1cv8.cf Россия Абонемент ($m) Практика программирования WEB Работа с интерфейсом

Конфигурация с подсистемой "Планировщик" (календарь). Бесплатная открытая версия для свободного использования не включает двустороннюю интеграцию с сервисом Google и Outlook.com.

5 стартмани

02.03.2015    55624    463    vandalsvq    62       

Анимация фона элементов на форме в стиле JQuery 74

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

К сожалению, у платформы 1С не так много красивостей, которыми обычно сдабривают формы обычных web-страниц. Нам недоступны эффекты JQuery и других javascript-библиотек. А иногда хочется сделать необычно, красиво и удобно.

1 стартмани

18.02.2015    13850    27    kraynev-navi    9       

Произвольное размещение и добавление кнопок на управляемых формах пользователем 37

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Иногда нам нужно чтобы пользователи могли сами рисовать себе формы в режиме 1С Предприятия, добавлять на них необходимые кнопки, назначать на эти кнопки объекты, размещать эти кнопки на форме произвольно. На управляемых формах даже в конфигураторе нет возможности произвольно размещать кнопки на форме. Чтобы исправить эту оплошность предлагаю вам свое решение данной проблемы.

1 стартмани

07.11.2014    16158    43    tvixeg    14       

[ТАКСИ] Шаблон внешней обработки...и не только 207

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Работа с интерфейсом Универсальные функции

Обработка предназначена для лентяев, к каковым, в первую очередь, отношу себя. Это в некотором роде шпаргалка в виде шаблона внешней обработки. Для создания новой копируем эту, удаляем ненужное, вставляем нужное - получаем результат. Чем ваять с нуля, каждый раз прописывая одно и то же, проще использовать заготовку, подобную этой... 24.11.2018 - Версия 1.21 - что-то добавил, что-то поправил.... 16.04.2019 - По просьбам трудящихся (немногочисленным, правда) оставил последнюю версию 1.21, дабы не было путаницы... 17.04.2019 - Версия 1.22 Вернул пример сохранения табличного документа в разных форматах и чтения DBF из версии 1.16 (как потерялось - сам не понял)

2 стартмани

22.09.2014    45991    687    Alex_E    27       

Визуализация и интерактивное изменение дерева значений. 68

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования Универсальные обработки Работа с интерфейсом

Обработка позволяет представить дерево значений в графическом виде, изменить его простым перетаскиванием блоков и выгрузить обратно в дерево значений.

1 стартмани

01.08.2014    16753    99    Belkin_Sergey    27       

Локализация конфигурации с помощью Google 13

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Обработка позволяет выполнять перевод интерфейсов в любой конфигурации 1С средствами Google. За основу взята обработка: http://infostart.ru/public/190890/

1 стартмани

06.06.2014    15403    32    x-tremeall    6       

Прогресс-бар длительных серверных операций (БСП) 45

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Простой и удобный шаблон для подобного рода задач в виде внешней обработки. Используется технология, предлагаемая в БСП (Библиотеке Стандартных Подсистем), практически без ноу-хау. Доработано таким образом, что обработка может быть как встроенной в конфигурацию, так и внешней.

1 стартмани

23.04.2014    24000    255    herfis    14       

Алгоритмы. Часть 1.1. Динамические соединения. 186

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Конспект первой лекции из свежего курса Принстонского университета США за 2014 год. Вольный перевод с английского с реализацией примеров на 1С. Курс в целом достаточно интересный и полезный для общего развития. Перевел и адаптировал только первую лекцию (в 1 части 11 лекций, 2 часть - еще не завершена преподавателями). Первоисточник на английском - https://www.coursera.org/course/algs4partI. Если сообщество посчитает материал полезным - займусь переводом следующих лекций (но это довольно трудоемко). Enjoy! :)

1 стартмани

04.04.2014    27752    23    Aleksey.Bochkov    33       

HTML редактор для 1С (1С HTML IDE) 74

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Работа с интерфейсом

Стандартный для 1с интерфейс не всегда может удовлетворить заказчика. В этом случае возникает необходимость реализовывать некоторые формы с использованием HTML. Как известно, встроенный в 1с объект "поле табличного документа" работает с использованием старых технологий. В результате, страничка, написанная в сторонней IDE в 1с может отображаться как угодно, но только не так как требуется. Когда у меня появилась задача сделать рабочий стол на HTML я сразу понял, что писать веб-код необходимо сразу на платформе 1с, что бы видеть результат Online и корректировать его. Для меня веб-программирование заканчивается знанием тега . Разнообразные глюки и особенности веб-среды мне просто неизвестны, поэтому сразу видеть что получается - самое то. Представляю один из результатов моей работы - IDE на управляемых формах, задача которой - генерация HTML документа, который будет правильно отображаться в 1с.

1 стартмани

20.02.2014    25470    170    Nikola23    28       

Изучаем мобильную платформу 8.3.4: геопозиционирование 155

Инструменты и обработки Программист Архив с данными v8 v8::Mobile Android Абонемент ($m) Работа с интерфейсом

Блеск и нищета geo-инструментов мобильной платформы 8.3.4. Пишем письмо турецкому султану. Но Чекин, как в Foursquare уже реально!

1 стартмани

14.02.2014    57099    198    barelpro    43       

Графический индикатор процесса в табличной части на Управляемых формах 50

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 Россия Windows Абонемент ($m) Работа с интерфейсом

Графический индикатор процесса на Управляемых формах, для любой ячейки в табличной части формы

1 стартмани

04.02.2014    18387    88    amyd    25