Подключение сканера штрих-кодов в 1С:Бухгалтерии 3.0

Публикация № 203591

Администрирование - Торговое оборудование - Сканер штрих-кода

сканер бухгалтерия редакция 3

22
Подключение сканера штрих-кодов в Бухгалтерии ред. 3.

Нам потребуется:
1. Бухгалтерия 3.0 (3.0.25.7)
2. Управление торговлей ред. 11 (11.1.2.9)
3. Установленный драйвер сканера.

Будем вносить изменения таким образом, чтобы работали все 3 типа сканеров, которые есть в УТ.
Можно конечно обойтись простым подключением через создание COM-объекта, но мы лёгких путей не ищем и будем делать всё как и принято в 1С, т.е. через жопу с задействованием внутренних универсальных механизмов.

Итак, чтобы подключить сканер нужно:
1. В общем модуле МенеджерОборудованияКлиентСерверПереопределяемый поправить функцию ПолучитьДоступныеТипыОборудования():

Функция ПолучитьДоступныеТипыОборудования() Экспорт

    СписокОборудования = Новый Массив;
    // Фискальные регистраторы
    СписокОборудования.Добавить(ПредопределенноеЗначение("Перечисление.ТипыПодключаемогоОборудования.ФискальныйРегистратор"));
    // Конец Фискальные регистраторы
    //~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ VladC# 01.10.2013
    СписокОборудования.Добавить(ПредопределенноеЗначение("Перечисление.ТипыПодключаемогоОборудования.СканерШтрихкода"));
    Возврат СписокОборудования;

КонецФункции


2. В том же модуле поправить функциюПолучитьОбработчикаДрайвера, т.е. нужно добавить строки относящиеся к санеру:

Функция ПолучитьОбработчикаДрайвера(ОбработчикДрайвера) Экспорт

    Результат = Неопределено;
    // Вызов метода выполнения команды у обработчика
    Если ОбработчикДрайвера <> Неопределено Тогда

    //~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ VladC# 29.09.2013
    // Сканеры штрихкода
    Если ОбработчикДрайвера = ПредопределенноеЗначение("Перечисление.ОбработчикиДрайверовПодключаемогоОборудования.Обработчик1ССканерыШтрихкода") Тогда
        Результат = ПодключаемоеОборудование1ССканерыШтрихкодаКлиент;
    ИначеЕсли ОбработчикДрайвера = ПредопределенноеЗначение("Перечисление.ОбработчикиДрайверовПодключаемогоОборудования.ОбработчикСканкодСканерыШтрихкода") Тогда
        Результат = ПодключаемоеОборудованиеСканкодСканерыШтрихкодаКлиент;
    ИначеЕсли ОбработчикДрайвера = ПредопределенноеЗначение("Перечисление.ОбработчикиДрайверовПодключаемогоОборудования.ОбработчикАтолСканерыШтрихкода") Тогда
        Результат = ПодключаемоеОборудованиеАтолСканерыШтрихкодаКлиент;
    КонецЕсли;

    ...


3. Из конфигурации УТ ред. 11 скопировать три общих модуля прямо из дерева конфигурации:
- ПодключаемоеОборудованиеАтолСканерыШтрихкодаКлиент
- ПодключаемоеОборудование1ССканерыШтрихкодаКлиент
- ПодключаемоеОборудованиеСканкодСканерыШтрихкодаКлиент

4. Из конфигурации УТ ред. 11 скопировать три общих формы настроек, тоже прямо из дерева конфигурации:
- ФормаНастройкиАтолСканерыШтрихкода
- ФормаНастройки1ССканерыШтрихкода
- ФормаНастройкиСканкодСканерыШтрихкода

5. Из конфигурации УТ ред. 11 скопировать иконку для отображения на форме настроек торгового оборудования (находится в общих картинках):
- ПодключаемоеОборудованиеСканерШтрихкода32

6. Создадим общий модуль, я назвал влОбщийМодуль (использование только на клиенте управляемого приложения), рекомендую сделать имя пока именно такое, потом сможете изменить.
В этом общем модуле нужно добавить процедуру:

Процедура ПодключитьСканер() Экспорт
    Массив=МенеджерОборудованияСервер.ПолучитьСписокОборудования(,,МенеджерОборудованияСервер.ПолучитьРабочееМестоКлиента());
    Для Каждого Стр из Массив Цикл
        Если Стр.ТипОборудования=ПредопределенноеЗначение("Перечисление.ТипыПодключаемогоОборудования.СканерШтрихкода") Тогда
            Идентификатор = Стр.Ссылка;
			
	    ПараметрыУстройства = МенеджерОборудованияКлиентПовтИсп.ПолучитьПараметрыУстройства(Идентификатор);
				
	    МенеджерОборудованияКлиент.ВыполнитьДополнительнуюКоманду("ПолучитьВерсиюДрайвера",,,Идентификатор,ПараметрыУстройства);
        КонецЕсли;
    КонецЦикла;
		
КонецПроцедуры



7. В модуле управляемого приложения, в процедуре ПриНачалеРаботыСистемы() добавить вызов ранее созданной процедуры:

Процедура ПриНачалеРаботыСистемы()

    // СтандартныеПодсистемы
    СтандартныеПодсистемыКлиент.ДействияПриНачалеРаботыСистемы();
    // Конец СтандартныеПодсистемы

    //РаботаСВнешнимОборудованием
    МенеджерОборудованияКлиент.ПриНачалеРаботыСистемы();
    //Конец РаботаСВнешнимОборудованием
    //~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ VladC# 02.10.2013
    влОбщийМодуль.ПодключитьСканер();

КонецПроцедуры



8. Все новые объекты конфигурации добавить в подсистему ПодключаемоеОборудование.

9. Для проверки, в справочнике номенклатуры например, создайте обработчик события формы элемента ВнешнееСобытие:

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
    Если Источник="BarCodeScaner" и Событие="BarCodeValue" Тогда
        Сообщить(Данные);
    КонецЕсли;
КонецПроцедуры


10. Сохраняемся, запускаем Бухгалтерию в пользовательском режиме. Идём в Администрирование -> Подключаемое оборудование.

11. Если рабочее место не выбрано, то выберите, затем слева щёлкните Сканеры штрихкода.

12. Добавьте сканер "АТОЛ: Сканеры штрихкода" (я отлаживал именно этот тип сканеров, можете выбрать свой) и установите в
нём галочку "Устройство используется".

13. Нажмите "Записать и закрыть", а потом нажмите "Настроить" и введите там необходимые настройки, порт, суффикс и т.д.,
настройки у всех разные, поэтому свои здесь приводить не буду, дабы не вводить в заблуждение.

14. Перейдите в справочник Номенклатуры, откройте форму элемента и сосканируйте любой штрихкод, должно появиться сообщение с
этим штрихкодом.

Ну вроде всё, ничего не забыл, надеюсь кому-нибудь поможет.

22

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. lihomanov 83 20.11.13 16:32 Сейчас в теме
Добрый день!
Очень полезная инструкция!

Все пункты выполнил в тесте драйвера штрих-код сканирует, но в справочнике номенклатуре нет, что сделал не правильно?
2. VladC# 63 20.11.13 17:13 Сейчас в теме
Спасибо, а настройки сканера в 1С такие же как в тесте драйвера? Подозреваю что у вас суффиксы не установлены.
3. lihomanov 83 20.11.13 17:31 Сейчас в теме
Можно немного по подробнее, опыта с штрих-кодами нет!
при сканировании штрих-код появляется в тесте оборудование
Прикрепленные файлы:
4. VladC# 63 20.11.13 18:15 Сейчас в теме
Покажите скриншот с отображенным штрихкодом в тесте драйвера.
5. lihomanov 83 21.11.13 05:23 Сейчас в теме
Вот что получилось!
Прикрепленные файлы:
6. VladC# 63 21.11.13 10:13 Сейчас в теме
в суффикс нужно добавить (10), т.е. там должно быть (13) CR, (10) LF
7. lihomanov 83 21.11.13 10:54 Сейчас в теме
Добрый день!
Подскажите где добавить суффикс ?
8. lihomanov 83 21.11.13 11:15 Сейчас в теме
Вот у меня параметры!
Прикрепленные файлы:
9. VladC# 63 21.11.13 11:28 Сейчас в теме
вот именно из этого списка, вы правильно открыли, когда выберете (10) LF, он у вас добавится к существующему и получится строка "(13) CR, (10) LF"
10. lihomanov 83 22.11.13 06:38 Сейчас в теме
Добрый день! Не работает! хотел спросить если штрих-код сканировать в блокноте он должен сканировать?
*Сканер Voyager 1250g USB
*Windows 7 Home
*Настройки сканера
Если подключить через USB то сканер работает как клавиатура, считывает в блокнот
Если подключен через USB настроен эмулятор COM работает как сканер, но в блокнот не считывает
*Тестирование
Тестировал на УТ 10.3 все работает ок.
11. VladC# 63 22.11.13 09:12 Сейчас в теме
(10) lihomanov, в блокноте сканер будет считывать только если подключен как клавиатура, через COM не будет. Сравните свои настройки сканера в УТ с настройками в бухгалтерии.
12. lihomanov 83 22.11.13 14:32 Сейчас в теме
Пробовал
1. Разные драйвера
2. Настройки заново
Мне кажется Процедура ВнешнееСобытие() не срабатывает!, что еще можно проверить!
13. lihomanov 83 22.11.13 14:34 Сейчас в теме
Конфа: Бухгалтерия предприятия, редакция 3.0 (3.0.24.12)
Платформа: 1С:Предприятие 8.3 (8.3.3.721)
14. VladC# 63 22.11.13 16:22 Сейчас в теме
Про 8.3 не знаю, не пробовал, да и сейчас уже нет возможности т.к. сканер отдал, может стоит пока попробовать на 8.2, я на 8.2 отлаживал? Как была создана процедура ВнешнееСобытие(), это точно обработчик события формы "ВнешнееСобытие", а не просто вручную созданная процедура?
15. lihomanov 83 22.11.13 17:51 Сейчас в теме
Попробовал на:
Платформа: 1С:Предприятие 8.2 (8.2.19.68)
Конфа: Бухгалтерия предприятия, редакция 3.0 (3.0.27.7)
Прикрепленные файлы:
16. lihomanov 83 22.11.13 18:20 Сейчас в теме
хотел уточнить, а какой драйвер надо было ставить?
17. VladC# 63 23.11.13 02:29 Сейчас в теме
(16) lihomanov, я на атоловском отлаживал.
18. lihomanov 83 23.11.13 07:08 Сейчас в теме
Добрый день! Попробовал на Атоловском драйвере, не чего не выходит!
Менял режим запуска: Тонкий клиент, Толстый клиент
Пробовал разные платформы, релизы, драйвера, компьютеры, но событие не срабатывает!!!
Прикрепленные файлы:
19. VladC# 63 23.11.13 10:29 Сейчас в теме
вот на этот вопрос ответьте: "Как была создана процедура ВнешнееСобытие(), это точно обработчик события формы "ВнешнееСобытие", а не просто вручную созданная процедура?"
20. lihomanov 83 23.11.13 15:06 Сейчас в теме
уже описывал выше, файл прикрепляю
Прикрепленные файлы:
21. VladC# 63 24.11.13 10:54 Сейчас в теме
посмотрел, сделано всё верно, проблема явно в настройках сканера в 1С, можно получить скриншот окна атоловского теста драйвера сканера с работающими настркойами и скриншот с настройками из 1с?
22. lihomanov 83 25.11.13 07:57 Сейчас в теме
Добрый день! Вот данные!
Прикрепленные файлы:
23. lihomanov 83 25.11.13 08:13 Сейчас в теме
Попробовал другую версию драйвера Атол
Прикрепленные файлы:
24. lihomanov 83 25.11.13 08:14 Сейчас в теме
Еще
Прикрепленные файлы:
25. VladC# 63 25.11.13 08:15 Сейчас в теме
Похоже что настройки в порядке, НО я увидел у вас ещё 2 других сканера, удалите их, на одном порту может сидеть только одно устройство, несколько сканеров в программе могут сидеть только в разных портах, либо они должны быть клавиатурные, так что лучше удалите, оставьте только атоловский.
26. lihomanov 83 25.11.13 08:20 Сейчас в теме
не помогло, удалил сканеры,оставил один
27. lihomanov 83 25.11.13 08:21 Сейчас в теме
у меня сканер штрих-кодов Voyager 1250g USB в режиме эмуляции COM-порта (USB Serial), настроен управляющий штрих-код «USB Serial» (TERMID130)
28. lihomanov 83 25.11.13 08:27 Сейчас в теме
На УТ 10.3 работает замечательно!
29. VladC# 63 25.11.13 08:35 Сейчас в теме
сделайте скриншот настроек, которые у вас находятся в меню Сервис->Параметры, вкладка Драйвер устройств ввода
30. lihomanov 83 25.11.13 08:52 Сейчас в теме
не понял, можно поточнее?
31. VladC# 63 25.11.13 09:38 Сейчас в теме
меню Сервис -> Параметры
32. VladC# 63 25.11.13 09:40 Сейчас в теме
вот
Прикрепленные файлы:
33. lihomanov 83 25.11.13 10:50 Сейчас в теме
открываю, ошибка
Прикрепленные файлы:
34. VladC# 63 25.11.13 11:07 Сейчас в теме
у меня платформа 1С:Предприятие 8.2 (8.2.19.68)
драйвер сканера 6.5.2.399

Может стоит платформу переустановить или драйвер другой взять, ещё может помочь копирование Scaner1C.dll из каталога атол в каталог bin платформы 1С.
35. lihomanov 83 26.11.13 07:15 Сейчас в теме
Добрый день! Не могу исправить данную ошибку
Прикрепленные файлы:
36. VladC# 63 26.11.13 07:35 Сейчас в теме
версия драйвера и платформы как у меня?
37. ToJIuK 17.02.14 19:14 Сейчас в теме
А как же быть потом с обновлениями? при каждом обновлении придется такое проделывать? Или можно по хитрому обновиться?
38. VladC# 63 18.02.14 01:55 Сейчас в теме
(37) ToJIuK, изменения, в основном, вносятся в те места конфигурации, которые меняются достаточно редко, поэтому их можно просто исключать из обновления и всё. Исключением будут только модули форм документов, да и то там изменений то совсем немного, лично мне это никак не мешает, обновляю регулярно и всё в порядке.
39. ToJIuK 23.02.14 09:59 Сейчас в теме
А вот сам Штрих код лучше добавить через добавление реквизита в номенклатуру или задействовать регистр ?
40. VladC# 63 23.02.14 10:47 Сейчас в теме
(39) ToJIuK, однозначно регистр
41. ToJIuK 25.02.14 19:06 Сейчас в теме
Тут недавно набрался смелости и начал делать все по плану.
взял Бух 3.0.29.8 (Знаю что отличается от описанной, но сказали что "изменения, в основном, вносятся в те места конфигурации, которые меняются достаточно редко, поэтому их можно просто исключать из обновления и всё")
Ут 11.1.2.9

Но сразу же столкнулся с проблемами:
1)пункт В общем модуле МенеджерОборудованияКлиентСерверПереопределяемый поправить функцию ПолучитьДоступныеТипыОборудования()
В ред.3.0.29.8 нет такого общего модуля, есть 2 разных МенеджерОборудованияВызовСервераПереопределяемый и МенеджерОборудованияКлиентПереопределяемый. При помощи поиска на названию функций нашел куда добавить 1 и 2 пункт. вроде все добавил запустилось . в меню Сервис-Параметр появилась вкладка . там все настроено как положено.

2) В обработку формы Элемента добавил как написано , но при сканировании она не отрабатывает. А просто набирает символы как при вводе с клавиатуры.
Что не так ?
Прикрепленные файлы:
42. ToJIuK 25.02.14 22:49 Сейчас в теме
Кое как добился чтобы срабатывала Процедура "Внешнее событие" , но даже она отрабатывает не корректно , Вместо Цифр штрихкода , в данные попадает номер сканирования (т.е если отсканировал ШК в первый раз то выходит "1", если 2-й ,то "2" и тд). Драйвер менял , что то ничего не помогает . Не могу ни как разобраться. Ни кто с таким не сталкивался?
43. VladC# 63 26.02.14 03:31 Сейчас в теме
(42) ToJIuK, в тесте драйвера всё работает?
44. ToJIuK 26.02.14 08:51 Сейчас в теме
(43) Да в тесте драйвера все нормально. Результата такой какой надо.
И ещё посмотрел как обрабатывается работа со сканером УТ 11! Там нет Процедуры "внешнееСобытие". Все делается через другую процедуру.
54. olbu 09.09.16 16:54 Сейчас в теме
(42) ToJIuK, Решили почему выводятся цифры 1,2,3...? Если - да, то может подскажете как это победить?
45. ToJIuK 28.02.14 07:11 Сейчас в теме
Единственное что получилось Это примерно вот так

В модуле обычного приложения

Перем Scaner Экспорт;  // 
 
...
 
Процедура ПриЗавершенииРаботыСистемы()
 
	// Показ финальной дополнительной информации
	Форма = Обработки.ДополнительнаяИнформация.Создать();
	Форма.ВыполнитьДействие();
	//
 
	Scaner = 0; // 
 
КонецПроцедуры
 
...
 
Процедура ПриНачалеРаботыСистемы()
...
	// 
	Попытка
		ЗагрузитьВнешнююКомпоненту("Scaner1C.DLL");
		//Сообщить("Внешняя компонента сканера штрих-кода успешно загружена");
        Попытка
			Scaner = Новый("AddIn.Scaner45");
			Scaner.OldVersion = 0;
			Scaner.AutoDisable = 1;
			Scaner.DataEventEnabled = 1;
		Исключение
			Сообщить("Объект не найден");
		КонецПопытки;
	Исключение
		Сообщить("Внешняя компонента сканера штрих-кода - Scaner1C.DLL не найдена");
	КонецПопытки;
	// 	
КонецПроцедуры // ПриНачалеРаботыСистемы()
...
 
Функция ОбработкаДанныхСканера(Источник,Событие,Данные) Экспорт
	Результат = "";
	Если Scaner.OldVersion <> 0 Тогда
		Результат = Данные;
	Иначе
		Результат = Scaner.ScanData;
	КонецЕсли;
	Scaner.DataEventEnabled = 1;
	Возврат СокрЛП(Результат);
КонецФункции
// 			
Показать


В документе (Справочнике)

Процедура ВнешнееСобытие(Источник, Событие, Данные)
 
	Если Источник = "BarCodeScaner" Тогда
		ШК = ОбработкаДанныхСканера(Источник,Событие,Данные);
		НайденаНоменклатура = Справочники.Номенклатура.НайтиПоРеквизиту("ХА_ШтрихКод",ШК);
		Если НайденаНоменклатура.Пустая() Тогда
			Возврат;
		КонецЕсли;
		ЭлементыФормы.Продукция.ДобавитьСтроку();
		ЭлементыФормы.Продукция.ТекущиеДанные.Номенклатура = НайденаНоменклатура;
		ЭлементыФормы.Продукция.ТекущиеДанные.Количество = 1;
		ПродукцияПродукцияПриИзменении("");
	КонецЕсли;
 
КонецПроцедуры // ВнешнееСобытие()
Показать



Но такое работает только в Обычном приложении . В управляемых формах почему то не работает, хотя я их и в модуль управляемого приложения засунул. но процедура "ВнешнееСобытие" не отрабатывает.
46. ducks01 20.05.14 13:48 Сейчас в теме
(45) ToJIuK, попробуйте добавить реквизиты формы:
  • ИспользоватьПодключаемоеОборудование - булево
  • ПоддерживаемыеТипыПодключаемогоОборудования - строка
а также следующие процедуры в модуль формы:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ИспользоватьПодключаемоеОборудование = Истина;	
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	МенеджерОборудованияКлиент.ПодключитьОборудованиеПриОткрытииФормы(ЭтаФорма, "СканерШтрихкода");		
КонецПроцедуры
Показать

Тогда сработает внешнее событие:
&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
    Если Источник="СканерШтрихкода" и Событие="ПолученШтрихкод" Тогда
	     Сообщить(Данные);	
    КонецЕсли;
КонецПроцедуры

Правда я использовал драйвер ScanOPOS

Спасибо автору за эту статью!
luch_09; Bukaska; +2 Ответить
49. Wall30 14.10.14 09:35 Сейчас в теме
(46) ducks01, да еще добавить Картинки "ПодключаемоеОборудованиеСканерШтрихкода32"(16)
47. piton66 2 09.06.14 15:34 Сейчас в теме
Ребята . кто пользовался дешевыми китайскими USB сканерами? Как они в работе и подключении к 1С? Проблем с ними нет?
48. ToJIuK 22.07.14 08:20 Сейчас в теме
(47) piton66, Если подключать их в режиме эмуляции клавиатуры с Атоловским драйвером(Старым) проблем не должно быть. Так как там все одинаково. А вот если пробовать подключить в режиме эмуляции COM порта то могут быть проблемы с драйверами на USB-COM.
50. Гость 27.10.14 08:51
Добрый день БП 3.0.36.15
Нифига не пойму, сделал все по описанию (с учетом уже текущей конфигурации). Но!
Подключаю сканер, но реквизит "Драйвер оборудования" пустой и не дает выбрать!
Установил под правами админа драйвер 1С и атоловский драйвер. Перенес драйверы и в папку Bin 1С, все равно пусто.
52. imispb 2 02.05.15 14:06 Сейчас в теме
(50) Гость,
реквизит "Драйвер оборудования" пустой и не дает выбрать!

Надо запустить процедуру МенеджерОборудованияВызовСервераПереопределяемый.ОбновитьПоставляемыеДрайвера(), я это сделал из внешней обработки, 1с рекомендует добавить данную строчку в процедуру запускаемую один раз при старте системы.
51. imispb 2 01.05.15 23:46 Сейчас в теме
На самом деле, можно сделать всё намного проще. У компании 1С есть Библиотека Подключаемого Оборудования(БПО). Заходим в бухгалтерию, смотрим в общем модуле МенеджерОборудованияВызовСервера в функции ВерсияБиблиотеки() версию БПО. Качаем с сайта 1С, где качаем обновления, такую же версию БПО или более новую. Берем её и просто объединяем с нашей конфигурацией по прилагаемой инструкции. В конце надо не забыть, запустить процедуру ОбновитьПоставляемыеДрайвера(), в инструкции это есть. Таким образом, я очень быстро прописал сканер в бухг. 3.0.
53. piton66 2 11.08.15 12:05 Сейчас в теме
Короче в режиме подключение в разрыв клавиатуры самый простой метод. Нужно только сам сканер настроить. ну чтобы нужную последовательность нажатий клавиш выдавал.
55. Galym77 10.11.17 04:20 Сейчас в теме
Распечатав ШК на этикетке через принтер печати шк сканер считывает не все штрих-кода при этом использую три вида сканера Линейнный Ханевел1250, Имидживый Моторола DS2208 и 2D сканер который считывает даже с экранов. Принтер модель ZEBRA 420. При этом сформированные и распечатанные эти шк из под УТ, Розницы эти сканера считывают на УРА. Куда копать подскажите
56. wmonref1 26.01.19 22:43 Сейчас в теме
Помогите пожалуйста:
Установил атоловские драйвера, платформа 8.3.13.1513, обычные формы.
В Сервис - Параметры отсутствует вкладка Драйвер. Как жить дальше?
Прикрепленные файлы:
57. VladC# 63 28.01.19 06:09 Сейчас в теме
(56) На обычных формах настройка драйверов торгового оборудования обычно осуществляется в меню Сервис -> Торговое оборудование -> Подключение и настройка торгового оборудования.
58. wmonref1 28.01.19 08:09 Сейчас в теме
(57) Дело в том что при загрузке Scaner1C.dll в меню Сервис - Параметры должна появится дополнительная вкладка для настройки ТО. Я думаю что дело в платформе, так как на других платформах (пр. 8.3.8) эта вкладка есть...
59. VladC# 63 28.01.19 12:52 Сейчас в теме
(58) Разрядность платформы и драйвера совпадает?
61. wmonref1 28.01.19 22:46 Сейчас в теме
(59)Платформа х64... Может в этом и проблема???
60. VladC# 63 28.01.19 12:53 Сейчас в теме
(58) просто установки драйвера недостаточно для появления вкладки, нужно чтобы он в 1с был подключен.
Оставьте свое сообщение

См. также

Как подключить сканер штрихкода 27

Статья Системный администратор Нет файла v8 Розница Розничная и сетевая торговля (FMCG) Россия Windows Бесплатно (free) Сканер штрих-кода

Собственно, решил написать все, что знаю про подключение сканера штрих-кода. На первый взгляд кажется все просто, а на итог можно долго провозиться. Особенно когда до этого имел дело только с 1С и не имел опыта работы с торговым оборудованием.

11.11.2019    5965    VachKirp    42       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Расширение конструктора мобильного рабочего места для варианта "клиент 1С+RDP" (для любых wi-fi терминалов). Экосистема решений Simple WMS 22

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8::УФ УУ Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Бесплатно (free) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Универсальные функции Мобильная разработка

Развитие проекта «Конструктор мобильного клиента на Android» https://infostart.ru/public/976636/ для устройств не на Андроиде (работающих в режиме RDP). В отличие от варианта Android работа на терминалах происходит в режиме 1С:Предприятие через RDP а конфигурации мобильных клиентов полностью совместимы для обоих версий. Т.е. конфигурация единая, создается один раз и ее может читать как Android -устройство, так и 1С-клиент на RDP без необходимости какой либо переделки.

05.02.2019    8041    informa1555    5       

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

Подключение сканера штрихкода к Бухгалтерии 3.0 19

Статья Системный администратор Программист Нет файла v8::БУ БП3.0 Россия БУ УУ Windows Оптовая торговля Учет ТМЦ Бесплатно (free) Сканер штрих-кода

Возникла потребность обеспечить идентификацию номенклатуры по штрихкоду. На складе уже было рабочее место с Бухгалтерией 3.0. Поиск по ключевой фразе «сканер ШК БП 3.0» выдал не так много результатов. На ИС была обнаружена статья от 2013 года, которая сейчас несколько устарела. В 2018 году процесс подключения сканера штрихкода стал существенно проще.

22.11.2018    8359    Dem1urg    19       

Штрих-кодирование без сканера с Barcode to PC 87

Статья no Нет файла v8 1cv8.cf Бесплатно (free) Сканер штрих-кода

Используйте свой телефон как сканер штрих-кода с бесплатной программой Barcode to PC.

12.11.2018    8190    BuriyLesha    14       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Подключение прайс-чекера ЗНАЙТ Z-Info к 1С в режиме Online 3

Статья Системный администратор Нет файла v8 УТ11 Розничная и сетевая торговля (FMCG) Россия Розничная торговля Бесплатно (free) Сканер штрих-кода

В статье рассматриваются особенности работы с прайс-чекером ЗНАЙТ Z-Info в типовой конфигурации "1С: Управление торговлей" редакция 11.1.2.18 (платформа 1С 8.2.19.80), когда база данных 1С хранится в СУБД Microsoft SQL Server, куда напрямую и подключается прайс-чекер для запроса информации.

06.07.2017    10582    user772738    0       

Сканер штрихкодов на Android смартфоне для 1С 91

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Розничная торговля Бесплатно (free) Сканер штрих-кода

Как сделать сканер штрихкодов из обычного Android телефона и привязать его к 1С.

07.05.2017    48739    tjurikov_ivan    22       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Настройка торгового оборудования в конфигурации "Управление торговлей" ред. 10.3 при работе в терминальном режиме 38

Статья Программист Нет файла v8::ОУ УТ10 Россия Розничная торговля Бесплатно (free) Сканер штрих-кода Терминал сбора данных Фискальный регистратор

У пользователей 1С:Управление торговлей, использующих терминальный доступ для работы в программе, могут возникнуть проблемы при подключении торгового оборудования. Эти проблемы связаны с тем, что в конфигурации УТ 10.3 настройки торгового оборудования хранятся с привязкой к имени компьютера, а работа в режиме терминального доступа означает, что у всех работающих с программой будет одно и тоже имя компьютера. В статье рассмотрим способы решения данной проблемы.

12.04.2017    26538    @lexandr    12       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Подключение сканера к 1С Предприятие 8.3 28

Статья Системный администратор Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Сканер штрих-кода

Подключение сканера к 1С Предприятие 8.3 (обычные и управляемые формы)

19.11.2014    62189    dchumak    27       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Подключение торгового оборудования по rdp. 87

Статья Системный администратор Программист Нет файла v8 КА1 УПП1 Россия УУ Windows Розничная торговля Бесплатно (free) ККМ Сканер штрих-кода

Задача следующая, есть две розничные точки и центральная оптовая. Пользователи работают в терминале на Win Server 2003, база находится на центральной точке, розничные подключаются по интернету. Необходимо подключить сканеры штрих-кода в центральной точке на складе и Сканеры и ФР в розничных точках. При чем в розничных точках один сканер должен переподключаться между кассовым узлом и компьютером в приёмке. Сканеры ШК - Datalogic QuickScan I QM2100 (беспроводной), Honeywell Eclipse 5145, ФР - Штрих-М-ФР-К. Все устройства с интерфейсом USB.

14.08.2013    123876    de0nis    37       

Эмуляция работы сканера штрих-кода. Настройка подключения сканера штрих-кода в 1С 7.7 и 1С 8. 86

Статья Системный администратор Нет файла v7.7 v8 1cv8.cf 1cv7.md Россия Windows Бесплатно (free) Сканер штрих-кода

Если под рукой нет сканера штрих-кода, а нужно проверить, отладить, работу программы. Работу сканера штрих-кода можно эмулировать с помощью программ. Описан пример эмуляции: настройка используемых программ и настройка подключения сканера штрих-кода в 1С 7.7 и 1С 8.

21.05.2013    80884    1st    29       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Подключение нескольких сканеров штрих-кода по rdp (win server 2003, 2008 х64 ) 1Сv8: Управление торговлей 10.3 62

Статья Системный администратор Нет файла v8 УТ10 Россия Windows Бесплатно (free) Сканер штрих-кода

Была задача: удаленные филиалы подключить по rdp к одному серваку под управление win 2008 и сканеры штрихкодов тоже, но они никак не хотели работать. То есть если работал один, остальные не работали.Ну и хотелось поделится опытом решения проблемы, вдруг кому то тоже поможет)))) Напишу сразу это решение проблемы для конкретного релиза УТ 10.3.3.3, на остальных не проверял может уже исправили в последующих.Просто конфигурация сильно переписанная и не обновляемая у нас))))

26.02.2013    32904    davlen    18       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

1С Переучет Android 27

Статья no Нет файла v8 1cv8.cf Бесплатно (free) Сканер штрих-кода

Приложение создано для удобного переучета товаров с помощью Android устройств с выгрузкой в 1С

31.08.2012    41995    bosterua    90       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Легкий способ подключения сканера штрих-кодов без установки драйвера 140

Статья Системный администратор Программист Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Сканер штрих-кода

Предлагаемое описание позволит подключить сканер штрих-кодов к любому решению на платформе 8.x - короткая подготовка и быстрое подключение.

21.08.2012    131931    bforce    73       

Подключение и настройка сканера штрихкодов 55

Статья no Нет файла v8 УТ10 Россия Windows Бесплатно (free) Сканер штрих-кода

Рассмотрен порядок подключения сканера штрих-кодов с USB интерфейсом (на примере Proton и Honeywell) используя ScanOPOS и обработку обслуживания торгового оборудования "1С: Сканер штрих-кода"

17.02.2012    180343    bodja_84    20       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Обслуживание торгового оборудования после обновления платформы в 1С: УТ 10.3 4

Статья Системный администратор Программист Нет файла v8 УТ10 Россия Бесплатно (free) Тестирование и исправление Сканер штрих-кода

Недавно назрела необходимость обновления платформы с 1С: 8.1 на 8.2.(13.219) на конфигурации Управление торговлей 10.3. Конвертация базы затруднений не вызвала, а вот справочник "Обработка обслуживания торгового оборудования" автоматически, разумеется, не отконвертировался. Собственно, из оборудования стоял сканер штрихкодов "Атол" и принтер печати этикеток "Зебра". Вопрос несложный, но вдруг кому-то поможет.

12.09.2011    5803    danny    9       

Twain для 8.2 17

Инструменты и обработки no Компонента, плагин (dll, vbs,..) v8 УТ10 Россия Бесплатно (free) Сканер штрих-кода

Архив служит для загрузки в двоичный макет - КомпонентаTWAIN.

28.03.2011    25582    494    yurowski    10       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Сканирование, сохранение и печать документов 29

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Печатные формы документов Сканер штрих-кода

Сканирование с использованием WIA, хранение в справочнике "Хранилище дополнительной информации" и печать из документов и справочников.

01.02.2011    27947    596    anig99    16