INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Платонов Сергей | Руководитель проектов | ООО «ЛАЙНЕТ»

«Об актуальных психологических и организационных проблемах взаимодействия заказчика и исполнителя. Функции Технического Заказчика в повышении эффективности взаимодействия при разработке и внедрении программных продуктов.»

1. Основные психологические и организационные препятствия перед разработчиками программного продукта со стороны заказчиков. 2. О «персонифицированном» управлении фирмой, как одном из самых распространённых препятствий в бизнесе. Возможные варианты их преодоления. 3. Место и роль технического заказчика при разработке программного продукта. 4. Задачи технического заказчика: обоснование задач и примерное направление их решения. 5. Система управления: субъект, объект и управленческие связи как целенаправленное организационное системно-сбалансированное регулирующее воздействие на объект управления. 6. Перечень актуальных вопросов для разработки и внедрения ПП. О критериях эффективности автоматизации управления. 7. О последовательности разработки и внедрения управленческого программного продукта. Алгоритм подготовки исходной информации, её анализа и разработки на этой основе программного продукта. 8. О целесообразности включения этапа ТЭО разработки программного обеспечения. Показатели и критерии оценки экономической эффективности. 9. АСУ «возрождает» утраченные функции экономистов, диспетчеров и замещает их ПО. Оценка текущего состояния и цепочка стратегического планирования. 10. А). Вопросы экономической целесообразности преобразования классического управления в АСУ. Б). О задачах автоматизации процесса разработки управленческого учёта – автоматизации Объекта управления. В) Упр.учёт, как система с обр. связью. Критерии и алгоритмы самооценки эффективности внедрения. О необходимости мониторинга качественных изменений.

Переключатель клавиатуры для 1С

Программирование - Внешние компоненты

11
Переключатель клавиатуры для 1С

Часто при сканировании сканером штрих кода с буквами бывает необходимо переключить язык на определенный. Для этого я использую dynwrap.dll. При этом в конфигурации прописываем, для версии 7.7:

//*******************************************
Процедура Раскладка(Кнопка)
    Если  Кнопка = "rus" тогда
        Wrapper.LoadKeyboardLayout(SRus, 1);
        Wrapper.ActivateKeyboardLayout(NRus, 0);   
    Иначеесли  Кнопка = "eng" тогда   
        Wrapper.LoadKeyboardLayout(SEng, 1);
        Wrapper.ActivateKeyboardLayout(NEng, 0);   
      ИначеЕсли Кнопка = "ukr" тогда   
          Wrapper.LoadKeyboardLayout(SUkr, 1);
        Wrapper.ActivateKeyboardLayout(NUkr, 0);   
    КонецЕсли;
КонецПроцедуры
//********************************************

Процедура ПриОткрытии() 
    Раскладка("eng");
КонецПроцедуры;

//Переключатель клавитуры   
Wrapper = createobject("DynamicWrapper");

Wrapper.Register("USER32.DLL", "ActivateKeyboardLayout", "i=ll", "f=s", "r=l");
Wrapper.Register("USER32.DLL", "LoadKeyboardLayout", "i=sl", "f=s", "r=t");
Wrapper.Register("USER32.DLL", "GetKeyboardLayoutName", "i=r", "f=s", "r=l");

SRus = "00000419";
SEng = "00000409";
SUkr = "00000422";


NRus = 1049;
NEng = 1033;
NUkr = 1058;

для версии 8.1 :

Процедура Раскладка(Кнопка)
    Если  Кнопка = "rus" тогда
        Wrapper.LoadKeyboardLayout(SRus, 1);
        Wrapper.ActivateKeyboardLayout(NRus, 0);   
    Иначеесли  Кнопка = "eng" тогда   
        Wrapper.LoadKeyboardLayout(SEng, 1);
        Wrapper.ActivateKeyboardLayout(NEng, 0);   
      ИначеЕсли Кнопка = "ukr" тогда   
          Wrapper.LoadKeyboardLayout(SUkr, 1);
        Wrapper.ActivateKeyboardLayout(NUkr, 0);   
    КонецЕсли;
КонецПроцедуры

Процедура ПриОткрытии() 
    Раскладка("eng");
 КонецПроцедуры  

//Переключатель клавитуры   
Wrapper = Новый COMОбъект("DynamicWrapper");

Wrapper.Register("USER32.DLL", "ActivateKeyboardLayout", "i=ll", "f=s", "r=l");
Wrapper.Register("USER32.DLL", "LoadKeyboardLayout", "i=sl", "f=s", "r=t");
Wrapper.Register("USER32.DLL", "GetKeyboardLayoutName", "i=r", "f=s", "r=l");

SRus = "00000419";
SEng = "00000409";
SUkr = "00000422";


NRus = 1049;
NEng = 1033;
NUkr = 1058;   

Очень помогает, если используется Code128

11

Скачать файлы

Наименование Файл Версия Размер
dynwrap.dll
.1245224758 36,00Kb
25.09.09
53
.1245224758 36,00Kb 53 Скачать

См. также

Комментарии
Сортировка: Древо
1. Огонек 22 29.05.13 18:15 Сейчас в теме
Спасибо автору, информация пригодилась в своей разработке.
Оставьте свое сообщение