Печать ценников и этикеток

Печать - Ценники

77
Печать ценников и этикеток разных размеров. Все настраивается.

Код открыт, можете править под себя как хотите. В УТ 10.2 много изменений поэтому на что-то может ругануться, например на "реестр напечатанных ценников".

Основана была на //infostart.ru/projects/1887/

Заказчику очень понравилось. Если предложите какой-то еще функционал, с удовольствием добавлю.

Возможности

Настройки: 

  • Выбор типа цены;
  • Выбор склада;
  • Дата формирования цены;
  • Округление цены;
  • Выбор валюты;
  • Настройка печати (ландшафт и портрет, масштаб, кол-во в строке и строк на странице, готовые шаблоны);

Опции:

  • Включение номенклатурной группы в наименование товара при печати;
  • Брать цену товара из документа "Реализация товаров и услуг";
  • Печать ценников по одному, если в документе количество номенклатуры больше одной;
  • Брать только ту номенклатуру. которая есть на остатке на сладе.

Работа с товаром:

  • Подбор по одному товару;
  • Подбор сразу нескольких товаров;
  • Поиск по штрикоду;
  • Добавление целой группы товаров по родителю;
  • Подбор из документов где есть товары;
  • Набитие товаров сканером ШК.
  • Удаление отдельно каждого товара;
  • Удаление всех товаров;
  • Переименование названия товара при выводе на печать;
  • двойным кликом по строке Вы снимаете этот товар с печати.

Реестра напечатанных ценников у Вас не будет, поэтому не описываю.

Не забываем ставить плюсики!

Добавлена версия 1.1:

  • Переработана таблица товаров.
  • Немного изменен интерфейс.
  • Добавлена возможность печатать только те ценники. которые есть на остатках. Для этого ставим галку "Только остатки по группе" и нажимаем "+All"  для выбора нужной группы (родителя) номенклатуры.

 

Добавлена версия 1.2:

  • Переработан интерфейс
  • Исправлена процедура получения остатков

 

Добавлена версия 1.2.1:

  • Мелкие исправления

 

 Добавлена версия под 10.3! Скажем спасибо Александру Фоломееву ака Novoross11

77

Скачать файлы

Наименование Файл Версия Размер
Печать ценников и этикеток 1.2.1
.1252658844 33,10Kb
10.04.13
646
.1252658844 33,10Kb 646 Скачать
Печать ценников и этикеток 1.2.1 ( 10.3 )
.1253600985 33,93Kb
10.04.13
512
.1253600985 33,93Kb 512 Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. slava-fa 03.09.09 10:37 Сейчас в теме
Заинтриговала обработка, но в УТП для Укр не пошла((
2. igyo 105 03.09.09 11:42 Сейчас в теме
(1) Ну я думаю там переделать не много :)
12. Hazer1 10.09.09 11:45 Сейчас в теме
УТ 10.3.7.8

{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(23,38)}: Переменная не определена (глТекущийПользователь)
Фирма = ПолучитьЗначениеПоУмолчанию(<<?>>глТекущийПользователь, "ОсновнаяОрганизация");
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(24,40)}: Переменная не определена (глТекущийПользователь)
ТипыЦен = ПолучитьЗначениеПоУмолчанию(<<?>>глТекущийПользователь, "ОсновнойТипЦенПродажи");
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(25,38)}: Переменная не определена (глТекущийПользователь)
Склад = ПолучитьЗначениеПоУмолчанию(<<?>>глТекущийПользователь, "ОсновнойСклад");
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(812,7)}: Переменная не определена (глТорговоеОборудование)
Если <<?>>глТорговоеОборудование <> Неопределено Тогда
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(814,9)}: Переменная не определена (глТорговоеОборудование)
Если <<?>>глТорговоеОборудование.ПолучитьТоварПоШтрихкоду(Данные, ТаблицаТоваров) Тогда
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(843,4)}: Переменная не определена (глТорговоеОборудование)
<<?>>глТорговоеОборудование.СканерПосылкаДанных(1);
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(23,10)}: Процедура или функция с указанным именем не определена (ПолучитьЗначениеПоУмолчанию)
Фирма = <<?>>ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, "ОсновнаяОрганизация");
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(24,12)}: Процедура или функция с указанным именем не определена (ПолучитьЗначениеПоУмолчанию)
ТипыЦен = <<?>>ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, "ОсновнойТипЦенПродажи");
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(25,10)}: Процедура или функция с указанным именем не определена (ПолучитьЗначениеПоУмолчанию)
Склад = <<?>>ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, "ОсновнойСклад");
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(260,12)}: Процедура или функция с указанным именем не определена (ПолучитьЦенуНоменклатуры)
Цена = <<?>>ПолучитьЦенуНоменклатуры(ЗначениеВыбора,, ТипЦены, ДатаФормирЦен, ЕдиницаЦены, ВалютаЦены);
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(282,14)}: Процедура или функция с указанным именем не определена (ПолучитьЦенуНоменклатуры)
Цена = <<?>>ПолучитьЦенуНоменклатуры(ПередающаяСтрока.Номенклатура,, ТипЦены, ДатаФормирЦен, ЕдиницаЦены, ВалютаЦены);
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(330,12)}: Процедура или функция с указанным именем не определена (ПолучитьЦенуНоменклатуры)
Цена = <<?>>ПолучитьЦенуНоменклатуры(Товар,, ТипЦены, ДатаФормирЦен, ЕдиницаЦены, ВалютаЦены);
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(377,15)}: Процедура или функция с указанным именем не определена (ПолучитьЦенуНоменклатуры)
Цена = <<?>>ПолучитьЦенуНоменклатуры(Товар,, ТипЦены, ДатаФормирЦен, ЕдиницаЦены, ВалютаЦены);
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(413,13)}: Процедура или функция с указанным именем не определена (ПолучитьЦенуНоменклатуры)
Цена = <<?>>ПолучитьЦенуНоменклатуры(ПереносимаяСтр.Товар,, ТипЦены, ДатаФормирЦен, ЕдиницаЦены, ВалютаЦены);
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(454,13)}: Процедура или функция с указанным именем не определена (ПолучитьЦенуНоменклатуры)
Цена = <<?>>ПолучитьЦенуНоменклатуры(Строка.Номенклатура,, ТипЦены, ДатаФормирЦен, ЕдиницаЦены, ВалютаЦены);
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(830,15)}: Процедура или функция с указанным именем не определена (ПолучитьЦенуНоменклатуры)
Цена = <<?>>ПолучитьЦенуНоменклатуры(Товар,, ТипЦены, ДатаФормирЦен, ЕдиницаЦены, ВалютаЦены);
{Обработка.ПечатьЦенниковИЭтикеток.Форма.Основная(776,8)}: Процедура или функция с указанным именем не определена (ОкруглитьЦену)
Если <<?>>ОкруглитьЦену(ВыбЗапр.ФактическаяЦена, ТипыЦен.ПорядокОкругления, ТипыЦен.ОкруглятьВБольшуюСторону) <> ВыбЗапр.ЦенаНаЦеннике тогда
3. Трактор 1162 03.09.09 22:03 Сейчас в теме
Не запускал, только глянул код. На первый взгляд весьма достойная работа.
4. igyo 105 04.09.09 04:05 Сейчас в теме
Спасибо, сегодня буду дорабатывать, заказчик попросил добавить еще одну фишку. К вечеру или завтра выложу новую версию.
5. igyo 105 04.09.09 08:23 Сейчас в теме
Новая версия ждет Вас! Качать обязательно! Много исправлено и доработано.
6. betepon 70 04.09.09 11:25 Сейчас в теме
Вопрос. Как вы решаете проблему с печатью ценников на непрерывной ленте с использованием термопринтера.
1С выдает принтеру данные постранично. Когда принтер начинает искать конец страницы на непрерывной ленте...
7. igyo 105 04.09.09 12:36 Сейчас в теме
На термопринтере мы не печатаем этой обработкой.
8. igyo 105 08.09.09 08:17 Сейчас в теме
Доступна новая версия. Все качаем и наслаждаемся!
9. shtucer-igor 09.09.09 10:11 Сейчас в теме
красиво и интерестно
немогу скачать :( может кто то на мыло скинуть ? shtucer-igor@mail.ru
10. personazh 09.09.09 11:57 Сейчас в теме
Насколько я понял, эта обработка является немного измененным вариантом http://infostart.ru/projects/1887/ Неплохо бы указать ссылку на первоисточник в описании.
11. igyo 105 10.09.09 04:55 Сейчас в теме
Возможно, я ее делал год назад и использовал разные приемчики.
13. igyo 105 11.09.09 06:31 Сейчас в теме
Я ж писал что работает под 10.2 и предупредил что есть изменения в конфе.
14. shtucer-igor 11.09.09 12:54 Сейчас в теме
очень заинтерисовало
а тоже самое под 10,3 можно ?
15. Петька77 13.09.09 12:21 Сейчас в теме
Не знаю ошибка или нет - при заполнении из документа не контролирует штрихкоды остальных позиций, тупо подставляет из тех что проверил, возможно потому что по 10,3 юзаю (((.Скорее всего касается внутренних кодов, сгенерированых 1С, хотя закономерности пока не нашел.
16. Novoross11 18.09.09 20:25 Сейчас в теме
Доработал, теперь работает на релизе 3.7.8. Правда сканер ШК не могу проверить, т.к. нет сканера. Куда тут выложить?
17. igyo 105 20.09.09 12:01 Сейчас в теме
Кидай мне код, выложу новую поправленую версию...
18. yakutin 22.09.09 14:41 Сейчас в теме
Здравствуйте igyo! У меня к Вам есть интересное предложение. Поговорим? yakutin33@mail.ru
19. zenz 22.09.09 23:15 Сейчас в теме
1.Дата документа из которого печатаются цены в формы ценников не помешала бы.
2. Выбор что печатать - краткие или полные наименования
20. igyo 105 23.09.09 05:22 Сейчас в теме
zenz: 1 - ценник получается заграможденным, заказчику это не надо было, хотя согласен, было бы удобнее. 2 - печатем только краткие наименования так как полные слишком большие и будут не влазить в ценник, а если уменьшать шрифт то убдет очень мелко. Собственно для этого и была сделана возможность переименования наименования, дабы сократить длинные названия убрав то что не нужно на ценнике.
21. Novoross11 23.09.09 08:34 Сейчас в теме
Можно еще сделать, чтобы на весовой товар цену печатать "за 100 гр.", а также добавить параметр ПЛУ (код товара в весах) в макет ценника.
22. Novoross11 23.09.09 19:49 Сейчас в теме
Для более корректной работы предлагаю еще заменить процедуру "ТоварыВыбор" следующим кодом:

Процедура ТоварыВыбор(Элемент,ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
Если Колонка.Имя="Выб" Тогда
ВыбраннаяСтрока.Выб = Не ВыбраннаяСтрока.Выб;
КонецЕсли;

Если Колонка.Имя="КолВо" Тогда
Если ВвестиЧисло(ВыбраннаяСтрока.КолВо,"Кол-во ценников для печати",10,) Тогда
Если (ВыбраннаяСтрока.КолВо=0) или (ВыбраннаяСтрока.КолВо<0) Тогда
Товары.Удалить(ВыбраннаяСтрока);
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецПроцедуры
23. igyo 105 01.10.09 05:49 Сейчас в теме
Всем спасибо за спасибо :) Скоро выйдет версия под новые релизы конфигураций, а именно: Розница, УТ, УПП, КА, может и Бухгалтерию.

Натолкнула данная обработка.
24. standart 05.11.09 08:52 Сейчас в теме
24. Обработка хорошая, но не работает с товарами у которых есть характеристики (Цвет, рост, размер и т.д.). Не переносится цена из документов и объединяются товары по наименованию, но с разными характеристиками. Может доработаете в будущем?
25. nfoc 02.12.09 01:22 Сейчас в теме
Подойдет для 1с предприятие 8.1 базовая?
26. provnick 08.12.09 10:14 Сейчас в теме
Папка PrintFormsCennikEtiket в каталоге базы и формы там, но
Предупреждение("Не обнаружено ни одной печатной формы!!!
|Проверьте правильность установки обработки!!!
Прошу помочь
27. provnick 08.12.09 10:26 Сейчас в теме
28. provnick 12.12.09 10:16 Сейчас в теме
Не работает в SQL, подскажите пож. как прописать пути для другого каталога?
29. provnick 12.12.09 22:40 Сейчас в теме
Так и не дождался помощи, пришлось самому решать, если автор не против, могу выложить для обсуждений и дополнений
Галина1976; +1 Ответить
30. provnick 13.12.09 22:10 Сейчас в теме
Тихо сам с собой веду беседу, дело в том, что обработку эту не стал скачивать, а пользовался предыдущей версией, а там каталог форм был привязан к файловому варианту, теперь все понятно, новый вариант уже открывается по другому
31. Dosaev 19.01.10 00:16 Сейчас в теме
добрый день, не могу скачать ... кинь те люди добрые в личку кто может поделиться... плиз...
32. odin_wolk 04.06.10 15:23 Сейчас в теме
Было бы хорошо если работало для Украины и выводило две цены на ценник
33. mihenius 86 11.06.10 18:50 Сейчас в теме
УТ 10.3.6.8
Версия для УТ

{Форма.Основная(685)}: Деление на 0
ЦенаВалютная=ЦенаРублевая*КурсВалютыВыбран.Кратность/КурсВалютыВыбран.Курс;
34. mihenius 86 11.06.10 18:51 Сейчас в теме
Поспешил )
Не заполняются значениями по умолчанию валюта и склад.

Всего лишь )
35. Iwan777 21.07.10 19:45 Сейчас в теме
Подскажите пожалуйста, как установить?
УТ 10.3.11.4
Выбираю Сервис->Внешние печатные формы и обработки->Внешние обработки
далее выбираю файл и выдаёт ошибку "Выбранный файл не является внешней обработкой. Либо, данная обработка не предназначена для запуска в этой конфигурации"
zombi555; lsm22; +2 Ответить
36. lsm22 08.08.10 11:08 Сейчас в теме
Подскажите пожалуйста, как установить? на
"Управление торговлей", редакция 10.3 (10.3.8.9)
ошибка {Справочник.ВнешниеОбработки.Форма.ФормаЭлемента(189)}: Ошибка при вызове метода контекста (Создать): Ошибка при выполнении файловой операции
"Выбранный файл не является внешней обработкой. Либо, данная обработка не предназначена для запуска в этой конфигурации" :(
37. lsm22 08.08.10 11:16 Сейчас в теме
1С:Предприятие 8.1 (8.1.15.14)
Подскажите пожалуйста, как установить? на
"Управление торговлей", редакция 10.3 (10.3.8.9)
ошибка {Справочник.ВнешниеОбработки.Форма.ФормаЭлемента(189)}: Ошибка при вызове метода контекста (Создать): Ошибка при выполнении файловой операции
"Выбранный файл не является внешней обработкой. Либо, данная обработка не предназначена для запуска в этой конфигурации"
38. vt007 08.09.10 16:07 Сейчас в теме
А можно попросить автора поправить обработку под 8.2 Розница ?
Очень хочется ценники нормальные напечатать...
42. malikov_pro 02.11.10 13:28 Сейчас в теме
(38) В 1С:Розница достаточно развитый механизм печати этикеток, с возможностью из пользовательского интерфейса изменения шаблонов этикеток
39. vt007 08.09.10 20:22 Сейчас в теме
Попробовал запустить в 8.2 УТ 10.3, предварительно сконвертив встроенными средствами 1С.
При попытке добавления номенклатуры, любым способом, выдает ошибку:
{Форма.Основная.Форма(359)}: Значение не является значением объектного типа (КолВо)
НайденнаяСтрока.КолВо = НайденнаяСтрока.КолВо+1;
Как можно поправить ?
40. neonzzz 11.09.10 07:48 Сейчас в теме
У меня в 10.3 буквы вместо шк баркод установлен
41. malikov_pro 02.11.10 13:25 Сейчас в теме
43. Kvint77 29.04.11 17:25 Сейчас в теме
Здравствуйте! У меня при попытке загрузить обработку ошибка "Выбранный файл не является внешней обработкой. Либо, данная обработка не предназначена для запуска в этой конфигурации". 1С 8.2 (8.2.13.205) УТ 2.3.3.4. Подскажите,что не так делаю?
45. Alex_Pet 21.09.11 09:05 Сейчас в теме
(43) Открыть в конфигураторе, переконвертировать и сохранить.
Но под 8.2 KA не работает.
46. 28.11.11 10:41 Сейчас в теме
спасибо тебе добрый человек!
48. dsadsadsa 21.03.12 08:10 Сейчас в теме
Отличная обработка! Попробуем.
49. bvk 18 22.03.12 19:52 Сейчас в теме
Не работает в 10.3. Обидно, хотя в описании написано.
50. smirnoffs 20.06.12 13:07 Сейчас в теме
В конфигурации УТП для Укрины обработка не работает :(
Оставьте свое сообщение