INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Назаров Алексей | Заместитель ИТ- директора | ПАО «Группа компаний ПИК»

«Открытая экосистема 1С в самом крупном девелопере России и Европы. Как быть на острие технологий?»

1. Бюджетирование, контроль проектирования, производство, строительство, обслуживание и многое другое. Все это на 1С? Да. Общая IT архитектура крупнейшего строительного холдинга. 2. Как сэкономить миллиард при помощи 1С? Проект централизованной номенклатуры. 3. 1С на стройке и управление мотивацией рабочего: Мобильное приложение на 1С: “ПИК-Строитель”. 4. Как 1С подружил AD с G-Suite и корпоративными системами. 5. Сердце финансов “1С Единая Финансовая Система” и собственный движок согласования “1С Система Управления Процессами”. 6. Электронный документооборот(электронные КС-2,3 и акты), собственный удостоверяющий центр и как это помогло 1С. 7. Консолидация бухгалтерских данных холдинга в онлайне из множества разных конфигураций и баз данных: “1С Хранилище Консолидированных Данных”. 8. 1С:ERP как целевая система для всех производств холдинга - это возможно?

Загрузка данных из ТСД с возможностью создания (определения) товаров с неизвестным штрихкодом + очистка справочника после загрузки.

Оборудование - Терминал сбора данных

3
Загрузка данных из ТСД с возможностью создания (определения) товаров с неизвестным штрихкодом + очистка справочника после загрузки.

Обработка позволяет по время загрузки создать (определить) товар для неизвестных штрихкодов. Тестировал на ТСД Opticon SMART с MobileLogistic: Сбор Данных.

В архиве приложено два файла:

  1. Обработка взаимодествия с ТСД от Атол;
  2. Обработка Загрузка данных из ТСД;

Для возможности очистки ТСД после загрузки необхтдимо в обработку ТОСервер добавить функцию:

Функция ОчиститьТаблицуТСД(Идентификатор)Экспорт

	Обработка = Неопределено;
	Объект    = Неопределено;
	Результат = ПолучитьОбъектДрайвера(Идентификатор, Обработка, Объект);

	Если НЕ ЗначениеЗаполнено(Результат) Тогда
		Результат = Обработка.ОчиститьТаблицу(Объект);
		мОписаниеОшибки = Объект.ОписаниеОшибки;
	Иначе
		мОписаниеОшибки = ПолучитьТекстОшибкиПодключенияТО("ТСД");
	КонецЕсли;

	Возврат Результат;

КонецФункции
В обработке заполнения табличной части "Загрузка данных из ТСД" в процедуре "Инициализировать" убрать комментарий со строк:
	//Очистка	
	//Текст = "Желаете очистить ТСД?";
	//Режим = РежимДиалогаВопрос.ДаНет;
	//Ответ = Вопрос(Текст, Режим);
	//Если Ответ = КодВозвратаДиалога.Да Тогда
	//	Результат = ПолучитьСерверТО().ОчиститьТаблицуТСД(Терминал);
	//	Ошибки = ПолучитьТекстОшибкиТСДТО(Результат);
	//	Если НЕ ПустаяСтрока(Ошибки) Тогда
	//		Сообщить("Не удалось очистить данные:" + Символы.ПС + Ошибки);	
	//	КонецЕсли;
	//КонецЕсли;
	//
 
3

Скачать файлы

Наименование Файл Версия Размер
Обработка табличной части (Загрузка данных из ТСД)
.7z 37,98Kb
19.03.14
51
.7z 37,98Kb 51 Скачать

См. также

Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение