Заполнение значениями по умолчанию для документов и справочников (универсальный механизм)

Публикация № 362759

Разработка - Практика программирования

Универсальная обработка заполнение по шаблону заполнение реквизитов заполнение по умолчанию обработка заполнения

В данном материале рассматривается процесс разработки механизма заполнения документов и справочников по шаблону.
Материал большой, букв много, так что не судите строго. :)
Данный механизм подойдет как для типовых конфигураций, так и для отраслевых и самописных.
В типовых конфигурациях есть некоторые алгоритмы заполнения предопределенными значениями при создании нового документа или справочника (например, организация по умолчанию, склад по умолчанию), и т.п.
Но что если в поступлении нам надо подставлять один склад, в реализации - другой, а в самописном документе - третий? Именно такую механику предусматривает данный механизм.
Он не претендует на полноценное решение, но может стать хорошей основой для дальнейшей разработки.

В типовых конфигурациях (например, УТ 10.3, УПП, Комплексная автоматизация) механизм значений по умолчанию основан на плане видов характеристик  НастройкиПользователей и связанном с ним регистре.

Однажды в одной светлой голове возникла мысль - а почему бы не сделать свои значения по умолчанию для каждого документа или справочника? И процесс пошел.

Рецепт не такой уж и сложный. Судите сами.

Нам понадобятся:

Общий неглобальный модуль  - 1 шт. (Я создал новый и назвал ПодпискиНаСобытия, вы можете использовать любой удобный)

Подписки на события ОбработкаЗаполнения- 2 шт. Одна - на документы, одна - на справочники.

Регистр сведений - 1 шт.

Я назвал его ПользовательскиеШаблоныЗаполнения (или как вам угодно назвать).

Измерения:

Пользователь - справочник Пользователи

Настройка - Строка, 255 знаков (В большинстве случаев должно хватать)

Ресурсы:

Значение - ХранилищеЗначения

Реквизиты:

ВидНастройки - Строка, 20  (В нашем примере там будет всегда записано либо слово "Справочники" либо "Документы")

Все просто. Мы заполняем реквизиты шапки нужными нам значениями, записываем в храилище значения, и при создании нового документа или справочника подставляем их.

Но дьявол, как известно, кроется в деталях.

Для начала разберемся с формой записи нашего регистра.

Прежде всего, поясню, почему вид настройки и настройка были выбраны в виде строки. Это сделано с целью обращения к метаданным через квадратные скобки - т.е. из конструкции Метаданные[ВидНастройки][Настройка] мы получим например

Метаданные.Справочники.Номенклатура или Метаданные.Документа.РеализацияТоваровУслуг.

 

Чтобы все работало корректно, нам понадобится немного докрутить поведение элементов управления.

ВидНастройки мы представим в виде переключателя, и укажем список выбора с двумя значениями "Документы" и "Справочники"

Поле Настройка заполним программно:

&НаСервере
Процедура ЗаполнитьПоМетаданнымНаСервере(ВидНастройки)
	
	Элементы.Настройка.СписокВыбора.Очистить();
	ТЗМетаданных.Очистить();
	ПредставлениеНастройки = "";
	ТаблицаШаблонаЗаполнения.Очистить();
	
	Для Каждого ВидМетаданных Из Метаданные[ВидНастройки] Цикл
		
		Элементы.Настройка.СписокВыбора.Добавить(ВидМетаданных.Синоним);
		СтрТЗ = ТЗМетаданных.Добавить();
		СтрТЗ.Имя = ВидМетаданных.Имя;
		СтрТЗ.Синоним = ВидМетаданных.Синоним;
	КонецЦикла;
	
КонецПроцедуры

ТЗМетаданных - это таблица значений, которую мы используем для сопоставления имени и синонима метаданных, чтобы пользователь выбирал привычные "Договоры контрагентов", а в настройку записывался идентификатор ДоговорыКонтрагентов.

На форму мы вынесем реквизит ПредставлениеНастройки, и при его изменении будем менять настройку.

&НаКлиенте
Процедура НастройкаПриИзменении(Элемент)
	ОтборТЗ = Новый Структура("Синоним", ПредставлениеНастройки);
	НайденныеСтроки = ТЗМетаданных.НайтиСтроки(ОтборТЗ);
	Если НайденныеСтроки.Количество() = 1 Тогда
		Запись.Настройка = ТЗМетаданных.НайтиСтроки(ОтборТЗ)[0].Имя;
		НастройкаПриИзмененииНаСервере();
	КонецЕсли;
	
КонецПроцедуры

При выборе настройки мы заполняем таблицу шаблона. В нашем примере мы заполняем только ссылочные реквизиты и реквизиты-перечисления. По большому счету, можно сделать список с пометками, и дать пользователю самостоятельно выбирать нужные реквизиты, но это в данном материале не рассматривается.

 

&НаСервере
Процедура НастройкаПриИзмененииНаСервере()
	
	ОбъектМетаданных = Метаданные[Запись.ВидНастройки][Запись.Настройка];
	ТаблицаШаблонаЗаполнения.Очистить();
	Для Каждого МетаРеквизит Из ОбъектМетаданных.Реквизиты цикл
		
		ЭтоНужныйТип = Ложь;
		Для Каждого МетаТип Из МетаРеквизит.Тип.типы() Цикл
			ЭтоСправочник = Справочники.ТипВсеСсылки().СодержитТип(МетаТип);
			ЭтоДокумент = Документы.ТипВсеСсылки().СодержитТип(МетаТип);
			ЭтоПеречисление = Перечисления.ТипВсеСсылки().СодержитТип(МетаТип);
			
			Если ЭтоСправочник ИЛИ ЭтоДокумент ИЛИ ЭтоПеречисление Тогда
				СтрТЗ = ТаблицаШаблонаЗаполнения.Добавить();
				СтрТЗ.Поле = МетаРеквизит.Имя;
				СтрТЗ.ПредставлениеПоля = МетаРеквизит.Синоним;
				СтрТЗ.Значение = Новый (МетаТип);
				Прервать;
			КонецЕсли;
		КонецЦикла;	
		
	КонецЦикла;
	
КонецПроцедуры

И при записи мы помещаем заполненный шаблон в хранилище:

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	
	ТекущийОбъект.Значение = Новый ХранилищеЗначения(ТаблицаШаблонаЗаполнения.Выгрузить());
	
КонецПроцедуры

Полный листинг всего модуля формы я приведу в конце материала.

 

С формой разобрались, осталось совсем чуть-чуть.

 

У нас есть две подписки на события. В первой тип источника указываем "ДокументСсылка", во второй "СправочикСсылка".

 

В общем модуле пишем обработчик:

Процедура РС_ЗаполнениеСправочниковИзНастроекПользователя(Источник, ДанныеЗаполнения, ТекстЗаполнения, СтандартнаяОбработка) Экспорт
	
	Если ДанныеЗаполнения = Неопределено Тогда
		ДанныеЗаполнения = Новый Структура;
	КонецЕсли;
	
	Запрос = Новый Запрос("ВЫБРАТЬ
	|	РС_НастройкиПользователей.Пользователь,
	|	РС_НастройкиПользователей.Настройка,
	|	РС_НастройкиПользователей.Значение,
	|	РС_НастройкиПользователей.ВидНастройки
	|ИЗ
	|	РегистрСведений.РС_НастройкиПользователей КАК РС_НастройкиПользователей
	|ГДЕ
	|	РС_НастройкиПользователей.Пользователь = &Пользователь
	|	И РС_НастройкиПользователей.Настройка = &Настройка
	|	И РС_НастройкиПользователей.ВидНастройки = &ВидНастройки");
	Запрос.УстановитьПараметр("Пользователь", ПользователиКлиентСервер.АвторизованныйПользователь());
	Запрос.УстановитьПараметр("Настройка", Источник.Метаданные().Имя);
	Запрос.УстановитьПараметр("ВидНастройки", "Справочники");
						  
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		Хранилище = Выборка.Значение;
		ТаблицаШаблонаЗаполнения = Хранилище.Получить();
		Для Каждого СтрокаШаблона Из ТаблицаШаблонаЗаполнения Цикл
			Если ЗначениеЗаполнено(СтрокаШаблона.Значение) Тогда
				ДанныеЗаполнения.Вставить(СтрокаШаблона.Поле, СтрокаШаблона.Значение);
				Если Метаданные.Справочники[Источник.Метаданные().Имя].Реквизиты[СтрокаШаблона.Поле].ЗаполнятьИзДанныхЗаполнения Тогда
					ДанныеЗаполнения.Вставить(СтрокаШаблона.Поле, СтрокаШаблона.Значение);
				Иначе
					Источник[СтрокаШаблона.Поле] = СтрокаШаблона.Значение;
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
	
КонецПроцедуры

 

Вот здесь-то нам и пригодятся наши строковые реквизиты "Настройка" и "ВидНастройки".

 

На этом все.

 

P.S.:

Как и обещал, листинг модуля формы записи регистра сведений.

&НаКлиенте
Процедура НастройкаПриИзменении(Элемент)
	ОтборТЗ = Новый Структура("Синоним", ПредставлениеНастройки);
	НайденныеСтроки = ТЗМетаданных.НайтиСтроки(ОтборТЗ);
	Если НайденныеСтроки.Количество() = 1 Тогда
		Запись.Настройка = ТЗМетаданных.НайтиСтроки(ОтборТЗ)[0].Имя;
		НастройкаПриИзмененииНаСервере();
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура НастройкаПриИзмененииНаСервере()
	
	ОбъектМетаданных = Метаданные[Запись.ВидНастройки][Запись.Настройка];
	ТаблицаШаблонаЗаполнения.Очистить();
	Для Каждого МетаРеквизит Из ОбъектМетаданных.Реквизиты цикл
		
		ЭтоНужныйТип = Ложь;
		Для Каждого МетаТип Из МетаРеквизит.Тип.типы() Цикл
			ЭтоСправочник = Справочники.ТипВсеСсылки().СодержитТип(МетаТип);
			ЭтоДокумент = Документы.ТипВсеСсылки().СодержитТип(МетаТип);
			ЭтоПеречисление = Перечисления.ТипВсеСсылки().СодержитТип(МетаТип);
			
			Если ЭтоСправочник ИЛИ ЭтоДокумент ИЛИ ЭтоПеречисление Тогда
				СтрТЗ = ТаблицаШаблонаЗаполнения.Добавить();
				СтрТЗ.Поле = МетаРеквизит.Имя;
				СтрТЗ.ПредставлениеПоля = МетаРеквизит.Синоним;
				СтрТЗ.Значение = Новый (МетаТип);
				Прервать;
			КонецЕсли;
		КонецЦикла;	
		
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	Если Не ЗначениеЗаполнено(Запись.ВидНастройки) Тогда
		Запись.ВидНастройки = "Документы";
		ЗаполнитьПоМетаданнымНаСервере(Запись.ВидНастройки);
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьПоМетаданнымНаСервере(ВидНастройки)
	
	Элементы.Настройка.СписокВыбора.Очистить();
	ТЗМетаданных.Очистить();
	ПредставлениеНастройки = "";
	ТаблицаШаблонаЗаполнения.Очистить();
	
	Для Каждого ВидМетаданных Из Метаданные[ВидНастройки] Цикл
		
		Элементы.Настройка.СписокВыбора.Добавить(ВидМетаданных.Синоним);
		СтрТЗ = ТЗМетаданных.Добавить();
		СтрТЗ.Имя = ВидМетаданных.Имя;
		СтрТЗ.Синоним = ВидМетаданных.Синоним;
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура ВидНастройкиПриИзменении(Элемент)
	
	ЗаполнитьПоМетаданнымНаСервере(Запись.ВидНастройки);

КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	
	ТекущийОбъект.Значение = Новый ХранилищеЗначения(ТаблицаШаблонаЗаполнения.Выгрузить());
	
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

	//Вставить содержимое обработчика
	Если Не ЗначениеЗаполнено(Параметры.Ключ.Пользователь) Тогда
		Запись.Пользователь = ПользователиКлиентСервер.АвторизованныйПользователь();
	КонецЕсли;
	Если Не Пользователи.ЭтоПолноправныйПользователь() Тогда
		Элементы.Пользователь.ТолькоПросмотр = Истина;
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура ПриЧтенииНаСервере(ТекущийОбъект)
	
	Запрос = Новый Запрос("ВЫБРАТЬ
	|	РС_НастройкиПользователей.Пользователь,
	|	РС_НастройкиПользователей.Настройка,
	|	РС_НастройкиПользователей.Значение,
	|	РС_НастройкиПользователей.ВидНастройки
	|ИЗ
	|	РегистрСведений.РС_НастройкиПользователей КАК РС_НастройкиПользователей");
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		ХЗ = Выборка.Значение;
		ТЗ = ХЗ.Получить();
	КонецЦикла;
	ХЗ = ТекущийОбъект.Значение;
	ТЗ = ХЗ.Получить();
	ТаблицаШаблонаЗаполнения.Загрузить(ТЗ);
	Попытка
		Для Каждого ВидМетаданных Из Метаданные[Запись.ВидНастройки] Цикл
			
			Элементы.Настройка.СписокВыбора.Добавить(ВидМетаданных.Синоним);
			СтрТЗ = ТЗМетаданных.Добавить();
			СтрТЗ.Имя = ВидМетаданных.Имя;
			СтрТЗ.Синоним = ВидМетаданных.Синоним;
		КонецЦикла;
		
		ПредставлениеНастройки = Метаданные[Запись.ВидНастройки][Запись.Настройка].Синоним;
		
	Исключение
	КонецПопытки;
	
КонецПроцедуры
 

Всем спасибо за потраченное время! Буду рад любой критике и комментариям.

Скачать файлы

Наименование Файл Версия Размер
Конфигурация Заполнение по шаблонам

.cf 29,31Kb
22.06.15
10
.cf 29,31Kb 10 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Универсальные функции Инструментарий разработчика Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    47227    156    ekaruk    32    

Интерактивная справка по объектам 1С (автономное расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Ведётся интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    5786    28    sapervodichka    33    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    24578    22    Stepa86    45    

Вам нравятся запросы в 1С?

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    20515    4    m-rv    86    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    30411    86    m-rv    57    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом

Печатные формы документов Универсальные функции Email v8 КА1 БП2.0 УТ10 УПП1 Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    24493    17    stvorl    0    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    21717    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    37323    54    dsdred    15    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    28256    19    mvxyz    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    28098    26    informa1555    26    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    47362    17    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    30857    11    SITR-utyos    13    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    27715    70    vasvl123    9    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    27033    53    kwazi    6    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    45305    12    swimdog    41    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    32475    132    PLAstic    59    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    51461    35    ildarovich    41    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    22747    21    sasha777666    63    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    129241    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    31396    112    romasna    49    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    29148    125    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    22231    105    Alxby    23    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    25802    16    Anton64    22    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    36643    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    26751    135    Stepa86    15    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    48110    36    Demanoidos    60    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    28221    76    ZhokhovM    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    57353    10    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    61428    181    rozer    65    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    58480    19    arakelyan    18    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    34509    48    ildarovich    23    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    80952    158    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    18255    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    49867    50    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    54960    178    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    23259    8    Tatitutu    5    

Генерация QR-кода программная и интерактивная (код открыт, управляемая форма, обычное и управляемое приложение, API)

Универсальные функции Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработку можно быстро и легко интегрировать в любую конфигурацию с и без БСП (Библиотека Стандартных Подсистем).

3 стартмани

04.02.2016    48170    173    TuneSoft    30    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    37025    20    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    56822    48    YPermitin    19    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    92903    459    Luchik    205    

Автоматическая подстановка уничтожений временных таблиц в текст запроса

Универсальные функции v8 1cv8.cf Абонемент ($m)

Функция, которая сама подставляет в текст запроса "УНИЧТОЖИТЬ" в местах последнего использования ВТ.

1 стартмани

14.11.2015    20252    0    SeiOkami    3