Быстрые отборы в списках типовых конфигураций

Публикация № 442411

Разработка - Работа с интерфейсом

Интерфейс Толстого клиента Типовые конфигурации

1
Несмотря на растущую популярность типовых программ на основе управляемых форм, всё ещё распространены программы на основе Толстого клиента. В основе типовых программ основные объекты (Документы и Справочники) представлены в форме списков (Динамические списки). Используемые формы хоть и снабжены универсальным отбором, но оперативный доступ к поиску нужных данных несколько затруднен. Для поиска нужного документа или элемента справочника, даже в форме Списка для подбора приходится производить множество манипуляций…

Для документов чрезвычайно удобным оказывается динамический интервал даты документа (Последние x дней для Начала интервала). Одновременно самым распространенным критерием поиска документа является ввод последних трех цифр номера, подразделения документа, Склада и т.п. Для своих нужд добавил в большинство используемых списков документов дополнительные поля быстрого отбора (чего и вам советую). Поля оптимизированы для самых массовых критериев поиска. А чтобы потратить минимум труда на добавление, использовал командное добавление полей и унифицированный код для добавления. Код позволяет добавлять и прятать поля быстрого отбора.

Следует учесть несколько моментов:

  • Поиск будет более быстрым, если для отбираемого реквизита будет существовать Индекс (настройка в конфигураторе).
  • И, разумеется, Поле должно быть выведено на форму списка.
  • Попадались случаи разного наименования Поля списка на форме (следует проверять).
  • Отбор числового значения (например, СуммаДокумента) можно настроить и как поиск точного значения, и как диапазон 1% разброса (или свой алгоритм).
  • На форме умещаются от 4 до 5 полей быстрого отбора (в одну строку и на развернутой форме).
  • При первоначальном заполнении, Форма списка оказывается в промежуточном размере, как следствие могут не все элементы расположатся оптимально. Лечится сворачиваем и разворачиваем быстрого отбора.
  • Форму списка снабжают кнопкой Сворачивания/Разворачивания Быстрого отбора.
  • После редактирования значений отбора, рекомендуется переносить фокус на сам список (для ускорения выбора нужного элемента).

Данная методика применима для большинства типовых конфигураций 1С на основе Толстого клиента (УТ_10, БП_2, УНФ, и др.).

Немного о структуре доработок:

ПриОткрытии() - автозапуск добавления быстрого отбора

БыстрыйОтборДок();// Подключаем быстрыйОтбор (или выключаем)

ПБОПриИзменении(Элемент) // Отработка изменения значения отбора (одна на всех)

 

Перем мОтбора;//Признак включения Быстрого отбора
Процедура ПриОткрытии()
    БыстрыйОтборДок();//НВЮ/ Подключаем быстрыйОтбор
    ЭтаФорма.ТекущийЭлемент = ЭлементыФормы.тНомер;//Активируем быстрый поиск по Номеру
КонецПроцедуры
//НВЮ/ Открыть быстрый отбор.
//Процедура ПриОткрытии()
//  БыстрыйОтборДок();// Подключаем быстрыйОтбор
Процедура БыстрыйОтборДок(ВклОтбора=Истина)
    //Параметры  (Начальное размещение полей)
    оВысота = 19;
    оВерх   = 28;
    оЛево   = 6;
    СпПБО   = Новый ТаблицаЗначений; //Таблица описания Быстрого отбора
    СпПБО.Колонки.Добавить("Значение");//Реквизит списка для отбора
    СпПБО.Колонки.Добавить("Представление");//Подпись на панели быстрого отбора
    СпПБО.Колонки.Добавить("Тип");//Тип значения отбора
    //Наполнение полей отбора
    НовПБО = СпПБО.Добавить();
    НовПБО.Значение = "Номер";  НовПБО.Представление = "№?"; НовПБО.Тип = "Строка";
    НовПБО = СпПБО.Добавить();
    НовПБО.Значение = "Контрагент"; НовПБО.Представление = "КА?";   НовПБО.Тип = "Контрагенты";
    НовПБО = СпПБО.Добавить();
    НовПБО.Значение = "Подразделение";  НовПБО.Представление = "Отд.?"; НовПБО.Тип = "Подразделения";
    НовПБО = СпПБО.Добавить();
    НовПБО = СпПБО.Добавить();
    НовПБО.Значение = "СуммаДокумента"; НовПБО.Представление = "Сум.?"; НовПБО.Тип = "Число";
//оРазд = 10;

    Если мОтбора = Неопределено Тогда
        мОтбора = Истина;//Первичная Инициализация
    ИначеЕсли Не ВклОтбора Тогда
        Для каждого ЭлмПБО Из СпПБО Цикл
            ЭлементыФормы["т"+ЭлмПБО.Значение].Высота   = 0;
            ЭлементыФормы["т"+ЭлмПБО.Значение].Видимость = Ложь;
            ЭлементыФормы["З"+ЭлмПБО.Значение].Высота   = 0;
            ЭлементыФормы["З"+ЭлмПБО.Значение].Видимость = Ложь;
        КонецЦикла;
        //Все Поля Скрыты
        ЭлементыФормы.ДокументСписок.Верх = 33;
        ЭлементыФормы.ДокументСписок.Высота = ЭтаФорма.Высота-40;
        Возврат;
    КонецЕсли;
    //Отработка инициализации
    НПП = 1;
    Для каждого ЭлмПБО Из СпПБО Цикл
        Если ЭлементыФормы.ДокументСписок.Ширина<оЛево+160+СтрДлина(ЭлмПБО.Представление) Тогда
            ЭлементыФормы.ДокументСписок.Ширина = ЭлементыФормы.ДокументСписок.Ширина+160+СтрДлина(ЭлмПБО.Представление);
        КонецЕсли;
        РазместитьПолеБО(ЭлементыФормы, ЭлмПБО.Значение, ЭлмПБО.Представление, ЭлмПБО.Тип, 19, оВерх, оЛево);
        Если НПП=1 Тогда
            ЭлементыФормы["з"+ЭлмПБО.Значение].СочетаниеКлавиш = Новый СочетаниеКлавиш(Клавиша._1, Истина); // Alt+1
        ИначеЕсли НПП=2 Тогда
            ЭлементыФормы["з"+ЭлмПБО.Значение].СочетаниеКлавиш = Новый СочетаниеКлавиш(Клавиша._2, Истина); // Alt+2
        ИначеЕсли НПП=3 Тогда
            ЭлементыФормы["з"+ЭлмПБО.Значение].СочетаниеКлавиш = Новый СочетаниеКлавиш(Клавиша._3, Истина); // Alt+3
        ИначеЕсли НПП=4 Тогда
            ЭлементыФормы["з"+ЭлмПБО.Значение].СочетаниеКлавиш = Новый СочетаниеКлавиш(Клавиша._4, Истина); // Alt+4
        ИначеЕсли НПП=5 Тогда
            ЭлементыФормы["з"+ЭлмПБО.Значение].СочетаниеКлавиш = Новый СочетаниеКлавиш(Клавиша._5, Истина); // Alt+5
        ИначеЕсли НПП=6 Тогда
            ЭлементыФормы["з"+ЭлмПБО.Значение].СочетаниеКлавиш = Новый СочетаниеКлавиш(Клавиша._6, Истина); // Alt+6
        ИначеЕсли НПП=7 Тогда
            ЭлементыФормы["з"+ЭлмПБО.Значение].СочетаниеКлавиш = Новый СочетаниеКлавиш(Клавиша._7, Истина); // Alt+7
        КонецЕсли;
        НПП=НПП+1;
    КонецЦикла;

    //Подвинем Список
    ЭлементыФормы.ДокументСписок.Высота = ЭлементыФормы.ДокументСписок.Высота - оВысота;
    ЭлементыФормы.ДокументСписок.Верх = ЭлементыФормы.ДокументСписок.Верх + оВысота;
КонецПроцедуры

//НВЮ/ Отбираем ПБО
Процедура ПБОПриИзменении(Элемент)
    ИскЗначение = Элемент.Значение;
    Если ЗначениеЗаполнено(ИскЗначение) Тогда
        Если Элемент.Ширина<75 Тогда
            Элемент.Ширина=75;
        КонецЕсли;
        Если Лев(СокрЛП(ТипЗнч(ИскЗначение)),6)="Строка" Тогда
            Отбор[Сред(Элемент.Имя,2)].Значение = ИскЗначение;
            Отбор[Сред(Элемент.Имя,2)].ВидСравнения = ВидСравнения.Содержит;
        ИначеЕсли Лев(СокрЛП(ТипЗнч(ИскЗначение)),5)="Число" Тогда
            Отбор[Сред(Элемент.Имя,2)].ВидСравнения = ВидСравнения.ИнтервалВключаяГраницы;
            Отбор[Сред(Элемент.Имя,2)].ЗначениеС = ИскЗначение*0.98;
            Отбор[Сред(Элемент.Имя,2)].ЗначениеПо = ИскЗначение*1.02;
        Иначе
            Отбор[Сред(Элемент.Имя,2)].Значение = ИскЗначение;
            Отбор[Сред(Элемент.Имя,2)].ВидСравнения=ВидСравнения.Равно;
        КонецЕсли;
        Отбор[Сред(Элемент.Имя,2)].Использование=Истина;
    Иначе
        Отбор[Сред(Элемент.Имя,2)].Использование=Ложь;
    КонецЕсли;
    Если Отбор[Сред(Элемент.Имя,2)].Значение<>ИскЗначение Тогда
        ЭтаФорма.Обновить();
    КонецЕсли;
    ЭтаФорма.ТекущийЭлемент = ЭлементыФормы.ДокументСписок;
КонецПроцедуры
//НВЮ/ Очищаем ПБО+
Процедура ПБООчистка(Элемент, СтандартнаяОбработка)
    Отбор[Сред(Элемент.Имя,2)].Использование=Ложь;//По имени Элемента отключаем отбор
    Если Отбор[Сред(Элемент.Имя,2)].Значение<>Элемент.Значение Тогда
        ЭтаФорма.Обновить();
    КонецЕсли;
    ЭтаФорма.ТекущийЭлемент = ЭлементыФормы.ДокументСписок;
КонецПроцедуры
//НВЮ/ Универсальное Размещение Поля отбора
//Параметры:
//  ЭФ  - <ЭлементыФормы>   - Размещение Элементов Формы
//
Процедура РазместитьПолеБО(ЭФ, ИмяПБО, ПредставлениеПБО, ТипПБО, оВысота=19, оВерх, оЛево) Экспорт
    тЗаг = ЭлементыФормы.Найти("т"+ИмяПБО);
    Если тЗаг=Неопределено Тогда
        тЗаг = ЭлементыФормы.Добавить(Тип("Надпись"),"т"+ИмяПБО,Истина);
        тЗаг.Значение = ПредставлениеПБО;
    Иначе
        тЗаг.Видимость = Истина;
    КонецЕсли;
    тЗаг.Верх = оВерх;
    тЗаг.Лево = оЛево;
    тЗаг.Ширина = СтрДлина(ПредставлениеПБО)*8;
    оЛево   = оЛево + тЗаг.Ширина;
    тЗаг.Высота = оВысота;
    тЗаг = ЭлементыФормы.Найти("З"+ИмяПБО);
    Если тЗаг=Неопределено Тогда
        тЗаг = ЭлементыФормы.Добавить(Тип("ПолеВвода"),"З"+ИмяПБО,Истина);
        тЗаг.УстановитьДействие("ПриИзменении",Новый Действие("ПБОПриИзменении"));
        тЗаг.УстановитьДействие("Очистка",Новый Действие("ПБООчистка"));
    Иначе
        тЗаг.Видимость = Истина;
    КонецЕсли;
    тЗаг.Верх = оВерх;
    тЗаг.Лево = оЛево;
//  ТипПБО  = СокрЛП(ТипЗнч(ЭлементыФормы.ДокументСписок.Колонки[ИмяПБО].ЭлементУправления.Значение));
    Если ТипПБО="Строка" Тогда
        тЗаг.Ширина = 75;
        тЗаг.ТипЗначения = ОбщегоНазначения.ПолучитьОписаниеТиповСтроки(10);
    ИначеЕсли ТипПБО="Число" Тогда
        тЗаг.Ширина = 110;
        тЗаг.ТипЗначения = ОбщегоНазначения.ПолучитьОписаниеТиповЧисла(14,2);
    Иначе
        тЗаг.Ширина = 130;
        тЗаг.ТипЗначения = ОбщегоНазначения.ПолучитьОписаниеТиповСправочника(ТипПБО);//
    КонецЕсли;
    оЛево   = оЛево + тЗаг.Ширина + 10;//НВЮ/ Добавлен разделитель полей
    тЗаг.Высота = оВысота;
    тЗаг.КнопкаОчистки = Истина;
    тЗаг.ПропускатьПриВводе = Истина;

КонецПроцедуры
//НВЮ/ Включение/Отключение Быстрого отбора
Процедура ДействияФормыБыстрыйОтбор(Кнопка)
    Если мОтбора Тогда//Включен, сл. Выключаем совсем
        БыстрыйОтборДок(Ложь);
        мОтбора = Ложь;
        ЭлементыФормы.ДокументСписок.Верх = 33 ;//Типовое Расположение
        ЭлементыФормы.ДокументСписок.Высота = ЭтаФорма.Высота - 33;
    Иначе   //Включаем (Отображаем) Быстрый Отбор
//      мОтбора=ТекущаяДата();
        БыстрыйОтборДок(Истина);
        мОтбора = Истина;
    КонецЕсли;
КонецПроцедуры

 

1

Скачать файлы

Наименование Файл Версия Размер
Описание доработок с Кодом
.docx 35,09Kb
09.01.16
0
.docx 1 35,09Kb Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. DrAku1a 1300 11.01.16 08:10 Сейчас в теме
Осталось вынести процедуры генерации элементов и обработки событий в общий модуль,
выгрузить файлы конфигурации и обработать тексты модулей форм.
А вообще, идея - не нова: http://infostart.ru/public/152560/, но не особо прижилась, судя по количеству "Лайков"...
2. nixel 794 13.01.16 14:48 Сейчас в теме
Толстый клиент <> Обычное приложение.

Не проще конструктором сгенерить управляемую форму списка?
И весь компоновщик настроек с быстрыми/небыстрыми отборами дает вам сама платформа.
4. Altair777 639 29.08.17 17:19 Сейчас в теме
(2) любопытно, а что Вы имеете в виду? Через "Найти"?
5. nixel 794 30.08.17 01:00 Сейчас в теме
(4) через "Настроить список". и вынесение установленных настроек в "Быстрый доступ"
3. V.Nikonov 119 13.01.16 21:58 Сейчас в теме
Я не парясь копировал фрагмент кода... Вставлял в нужную форму подправляя Автозапуск и требуемые реквизиты отбора в Процедуре БыстрыйОтборДок()... 10 или 15 форм списков обтяпал за час.
Идея централизованного хранения параметров панели быстрого отбора теплилась, но так и не родилась... Времени и финансирования не хватило.
Оставьте свое сообщение

См. также

Альтернативный способ добавления элементов и реквизитов на формы 29

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 ERP2 УТ11 Россия Абонемент ($m) Работа с интерфейсом

Предлагаю альтернативный вариант добавления динамически создаваемых элементов и реквизитов на форму.

1 стартмани

09.09.2019    2370    4    bmk74    0       

Удобный выбор из таблицы/дерева в УФ 61

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом Разработка

Выбор из таблицы значений или дерева значений в выпадающем списке рядом с полем ввода - УФ, быстро и просто!

1 стартмани

12.08.2019    2882    4    Yashazz    18       

[Механизм интерфейса] Свой флажок (чекбокс) 109

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Создадим свой флажок для интерфейса, используем простой универсальный алгоритм.

1 стартмани

09.08.2019    4101    4    rpgshnik    37       

Отбор на управляемой форме из списка значений 41

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом Разработка

Пример простого удобного отбора любых данных ссылочного типа на управляемой форме. Работа обработки проверена на релизе: 1С:Предприятие 8.3.13.1513.

1 стартмани

09.08.2019    4188    4    nagaitseff    6       

Изменяющееся контекстное меню в 1С 8.3 44

Статья Программист Архив с данными v8 v8::УФ Абонемент ($m) Практика программирования Разработка Работа с интерфейсом

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    4227    1    signum2009    14       

"Мобильный ТСД" - инвентаризация и сбор штрихкодов для iOS и Android 21

Инструменты и обработки Программист Пользователь Расширение (cfe) v8 v8::Mobile Розница УНФ ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Монитор заказов Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Внешние источники данных Сканер штрих-кода Терминал сбора данных Работа с интерфейсом Мобильная разработка

Простой мобильный терминал сбора данных для iOS и Android, не требующий сложных настроек и установки дополнительных программ. Для выгрузки базы штрихкодов и загрузки собранных штрихкодов в документы учетной системы используется Яндекс Диск или облачный сервис и расширение конфигурации. Работает с конфигурациями Розница 2, УНФ 1.6, УТ 11, ERP, КА2.

3 стартмани

22.04.2019    9705    51    suepifanov    61       

Шпаргалка разработчика для работы с формами 23

Отчеты и формы Программист Архив с данными v8 Россия Абонемент ($m) Работа с интерфейсом

Сборник помогает быстро освоить встроенный язык и средства конфигурирования при разработке обычных и управляемых форм.

3 стартмани

31.10.2018    7824    68    ELAM    3       

Открывашка ячеек таблиц 85

Инструменты и обработки Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Глобальное сочетание клавиш для открытия объекта по ссылке из текущей ячейки любой таблицы в большинстве управляемых форм

1 стартмани

27.10.2018    9209    11    tormozit    28       

Визуализация событий на временной шкале средствами "Поле HTML документа" 165

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Интересный способ наглядно отобразить события на временной шкале. Например, может быть применен для красивого вывода документов по клиенту. Тестировалось на платформе 8.3.12.1469

1 стартмани

31.07.2018    13840    127    Plotks2017    24       

Продвинутое рисование в табличном документе (стрелок и не только) 73

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Практика программирования Работа с интерфейсом

Вспоминаем геометрию и основы компьютерной графики. Матрицы и аффинные преобразования на плоскости.

1 стартмани

24.07.2018    8051    16    WalterMort    27       

Работа с данными выбора 38

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    19601    13    kalyaka    15       

Управление состоянием формы через конечный автомат 81

Статья Программист Конфигурация (md, cf) v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

Взаимодействие пользователя с интерфейсом приводит к изменению состояния формы и её элементов. Элементы отражают текущее состояние формы через свойства: видимости, доступности, оформления, текста заголовка и т.д. Даже при небольшом количестве элементов количество возможных состояний формы может быть достаточно большим. Необходимость учета всех состояний формы порождает сложные алгоритмы настройки элементов. В статье рассматривается алгоритмическое решение перехода к состоянию формы с использованием функционального подхода на основе декларативного описания

1 стартмани

19.06.2018    9911    11    kalyaka    35       

Иерархическая диаграмма 42

Инструменты и обработки Программист Бизнес-аналитик Руководитель проекта Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Концепция диаграммы по иерархической структуре данных, например по номенклатуре (продажи или остатки на складах).

2 стартмани

17.06.2018    7134    14    DrAku1a    4       

Программная работа с графическими схемами. Готовое решение 39

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Универсальные обработки Работа с интерфейсом

Работоспособное, проверенное на практике, простое и удобное программное управление графическими схемами.

1 стартмани

18.02.2018    11377    16    Yashazz    13       

Тестирование интерфейса в обычном приложении 8.2 при помощи SikuliX 105

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Как же не хватает клиента тестирования на платформе 8.2. Не кликнешь на кнопку, не выберешь из списка, не проверишь видит ли надпись пользователь. Воспользуемся внешним инструментом SikuliX, который позволит нам протестировать функционал форм. Данный инструмент легко встраивается в линию сборки и может "дружить" с уже известным многим Open-source продуктами.

1 стартмани

03.01.2018    19559    2    kraynev-navi    40       

Программное формирование форматированной строки в стиле html+inline CSS 52

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом Инструментарий разработчика

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    19176    24    bonv    5       

Размеры управляемой формы 100

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом Универсальные функции

Как рассчитать ширину и высоту управляемой формы или отдельного элемента, чтобы адаптировать интерфейс программно при их изменении.

1 стартмани

08.10.2017    17573    46    json    8       

Программное создание элементов графической схемы (через XSLT) 57

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Встала как-то передо мной задача визуализировать определенный прикладной процесс, лучше всего для этого подходит графическая схема. Так уж вышло, что 1С по не понятным мне причинам не предоставила возможность программно работать с элементами графической схемы. Пришлось импровизировать.....

1 стартмани

20.07.2017    13861    49    lazarenko    16       

Расширенная настройка динамического списка УФ 115

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Работа с интерфейсом

Открывая управляемую форму выбора и не увидев там видимых в форме списка элементов, часто хочется узнать причину их отсутствия там, т. е. какой наложен отбор. Но стандартная настройка списка управляемой формы показывает только пользовательские настройки, скрывая от пользователя фиксированный отбор. Предлагаю вам расширение конфигурации с расширенной настройкой динамического списка, отображающей пользователю кроме пользовательских настроек еще фиксированные.

1 стартмани

31.05.2017    24131    143    tormozit    20       

Простой редактор плана помещения JavaScript 100

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования Работа с интерфейсом

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    14836    91    igel9780    16       

Настройка начальной страницы (Рабочего стола) 47

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом Рабочее место Универсальные обработки

Альтернатива стандартной настройке начальной страницы. В типовой доступны лишь те формы, что явно "разрешены" разработчиком в режиме конфигуратора. Эта обработка позволяет собрать "Рабочий стол" из любых подходящих форм в пользовательском режиме. Без программирования. БСП не используется. Не расширение. Универсальна, т.е. подойдет для любой конфигурации (в т.ч. самописной).

2 стартмани

19.10.2016    24170    186    Erne100    24       

[Расширение] Стартовые страницы. Автозапуск форм при старте 1С. (8.3.9+, без доработки конфигурации) 51

Инструменты и обработки no Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Уверен, что в большинстве случаев список справочников, отчетов, обработок (объектов 1С в целом), к которому обращаются пользователи после запуска конфигурации 1С, раз от раза меняется не сильно. Так почему бы немного не упростить процесс открытия часто используемых форм? Данное расширение позволяет настроить автоматическое открытие различных форм объектов сразу после запуска 1С. Список форм настраивается индивидуально для каждого пользователя. Работает на платформе 8.3.9, без доработки конфигурации.

1 стартмани

03.10.2016    15883    78    Artem-B    19       

Конструктор условного оформления 40

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Иногда требуется сделать отчет, который бы содержал в себе множество показателей. В таком случае в получившейся "портянке" показатели сливаются. Как один из вариантов решения (ну, кроме упрощения отчета) можно рассматривать раскраску показателей в индивидуальные цвета. После нескольких подобных случаев (особенно, когда в уже готовый отчет добавляются или убираются поля) сделал обработку, которая позволяет в режиме предприятия быстро подготовить болванку условного оформления для подобных отчетов.

1 стартмани

27.09.2016    12732    15    Fragster    6       

HTTP-сервис: отчеты [Расширение] 122

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    18874    125    Stepa86    15       

Простые радости жизни программиста 1С: выбор типа значения 51

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    38478    45    yuraos    17       

Визуальный редактор цветовых схем подсветки синтаксиса 1С + импорт схем Visual Studio 43

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Работа с интерфейсом

Данная обработка призвана облегчить настройку рабочего места программиста 1С, а именно улучшить визуальное восприятие кода, уменьшить утомляемость, и, как следствие, увеличить общую производительность труда!

1 стартмани

29.01.2016    11475    74    ram3    27       

Передача реквизитов объекта из основной формы в дополнительную и обратно на управляемых формах 91

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Работа с интерфейсом

Наверное, многие сталкивались с ситуацией, когда у некоего редактируемого объекта (справочник, документ, внешняя обработка) кроме основной формы нужно сделать парочку дополнительных, чтобы часть реквизитов заполнять в них, а потом возвращать заполненные значения в основную форму и в сам объект. И если бы речь шла об обычных формах, то проблемы бы и не было. Но в управляемых формах с этим возникает проблема, а в случае отказа от модальности она становится немного больше.

1 стартмани

02.11.2015    22207    8    Wolex    29       

Инструмент для создания веб приложений на основе 1С REST сервиса 67

Инструменты и обработки Программист Пользователь Приложение (exe) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика WEB Работа с интерфейсом

Обзор платформы-конструктора для создания веб-приложений, использующих в качестве источника базы данных 1С

1 стартмани

13.10.2015    21323    82    dmzubr    23       

Асинхронная загрузка данных на Управляемую Форму. Прогресс бар (УФ 8.3). Индикация состояния процесса 78

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Работа с интерфейсом Универсальные функции Внешние источники данных

Часто бывает, что возникает необходимость загрузить множество данных из разнообразных источников в определенную форму или рабочее место. В процессе загрузки пользователь в неведении — информация готовится или нет. Прием позволяет загружать данные из нескольких источников асинхронно, не блокируя форму\интерфейс, а также отображать ошибки и состояние прогресса. По мере готовности данных, они будут отображены на форме

1 стартмани

09.10.2015    28725    133    pbazeliuk    6       

Визуальный html редактор на управляемых формах 64

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB Работа с интерфейсом

Мы рассмотрим некоторые особенности и возможности подключения сторонних визуальных html редакторов на javascript - TinyMCE, CK Editor. С помощью приложенной обработки Вы сможете попробовать в действии полноценный и удобный визуальный html редактор, а при желании перенести подобный функционал к себе.

1 стартмани

30.09.2015    20678    183    ivanov660    26       

NativeDraw: Компонента рисования для 1С [V2.6.2] 106

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Windows Абонемент ($m) Разработка внешних компонент Работа с интерфейсом

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    39508    421    ПерваяСистема    140       

Универсальное настраиваемое рабочее место (Версия 2.0) 52

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Работа с интерфейсом Рабочее место

При работе очень часто штатные интерфейсы 1С бывают неудобны в силу разной специфики работы каждого пользователя, а также конфигурация обычно "обрастает" новыми обработками, отчетами, документами и справочниками, которые требуются для работы организации, а в стандартных меню их, естественно, нет. Это особенно относится к толстому клиенту (например, программы УПП, УТ10.3 и пр.). Делать свои интерфейсы - не всегда спасает: то, что нужно одному пользователю, другому совершенно не надо, даже если у них одинаковые функциональные обязанности. Открывать все через меню "Операции" тоже неудобно: у нас, например, за несколько лет работы добавилось столько нового и специфичного, что уже и не помнишь, что и для чего. Поэтому родилась идея сделать что-то удобное и универсальное, что и получилось в результате: пользователь сам, не прибегая к помощи программиста, может сделать удобное меню для себя и всегда изменить, если требуется. И без всяких изменений конфигурации...

3 стартмани

13.06.2015    11976    120    yuraskid    29       

Кнопки управления группировками табличного документа для управляемых форм 23

Инструменты и обработки Программист Внешний отчет (ert,erf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Универсальный механизм управления группировками табличного документа из управляемой формы

1 стартмани

02.06.2015    21627    31    unichkin    9       

Управляемая форма 1С 8.2 (8.3) – работа с деревом значений и таблицей значений. Часть I (Основы) 64

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Windows Абонемент ($m) Практика программирования Работа с интерфейсом

Как известно, в платформе 1С 8.1 не составляло никакого труда связать дерево значений с табличным полем на форме, единственное, что при этом нужно было не забыть, так это СоздатьКолонки(). В управляемом приложении 1С 8.2 (8.3) сделать это не так просто, как кажется на первый взгляд. В данной статье речь пойдет о программном создании дерева значений (таблицы значений) на управляемой форме в управляемом приложении 1С

2 стартмани

14.05.2015    69618    25    ll13    13       

[БП 3.0] [ЗУП 3.1 ] [БГУ 2.0] [УТ 11.4 ] [Расширения] Отключение регламента, оповещений и пр. 43

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 v8::БУ БП3.0 Россия Windows Абонемент ($m) Работа с интерфейсом

Облегчить жисть БП 3.0 отключением всякого разного можно! Обработка позволяет отключить ряд оповещений, регламентных заданий (подробно описано в http://infostart.ru/public/303564/). Кроме того, позволяет более подробную настройку использования: - Регламентных и фоновых заданий; - Информации для форм; - Задач бухгалтера (где они есть). 21.01.2019 Версии с новым режимом совсместимости для основных конфигураций С удовольствием выслушаю (по возможности реализую) сообщество, что ещё можно сделать, чтобы программа работала по шустрее.

1 стартмани

04.03.2015    22330    131    Alex_E    17       

Подсистема "Планировщик" (версия 1.1) 138

Отчеты и формы no Конфигурация (md, cf) v8 1cv8.cf Россия Абонемент ($m) Практика программирования WEB Работа с интерфейсом

Конфигурация с подсистемой "Планировщик" (календарь). Бесплатная открытая версия для свободного использования не включает двустороннюю интеграцию с сервисом Google и Outlook.com.

5 стартмани

02.03.2015    55681    463    vandalsvq    62       

Анимация фона элементов на форме в стиле JQuery 75

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

К сожалению, у платформы 1С не так много красивостей, которыми обычно сдабривают формы обычных web-страниц. Нам недоступны эффекты JQuery и других javascript-библиотек. А иногда хочется сделать необычно, красиво и удобно.

1 стартмани

18.02.2015    13872    27    kraynev-navi    9       

Произвольное размещение и добавление кнопок на управляемых формах пользователем 37

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Иногда нам нужно чтобы пользователи могли сами рисовать себе формы в режиме 1С Предприятия, добавлять на них необходимые кнопки, назначать на эти кнопки объекты, размещать эти кнопки на форме произвольно. На управляемых формах даже в конфигураторе нет возможности произвольно размещать кнопки на форме. Чтобы исправить эту оплошность предлагаю вам свое решение данной проблемы.

1 стартмани

07.11.2014    16172    43    tvixeg    14       

[ТАКСИ] Шаблон внешней обработки...и не только 207

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Универсальные обработки Работа с интерфейсом Универсальные функции

Обработка предназначена для лентяев, к каковым, в первую очередь, отношу себя. Это в некотором роде шпаргалка в виде шаблона внешней обработки. Для создания новой копируем эту, удаляем ненужное, вставляем нужное - получаем результат. Чем ваять с нуля, каждый раз прописывая одно и то же, проще использовать заготовку, подобную этой... 24.11.2018 - Версия 1.21 - что-то добавил, что-то поправил.... 16.04.2019 - По просьбам трудящихся (немногочисленным, правда) оставил последнюю версию 1.21, дабы не было путаницы... 17.04.2019 - Версия 1.22 Вернул пример сохранения табличного документа в разных форматах и чтения DBF из версии 1.16 (как потерялось - сам не понял)

2 стартмани

22.09.2014    46012    687    Alex_E    27       

Визуализация и интерактивное изменение дерева значений. 68

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования Универсальные обработки Работа с интерфейсом

Обработка позволяет представить дерево значений в графическом виде, изменить его простым перетаскиванием блоков и выгрузить обратно в дерево значений.

1 стартмани

01.08.2014    16772    99    Belkin_Sergey    27       

Локализация конфигурации с помощью Google 13

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Обработка позволяет выполнять перевод интерфейсов в любой конфигурации 1С средствами Google. За основу взята обработка: http://infostart.ru/public/190890/

1 стартмани

06.06.2014    15415    32    x-tremeall    6       

Прогресс-бар длительных серверных операций (БСП) 45

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Работа с интерфейсом

Простой и удобный шаблон для подобного рода задач в виде внешней обработки. Используется технология, предлагаемая в БСП (Библиотеке Стандартных Подсистем), практически без ноу-хау. Доработано таким образом, что обработка может быть как встроенной в конфигурацию, так и внешней.

1 стартмани

23.04.2014    24033    255    herfis    14       

Алгоритмы. Часть 1.1. Динамические соединения. 186

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Работа с интерфейсом

Конспект первой лекции из свежего курса Принстонского университета США за 2014 год. Вольный перевод с английского с реализацией примеров на 1С. Курс в целом достаточно интересный и полезный для общего развития. Перевел и адаптировал только первую лекцию (в 1 части 11 лекций, 2 часть - еще не завершена преподавателями). Первоисточник на английском - https://www.coursera.org/course/algs4partI. Если сообщество посчитает материал полезным - займусь переводом следующих лекций (но это довольно трудоемко). Enjoy! :)

1 стартмани

04.04.2014    27770    23    Aleksey.Bochkov    33       

HTML редактор для 1С (1С HTML IDE) 74

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Работа с интерфейсом

Стандартный для 1с интерфейс не всегда может удовлетворить заказчика. В этом случае возникает необходимость реализовывать некоторые формы с использованием HTML. Как известно, встроенный в 1с объект "поле табличного документа" работает с использованием старых технологий. В результате, страничка, написанная в сторонней IDE в 1с может отображаться как угодно, но только не так как требуется. Когда у меня появилась задача сделать рабочий стол на HTML я сразу понял, что писать веб-код необходимо сразу на платформе 1с, что бы видеть результат Online и корректировать его. Для меня веб-программирование заканчивается знанием тега . Разнообразные глюки и особенности веб-среды мне просто неизвестны, поэтому сразу видеть что получается - самое то. Представляю один из результатов моей работы - IDE на управляемых формах, задача которой - генерация HTML документа, который будет правильно отображаться в 1с.

1 стартмани

20.02.2014    25485    170    Nikola23    28       

Изучаем мобильную платформу 8.3.4: геопозиционирование 155

Инструменты и обработки Программист Архив с данными v8 v8::Mobile Android Абонемент ($m) Работа с интерфейсом

Блеск и нищета geo-инструментов мобильной платформы 8.3.4. Пишем письмо турецкому султану. Но Чекин, как в Foursquare уже реально!

1 стартмани

14.02.2014    57158    198    barelpro    43       

Графический индикатор процесса в табличной части на Управляемых формах 50

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 Россия Windows Абонемент ($m) Работа с интерфейсом

Графический индикатор процесса на Управляемых формах, для любой ячейки в табличной части формы

1 стартмани

04.02.2014    18406    88    amyd    25